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● Safety Precautions ●
(Please read the precautions carefully before carrying out practical training.)
Read the relevant manuals and pay careful attention to safety when designing the system.
When carrying out practical work, pay sufficient attention to the following points and handle the device
properly.

[Practical training precautions]
WARNING
● To avoid electric shock, do not touch the terminal while the power is on.
● When opening a safety cover, make sure that the power supply is disconnected or ensure
sufficient safety before carrying out the work.

CAUTION
● Follow the instructor's instructions to carry out practical training.
● Do not remove the training machine module or change the wiring without prior consent.
Doing so may cause failure, malfunction, injury, or fire.
● Turn the power supply OFF before removing or installing a module.
Removing or installing while the power is ON may cause module failure or electric shock.
● If the training machine emits an abnormal odor or an abnormal sound, press the "Power switch" or
"Emergency switch" to stop the device.
● When an error occurs, contact the instructor immediately.
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● Safety Precautions
(Q Series Programmable Controllers) ●
(Please read the precautions carefully before use.)
When using a Q series programmable controller, please read the Q Series Programmable Controller
Manual carefully and pay sufficient attention to safety and handle the device properly.
In this manual, the safety precaution levels are classified under "WARNING" and "CAUTION".

WARNING

Incorrect handling may cause hazardous conditions, resulting in death or
severe injury.

CAUTION

Incorrect handling may cause hazardous conditions, resulting in medium
or slight injury, or may cause only material damage.

CAUTION level may lead to a serious consequence according to conditions.
Note that the
Please follow the instructions of both levels because they are important to personnel safety.

[Design precautions]
WARNING
● Configure a safety circuit outside the programmable controller so that the entire system can
operate safely even when an external power supply error or a programmable controller failure
occurs. Failure to do so may cause an incorrect output or malfunction, resulting in accidents.
(1) Configure safety circuits such as an emergency stop circuit, protection circuit, interlock circuit for
opposite operations such as forward/reverse rotations or interlock circuit for machine damage
protection such as upper/lower limits for positioning outside the programmable controller.
(2) When the programmable controller detects the following error status, it will stop operations and
turn OFF all outputs in the case of (a).
In the case of (b), it will hold or turn OFF all outputs according to the parameter setting.
Note that the AnS series module will turn off the output in either case (a) or (b).

(a) When overcurrent protection or
overvoltage protection of the power
supply module works
(b) When the programmable controller
CPU detects a watchdog timer error
and the like in the self-diagnostics
function

Q series modules

AnS series modules

Output OFF

Output OFF

All outputs will be
retained or OFF,
depending on parameter
setting

Output OFF

When an error occurs at the I/O control part where the programmable controller CPU cannot
detect, all outputs can be turned ON. Configure a fail-safe circuit or some mechanism outside the
programmable controller so that the machine operates safely in such a case. For a fail-safe circuit
example, refer to "Safety Design Using a Fail-safe Circuit" on this manual.
(3) Outputs may remain ON or OFF due to a failure of an output module relay or transistor. Configure
an external circuit for monitoring output signals that may lead to a serious accident.
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[Design precautions]
WARNING
● Configure a safety circuit such as a fuse outside the output module because smoke or fire may
result if a load current exceeding the rated current or an overcurrent caused by load short flows
continuously for a long time.
● Configure a circuit so that an external power supply will be turned on after the start-up of the
programmable controller.
If the external power supply is turned on first, an incorrect output or malfunction may occur,
resulting in accidents.
● For the operating status of each station during data link communication error, refer to each data
link manual.
Failure to do so may cause an incorrect output or malfunction, resulting in accidents.
● When controlling (changing data) the running programmable controller from a peripheral
connected to the CPU module or from a personal computer connected to an intelligent function
module or special function module, configure an interlock circuit in the sequence program to
ensure that the entire system will always operate safely.
For other operations (program modification, operating status change (status control)) to the
running programmable controller, read relevant manuals carefully and ensure the safety before
operation.
Ensure the safety especially when controlling the remote programmable controller from eternal
devices because trouble occurred on the programmable controller side may not be responded
immediately due to data communication error.
Along with configuring an interlock circuit in a sequence program, determine the system’s
corrective actions to be taken between external devices and the programmable controller CPU in
case of a data communication error.

CAUTION
● Do not bundle or adjacently place the control line or a communication cable with the main circuit
or a power cable.
Keep a distance of approximately 100 mm or more between them.
Failure to do so may cause malfunction due to noise.
● When a device such as a lamp load, heater, or solenoid valve is controlled through an output
module, a large current (approximately 10 times greater than normal) may flow when the output is
turned OFF → ON. Take measures such as replacing the module with one having a sufficient
rated current.
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[Installation precautions]
CAUTION
● Use the programmable controller in an environment that meets the general specifications
described in this manual.
Failure to do so may cause electric shock, fire, malfunction, or damage to or deterioration of the
product.
● While pressing down the module mounting lever in the lower part of the module, insert the module
fixing projections into the fixing holes on the base unit completely. Mount the module as above
with the module fixing holes as a support.
Incorrect mounting may cause malfunction, failure or drop of the module.
When using the programmable controller in an environment of frequent vibrations, fix the module
with a screw.
Tighten the screws within the specified torque range.
A screw that has been tightened too loosely may cause a drop, short-circuit, or malfunction.
A screw that has been tightened too tightly may cause a drop, short-circuit, or malfunction due to
the screw or module breakage.
● When using an extension cable, connect it to the extension cable connector of the base unit
securely.
Check it after mounting.
Poor connection may cause incorrect input or output.
● When using a memory card, insert it securely, pressing it to the memory card mounting slot.
Check it after mounting.
Poor connection may cause malfunction.
● Switch off all phases of the external power supply used in the system before mounting or
removing a module. Failure to do so may damage the product.
A module can be replaced online (while power is on) on any MELSECNET/H remote I/O station or
in the system where a CPU module supporting online module change is used.
Note that there are restrictions on the modules that can be replaced online (while power is on),
and each module has its predetermined replacement procedure.
For details, refer to the section of online module change in this manual or the manuals of modules
that support online module change.
● Do not directly touch any conductive part of the module.
Doing so can cause malfunction or failure of the module.

[Wiring precautions]
WARNING
● Be sure to switch off all phases of the external power supply used by the system before wiring
work.
Failure to do so may cause electric shock or damage the product.
● When turning on the power and operating the module after wiring is completed, always attach the
enclosed terminal cover.
The absence of the terminal cover may cause electric shock.
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[Wiring precautions]
CAUTION
● Ensure to ground the FG and LG terminals of the programmable controller with the ground
resistance of 100Ω or less for the exclusive use.
Failure to do so may cause electric shock or malfunction.
● Before wiring the module, confirm the rated voltage and terminal layout of the product to wire
correctly.
Connection to a power supply with different ratings or incorrect wiring may cause fire or failure.
● Crimp or solder external connectors correctly using tools specified by the manufacturer.
Incomplete connection may cause short-circuit, fire, or malfunction.
● Tighten the terminal screws within the specified torque range.
A terminal screw that has been tightened too loosely may cause short-circuit, fire, or malfunction.
A terminal screw that has been tightened too tightly may cause a drop, short-circuit, or malfunction
due to the screw or module breakage.
● Be careful to prevent foreign matter such as sawdust or wiring chips from entering the module.
Failure to do so may cause fire, failure, or malfunction.
● The top surface of the module is covered with protective film to prevent foreign matter such as
wiring chips from entering the module when wiring.
Do not remove this film during wiring.
Before operating the system, be sure to remove this film to dissipate heat.

[Startup and maintenance precautions]
WARNING
● Do not touch any terminal while power is on.
Doing so may cause an electric shock.
● Connect the battery correctly.
Do not charge, disassemble, heat, short-circuit, or solder the battery, or throw it into the fire.
Mishandling the battery may cause heat, burst, or ignition, resulting in injury or fire.
● Switch off all phases of the external power supply used in the system before cleaning the module
or retightening the terminal screws or module fixing screws.
Failure to do so may cause electric shock.
A terminal screw that has been tightened too loosely may cause a short circuit or malfunction.
A terminal screw that has been tightened too tightly may cause a drop, short-circuit, or malfunction
due to the screw or module breakage.
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[Startup and maintenance precautions]
CAUTION
● When performing online operations (especially when performing program modification, forced
output, and operating status change) for the running CPU from the peripheral device, read the
manual carefully and ensure the safety before operation.
Improper operation may cause machine damage or accident.
● Do not disassemble or modify the modules.
Doing so may cause failure, malfunction, injury, or a fire.
● Use any wireless communication device such as a cellular phone or PHS (Personal Handy-phone
System) more than 25 cm away in all directions from the programmable controller.
Failure to do so may cause malfunction.
● Switch off all phases of the external power supply used in the system before mounting or
removing a module. Failure to do so may cause a failure or malfunction of the module.
A module can be replaced online (while power is on) on any MELSECNET/H remote I/O station or
in the system where a CPU module supporting online module change is used.
Note that there are restrictions on the modules that can be replaced online (while power is on),
and each module has its predetermined replacement procedure.
For details, refer to the section of online module change in this manual or the manuals of modules
that support online module change.
● After the first use of the product, do not mount/remove the modules to/from the base unit more
than 50 times. (JIS-B3502 compliant)
Exceeding the limit of 50 times may cause malfunction.
● Do not drop or apply shock to the battery to be installed in the module.
Doing so may damage the battery, causing the battery fluid to leak inside the battery.
If the battery is dropped or any shock is applied to it, dispose of it without using.
● Before handling the module, touch a conducting object such as a grounded metal to discharge the
static electricity from the human body.
Failure to do so may cause module failure or malfunction.

[Disposal precautions]
CAUTION
● Dispose of this product as industrial waste.
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[Transportation precautions]
CAUTION
● When transporting lithium batteries, follow the transportation regulations.
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● Safety Precautions (GX Works2) ●
(Please read the precautions carefully before use.)
When using the integrated FA software (GX Works2 Version 1), please read carefully the GX Works2
operating manual and related manuals referenced in this manual. Pay sufficient attention to safety and
handle the software properly.
In this manual, the safety precaution levels are classified under "WARNING" and "CAUTION".

WARNING

Incorrect handling may cause hazardous conditions, resulting in death
or severe injury.

CAUTION

Incorrect handling may cause hazardous conditions, resulting in
medium or slight injury, or may cause only material damage.

CAUTION level may lead to a serious consequence according to conditions.
Note that the
Please follow the instructions of both levels because they are important to personnel safety.

[Design precautions]
WARNING
● When data change, program change, or status control is performed from a personal computer to
a running programmable controller, configure an interlock circuit outside the programmable
controller system to ensure that the entire system will always operate safely.
Furthermore, for the online operations performed from a personal computer to a programmable
controller CPU, predetermine the system’s corrective actions in case of a communication error
caused by poor cable connection, etc.

[Startup and maintenance precautions]
CAUTION
● When performing online operations (program change while a programmable controller CPU is
running, forced input/output operation, operating status changes such as RUN-STOP, and remote
control operation) for the running programmable controller CPU from a personal computer, read
the manual carefully and ensure sufficient safety before operation. When changing a program
while a programmable controller CPU is running (online program change), a problem such as
program corruption may occur depending on operating conditions. Fully understand the
precautions described in Section 12.9 of the GX Works2 Version 1 Operating Manual (Common)
(refer to Appendix 1 of this school text) before use.
● Refer to the manual of each module before performing online module change because only
limited modules allow online module change.
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Introduction
This text is intended to give necessary background information and how to use a peripheral personal computer
(GX Works2) for maintenance of the MELSEC-Q series.
<The following are related materials>
Manual name
QCPU User's Manual (Hardware Design, Maintenance and Inspection)
Description of specifications such as the CPU module, power supply module, base unit,
extension cable, and memory card is provided.

Manual number
(Model code)
SH-080483ENG
(13JR73)

GX Works2 Version 1 Operating Manual (Common)
Description of common functions between simple project and structured project such as system
configuration of GX Works2, parameter setting, operation methods for online functions is

SH-080779ENG
(13JU63)

provided.

GX Works2 Version 1 Operating Manual (Simple Project)
Description of operation methods such as program creation and monitoring in a GX Works2
simple project is provided.
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SH-080780ENG
(13JU64)

Table of Contents
Chapter 1: Importance of Production Maintenance

1- 1 to 1- 6

1.1 Importance of Maintenance ····························································································· 1- 1
1.2 Maintenance System ····································································································· 1- 2
1.3 Maintenance Plan ········································································································· 1- 3
1.4 Management of Maintenance Documents ·········································································· 1- 4
1.5 Maintenance Record······································································································ 1- 4
1.6 Tendency of Failure Cause ····························································································· 1- 5
1.7 Failure Modes ·············································································································· 1- 6
Chapter 2: Understanding Programmable Controller System

2- 1 to 2- 8

2.1 System Configuration of Training Machine ············································································ 2- 1
2.2 I/O Number Assignment ···································································································· 2- 2
2.2.1 Concept of I/O Number Assignment ··············································································· 2- 2
2.2.2 I/O Assignment Using GX Works2 ················································································· 2- 4
Chapter 3: Learning Personal Computer (GX Works2) Operation

3- 1 to 3-34

3.1 Creation of New Project Using GX Works2 ············································································ 3- 1
3.2 Programming in Ladder Mode····························································································· 3- 5
3.3 Parameter Setting for Multiple CPU (Not Required for Single CPU Configuration) ························· 3- 8
3.4 Storing and Managing Programs ························································································· 3- 9
3.5 Writing Data to Programmable Controller CPU ······································································ 3-10
3.6 Monitoring Operation in Ladder Mode·················································································· 3-15
3.7 Entry Ladder Monitor Operation ························································································· 3-17
3.8 Device Batch Monitor Operation ························································································· 3-19
3.9 Entry Data Monitor Operation (Watch Window) ····································································· 3-21
3.10 Device Test Operation ···································································································· 3-22
3.11 Online Program Change ································································································· 3-25
3.12 PLC Verify Operation ····································································································· 3-28
3.13 Read from PLC Operation ······························································································· 3-29
3.14 Termination Operation of GX Works2 ················································································ 3-30
3.15 New Read from PLC Operation ························································································ 3-31
Chapter 4: Designing Maintenance Measures

4- 1 to 4-12

4.1 Preliminary Actions to Implement Maintenance Measures ························································ 4- 1
4.2 Using Programmable Controller with High Serviceability··························································· 4- 2
4.2.1 RAS Function ············································································································ 4- 2
4.2.2 Self-diagnostics Function ····························································································· 4- 3
4.3 Safety Design Using a Fail-safe Circuit ················································································· 4- 7
Chapter 5: Preventive Maintenance

5- 1 to 5- 5

5.1 Necessity of Preventive Maintenance ··················································································· 5- 1
5.2 Daily Maintenance and Inspection ······················································································· 5- 2
A - 11

5.3 Regular Maintenance and Inspection ··················································································· 5- 3
5.4 Condition Monitoring-based Maintenance·············································································· 5- 4
5.5 Checking Operating Environment ························································································ 5- 5
Chapter 6: Corrective Maintenance

6- 1 to 6-113

6.1 Important Points in Corrective Maintenance··········································································· 6- 1
6.2 Operation to Read Error Codes Using GX Works2 ·································································· 6- 3
6.3 Basic Practice of Troubleshooting······················································································· 6-12
6.4 Troubleshooting for the Power Supply Module ······································································ 6-15
6.4.1 Selection of a Power Supply Module·············································································· 6-16
6.4.2 When the "POWER" LED Turned Off············································································· 6-21
6.4.3 When the ERR Terminal (Negative Logic) Turned OFF (Opened)········································ 6-22
6.4.4 When Uninterruptible Power Supply (UPS) Is Connected ·················································· 6-23
6.5 Troubleshooting for the CPU ····························································································· 6-24
6.5.1 Troubles regarding Hardware Failure············································································· 6-24
6.5.2 When a Program Cannot Be Read/Written······································································ 6-34
6.5.3 CPU Troubles and Measures ······················································································· 6-38
6.6 Troubleshooting for the Input Module ·················································································· 6-40
6.6.1 Troubles regarding Hardware Failure············································································· 6-40
6.6.2 Input Circuit Troubles and Measures ············································································· 6-42
6.6.3 Input Module Terminal Voltage Checking Methods ··························································· 6-45
6.7 Troubleshooting for the Output Module ················································································ 6-46
6.7.1 Troubles regarding Hardware Failure············································································· 6-46
6.7.2 Output Circuit Troubles and Measures ··········································································· 6-48
6.7.3 Output Module Terminal Voltage Checking Methods························································· 6-53
6.8 Troubleshooting Using Cart Conveying System Training Machine ············································· 6-55
6.9 Trouble Example: Troubleshooting Using Training Machine ····················································· 6-68
6.10 Troubleshooting for the Intelligent Function Module ······························································ 6-72
6.10.1 Common Items about Intelligent Function Modules ························································· 6-72
6.10.2 Buffer Memory Monitor Operation of the Intelligent Function Module ·································· 6-74
6.10.3 Intelligent Function Module Troubles and Measures························································ 6-78
6.11 Sequence Program Troubles ··························································································· 6-82
6.12 Practical Training in Case of Error····················································································· 6-84
6.12.1 Training 1 I/O Number Assignment Mistake Using Personal Computer GX Works2··············· 6-84
6.12.2 Training 2 Operation Failure Due to Redundant Coil ······················································· 6-87
6.12.3 Training 3 Jump Destination Error in Use of CJ Instruction ··············································· 6-89
6.12.4 Training 4 BCD Code Error························································································ 6-91
6.12.5 Training 5 BCD Instruction Error to Minus Data······························································ 6-93
6.12.6 Training 6 How to Use Failure Detection Annunciators (F) ··············································· 6-94
6.12.7 Training 7 Setting of Operation Mode When There Is an Error ·········································· 6-96
6.12.8 Training 8 Error Check and Error Clean from a Program Using SM and SD ························· 6-97
6.12.9 Training 9 Saving of Error Histories ············································································· 6-98
6.12.10 Training 10 Sampling Trace······················································································ 6-99
6.12.11 Training 11 Scan Time Measurement ········································································6-105
6.12.12 Training 12 Remote Operation ·················································································6-106
6.12.13 Training 13 Forced ON/OFF Function for External I/O···················································6-108
6.12.14 Sequence Program ································································································6-112

A - 12

Chapter 7: Improvement Maintenance

7- 1 to 7- 4

7.1 Equipment Serviceability Improvement ················································································· 7- 1
7.2 Improving Automatic Detection of Equipment Failure ······························································· 7- 1
7.3 Enhanced Condition Monitoring-based Maintenance ······························································· 7- 2
Chapter 8: Reviewing Installation Environment

8- 1 to 8-10

8.1 Environment···················································································································· 8- 1
8.2 Electrical Environment······································································································· 8- 1
8.3 Mounting Condition··········································································································· 8- 2
8.4 Wiring ···························································································································· 8- 5
8.4.1 Wiring Precautions······································································································ 8- 5
8.4.2 Wiring Power Supply Module ························································································ 8- 8
Chapter 9: Measures against Noise

9- 1 to 9-12

9.1 Common Mode Noise and Normal Mode Noise ······································································ 9- 1
9.2 Common Mode Noise ······································································································· 9- 1
9.3 Normal Mode Noise ·········································································································· 9- 2
9.4 Measures against Noise in External Input Signal Cable···························································· 9- 3
9.5 Measures against Noise in External Output Signal Cable ························································· 9- 4
9.6 Measures against Noise Troubles························································································ 9- 6
9.7 Procedure for Noise Measurement ······················································································ 9- 7
9.8 Solution Examples for Noise Troubles ················································································· 9-10
Chapter 10: Life of Programmable Controller Components

10- 1 to 10-18

10.1 Battery Life·················································································································· 10- 1
10.2 Fuse ··························································································································10-13
10.3 Life of Electrolytic Capacitor····························································································10-14
10.4 Life of Output Relay ······································································································10-15
10.5 Spare Parts ·················································································································10-16
Chapter 11: Preparing for Test Operation

11- 1 to 11- 2

11.1 Check Items before Starting Test Operation······································································· 11- 1
11.2 Preparation Procedure for Test Operation ········································································· 11- 2
Chapter 12: CPU Replacement Procedure during Operation

12- 1 to 12-32

12.1 Universal Model QCPU Replacement Procedure ································································ 12- 2
12.1.1 Preparation············································································································ 12- 2
12.1.2 Data Backup ·········································································································· 12- 2
12.1.3 Replacement ·········································································································12-20
12.1.4 Data Restoration·····································································································12-21
12.1.5 Operation Check·····································································································12-31

A - 13

Appendix

A- 1 to A-71

Appendix 1 Online Program Change ·························································································A- 1
Appendix 1.1 Online Program Change in Unit of Ladder Blocks···················································A- 2
Appendix 1.2 Online Program Change in Unit of Files································································A- 4
Appendix.1.3 Precautions for Online Program Change ······························································A- 5
Appendix 1.4 Actions to Be Taken When Online Change Is Not Properly Completed ·······················A- 8
Appendix 2 Index Modification ·································································································A- 9
Appendix 2.1 Index Modification Overview ··············································································A- 9
Appendix 2.2 16-bit Index Modification ···················································································A- 9
Appendix 2.3 32-bit Index Modification (Universal Model QCPU Only) ········································· A-11
Appendix 2.4 Index Modification to Extended Registers (D) or Extended Link Registers (W)
(Universal Model QCPU) ················································································· A-15
Appendix 2.5 Other Index Modifications ················································································· A-17
Appendix 2.6 Precautions ··································································································· A-18
Appendix 3 Questions and Answers regarding Personal Computer ················································ A-20
Appendix 4 Questions and Answers regarding GX Works2 ··························································· A-21
Appendix 5 Warranty ············································································································ A-24
Appendix 6 Programmable Controller Fault Investigation Report ···················································· A-25
Appendix 7 QCPU Replacement Checklist ················································································ A-27
Appendix 7.1 Qn(H)CPU Replacement Checklist····································································· A-27
Appendix 7.2 QnU(D)(E)(H)CPU Replacement Checklist ·························································· A-29
Appendix 8 Reference Material for Cart Conveying System Training Machine ·································· A-31
Appendix 9 Buffer Memory Access Instruction············································································ A-32
Appendix 9.1 Reading One-word or Two-word Data from an Intelligent Function Module
(FROM(P), DPRO(P)) ····················································································· A-32
Appendix 9.2 Writing One-word or Two-word Data to an Intelligent Function Module
(TO(P), DTO(P)) ···························································································· A-35
Appendix 10 High Performance Model QCPU Replacement Procedure··········································· A-38
Appendix 10.1 Preparation·································································································· A-38
Appendix 10.2 Data Backup ································································································ A-39
Appendix 10.3 Replacement································································································ A-56
Appendix 10.4 Data Restoration··························································································· A-57
Appendix 10.5 Operation Check··························································································· A-68

A - 14

Chapter 1: Importance of Production Maintenance
If a production system stops because of failure or power failure, a loss proportional to
the stop time occurs.
Therefore, it is required to design an equipment system to prevent [stop because of
failure] or [stop because of power failure] from occurring.
The important issue is how the production system can quickly be restored if the system
stops by any chance. Therefore, the maintenance staff group is assigned to each
factory for improving availabilities of the production systems.
1.1 Importance of Maintenance
In recent production systems, a lot more machinery equipment adopts the mechatronics
technology and systems are becoming more complex and significantly sophisticated. Also,
using black box systems for equipment is becoming increasingly common. For these
reasons, the maintenance quality is relatively decreasing, making improvement in system
availability difficult.
Therefore, [highly reliable products] and [increased level of maintenance technology] are
strongly required.
Standard production system

Mechatronics of machinery
and equipment

Complicated and highly-developed
production system

Black boxing of the equipment

Decrease in relative
maintenance level

Highly reliable product application

Increasing the level of
maintenance technology

Realization of highly reliable
production system
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1.2 Maintenance System
In order to achieve a highly reliable production system, it is important to have an
established maintenance system in place.
The following shows an outline of a maintenance system.
Production
maintenance
When developing new machinery, give due consideration to
maintenance measures at the designing stage.

Maintenance
measure
design

Preventive
maintenance

Preventive maintenance of the machinery is carried out if the
machinery is prone to financial losses or serious disasters due to
failures or accidents, and if it is beneficial to carry out preventive
maintenance of such machinery. Also perform maintenance actions
for predictable failures and accidents before such incidents occur.

Daily maintenance
and inspection

Perform daily inspection to detect any dangerous
conditions that may cause breakdown of the
production system due to failure or any detrimental
decrease in performance.

Periodic maintenance
and inspection

Perform regular inspection to detect any dangerous
conditions that may cause breakdown of the
production system due to failure or any detrimental
decrease in performance.

Condition-based
maintenance

Monitor the status to detect any dangerous
conditions that may cause breakdown of the
production system due to failure or any detrimental
decrease in performance.

Corrective
maintenance

Corrective maintenance is carried out when it is easier to
repair equipment after it has broken down (such as digital
displays, CRTs, all types of lamps) due to accidents.

Maintenance for
improvement

This maintenance is carried out to minimize degradation of
installed machinery and to simplify the inspection process.
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1.3 Maintenance Plan
In production systems, the recovery time can be long, and improvements in system
availability cannot be expected if repairs are considered only after a failure occurs.
Therefore, a maintenance plan is developed from when a production system is
implemented, and efficient maintenance is conducted.
In order to quickly restore the system after a failure occurs, it is necessary to systematically
execute the contents of the following table.
Table1-1: Maintenance Plan of the Programmable Controller System
Plan item
Maintenance
training

Maintenance
timing
Maintenance
equipment
Maintenance
procedure
Maintenance
staff
Maintenance
method
improvement
Understanding
a service and
support
system of
the
programmable
controller

Description
Knowledge of  Fundamental knowledge of principle, function, performance,
etc. of the programmable controller
the
programmable  Characteristics of the programmable controller (difference
from a calculator, relay, etc.)
controller
 Position of the programmable controller (sequence control,
and control function of data collection and distribution)
 Introductory state of the programmable controller (usage in
your own department etc.)
 Description of the type of machine installed (introduced)
(model, function, performance, characteristics, etc. of the
programmable controller used)
Maintenance  Knowledge about maintenance related to the programmable
controller (characteristics of the programmable controller
scope and
from a maintenance perspective, and maintenance items of
technology
the programmable controller)
 Precautions for maintenance of the programmable
controller (handling method, key points of maintenance,
etc.)
Training
 Functions related to maintenance of the programmable
controller (self-diagnostics function, RAS function, etc.)
 Functions related to maintenance of peripherals
(troubleshooting function, etc.)
 Practical training of troubleshooting (operation of
peripherals, replacement of hardware, etc.)
Specify the target type, etc., of preventive maintenance and corrective
maintenance, and determine the implementation timing.
Preparation of spare parts, components, measuring instruments,
measurement equipment, etc. for maintenance
Prepare the manuals, etc., and clearly define the implementation method and
a description.
Determine the staff procurement, positions, assigned areas, etc.
Study to improve the maintenance methods, etc.
After-sales
service

Technical
support

 Service base (location, address, person in charge, etc.)
 Service range (target model, handling range, etc.)
 Service time (start/end time, turnaround time, emergencies,
etc.)
 Service period (free service period, handling at the time of
paid service, etc.)
 Spare parts supply period (repair after discontinuing
production, supply period, etc.)
 Measures against discontinuance of production (contents of
discontinuance declaration, repair period, etc.)
 Time required for repair (standard delivery, short term/long
term deliveries, etc.)
 Support base (location, address, person in charge, etc.)
 Support range (target model, hardware/software, and
system)
 Support method (telephone, FAX, visit, school, and actual
machine operation)
 Manual (manual effective for maintenance)
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1.4 Management of Maintenance Documents
In order to quickly restore after the failure, it is necessary to organize and manage the
documents as shown in the following table.
Table 1-2: Maintenance-related Documents to Manage
Document
Name of document
classification
SystemSystem and control
specific
specifications documents
documents

General
documents

Description

Documents describing the functions and operations of a target
system and control
(sequence and timing of operation, operation condition,
operation procedure, and interlock condition)
Network connection
Documents illustrating how modules are connected with
diagram
communication cables
Electrical wiring diagrams Schematic diagrams
(power supply circuit, motor circuit, control circuit, operating
circuit, display circuit, etc.)
Connection diagrams among equipment and panels (cable
layout diagram, ground wire layout diagram)
Equipment layout
Layout diagrams for electrical equipment in the panel, terminal
diagrams
block wiring number layout drawings, connection assignment
tables for connector pins
(For identifying models and wiring numbers for each
equipment)
List of hardware used
Lists of electrical equipment used in the system
(model name and specifications of all the electrical equipment
constituting the programmable controller system, such as
modules, peripheral equipment, electrical components in the
control panel, I/O equipment, and software packages)
Programmable controller Control programs for the programmable controller (ladder
program
diagrams and lists)
Assignment lists of
Assignment lists of external I/O signals and internal devices
input/output, etc.
(signal names corresponding to respective device numbers,
signal descriptions, and setting values)
Program descriptions
Program configurations, process descriptions, and function
(specifications)
descriptions
(explanations for operations in programs that are difficult to
understand, etc.)
Instruction manuals of
For handling (operation), maintenance, and inspection of the
controlled systems
controlled systems
 Maintenance and
inspection instructions
Catalogs of hardware
Identifies configuration, manufacturer of the equipment model
used
Instruction manuals and
technical documents of
For troubleshooting of hardware and software
hardware used

1.5 Maintenance Record
After recovery following a failure, it is necessary to manage the maintenance record as
follows for future reference.
Table 1-3: Maintenance Record to Manage
Record item
Occurrence status of error and failure
System stop time
Impact due to occurrence
Cause
Recovery method
Measures against re-occurrence
Failure record
Name of a person in charge
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Description
Name of device/equipment, phenomenon, and environment
Time of occurrence and stop time
Amount of loss, time loss, and other impact
Method of cause investigation and cause including
presumption
Recovery method such as replacement and repair
Defensive measures against the re-occurrence of the similar
failure and lessons learned
Record of failure cause, measures, etc.

1.6 Tendency of Failure Cause
The following graphs show the ratios of the failed parts and the failure causes of
programmable controller troubles.
[Based on the research by the Japan Electrical Manufacturers' Association (JEMA)]
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Power supply
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Figure 1-1: Failed Part of the Programmable Controller (Multiple Answers)
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No answer
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Others

Manufacturer's responsibility

Poor connection

Load short

Malfunction due to noise

Unknown cause

0

Figure 1-2: Failure Cause of the Programmable Controller (Multiple Answers)
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1.7 Failure Modes

Rate of failure occurrences

In general, failure modes of a complicated system can be classified into three levels
recognized as Figure 1-3: initial failure, random failure, and wear-out failure. An initial
failure is considered a failure that is removed during the manufacturing process or
through inspection by the manufacturer. A random failure is an unexpected failure,
which cannot be anticipated and can occur anytime before the wear-out progresses
during the life of the equipment. It is difficult to take technical measures against
random failures, and at this point, only the measures based on statistical handling can
be implemented.
A wear-out failure occurs near the end of the usable life as a result of deterioration or
abrasion and increases rapidly with the time. Replacement years mentioned here
indicate a point "tb" in Figure 1-3, at which point a specified part is replaced with a new
one in order to achieve appropriate preventive maintenance.

Initial failure
period

Random failure
period

Wear-out failure
period

Useful life

Figure 1-3: Bath-tub Curve
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Chapter 2: Understanding Programmable Controller System
A programmable controller system consists of a base unit, power supply module, CPU
module, input module, output module, and special function module.
2.1 System Configuration of Training Machine
Output module

CPU module

Power supply
module

2

Input module

Base unit Q38DB

Q61P QCPU Empty

QX
QY Q64 Q62
42
42P
AD DAN
(64
(64
(16
(16
points) points) points) points)

USB cable

X0

Y40

X3F

Y7F

Peripheral device

I/O panel
Y6F

Y77

Y76

Y75

Y74

Y73

Y72

Y71

Y70

Y7F

Y7E

Y7D

Y7C

Y7B

Y7A

Y79

Y78

X7

X6

X5

X4

X3

X2

X1

X0

Y60

X3F

ON

X30

1 9 4 2

Y5F

X2F

Y50

Y4F

Y40

X20

4 1 3 6

MELSEC-Q

OFF
XF

XE

XD

XC

XB

XA

X9

A/D INPUT

X8
ON
OFF

Table 2-1: System Configuration of the Training Machine
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D/A OUTPUT

2.2 I/O Number Assignment
This section describes I/O number assignment which is necessary for data
communication with an I/O module or an intelligent function module in QCPU.
An I/O number is intended to input data from an input module or to output data to an
output module in a sequence program.
The I/O number is represented in three-digit hexadecimal.
The I/O numbers of I/O modules all of which have 16 points are shown in Figure 2-2.

X0 1 F
Input 16
points

X0 2 F
Input 16
points

Y0 4 0

～

X0 0 F
Input 16
points

Y0 3 0

～

～

X0 2 0

～

X0 1 0

～

CPU module

Power supply module

X0 0 0

Y0 3 F

Y0 4 F

Output 16 Output 16
points
points

Figure 2-2: Concept of I/O numbers
2.2.1 Concept of I/O Number Assignment
I/O number assignment is carried out as shown below when the power turns on or
when the CPU module is reset.
Specify I/O numbers that are assigned according to the following items in a sequence
program.
(1) The I/O number of Slot 0 of the main base unit (located at the right side of the
CPU module) is zero, and numbers are assigned rightward sequentially.
If it is an input module, the number will be "X
".

module, the number will be "Y
Slot 0
1 2

Input

3

4

5

6

7

Output

0

Input

CPU module

Power supply module

Main base

16 16
16
points points points

X000 X010 Y020
X00F X01F Y02F

Input (X) and output (Y) are
sequentially assigned
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", and if it is an output

Slot number

Direction of assignment
(Assigned rightward from Slot 0)

(2) If an extension base unit is connected, the number starts from the next number of
the assignment of the main base unit.
A base number (one to seven) is assigned to the extension base unit according to
the connection order of extension cables.
Assignment when an extension base unit is used
Power supply module

Main base

Extension cable
Number of
extensions
First
extension

C

0 1 2 3 4 5 6 7
00 10 20 30 40 50 60 70

P
U

0F 1F 2F 3F 4F 5F 6F 7F

Extension base (1)
I/O number assignment order (2)
unit

8 9 10 11 12 13 14 15
80 90 A0 B0 C0 D0 E0 F0

8F 9F AF BF CF DF EF FF
(3)
(4)

Extension base unit

Second
extension

16 17 18 19 20 21 22 23
100 110 120 130 140 150 160 170

10F 11F 12F 13F 14F 15F 16F 17F
(5)
(6)

* The I/O number assignment is carried out sequentially, in the order of (1) → (2) →
(3) → (4) → (5) → (6).
In this I/O number assignment example, each module has 16 points.
(3) One module occupies I/O numbers equal to its number of I/O points.
For example, if an input module that has 32 points is mounted to Slot 0 of the
1

2

3

Input

Output

Output

CPU

0

Input

Power supply module

main base unit, 32 points of I/O numbers, which are X00 to X1F, are occupied.
4

32 16 32 16
points points points points
X000 X020 Y030 Y050
X01F X02F Y04F Y05F

Each slot occupies 32 points

(4) To an empty slot, to which neither an I/O module nor an intelligent function
module is mounted, number of points specified in the PLC System Settings in

2

3

Empty

Empty
(

(

32 32
points points

4

Slots to which no I/O module and
intelligent function module are mounted

Input

1

Input

CPU

0

Input

Power supply module

PLC parameters are assigned. (The default is 16 points.)

16
points

X000 X020 040 050 X060

)

)

X01F X03F 04F 05F X06F

To each empty slot, 16 points are assigned
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2.2.2 I/O Assignment Using GX Works2
In QCPU, the I/O module or the intelligent function module can be controlled without
I/O assignment using GX Works2.
I/O assignment using GX Works2 is effective in the following cases.
(1) Purpose of I/O assignment using GX Works2
(a) Reservation for replacement to a module other than 16-point modules
In case replacement of a current module with another that has different points
is planned, reservation in advance eliminates the need of future I/O number
change.
(b) Prevention of I/O number change due to module replacement
In case failure occurs in an I/O module or an intelligent function module other
than 16 points and the module is removed, change of I/O numbers can be
avoided.
(c) Change to I/O numbers specified by a program
In case a designed program uses different I/O numbers from the ones an
actual system uses, the I/O numbers of each module of the base unit can be
changed to the numbers specified by the program.
(d) Detailed settings for an I/O module and an intelligent function module
Selecting "Type" in I/O assignment displays detailed settings below.
 Input response time setting for an input module and an interrupt module
(I/O response time)
 Error time output mode setting for an output module and an intelligent
function module
 Switch setting for an intelligent function module
 Operation setting for QCPU
(during hardware error of the intelligent function module)
POINT
(1) I/O assignment is necessary for input module response time change and
intelligent function module switch setting.
I/O assignment, input module response time setting, intelligent function module
switch setting, and output mode upon error require the programmable
controller's power turned OFF and ON (ON → OFF → ON) or resetting QCPU.
(2) If a failure of an I/O module other than 16 points occurs without I/O assignment
using GX Works2, the I/O numbers of the following modules may change. This
can cause malfunction. I/O assignment using GX Works2 is recommended
therefore.
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(2) Concept of I/O assignment using GX Works2
(a) I/O assignment per slot
"Type" (module type), "Number of points" (number of I/O points), and "Start
XY" (start I/O number) can be set individually for each slot of the base unit.
For example, if the number of I/O points of a specified slot is changed, the
number of points alone can be set.
Items that are not specified depend on a mounted status of the base unit.
I/O assignment can be performed from the I/O assignment setting of the PLC
parameter.
(1)

(2)

(3)

(4)

(5)

1) Slot
Displays a slot number as well as how many extensions and slots exist in
the base unit before a specified slot.
If the basic setting does not provide the number of slots in the base unit,
"*" is displayed as the number of extensions in the base unit, and a serial
number from the 0th slot of the main base unit is displayed as the number
of slots.
2) Type (used by QCPU)
Select the type of a mounted module from the following items.
 Empty (empty slot)
 Input (input module)
 High-speed input (high-speed input module)
 Output (output module)
 I/O combined (I/O combined module)
 Intelligent (intelligent function module, or special function module
compatible with AnS)
 Interrupt (interrupt module)
 Slots without any type specified will be the type of an implemented
module.
3) Model name
Set the model name of a mounted module using up to 16 single-byte
characters.
QCPU does not use the specified model name. (This is regarded as a user's
memo.)
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4) Points
When changing the number of I/O points for each slot, select the number
of points from below.
• 0 points
• 48 points
• 256 points

• 16 points
• 64 points
• 512 points

• 32 points
• 128 points
• 1024 points

Slots without any number of points specified will have the number of
points for an implemented module.
5) Start XY
 When changing I/O numbers for each slot, set a new start I/O number.
To slots without any start XY specified, I/O numbers that start from a
specified slot will be assigned sequentially.
 Set I/O numbers for each slot so that the numbers will not overlap with
ones assigned by QCPU.
A duplicated I/O number causes an error (SP.UNIT LAY ERR.).
 Assigning I/O numbers for each module in advance prevents the I/O
numbers of other modules from being changed during module
replacement.
(b) Status of slots to which I/O assignment has done
Slots to which I/O assignment has done reflect assigned I/O numbers, regardless
of module implementation.
1) When the number of points smaller than the implemented points of an I/O
module is set, the available points of the implemented I/O module
decrease.
For example, when a slot implemented with a 32-point input module is
configured as a 16-point input module using I/O assignment, the latter 16
points out of the 32 points become unavailable.
2) When the number of points smaller than the implemented points of an
intelligent function module is set, "SP.UNIT LAY ERR." occurs.
(If number of points larger than the point of the module is set, no error is
displayed.)
3) When the number of points larger than the implemented points of an I/O
module is set, points that exceed the available points are regarded as
dummy.
4) Use an identical type as an implemented module for I/O assignment.
In I/O assignment, if a type is different from an implemented module type, it does
not operate properly. For an intelligent function module, number of I/O points
must be identical too. (If the number of I/O points is not identical, no error is
displayed.)
Implemented module
Input module
Output module
Input module/output module
Intelligent function module
Empty slot

I/O assignment setting
Output/Empty
Input/Empty
Intelligent
Empty
Input/Output
Intelligent

Result
Empty
Empty
Error (SP.UNIT LAY ERR.)
Empty
Error (SP.UNIT LAY ERR.)
No error

5) When I/O assignment is done, the last I/O number must be within FFFH. If
the last I/O number exceeds FFFH, an error (SP.UNIT LAY ERR.) occurs.
(In the system monitor of GX Works2, "***" is displayed as an I/O
address.)
(c) To a slot to which I/O assignment using GX Works2 has not done, the
number of points identical to an implemented module is assigned.
(d) It is recommended to attach a seal or something that has description of I/O
assignment settings to each module for easy recognition from outside, in
order not to mount a wrong module during maintenance.
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(3) Example of I/O assignment using GX Works2
Consider an example in which I/O assignment is done for the following purposes.
(a) Because no 16-point input module is available at hand, a 32-point input
module must be used.
(b) Because delivery of a 32-point output module is behind schedule, an empty
slot for 32 points must be temporarily reserved.

1

2

3

4

Input

Input

Output

Output

Substitute module
0
Input

CPU module

Power supply module

Q35B base unit

32
32
16
16
16
points points points points points
X32 X16 X16 Y16 Y16
points points points points points
X00 X20 X30 Y40 Y50
X1F

Q65B base unit

7

8

9

Output

Output

Output

16
32
32
32
points points points
points
Y32
Y16 Y32 Y32
Y32
points points points points points
Y60 80 YA0 YB0 YD0
Y7F

Number of I/O points according
to mounted status
Number of I/O assignment
points by GX Works2

Y5F

Mounting a 32-point output module is planned.
6
Empty

Output

Power supply module

5

X2F X3F Y4F
（a）

Slot number

9F YAF YCF YEF
（b）
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MEMO
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Chapter 3: Learning Personal Computer (GX Works2) Operation
3.1 Creation of New Project Using GX Works2
(1) Click the [Start] button.
(2) Select the [All programs] menu.
(3) Select the [MELSOFT application] menu.
(4) Select the [GX Works2] menu.
(5) Click the [GX Works2] menu.
(3) Select!

(5) Click!

(2) Select!
(4) Select!

(1) Click!

(6) GX Works2 starts.

(6) GX Works2 starts.

(To the next page)

3-1

3

(From the previous page)

on the toolbar or click the [Project]
(7) Click
→ [New] menu ( Ctrl + N ).

(8) Click the [Project Type] list button.
(9) Click to select "Simple project" from the
displayed list box.

(10) Click the [Series] list button.
(11) Select "QCPU (Q mode)" from the displayed
list box.

(To the next page)
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(From the previous page)
(12) Click the [Type] list button.
(13) Select "Q06UDH" from the displayed list box.

(14) Click the [Language] list button.
(15) Select "Ladder" from the displayed list box.
(16) Click the OK button.

(17) A new project opens.
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REFERENCE
In GX Works2, shortcut key assignment can be changed using the [Tool] →
[Key Customize] menu.

Item
Shortcut Key
Category
Command
Current key
Press the keys to assign
Currently assignment

Template

Description
Select a classification from a list of groups categorized by each window.
Select a function name whose shortcut key is to be changed.
Shortcut keys currently assigned to a selected command are displayed.
Specify a shortcut key to be newly assigned. It can be specified by
pressing keys of the keyboard.
Example)
The name of a menu assigned to a selected shortcut key is displayed.
If the selected shortcut key has already been assigned to another function,
the name of the function is displayed.
Select a shortcut key template from the list box.
 Default settings
Changes to the initial status.
 GPPA type setting
Collectively changes key assignment to the one same as GPPA during
creation of a ladder diagram.
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3.2 Programming in Ladder Mode
This section describes practical training for an operation to create and execute a
sequence program.
(1) Function key operation during ladder mode
Operation

Key combination

Operation

Key combination

Write Mode

F2

Rising Pulse Branch
(
)

Alt + F7

Statement Display

Ctrl + F7

Rising Pulse Close
)
Branch (

Shift + Alt + F7

Find Contact or Coil

Ctrl + Alt + F7

Shift + F2

Read Mode
Start Monitoring

F3

Monitor (write mode)

Shift + F3

Stop Monitoring

Alt + F3

Conversion

F4

Application Instruction
(
)
Falling Pulse (
)

F8
Shift + F8

Conversion + Online
Program Change

Shift + F4

Falling Pulse Branch
(
)

Alt + F8

Conversion (All
Program)

Shift + Alt + F4

Note

Ctrl + F8

Falling Pulse Close
)
Branch (

Shift + Alt + F8

Normally Open
)
Contact (

F5

Normally open contact
)
OR (

Shift + F5

Operation result rising
pulse conversion ( )

Alt + F5

Vertical Line ( )

Shift + F9

Comment

Ctrl + F5

Delete Line (

)

Alt + F9

Operation result fall
pulse conversion ( )

Ctrl + Alt + F5

Rising Pulse Close
)
(

Shift + Alt + F5

Normally Closed
)
Contact (

)

Horizontal Line (

F6

Delete Horizontal Line
)
(
Edit Line (

)

F9

Ctrl + F9
F10

Delete Vertical Line ( )

Ctrl + F10

Normally closed
)
contact OR (

Shift + F6

Operation Result
Inversion (
)

Ctrl + Alt + F10

Falling Pulse Close
(
)

Shift + Alt + F6

Insert Row

Shift + Ins

Device Display

Ctrl + Alt
F6

Insert Column

Ctrl + Ins

Delete Row

Shift + Del

Delete Column

Ctrl + Del

Coil (

)

Rising Pulse (

+

F7

)

Shift + F7
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1) Change to Write Mode using the function key F2 .
(Mode switching can be done using F2 (Write), Shift +
F3 (Monitor).)

F2

(Read), or

2) There are three operations for conversion after writing a ladder:
F4 ( ) ...................................... Converts a program currently editing.

 Ctrl + Alt + F4 ( ) ........ Converts all programs currently editing.
 Shift + F4 ................................ Converts an edited program and writes to a
programmable controller CPU in a RUN
state.
3) Follow the steps below to write instructions using function keys.
a. Operation for inputting contacts
Using the keyboard, press the F5 key then input "X1".
Press the
key or the OK button to write to the editing screen.

b. Operation for inputting application instruction
Using the keyboard, press the F8 key then input "MOV K1 D0".

REFERENCE
The following procedures can also be used for writing instructions:
 By the tool button
then input "MOV K1 D0" using the keyboard.
Click

 By the menu bar
Select the [Edit] → [Ladder Symbol] → [Application Instruction] menu then input "MOV K1 D0" using
the keyboard.

Press the
screen.

key or clicking the
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OK

button to write to the editing

Project name

QHOZEN

(2) Sequence programming in ladder mode
X2

0

X2
SM411

Y70
K200

X2

3

T1
BCD

K4Y40

RST

T1

X0

10

SM400
16

35

T1

>

K100

T1

<=

K100

T1

<

K150

T1

SM412

Y71
>=

K150

T1

Y72
Y73

M100

Y74
K1000
C0
BCD

C0

K4Y60

RST

C0

X1
45

END

50

Use the function keys
1)

F6

(

X

2

(

(

Y

F10

F5

)
F7

2)

to

F5

7

for typing.

S

M

4

1

1

)

0

)
F5

X

2

F7

)

(

(

→

↑

1

T

1

K

)

Shift + F9
( )
K
4

↓
(
4

Y

(Space)
F8
B

2
C

0

0

D

)

T

(Space)
0

(Space)
3) Press the function key
Key input

F5

Shift +

F5

F6

F4

(

).

Shift +

Ladder
symbol
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F6

F7

F8

F9

Shift +

F9

3.3 Parameter Setting for Multiple CPU (Not Required for Single CPU Configuration)
Two CPUs have been installed in a Q series training machine configured for multiple CPU
compatibility.
Parameter setting is required for operation with multiple CPU, although this configuration is
not used in this text.
(1) In GX Works2, double-click "PLC parameter"
in the project list.

(2) The Q parameter setting dialog box appears.
Click the "Multiple CPU setting" tab.

(3) Set "No. of PLC" to "2".
(4) Click the End button.
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3.4 Storing and Managing Programs
Parameters and sequence programs can be stored as a file with a project name.
on the toolbar or select the
S ).
[Project] → [Save] menu ( Ctrl +

(1) Select

If a project has already been saved,
save operation is completed here.

①

Click!

(Only when saving a project for the first time)

(2) Select a storage location for the project.
(3) Set a project name.
(4) Set a title if needed.
(5) When the setting for each item is completed,
click the Save button.

(6) Click the Yes button.
This completes save operation.

(6) Click!

REFERENCE
 Characters such as "%", "'", "*", "/", ":", "<", ">", "?", "\", and "|" are not available. (":" and "\" are available
only when specifying a drive)
Do not use "." (period) at the end of a project name.
 Specify a storage folder path and a project name within 200 single-byte characters (100 double-byte
characters) in total.
 Specify a title within 128 single-byte characters (64 double-byte characters).
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3.5 Writing Data to Programmable Controller CPU
In this section, a sequence program created in Section 3.2 will be written to the
programmable controller CPU.
Connect the personal computer and the programmable controller CPU with a USB
cable.
(1) Write to QCPU No. 1
1)

Set the "RUN/STOP/RESET" switch
to "STOP" in No. 1 and No. 2 QCPU.

2)

Click the "Connection destination" view in the
view selection area of the navigation window.

3)

The connection destination view appears.
Double-click
the
current
connection
"Connection1".

(2) Set to "STOP"!

(To the next page)
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4)

The personal computer side I/F is set to
"USB" by default.
If other means are used in order to connect
to the programmable controller CPU,
double-click an icon that represents each
connection type to change the setting.
In addition, check the connection destination
setting screen to make sure that the target
system is set to "No. 1".

5)

When the setting is completed, click the
OK button.

6)

The memory of the No.1 QCPU must be
formatted.
Select the [Online] → [Operate on the PLC
Memory] → [Format the PLC Memory] menu.
Select either one in "Format type" by
clicking.
In this training, select "Do not create a user
setting system area".
Click the Execute button.
The memory of the programmable controller
CPU is formatted.

7)

8)

9)

Click the Yes button.

10) Click the [Online] → [Write to PLC] menu.

(10) Click!

(To the next page)
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(From the previous page)
11) The online operation dialog box appears.
12) Click the "Parameter + Program" button.
13) Click the Execute button.

14) When the write to QCPU No. 1 is
completed, a dialog box on the left appears.
Click the Close button.
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(2) Write to QCPU No. 2 (not required for single CPU configuration)
Just like No. 1, data such as parameters must be written to QCPU No. 2.
1)

Set the target system to "No. 2" in the
connection destination setting screen.

2)

Just like QCPU No. 1, complete Step 6) to
13) described in (1) of this section for
QCPU No. 2.
 Formatting CPU program memory
 Writing CPU parameters and programs

(To the next page)

3 - 13

3)

When the write to QCPU No. 2 is
completed, a dialog box on the left
appears. Click the Close button.

4)

In the connection destination setting
screen, click "1" in [Multiple CPU Setting]
to select it.

5)

Click the OK button.

6)

(From the previous page)

Push down the "RUN/STOP/RESET" switch
to the "RESET" position once (for about one
second) in QCPU No. 1.
The "ERR." LED flashes several (three to
four) times. (Reset is accepted and in
progress)
Turning off the "ERR." LED means reset
operation is completed.

7)
(6) Perform "RESET"!

Return the RUN/STOP/RESET switch to the
"STOP" position.

REFERENCE
Reset the programmable controller CPU after a
new parameter or a program is written.
Error and device descriptions before writing
must be initialized.
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3.6 Monitoring Operation in Ladder Mode
In this section, operation of the CPU executing the program written to the
programmable controller CPU in Section 3.5 will be monitored using ladder monitor
operation.
Set the "RUN/STOP/RESET" switch of the CPU to
"RUN".
(1) Click!

(monitoring mode) on the toolbar.

1)

Click

2)

The monitor status dialog box appears, and the
ladder monitor is executed.

(a)

Connection status
Connection status to the programmable
controller CPU and simulation function is
displayed.
(b) RUN/STOP state
Operating status of the programmable
controller CPU, triggered by the key
switches of the programmable controller
CPU or a remote operation using GX
Works2, is displayed.
(c) ERR status (PLC diagnostics)
Error status of the programmable controller
CPU is displayed.
The PLC diagnostics screen (*1) appears
by clicking the icon.
(d) USER status (PLC diagnostics)
User error status of the programmable
controller CPU is displayed.
The PLC diagnostics screen (*1) appears
by clicking the icon.
(e) Scan time
Maximum scan time of the monitoring
programmable controller CPU is displayed.
In Q series, it is displayed in unit of 0.1 ms.
*1: For PLC diagnostics, refer to Section 6.2.
The ON and OFF status of the ladder is as
follows.
OFF
ON

*2: The displayed maximum scan time can be
different from an actual value.
(When online program change was carried out,
for example, a displayed value becomes larger
than an actual scan time.)
The actual scan time can be checked using the
program monitor list function (refer to the next
page).
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Training machine operation
1) Turn ON the X2 switch then monitor T1.
2) Check that the timer T1 is reset when the X0 switch turns ON.
REFERENCE
 Program monitor list
A program monitor list can be used with the following steps.
1) Click the [Online] → [Monitor] → [Program Monitor List] menu.
2) The program monitor list appears. Check the actual scan time.

(a) Execution state for each program
Displays execution state for each program.
 Program
: Displays a program name.
 Execution
: Displays a program type.
 Scan time
: Displays an actual scan time (current value).
When a program is in a stop (standby) state,
0.000 ms is displayed as a scan time.
 Number of executions : Displays the number of executions, which is
zero when measurement starts. (It returns to 0
when it reaches 65536.) The number of
executions is retained after a program stops.
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3.7 Entry Ladder Monitor Operation
Multiple relevant ladder blocks can be monitored together by registering a ladder block.
Horizontally tiling ladder monitor screens allows monitoring another ladder while
monitoring the registered ladder all the time.
In this section, a ladder block is registered from the program written to the
programmable controller CPU in Section 3.5 for monitoring.
(1) Select [Online] → [Monitor] → [Entry Ladder
Monitor].

(2) The Entry
displayed.

Ladder

Monitor

screen

is

(3) Click the [Window] → [Tile Horizontally]
menu.

(To the next page)
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(From the previous page)

(4) Select a ladder block in the ladder program
and select [Edit] → [Copy].
(5) Select [Edit] → [Paste] on the Entry Ladder
Monitor screen.
The copied ladder block is pasted.

Set the "RUN/STOP/RESET" switch of the CPU to
"RUN".
on the toolbar or the [Online] →
(6) Select
[Monitor] → [Monitoring Mode] menu.
Monitoring of the registered ladder block is
started.

(6) Click!

(7) The entry ladder screen switches to the
monitoring mode.
(8) Turn ON/OFF X2.
Change of the current value of the timer can
be monitored.

(9) After clicking the title bar on the monitor
screen, scroll the ladder monitor so that
monitoring any step is possible while
monitoring on the entry ladder monitor screen
at the same time.

REFERENCE
The following functions can be executed on the entry ladder screen.
1. Deletion of ladders in increments of ladder blocks 4. Device test
2. Device search, instruction search, and character string search 5. Zoom in and out on screen
3. Displaying comments, statements and notes
6. Drag and drop on the entry data monitor
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3.8 Device Batch Monitor Operation
Monitor device statuses of the program written to the programmable controller CPU in
Section 3.5.
There are two types of device monitors: "Device/Buffer Memory Batch Monitor" and
"Watch Window". In this section, perform "Device/Buffer Memory Batch monitor",
which is monitoring of a specified one type of device.
Set the "RUN/STOP/RESET" switch of the CPU to
"RUN".
(1) Select the [Online] → [Monitor] →
[Device/Buffer Memory Batch] menu.

(2) Click the Reference button and select the TC
setting value reference.

(3) Select "MAIN" and click the OK button.

(4) Input "C0" in Device on the device/buffer
memory batch monitor dialog box and press
key.

(To the next page)
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(From the previous page)

(4) Monitoring of the specified device is started.
(C0 and subsequent devices are displayed)
(5) Perform device batch monitoring of T0 in the
same way. (T0 and subsequent devices are
displayed)

(6) When the screen is tiled horizontally with the
ladder monitor screen, device statuses can
be checked both on the ladder display and in
the list, which facilitates monitoring.
Click the [Window] → [Tile Horizontally]
menu.
REMARKS
Device test operation can forcibly change
device statuses while monitoring devices by
the device/buffer memory batch monitor.
For device test operation, refer to Section
3.10.
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3.9 Entry Data Monitor Operation (Watch Window)
Devices which are not monitored on the ladder monitor screen cannot be directly
monitored.
Monitor them by either "Device/Buffer Memory Batch Monitor" or "Watch Window".
In this section, perform monitoring by "Watch Window", which is for a device registered
by the user.
Set the "RUN/STOP/RESET" switch of the CPU to
"RUN".
(1) Click the [Display] → [Docking Window] →
[Watch (1) To (4)] menu.
* In this training, select (1).

(2) The watch 1 window is displayed. Select the
row to be edited, click the Device/Label field,
and input "Y70".

(3) The input device/label will be registered.

(4) Click the [Online] → [Watch] → [Start
Watching] menu.
The current value of the registered
device/label is displayed on the window.

REMARKS
Device test operation can forcibly change device statuses while monitoring
devices by Device/buffer memory batch monitor.
For device test operation, refer to Section 3.10.
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3.10 Device Test Operation
Debug operation can forcibly turn ON/OFF bit devices (X, Y, M, L, B, and F) or forcibly
change the current values of word devices (D, W, T, C, etc.).
There are two methods of operations. One is double-clicking a device during ladder
monitor and the other is using the device test dialog box.
In this section, perform a device test of the program written to the programmable controller
CPU in Section 3.5.
Set the "RUN/STOP/RESET" switch of the CPU to
"RUN".
Click

(monitoring mode) on the toolbar.

Click!

(1) Operation by double-clicking a device during ladder monitor.
 Turning ON/OFF internal relay M100 or input X1.
Select M100 on the ladder monitor and
double-click it with Shift pressed.
(Alternatively, Shift +
keys)
Select X1 on the ladder monitor and
double-click it with Shift pressed in the
same way.
keys)
(Alternatively, Shift +

Shift + double-click!



Setting the current value of C0 to 990.

(1) Shift + double-click!
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1)

Select C0 on the ladder monitor and
Shift pressed.
double-click it with
(Alternatively,
key)

2)

Select "Word [Signed]" from the "Data Type"
list box.

3)

Input "990" in the "Value" list box.
9
9
0

4)

After finishing the setting, click the Setting
button to change the current value of C0 to
990.

(2) Operation on the Modify Value dialog box
First, follow the procedure below to display the Modify Value dialog box.



1)

Click the [Debug] → [Modify Value] menu.

2)

The Modify Value dialog box is displayed.

Turning ON/OFF output Y75, internal relay M100, or input X1.
1)

Specify the bit device to be turn ON/OFF in
"Device/Label". (in the case of M100)
M

2)
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1

0

0

Turn ON/OFF the specified bit device using
the following buttons.
ON
: Forcibly turns ON the specified bit
device.
OFF
: Forcibly turns OFF the specified
bit device.
Switch ON/OFF : Forcibly inverses
ON/OFF status of the
specified bit device.



Setting the current value of Timer T1 to 100.
1)

Specify the word device (T1) whose value is
going to be changed in the "Device/Label"
list.
T
1

2)

Select "Word [Signed]" from the "Data Type"
list box.

3)

Input "100" in the "Value".
1
0
0

4)

Click the Set button.

POINT
When the programmable controller CPU is in the RUN status, if a coil whose
input signal of output condition is OFF is forcibly turned ON, the output of the coil
turns ON only for a moment because priority is given to the execution of the
program.
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3.11 Online Program Change
Change a program when the programmable controller CPU is in the RUN status.
There are two types of methods for online program change as follows.
 Online change (ladder mode)
 Online change (files)

: Writes only the changed part of the program
: Writes programs and files such as device
comments together.

WARNING

● When data change, program change, or status control is performed from a
personal computer to a running programmable controller, configure an
interlock circuit outside the programmable controller system to ensure that
the entire system will always operate safely.
Furthermore, for the online operations performed from a personal computer
to a programmable controller CPU, predetermine the system’s corrective
actions in case of a communication error caused by poor cable connection,
etc.

CAUTION

● When performing online operations (program change while a programmable
controller CPU is running, forced input/output operation, operating status
changes such as RUN-STOP, and remote control operation) for the running
programmable controller CPU from a personal computer, read the manual
carefully and ensure sufficient safety before operation.
When changing a program while a programmable controller CPU is RUN
(online program change), a problem such as program corruption may occur
depending on operating conditions. Fully understand the precautions
described in this section before use.
POINT
Precautions for online program change
 Parameters and programs on the CPU memory before change and ones on
GX Works2 must match.
 Up to 512 program steps can be written at a time in online program change.
 For details of online program change, refer to Appendix 1.

In this section, perform online change (ladder mode).
Change the setting value of Timer T1 to 100 seconds as follows.
Set the "RUN/STOP" switch of the CPU to "RUN".
(1) Click
toolbar.

(1) Click!

(To the next page)
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(monitor write mode) on the

(From the previous page)
(2) Click the OK button.

(3) Select T0 on the ladder monitor and
double-click it.

(3) Double-click!

(4) Change "K200" to "K1000".

(5) After
the
change,
click
the
[Conversion/Compilation] → [Conversion +
Online Program Change] menu.
(If "Change the optional online change setting
to "Execute online change by Conversion
(+Compilation)" is checked in step 2, online
program change can be executed by the
normal conversion process ([Conversion] →
[Conversion] menu/Function key F4 ).)

(5) Click!

(6) A "Caution" message is displayed. Check
and understand the description and click the
Yes button.

(7) The message "Online program change is
completed" is displayed. Click the OK
button.

CAUTION
If the program on the programmable controller CPU and that on GX Works2
before modification do not match, online program change cannot be executed.
When it is uncertain that they match, conduct verification, make modifications on
GX Works2, and then perform online program change.

3 - 26

Training machine operation
When turning ON X2, T1 is increased to 1000.
Digital HMI (Human Machine Interface)
Y6F

Y60

X3F

0 0

X30

0 0

Y5F

X2F

0

Y50

Y4F

Y40

X20

0 0 0

A/D I NPUT

MELSEC-Q
D/A OUTPUT

POINT
Precautions for using rise, fall, or SCJ instruction
(1) Fall instruction
Even if the execution condition for a fall instruction in an online changed
ladder *1 is not satisfied (in continuity state), the fall instruction is
executed.
For fall instructions, refer to the programming manual of QCPU. The
following are examples of the instructions.
Fall instruction: PLF, LDF, ANDF, ORF, MEF, FCALLP, EFCALLP, and
XCALL
ON/OFF status of contact
(Continuity state at online change)

Rise instruction

Fall instruction

OFF
ON

Not executed
Not executed

Executed
Not executed

*1: When a new ladder block is inserted without changing existing
programs, the added program is written together with the next ladder
block to the programmable controller CPU. (If the next ladder block
does not exist, the previous ladder block is written together.)
Thus online program change may not be completed at a time
depending on the number of program steps of the added program and
the previous or next one. In this case, reduce the number of steps
written at a time and perform online program change in several times.
<Example>
Programs added by pasting
and inserting a row
Programs on the left is also
written to the programmable
controller

(2) Rise instruction
When writing is completed, even if the execution condition for a start-up
execution instruction (PLS instruction / P instruction) is ON, the start-up
execution instruction is not executed.
When the execution condition turns OFF → ON again, the start-up
execution instruction is executed.
(3) SCJ instruction
When writing is completed, if the execution condition for SCJ instruction is
ON, the instruction executes a jump to the specified pointer without
waiting for 1 scan.
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3.12 PLC Verify Operation
Compare and verify programs, parameters, device comments on the programmable
controller CPU with data on GX Works2.
(1) Click the [Online] → [Verify with PLC] menu.

(1) Click!

(2) The Online Data Operation dialog box is
displayed. Click Parameter + Program.
(3) Click the Execute button.

(4) The verification result is displayed.
To check details of data, double-click the
corresponding row.

(5) The detailed result is displayed.
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3.13 Read from PLC Operation
Read programs, parameters, device comments on the programmable controller CPU.
(1) Click
on the toolbar or the [Online] →
[Read from PLC] menu.

(1) Click!

(2) Click to select the program and the parameter to
be read on the "CPU module" tab.
Alternatively, click "Parameter + Program".
Also, select "Program/Device Memory" in
"Target Memory".
(3) After finishing all selections, click Execute .

(4) When the project is already under editing, a
dialog box asks whether to save changes.
Click Yes .

(5) The dialog box showing the read progress is
displayed.
(6) When the read is completed, the message
"Completed" is displayed. Click the
Close button.
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3.14 Termination Operation of GX Works2
(1) Click the [Project] → [Exit] menu.

(1) Click!

(2) A confirmation dialog box is displayed. Click
the Yes button.
GX Works2 is terminated.

The dialog box on the left will appear depending
on the status of the project.
(If the ladder is not converted.)

Yes ·················Exits GX Works2 without
conversion.
No ··················Does not exit GX Works2.

Yes ·················Exits GX Works2
after saving the project.
No ··················Exits GX Works2
without saving the project.
Cancel ·············Does not exit GX Works2.

(If the project is not saved.)
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3.15 New Read from PLC Operation
Newly read programs, parameters, device comments on the programmable controller
CPU.
(1) Click the [Start] button.
(2) Select the [All programs] menu.
(3) Select the [MELSOFT application] menu.
(3) Select!

(5) Click!

(4) Select the [GX Works2] menu.
(5) Click the [GX Works2] menu.

(2) Select!

Creating a shortcut of GX Works2 on the
desktop will facilitate starting up GX
Works2.

(4) Select!

(1) Click!

(6) GX Works2 starts.

(6) GX Works2 starts.

(7) Click the [Online] → [Read from PLC] menu.

(7) Click!

(8) Select "QCPU (Q mode)" from the "PLC" list
box.
(9) Click the OK button.

(To the next page)
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(From the previous page)
(10) Check that settings in Transfer Setup are
as follows.
Personal computer side I/F : Serial (USB)
PLC side I/F
: CPU module
QCPU (Q mode)
Other Station Setting
: No Specification
(11) Click the

OK

button.

(12) Click to select the program and the parameter to
be read on the "CPU module" tab.
Alternatively, click "Parameter + Program".
(13) Click the Execute button.

(14) The dialog box showing the read progress is
displayed.
(15) When the read is completed, the message
"Completed" is displayed. Click the
Close button.

(To the next page)
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(From the previous page)
(16) Click the data read from "No Execution Type"
in the project list to display the sequence
program.
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Chapter 4 Designing Maintenance Measures
It is necessary to consider the maintenance in the design stages in order to achieve a
design that is less susceptible to failure or accidents and is easily maintainable.
4.1 Preliminary Actions to Implement Maintenance Measures
(1) Adopt products with fewer failures
To put it simply, products with high reliability should be used, but the following
points should also be considered.
1) Is the manufacturer reliable?
2) Is it accredited by various national and international standards?
3) Is the design simple?
4) Does the product have good performance with low failure rate?
5) Is the industry reputation good?
(2) System design with good serviceability
The following points may be considered to design a system that can be easily
maintained.
1) Adopt a programmable controller for which the parts and products are easily
available.
2) Adopt a programmable controller having high serviceability with
self-diagnostics function, etc.
3) Adopt a programmable controller in which the programs can be easily read,
changed and stored.
4) Design the system so as to automatically display the defects.
5) Carry out the design in a space in which maintenance, inspection and repair
work can be easily carried out.
6) Design the system such that the parts replacement, product replacement,
wiring change etc. can be carried out easily.
(3) Copying sequence programs into ROM
Running a sequence program stored in program memory is convenient and
facilitates program changes. However, lightning surge noise, power supply failure,
or others can cause loss of the program.
To prevent the trouble, store them in standard ROM or a memory card (ATA/Flash
ROM), which ensures safety.
(4) Backup of sequence programs
Be sure to make backups of sequence programs in hard disk drives or CD-ROMs
so that they can be easily written when the programmable controller fails and
needs restoration.
Describe the day, month and year and details of changes as a comment on a
backup file.
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4.2 Using Programmable Controller with High Serviceability
MELSEC-Q has an excellent RAS function and self-diagnostics function.
4.2.1 RAS Function
RAS function is a generic term for the function improving [product reliability],
[equipment availability] and [serviceability].
Table 4-1 RAS Function
Name
R Reliability

A

Availability

S

Serviceability

Meaning

RAS function (other than self-diagnostics function) of
programmable controller
Because the required quality is realized during the
Reliability of the
design, production and quality assurance phases,
hardware or
system that relates the product is highly reliable and has a low failure
rate
to failures
 A module can be replaced in a single operation
Effectiveness or
 I/O module working during the power-on
availability as
 Sampling trace function
equipment
 Latch function
Ease of service
 Remote PAUSE function
Function improving
 Multiple-user debug function
the availability of
 Monitor function by peripherals
equipment

RAS concepts
If the equipment fails for the first time in five years, R (reliability) can be deemed as
high.
On the other hand, if there is no spare part or it takes long because of a lack of
experience in recovery, S (serviceability) is deemed as low, thus resulting in A
(availability) being poor.
Additionally, if the equipment sometimes fails, but can be recovered in a short time, R
(Reliability) may be low, but S (serviceability) is high, causing A (availability) to be
excellent. RAS function requires the three functions to be high in a balanced manner.
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4.2.2 Self-Diagnostics Function
(1) Self-Detecting the Error Definition of the Programmable Controller
Function that enables the programmable controller CPU to automatically detect an
error occurring in the programmable controller and to turn on the predefined bit
device (bit signal) or to store an error number in the word device (word signal).
Table 4-2 Self-diagnostics Function
Processing
Sample error items that can occur
function
 Self-diagnostic error (indicates the total number of self-diagnostic errors)
Displays the
diagnostics result  Operation error (indicates that an operation error occurred)
by turning ON or  Battery voltage drop (warns that the battery for backing up the memory
has low capacity now)
OFF bit signals
 AC down detection (instantaneous power failure or voltage drop within
the specified instantaneous power failure time)
Special relay
(SM0 to SM1199)  I/O module verification error
(The mounting status of the I/O module differs from that which was
registered during the power-on)
 Watchdog timer error
(Program scan does not complete within the specified time, causing the
operation to hang up)
 Fuse blown detection (detects a fuse blown in the I/O module)
Displays a code  Fuse blown (I/O number of the output module where the fuse was blown)
 I/O module verification error
number for the
(I/O number of a module whose the state differs from the mounted state
diagnostics result
when the power supply was turned on)
using a numerical
value (word data)  Number of AC power supply failures (number of instantaneous power
failures or voltage drops of AC power supply)
 Self-diagnostic error (number of the error when the self-diagnostics
Special register
detects an error)
(SD0 to SD1431)
 Error step (step number of a program that generated an operation error)

1) When a trouble occurs in the programmable controller, trouble contents can
determined by using a peripheral to read the contents of the self diagnostics result.
Take corrective actions according to the contents to shorten the recovery time.
2) In the event an operation unexpectedly stops, etc., the power failure or voltage
drop of AC power supply can be determined to be a cause if AC down detection is
turned on.
3) When contacting the manufacturer, informing them of the self diagnostics result
(error number) would let them locate the cause faster.
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(2) To display the list of error codes in GX Works2
1)

Select the [Help] → [GX Works2 Help] menu.

2)

The GX Works2 help is displayed.

3)

Select "CPU Error Help" and choose your
programmable controller CPU from the Help
menu.
In this case, double-click "Q series PLC (Q
Mode)".

4)

The error code list of the chosen
programmable controller CPU is displayed.
Double-click the error code whose description
you want to check.
In this case, double-click and select [Error
Code 1000 to 1610] → [Error Code 1000 to
1035] → [Error Code 1001 MAIN CPU
DOWN].

5)

The system displays the details such as the
cause and corrective action of the selected
error code.

(1) Click!
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(3) What are special relays and special registers?
These are the devices whose applications are fixed in the programmable
controller.
They are used for error detection, CPU module operating status and special
functions.
(They can be applied or not depending on the CPU type.)
[Sequence program of the application example]
(Battery low)
SM52
SM1
Error
detection

SM56

(1 second clock)
SM412

Y77

(Self-diagnostic error)

Y77 lamp flashing due
to CPU battery low

(Operation error)

SM400 (Always ON)

X7

BCD

SD0

K4Y40

BCD

SD1010

K4Y50

Outputs self-diagnosis error
code to the digital HMI
(Human Machine Interface)
Outputs the step number of
application instruction
operation error to the digital
HMI (Human Machine Interface)

H0210

Day 2 , Hour 10

H4020

Minute 40, Second 20
Clock data set request

Clock
function

X7

Clock data read request

SM400 (Always ON)

Displays year (in 2-digit)
and month
Displays day and hour
Displays minute and second

REMARKS
 If the annunciator of the device for failure detection is turned ON, an error code
"9000" is stored in SD0.
Use a peripheral to read the error individual information and check the program
of the numerical value (annunciator number).
 The error diagnostics information is stored in the following devices:
SD0
: Stores the diagnosed error code using a BIN code.
SD1 to SD3
: Stores the date and time when the SD0 data was updated.
SD4
: Stores the category codes that determine the description of the
error information stored in the common information (SD5 to
SD15) and the individual information (SD16 to SD26).
SD5 to SD15 : Stores the following common information (either of the following
"1)" to "5)") corresponding to the error code (SD0):
1) Module number
4) Program error location
2) File name/drive name
5) Cause of switching
3) Time (setting value)
SD16 to SD26 : Stores the following individual information (either of the
following "1)" to "6)") corresponding to the error individual
information (SD0):
1) File name/drive name
4) Parameter number
2) Time
5) Annunciator number/CHK
(actual measurement value)
instruction failure number
3) Program error location
6) Intelligent function module
parameter error
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(4) To display the list of special relays and special registers in GX Works2
1)

Select the [Help] → [GX Works2 Help] menu.

2)

The GX Works2 help is displayed.

3)

Select "Special Relay/Register Help" and
choose your programmable controller CPU
from the Help menu.
In this case, double-click and select the "Q
series PLC (Q Mode)" menu.

4)

The system displays the error code list of the
special relays and special registers for the
chosen programmable controller CPU.
Double-click and select the device whose
description required you want to check.
In this case, double-click and select the
[Special Relay (diagnostics information)
[Number SM0 to SM165]] → [Number SM0 to
16] → [Number SM0 Diagnostic errors].

5)

The system displays the detail of the selected
special relay device.

(1) Click!
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4.3 Safety Design Using a Fail-safe Circuit

WARNING

● Configure a safety circuit outside the programmable controller so
that the entire system can operate safely even when an external
power supply error or a programmable controller failure occurs.
Failure to do so may cause an incorrect output or malfunction,
resulting in accidents.
(1) Configure safety circuits such as an emergency stop circuit,
protection circuit, interlock circuit for opposite operations such
as forward/reverse rotations or interlock circuit for machine
damage protection such as upper/lower limits for positioning
outside the programmable controller.
(2) When the programmable controller detects the following error
status, it will stop operations and turn OFF all outputs in the
case of (a).
In the case of (b), it will hold or turn OFF all outputs according
to the parameter setting. Note that the AnS series module will
turn OFF the output in either case (a) or (b).

(a) When overcurrent protection or
overvoltage protection of the
power supply module works
(b) When the programmable controller
CPU detects a watchdog timer
error and the like in the
self-diagnostics function

Q series modules

AnS series modules

Output OFF

Output OFF

All outputs will be
retained or OFF,
depending on
parameter setting

Output OFF

When an error occurs at the I/O control part where the
programmable controller CPU cannot detect, all outputs can
be turned ON. Configure a fail-safe circuit or some
mechanism outside the programmable controller so that the
machine operates safely in such a case.
(3) Outputs may remain ON or OFF due to a failure of an output
module relay or transistor. Configure an external circuit for
monitoring output signals that may lead to a serious accident.
● Configure a safety circuit such as a fuse outside the output
module because smoke or fire may result if a load current
exceeding the rated current or an overcurrent caused by load
short flows continuously for a long time.
● Configure a circuit so that an external power supply will be turned
on after the start-up of the programmable controller. If the external
power supply is turned on first, an incorrect output or malfunction
may occur, resulting in accidents.
● For the operating status of each station during data link
communication error, refer to each data link manual. Failure to do
so may cause an incorrect output or malfunction, resulting in
accidents.
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WARNING

● When controlling (changing data) the running programmable
controller from a peripheral connected to the CPU module or from
a personal computer connected to an intelligent function module,
configure an interlock circuit in the sequence program to ensure
that the entire system will always operate safely.
For other operations (program modification, operating status
change (status control)) to the running programmable controller,
read relevant manuals carefully and ensure the safety before
operation.
Ensure the safety especially when controlling the remote
programmable controller from eternal devices because trouble
occurred on the programmable controller side may not be
responded immediately due to data communication error.
Along with configuring an interlock circuit in a sequence program,
determine the system’s corrective actions to be taken between
external devices and the programmable controller CPU in case of
a data communication error.

CAUTION

● Do not bundle or adjacently place the control line or a
communication cable with the main circuit or a power cable.
Keep a distance of approximately 100 mm or more between them.
Failure to do so may cause malfunction due to noise.
● When a device such as a lamp load, heater, or solenoid valve is
controlled through an output module, a large current
(approximately 10 times greater than normal) may flow when the
output is turned OFF → ON. Take measures such as replacing the
module with one having a sufficient current rating.

Incorrect process outputs may occur temporarily due to a delay time and difference in
rise time between the power supply to the programmable controller and the external
power supply to the process (especially in DC) when the programmable controller is
turned ON → OFF.
For example, if the power supply to the programmable controller is turned on after the
external power supply to the DC output module process is turned on, the DC output
module may output instantaneously by mistake when the programmable controller is
turned on. Therefore, it is necessary to configure a circuit so that the power is supplied
to the programmable controller first.
In addition, faulty operations may occur at the time of external power supply failure or
programmable controller failure.
Configure safety circuits (emergency stop circuit, protection circuit, interlock circuit, etc.)
that may lead to machine damage or accidents due to faulty operations outside the
programmable controller to prevent faulty operations from causing the entire system to
operate faulty or from the fail safe aspect.
The following page shows a system design circuit example based on points above.
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(1) System design circuit example (when the contact of the power supply moduleERR
is not used)
Power supply

For AC

For AC/DC

Power supply
Transformer

Transformer

CPU module
SM52
SM403

Fuse

DC current
establishment
signal input

Fuse

Yn

CPU module

Can be started by
turning ON RA1, which
is the RUN output of
the programmable
controller

Yn
TM
TM
NO

Input module

Start up SW

MC1 NO M10

M10
Program
RA1

MC Stop SW

Ym
L
Yn
RA1

Alarm output
(Lamp or buzzer)

RA2

XM

ON during RUN due
to SM403

Ym

RA1

MC1

MC1
MC2

ON during RUN
due to SM403

L
Yn

Emergency stop or
stop at upper limit

MC2

A voltage relay is
recommended.

Alarm output
(Lamp or buzzer)

Output module
Power-off output
equipment when stops

MC

MC

RA2

MC

Output module

Fuse
The time until DC
input signal is
established shall
be set to TM.

XM

MC

Output module

( -)( +)

SM403

RA1

MC Stop SW

DC power
supply

Ym

Program
Start up SW

Fuse

SM52

Start/stop circuit
Ym

Transformer

Output module

MC

Interlock circuit

MC
Power-off output
equipment when stops

Configure an external
interlock circuit in a part
where opposite actions
such as forward/reverse
rotation is performed or
where damage or an
accident may occur.

MC2
MC1

Emergency stop or
stop at upper limit

MC1
MC2

Start up the power supply in the following procedure:
For AC

For AC/DC

[1]
[2]
[3]
[4]

Turn "ON" the power.
"RUN" CPU.
Turn "ON" RA2 after the DC power supply on.
Turn "ON" the timer (TM) after the DC power supply is
completely on. (The setting value of the TM shall be
the time between turning "ON" RA2 and the full
establishment of the DC voltage. Configure the setting
value to 0.5 second.)
[5] Turn "ON" the start-up SW.
[6] Turn "ON" the electromagnetic contactor (MC) to drive
the output equipment with a program. (If a voltage relay
is used for RA2, the timer (TM) in the program is not
required.)

Turn "ON" the power.
[1]
"RUN" CPU.
[2]
Turn "ON" the start-up SW.
[3]
Turn "ON" the electromagnetic contactor (MC) to drive the [4]
output equipment with a program.
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(2) System design circuit example (when the contact of the power supply moduleERR
is used)
Power supply

For AC/DC

Transformer Transformer

Fuse

DC current
establishment

Fuse

CPU module
DC power
supply

SM52

Start/stop circuit

Ym

Can be started by
turning ON RA1, which
is the RUN output of the
programmable
controller

( -)( +)

SM403
Yn
XM

NO
Start up
SW
MC

Fuse
The time until DC input
signal is established
shall be set to TM.

TM

TM
MC1 NO M10

M10
Program
RA1 RA3

MC

Stop SW

RA2

RA2

XM

A voltage relay is
recommended.

Output module
Ym

Alarm output
(Lamp or buzzer)

L

Yn
RA1

Power supply module

RA3

Output module

MC

Interlock circuit
Configure an external
interlock circuit in a
part where opposite
actions such as
forward/reverse
rotation is performed
or where damage or
an accident may occur.

OFF when a stop error
occurs due to ERR

ERR

MC2
MC1

MC
Power-off output
equipment when the
ERR contact OFF
Emergency stop or
stop at upper limit

MC1
MC2

Start up the power supply in the following procedure:
For AC/DC
[1]
[2]
[3]
[4]

Turn "ON" the power.
"RUN" CPU.
Turn "ON" RA2 after the DC power supply on.
Turn "ON" the timer (TM) after the DC power supply is completely on. (The
setting value of the TM shall be the time between turning "ON" RA2 and the
full establishment of the DC voltage. Configure the setting value to 0.5
second.)
[5] Turn "ON" the start-up SW.
[6] Turn "ON" the electromagnetic contactor (MC) to drive the output
equipment with a program. (If a voltage relay is used for RA2, the timer
(TM) in the program is not required.)
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(2) Fail safe measure against programmable controller failures
Although failures of the programmable controller CPU and memory are detected
by the self-diagnostics function, a failure may not be detected depending on the
CPU when an error occurs at the I/O control part. etc.
In such cases, depending on the failure status, it is expected that all outputs are
turned ON or OFF or that the proper operations or safety of the controlled
systems cannot be secured.
Although Mitsubishi assures the best quality products, configure a fail-safe circuit
outside in order to prevent machine damage and accidents when the
programmable controller fails for some reason.
The following illustrates a sample system and its fail safe circuit example:
<Sample system>
Power

CPU

supply
module module

Output
Power Output Output Output 16 points
supply
Y80 Empty
module

Input Input Input Input Output
16 points 16 points 16 points 16 points 16 points

16 points 16 points 16 points

Y8F

Fail safe output
module*1

*1: Mount the output module for fail safe in the last slot of the system. (For
the above system, the last slot shall contain Y80 to Y8F.)
<Sample fail-safe circuit>
On delay timer
Internal program

T1

Y80

1s

On delay timer

SM412
Y80

T2

Y80

Ｌ

Y8F

0. 5 s 0. 5 s

24V

0V
CPU module

1s

MC

External load
Ｌ

Y81

*2

24 V DC

Output module
*1

T1

T2

MC

Figure 4-3 Sample fail-safe circuit 1
*1

Since Y80 is repeatedly turned ON and OFF every 0.5 second, use an output
module (transistor in the example above) with no contact.

*2

If off delay timers (especially, miniature timer) are difficult to obtain, use on delay
timers as shown in the next page to configure a fail-safe circuit.
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When configuring a fail-safe circuit using only delay timers
On delay timer
Internal program

T1

Y80

*1

SM412

1s

M1

Y80
On delay timer

M1

T2

1s

M1

M2
M2

T2

Y80

0. 5 s 0. 5 s

External load
Ｌ

Y81

Y8F

MC

Ｌ

24V

0V
CPU module

24 V DC

Output module
T1

M2

MC

Figure 4-4 Sample Fail-safe Circuit 2
*1

Use a solid state relay for the M1 relay.
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Chapter 5 Preventive Maintenance
Preventive maintenance consists of daily maintenance and inspection and periodic
maintenance and inspection.
5.1 Necessity of Preventive Maintenance
High availability of equipment cannot be ensured from occurrence of production
system failure to its repair.
Because preventing failures and equipment stop are top priorities, if reliable preventive
maintenance is performed, prevention of catastrophic failures becomes possible, and
recovery from failures will be quick.

5
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5.2 Daily Maintenance and Inspection
The following table shows items to be inspected daily to find risks in a production
system in advance.
Table 5-1 Daily Maintenance and Inspection

1

2

3

4

Inspection item

Inspection content
Check that mounting
Mounting condition of screws are not
loosened and the
base unit
cover is not detached.
Check that the
modules are not likely
Mounting conditions of
to come off and
I/O modules, etc.
module fixing hooks
are surely locked.
Looseness of terminal
screws
Proximity of solderless
Connection status
terminals
Connector parts of
cables

Main indicator lamp

Item

Power supply
"POWER" LED

Check if it is ON

CPU
"RUN" LED

Check if it is ON in
"RUN" state

CPU
"ERR." LED

Check if it is OFF

CPU
"BAT." LED

Check if it is OFF

Input module
Input status
indicator LED

Check whether it is
ON or OFF.

Output module
Output status
indicator LED

Check whether it is
ON or OFF.

Criterion
They must certainly
be fixed.

Condensation

of water droplet and
moisture.
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Drive the screws in
tight again.

The module fixing
Be sure to lock the
hooks shall be surely
module fixing hooks.
locked and fixed.
They must not be
loosened.
They must be at an
appropriate interval.
The connectors shall
not be loosened.
ON
(The LED is faulty if is
OFF)
ON
(The LED is faulty if is
OFF)
OFF
The LED is faulty if is
ON or flashing
OFF
(The LED is faulty if is
ON)
ON when input is ON.
OFF when input is
OFF.
(The LED is faulty if it
is in a state other than
above)
ON when output is
ON.
OFF when output is
OFF.
(The LED is faulty if it
is in a state other than
above)

Check the presence
5

Corrective action

Not allowed.

Drive them in tight
again.
Correct the interval.
Drive connector fixing
screws in tight again.
Refer to Section 6.4

Refer to section 6.5

Refer to Sections 6.6
and 6.7

Remove the
condensation.

5.3 Regular Maintenance and Inspection
The following table shows items to be inspected once or twice a year to find risks in a
production system in advance.
Table 5-2 Regular Maintenance and Inspection

3

4

Atmosphere

Power supply voltage
check

Mounting condition

2

Inspection item
Ambient
temperature
Ambient humidity

Connection status

1

Environment

Item

Inspection method
Measure using
thermo-hygrometers.
Measure corrosive
gases.
100/200 V AC, 24 V
DC, Measure voltage
between terminals

Criterion
0 to 55°C
5 to 95%RH *1
No corrosive gases

Corrective action
If a module is used
inside a panel, the
in-panel temperature
must meet the criterion
for the ambient
temperature.

85 to 132 V AC
170 to 264 V AC

Change the supply
power.

15.6 to 31.2 V DC

Looseness and
play

Move the modules.

They must firmly be
fixed.

Drive the screws in tight
again.
If the CPU module, the
I/O module, or the
power supply module is
loosened, fix it with
screws.

Adhesion of dirt
and foreign
matters

Visual inspection

There must be no
adhesion of them.

Remove and clean

Looseness of
terminal screws

Retightening the
screws using a
screwdriver

They must not be
loosened.

Drive the screws in tight
again.

Visual inspection

They must be at an
appropriate interval.

Correct the interval.

Visual inspection

They must not be
loosened.

Proximity of
solderless
terminals
Looseness of
connectors

5

Battery

Check that SM51 or
(preventive
SM52 is OFF in the
monitoring mode of GX maintenance)
Works2.

6

Fuse

Check that they are
not blown with a blown
fuse indicator LED.

7

Spare parts

8

Checking stored
programs

9

Fan (heat exchanger)
filter

10

Analog input/output

Attach them to the
actual module and
check the operation.
Compare with the
current programs.
Rotation status
Rotation sound
Clogging
Checking the
offset/gain values

(preventive
maintenance)

They must work as the
specifications.
Must be the same.
It must rotate without
abnormal sound and
not be clogged.
Are they the same as
the specifications
(designed values)?

Drive connector fixing
screws in tight again.
Replace a battery of
which specified life is
exceeded even if there
is no indication of low
battery capacity.
Periodically replace
them even if they are
not blown because the
elements are
consumed by inrush
current.
Use the parts that
attached to the actual
module as spare parts.
Correct if they are not
the same.
Clean or replace it if
there is a problem.
Correct if they are not
the same.

*1: 10 to 90% RH when a module for AnS series is used for the system.
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5.4 Condition Monitoring-based Maintenance
This design achieves maintenance in response to errors and failures by externally
monitoring the condition of production system all the time and immediately reporting
the occurrence of errors and failures.
The following are examples of condition monitoring.
(1) Example of external display of error code numbers
Connect a digital HMI (Human Machine Interface) to output modules of the
programmable controller to display a code number on the HMI (Human Machine
Interface) when an error code is detected.

Output module (Y70 to Y8F)

Fault indicator lamp
Error code

0

0

Error code

3

2

Control panel

SM1
(Error detection)

BCD
SD0
K2Y70
(Error code)
Y80

Displays an error code number
on the digital indicator when an
error is detected

Turns on the fault indicator
lamp when an error is detected

(2) Example of displaying error code numbers on GOT screen
Error report messages and error code numbers are displayed on a liquid crystal
screen externally connected to the programmable controller.
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5.5 Checking Operating Environment
When equipment is changed, modified, added, or replaced, the following items must
be checked because the usage environment may change.
Table 5-3 Operating Environment
Checkpoint

Check timing

Power supply voltage,
voltage drop,
instantaneous power failure, When equipment is changed (especially when equipment which
frequency fluctuation,

has large power consumption is installed)

waveform distortion, and
harmonics
Noise and surge levels

When high frequency equipment, large current equipment, or
equipment which generates high noise is installed or connected

Temperature

When the environment changes

Humidity

When the environment changes

Vibration and shock

When equipment which generates them is installed
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Chapter 6: Corrective Maintenance
Electronic devices such as a programmable controller have fewer consumable parts
and those to be deteriorated. However, it does not mean that troubles caused by
failures and accidents can always be prevented even if preventive maintenance is
not performed. When an unexpected reason causes failure and a production system
stops, corrective maintenance will be performed.
There are four types of troubles, and it is necessary to identify causes and take actions
quickly.
Table 6-1: Trouble Types
Trouble type
Hardware failure
Malfunction of a
programmable
controller system
Trouble due to an
accident
Fault of a sequence
program

Description
Error status continues due to reasons such as electronic component
failure and pattern disconnection in a module circuit board. Repairing
or replacing with a good one will fix it.
Error in CPU operation or input/output occurs due to causes such as
noise, surge, voltage drop, instantaneous power failure, external radio
wave, and static electricity. Identifying the cause and taking measures
will restore it.
Due to an accident such as power supply short, load short, disconnection
of signal wire, and faulty operation of a programmable controller main unit
or peripherals. Repairing will restore it.
Due to reasons such as incorrect interlock setting and device number
error. Revising it to a correct program will fix it.

POINT
For the life and preventive maintenance of a programmable controller CPU or a
module, refer to Mitsubishi programmable controller TECHNICAL BULLETIN
"MELSEC A/Q series, preventive maintenance of a programmable controller"
(PLC-D-434).
The TECHNICAL BULLETIN described above can be found at the Mitsubishi
Electric FA Global Website.
(Mitsubishi Electric FA Global Website:
http://www.mitsubishielectric.co.jp/fa/index.html)
6.1 Important Points in Corrective Maintenance
In corrective maintenance, error is discovered by troubleshooting, and then its cause
is identified and repaired. The important points and advance preparations of the
corrective maintenance are described below.
(1) Important points
1) Read error codes self-detected by the programmable controller or each module.
If the error code is identified, the cause can be estimated from the list of error codes.
2) Understand the real cause of the failure.
Assume it was restored normally after replacing the module suspected to be
the cause with a good one. To determine whether the module is the real
cause or not, put it back to the previous state. If the trouble occurs again, the
executed action is confirmed to be correct.
In the case that the trouble does not occur, however, the module before the
replacement was good and the real cause lies somewhere else.
3) Save the status when the error occurs.
With GX Works2, the status can be read and stored to a personal computer
when an error occurs.
The cause of the error can be analyzed later using the stored information.
The following information can be read:
• Device
• Buffer memory
• System configuration
• Link memory
4) Minimize the stop time of the production system.
Long stop time results in larger production loss and bad serviceability.
5) Resume operation carefully while restoration.
When the operation is resumed, it is necessary to provide sufficient safety
confirmation in order to prevent accidents.
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(2) Advance preparation
1) Understand the target equipment and machines well.
Receiving enough explanations during test operation and reading manuals
for deeper understanding is important.
2) Get to know well about the programmable controller and the related equipment.
It is important to improve product knowledge on a regular basis, for example,
attending manufacturer's training school.
(For information about a programmable controller, refer to the Mitsubishi
Electric FA Global Website.
(http://www.mitsubishielectric.co.jp/fa/index.html))
3) Get used to peripheral operation.
It is important to get used to peripheral operation on a regular basis, for
example, attending manufacturer's training school.
4) Understand the status immediately before the accident.
It is important to carry out periodic inspection frequently in order to always
understand the operating status of the target equipment and machines.
5) Understand the causes and measures well.
It is important to learn background information in advance, for example, reading
the "Causes and measures" of instruction manuals and attending
manufacturer's training school.
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6.2 Operation to Read Error Codes Using GX Works2
Current error status or error history can be displayed using the PLC diagnostic
function and the system monitor of GX Works2.
In this example, an error is raised intentionally so that an operation to find the cause
can be performed using GX Works2.
(1) PLC diagnostics function
This function monitors the error status of the CPU.
(Actual machine operation)
Side of the CPU module

Front

Battery

1)

Power-off the programmable controller
CPU and open the battery holder.

2)

Disconnect the battery connector.

3)

Close the battery holder and power-on
the programmable controller CPU.

4)

Click the [Diagnostics]
Diagnostics] menu.

5)

The PLC diagnostics dialog box is
displayed.
Make sure that "1600 BATTERY
ERROR" is displayed in the Current
Error.

6)

Click the

Battery holder

Battery connector

→

[PLC

(5) Click!

Error Help

button.

Error details are displayed. Operate as
described in Section 4.2.2 in order to
check the error description of the error
code 1600.

6-3

POINT
When a current error is double-clicked in the error display area, the content of SD5
to 15 (common error information) and SD16 to 26 (error individual information) of
the programmable controller CPU is displayed in the error details dialog box.
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(2) System monitor
The error status of the entire system can be monitored.
Errors diagnosed by the module are displayed as well as ones diagnosed by the
CPU.
(a) Writing a test project
To raise an error in the D/A converter module (Q62DAN), open the
following project and write it to the CPU.
Project name

System monitor

CH1 enabled, CH2 disabled setting

Operating condition setting completed

CH1 output enabled

CH1 DA conversion data writing

(b) Error confirmation
Operate the training machine to raise an error.
1) Turn ON X2.
2) Set "9999" in the digital switch (X20 to X2F) and turn ON X3.
3) The ERROR lamp of the Q62DAN turns on.
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(c) Launching the system monitor
1)

Click the [Diagnostics]
Monitor] menu.

→

[System

2)

The system monitor screen is displayed.
The system status is displayed as
follows:

(1) Click!

a)
b)

c)

(To the next page)
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Base information list:
The status of each base unit/block is
displayed.
Module information list:
The module information on the
base unit or in the block to which
the selected module is attached is
displayed.
Legend:
The legend of screen icons is
displayed.

3)

Select the Q62DAN.

4)

Click the detailed information button.

(From the previous page)

5)

The module detailed information screen
is displayed.
This shows the information on
"Q62DAN".

6)

On the "Error Information", check the
error code that has been occurred.
On the module detailed information
screen, the error code stored in the
buffer memory address of the D/A
converter module is displayed.
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7)

Set the "Display Format" of the error
code to "Decimal".

8)

Click the error history update button to
display the "Error description/handling".

REMARKS
The system monitor allows the following system statuses can be monitored:

1)

The error status of the module is displayed with icons.
The legend of icons can be found here.

2)

Diagnostics button
The status and the setup content of
the module indicated by the cursor
can be changed.
This will not be displayed if the
utility package has not been
installed.
For the detailed description, refer to
each utility manual.

3)

Product Information List button
The product information list of the
module installed on the base is
displayed.
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(3) Diagnosing network status
GX Works2 can diagnose the network module and the line status of the network.
The list of the network diagnostic functions is described below.
Network type

Function list
1) Network diagnostics
Click the [Diagnostics] → [CC IE Control Diagnostics]/[CC IE Field Diagnostics]/[MELSECNET Diagnostics]
menu to display.
This provides the network status of MELSECNET/10, MELSECNET/H, and CC-Link IE, as well as the
execution of various tests.
<CC IE control diagnostics>

MELSECNET/10
MELSECNET/H
CC-Link IE

 Module change
Changes the module to be diagnosed.
 Selected station change
Click this after inputting a station number to the
"Selected Station" so that the selected station is
changed to the station specified by the number.
The status of the selected station is displayed in the
"Display field of network device status on the
selected station".
 Previous screen ▲/Next screen ▼
Switches the network information screen when the
total number of stations is 61 or more.
 Communication test
Checks the communication route from the
connection station to the communication
destination specified station.
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 IP communication test (available for universal model
only)
Checks the IP communication route from the
connection station to the communication destination
station.
 Link start/stop
Starts/stops data link for the specified station.
 Logging
Monitors the communication route switching
information and the transient transmission errors of
the connection station. The monitored information
can be saved in a file.
 System monitor
Checks the system status of the selected station.
 Remote operation
Performs remote operation for the programmable
controller CPU of the selected station.

Network type

Function list
<CC IE field diagnostics>

MELSECNET/10
MELSECNET/H
CC-Link IE

 Module change
Changes the module to be diagnosed.
 Disconnected station deletion
Deletes disconnected stations from the network map.
 Legend display
Displays the legend of icons on the diagnostics
screen.
 Communication test
Checks the communication route from the connection
station to the communication destination specified
station.
 IP communication test (available for universal model
only)
Checks the IP communication route from the
connection station to the communication destination
station.
 Cable test
Tests the connection status of the cable.
 Link start/stop
Starts/stops data link for the specified station.
<MELSECNET diagnostics>

 Network event history
Displays the event history and various network
information that occur on the host station or the
network.
 Temporary clear/cancel of a reserved station
Clears/cancels a reserved station temporarily.
 Temporary error invalid station setting/clear
Sets/cancels a temporary error invalid station.
 System monitor
Checks the system status of the selected station.
 System error history
Checks the system status of the selected station.
 Remote operation
Performs remote operation for the programmable
controller CPU of the selected station.

 Network test
Tests link status, starting/stopping a link for the
network.
 Loop test
Checks network loop status.
 Setup confirmation test
Checks the setup contents of the station number, the
network number, and the group number of each
station.
 Station order setting test
Checks the forward/reverse loop station order of the
network.

 Communication test
Performs communication test between networks.
 Error history monitor
Displays error history of the network.
 Network monitor details
Displays detailed network line status of the
network.
 Other station information
Monitors other stations connected to the network.
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Network type

Function list
2) CC-Link/CC-Link/LT diagnostics
Click the [Diagnostics] → [CC-Link/CC-Link/LT Diagnostics] menu to display.
This function monitors the network information of each station, as well as diagnoses and tests the network
status.
The CC-Link and CC-Link/LT diagnostic function can be executed only when the programmable controller
CPU is directly connected.

CC-Link

 Other station monitor
 Network test
Monitors CC-Link's other station line connected to
Starts/stops data link for a CC-Link module specified
the programmable controller CPU.
by target module specification (all stations
This function can be executed only during data link.
specification).
 Line test
Performs a test with all stations specification or of a
specified station.
This function is effective only when a master station
is specified in transfer setup.
3) Ethernet diagnostics
Click the [Diagnostics] → [Ethernet Diagnostics] menu to display.
It checks the various setting status of the Ethernet module.

Ethernet
 Parameter status

Monitors the parameter status of the
Ethernet module.
 Error history
Monitors the error log area.
 ・Status for each connection
Monitors status for each connection.
 Status for each protocol
Monitors status for each protocol.
 LED status

Monitors the LED lighting status in front
of the Ethernet module.
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 Received e-mail information
Monitors received e-mail information.
 Sent e-mail information
Monitors sent e-mail information.
 PING test

Tests and checks the existence of a
specified IP address or an Ethernet
module on the Ethernet line whose initial
processing has ended.
 Loopback test

Checks whether each module has
ended initial processing or not,
sequentially sending loopback test
transmission to the Q-compatible E71
whose network number and station
number are specified.

6.3 Basic Practice of Troubleshooting
The following items are the basic contents that must be kept in mind during
troubleshooting.
(1) Visual check
1) Determine whether the cause of the trouble lies inside of the programmable
controller or lies in an external controlled system.
(Note that usually this cannot be determined only by visual check.)
2) Watch the operating status of the machine, and take notes of it.
 In which process of the controlled system does the trouble occur?
 Is the controlled system in operation or stopped?
 What is the type of the stop? Is that overrunning, disorder, fire, human
error, or other types?
3) Watch the I/O module and the intelligent function module, and take notes of
their status.
 How is the wiring status of each module?
 How is the setting switch status of each module?
4) Watch the LED status of each module, and take notes of it.
 Is the "POWER" LED of the power supply module on or off?





Is the "MODE" LED of the CPU module on, off, or flashing?
Is the "RUN" LED of the CPU module on, off, or flashing?
Is the "ERR." LED of the CPU module on, off, or flashing?
Are the "USER", "BAT.", and "BOOT" LEDs of the CPU module on or
off?

 Is the monitor LED of the I/O module on or off?
 Is the monitor LED of the intelligent function module on or off?
(2) Checking an error number by reading the error code
1) Read the error code of the CPU and the error code of each module using GX
Works2.
2) Use the error code that was read in order to check the cause of the error and
the corrective action.
(3) Observation of the fault after resetting the CPU
If it goes back to the normal operation after resetting the CPU, the cause may be
noise or temporary fault in the CPU, I/O module, electrical connection part,
external devices, etc.
1) Set the RUN/STOP/RESET switch to [STOP].
2) Reset using the RUN/STOP/RESET switch.
3) Turn the power OFF and ON again.
(4) Troubleshooting for each module
1) Troubleshoot the power supply module.
2) Troubleshoot the CPU module.
3) Troubleshoot the input module.
4) Troubleshoot the output module.
5) Troubleshoot the intelligent function module.
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(5) Narrowing the range of the failure cause
1) Replace the programmable controller module with a spare module to check
whether the trouble occurs again.
2) Disconnect a ground cable and a control line for a test.
(6) Fault investigation for the failure module
1) Take notes of the product's serial number and function version.
The serial number and the function version can be checked on the rating
plate or in the system monitor of GX Works2.
 Check by the rating plate

-Q
MODEL
Serial number

SERIAL 05032 0000000000 C

Function version

80M1 IND. CONT. EQ.
MADE IN JAPAN

 Check by the system monitor (product information list) of GX Works2
Display the system monitor screen using the [Diagnostics] - [System
Monitor] menu, then click the product information list button to display the
product information list.
The serial number and the function version of the CPU or the intelligent
function module can be checked on the product information list.

Clicking the CSV file creation button shows the [Save as] screen. Specify a file
name here.
The file can be opened using software such as Excel.
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2) Save the device status during an error.
Read the status of the device, link memory, and buffer memory during an
error from the programmable controller CPU and save them.
 Procedure for reading device status using GX Works2 (read from PLC)
Click the [Online] - [Read from PLC] menu, and read the device status on
the read from PLC screen.

3) Fill out a [Programmable Controller Fault Investigation Report] (refer to
Appendix 6), and send the faulty module to the manufacturer with the report
to have them investigate the cause of the failure.
(The programmable controller fault investigation report is in Appendix. Copy
and use it.)
4) Carry out sufficient measures for investigation results returned from the
manufacturer.
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6.4 Troubleshooting for the Power Supply Module
There are two types of troubles regarding the power supply module: a case in which
a type of the power supply module was selected incorrectly, and a case in which the
POWER LED does not turn on.
Power
supply
Q61P

5 V DC output
current
6A

Q62P

3A

Q63P

6A

Main base
Q33B

5 V DC current
consumption
0.105 A
*1

Q64PN

8.5 A

Q35B

0.110 A (0.074 A)

Q61SP

2A

Q38B
Q312B
Q32SB

0.114 A (0.077 A)*1
0.121 A (0.087 A)*1

Q33SB
Q35SB

0.086 A
0.091 A

CPU
Q00UJCPU
Q00UCPU,
Q01UCPU
Q02UCPU
Q03UD(E)CPU
Q04UD(E)HCPU
Q06UD(E)HCPU
Q13UD(E)HCPU

5 V DC current
consumption
0.37 A
0.33 A
0.23 A
0.33 A

0.39 A

Q20UD(E)HCPU
CPU (power supply integrated type)
Q00JCPU

0.22 A*2

Extension base (power supply module unmountable)

Q26UD(E)HCPU

Q52B

0.080 A

Q50UDEHCPU

Q55B

0.100 A

Q100UDEHCPU

Extension base (power supply module mountable)
Q63B
Q65B
Q68B
Q612B
For
QA1S65B
and
QA1S68B

0.105 A
0.110 A (0.081 A)*1
0.114 A (0.087 A)*1
0.121 A (0.098 A)*1

Input module
QX10
QX28
QX40
QX40-S1

5 V DC rated

QX41

output current

QX41-S1

A1S61PN

5A

A1S62PN

3A

A1S63P

5A

0.50 A

0.05 A
0.06 A
0.075 A

Extension base (power supply module
mountable, AnS series)
For mounting an input, output, and special
function module
QA1S65B
0.117 A (0.088 A)*1
QA1S68B

0.118 A (0.091 A)*1

For an AnS series input, output, and special
function module available for the QCPU, refer
to the user's manual of each CPU.

QX42

0.09 A

QX42-S1
QX70

0.055 A

QX71

0.07 A

QX72

0.085 A

QX80

0.05 A

QX81

0.075 A

QX82
QX82-S1

*1: Values for a non CE compatible product are given in ( ).

0.09 A

Output module

*2: Total value of the CPU and the base unit.

QY10
QY18A
QY22
QY40P
QY41P
QY42P
QY50
QY68A
QY70
QY71
QY80
QY81P

0.43 A
0.24 A
0.25 A
0.065 A
0.105 A
0.15 A
0.08 A
0.11 A
0.095 A
0.15 A
0.08 A
0.095 A

I/O combined module
QH42P
QX48Y57

0.13 A
0.08 A

Interrupt module
QI60
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0.06 A

6.4.1 Selection of a Power Supply Module
If 5 V DC supply capacity is insufficient because the power supply module was
selected incorrectly, devices such as an I/O module and an intelligent function
module may malfunction.
Therefore, it is necessary to select a power supply module whose output current is
larger than the total current consumption of connected modules.
(1) 5 V DC current consumption of major modules

A/D conversion

D/A conversion

Temperature input

Temperature control

High-speed counter
Pulse input

Positioning

Q64AD
Q68ADV
Q68ADI
Q64AD-GH
Q62AD-DGH
Q62DA
Q64DA
Q68DAV
Q68DAI
Q62DA-FG
Q64TDV-GH
Q64TD
Q64RD

Intelligent function module
0.63 A
ID interface
0.64 A
Web server
0.89 A
Ethernet
0.22 A
0.33 A
0.34 A
0.39 A
0.38 A
MELSECNET/H
0.37 A

QD35ID1
0.40 A
QD35ID2
0.42 A
QJ71WS96
0.65 A
QJ71E71-B5
0.50 A
*1
QJ71E71-B2
0.60 A
QJ71E71-100
0.50 A
QJ71BR11
0.75 A
QJ71LP21-25
0.55 A
QJ71LP21G
QJ72BR15
1.10 A
QJ72LP25-25
0.89 A
QJ72LP25G
QJ71FL71-F01
0.50 A
FL-net
QJ71FL71-B2-F0
0.70 A
1
CC-Link
QJ61BT11
0.46 A
CC-Link/LT
QJ61CL12
0.13 A
AS-i
QJ71AS92
0.40 A
Serial
QJ71C24N
0.31 A
communication
QJ71C24N-R2
0.26 A
Modem I/F
QJ71CMO
0.46 A
Intelligent
QD51
0.26 A
communication
QD51-R24
0.31 A
*1: For internal current consumption (5VDC) whose the first
five digits of the serial number are 04091 or earlier,
internal current consumption (5 V DC) is 0.70 A.

0.50 A
0.60 A

Q64RD-G

0.62 A

Q64TCTT
Q64TCTTBW
Q64TCRT
Q64TCRTBW
QD62
QD62D
QD62E
QD60P8-G

0.55 A
0.60 A
0.55 A
0.60 A
0.30 A
0.38 A
0.33 A
0.58 A

QD75P1

0.40 A

QD75P2
QD75P4
QD75D1
QD75D2
QD75D4
QD75M1
QD75M2
QD75M4
QD70P4
QD70P8

0.46 A
0.58 A
0.52 A
0.56 A
0.82 A
0.40 A
0.55 A
0.74 A
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(2) Criteria for use of an extension base requiring no power supply module
In the Q52B/Q55B (hereafter, the Q5B), a voltage drop occurs at an extension
cable because a power supply module on a main base unit supplies 5 V DC.
If the "IN" connector of the Q5B does not supply a specified voltage (4.75 V
DC or more), incorrect input or incorrect output may occur.
When using the Q5B, make sure that the voltage is 4.75 V DC or more at the
"IN" connector of the Q5B.
When using the Q5B, it is recommended to use an extension cable as short
as possible for connection just after the main base unit because of a voltage
drop.
(a) When only the Q5B is connected to an extension base unit
The 5 V DC output voltage minimum value of the power supply module on
the main base unit is set to 4.90 V DC. Therefore, if a voltage drop due to
an extension cable is 0.15 V (4.9 V - 4.75 V = 0.15 V) or less, the Q5B is
usable.
Main base unit（Q3□B）

Extension cable
model

Power
supply
module

V1

R1

Extension base unit（Q5□B）

I1

V2

R2

Extension base unit（Q5□B）
Second extension

I2

V7

R7

QC05B
QC06B
QC12B
QC30B
QC50B
QC100B

First extension

Extension cable
conductor
resistance value
(Ω)
0.044
0.051
0.082
0.172
0.273
0.530

Extension base unit（Q5□B）
Seventh extension

I7

Symbol
V1

Description
The voltage drop of the extension cable between the main base unit and the extension base unit
The voltage drop of the extension cable between the extension base unit ((n-1)th extension) and the extension base unit (nth
Vn
extension)
R1
The cable resistance between the main base unit and the extension base unit
Rn
The cable resistance between the extension base unit ((n-1)th extension) and the extension base unit (nth extension)
I1 to I7
5 V DC current consumption in the first to seventh extension *1
*1: I1 to I7, which is the current consumption of the Q5B + the total current consumption of the I/O modules and intelligent function
modules mounted to the Q5B, varies depending on modules mounted to the extension base unit. Refer to the user's manual for
the value of each module.

Calculation list of a voltage drop by an extension cable in first to seventh extension system configuration
Q5B
mount
position
1st
extension
2nd
extension
3rd
extension
4th
extension
5th
extension

Voltage drop by an extension cable for each extension base number
V1
R1･I1
R1(I1 + I2)

R1(I1 + I2 +
I3)
R1(I1 + I2 +
I3 + I4)
R1(I1 + I2 +
I3 + I4 + I5)
R1(I1 + I2 +
6th
I3 + I4 + I5 +
extension
I6)
R1(I1 + I2 +
7th
I3 + I4 + I5 +
extension
I6 + I7)

Total voltage drop to the
Q5B "IN" connector
(V)

V2

V3

V4

V5

V6

V7

－

－

－

－

－

－

V = V1

－

－

－

－

－

V = V1 + V2

－

－

－

－

V = V1 + V2 + V3

－

－

－

V = V1 + V2 + V3 + V4

－

－

V = V1 + V2 + V3 + V4
+ V5

－

V = V1 + V2 + V3 + V4
+ V5 + V6

R7･I7

V = V1 + V2 + V3 + V4
+ V5 + V6 + V7

R2･I2
R2(I2 + I3)
R2(I2 + I3 +
I4)
R2(I2 + I3 +
I4 + I5)

R3･I3
R3(I3 + I4)

R4･I4

R3(I3 + I4 +
R4(I4 + I5)
I5)

R5･I5

R2(I2 + I3 +
I4 + I5 + I6)

R3(I3 + I4 + R4(I4 + I5 +
I5 + I6)
I6)

R5(I5 + I6)

R6･I6

R2(I2 + I3 +
I4 + I5 + I6 +
I7)

R3(I3 + I4 + R4(I4 + I5 +
I5 + I6 + I7) I6 + I7)

R5(I5 + I6 +
I7)

R6(I6 + I7)
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(b) When the Q6B is connected between the Q3B and the Q5B
Extension cable
model

[When the Q5B is connected at the second extension]
Main base unit（Q3□B）

QC05B
QC06B
QC12B
QC30B
QC50B
QC100B

Power
supply
module

R1
V

Extension base unit（Q6□B）
Power
supply
module

Extension cable
conductor
resistance value
(Ω)
0.044
0.051
0.082
0.172
0.273
0.530

First extension

Extension base unit（Q5□B）

I1
Symbol
V
In
Rn
Rn+1

Second extension

Description
The voltage drop by an extension cable between the main base unit and the extension base unit (Q5B)
The 5 V DC current consumption when the Q5B is used at the (n+1)th extension, where n = 1 to 6 (n: number of
extension bases of the Q6B)
(The current consumption of the Q5B + the total current consumption of the I/O modules and intelligent function modules
mounted to the Q5B)
Extension cable resistance value between the main base unit or an extension base unit (Q6B) and another extension
base unit (Q6B)
Extension cable resistance value between the extension base unit (Q6B) and the extension base unit (Q5B)

Calculation list of a voltage drop by an extension cable when the Q6B is connected
between the Q3B and the Q5B
Mount position of the extension base unit
Q6B
Q5B
1st extension
2nd extension
1st and 2nd extension 3rd extension
Fourth extension
1st to 3rd extension
5th extension
1st to 4th extension
6th extension
1st to 5th extension
7th extension
1st to 6th extension

Voltage drop by an extension cable from the main base
unit and the IN connector of the Q5B (V)
V = (R1
V = (R1
V = (R1
V = (R1
V = (R1
V = (R1

＋
＋
＋
＋
＋
＋

R2)I1
R2 ＋
R2 ＋
R2 ＋
R2 ＋
R2 ＋

R3)I1
R3 ＋
R3 ＋
R3 ＋
R3 ＋

R4)I1
R4 ＋ R5)I1
R4 ＋ R5 ＋ R6)I1
R4 ＋ R5 ＋ R6 ＋ R7)I1

POINT
 An I/O module and an intelligent function module, which have large internal
current consumption (internal current consumption (5VDC)), must be mounted to
the main base unit or an extension base that requires power supply module
(Q63B, Q65B, Q68B, and Q612B) in order to use.
 Overall cable distance of an extension cable must be 13.2 m or less.
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(3) 24 V DC current consumption for each module
The 24 V DC output current capacity of the power supply module and the 24 V
DC current consumption of each module are described below. Refer to the
values below, and when insufficient, use an external DC stabilized power
supply.
Power supply 24 V DC output
module
current
Q62P
0.6 A
Output module

Transistor output

QY40P
QY41P
QY42P
QY50
QY70
QY71
QY80
QY81P

Intelligent function module
A/D conversion

Q62AD-DGH
Q62DA
Q64DA
D/A conversion
Q68DAV
Q68DAI
Q62DA-FG
QD62
High-speed counter QD62E
QD62D
QD70P4
Positioning
QD70P8
QD35ID1
I/D interface
QD35ID2
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24 V DC current
consumption
0.01 A
0.02 A
0.04 A
0.02 A
0.09 A
0.17 A
0.02 A
0.04 A

24 V DC current
consumption
0.36 A
0.12 A
0.18 A
0.19 A
0.28 A
0.30 A
0.008 A
0.065 A
0.12 A
0.17 A
0.33 A

(4) Power supply module selection example
When the sum of the connected modules described below is 5 V DC 2.399 A
and 24 V DC 0.48 A, the Q62P (5 V DC 3 A output and 24 V DC 0.6 A output)
must be selected.
If an external stabilized power supply is designed to provide 24 V DC, the Q61P
(5 V DC 6 A output) is also acceptable.
Base unit

5 V DC current consumption
24 V DC current consumption

Q
3
8
B

Q
6
2
P

Q
0
6
U
D
H

Q
X
4
1

Q
X
8
0

Q
X
8
0

Q
Y
4
2
P

Q
Y
4
2
P

Q
6
2
D
A

Q
6
8
D
A
I

Q
J
6
1
B
T
1
1

0.114
－

－
－

0.64
－

0.075
－

0.05
－

0.05
－

0.15
0.04

0.15
0.04

0.33
0.12

0.38
0.28

0.46
－
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6.4.2 When the "POWER" LED Turns Off
The flow chart below shows causes and measures in the case that the "POWER"
LED turns off at power-on or during operation.
The "POWER" LED turns off

Is the power supplied?

NO

YES

Is power supply voltage
within the specified
voltage range?

NO

NO

YES

Is the power supply
module fixed?

Supply the power

YES

Does the "POWER"
LED turn on?

Control the supply voltage to be within the rated range

NO

NO

YES

Does the "POWER"
LED turn on?

Securely fix the power supply module

YES
NO

Is overcurrent
protection or
overvoltage protection
working?

YES

Does the "POWER"
LED turn on?
(1) Check the current capacity.
Suppress the overcurrent.
(2) Turn OFF the input power supply
then on again after several minutes.

YES

NO
NO

Explain the fault symptoms and
consult with the nearest system
service, distributor or branch office

YES

Does the "POWER"
LED turn on?

End
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6.4.3 When the ERR Terminal (Negative Logic) Turns OFF (Opens)
The flow chart below shows causes and measures in the case that the " ERR
terminal" of the power supply module turns OFF (opens) at power-on or during
operation.
The ERR terminal turns OFF (opens)

The "ERR" LED of the
CPU module is...

Flashing (CPU
module is in stop
error)

Check the error details and take
measures according to them

Not flashing
・Is the power supplied?
・Is the voltage of the
supply power proper?

NO

Supply the power with a proper voltage

YES
Hardware failure
Perform operation check one by one,
starting from the minimum
configuration system.
For a module that does not work,
explain the fault symptoms and
consult with the nearest system
service, distributor or branch office.

 Detectable error definitions at the ERR terminal
Detectable error definitions at the ERR terminal of a power supply module are
described below.
1) When a power supply module is the Q61P-A1, Q61P-A2, Q61P, Q62P,
Q63P, and Q64P
Base unit
Main base unit (Q3B)
Extension base unit (Q6B)

Error definition
No AC power supply input, power supply module fuse blown, and CPU module stop
error (including when the CPU module is
reset) are detectable.
Error definitions are not detectable (always OFF)

2) When a power supply module is the Q61SP
Base unit
Slim type main base unit
(Q3SB)

Error definition
No AC power supply input, power supply module fuse blown, and CPU module stop
error (including when the CPU module is reset) are detectable.
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6.4.4 When Uninterruptible Power Supply (UPS) Is Connected
With a standby UPS, momentarily interruption occurs in timing of power supply relay
switching from the battery and AC down (error code: 1500 AC/DC DOWN) may be
detected at the time of power failure or a voltage drop.
Therefore, an online inverter UPS or line-interactive UPS whose voltage distortion is
5% or less must be used.
Mitsubishi's recommendation products are described below:
(1) Online inverter UPS
(Example) FREQUPS-V series, FW-V10-0.7K
(2) Line-interactive UPS
(Example) FREQUPS-A series, FW-A10L-0.7K
Note that when a standby UPS is adopted, only Mitsubishi's FREQUPS-F series
UPS (serial number P or later) is usable. (Example) FW-F10-0.3K/0.5K
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6.5 Troubleshooting for the CPU
For troubles regarding a CPU module, there are cases in which hardware failure
occurs or a program cannot be written.
6.5.1 Troubles regarding Hardware Failure
Identify a CPU error based on each LED status.
LED type
"MODE" LED
"RUN" LED

"ERR." LED

"USER" LED
"BAT." LED
"BOOT" LED

Status
Not turn on
Flashes
Turns off
Flashes
Turns on/flashes
Turns on/flashes
(UNIT VERIFY ERR. occurs)
Turns on/flashes
(CONTROL-BUS ERR. occurs)
Turns on
Turns on
Flashes
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Reference
(1) of this section
(2) of this section
(3) of this section
(4) of this section
(5) of this section
(6) of this section
(7) of this section
(8) of this section
(9) of this section
(10) of this section

(1) When the "MODE" LED does not turn on
The flow chart below shows causes and measures in the case that the "MODE"
LED does not turn on at power-on.
The "MODE" LED does not turn on

Is the "POWER" LED
of the power supply
module on?

NO

Go to the "when the 'POWER' LED turns
off" flow diagram, described in Section 6.4.2

NO

Check wiring, and turn on all power
supplies

YES
Have all the powers of the
power supply modules been
turned on? Is the wiring of the
power supply module correct?

NO

YES

YES

Does the "MODE" LED turn on?

Connect between GX Works2 and the
CPU module

Can the CPU module
communicate with GX Works2?

Perform PLC diagnostics, and troubleshoot
according to the diagnostic results.

NO
Is the connection direction of
the extension cable correct?
(IN-IN, OUT-OUT, or IN-OUT
connection is not correct)

NO

Connect the extension cable properly

NO

YES

Does the "MODE" LED turn on?

Replace the power supply module
and check the "POWER" LED status
YES

Does the "MODE" LED
turn on?

Power supply module hardware failure

NO
The following hardware failure may have
occurred.
(1) CPU module
(2) Main base unit or extension base unit
(3) Extension cable
(4) Network module
Perform operation check one by one,
starting from the minimum configuration
system, which consists of the main base
unit with the power supply module and the
CPU module mounted.
For a module that does not work, explain
the fault symptoms and consult with the
nearest system service, distributor or
branch office.
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End

YES

(2) When the "MODE" LED flashes
The flow chart below shows causes and measures in the case that the "MODE"
LED flashes at power-on, at the time of starting operation, or during operation.
The MODE LED flashes

YES

Has forced ON/OFF
settings been done?

Clear the forced ON/OFF settings

NO
NO

Hardware failure
Perform operation check one by
one, starting from the minimum
configuration system.
For a module that does not work,
explain the fault symptoms and
consult with the nearest system
service, distributor or branch office.
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YES

Does the "MODE" LED 
turn on?

End

(3) When the "RUN" LED turns off
The flow chart below shows causes and measures in the case that the "RUN"
LED turns off at power-on or during operation.
The "RUN" LED turned off

Is the "POWER" LED
of the power supply
module on?

Go to the "when the 'POWER' LED
turnsoff" flow diagram, described in
Section 6.4.2

NO

YES

Go to the "when the 'ERR.' LED turns
on or flashes" flow diagram,
described in Section 6.5.1 (6)

YES

Is the "ERR" LED on
or flashing?
NO

Reset using the RUN/STOP/RESET
switch of the CPU module

"RUN" LED is on

"RUN" LED is off

(1) Failure of programmable
controller parts or poor contact
(2) Due to excessive noise
In the case of (1)

Set the RUN/STOP/RESET switch of
the CPU module to STOP, and write
END to Address 0 using GX Works2

Set the RUN/STOP/RESET switch to
RUN, and operate in the monitoring
mode using GX Works2

In the case of (2)

Explain the fault symptoms and
consult with the nearest system
service, distributor or branch office
"RUN" LED does not
turn on

"RUN" LED is on
Some error in a sequence program
may be the cause

Check the program and correct the
defective part

NO

Does the "RUN" LED
turn on?
YES

End
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Connect a surge suppressor circuit
such as CR to a noise source

(4) When the "RUN" LED flashes
When the "RUN" LED flashes during operation, it is presumed that a parameter
or program change is in invalid status (operation stop).
If a program was written, perform one of the following operations:
 Reset the CPU using the RUN/STOP/RESET switch
 Turn the power off and on again
 Set the RUN/STOP/RESET switch from STOP → RUN again
If parameters were changed, perform one of the following operations:
 Reset the CPU using the RUN/STOP/RESET switch
 Turn the power off and on again
If the "RUN" LED flashes even after the operation described above was
performed, it is presumed to be hardware failure.
POINT
After a program or parameters were written during stop, the QCPU checks
programs when setting the RUN/STOP/RESET switch from STOP → RUN.
In this state, the CPU has been stopped its operation. (Though it is not an error, the
"RUN" LED flashes.)
To resume the operation, set the RUN/STOP/RESET switch from STOP → RUN
again.
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(5) When the "ERR." LED turns on or flashes
The flow chart below shows causes and measures in the case that the "ERR."
LED turns on or flashes at power-on, at the time of starting operation, or during
operation.
When the "ERR." LED turns on or flashes, it is presumed that an error has
occurred.

The "ERR." LED is on or flashing

Hardware failure

Explain the fault symptoms and
consult with the nearest system
service, distributor or branch office

Check the error definition using
GX Works2

Set the RUN/STOP/RESET switch to STOP

Take measures according to the error definition

Reset using the RUN/STOP/RESET
switch

Set the RUN/STOP/RESET switch to RUN

Does the "ERR." LED
turn off?
YES

End
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NO

(6) When the "ERR." LED turns on or flashes (when UNIT VERIFY ERR. occurred)
The flow chart below shows causes and measures in the case that a UNIT
VERIFY ERR. occurred and the "ERR." LED turns on or flashes.
UNIT VERIFY ERR. occurred

Check the error slot using GX
Works2

Check that the module of the
slot is connected and
disconnected during
operation

YES

Reset the CPU module

NO

Did the error disappear?
Check that the module of the
slot is mounted correctly

NO

Mount the module properly

NO

Replace the module

YES
NO

Check that all extension
cables of the base unit have
been connected properly

NO

Did the error disappear?

YES

Connect the extension cable properly

YES
NO

Replace the module

Did the error disappear?

YES

Normal operation

Error detection

Replace the CPU module

Normal operation

Error detection

Replace the base unit

Normal operation

Error detection
Hardware failure.
Explain the fault symptoms and consult
with the nearest system service,
distributor or branch office

End
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YES

(7) When the "ERR." LED turns on or flashes (when CONTROL-BUS. ERR.
occurred)
The flow chart below shows causes and measures in the case that a
CONTROL-BUS. ERR. occurred and the "ERR." LED turns on or flashes.
Note that this flow diagram is available only when a slot/base unit can be
specified by an error code.

CONTROL-BUS ERR. occurred

Check the error slot and the base unit
using GX Works2

Check that the module of the
slot is mounted correctly
Check that the extension
cable of the base unit is
connected properly

NO

Mount the module and the cable properly

NO

YES

Check that all extension
cables of the base unit have
been connected properly

NO

YES

Check that there is any
noise influence

YES

Connect the extension cable properly

NO

YES

Did the error disappear?

Did the error disappear?

YES

Take measures against noise

NO
Replace the module

Normal operation

Error detection
Replace the CPU module

Normal operation

Error detection
Replace the base unit

Normal operation

Error detection

Hardware failure.
Explain the fault symptoms and
consult with the nearest system
service, distributor or branch office

End
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(8) When the "USER" LED turns on
The "USER" LED turns on when an error is detected at a CHK instruction or
when an annunciator (F) turns on.
When the "USER" LED turns on, monitor SM62 and SM80 of the special relay
using the GX Works2 monitoring mode.
 When SM62 is ON
An annunciator (F) is ON.
Identify the error cause using SD62 to SD79.
 When SM80 is ON
Execution of a CHK instruction turns on the "USER" LED.
Identify the error cause using SD80.
Once an error cause is identified, remove the error cause.
The following operation will turn off the "USER" LED:
 Reset using the RUN/STOP/RESET switch
 Execution of a LEDR instruction by a programmable controller program
REMARKS
To execute latch clear processing, use the remote latch clear operation of GX
Works2.

(9) When the "BAT." LED turns on
The "BAT." LED turns on when a battery low is detected.
If the "BAT." LED turns on, monitor special relays and special registers using
functions of GX Works2 such as the device batch monitor in order to identify
which battery is low, either the CPU module or an SRAM card. (SM51 to SM52
and SD51 to SD52)
After identification and replacement with a new battery, reset using the
RUN/STOP/RESET switch or execution of a LEDR instruction will turn off the
"BAT." LED.
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(10) When the "BOOT" LED flashes
The flow chart below shows causes and measures in the case that the "BOOT"
LED of the CPU module flashes at the programmable controller power-on, at the
time of starting operation, or during operation.
The "BOOT" LED flashes
Turn OFF the power supply of the programmable
controller

Detach a memory card

Turn on the SW2 and SW3 DIP switches

Turn ON the power supply of the programmable
controller

Does the "BOOT" LED turn on?

YES

Automatic writing from a memory card
to the standard ROM is completed
Execute boot operation from the standard ROM

NO
CPU module hardware failure.
Explain the fault symptoms and
consult with the nearest system
service, distributor or branch office
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6.5.3 When a Program Cannot Be Read/Written
(1) When a program cannot be written
The flow chart below shows causes and measures in the case that a program
cannot be written to the CPU module.

A program cannot be written

Set the DIP switch 1 (system
protection) to OFF

ON

Is the DIP switch 1 OFF?

Only for high
performance models
OFF

NO

YES

Clear the password using GX
Works2

YES

Has a password been
registered?

Can a program be written?

NO
NO

Is the memory program
memory?
Program memory

Can a program be written?

YES

Memory Try the following items
・ Check whether the write protect
card
switch is OFF
・ Check whether it is formatted
・ Check the specification of a write
destination

Try the following items
・ Organize and rearrange files
・ Check the free space of the memory
・ Check the specification of a write destination

Can a program be written?

YES

NO

Can a program be written?

YES

NO

Format the memory

Can a program be written?

YES

NO

End

Explain the fault symptoms and
consult with the nearest system
service, distributor or branch office
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(2) When a program cannot be read
The flow chart below shows causes and measures in the case that GX Works2
cannot communicate with the programmable controller while its power is ON.
Cannot communicate with GX Works2

Is memory to be read correct?

NO

NO

YES

Is the connection cable
connected correctly?

Can the CPU
module communicate with
GX Works2?

YES

Connect the connection cable
correctly.

NO

YES

Can it communicate with
GX Works2 after the replacement
of the connection cable?

Choose correct memory

NO

Can the CPU
module communicate with GX
Works2?

YES

YES

NO

Has a USB driver
been installed to the
personal computer?

NO

Install a USB driver to the personal
computer.

YES
NO

Explain the fault symptoms and
consult with the nearest system
service, distributor or branch office

Can the CPU
module communicate with GX
Works2?

YES

End
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(3) When a program is unexpectedly overwritten
The flow chart below shows causes and measures in the case that a program is
unexpectedly overwritten at power-on or reset operation.
A program is unexpectedly overwritten

Is SM660 ON?

OFF (Program memory execution)

ON (Boot operation is going on)
Format the program memory that is
executing boot operation from the standard
ROM, and write to the standard ROM

Disable the "Execute boot operation from
the standard ROM" checkbox in the boot
file setting of the PLC parameter

Write parameters and a sequence
program to the program memory

Restart/reset the power supply of
the programmable controller

Is a program overwritten?

YES

End

Hardware failure.
Explain the fault symptoms and
consult with the nearest system
service, distributor or branch office.
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(4) When boot operation from a memory card cannot be executed
The flow chart below shows causes and measures in the case that boot
operation of the CPU module from a memory card cannot be executed.
Boot operation cannot be executed

Did CPU fault occur?

YES

NO

Has a parameter-valid
drive been specified?

Remove the error causes

NO

NO

YES

Can boot operation be
executed?

Specify a parameter-valid drive
using the DIP switches 2 and 3
Only for high
performance models

YES
NO

Has a file set in
the boot file setting of
the parameters?

NO

YES

Has a file set in
the program settings of
the parameters?

Has a file executed
by boot operation been stored
in the memory card?

YES

Set a file to the boot file setting

NO

NO

YES

Can boot operation be
executed?

Can boot operation be
executed?

YES

Set a file to the program settings

NO

NO

YES

Can boot operation be
executed?

Write a file to the memory card

YES
NO

YES

Can boot operation be
executed?

Explain the fault symptoms and
consult with the nearest system
service, distributor or branch office

End
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6.5.3 CPU Troubles and Measures
Trouble symptom
Measures
 Disturbance to the programmable  Fundamentally, various measures against noise are required. For temporary and
early restoration, however, avoiding this trouble using boot operation from a flash
controller such as noise causes
ROM (standard ROM), which is an internal standard attachment, or from a
unauthorized access to the memory
memory card is useful. Storing programs and parameters into a standard ROM or
inside the CPU, overwriting data
a memory card in advance enables to perform boot operation triggered by a CPU
temporarily.
reset or turning the power OFF and ON again, which transfers data to an internal
program memory (SRAM) whenever this happens. (The following figure is a
operation image) Furthermore, backing up programs and parameters to a CF
card using the backup and restoration function of the GOT also enables this. (The
following figure is a operation image) The CPU module processes the operation
of programs stored in the program memory. The operation of program stored in
the standard ROM and the memory card is not processed. To process the
operation of programs stored in the standard ROM or the memory card, configure
the module so that programs in the standard ROM and the memory card can be
booted (read) into the program memory when the power is turned OFF and ON
again or when the CPU module is reset.

Example 1

Boot operation from the standard ROM or the memory card

Boot

Program
memory
Boot

Memory card

Standard
ROM

Function to backup and restore connected devices
Backs up the setting information of connected
devices to a memory card/USB memory
Memory card/
USB memory

Example 2

Restores the backed up setting
information of connected devices

 Once a battery error occurs, the battery  There are two types of battery errors depending on a place in which the error
error can be displayed after battery
occurred. Therefore, perform the PLC diagnostics using peripherals such as GX
replacement.
Works2 to check the error code.
(1) Error code 1600: CPU module itself
(2) Error code 1601: Memory card
* The basic model and the universal model QCPU Q00U(J)CPU and Q01UCPU
are not equipped with a memory card.
 The programmable controller does not  The RESET switch may be fixed at the reset position. Check visually to make
start and the front LED does not turn
sure that the RESET switch is not at1 the reset position.
2
on, even after power-on.
3
4
5

Example 3

S TOP RUN

RESE T L.CLR

RESET/
L.CTR switch

* The basic model and universal model QCPU has the RUN/STOP/RESET
switch. When the switch is released at the reset position, it automatically goes
back to the stop position. Therefore it cannot be fixed at the reset position.

(To the next page)
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(From the previous page)
Trouble symptom
 When the base is mounted, the base
connector can be damaged.

Measures
 When the base is mounted, ensure that the module fixing projection and the
module fixing hole are fitting into each other, then insert the module.

Base unit
Module
fixing
hook

Module connector
Base unit
Module fixing
projection

Module

Module
mounting lever

Example 4

Module fixing hole

Base unit

Module
mounting lever
Module fixing
projection

Example 5

Module fixing hole

 When a module with USB interface is
connected to a personal computer
using USB, electric shock or module
failure may occur depending on the
model of the personal computer and
operating conditions.

When using a personal computer with an AC power supply, use one whose
power plug has three pins or a grounding wire, or ensure that the ground cable is
grounded. When using a battery-driven personal computer, use the computer as
is.
(For more details, refer to the Mitsubishi programmable controller TECHNICAL
BULLETIN No. PLC-D-464.)
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6.6 Troubleshooting for the Input Module
6.6.1 Troubles regarding Hardware Failure
(1) If external input equipment is OFF and a programmable controller side input
signal is ON, it is presumed to be input module failure or a leakage current.
The input signal is on even though
the external input device is OFF

NO

Is the LED of the input
module on?
YES

Remove the input module from
the base unit, and monitor the
input signal using GX Works2

NO

Can an external factor be
the cause?
YES

Is the input signal ON?
Restart it after removing the error
cause such as a leakage current

YES

Reset the CPU module and
monitor the signal again
using GX Works2
Check the program,
because the signal turns
ON after the reset if the
program improperly outputs
to an input

NO

Replace the input signal
cable and monitor the signal
again using GX Works2

Is the input signal ON?

NO

YES

NO

Is the input signal ON?

The input signal cable is
faulty. Replace it with a
new cable.

YES
Reset has not been performed
after it turned ON forcibly in
device test operation

The CPU module may be
faulty. Explain the fault
symptoms and consult with
the nearest system service,
distributor or branch office.

The input module may be
faulty. Explain the fault
symptoms and consult with
the nearest system service,
distributor or branch office.

POINT
The external factors include external device failure, external power supply failure,
incorrect wiring, and noise.
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(2) If external input equipment is ON and a programmable controller side input
signal is OFF, it is presumed to be input module failure or disconnection of an
input circuit.
The input signal is OFF even though
the external input device is on

Is the external
NO
input voltage within the range of
input signal?

NO

Set the input signal of the
programmable controller within
the range of voltage specifications

YES
Check the external input circuit

Does the LED of
the input module turn
on?

NO

YES

Check the "POWER" LED
of the power supply module

Is the "POWER"
LED on?

Monitor the input signal using
GX Works2

NO

Go to the "when the 'POWER'
LED turned off" flow diagram

YES

Replace the input signal cable
and the extension cable
NO

Is the signal on the
monitor ON?
YES

End

NO

Does the LED
of the input signal
turn on?

YES
The input signal cable or the
extension cable is faulty
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NO

The input module may be faulty.
If there is an empty input terminal
on the input module, migrate the
wiring of the external input
devices and change the input
number. Otherwise, replace the
module.

6.6.2 Input Circuit Troubles and Measures
This section explains examples of input circuit troubles and measures.
Table 6-2: Input Circuit Troubles and Measures
Condition

Cause

Example 1

 Leakage current of the input switch
(For example, drive by a contactless switch)
AC input
An input signal
does not turn
OFF.

Measures
 Connect a proper resistor so that a voltage between
input module terminals can be lower than the OFF
voltage value.
AC input

Input module

Leakage current

Input module

Power supply

Example 2

 Drive by a limit switch with neon lamp
An input signal
does not turn
OFF.

Leakage current

AC input






Power supply
The recommended CR constant is:
0.1 to 0.47 μF + 47 to 120 Ω (1/2 W).
Same as Example 1
Alternatively, make the circuit independent and
install a display circuit separately.

Input module

Example 3

Power supply
 Leakage current due to the line capacity of an
connecting cable
The approximate line capacity of a twisted pair
cable C is defined as: C = 100 PF/m.
AC input
An input signal
does not turn
OFF.
Leakage
Input module
current

 Same as Example 1
 However, when the power supply is located at the
side of the input equipment shown as the following
figure, this trouble does not occur.
AC input

Input module

Power supply

Power supply

 Drive by a switch with a LED indicator

Example 4

DC input
(Positive common)

An input signal
does not turn
OFF.

Leakage current

Input module

Example 5

 Sneak current due to usage of two power supplies
DC input
An input signal
does not turn
OFF.

 Connect a proper resistor so that a current in the
input module is lower than the OFF current.
DC input
(Positive common)

Resistor

* The next page shows the calculation examples for
the values of resistance to be connected.
 Unite two power supplies into one.
 Connect a diode to suppress a sneak current. (The
figure below)
DC input

Input module

diode

Lamp
Input module
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Input module

Lamp

Table 6-2: Input Circuit Troubles and Measures (Continued)

Example 6

Condition

An input signal
does not turn
ON.
(AC input module)

Cause
Measures
There exists stepwise distortion near the zero cross Improve the waveform of the input signal, for
voltage in the input signal (AC) as shown below.
example, using an online inverter UPS.

Zero cross
voltage

Example 7

*1

Change the response time setting.
Example: 1 ms → 5 ms
If setting the response time longer makes no
difference, take measures described below:
 Avoid bundling a power cable and an I/O cable to
prevent excessive noise.
 Take measures against noise. For example,
suppress noise by adding a surge absorber to noise
sources such as relays and conductors that use the
same power supply.

Incorrect input
Noise is captured as input.
due to noise

*1: If the noise is periodic and excessive, setting response time short may be more effective.
<Calculation examples for Example 4>
When a switch with LED indicator, through which a 2.33 mA leakage current
flows when a 24 VDC power supply is applied to the QX40, is connected:

Leakage current 2.33 mA

Input module

(1) This does not meet the QX40 OFF current, 1.7 mA. Therefore, a resistor must
be connected as follows:

input impedance

(2) The connection resistance value R is calculated as follows.
The connection of a resistor R by which 0.63 mA or more flows through the
connection resistor is required in order to meet the QX40 OFF current of 1.7 mA
or less.
IR:IZ＝Z（ Input impedance ）:R
R≦

IZ
IR

Z（ Input impedance ）＝

1.7
0.63

5.6＝15.11[kΩ]

That is, R ＜ 15.11 kΩ.
When resistor R is 12 kΩ, power capacity W for the resistor R is:
W = (input voltage) 2 ÷ R = 28.82 ÷ 12000 = 0.069 (W)
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(3) Because the power capacity of a resistor is three to five times of the actual
power consumption, a 12 (kΩ) and 1/4 to 1 (W) resistor must be connected to
the issued terminal,
(4) Besides, the OFF voltage when resistor R is inserted is:
1
1
1
＋
12.0[kΩ]
5.6[kΩ]

×2.33[mA]＝8.90[V]

It satisfies the QX40 OFF voltage, which is 11 V or less.
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6.6.3 Input Module Terminal Voltage Checking Methods
The input module differs in control voltage, which is 100 V AC, 200 V AC, 5 V DC, 12
V DC, and 24 V DC, and in source/sync input. This offers various combinations.
Methods for terminal voltage check for the input module using a tester are described
below.

Negative electrode (-)

Positive electrode (+)

Table 6-3: Terminal Voltage Checking Methods
Control voltage
9
A
B
C
D

100 V AC
200 V AC

E
F
COM
NC
100VAC
8mA60Hz
7mA50Hz

9
A
B

5 V DC
12 V DC
24 V DC
Positive
common

C
D
E
F
- +

COM

NC
24VDC
4mA

9
A
B

5 V DC
12 V DC
24 V DC
Negative
common

C
D
E
F
NC
COM

24VDC
4mA

7
8
9
A
B
C
D
E
F

Module/unit terminal measuring point
Set the voltage range of the tester to 100 V AC/200 V
AC measurement.

Connect the negative electrode of the tester to each
input terminal
Connect the positive electrode of the tester to the
COM terminal

7
8
9
A
B
C
D
E
F

7
8
9
A
B
C
D
E
F
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Set the voltage range of the tester to 100 V DC
measurement.

Connect the negative electrode of the tester to each
input terminal
Connect the positive electrode of the tester to the
COM terminal
Set the voltage range of the tester to 100 V DC
measurement.

Connect the negative electrode of the tester to the
COM terminal

Connect the positive electrode of the tester to each
input terminal

6.7 Troubleshooting for the Output Module
6.7.1 Troubles regarding Hardware Failure
(1) When the load of the output module does not turn ON during operation
The flow chart below shows causes and measures in the case that the load of
the output module does not turn ON during operation.
An output load does not turn ON

Is the operation
indication of the output
module on?

NO

Check the output status using the
GX Works2 monitoring mode

YES

NO

Is the operation
indication of the
output module on?

OFF

Measure the voltage between the
output of the module and the
COM terminal
0V

What is the voltage
between output
COM terminals of
the output module?

0V

Confirm that the output signal is
off using the GX Works2
monitoring mode

Equal to the
supply voltage
The output module is faulty
Replace the output module

Check the wiring of the power
supply to the load, and restore the
power

(The monitor signal is OFF)

ON

YES

Check the external wiring and the
external output devices

Check the load and its wiring, and
restore them

Check the rush current while the
maximum number of loads is
simultaneously ON

NG

Change the output relay number and change
the maximum simultaneous ON current of the
load so that it satisfies the specifications

OK
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Explain the fault symptoms and
consult with the nearest system
service, distributor or branch
office

The value of the supply voltage

Is a voltage to
the load
applied?

(2) When the LED of the output module does not turn ON during operation
The flow chart below shows causes and measures in the case that the LED of
the output module does not turn ON during operation.
The LED of the output module does not turn on

Is the "MODE" LED on?

NO
(flashing)

Refer to Section 11.2.3

YES

Is it ON when monitoring
using GX Works2?

NO

Review the program

YES

Check the I/O number using
GX Works2 system monitor

Is the output number
correct?

NO

Change the output number

YES

Does the LED turn ON by
turning on forcibly another
output module?

NO

YES

Does the LED turn ON after
replacing with another output module
and turning on forcibly again?

YES

Output module hardware failure.
Explain the fault symptoms and
consult with the nearest system
service, distributor or branch office
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NO

Hardware failure of the CPU module,
base unit, or extension cable.
Explain the fault symptoms and
consult with the nearest system
service, distributor or branch office

6.7.2 Output Circuit Troubles and Measures
This section explains the examples of output circuit troubles and measures.
Table 6-4: Output Circuit Troubles and Measures
Condition

Cause
Measures
 When the load is internally half-wave rectified
 Connect a resistor (from 10kΩ to 1000kΩ)
(Some solenoids act like this.)

on across the load.

QY22
Output module

D1

[1]

Resistor

Example 1

Load
Load

Overvoltage
is
applied to the load
during output OFF.

[2]

 C is charged when the polarity of the power
supply is [1], and the sum of a voltage
charged to C while the polarity is [2] and the
power supply voltage is applied across D1.
The maximum voltage value is about 2.2 E.
(If it is used in this way, although output
element does not pose a problem, a built-in
diode in the load is deteriorated and
accidents such as burnout may occur.)

Example 2

 Leakage current due to a built-in surge
suppressor

The load does not
turn OFF.
(Triac output)

QY22
Output module

Load
Leakage current

 Connect a resistor across the load.
(Caution is required when wiring length
between the output module and the load
is long, because there is also a leakage
current due to line capacity.)
Resistor

Load
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Table 6-4: Output Circuit Troubles and Measures (Continued)

Example 3

Condition

Cause
Measures
 The minimum load current is not satisfied.
 Connect a resistor across the load so that a
 If the load current is lower than the minimum
current equal to or higher than the minimum
load current of the output module, the triac
load current will flow.
does not work and the load current will flow
to the phototriac, as the arrow in the following
Resistor
figure shows.
When an inductive load is connected as a
load in this state, the off-time surge is applied
Load
to the phototriac and the load may not turn
OFF.

The load does not
turn OFF.
(Triac output)

Surge suppressor
QY22

Phototriac

Control
circuit

Load

Triac

6 - 49

Table 6-4: Output Circuit Troubles and Measures (Continued)
Condition

Cause

Measures

Incorrect output due to floating capacitance (C) between the collector
and the emitter of the photocoupler.
Although it poses no problem at a normal load, a sensitive load
(such as a solid state relay) may output incorrectly.

When the external power supply is turned
ON/OFF, make sure that the start-up of
the external power supply itself takes 10
ms or more and then insert a switch SW1
into the primary side of the external
power supply.

Output module/combined module

Primary side

Photocoupler

Secondary side

External power supply
Programmable
controller

Load

If a switch is need to be inserted into the
secondary side of the external power
supply, connect a capacitor and a resistor
so that the start-up of the external power
supply becomes slower (10 ms or more).
Sink output

Constantvoltage circuit

Load

When an external power supply is started up rapidly, a current Ic
flows due to floating capacitance (C) between the collector and the
emitter of the photocoupler.
The current Ic flows into the next stage, the gate of the transistor
Tr1, and the output of Y0 turns ON for about 100 μs.

Example 4

Source output
The load turns ON
momentarily when an
external power supply
is started up. (transistor
output)

External power
supply due to SW
ON (24 V)

Load

10 ms or less

Y0 output
About 100 µs

* The measures have no effect for the
module(s) below, due to the
characteristics of its/their external
power supply circuit.
• QY81P
R1: Several tens of Ω
Power capacity ≥ (External power supply
*1 2
*2
current ) × Resistance value × (3 to 5)
C1: Several hundreds μF 50 V
*1: Refer to the manual of the current
consumption for the external power
supply of a module to be used.
*2: The power capacity of a resistor is
chosen from three to five times of the
actual power consumption.
(application example)
R1 = 40 Ω, C1 = 300 μF
Time constant is calculated by the
following formula:
-6
C1 × R1 = 300 × 10 × 40
-3
= 12 × 10 s
= 12 ms
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Table 6-4: Output Circuit Troubles and Measures (Continued)
Condition

Cause

Measures

When an inductive load is used, the load [2] that has been OFF Take one of the measures described
may turn ON because a back EMF during the power supply below.
1. Connect a diode parallel to the load in
shut-off [1] sneaks.
which a back EMF is generated in
order to suppress the back EMF.
Output module/
combined module
Source output

Back EMF

Source output
[3]

Load

－ Back EMF ＋

Load

Load
Shut-off

Sink output
[3]
＋ Back EMF －

Load

Output module/
combined module
Sink output

Back EMF
Load

Load

2. Make a sneak current path by
connecting a diode between (+) and (-)
of the external power supply.
Note that if Example 4 is implemented
simultaneously, connect it parallel to
C1 and R1.
Source output

Back EMF

Example 5

Load

Shut-off

The load that has
been OFF turns ON
when
the
power
supply is shut off.
(transistor output)

Load
Shut-off

Example 4

* The measures have no effect for the
module(s) below, due to the
characteristics of its/their external
power supply circuit.
• QY81P
• QY82P
Sink output

Back EMF
Load

Load
Shut-off

Example 4

D1: Reverse voltage VR (VRM)…*1,
Forward current IF (IFM)…*2
*1: Approximately 10 times of the
specified rated voltage
Example: Approximately 200 V when
24 V DC
*2: Equal to or higher than two times of
the specified maximum load current
(common)
Example: More than 4 A when 2 A/1
common
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Table 6-4: Output Circuit Troubles and Measures (Continued)
Condition

Cause

Measures

The polarity of the external power supply is reversely connected.
Transistor output
module

Load
Wrong

Example 6

Connect the polarity of the external power
supply correctly.

Correct

External
power supply

The load operates only
by
external
power
supply power-on
(transistor output)
Output element
protection diode

When the polarity of the external power supply is reversely
connected, a current may go through the output element
protective diode and flow to the load.
When it becomes unwired due to shut-off or disconnection of
wiring that connects the 0 V of the external power supply and the
common of the load, a current flows to the load of an output
element that has been turned ON, passing through the parasitic
circuit of an output terminal that has been turned OFF.
Transistor
output module

Source output

Source output

Example 7

Output
element

When output is ON, a
load connected to other
output
turns
ON
simultaneously.
(transistor
output (source type))

Connect the wiring between the external
power supply and the load correctly.
In addition, prevent the occurrence of the
conditions described on the left by
attaching diodes to each output terminal
as shown below.

Output
control
circuit

Load

Load
Load

Output
element
Output
control
circuit

Load

Shut-off
or
disconnection

If it continues to be used in those conditions, it may cause a
failure.

REMARKS
When short-circuit occurs in an output module with protection, a programmable
controller CPU cannot detect an error because a thermal protection works and
prevents fuses from blowing.
Therefore, a check circuit or its equivalent must be made externally.
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6.7.3 Output Module Terminal Voltage Checking Methods
The output module, depending on its output, differs from AC and DC, in addition to
the difference in control voltage. This offers various combinations.
Methods for terminal voltage check of each output module using a tester are
described below.

Negative electrode (-)

Positive electrode (+)

Table 6-5: Terminal Voltage Checking Methods
Control
voltage

Module/unit terminal measuring point

L

9
A

L
L

B
C

L

Contact output
AC/DC
common

L

D
E

L
L

F
COM

NC
24VDC
240VAC
2A

L

9
A

L
L

B
C

L

Triac output
AC only

L

D
E

L
L

F

COM

100VAC
240VAC
0.6A

L

9
A

L
L

B
C

L

Transistor DC
sink output
only

L

D
E

L
L

F

COM

12VDC
24VDC
0.1A

7
8
9
A
B
C
D
E
F

7
8
9
A
B
C
D
E
F

7
8
9
A
B
C
D
E
F

Set the voltage range of the tester to AC/DC
measurement.

Connect the negative electrode of the tester to each
output terminal
Connect the positive electrode of the tester to the
COM terminal
Set the voltage range of the tester to AC
measurement.

Connect the negative electrode of the tester to the
COM terminal
Connect the positive electrode of the tester to each
output terminal
Set the voltage range of the tester to DC
measurement.

Connect the negative electrode of the tester to the
COM terminal

Connect the positive electrode of the tester to each
output terminal
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Table 6-5: Terminal Voltage Checking Methods (Continued)
Control
voltage

Module/unit terminal measuring point

L

9
A

L
L

Transistor DC
source
output only

B
C

L
L

D

L

E

F
L
- +

COM

12VDC
24VDC
0.5A

7
8
9
A
B
C
D
E
F
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Set the voltage range of the tester to DC
measurement.

Connect the negative electrode of the tester to each
output terminal
Connect the positive electrode of the tester to the
COM terminal

6.8 Troubleshooting Using Cart Conveying System Training Machine
(1) Explanation of the training machine (operation panel)
This section explains troubleshooting using the training machine system that
conveys workpieces.
It contains practical training of moving the conveyance table to the workpiece set
position with GOT screen operation.
(2) Explanation of operating procedures
(a) Manual control
1) JOG operation
It moves left and right by touching arrow switches on the operation panel.
It stops by touching the stop switch.
2) Point specification
It can be moved to the workpiece set workpiece set position, inspection
position, and pass sensor position.
It starts to move by touching the square switch near the screen center
then touching an arrow switch of desirable direction. It stops moving
when it reaches a specified point.
(b) Automatic control
Starts automatic operation: Touch…Start (HMI (Human Machine Interface))
Stops automatic operation : Touch…Stop (HMI (Human Machine Interface))
Failure switch (HMI (Human Machine Interface)): Touch…Failure
Pass switch (HMI (Human Machine Interface)): Touch…Pass
[Operation example]
1) Stop the table at the workpiece set position.
2) Touching the start switch on the operation panel starts automatic
operation.
First, the table moves to the inspection position. Inspect the workpiece
visually.
3) When it fails → Touch the failure switch on the visual inspection panel.
If the result of the visual inspection is failure, it moves back from the
inspection position to the workpiece set position and stops automatic
operation.
When it passes → Touch the pass switch on the visual inspection panel.
If the result of the visual inspection is passed, the table moves forward
from the inspection position to the pass sensor, then moves back to the
workpiece set position and stops automatic operation.
*

For the safety reasons, the workpiece on the table cannot be removed.
Proceed with the training assuming the workpiece is set.
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[Operation panel]
①

③

②

⑩
⑨

④

⑦

⑤

⑧

⑥

⑩
⑨

1) M0: Move left switch
2) M1: Move right switch
3) M2: Stop switch
4) M20: Point specification switch (pass sensor position)
5) M22: Point specification switch (inspection position)
6) M24: Point specification switch (workpiece set position)
7) M300: Start automatic operation switch
8) M300: Stop automatic operation switch
9) Control switching switch
10) Device display switching switch
To understand the status, check the inspection, passed, and failure lamps under
the cart training machine.
[Visual inspection panel]

①

②

1) Passed switch
2) Failure switch
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[Wiring of the training machine]
Programmable controller
training machine

X20～X3F
Cart training machine

Y60～Y7F
RS-232C

USB

RS-485

Connect the input cable of the training
machine to X20 to X3F of QX42, and the
output cable to Y60 to Y7F of QY42.

*

Before starting-up, set the training programmable controller CPU to STOP first.
When the cart training machine is started up first, an error may be displayed on
the GOT.

[Overview of the cart training machine]
Pass LS

Inspection LS
(X21)

(X20)

Workpiece
Table

Inspection

Workpiece set

Retract

end LS

position LS

position LS

end LS

(X24)

(X22)

(X23)

(X25)

Advance
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[Assignment of I/O signals]
MELSEC-Q
Input

Output

X20

Y60

Passed lamp (Terminal number 1)

(Terminal number 5) Inspection LS

X21

Y61

Inspection lamp (Terminal number 2)

(Terminal number 7) Inspection position LS

X22

Y62

Failure lamp (Terminal number 3)

(Terminal number 9) Workpiece set position

X23

Advance end LS

X24

Backward end LS

X25

(Terminal number 10) Mock contact 1

X26

(Terminal number 11) Mock contact 2

X27

(Terminal number 12) Mock contact 3

X28

(Terminal number 4) Pass LS

*

The terminal numbers represent the switch numbers on the rear side of the
training machine.
(Initial setting) Terminal number 1 to 5, 7, and 9…ON/6, 8, and 10 to
12…OFF
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Project name

QDAISYA

(3) Sequence program
Manual/automatic

Control mode switching

The virtual production system starts in the manual mode.

Always ON only
OFF
for one
scan after
RUN

Manual
mode flag

Manual control
switching request

Automatic
flag mode

Automatic
control
switching
request

Automatic
flag mode

Manual
mode flag

Manual control JOG operation Forward rotation start

Manual
Manual Manual Point
Manual Advance
specification reverse end LS
mode flag forward stop
run JOG request stop
run JOG
command
request
command

Manual
forward run
JOG
command

Manual
forward run JOG
command
Manual control JOG operation Reverse rotation start
Manual
Manual
mode flag reverse
run JOG
request

Manual Point
Manual Backward
specification forward end LS
stop
run JOG
request stop
command
command

Manual
reverse run JOG
command
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Manual
reverse
run JOG
command

Manual control Select a point
Select a stopping point
Manual
mode
flag

Point
specification:
Passed

Point
specification:
Pass flag

Point
specification
stop instruction

Point
specification:
Pass flag

Point
specification:
Inspection
position

Point
specification
stop instruction

Point
specification:
Inspection
position flag

Point specification:
Inspection position
flag

Point
specification:
Workpiece
set

Point
specification:
Workpiece
set flag

Point
specification
stop instruction

Point
specification:
Workpiece
set flag
Stop when it reaches a point

Manual Point
Pass
mode
specification: sensor
flag
Pass flag

Point
specification
stop
command

Point
Inspection
specification: position
Inspection
LS
position flag

Point
Workpiece
specification: set position
Workpiece
set flag
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Automatic control Operating flag

Automatic Automatic
mode flag start
request

Workpiece Workpiece Workpiece
set
set position set position
position
move end: move end:
Passed
Failure

Advance
end LS

Backward
end LS

Automatic
operating flag

Automatic
stop
request

Automatic
operating flag

Automatic
start PLS

Automatic control Move to inspection position

Automatic
mode flag

Automatic
operating
flag

Automatic
start PLS

Inspection
position move
end pulse

Inspection
position
move

Inspection
position
move

Inspection Inspection
position
sensor
move

Inspection
position LS

Inspection
position
move end
pulse

Inspection
end pulse:
Failure

Inspecting

Automatic control Waiting for passed/failure determination

Automatic
mode flag

Automatic
operating
flag

Inspection Inspection
position
end pulse:
move end Passed
pulse

Inspecting

Inspection
lamp

Inspection
window
display

Inspecting

Touch
passed

Inspection
end pulse:
Passed

Touch
failure

Inspection
end pulse:
Failure
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Automatic control Determination result: Passed
Move to pass sensor position

Automatic
mode flag

Automatic
operating
flag

Inspection
end pulse:
Passed

Passed
position
move end
pulse

Passed
position
move

Passed
position move

Passed
lamp
output

Passed
position
move

Passed
position move
end pulse

Pass sensor

Standby 2 seconds

Automatic
mode flag

Automatic
operating
flag

Passed
position
move end
pulse

Standby
for 2
seconds
end pulse

Standing by
for
2 seconds

Standing by for
2 seconds

Standing by for
2 seconds

2.0 s timer

2.0 s timer

Standby for
2 seconds
end pulse

Move to workpiece set position and end

Automatic
mode flag

Automatic
operating
flag

Standby for
2 seconds
end pulse

Workpiece
set position
move end:
Passed

Workpiece
set position
move:
Passed

Workpiece
set
position

Workpiece
set position
move end:
Passed

Workpiece
set position
move:
Passed

Workpiece
set position
move:
Passed
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Automatic control Determination result: Failure
Move to workpiece set position and end

Automatic
mode flag

Automatic
operating
flag

Inspection
end pulse:
Failure

Workpiece
set position
move end:
Failure

Workpiece
set position
move:
Failure

Workpiece
set position
move: Failure

Workpiece
set position
move:
Failure

Failure
lamp
output

Workpiece
set position

Workpiece
set position
move end:
Failure

Stroke limit error Display

Advance
end LS

Stroke limit
error screen
display

Backward
end LS

Stroke limit
error
screen
display

Device name
screen
display

Touch panel initial display: Manual control

Stroke limit
error screen
display

ON only for
one scan after
RUN
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Output processing
Cart forward rotation output

Manual
forward run
JOG
command

Cart forward
rotation

Inspection
position
move

Passed
position
move

Cart reverse rotation output

Manual
reverse run
JOG
command

Cart reverse
rotation

Workpiece
set position
move:
Passed

Workpiece
set position
move:
Failure

Passed lamp output

Passed
lamp
output

Passed lamp

Inspecting lamp output

Inspecting

Inspection
lamp

Failure lamp output

Failure
lamp
output

Failure
lamp
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The following is a communication program between a programmable controller and an inverter.
Do not change this program because it is completed.
Command send preparation

ON only for
one scan
after RUN

Forward rotation start command send

Cart forward
rotation

Reverse rotation start command send

Cart
reverse
rotation

Stop command send

Cart
forward
rotation

Cart
reverse
rotation
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Receive response

(4) Practical operation for trouble examples
Mock contacts and switches of an I/O signal disconnection terminal block on the
rear side of the training machine are used as a trouble example of the training
machine, as shown in the following figure.
1) When a contact does not turn ON
Fault contact
A mock contact that turns non-conductive when it turned ON externally
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Investigate the cause of Trouble example 1 to 4 described below.
<Trouble example 1>
The cart does not move forward.

<Trouble example 2>
The cart does not stop at the position of the inspection sensor.

<Trouble example 3>
The cart does not move backward.

<Trouble example 4>
The cart does not stop at the workpiece set position.
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For the cause of Trouble example 1 to 4, refer to Appendix 8.

6.9 Trouble Example: Troubleshooting Using Training Machine
Write the following sequence program to the training programmable controller, make
sure it works correctly, and then investigate the occurring troubles and their causes.
Project name

6 - 68

QTORABURU

(1) Question 1
1)

Training machine system
Q61P

Q06UDHCPU

Empty

QX42

QY42P

Q64AD

64 points

64 points

16 points

16 points

Occupied

Occupied

X02

Q62DAN

X03
X04
X05
X06

+
-

24 V DC

2)

Fault description
Whichever input signal turns ON, it does not turn ON in the program, even
though the monitor LED of the input module has turned on.
Target
Input
X0 to X3F

3)

External device

QX42 monitor
LED

Program

ON/OFF
switching

ON/OFF

Always OFF

How to answer
Use the flow diagram in troubleshooting (Section 6.6) of the school text to
find the cause of the trouble, the reason why the CPU does not read the
signals even though they are input to the input module from outside.
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(2) Question 2
1)

Training machine system
Q61P

2)

Q06UDHCPU

QX42

QY42P

Q64AD

Q62DAN

64 points

64 points

16 points

16 points

Occupied

Occupied

Fault description
When the CPU is set to RUN and Y60, Y61, Y62, and Y63 are turned
ON/OFF in the program, nothing is output to the external device even
though the monitor LED of the output module QY42P turns on/off.
When Y70, Y71, and Y72 are turned ON/OFF in the program, nothing is
output to the external device even though the monitor LED of the QY42P
turns on/off.
Assume that external wiring is correct.
Target
Output
Y60 to Y63
Y70 to Y72

3)

Empty

Program
ON/OFF
switching
ON/OFF
switching

QY42P monitor
LED
ON/OFF
ON/OFF

External device
No output
(always OFF)
No output
(always OFF)

How to answer
Use the flow diagram in troubleshooting (Section 6.7) of the school text to
find the cause of the trouble, the reason why the external device does not
turn ON/OFF.
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(3) Question 3
1)

Training machine system
Q61P

Q06UDHCPU

Empty

QX42

QY42P

Q64AD

Q62DAN

64 points

64 points

16 points

16 points

Occupied

Occupied

CPU fault occurs after the sequence program described below is modified.
Ladder diagram

D10

D10

2)

Fault description
CPU error occurs.

3)

How to answer
Use the flow diagram in troubleshooting (Section 6.5) of the school text to
find the cause of the trouble, the reason why the CPU error occurs.
*

For the FROM instruction, refer to Appendix 9.
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6.10 Troubleshooting for the Intelligent Function Module
Various intelligent function modules can be used with a programmable controller.
This section explains common items that should be known at troubleshooting.
6.10.1 Common Items about Intelligent Function Modules
(1) Type of intelligent function modules
Intelligent function modules are designed to process functions that the
programmable controller CPU cannot do or functions whose application is
limited. Some typical types are described below:
1) Analog module
 Analog-digital converter module
Receives analog (current/voltage) as input and converts it to digital value.
 Digital-analog converter module
Converts digital value and outputs analog (current/voltage).
 Temperature input module
Connects a temperature sensor and converts to digital value.
 Temperature control module
Connects a temperature sensor and controls a heating/cooling device to
keep the temperature of a target object constant.
2) High-speed counter module and positioning module
 High-speed counter module
Receives high speed pulses as input from an encoder in order to count.
 Positioning module
Outputs high-speed pulses to a servo amplifier for positioning.
3) Network module
 MELSECNET/H network module
Performs data communication between programmable controllers using a
network.
 Ethernet interface module
Performs data communication between a personal computer and a
programmable controller via Ethernet.
 Web server module
Allows a personal computer to monitor a programmable controller via the
Internet.
 CC-Link module
Performs data communication of a programmable controller or various
devices on a distributed system.
 CC-Link IE
An integrated network which realizes seamless data transfer, from
information systems to production sites. This achieves both conventional
control information transmission and information processing data
transmission, such as equipment information maintenance and device
settings.
4) Serial communication module and modem interface module
 Serial communication module
Connects a programmable controller and a calculator, printer, bar code
reader, or other devices and performs data communication.
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(2) Relation to the programmable controller CPU
An intelligent function module has internal buffer memory to store necessary
data.
As needed, a programmable controller CPU can write data to the buffer memory
using a TO instruction, and read from the buffer memory using a FROM
instruction.
Besides, specifying an intelligent function module device (U\G) using a MOV
instruction enables writing to and reading from the buffer memory.

Device
memory such
as D, W, R,
X, and Y

Intelligent function
module

I/O module

I/O module

CPU module

Power supply module

Signals are exchanged by setting output signal Y to ON/OFF when the
programmable controller CPU commands the intelligent function module, and by
setting input signal X to ON/OFF when the intelligent function module answers
to the programmable controller CPU.
REFERENCE
When an error occurs during the
execution of TO/FROM
instruction, error code numbers
described below are stored to
SD0 and the CPU stops.
1412 ··· Cannot be executed.
1402 ··· No answer came. *
2110 ··· No intelligent function
MOV instruction
Intelligent function
module. *
module device
MOV instruction
*: If some CPU parameters
(U□\G□)
have been set, operation
will not stop but continue.
FROM instruction
TO instruction

Input X
Output Y

Buffer
memory

I/O
signals

Assignment of the buffer memory and the I/O signals is explained in the user's
manual of each intelligent function module.
REMARKS
 With intelligent function module operation by GX Works2, it is possible to set,
monitor, and test functions easily without realizing the I/O signals and the
buffer memory. Example functions are intelligent function module parameters
of an analog module (initial setting and auto refresh), the system settings of a
serial communication module, and the positioning data and parameters of a
positioning module.
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6.10.2 Buffer Memory Monitor Operation of the Intelligent Function Module
The buffer memory of the intelligent function module can be directly monitored using
a personal computer (GX Works2) to check the current value.
(1) Monitoring buffer memory
Set the "RUN/STOP/RESET" key switch of the
CPU to "RUN".
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1)

Click the [Online] → [Monitor]
[Device/Buffer Memory Batch] menu.

→

2)

Specify a start I/O number (whole digit
specification) and a buffer memory
address (decimal/hexadecimal) of the
intelligent function module to be
monitored.
In this example, specify "80" as a module
start number, and "0" as an address.

3)

Press

4)

Monitoring of the specified buffer memory
is started.

5)

Turn the voltage potentiometer of the
training machine to set the meter to 5 to 8
V DC.
The current value of Q64AD CH.1 can be
monitored.

.

(2) Changing a current value of the buffer memory
In this example, a current value of the buffer memory monitored in (1) will be
changed.
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1)

Click the

Modify Value

2)

From the "Buffer memory" tab, specify
"80" in the "Module start" and "0" in the
"Address".

3)

Input "2" in the "Value to be set".

4)

Click the

5)

The current value is replaced with the
specified value.

Set

button.

button.

(3) Saving the buffer memory
In this example, a current value of the buffer memory will be read and saved.
1)

Click the [Online] → [Read from PLC]
menu.

2)

Click the

3)

Click the Execute button. When the
"The parameter exists already. Do you
want to overwrite it?" message appears,
click the Yes button.

4)

When the "Operation ended" message
appears, click the OK button.

5)

Check the "Device data" to select it.

6)

Click the "Detailed information" button.

(1) Click!

(To the next page)
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Parameter + Program

button.

(From the previous page)

7)

Input "MAIN" in the Device data name.

8)

Check the "Buffer memory" to select it.

9)

Input the address of the module whose
buffer memory is read.

10) Click the

OK

button.

11) Click the Execute button.
When the "The device memory (MAIN)
exists already. Do you want to overwrite
it?" message appears, click the Yes
button.
12) Click the
finished.

Close

button after reading

13) Click the [Project] → [Save] menu to save
the project.
By saving the project, the read device
memory is saved.
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6.10 Intelligent Function Module Troubles and Measures

Example 1

Q62DA(N)
Q64DA(N)
Q68DAV(N)
Q68DAI(N)

Example 2

Product model

Q62DA(N)
Q64DA(N)
Q68DAV(N)
Q68DAI(N)

Trouble symptom

Measures

In analog input wiring check, when a wiring
conduction test is performed using a
checker with a buzzer (6 V, 60 mA) while a
programmable controller power supply is
being turned on, a operational amplifier IC in
analog output circuit may cause a failure.

The cause is presumed as that an excessive
surge voltage is applied during a wiring check
with a buzzer or current application test using
an external device. Take measures described
below.
(1) Stop using the buzzer used in the test in
order not to apply an external voltage.
(2) When an external voltage is applied,
perform the test holding the terminal
block of the module afloat.
It is presumed that a poor contact causes
unstable analog output because a screw is
not tightened enough at the load side
(isolator) terminal block connected to the
analog output. Tighten the screw at the load
side.
(1) Change to the Q64DAN (a typical
example), in which a gap between the
external power supply and the analog
output is isolated.
(2) Ensure to avoid combined use of an
RS-232 cable and a USB cable in order
not to form a closed loop circuit.

Analog output reduces sometimes.

Example 3

Due to combined use of an RS-232 cable
and a USB cable as well as 24 V DC
positive grounding specification conditions,
a closed loop circuit is formed by 24 VDC
power supply, Q64DA (a typical example),
servo amplifier, personal computer,
Q06UDHCPU, and FG. When the RS-232
cable is connected to the servo amplifier, a
voltage is applied between external power
supply 24 G and analog output COM,
causing a current flow through the filter coil
of the Q64DA internal common line and
blowing the coil.
Q62DA
Q64DA
Q68DAV
Q68DAI

Q06UDHCPU

Servo amplifier

Q64DA

F
G

The analog
output and
the common
are in
common

Analog output

FIL

The input and the RS-232
common are in common

24 V DC
common
24 V DC
positive

USB

Filter coil blown

The shield of USB
and FG are in
common

RS-232

Compared to the ground, FG and
24 V DC positive are in common

Failure occurs when the
cable is connected

Personal computer
The USB shield and the
RS-232 common are in
common internally

USB communication cable

RS-232 communication cable

(To the next page)
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(From the previous page)
Product model

Trouble symptom

Measures

In the Q64DA (a typical example), when 24
V DC is applied to external wiring of the
COM terminal, a current flows through the
filter coil of the common line, blowing the
coil.

(1) Change to the Q64DAN (a typical example),
in which a gap between the external power
supply and the analog output is isolated.
(2) Improve the wiring so that the 24 V DC is not
applied to the external wiring.

<Internal ladder block diagram of Q64DA>

Example 4

To internal
control circuit

D/A
conversion
circuit

Channel
switching
circuit

Output
circuit

Q62DA
Q64DA
Q68DAV
Q68DAI
It is presumed that 24 V
DC is applied to the
COM terminal of one of
the channels according
to external wiring, and
an overcurrent flows.
DC-DC converter
Filter

24 V DC

Analog ground (AG)

Example 5

Digital conversion value of analog input is
unstable (varies).
Q68AD
Q68ADV
Q68ADI

Analog/digital conversion value is unstable
(varies) due to the influence of superposition of
noise generated by the servo to analog input
signals.
(1) Configure the average processing function
using parameters in order to reduce the
influence of the input noise.
(2) Review wiring so that any cable does not
come near to the power cable and is not
bundled to it.

(To the next page)
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(From the previous page)

Example 6

Product model

Q68AD-G
Q66AD-DG

Trouble symptom

Measures

When a connector/terminal block converter
module and a dedicated cable are used with
current input, the accuracy of analog/digital
conversion value is not within the
specifications.

The factory default setting of offset/gain
setting has been adjusted for a single module.
Therefore, when the connector/terminal block
converter module and the dedicated cable are
used, error in conversion property may occur
due to influence such as conductor resistance.
If the influence such as conductor resistance
is a problem, configure the offset/gain setting
using user range setting. (For more details,
refer to the Mitsubishi programmable controller
TECHNICAL BULLETIN No. PLC-D-555.)

When a personal computer (with a power supply
plug and without a ground cable connected) and the
QJ71C24N are connected with an RS-232 cable,
the QJ71C24N and the personal computer may
cause a failure due to the potential difference of the
QJ71C24N and the personal computer.

When the QJ71C24N and a personal computer are
connected, ground the ground cable of the personal
computer first, then connect the RS-232 cable. If a
personal computer with no ground cable is used,
check whether it has shock protection with no earthing
(grounding) cable. Ensure to use a personal computer
with shock protection.
Alternatively, use a battery-driven personal computer.
(For more details, refer to the Mitsubishi programmable
controller TECHNICAL BULLETIN No. PLC-D-464.)

QJ71C24N

Personal computer

Example 7

COM port

QJ71C24N
QJ71C24N-R2

Frame

Example 8

Potential is
generated

QJ71C24N
QJ71C24N-R4

When a relay device (intrinsically safe
explosion-proof interface) is connected
between the QJ71C24N and the measuring
equipment, normal communication becomes
unavailable.

Leakage current

AC
adapter

Remove the relay device and connect the
QJ71C24 and the measuring equipment
directly.

(To the next page)
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(From the previous page)
Product model

Trouble symptom

Measures

Because the communication cable and the
power cable are bundled together,
communication becomes unstable when the
servo turns ON.

Separate the communication cable and the
power cable.

Terminal

Example 9

Programmable controller

RS-232C cable

QJ71C24N
QJ71C24N-R2
QJ71C24N-R4

Ground (FG)

Power cable
Motor

Separate a communication
cable and a power cable

Example 11

Example 10

Servo amplifier

QJ71E71-100

A self-made communication cable is used,
causing the deformation of contact pins of a
10BASE-T connector. After that,
communication error occurs due to poor
contact between the communication cable
and the connector part.
Communication error occurs in Ethernet
communication because noise prevents data
from being received correctly.

QJ71E71-100
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Replace the module, and use a genuine cable
specified by Mitsubishi as a communication
cable.

(1) Ground the shield of the communication
cable.
(2) Use a HUB designed for FA.
(3) Ground the power supply of the HUB.
(4) Separate the communication cable from
the main circuit and the power cable.
(5) When a non-shielded twisted pair cable is
used, replace it with a shielded twisted
pair cable.

6.11 Sequence Program Troubles
Using ladder monitor, check the relevant ON/OFF status in the program as well as
whether program errors like the following exist or not.
(1) Example of normally open/closed contact program error
When an external stop switch is a normally closed contact, because
programming is done as a normally closed contact, a stop normally closed
contact becomes non-conductive and it cannot be started.
Start

Start output
Y70

Stop
Normally open contact is correct.

Y70

(2) Example of device number program error
Because a start-up Y70 self-holding circuit is programmed as Y07, self-holding
cannot be done.
Start

Start output
Y70

Stop

Y7
Y70 is correct.

(3) Example of interlock program error
It does not work when a move-forward command and a move-back command
turn ON.
Advance Advance
command end LS

Advance output
Y70

Y71

Backward Backward
command end LS
Y70

Backward output
Y71

Normally closed contact are correct for these interlocks.

(4) Example of operation program error, such as four arithmetic operations
Multiply C55 by 30 and output the result to the digital HMI (Human Machine
Interface).
Because D50 is 32-bit data and exceeds 32767, a 4-digit BCD conversion
instruction is not available.
(An operation result of integration of 16-bit and 16-bit may exceed 32767.)
Operation Execution
condition instruction

*P

C55

K30

D50

BCD

D50

K4Y40

Using a DCCD D50 K8Y40 conversion instruction is correct.
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(5) Example of program jump destination error by a CJ and CALL instruction
Programming of jump destination pointer P5 is forgotten.
X0

M2

X3

M7

CJ

P5

No Pointer P5
Y77

END

(6) Example of TO instruction program error
Because there is a mistake in a TO instruction when the Q62DA conversion
module is mounted to X/Y0A0, analog output cannot be done.
X0

X0A1

BINP

TOP

H0A0

K4X20

K0

D10

D10 K1

Upper two digit H0A is correct for a mounting address.
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Project name

QHOZEN

6.12 Practical Training in Case of Error
This document is intended for training of reading error descriptions and taking actions
by operating a personal computer (with GX Works2). Use the [Project Name:
QHOZEN] sequence program for training.
There are training operations from Training 1 to Training 13. Follow instructions for the
operations.
6.12.1 Training 1 I/O Number Assignment Mistake Using Personal Computer with GX Works2
Check faults when the parameter I/O number setting differs from that of the mounted
module using a personal computer with GX Works2.
(1) Assign a slot to 16 inputs according to the following operations.
<Operation>
(a) Double-click "Parameter" → "PLC parameter" in the project data list.

(b) Click the "I/O assignment setting" tab of the Q Parameter Setting dialog box.
(c) Assign a slot as follows.
 "Type": Input, "Model Name": QX42, "Points": 16 points

(d)
(e)
(f)
(g)

Click the End Setting button.
Set the CPU to STOP.
Click
(Write to PLC) on the toolbar.
On the Write to PLC dialog box, click to select "Parameter" → "Network/remote
password/switch setting" and click the Execute button.
(h) A confirmation dialog box is displayed. Click the Yes button.
(2) Set the CPU to RUN and turn ON X2. The current value of timers is not displayed
in the digital HMIs (Human Machine Interfaces) for Y40 to Y4F.
(3) Monitor the ON/OFF statuses of outputs Y40 to Y4F with the following operations.
<Operation>
(a) Click the [Online] → [Monitor] → [Device/Buffer Memory Batch] menu.
(b)Input "Y40" in "Device" on the Device Batch Monitor dialog box.
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(c) Click the Start Monitoring button.

Turn on X2 and turn ON/OFF X0.
The display shows that the values are normally output to Y40 to Y4F in the
program.
It is assumed that the current value of the timer is not output to the output
module because of a problem other than the program.
(4) Check that the number of I/O points matches that of the mounted I/O points with
the following operation.
<Operation>
(a) Click the [Diagnostics] → [System monitor]menu.
(b) On the System Monitor screen, check that the number of I/O points assigned in
parameters matches that of the mounted I/O points.

(5) Action
Correct the I/O assignment for the parameters according to the mounted module.
REMARKS
The following examples show possible causes of mismatching between the I/O
number and the mounted one.
 Assignment of an I/O numbers is incorrectly set using the personal computer
with GX Workers2.
 Connector pins on the back side of the I/O module are bent or faulty.
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(6) Set the CPU to STOP and restore the parameters to the original status before the
next practical training with the following operations.
<Operation>
(a) Double-click "Parameter" → "PLC parameter" in the project data list.

(b)
(c)
(e)
(f)
(g)
(h)
(i)

Click the "I/O assignment setting" tab of the Q Parameter Setting dialog box.
Click the Default button.
A confirmation dialog box is displayed. Click the Yes button.
Click the End Setting button.
Click
(Write to PLC) on the toolbar.
On the Write to PLC dialog box, click to select "Parameter" → "Network/remote
password/switch setting" and click the Execute button.
A confirmation dialog box is displayed. Click the Yes button.
RESET CPU
↓
RUN CPU

The current value of timers are not displayed
in the digital indicators for Y40 to Y4F HMIs (Human
Machine Interfaces). (Turn ON X2 and turn ON/OFF
X0.)
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6.12.2 Training 2 Operation Failure Due to Redundant Coil
If there are two or more coils of the same device in a program, executing ON/OFF
causes an operation failure.
(1) Create a new project and then create the following program.

(2) The ON/OFF status of Y70 cannot be changed by operation of X2.
(3) Methods for checking redundant coils are described below.
 Displaying coils in ladder programs
(read mode) on the toolbar to switch to the read mode.
(a) Click
(b) Press the following keys to search coils.
F7
Y
7
0
)
(
Reads the
first coil

Reads the
second coil

Reads the third coil
(Displays "Search
completed." when the
third coil does not
exist.)

 Displaying coils in the list of used devices
(a) Click to select the [Search/Replace] → [List of used devices] menu.
(b) Input "Y70" in "Device" on the List of Used Devices dialog box.
(c) Click the Search button.
[List of used devices]

 Displaying coils in cross reference
(a) Click to select the [Search/Replace] → [Cross Reference] menu.
(b) Input "Y70" in "Device/Label" on the Cross Reference dialog box.
(c) Click the Search button.
[Cross Reference]

This result shows that the Y70 coil exists in two places, step 1 and step 3 of
the MAIN program.
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 Executing program check
(a) Click to select the [Tool] → [Check Program...] the menu.
(b) Click the Execute button.
[Check Program...]

This result shows that there are two Y70 coils.
(4) Action
Avoid the duplication of coils using an internal relay.
Change the existing program to the following program.

This change enables ON/OFF operation of Y70 with either X2 or X3.
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6.12.3 Training 3 Jump Destination Error in Use of CJ instruction
If there is no jump using a branch instruction, the CPU stops.
Confirm the phenomenon.
(1) Add the following program to the existing program.

(2) Turn ON X4.
An error occurs and the CPU will stop.
(3) Read the error step and code with the following operation.
<Operation>
(a) Click the [Diagnostics] → [PLC Diagnostics] menu.
(b) Check "Current Error" on the PLC Diagnostics dialog box.
No.

Current error

4210

CAN'T EXECUTE(P)

Year/Month/
Day
2013-10-1

Time
9:10:11

For details of errors, click the Error Help button on the PLC Diagnostics
dialog box to display details of currently generated errors.
(4) Reset the programmable controller CPU.
(a) Turn OFF X4.
(b) Press the RESET switch of the CPU to reset.
(5) Action
When programming with a CJ, SCJ, JMP, CALL, or CALLP instruction, be sure to
insert the jump destination pointer "P3" as a label before the destination ladder.
(a) In the write mode ( ), select outside the left rail of the ladder just below the
ladder of the added CJ instruction.
Change the existing program to the following program.

(b) Turn ON X4.
No error will occur.
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REMARKS
 CAN'T EXECUTE(P) error occurs when a jump destination specified with a CJ,
SCJ, JMP, CALL, or CALLP instruction does not exist.
"A jump destination does not exist" means that the label from P0 to P4095 has
not been input.
 In use of a CJ, SCJ, JMP, CALL, or CALLP instruction, if the same label exists
in a program, CAN'T SET(P) error occurs.
 On GX Works2, CAN'T EXECUTE(P) and CAN'T SET(P) errors can be
checked by the program check function ([Tool]→[Check Program...] menu) in
advance.
 After the timer coil turns on, the current value will not be updated even if the coil
is moved by a jump instruction.
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6.12.4 Training 4 BCD Code Error
When the input data is not a BCD code at an execution of a conversion instruction
(BIN, etc.) or when a value cannot be converted at an execution of a conversion
instruction (BCD, etc.), an error occurs.
(1) Add the following program to the existing program.
SM400
X2

BIN

K4X20

D1

(2) Change the digital switches X20 to X2F to various values until an error occurs.
(BCD code error does not occur depending on the structure of digital switch.)
(3) Read the error step and code with the following operation.
<Operation>
(a) Click the [Diagnostics] → [PLC Diagnostics] menu.
(b) Check "Current Error" on the PLC Diagnostics dialog box.
No.

Current error

4100

OPERATION ERROR

Year/Month/
Day
2013-10-1

Time
9:10:11

For details of errors, click the Error Help button on the PLC Diagnostics
dialog box to display details of currently generated errors.
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(4) Read the program in the error step.
There are two methods to read the program as follows.
 Click the Error JUMP button on the PLC Diagnostics dialog box which read
the error step in (3).
 Read the error step by the device/buffer memory batch monitor.
1) Click the [Online] → [Monitor] → [Device/buffer Memory Batch Monitor] menu.
2) Input "SD4" in "Device Name" on the Device/Buffer Memory Batch Monitor
.
dialog box and press

Error step 59 (BIN K4X20 D1) can be read.
This instruction converts a BCD code into a binary code. When the data is not a
BCD code, the error occurs.
The cause is that the program constantly reads BCD-coded values of digital switches and
hexadecimal codes A to F are generated when the values of the digital switches is
changed.
(5) Action
Modify and make an addition to the program as follows so that signals other than 0
to 9 will not be read.
When a ladder with 12 contacts or more in a line is created as follows, the program
automatically loops back (*1) and proceeds to the next line. (It is necessary to
insert an empty line to loop the program back in advance.)
*1

REMARKS
The following cases are examples of BCD code errors.
 When BIN K4M0 D1 is executed, any of the contents of M0 to M15 is not a
BCD code (binary-coded decimal).
 When BCD D8 K4Y40 is executed, the content of D8 is a negative value or
larger than 9999.
 When DBCD D8 K8Y40 is executed, the content of D8 and D9, which is 32-bit
data, is a negative value or larger than 99999999.
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6.12.5 Training 5 BCD Instruction Error to Minus Data
Check an error phenomenon when BCD instruction is executed to minus data.
(1) Add the following program to the existing program.
X7
X2

X8

MOVP

D1

D2

D2

K10

D2

BCD

D2

K4Y40

-P

(2) With ladder monitoring, set the programmable controller to RUN, set X20 to X2F
digital switches to 0050, turn ON X7, and turn ON/OFF X8 to decrease D1 in
increments of 10. When D1 becomes minus data, BCD code error occurs.
(3) Read the error step and code with the following operation.
<Operation>
(a) Click the [Diagnostics] → [PLC Diagnostics] menu.
(b) Check "Current Error" on the PLC Diagnostics dialog box.
No.

Current error

4100

OPERATION ERROR

Year/Month/
Day
2013-10-1

Time
9:10:11

For details of errors, click the Error Help button on the PLC Diagnostics
dialog box to display details of currently occurring errors.
(4) Action
Insert an interlock as follows so that BCD conversion is not carried out when D1 is
minus data.
X7
X2
X8

<=

-P
K0

D2

Interlock
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MOVP

D1

D2

D2

K10

D2

BCD

D2

K4Y40

6.12.6 Training 6 How to Use Failure Detection Annunciators (F)
Upon an annunciator (F) receives the failure condition of an external signal, the F
numbers to be turned ON are automatically stored in special registers (SD64 to SD79)
depending on failures descriptions and the number of detected failures is stored in
SD63. The contents can be output to an external HMI (Human Machine Interface) or
read by the host computer.
(1) Add the following program to the existing program.

When X0 is turned ON, LEDR instruction can be executed to reset the memory.
X9 and XA assume failure conditions of external failure signals such as "stroke limit
signal", "blade breakage detection signal", and "arm breakage detection signal"
and turn ON annunciators F.
(2) Write the program to the CPU.
STOP CPU
(a) Click
(Write to PLC) on the toolbar.
(b) Click the Parameter + Program button on the Write to PLC dialog box
and then click the Execute button.
(c) A confirmation dialog box is displayed. Click the Yes button.
RUN CPU
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(3) Monitor special relays and special registers with the following operation.
The display shows whether each annunciator (F) is ON, which annunciator turned
ON first, and how many annunciators are ON.
<Operation>
(a) Click the [Display] → [Docking window] → [Watch window (1) to (4)] menu.
* In this training, select (1).
(b) The watch 1 window is displayed. Select the line to be edited, click the
Device/Label field, and input the following devices.
SM52
Turns ON when the battery voltage becomes lower than the
specified level and turns OFF when it returns to normal.
SM51
Turns ON when the battery voltage becomes lower than the
specified level and remains ON even after it returns to normal.
SM1
Turns ON when there is an error as the result of self
diagnostic and remains ON even after the condition returns to
normal.
SM62
Turns ON when at least one annunciator F turns ON.
SM63
Stores the number of annunciators F which have turned ON.
SD64
Stores the number of the F that turned ON in the first place.
SD65
Stores the number of the F that turned ON in the second
place.
SD66
Stores the number of the F that turned ON in the third place.
SD67
Stores the number of the F that turned ON in the fourth place.
SD68
Stores the number of the F that turned ON in the fifth place.
SD69
Stores the number of the F that turned ON in the sixth place.
SD70
Stores the number of the F that turned ON in the seventh
place.
SD71
Stores the number of the F that turned ON in the eighth place.
(c) Click the [Online] → [Watch] → [Start Watching] menu.
The following screen is displayed. Check the contents.
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6.12.7 Training 7 Setting of Operation Mode When There Is an Error
The operation of CPU after an error occurrence can be selected from "Stop" and
"Continue" by setting a parameter.
(1) Setting
1)

Double-click
"Parameter"
→
parameter" in the project data list.

"PLC

2)

On the "PLC RAS setting" tab, change
"Operating Mode When there is an Error" →
"Computation Error" to "Continue".

3)

Write the parameter to the programmable
controller using the Write to PLC function to
reset.

(2) Operation check
1)

Turn ON XB and operate the digital switch (K4X30).

2) When the numerical value changes from 7 to 8 or from 8 to 7, an error occurs.
Check that the CPU does not stop even when the error occurs.
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6.12.8 Training 8 Error Check and Error Clean from a Program Using SM and SD
Errors can be checked and cleared by using special relays SM and special registers
SD.
●

Error check
The number of the occurring error is stored in [SD0] (diagnostic errors). The
occurring error can be checked by displaying the current value.

●

Error clear
(1) Checking special relays and special registers
1)

Click "Help"→"GX Works2 Help" on the
menu bar.

2)

Click "Special Relay/Register Help" → "Q
series PLC (Q Mode)" → "Special register
(Diagnostic information) [Numbers SD0 to
SD183]" → "[Numbers SD50 to SD53]" →
"[Number SD50] Error reset".

3)

Check the content of [SD50].
(Also, check the content of [SM50] in the
same way.)

(1) Click!

[SD50] (Error reset): Stores the number of the error to be cleared.
[SD50] (Error reset): Clears the error.
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(2) Operation check
1)

Turn ON XB and operate the digital switch (K4X30).

2) When the numerical value changes from 7 to 8 or from 8 to 7, an error occurs.
Check that the CPU does not stop even when the error occurs.
3)

Turn ON XC and check that the error LED turns off.

6.12.9 Training 9 Saving of Error Histories
The history of errors which have occurred can be saved in CSV format on the personal
computer.
(1) Operating procedure
1)

Click [Diagnostics] → [PLC Diagnostics] on
the menu bar.

2)

Click "Create CSV file" on "Error History" to
save a file on the personal computer.

(2) Confirmation
Open and check the saved file on the personal computer.
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6.12.10 Training 10 Sampling Trace
What is the sampling trace function?
The sampling trace function sequentially collects contents of specified devices in the
CPU module at a specified timing.
Sampling trace samples contents of the specified devices at specified intervals
(sampling cycle) and stores the trace results in a sampling trace file.
Application of sampling trace
During debugging, this function allows checking changes of the contents of devices
used in a program at a specified timing.
This function also reads contents of devices when a trigger condition is satisfied.
POINT
(1) Sampling trace files can be stored only in standard RAM and SRAM cards.
(2) When storing a sampling trace file in standard RAM, check the versions of the
CPU module and GX Works2. *1
*1: CPUs whose the first five digits of the serial number are 07032 or later are supported

First, follow the procedure below for preparation.
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1)

Double-click
"Parameter"
→
Parameter" in the project data list.

"PLC

2)

On the "PLC RAS setting" tab, change
"Operating Mode When there is an Error" →
"Computation Error" to "Continue".

3)

Write the parameter to the programmable
controller using the Write to PLC function to
reset.

(1) Trace setting

(To the next page)
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1)

Click "Debug" → "Sampling Trace" → "Open
Sampling Trace" on the menu bar.

2)

The Sampling Trace screen is displayed.

3)

Click the [Debug] → [Sampling Trace] →
[Trace Setting] menu.

(From the previous page)

4)

Set the trace execution method as follows.
Target memory: Standard RAM
File name: MAIN
Select "Execute after overwriting current
trace setting in the PLC".

5)

Click the Condition Setting tab.

6)

Select "Detail Setting" in Trigger Condition
Setting and set the Trace Count Setting as
follows.
Total Count: 8192 counts
Count Before Trigger: 4096 counts

7)

(To the next page)

6 - 101

Click the Setting Change button.

(From the previous page)

8)

The Detail Setting - Trigger Condition dialog
box is displayed. Set the following items.
In this case, set error occurrence as a trigger
condition.
Device/Label: SM0
Condition: ↑

9)

Click the End Setting button.

10) The display returns to the Trace Setting
dialog box. Click the End Setting button to
close the dialog box.

11) On the Sampling Trace screen, set devices
to be traced as follows.
Bit device: X33, X32, X31, X30
Word device: SD0
12) Place a checkmark in the checkbox to
display the trend graph of SD0.
(12) Check!

13) "SD0" is displayed in the trend graph field of the Sampling Trace screen.
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(2) Trace execution
1)

Click the [Debug] → [Sampling trace] →
[Start Trace] menu.

2)

The message on the left is displayed.
Click the Yes button.

3)

When trace execution starts, the trace data
storage condition screen is displayed.
After checking that the Total Data reaches
100%, turn ON XB and operate the digital
switch (K4) to change 7 to 8 (or 8 to 7).
The trigger condition is satisfied by the error
occurrence.

4)
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The trace result is displayed on the
Sampling Trace screen.

(3) Trace result
1)

Scroll down to the trigger point and check
that the device value at the time of error
occurrence.

2)

Click the [Debug] → [Sampling trace] →
[Export CSV Data] menu to display a dialog
box to save the trace data on the personal
computer.
The saved data can be processed and used
for operation check, etc. on a personal
computer.

REMARKS
Turning ON SM722 prevents occurrence of OPERATION ERROR at the execution
of BIN or DBIN instruction.
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6.12.11 Training 11 Scan Time Measurement
Scan time within the range of specified steps can be measured.
(1) Setting
1)

Switch to the monitoring mode.

2)

Click "Debug" → "Scan Time Measurement"
on the menu bar.

3)

Set the measurement range as follows.
Start Step: 0
End Step: Step number of END instruction
-1

4)

Click Start.

(2) Operation check
Check the change of scan time.
Check that scan time changes depending on instruction execution and
non-execution in the program.
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6.12.12 Training 12 Remote Operation
Remote operation changes the CPU module operating status with external operations.
RUN/STOP
state

RUN

STOP

Remote operation
PAUSE

RUN

RUN

STOP

PAUSE

STOP

STOP

STOP

STOP

RESET
Cannot be
operated
RESET

Latch clear
Cannot be
operated
Latch clear

*: Remote RESET requires a parameter setting.

(1) Remote RUN/STOP/PAUSE/latch clear
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1)

Click "Online" → "Remote Operation" on the
menu bar.

2)

Select the operating status to be executed
from the "Operation" list box and click the
"Execute" button.

*:

Remote latch clear can be executed only
when the CPU is in the STOP state.

(2) Remote RESET
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1)

Double-click
"Parameter"
→
parameter" in the project data list.

"PLC

2)

Place a checkmark in the checkbox
"Remote Reset" on the "PLC System
Setting" tab to permit remote reset operation.

3)

Write the parameter to the programmable
controller using the "Write to PLC" function
to reset.

4)

Select "RESET" from the "Operation" list box
and click the "Execute" button.

*:

Remote RESET clear can be executed only
when the CPU is in the STOP state.

6.12.13 Training 13 Forced On/Off Function for External I/O
Select [Debug] → [Modify Value] on GX Works2 to forcibly turn ON/OFF external input
and output.
Registered forced ON and OFF information can be cleared by operation on GX
Works2.
*

Alternatively, selecting [Debug] → [Forced Input and Output Registration/Clear] to
forcibly turn ON/OFF external input and output.

Behaviors of devices at forced ON/OFF
Forced ON/OFF registration allows forced ON (Register Forced ON), forced OFF
(Register Forced OFF), and clear of forced ON/OFF (Clear Registration).
The behaviors of devices at forced ON, forced OFF, clear of forced ON/OFF are
shown below.
Operation
At clear (no operation)

Behavior of input (X)
Executes operations of sequence
programs by external input.

ON

Processes operations of sequence
programs in the forced ON status.

OFF

Processes operations of sequence
programs in the forced OFF status.

Behavior of output (Y)
Externally outputs operation results of
sequence programs.
Externally outputs "ON" regardless of
operation
results
of
sequence
programs.
Externally outputs "OFF" regardless of
operation
results
of
sequence
programs.

The behaviors of devices forcibly turned ON/OFF are shown below.

Forced ON/OFF operation for output

Output refresh
Input refresh
Forced ON/OFF operation for input

Y10 device forced OFF

Y10 output
(OFF)
X0 input
(ON)
X0 device forced OFF

Sequence execution

M0
Y10
X0

External input performs
forced OFF operation

Y11

Y10
It turns on on the ladder even if it is
turned OFF forcibly (external output
is off)
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M1
END

External output

(Y10 OFF)

External input

(X0 ON)

Checking the forced ON/OFF and clear status
The statuses of forced ON/OFF and ON/OFF inversion can be checked on GX
Works2.
When at least one device is registered in "Forced Input Output Registration/Clear", the
status can be checked by the MODE LED. (The MODE LED flashes.)
In the case of Universal model QCPU, the status can be checked by a special register
(SD849).
Forced ON/OFF registrations can be cleared by any of the following operations.
 Power-on → Power-off
 Reset by RESET/L.CLR switch or RUN/STOP/RESET switch of the CPU module
 Reset by remote reset operation
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(1) Setting
1)

Switch GX Works2 to the monitoring mode.

2)

Click "Debug" → "Forced Input Output
Registration/Cancellation" on the menu bar.

3)

Input "XD" in the Device field and click the
"Register Forced ON" button.
The device XD is in ON status regardless of
ON/OFF status of the external input XD.

6 - 110

4)

Input "Y79" in the Device field and click the
"Register Forced ON" button.
The device Y79 is in ON status regardless of
operation result of the device Y79.
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5)

Check that the MODE LED of the CPU is
flashing.

6)

Click the "Batch Clear Registration" button.

7)

Check that the MODE LED of the CPU is
turned ON.

6.12.14 Sequence Program

Sequence program
Operation failure due to duplicated coil

Jump destination error in use of CJ instruction

BCD code error

BCD instruction error to minus data

How to use failure detection annunciators (F)

Operation mode setting when there is an error
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Sequence program
Error check and error clean from a program using SM and SD

Forced ON/OFF function for external I/O
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Chapter 7 Improvement Maintenance
In order to improve serviceability of production systems, it is necessary to reduce
deterioration of equipment and make maintenance work easier.
7.1 Equipment Serviceability Improvement
(1) Improvement for reducing deterioration of equipment
1) Review the working environment and carry out improvements such as
provision of ventilation and air-conditioning so that the equipment does not
deteriorate abnormally.
2) Carry out improvements for preventing abnormal deterioration of equipment by
taking dust-proof, moisture-proof, and anti-vibration measures.
3) Replace any equipment estimated to deteriorate faster with ones with higher
durability.
(2) Carry out improvement to make repair easier
1) Improve the equipment structure.
2) Carry out improvements to secure a repair space.
3) Change to products that can be easily repaired.
(3) Change to products with fewer failures
(1)
Change to products with a low failure rate and high reliability.
7.2 Improving Automatic Detection of Equipment Failure
(1) Detection with sequence programs
Change sequence programs so that equipment failures can be detected
automatically.
<Program example>
When an LS configured at the limit end is a normally closed contact, an
equipment failure is automatically detected with the following ladder because the
forward end LS and the backward end LS cannot be non-conductive at the same
time.
Advance Advance
command end LS

Y71

Backward Backward
command end LS

Y70

Advance
end LS

Backward
SM412 (1 second clock)
end LS
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Advance
output
Y70
Backward
output
Y71

Equipment failure
detection

Y73

7

7.3 Enhanced Condition Monitoring-based Maintenance
This section introduces four examples that automatically display or notify of error
definitions to improve the function always monitoring the status of the equipment
controlled by the programmable controller.
Example 1 Displays detected error descriptions in a character message
Connect the GOT to the programmable controller and display a message
corresponding to detected error descriptions.

Character
display

GOT

Error
occurred!
No.1

95

No.2

58

Messages registered in advance are
displayed for each error detection
signal and error code number.

Error 1 detected
Error 2 detected

Example 2 Announces voice message of detected error descriptions
Voice
announce
ment

Connect the GOT to the programmable controller and announce voice messages,
etc. that have been prerecoded using a microphone from a speaker when an
error is detected. (A voice output module and external amplifier speaker are
separately required.)
GOT

External
amplifier speaker

Error
occurred!
No.1

95

No.2

58

Error is detected!
Investigate the
error.

Messages registered in advance are
announced from a speaker for each
error detection signal and error code
number.

Error 1 detected
Error 2 detected
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Example 3 Prints out detected error descriptions
Printing

Connect a printer to a programmable controller unit that enables the print output
and print out error messages and error times.

Printer

F us

'04-

e bl

04-0

own

1

Error detection
A message is printed out

Program to print out a
message

The MELSEC-Q offers various types of intelligent function modules and GOTs that can
be connected to a printer.
Modules that enable the print output
QJ71C24(N) serial communication
QJ71C24(N)-R2 serial communication
QD51 serial communication
QD51-R24 intelligent communication
GOT1000 series (GT15-PRN)
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Printer type
RS-232C compliant
PictBridge-compatible printer

Example 4 Sends detected error descriptions by email
E-mail

Connect an Internet connectable network cable to the Web server module of the
programmable controller and send detected error contents to cellular phones and
personal computers by e-mail.

E-mail is sent when
an error is detected

Error is detected!
The temperature
has become higher
than the specified
value.

Internet

A web server module
monitors collected data

It is also possible to monitor device data, etc. collected by the Web server module
on the cellular phones and personal computers via the Internet.
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Chapter 8 Reviewing Installation Environment
8.1 Environment
Install the programmable controller while avoiding the following environments:
(1) Location where the ambient temperature (for a panel, in-panel temperature)
exceeds the range of 0 to 55°C
(2) Location where the ambient humidity exceeds the range of 5 to 95% RH
(3) Location where a sudden change in temperature causes condensation
(4) Location where there is corrosive gases or combustible gases
(5) Location where there are many or much conductive powders such as dust
and iron powders, oil mist, sodium, or organic solvent(s)
(6) Location which receives direct sunlight
(7) Location where a high electric or magnetic field is generated
(8) Location where a vibration or shock can be transmitted directly to the main
unit
8.2 Electrical Environment
(1) The fluctuation range of power supply 100 V AC or 200 V AC shall be within a
range of -15% to +10%.
(For 24 V DC (Q63P), it shall be within a range of -35% to +30%.)
(2) Instantaneous power failure
If it lasts for 20 ms or shorter, the operation can continue.
(For 24 V DC (Q63P), if it lasts for 10 ms or shorter, the operation can
continue.)
(3) Power supply waveform distortion
It shall be a sine wave and its distortion rate shall be within 5%. Take heed of
an electric power capacitor and rectifier.
(4) Wire it as far from a power cable and large-current wire as possible.
The distance when they are placed in parallel shall be 100 mm or more.
(5) Do not place it in a panel containing a noise generating equipment, too.
Install a high frequency equipment, inverter, and electric discharge machine
in a separate panel as far as possible. Separate the wiring.
(6) Install it as far from the equipment generating an arc when it is opened and
closed, such as an electromagnetic contactor and breaker, as possible.
Figure 8-1 Layout in the Control Panel
Power supply
Programmable
controller

Branch
breaker
Output

Input

Auxiliary relay

Main circuit parts
Main
such as an
circuit
electromagnetic
breaker
contactor

Junction terminals
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8.3 Mounting Condition
This section describes the installation precautions and installation position of the
programmable controller.
When installing a programmable controller in a panel, fully consider the usability,
maintainability, and environmental resistance.
(1) Module mounting position
To improve the ventilation and facilitate the module replacement, maintain the
following distance between the top/bottom of the module and the structure or
parts.
(a) For the main base unit and extension base unit
Position of the ceiling of an
enclosure, a wiring duct, or a part.

30 mm or
more *1

Programmable
controller

Door

Enclosure

30 mm or
more *1

5 mm or more *2

20 mm or
more *3

5 mm or more

*1: This applies if the height of the wiring duct is 50 mm or lower. Otherwise, the
distance shall be 40 mm or more.
*2: When mounting an extension cable without removing an adjacent module,
the distance shall be 20 mm or more.
*3: For the connector type, the distance shall be 80 mm or more.
For a network module, maintain the distance considering the F-type
connector or cable bending radii.
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(b) For the slim type main base unit
Position of the ceiling of an
enclosure, a wiring duct, or a part.

30 mm or
more *1

Programmable
controller

Enclosure

30 mm or
more *1

17 mm or more *2

Door

20 mm or
more *3

5 mm or more

*1: This applies if the height of the wiring duct is 50 mm or lower. Otherwise, the
distance shall be 40 mm or more.
*2: The slim type main base unit will have the wiring of the power supply module
come out from the left end of the module. To reserve wiring space, install the
unit apart from the end by 17 mm or more. Additionally, if the structure,
equipment, or part on the left side of the unit can damage the coating of
electric wires, protect them with insulators such as a spiral tube.
*3: For the connector type, the distance shall be 80 mm or more.
For a network module, maintain the distance considering the F-type
connector or cable bending radii.
(2) Module mounting direction
(a) For heat dissipation, use the programmable controller in the mounting
direction shown in the following figure, which ventilates the controller well.

(b) Do not use the module in the mounting direction in the following figure.

Vertical mounting

Horizontal mounting
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(3) Installation surface
Install the base unit on a flat surface.
The uneven installation surface will apply an excessive force to the printed-circuit
board, causing trouble.
(4) Coexistence with other equipment
Avoid the co-existence with sources of vibration such as a large electromagnetic
contactor and fuse circuit breaker, and install the base unit in another panel or
apart from them.
(5) Distances from other instruments
To avoid the impact of radiation noise and heat, maintain the following distance
between the programmable controller and instruments (contactors and relays).
 From instruments mounted on the front side of the programmable controller:
100 mm or more
 From instruments mounted on the right and left sides of the programmable
controller: 50 mm or more

50 mm or more

100 mm or more

50 mm or more

Conductor, relay, etc.

8-4

8.4 Wiring
8.4.1 Wiring Precautions

WARNING

CAUTION

● Be sure to switch off all phases of the external power supply
used by the system before wiring work. Failure to do so may
cause electric shock or damage the product.
● When turning on the power and operating the module after
wiring is completed, always attach the enclosed terminal cover.
The absence of the terminal cover can cause electric shock.
● Be sure to ground the FG and LG terminals of the programmable
controller with the ground resistance of 100Ω or less for the
exclusive use. Failure to do so may cause electric shock or
malfunction.
● Before wiring the module, confirm the rated voltage and terminal
layout of the product to wire correctly.
Input of voltage or connection to a power supply with different
ratings, or incorrect wiring of them may cause fire or failure.
● Crimp or solder external connectors correctly using tools
specified by the manufacturer.
Incomplete connection may cause short-circuit, fire, or
malfunction.
● Tighten the terminal screws within the specified torque range.
A terminal screw that has been tightened too loosely may cause
short-circuit, fire, or malfunction.
A terminal screw that has been tightened too tightly may cause a
drop, short-circuit, or malfunction due to the screw or module
breakage.
● Be careful to prevent foreign matter such as sawdust or wiring
chips from entering the module.
Failure to do so may cause fire, failure, or malfunction.
● The top surface of the module is covered with protective film to
prevent foreign matter such as wiring chips from entering the
module when wiring.
Do not remove this film during wiring.
Before operating the system, be sure to remove this film to
dissipate heat.

The following description is of the precautions for wiring power cables.
(1) Wiring the power supply
(a) Wire the programmable controller power supply, I/O equipment, and motor
equipment in different systems as follows:
When there are many noises, connect an isolation transformer.
Programmable Isolation
controller transformer
Main power supply power supply
200 V AC

Programmable
controller

T1
I/O power supply

I/O equipment
Main circuit equipment
Main circuit
equipment
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(b) Do not connect the 24 V DC outputs of multiple power supply modules in
parallel to supply the outputs to one I/O module.
Parallel connection may break down the power supply module.
Power supply module

Power supply module

I/O module

I/O module

24 V DC

24 V DC

24 V DC

External
power supply

(c) Twist 100 V AC wire, 200 V AC wire, and 24 V DC wire as closely as
possible, and use them to connect modules in the shortest distance.
2
Also, use as thick a wire (MAX. 2 mm ) as possible to lessen the voltage
drop.
(d) Do no bundle or adjacently place the100 V AC wire and 24 V DC wire with
the main circuit (high voltage, large current) wire and I/O signal line. Keep a
distance of approximately 100 mm or more between them.
(e) As a measure against surge for lightening, connect the surge absorber for
lightening as shown in the following figure.
Programmable
controller I/O
equipment

AC

E2
E1

Surge absorber for
←
lightening

POINT
(1) Separately ground the surge absorber for lightening (E1) and the
programmable controller (E2).
(2) Select a surge absorber for lightening that would not exceed its maximum
allowable circuit voltage even when line voltage is maximum.
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(2) Wiring the I/O equipment
(a) The solderless terminal with an insulation sleeve cannot be used in the
terminal block.
It is recommended to put a mark tube or insulation tube on the cable
connection part of a solderless terminal.
(b) For a cable connected to the terminal block, use a cable having a core of 0.3
2
2
mm to 0.75 mm and outer diameter of 2.8mm or less.
(c) Set up a wiring route separately from the I/O cables and output cables.
(d) When those cables cannot be separated from the main circuit line or power
cable, use the batch shield cable and ground it on the programmable
controller side.
However, in some cases, ground it on the opposite side.
Programmable controller

Shielded cable

Input
Output

Shield coating

RA

DC

(e) When piping and wiring, ground the pipes securely.
(f)

Separate the 24 V DC input wire from the 100/200 V AC wires.

(g) The long distance wiring of 200 m or more causes trouble caused by a
leakage current due to the line capacity.
(h) Provide a means of using a switch to individually disconnect an external
power supply of a module relevant for the online module change, in order to
avoid electric shock or malfunction of an operating module.
(3) Grounding
For grounding, perform steps (a) to (c) below:
(a) Use the independent grounding as much as possible.
Ground with the grounding resistance of 100 Ω or less.
(b) If the independent grounding cannot be performed, conduct "(2) Shared
grounding" in the following figure.

Programmable
controller

Another device

Programmable
controller

Another device

Ground resistance
of 100 Ω or less

Ground resistance
of 100 Ω or less

(1) Independent grounding......Ideal

Programmable
controller

Another device

(2) Shared grounding......Acceptable

(3) Common grounding......Not acceptable

2

(c) Use cables with a cross-sectional area of 2 mm or thicker for grounding.
Set the grounding point as close to this programmable controller as possible,
and shorten the length of the ground cable.
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8.4.2 Wiring Power Supply Module
This section illustrates wiring examples of the power cables and ground cables, etc.
used to connect the main base unit and extension base unit.
(1) For a stand-alone power system
100/110 V AC

Main base unit
(Q38B)
CPU module

Fuse

24 V DC

Connect to the 24 V DC
terminal of modules that
require 24 V DC inside
of the I/O module

Extension base unit
(Q68B)

Extension cable

I/O module

100 V AC

Ground cable
Grounding
*1: The following is the operation of the ERR terminal.
<When a power supply module is mounted to a main base unit>
It turns OFF (opens) when an AC power is not supplied, when a CPU module stop error (including reset) occurs,
or when the fuse of the power supply module is blown.
<When a power supply module is mounted to a extension base unit>
It is alway OFF (open).
*2: Short-circuit between the LG and FG terminals using a ground cable as thick and short as possible (Ø2 mm),
and ground it.

POINT
(1) The power cables for 100/200 V AC and 24 V DC shall be as thick cables as
possible (a maximum of 2 mm2) and shall be twisted from a cable connected
terminal. For the terminal block wiring, be sure to use solderless terminals. Use
the solderless terminal with an insulation sleeve that has a thickness of 0.8 mm
or less in order to prevent short-circuit when screws get loosened. In addition,
connect up to two solderless terminals for one terminal area.
Solderless
terminal with an
insulation sleeve

Terminal block

(2) If the LG terminal is connected to the FG terminal, do not forget to perform
grounding. If the grounding is not performed, the system will be susceptible to
noise. Because the LG terminal has half as high a potential as the input
voltage, touching the terminal area may cause electric shock.
(3) The ERR terminal on the extension base unit cannot detect errors from the
system. (The ERR terminal is always turned OFF.)

8-8

(2) For a redundant power supply system
System A System B

Redundant power main base unit
電源二重化基本ベースユニット
(Q38RB)
CPU module

Redundant
power extension base unit
電源二重化増設ベースユニット
(Q68RB)

Extension
cable
増設ケーブル

入出力ユニット
I/O module

Ground
cable
接地線
Grounding
接地

Ground接地線
cable
Grounding
接地

is the operation of the ERR terminal.
＊*2:
2 The
ERRfollowing
端子の動作は以下のとおりです。
<When
a redundant power supply module is mounted to a redundant power main base unit>
＜電源二重化基本ベースユニットに二重化電源ユニットを装着した場合＞
ItAC
turns
OFF (opens) when
the AC power is not supplied, when a CPU module stop error (including reset) occurs,
電源未入力時，CP
U ユニット停止エラー（リセット時を含む）発生時，二重化電源ユニットのヒューズ断時，ま
when
the fuse of the redundant power
supply
module is blown, or when redundant power supply module failure
たは二重化電源ユニット故障時に
OFF（開
放）となります。
occurs.
＜電源二重化増設ベースユニットに二重化電源ユニットを装着した場合＞
<When
a redundant power supply module is mounted to a redundant power extension baseOunit>
AC 電源未入力時，二重化電源ユニットのヒューズ断時，または二重化電源ユニット故障時に
FF（開 放）となりま
Itす。
turns OFF (opens) when the AC power is not supplied, when the fuse of the redundant power supply module is
or when redundant power supply module failure occurs.
＊ 3 blown,
電源二重化基本ベースユニットに装着した二重化電源ユニットと電源二重化増設ベースユニットに装着した二重化電
*3: When
both
input powers of the redundant power supply modules mounted on theER
redundant
main base
ON（短絡）タイミン
源ユニットの入力電源を同時に供給した場合，電源二重化基本ベースユニット上の
R 端子のpower
unit
and the
type extension base unit are supplied simultaneously, the ONERR
(short-circuit)
timing
of the
グは，CP
U redundant
ユニットのイニシャル処理時間の分，電源二重化増設ベースユニット上の
端子の ON（短
絡）より
ERR
terminal
on
the
redundant
power
main
base
unit
is
delayed
from
that
of
the
redundant
type
extension
base
遅くなります。
unit by the time of the initial processing of the CPU module.
＊ 4 LG 端子と FG 端子は可能な限り太く短い接地線（φ2mm）で 短絡し，必ず接地してください。
*4: Short-circuit between the LG and FG terminals using a ground cable as thick and short as possible (Ø2 mm),
and ground it.
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POINT
(1) The power cables for 100/200 V AC and 24 V DC shall be as thick cables as
possible (a maximum of 2 mm2) and shall be twisted from a cable connected
terminal.
For the terminal block wiring, be sure to use solderless terminals.
Use the solderless terminal with an insulation sleeve that has a thickness of
0.8 mm or less in order to prevent short-circuit when screws get loosened.
In addition, connect up to two solderless terminals for one terminal area.
Solderless
terminal with an
insulation sleeve

Terminal block

(2) Supply the power to the redundant power supply modules via respective
systems (duplicate the power system).
(3) If two redundant power supply modules (Q64RP) are operated in parallel as a
redundant power supply system, it is recommended to use one redundant
power supply module to input the AC power supply and the other to connect an
uninterruptible power supply (UPS).
(4) If the LG terminal is connected to the FG terminal, do not forget to perform
grounding.
If the grounding is not performed, the system will be susceptible to noise.
Because LG terminal has half as high a potential as the input voltage, touching
the terminal area may cause electric shock.
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Chapter 9 Measures against Noise
9.1 Common Mode Noise and Normal Mode Noise
The causes of troubles occurring while operating the programmable controller include
malfunction and stop due to noise.
Measures against noise are essential to maintenance of the programmable controller.
In general, the common mode noise impacts the programmable controller more
significantly than normal mode noise. This is because the normal mode noise is line
noise that can be filtered out while the common mode noise depends on the floating
capacitance that disables it to be easily filtered out. It is also because the measures
against normal mode noise can be taken even by the user while common mode noise
immunity is a feature that the manufacturer built in, which the user cannot take an
effective measure against the actual programmable controller.
9.2 Common Mode Noise
The following figure illustrates the concept of common mode noise.
Programmable controller
Cs
Input

Cs

Internal
Cs

Power supply

circuit
Output

L

Cs

Grounding
Noise source

Noise source
Cs: Floating capacitance

Figure 9-1 Common Mode Noise
Common mode noise may cause malfunctions when the internal circuit is affected by a
potential different generated between the grounding (ground) and the power supply or
the I/O signal wire due to noise induced from other wires to each wire, induced voltage
with high potential, radio waves, or static electricity.
This is because the floating capacitance between each external signal and the internal
circuit causes electric charge and discharge, resulting in sudden changes in the
internal circuit voltage.
Programmable controllers with a metal case is said to be more susceptible to common
mode noise due to floating capacitance Cs.
In addition, grounding is important because it is also a measure against common mode
noise.
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9.3 Normal Mode Noise
The following figure illustrates the idea of normal mode noise.
Programmable controller

Input

Noise source

Power supply
L

Noise source
Output

Noise source

Grounding

Figure 9-2 Normal mode noise
Most of normal mode noise is generated by the back EMF of inductive load applied to
the power supply, input and output cables. For a power supply, normal mode noise is
generated from the instrument connected to the power supply system. On the other
hand, for an output cable, normal mode noise is generated from the instrument
controlled by the programmable controller. All these noises are also referred to as line
noises, too.
Consequently, the user can easily take measures against this noise such as
suppressing it in the instrument generating the noise, filtering it out in the programmable
controller, and installing a transformer and surge (noise) suppressor.
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9.4 Measures against Noise in External Input Signal CableH
(1) When an inductive load is connected in parallel with the input module of a
programmable controller, as in the following figure, connect a CR surge suppressor
for alternating current input and a flywheel diode for direct current input, both in
parallel with each load. Connect the surge suppressor as close to the inductive
load as possible.
Programmable controller

Programmable controller

Input

Input

L Load

L Load

C
R

Common
AC
CR: Surge suppressor

D
Common

DC
D: Flywheel diode

(1) AC input

(2) DC input

Figure 9-3 When There Is an Inductive Load in Parallel with Input
(2) In the following cases, take measures against induced voltages as in the figure
below:
 When an external wiring is 200 m or more long
 When a built-in operation indication neon lamp or an opened contact of a limit
switch generate a voltage because of the current of the neon lamp
 When an induced voltage is high for alternating current input signal
Programmable controller

Programmable controller

Input

Input

Programmable controller
RA
Input
RA

AC Z

AC

Common

Z: Dummy resistor or CR
surge suppressor

DC

(1) Input power supply DC
conversion

(2) Connection of dummy
resistor or CR surge
suppressor

Common

AC

RA: Auxiliary relay
(3) Making a relay circuit
using a relay

Figure 9-4 Measures against an Induced Voltage for Input

9-3

9.5 Measures against Noise in External Output Signal Cable
(1) For an inductive load for an alternating current, connect a CR surge suppressor to
the both ends of the load, because noise is generated by an inrush current when
an output signal is turned OFF and ON and by back EMF when the signal is turned
ON and OFF and because arc noise is generated by a contact such as an
electromagnetic contactor.
Use a CR surge suppressor with 0.5 μF + 47 Ω if its specifications are up to about
400 VA for 100/200 V AC. This CR surge suppressor will not be effective unless it
is connected most close to the load.
Programmable controller

R 47Ω
AC

L Load

C 0.47μF

Output

Place CR near the load

Figure 9-5 Measures against Noise in Alternate Current Inductive Load
(2) For a direct current inductive load, connect flywheel diodes across the load. Ensure
to connect these diodes most close to the load. The diodes should have four or
more times as high a reverse breakdown voltage as the load voltage.
Connecting flywheel diodes to the direct current inductive load causes the load
operation to be delayed due to the current flowing through the diodes during
shutdown. When this delay matters, connect a CR surge suppressor as in the
alternate current measures described above.
Programmable controller

DC

L Load

D

Output

Place D near the load

Figure 9-6 Measures against Noise in Direct Current Inductive Load
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(3) When an external contact opens and closes a load connected to programmable
controller output, ensure to take the measures in the following figure, whether or
not the programmable controller provides measures against noise.
Programmable controller

Programmable controller

LS (external contact)

LS (external contact)

R

D

L Load

L Load

C

DC

AC

(1) For AC

(2) For DC

Figure 9-7 When an External Contact Opens and Closes a Load
(4) For an alternating current inductive load where a large amount of noise is
generated during shutdown, effective will be the opening and closing of it at a triac
that will be shut down by the load current.
(5) For arc noise when opening and closing the contact of an electromagnetic
contactor, it would be effective to connect a CR surge suppressor across the
contact. Note that, even when the contact is opened, the CR surge suppressor
circuit causes a leakage current (part (A) in Figure 9-8).
(6) When the shutdown noise of a motor or transformer matters, connect a CR surge
suppressor between phases (part (B) in Figure 9-8).
Measures against arc noise (A)

MC

Programmable
controller output

C

R

C

R

C

R

C
R
C

C

R

R

M

Measures against break noise (B)

MC

Figure 9-8 Measures against Noise in a High Capacity Load
(7) Relaying in a panel is also effective.
It is desirable to relay those specific outputs of a programmable controller which
generate a large amount of noise.

Output

RA

AC

L Load

Programmable controller

RA
AC

Figure 9-9 Relay-based Load Driving
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9.6 Measures against Noise Troubles
When a control trouble occurs, if the following is the case, the possible cause would be
an external noise.
Figure 9-1 Measures against Noise Troubles

(1) When noise is
generated in
sync with the
behavior of a
specific
output
equipment

(2) When noise is
generated in
sync with the
behavior of an
instrument
irrelevant for
the
programmable
controller
(3) When noise
occurs in
applying a
high capacity
load
(4) When the
behavior of the
programmable
controller is
unstable at
random
(5) When the
induced
voltage of an
input is high

(6) Others

1) Noise or surge from output equipment are considered as the major
cause. When the instrument is turned ON and OFF, this trouble
always or sometimes occurs and the programmable controller
stops.
In such cases, measures in Figure 9-5 and 9-6 are usually effective
as measures against noise. A surge suppressor and diode are not
effective unless they are connected most close to the load. Note
that, for a high capacity load, take measures described in Figure
9-8.
2) Possible troubles occurring in sync with the behavior of the
instrument include bad connection such as disconnection and
slackness of an input cable and bad electrical contact of input
equipment. Conduct an inspection thoroughly.
1) Such noise is caused by noise or surge from another instrument.
Thus, conduct the same measures as for item "(1)" above.
2) Try out measures such as grounding when using the instrument
without grounding it and changing to non-grounding when using it by
grounding it, set an I/O signal wire apart from the cable laying of the
corresponding equipment, or consider the route.

1) Possible causes include the reduction of the power supply voltage
and the rise of the ground potential of shared grounding.
If the power supply voltage is reduced to lower than the prescribed
value when the load is applied, add a constant-voltage transformer
in the power supply and change the power supply systems.
2) When grounding has been done, ungrounding may be an alternative
measure.
1) Either in the event of frequent instantaneous power failures of the
power supply, when the waveform is significantly poor, or when
there are many power supply noises, it would be effective to add a
constant-voltage or only an isolation transformer.
2) When there is impact of a high frequency equipment, ensure to
ground the high frequency equipment and the programmable
controller storage panel and shield the I/O signal wire of the
programmable controller.
1) The programmable controller will not stop, resulting in false input
causing faulty output. Even if the induced voltage is low, it is
overlapped with noise, and results to false input.
In that case, take the measures described in Figure 9-3.
1) Noise from the ignition system of a forklift: Occurs when a car
passes by.
2) Noise affected by radio wave: Occurs when a door of the control
panel is opened.
3) Noise generated by radio wave: Occurs when a transceiver or
cellular phone are used.

The above measures taken against the noise troubles of the programmable controller
should have been conducted when producing a panel or during external wiring
construction, in order to reduce the costs. During a system is designed using a
programmable controller, the designer should have considered which measure to
take,
The designer also must check whether the taken measure is really effective when a
trouble occurs, by reproducing the same trouble and omitting that measure.
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9.7 Procedure for Noise Measurement
This section describes the measurement procedures of noise and items related to
programmable controller power supply 100/200 V AC systems / 24/5 V DC systems.

Type

System

Table 9-2 Noise Measurement of 100/200 V AC Systems
Item
Voltage

Waveform

Measuring
point
Input terminals
of
programmable
controller
power supply
module
(e.g. Q61)

100/200 V AC systems

Noise

Against FG terminal

Noise

Must be within
the input
voltage range

Digital voltmeter

100 V system
85 to 132 V
200 V system
170 to 264 V

Must be a
waveform
similar to a sine
wave

Synchroscope
Digital scope
Memory high
coder
(for observing
repeatedly)
+
high-pressure
probe (for 200
V system and
noise
observation)

No fluctuation
for 85 to 132
V of peak
voltage
Distortion
factor must
be 5% or less
Must be
between 47.5
Hz and 63 Hz
and have no
significant
fluctuation

Key point

No momentary
power
failure/sag

Momentary
power failure
Momentary
power sag
Waveform

Judgment
level

Must be
successfully
observed with
waveforms
stabilized, using
the same
trigger
No periodic or
temporary
noise must be
observed

Line

Period

Measuring
instrument

One end (with
higher voltage)
of input
terminal and
FG terminal

Must be a
waveform
similar to a sine
wave

No periodic or
temporary
noise must be
observed
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-1500 to 1500
V,
1 μs or less

20 ms or less
No fluctuation
for 85 to 132
V of peak
voltage
Distortion
factor must
be 5% or less
-1500 to 1500
V,
1 μs or less

Actual
measurement
value

Check

Type

System

Table 9-3 Noise Measurement of 24 V DC System
Item
Voltage

24 V DC system

Line

Waveform

Measuring
point
Input terminals
of the module
When
unmeasurable,
use junction
terminals
or power
supply output
terminals

Noise

Against FG terminal

Must be within
the voltage
range of the
module

Digital
voltmeter

Must be within
the voltage
range of the
module

Synchroscope
Digital scope
Memory high
coder +
high-pressure
probe

No periodic or
temporary noise
must be
observed
Overshoot and
undershoot
when turned ON
and OFF must
be within the
voltage range of
the module
No momentary
power
failure/sag

Rise
Fall

Momentary
power failure
Momentary
power sag
Waveform

Key point

Measuring
instrument

Point of +24 V
and against
FG terminal

Actual
measurement
value

Check

Actual
measurement
value

Check

For Q63P:
15.6 to 31.2 V
For an I/O
module:
Example)
QX41
10.2 to 26.4 V
Same as the
judgment
level of the
voltage
Must have little
fluctuation
-750 to 750 V,
1 μs or less
Same as the
judgment
level of the
voltage

0 ms except
for specifically
disallowed
modules
Same as the
judgment
level of the
voltage
Must have little
fluctuation
+/-750 V,
1 μs or less

Must be within
the voltage
range of the
module
No periodic or
temporary noise
must be
observed

Noise

Judgment
level

Type

System

Table 9-4 Noise Measurement of 5 V DC System
Item

Ripple
Line

5 V DC system

Voltage

Spike

Measuring
point
Base power
supply
Between slot
and extension
connector
Between 5 V
pin and SG pin

Key point

Measuring
instrument

Judgment
level

There is no
significant
voltage drop

Digital
voltmeter
Synchroscope

4.75 V
to 5.25 V

There is no
significant ripple

Synchroscope

300 mVpp
or lower
Refer to
Figure 9-10

There is no
significant spike
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Digital
scope
These should
be accessed
as needed
Probe
Within the AC
range

800 mVpp
or lower
Refer to
Figure 9-10

Type

System

Table 9-5 Ground Noise Measurement
Item

-

Between SG-FG

Noise

Measuring
point
FG terminal
and SG
terminal (GND
side of
measuring
points for 5 V
DC system)

Key point
Whether noise
from FG terminal
affects the inside
of the
programmable
controller

Measuring
instrument

Judgment
level

Synchroscope
/digital scope
Memory
high coder

10 Vpp or
lower
Even if lower
than this,
care must be
taken if it is
obviously
noise

Ripple
voltage

Spike
voltage

Figure 9-10 Ripple/Spike Waveforms
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Actual
measurement
value

Check

(3) Separating cables in the duct

(2) Ground cable dedicated to the programmable
controller

(1) Using different earthing cables

9.8 Solution Examples for Noise Troubles
Before improvement
The same cable is used as both a ground cable for
power and a ground cable for the programmable
controller and leads to power noise so as to make the
programmable controller malfunction during motor
operation.
Programmable
controller
FG

Programmable
controller

LG

FG

After improvement
The trouble was successfully solved by separating
the ground cable for power from that for the
programmable controller.
Programmable
controller
FG

Programmable
controller

LG

FG

LG

LG

FG

FG

Motor

Grounding

Motor

Grounding

Because an iron panel connects ground terminals A
and B, the ground cable of the programmable controller
has an impedance. As a result, the effect of the ground
cable is halved, causing the programmable controller to
malfunction.

Programmable
controller
FG
LG

Control
panel
(Made of
iron plates)

Programmable
controller
FG
LG

Control
panel
(Made of
iron plates)

The trouble was successfully solved by directly
grounding the ground cable for the programmable
controller.

B earth terminal

B earth terminal
A earth terminal

A earth terminal
Grounding

Grounding

The mix of the MELSECNET coaxial cables with the
power cables for the motor in the wiring duct causes
communication failures for MELSECNET.

The trouble was successfully solved by separating
the coaxial cables from the power cables in the
wiring duct.

Wiring duct

Coaxial
cable

Wiring duct

Power
cable

Coaxial
cable

Figure 9-11 Solution Examples 1, 2, and 3
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Power
cable

(4) Making signal wires into a twisted pair

Before improvement
The RS-232C cables can sometimes come close to the
power cables for the motor, causing the terminal CRT
screen to go out of control.
Terminal
Programmable controller

To terminal

To computer
link module
SD

RD

RD
RS-232C cable
Ground (FG)
MS

Power cable
Motor

Having bundled the primary winding and secondary
winding for the noise filter (LNF) leads power supply
noises to enter the programmable controller, thus
causing the controller to malfunction.
(5) Separating bundled wires

After improvement
The trouble was successfully solved by making all
the signal wires of the RS-232 cable and SG
terminal wires into twisted pairs.

SD

DSR

DTR

DTR

DSR

SG

SG

FG

FG

The trouble was successfully solved by setting the
bundled primary and secondary windings of the
noise filter (LNF) 10 cm or more apart from each
other, making them into a twisted pair, and
grounding the LNF.

100 V AC
100 V AC

NFB

Programmable controller

Programmable controller

NFB

Bundle

Separate

LNF

LNF

Make a twisted pair
cable

(6) Separating a control line from a power cable

Ground

Having housed the programmable controller I/O cable
and power cable in the same duct causes the controller
to malfunction.

The trouble was successfully solved by moving the
programmable controller I/O cable to a different
duct from that of the power cable.

Programmable
controller

Programmable
controller
I/O cable

Duct

NFB

Duct

NFB

Duct
Power cable
MS

Terminal block

MS

MS

RA

Duct

Terminal block

Figure 9-12 Solution Examples 4, 5, and 6
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MS

RA

(7) Filtering out static electricity noises
(8) Filtering out relay noises

Before improvement
When the static electricity electrified in the pallet was
discharged, the discharge noise affected the
MELSECNET coaxial cable, causing a communication
failure.

Pallet

Pallet

Workpiece

A place where static
electricity is discharged

Workpiece

Add discharge bars
Workpiece

Relay noises from the control line adjacent to the input
signal wire causes the programmable controller to
malfunction.
SG wire

Programmable
controller

Coaxial cable of MELSECNET

Coaxial cable of MELSECNET

Shield wire

Workpiece

Programmable
controller

OUT

The trouble was successfully solved by changing the
groundings of the shield wire into a single grounding.
OUT

Input signal wire

IN

IN

Grounding
Single grounding
Grounding

Double
grounding

Grounding

Grounding

Power noises from the main circuit line adjacent to the
input signal wire causes the programmable controller to
malfunction.
(9) Filtering out power noises

After improvement
The trouble was successfully solved by additionally
installing a discharge bar in the pallet and eliminating
the static electrification.

The trouble was successfully solved by changing the
shield wire to a change the shield wire to a magnetic
shielded wire.

Add a magnetic shield

SG wire

Input signal wire

OUT

IN

OUT

Grounding

IN

Shield wire
Grounding
Grounding

Figure 9-13 Solution Examples 7, 8, and 9
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Grounding

Grounding

Chapter 10: Life of Programmable Controller Components
This section describes the lives of a battery, fuse, electrolytic capacitor, and output
relay.
POINT
For the lives of a programmable controller CPU and a module, refer to Mitsubishi
programmable controller TECHNICAL BULLETIN "Recommendation on preventive
maintenance and inspection of MELSEC A/Q series programmable controllers"
(PLC-D-434-A).
The TECHNICAL BULLETIN described above can be found at the Mitsubishi
Electric FA Global Website.
(Mitsubishi Electric FA Global Website:
http://www.mitsubishielectric.co.jp/fa/index.html)
10.1 Battery Life
(1) Battery replacement
The voltage drop of the backup battery for the program function and backup power
function triggers special relays SM51 and SM52 to be turned ON. Though these
special relays being turned ON does not immediately cause the program content
saved by the backup power to be lost, missing the special relays being turned ON
may result in the contents being lost.
Replace the battery before the total backup power time since SM51 is turned ON
reaches the specified time.
POINT
SM51 turns ON when the battery voltage falls below the specified value and
maintains ON even after the battery voltage returns to normal. SM52 turns ON
when the battery voltage falls below the specified value and turns OFF when the
battery voltage returns to normal.
Replace the battery immediately after SM51 or SM52 turns ON.
However, it is recommended to replace the battery periodically according to the
usage status even before an alarm occurs.
SM51 and SM52 turn ON when any battery voltage for the CPU module and SRAM
card drops. To judge the memory battery of which voltage drops, check the
contents of special registers SD51 and SD52.
When the battery voltage for each memory drops, an SD51 or SD52 bit
corresponding to the memory turns ON.
Bit number of SD51 and SD52
Target memory
Bit 0
CPU module
Bit 1, 2
SRAM card

POINT
The following table explains the relationships of memory backup between a battery
mounted on the CPU module and that mounted on the SRAM card.
There are two points:
(1) The battery mounted on the CPU module cannot back up the SRAM card
memory.
(2) The battery mounted on the SRAM card memory cannot back up the CPU
module memory.
Power supply of
power supply
module

Battery of CPU
module
Connected

ON
Not connected
Connected
OFF
Not connected
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Battery of
SRAM card

Memory of
CPU module

Memory of
SRAM card



Mounted


Not mounted


Mounted


Not mounted


Mounted

Not mounted
×

Mounted
×
Not mounted
×
×
: Can be backed up ×: Cannot be backed up
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(2) Battery life
(a) Battery (Q6BAT, Q7BAT) life of the CPU module
The battery life depends on the serial number (the first five digits) and model
of the CPU module.
1) For the CPU modules whose the first five digits of the serial number are
"05011" or later
Battery life
Q6BAT
Model of CPU
module

Power-on
time ratio
*1

0%
30%
Q02CPU

50%
70%
100%
0%
30%

Q02HCPU
Q06HCPU

50%
70%
100%
0%
30%

Q12HCPU
Q25HCPU

50%
70%
100%
*1:

*2:
*3:

Guaranteed
value
(70°C)
*2

Actual value
(40°C)
*3

30,000 h
3.42 years
42,857 h
4.89 years
43,800 h
5.00 years
43,800 h
5.00 years
43,800 h
5.00 years
2,341 h
0.26 years
3,344 h
0.38 years
4,682 h
0.53 years
7,803 h
0.89 years
43,800 h
5.00 years
1,260 h
0.14 years
1,800 h
0.20 years
2,520 h
0.28 years
4,200 h
0.47 years
43,800 h
5.00 years

43,800 h
5.00 years
43,800 h
5.00 years
43,800 h
5.00 years
43,800 h
5.00 years
43,800 h
5.00 years
18,364 h
2.09 years
26,234 h
2.99 years
36,728 h
4.19 years
43,800 h
5.00 years
43,800 h
5.00 years
7,755 h
0.88 years
11,079 h
1.26 years
15,510 h
1.77 years
25,850 h
2.95 years
43,800 h
5.00 years

Q7BAT
Time since
SM52 is
turned ON
(guaranteed
time since
an alarm is
raised)
120 h
5 days
120 h
5 days
120 h
5 days
120 h
5 days
120 h
5 days
120 h
5 days
120 h
5 days
120 h
5 days
120 h
5 days
120 h
5 days
48 h
2 days
48 h
2 days
48 h
2 days
48 h
2 days
48 h
2 days

Guaranteed
value
(70°C)
*2

Actual value
(40°C)
*3

43,800 h
5.00 years
43,800 h
5.00 years
43,800 h
5.00 years
43,800 h
5.00 years
43,800 h
5.00 years
5,000 h
0.57 years
7,142 h
0.81 years
10,000 h
1.14 years
16,666 h
1.90 years
43,800 h
5.00 years
2,900 h
0.33 years
4,142 h
0.47 years
5,800 h
0.66 years
9,666 h
1.10 years
43,800 h
5.00 years

43,800 h
5.00 years
43,800 h
5.00 years
43,800 h
5.00 years
43,800 h
5.00 years
43,800 h
5.00 years
43,800 h
5.00 years
43,800 h
5.00 years
43,800 h
5.00 years
43,800 h
5.00 years
43,800 h
5.00 years
21,107 h
2.40 years
30,153 h
3.44 years
42,214 h
4.81 years
43,800 h
5.00 years
43,800 h
5.00 years

Time since
SM52 is
turned ON
(guaranteed
time since
an alarm is
raised)
240 h
10 days
240 h
10 days
240 h
10 days
240 h
10 days
240 h
10 days
240 h
10 days
240 h
10 days
240 h
10 days
240 h
10 days
240 h
10 days
96 h
4 days
96 h
4 days
96 h
4 days
96 h
4 days
96 h
4 days

The power-on time ratio indicates the percentage of the time per day (24 hours) while the
programmable controller power supply is turned ON.
(The power-on time ratio will be 50% if the total power-on time is 12 hours and the total power-off
time is 12 hours.)
The guaranteed values are the values when the storage ambient temperature is -25 to 75°C
(operating ambient temperature is 0 to 55°C).
The actual values are the values when the storage ambient temperature is 40°C (operating
ambient temperature is 25°C).
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2) For the CPU modules whose the first five digits of the serial number are
earlier than "05011".
Battery life
Q6BAT

Model of CPU
module

Q02CPU

Q02HCPU
Q06HCPU

Q12HCPU
Q25HCPU

Q7BAT
Time since
Time since
SM52 is
SM52 is
Guaranteed
Guaranteed
Actual value
turned ON
Actual value
turned ON
value
value
(40°C)
(guaranteed
(40°C)
(guaranteed
(70°C)
(70°C)
*3
time since
*3
time since
*2
*2
an alarm is
an alarm is
raised)
raised)
5,433 h
43,800 h
120 h
13,000 h
43,800 h
240 h
0%
0.62 years
5.00 years
5 days
1.48 years
5.00 years
10 days
7,761 h
43,800 h
120 h
18,571 h
43,800 h
240 h
30%
0.88 years
5.00 years
5 days
2.11 years
5.00 years
10 days
10,866 h
43,800 h
120 h
26,000 h
43,800 h
240 h
50%
1.24 years
5.00 years
5 days
2.96 years
5.00 years
10 days
18,110 h
43,800 h
120 h
43,333 h
43,800 h
240 h
70%
2.06 years
5.00 years
5 days
4.94 years
5.00 years
10 days
43,800 h
43,800 h
120 h
43,800 h
43,800 h
240 h
100%
5.00 years
5.00 years
5 days
5.00 years
5.00 years
10 days
2,341 h
14,550 h
120 h
5,000 h
38,881 h
240 h
0%
0.26 years
1.66 years
5 days
0.57 years
4.43 years
10 days
3,344 h
20,786 h
120 h
7,142 h
43,800 h
240 h
30%
0.38 years
2.37 years
5 days
0.81 years
5.00 years
10 days
4,682 h
29,100 h
120 h
10,000 h
43,800 h
240 h
50%
0.53 years
3.32 years
5 days
1.14 years
5.00 years
10 days
7,803 h
43,800 h
120 h
16,666 h
43,800 h
240 h
70%
0.89 years
5.00 years
5 days
1.90 years
5.00 years
10 days
43,800 h
43,800 h
120 h
43,800 h
43,800 h
240 h
100%
5.00 years
5.00 years
5 days
5.00 years
5.00 years
10 days
1,260 h
6,096 h
48 h
2,900 h
16,711 h
96 h
0%
0.14 years
0.69 years
2 days
0.33 years
1.90 years
4 days
1,800 h
8,709 h
48 h
4,142 h
23,873 h
96 h
30%
0.20 years
0.99 years
2 days
0.47 years
2.72 years
4 days
2,520 h
12,192 h
48 h
5,800 h
33,422 h
96 h
50%
0.28 years
1.39 years
2 days
0.66 years
3.81 years
4 days
4,200 h
20,320 h
48 h
9,666 h
43,800 h
96 h
70%
0.47 years
2.31 years
2 days
1.10 years
5.00 years
4 days
43,800 h
43,800 h
48 h
43,800 h
43,800 h
96 h
100%
5.00 years
5.00 years
2 days
5.00 years
5.00 years
4 days
*1: The power-on time ratio indicates the percentage of the time per day 24 hours) while the
programmable controller power supply is turned ON.
(The power-on time ratio will be 50% if the total power-on time is 12 hours and the total power-off
time is 12 hours.)
*2: The guaranteed values are the values when the storage ambient temperature is -25 to 75°C
(operating ambient temperature is 0 to 55°C).
*3: The actual values are the values when the storage ambient temperature is 40°C (operating
ambient temperature is 25°C).
Poweron
time ratio
*1

POINT
The life of batteries (Q6BAT, Q7BAT) when not connected to the CPU module is
five years.
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(a) Battery (Q6BAT, Q7BAT) life of Universal Model CPU modules
1) Other than QnUDVCPU, QnUDPVCPU
Battery life

Model of
CPU module

Q6BAT
Q7BAT
PowerTime since
Time since
Battery
on
SM52 is
SM52 is
usage
Guaranteed
Guaranteed
time ratio
Actual value turned ON
Actual value turned ON
frequency
value
value
*1
(40°C)
(guaranteed
(guaranteed
(40°C)
(70°C)
(70°C)
*3
time since an
time since an
*3
*2
*2
alarm is
alarm is
raised)
raised)

1

0%

30,100 h
3.44 years

30%

43,000 h
4.91 years

50%
70%

Q00U(J)CPU
Q01UCPU
Q02UCPU
Q03UD(E)CPU

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

100%

2

0%

25,300 h
2.89 years

30%

36,100 h
4.12 years

50%
70%

43,800 h
5.00 years

100%

1

0%

30,100 h
3.44 years

30%

43,000 h
4.91 years

50%
70%

43,800 h
5.00 years

100%
Q04UD(E)HCPU

2

0%

4,300 h
0.49 years

30%

6,100 h
0.70 years

50%

8,600 h
0.98 years

70%

14,300 h
1.63 years

100%

43,800 h
5.00 years

32,100 h
3.66 years

11,700 h
1.34 years
16,700 h
1.91 years

43,800 h
5.00 years

384 h
16 days

23,400 h
2.67 years
39,000 h
4.45 years
43,800 h
5.00 years
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Battery life

Model of
CPU module

Q6BAT
Q7BAT
PowerTime
since
Time since
Battery
on
SM52 is
SM52 is
usage
time ratio Guaranteed Actual value turned ON Guaranteed Actual value turned ON
frequency
value
value
*1
(40°C)
(40°C)
(guaranteed
(guaranteed
(70°C)
(70°C)
*3
*3
time since an
time since an
*2
*2
alarm is
alarm is
raised)
raised)

1

0%

25,300 h
2.89 years

30%

36,100 h
4.12 years

50%
70%

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

100%

2

0%

4,200 h
0.48 years

30%

6,000 h
0.68 years

50%

8,400 h
0.96 years

70%

14,000 h
1.60 years

100%

43,800 h
5.00 years

0%

2,300 h
0.26 years

19,200 h
2.19 years

5,000 h
0.57 years

30%

3,200 h
0.37 years

27,400 h
3.13 years

7,100 h
0.81 years

50%

4,600 h
0.53 years

38,400 h
4.38 years

70%

7,600 h
0.87 years

100%

43,800 h
5.00 years

Q06UD(E)HCPU

3

32,100 h
3.66 years

11,400 h
1.30 years
16,200 h
1.85 years

43,800 h
5.00 years

384 h
16 days

22,800 h
2.60 years
38,000 h
4.34 years
43,800 h
5.00 years

43,800 h
5.00 years
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192 h
8 days

10,000 h
1.14 years
16,600 h
1.89 years
43,800 h
5.00 years

Battery life

Model of
CPU module

Q6BAT
Q7BAT
PowerTime
since
Time since
Battery
on
SM52 is
SM52 is
usage
time ratio Guaranteed Actual value turned ON Guaranteed Actual value turned ON
frequency
value
value
*1
(40°C)
(40°C)
(guaranteed
(guaranteed
(70°C)
(70°C)
*3
*3
time since an
time since an
*2
*2
alarm is
alarm is
raised)
raised)

1

0%

22,600 h
2.58 years

30%

32,200 h
3.68 years

50%
70%

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

100%

2

Q10UD(E)HCPU
Q13UD(E)HCPU
Q20UD(E)HCPU
Q26UD(E)HCPU

3

4

0%

4,100 h
0.47 years

26,200 h
2.99 years

11,100 h
1.27 years

30%

5,800 h
0.66 years

37,400 h
4.27 years

15,800 h
1.80 years

50%

8,200 h
0.94 years

70%

13,600 h
1.55 years

100%

43,800 h
5.00 years

0%

2,300 h
0.26 years

18,600 h
2.12 years

5,000 h
0.57 years

30%

3,200 h
0.37 years

26,500 h
3.03 years

7,100 h
0.81 years

50%

4,600 h
0.53 years

37,200 h
4.25 years

70%

7,600 h
0.87 years

100%

43,800 h
5.00 years

0%

1,500 h
0.17 years

13,800 h
1.58 years

3,700 h
0.42 years

30%

2,100 h
0.24 year

19,700 h
2.25 years

5,200 h
0.59 years

50%

3,000 h
0.34 years

27,600 h
3.15 years

70%

5,000 h
0.57 years

100%

43,800 h
5.00 years

384 h
16 days
43,800 h
5.00 years

22,200 h
2.53 years
37,000 h
4.22 years
43,800 h
5.00 years

192 h
8 days

16,600 h
1.89 years

43,800 h
5.00 years

43,800 h
5.00 years
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10,000 h
1.14 years

43,800 h
5.00 years

144 h
6 days

7,400 h
0.84 years
12,300 h
1.40 years
43,800 h
5.00 years

36,100 h
4.12 years

43,800 h
5.00 years

432 h
18 days

Battery life

Model of
CPU module

Q6BAT
Q7BAT
PowerTime
since
Time since
Battery
on
SM52 is
SM52 is
usage
time ratio Guaranteed Actual value turned ON Guaranteed Actual value turned ON
frequency
value
value
*1
(40°C)
(40°C)
(guaranteed
(guaranteed
(70°C)
(70°C)
*3
*3
time since an
time since an
*2
*2
alarm is
alarm is
raised)
raised)
0%

19,000 h
2.16 years

30%

27,100 h
3.09 years

50%

38,000 h
4.33 years

1
70%
100%

2

Q50UDEHCPU
Q100UDEHCPU

3

4

5

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

0%

4,000 h
0.45 years

25,000 h
2.85 years

10,900 h
1.24 years

30%

5,700 h
0.65 year

35,700 h
4.07 years

15,500 h
1.76 years

50%

8,000 h
0.91 years

70%

13,300 h
1.51 years

100%

43,800 h
5.00 years

0%

2,200 h
0.25 years

18,000 h
2.05 years

4,900 h
0.55 years

30%

3,100 h
0.35 years

25,700 h
2.93 years

7,000 h
0.79 years

50%

4,400 h
0.50 years

36,000 h
4.10 years

70%

7,300 h
0.83 years

100%

43,800 h
5.00 years

0%

1,500 h
0.17 years

13,500 h
1.54 years

3,600 h
0.41 years

30%

2,100 h
0.24 years

19,200 h
2.19 years

5,100 h
0.58 years

50%

3,000 h
0.34 years

27,000 h
3.08 years

70%

5,000 h
0.57 years

100%

43,800 h
5.00 years

0%

1,160 h
0.13 years

10,800 h
1.23 years

2,700 h
0.30 years

30%

1,600 h
0.18 years

15,400 h
1.75 years

3,800 h
0.43 years

50%

2,300 h
0.26 years

21,600 h
2.46 years

70%

3,800 h
0.43 years

36,000 h
4.10 years

9,000 h
1.02 years

100%

43,800 h
5.00 years

36,000 h
4.10 years

43,800 h
5.00 years

384 h
16 days
43,800 h
5.00 years

21,800 h
2.48 years
36,300 h
4.14 years
43,800 h
5.00 years

192 h
8 days

16,300 h
1.86 years

43,800 h
5.00 years

43,800 h
5.00 years

144 h
6 days

7,200 h
0.82 years
12,000 h
1.36 years

43,800 h
5.00 years
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9,800 h
1.11 years

35,200 h
4.01 years

43,800 h
5.00 years

432 h
18 days

43,800 h
5.00 years

120 h
5 days

5,400 h
0.61 years

28,600 h
3.26 years

40,800 h
4.65 years

336 h
14 days

*1:

*2:
*3:

The power-on time ratio indicates the percentage of the time per day 24 hours) while the
programmable controller power supply is turned ON.
(The power-on time ratio will be 50% if the total power-on time is 12 hours and the total power-off
time is 12 hours.)
The guaranteed values are the values when the storage ambient temperature is -25 to 75°C
(operating ambient temperature is 0 to 55°C).
The actual values are the values when the storage ambient temperature is 40°C (operating
ambient temperature is 25°C).

POINT
The life of batteries (Q6BAT, Q7BAT) when not connected to the CPU module is
five years.
2) QnUDVCPU, QnUDPVCPU
The battery life varies by the power-on time ratio and whether an extended
SRAM cassette is used or not.
Battery life

Model of
CPU module

Usage of
extended
SRAM
cassette

Q6BAT
Power-on
time ratio
*1

0%
Unused

Guaranteed
value
(70°C)
*2

70%

Actual value
(40°C)
*3

Guaranteed
value
(70°C)
*2

Actual value
(40°C)
*3

Time since
SM52 is
turned ON
(guaranteed
time since an
alarm is
raised)

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

41,400 h
4.72 years

30%
50%

Q7BAT
Time since
SM52 is
turned ON
(guaranteed
time since
an alarm is
raised)

43,800 h
5.00 years

100%

Q4MCA1MBS

0%

26,600 h
3.03 years

30%

38,000 h
4.33 years

50%
70%

43,800 h
5.00 years

100%

Q4MCA2MBS
Q03UDVCPU

0%

23,100 h
2.63 years

30%

33,000 h
3.76 years

50%
70%

43,800 h
5.00 years

100%

Q4MCA4MBS

0%

17,400 h
1.98 years

30%

24,800 h
2.83 years

50%

34,800 h
3.97 years

70%
100%

Q4MCA8MBS

43,800 h
5.00 years

0%

11,000 h
1.25 years

28,500 h
3.25 years

30%

15,700 h
1.79 years

40,700 h
4.64 years

50%

22,000 h
2.51 years

70%

36,600 h
4.17 years

100%

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days
43,800 h
5.00 years
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Battery life

Model of
CPU module

Usage of
extended
SRAM
cassette

Q6BAT
Power-on
time ratio
*1

0%
Unused

Guaranteed
value
(70°C)
*2

70%

Actual value
(40°C)
*3

Guaranteed
value
(70°C)
*2

Actual value
(40°C)
*3

Time since
SM52 is
turned ON
(guaranteed
time since an
alarm is
raised)

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

31,700 h
3.61 years

30%
50%

Q7BAT
Time since
SM52 is
turned ON
(guaranteed
time since
an alarm is
raised)

43,800 h
5.00 years

100%

Q4MCA1MBS

0%

22,000 h
2.51 years

30%

31,400 h
3.58 years

50%
70%

43,800 h
5.00 years

100%

Q4MCA2MBS
Q04UDVCPU
Q04UDPVCPU

0%

19,600 h
2.23 years

30%

28,000 h
3.19 years

50%

39,200 h
4.47 years

70%

Q4MCA4MBS

100%

43,800 h
5.00 years

0%

15,300 h
1.74 years

30%

21,800 h
2.48 years

50%

30,600 h
3.49 years

70%

Q4MCA8MBS

36,600 h
4.17 years
43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

100%

43,800 h
5.00 years

0%

10,100 h
1.15 years

26,500 h
3.02 years

30%

14,400 h
1.64 years

37,800 h
4.31 years

50%

20,200 h
2.30 years

70%

33,600 h
3.83 years

100%

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days
43,800 h
5.00 years
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Battery life

Model of
CPU module

Usage of
extended
SRAM
cassette

Unused

Q6BAT
Power-on
time ratio
*1

Guaranteed
value
(70°C)
*2

0%

30,600 h
3.49 years

30%

43,700 h
4.98 years

50%
70%

Q7BAT

Actual value
(40°C)
*3

Time since
SM52 is
turned ON
(guaranteed
time since
an alarm is
raised)

Guaranteed
value
(70°C)
*2

Actual value
(40°C)
*3

Time since
SM52 is
turned ON
(guaranteed
time since an
alarm is
raised)

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

100%

Q4MCA1MBS

0%

21,500 h
2.45 years

30%

30,700 h
3.50 years

50%

43,000 h
4.90 years

70%
100%

Q06UDVCPU
Q06UDPVCPU
Q13UDVCPU
Q13UDPVCPU
Q26UDVCPU
Q26UDPVCPU

Q4MCA2MBS

0%

19,100 h
2.18 years

30%

27,200 h
3.10 years

50%

38,200 h
4.36 years

70%

Q4MCA4MBS

100%

43,800 h
5.00 years

0%

15,000 h
1.71 years

30%

21,400 h
2.44 years

50%

30,000 h
3.42 years

70%

Q4MCA8MBS

*1:

*2:
*3:

43,800 h
5.00 years
43,100 h
4.92 years
43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

36,200 h
4.13 years
43,800 h
5.00 years

600 h
25 days

43,800 h
5.00 years

100%

43,800 h
5.00 years

0%

10,000 h
1.14 years

24,800 h
2.83 years

30%

14,200 h
1.62 years

35,400 h
4.04 years

50%

20,000 h
2.28 years

70%

33,300 h
3.80 years

100%

43,800 h
5.00 years

43,800 h
5.00 years

600 h
25 days
43,800 h
5.00 years

The power-on time ratio indicates the percentage of the time per day 24 hours) while the
programmable controller power supply is turned ON.
(The power-on time ratio will be 50% if the total power-on time is 12 hours and the total power-off
time is 12 hours.)
The guaranteed values are the values when the storage ambient temperature is -25 to 75°C
(operating ambient temperature is 0 to 55°C).
The actual values are the values when the storage ambient temperature is 40°C (operating
ambient temperature is 25°C).

POINT
The life of batteries (Q6BAT, Q7BAT) when not connected to the CPU module is
five years.
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(c) Battery life of SRAM cards
Battery life of SRAM cards depends on the serial number (the first five digits)
and model of the memory card.
The following table describes the battery life of SRAM cards.
1) For the CPU modules whose the first five digits of the serial number are
"04012" or later
Battery life
SRAM card

Q2MEM-1MBS
manufacturer
control number
"A" *2

Power-on
time ratio
*1

0%
100%
0%

Q2MEM-1MBS
manufacturer
control number
"B" *2
or
"B" *2

30%
50%
70%

(B or later)

100%
0%
30%
Q2MEM-2MBS

50%
70%
100%
0%
30%

Q3MEM-4MBS

50%
70%
100%
0%
30%

Q3MEM-8MBS

50%
70%
100%

Guaranteed value
(MIN)

Actual value (TYP)

690 h
0.07 years
11,784 h
1.34 years
2,400 h
0.27 years
2,880 h
0.32 years
4,320 h
0.49 years
6,480 h
0.73 years
43,800 h
5.0 years
2,400 h
0.27 years
2,880 h
0.32 years
4,320 h
0.49 years
6,480 h
0.73 years
43,800 h
5.0 years
43,800 h
5.0 years
43,800 h
5.0 years
43,800 h
5.0 years
43,800 h
5.0 years
43,800 h
5.0 years
36,300 h
4.1 years
43,800 h
5.0 years
43,800 h
5.0 years
43,800 h
5.0 years
43,800 h
5.0 years

6,336 h
0.72 years
13,872 h
1.58 years
23,660 h
2.7 years
31,540 h
3.6 years
39,420 h
4.5 years
43,800 h
5.0 years
43,800 h
5.0 years
23,660 h
2.7 years
31,540 h
3.6 years
39,420 h
4.5 years
43,800 h
5.0 years
43,800 h
5.0 years
43,800 h
5.0 years
43,800 h
5.0 years
43,800 h
5.0 years
43,800 h
5.0 years
43,800 h
5.0 years
43,800 h
5.0 years
43,800 h
5.0 years
43,800 h
5.0 years
43,800 h
5.0 years
43,800 h
5.0 years
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Time since SM52 is
turned ON
(guaranteed time
since an alarm is
raised)
8h
8h
20 h
20 h
20 h
20 h
50 h
20 h
20 h
20 h
20 h
50 h
50 h
50 h
50 h
50 h
50 h
50 h
50 h
50 h
50 h
50 h

2) For the CPU modules whose the first five digits of the serial number are
"04011" or earlier
Battery life
Guaranteed value
(MIN)

Actual value
(TYP)

Time since SM52 is
turned ON
(guaranteed time
since an alarm is
raised)

0%

690 h
0.07 years

6,336 h
0.72 years

8h

100%

11,784 h
1.34 years

13,872 h
1.58 years

8h

SRAM card

Power-on
time ratio
*1

Q2MEM-1MBS
manufacturer
control number
“□□A”
＊2
“□□B”

Q2MEM-2MBS

*1: The power-on time ratio indicates the percentage of the time per day (24 hours)
while the programmable controller power supply is turned ON.
(The power-on time ratio will be 50% if the total power-on time is 12 hours and the
total power-off time is 12 hours.)
*2: The manufacturer control number (the third digit from the left) is described on the
the back label of the SRAM card main unit (refer to the following figure).
注意事項
CAUTION

**-*********
3LBN
・ 強いショ ッ ク を 与えな いこ と 。
Do not subject to mechanical shock!
・ 高温 ・ 直射日光 ・ 水にさ ら さ れな いこ と 。
Do not expose to extreme.

Manufacturer control number

POINT
Note that the SRAM card consumes the battery even when the battery is
connected to the CPU module and the programmable controller is powered ON.

(3) Replacement
In the period after the old battery is removed and before a new battery is
connected, the built-in capacitor automatically performs backup. The period
should be within three minutes.
POINT
Replace the battery of the SRAM card while the programmable controller power is
ON and the SRAM card is mounted in order to retain data.
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10.2 Fuse
The following MELSEC-Q series modules have a built-in fuse to prevent short-circuit
current and overcurrent.
Table 10-2 List of Modules with a Built-in Fuse
Module type

Model
Q61P, Q61P-A1, Q61P-A2, Q61P-D, Q61SP,
Q62P, Q63P, Q63RP, Q64P, Q64PN, Q64RP
Q00JCPU, Q00UJCPU
QY50, QY70, QY71, QY80, QY80-TS
QX48Y57

Power supply
CPU module
Output module
I/O combined module (output)

POINT
Note that fuses cannot be replaced by users.

For the QY22 and QY68A output modules, it is recommended to install a fuse to an
external terminal in order to prevent burnout of an external device and the module in
the event of load short.
Fuse model
Recommended whose operation
Module name
fuse
has been
checked
QY22

QY68A

IEC60127
sheet 1
compliant item

216 02.5

Quick action
type
having a rated
current of 3 A

216 3.15

Manufacturer

Distributor

Littelfuse, Inc.

Kuroda Electric Co., Ltd.
Headquarters (Tokyo)
03-5764-5500
Osaka
06-6303-1300
Nagoya
052-852-3321

216 002

312 003
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10.3 Life of Electrolytic Capacitor
The modules using an aluminum electrolytic capacitor has a life of 10 years at an
ambient temperature of 40°C, but under a condition of a high ambient temperature,
their capacitance may decrease in four to six years.
It is recommended to replace it with a new one or have it overhauled considering the
life described below as a preventive maintenance.
 Module using an electrolytic capacitor
In general, aluminum electrolytic capacitors are characterized by extremely varying life
according to the ambient temperature (twofold changes in life when the temperature
changes by 10°C) become there are chemical reactions inside.
These characteristics are called Arrhenius law, which is illustrated in the following
figure.
Life

10 years

5 years

10℃

30℃

50℃

Figure 10-1 Arrhenius Law
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Temperature

10.4 Life of Output Relay
The relays of the contact output module become worn with switching actions.
If the relay mounted directly on the printed-circuit board of the output module becomes
worn, the entire output module must be replaced.
As measures against wear, for an alternate current load, change to triac output, for a
direct current load, change to transistor output, and thus eliminate the contacts.

200

Switching life (10,000 times)

100
70
50

30

20

10
7
DC30V τ = 0ms

5

DC100
τ＝7ms
AC100V cosφ= 0.7
AC200V cosφ= 0.7

3
τ( L/R) ： Time constant
cosφ ： Power factor

AC100V cosφ= 0.35
AC200V cosφ= 0.35
DC24Vτ= 7 ms

2

AC120V cosφ= 0.2

1
0. 1

AC240V cosφ= 0.2
0. 2

0. 3

0. 5

0. 7

1

2

3

Switching current (A)

Figure 10-2 Contact Life Characteristics of Output Relay
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5

10.5 Spare Parts
Replacement parts for domestic use can be obtained in a timely manner even after an
accident occurs because they are easy to obtain from the system service, branch
office, or distributor. On the other hand, replacement parts for overseas be should be
shipped beforehand.
Maintenance will become easy if the following points are considered in the design
phase:
(1) Adopting quick recovery types
Because Q series programmable controllers are a building-block type where each
module is mounted to the base unit, module replacement is easy. Because of the
structure, recovery is completed only by replacing the faulty module.
(2) Memory type
The standard RAM or memory card (SRAM) requires a battery for backup.
The standard ROM or memory card (Flash/ATA) does not require a battery and
can prevent the program from being changed due to a human error. It is
recommended to use the backup memory particularly for exports.
(3) Module types reduced
The number of types of spare parts can be effectively reduced by standardizing
module names to be used and reducing the number of types.
(4) Reserving I/O points
Do not use all I/O points of the 16, 32, and 64 I/O modules but reserve 10 to 20%
of them. By doing this, faulty modules can be substituted by rewiring and program
changes (changes in I/O signals) when there is no spare parts.
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(5) Spare parts
Table 10-3 Spare Parts
No.

Product name

Quantity

1

Battery

1 to 2 pcs

2

Power supply
module

1 pc per model in
use

3

I/O module

1 pc per module
model

4

CPU module

5

Memory card

1 pc per model in
use
1 pc per model in
use
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Remarks
Since the storage life is about five years, the
battery does not need to be always stocked, but
should be arranged when the battery in use
comes close to the end of life. Prepare the one or
two batteries for an unexpected case.
The life of this tends to be short when the
ambient temperature is high, since it is a part that
easily becomes hot.
Consider that it is likely to fail in test operation.
Additionally, when it is used for a long time, the
contact of the relay output module will be worn.
Since this is a core part of the programmable
controller, if this part should fail, the system will
go down. Prepare upper compatible spare
models.

MEMO
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Chapter 11: Preparing for Test Operation
When starting operation after new installation or modification of a programmable
controller, if the safety checks are not carried out sufficiently, an accident may result.
This section describes the check items to proactively prevent accidents and the
preparation procedure for test operation.
11.1 Check Items before Starting Test Operation
The following table describes the check items regarding the programmable controller.
Table 11-1 Check Items
No.

Check item

1

Setting the CPU

2

Mounting a battery








3


Mounting and setting

up memory cards




4

5

Connecting an
extension cable

Setting the extension 
base numbers for 
extension bases



6

Mounting modules

7

Fuses

8







Connecting the power 
supply and I/O cables


Description
Is the memory capacity to be used correct?
Is the type (RAM/ROM) correct?
Is the system protection not turned ON? *
*
Is the parameter-valid drive set correctly?
Is the connector for the lead wire of the removed battery when
shipped inserted securely into the connector pin on the CPU
side?
Are memory cards securely mounted onto the mounting
connector?
Is the memory capacity to be used correct?
Is the type (RAM/ROM) correct?
Is the write protect not turned ON?
(only for SRAM card, Flash card, SD memory card)
Is the battery holder securely inserted? (only for SRAM card)
Are the connectors of the main/extension bases well fitted with
the connectors of the extension cable?
Is the connectors of the extension base positioned correctly
(IN/OUT)?
Are the numbers set?
Is the same number set for multiple bases?
Are jumpers inserted into several positions for one base?
Are the module models mounted on each slot of the
main/extension bases correct?
Does the module configuration use a larger number of I/O
points than that in the CPU specifications?
Are fuses blown or damaged?
Do the cables connected to each terminal of the terminal
blocks correspond to signal names?
Are the terminal screws of the terminal blocks for power supply
module, I/O module and intelligent function module well
tightened?
Do the cables have a proper wire size?

* For high performance models only
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11.2 Preparation Procedure for Test Operation
The following shows a flowchart from a completion of installation until test operation of
a programmable controller.
Start

Test operation

Power-on
1. Confirm voltage input from power
supply.
2. Confirm power supply voltage for
I/O equipment.
3. Set the RUN/STOP/RESET switch
of the CPU module to [STOP].
4. Turn on the power.
5. Confirm that the "POWER" LED of
the power supply module is on.

1. Set the RUN/STOP/RESET switch
of the CPU module to RUN.
2. Confirm that the "RUN" LED is on.

Sequence check
Check sequence operations.

Programming
Write a sequence program that has
been programmed with GX Works2
to the CPU.

Program modification
Modify a sequence program if it
causes a trouble.

External output wiring check
Check external output wiring by
forcibly turning ON using device test
operation in GX Works2 with a
personal computer.

Program protection
1. Save programs on hard disk or
a CD-ROM.
2. Print a ladder diagram and a list
using a printer.

External input device wiring check
Check the wiring of input devices in
the monitoring mode of GX Works2
with a personal computer.

End

11 - 2

Chapter 12: CPU Replacement Procedure during Operation
When replacing the programmable controller CPU while operating the system and
machineries and continuing operation, it is necessary to read the sequence program
and device data (latch data, etc.) out to peripherals and mount a new CPU. The
procedure is as follows:

12

Stop during operation.

STOP the CPU.

Start GX Works2 on a personal computer. Refer to Section 3.1.

Connect the personal computer and the CPU using a cable.

Read a sequence program and device data. Refer to Section 3.13.

Save the program. Refer to Section 3.4.

Turn OFF the power supply of the programmable controller.

Replace the CPU.

STOP the CPU.

Turn ON the power supply of the programmable controller.

Connect the personal computer and the CPU using a cable.

Format the memory of the programmable controller. Refer to Section 3.5.

Write the sequence program and the device data. Refer to Section 3.5.

RUN the programmable controller CPU.

Continuous operation starts.
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POINT
Precautions for module/unit replacement
 For an intelligent function module
The intelligent function module may contain data such as parameters in E2PROM
or EROM.
In such cases, it is necessary write the same data to the replacement module.
 For an Ethernet interface module
If the Ethernet module has also been replaced, reset the external device as well.
(If the external device retains the Ethernet address of another external device,
communication may be disconnected because replacing Ethernet module
changes the Ethernet addresses.)
Likewise, an external device (e.g. personal computer) is replaced, start up the
Ethernet module again.
12.1 Universal Model QCPU Replacement Procedure
Use the QnU(D)(E)(H)CPU Replacement Checklist described in Appendix 7.2
together.
12.1.1 Preparation
(1) Enter the date, operator, panel name, and CPU model name in the
QnU(D)(E)(H)CPU Replacement Checklist.
(2) In the checklist, enter the switch setting of the CPU to be removed and whether
there is a memory card.
(3) As needed, for identification, stick a panel name label on the surface of the CPU
to be removed.
(4) When replacing QnUCPU module, use the "CPU module replacement" function.
For details on how to use, refer to Section 12.1.2.
12.1.2 Data Backup
(1) Connect GX Works2 to the CPU to be removed, and set the PLC type and
transfer setup to "Programmable Controller Side I/F: CPU Module".

(3) Click!

(To the next page)
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1)

Connect the CPU with a personal computer
using an RS-232C, USB or Ethernet cable.
(This textbook illustrates the example where
a USB cable is used.)

2)

Start up GX Works2.

3)
4)

Click the [Online] → [Read from PLC] menu.
Set the PLC series to [QCPU(Q Mode)] and
click the OK button.

(From the previous page)

(To the next page)
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5)

Double-click [Serial/USB] on the PC side I/F.

6)

Select the cable used for connection and
click the OK button.

7)

Double-click the PLC Module on the PLC
side I/F.

8)

Select "QCPU(Q module)" for the PLC Mode
and click the OK button.

(From the previous page)
9)

Select "No Specification" for Other Station
Setting.

10) Click the Connection Test button.

11) If properly connected, the screen on the left is
displayed. Click the OK button.
If not properly connected, the following
screen is displayed. Check the connection
and conduct the communication test again.

12) Click the OK button.

13) The Read from PLC dialog box is displayed.
Click the Close button.
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(2) Delete the program name "MAIN" from the project data.

(3) Delete Global Device Comment from the project data.

(4) Delete the device memory "MAIN" from the project data.

(5) Check that there is no error for the CPU to be removed. In addition, create a
new project after starting up GX Works2 and use the system monitor to check that
there is no error for the mounted module.
1)

In the LED on the front of the CPU, check
that the ERR.LED is turned OFF.

2)

If the ERR.LED is turned ON or flashes, click
the [Diagnostics] → [PLC Diagnostics] menu.

3)

Double-click an error code in [Current Errors].

③(1)クClick!
リ ッ ク!

(To the next page)
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(From the previous page)
4)

Check the error details to enter the common
error information and individual information in
the checklist.
As needed, click the Error JUMP and
Error Help buttons to enter the error details
in the checklist.
Also, ask the user for check.

5)

Click the Close button to close the PLC
diagnostics dialog box.

6)

Click the [Diagnostics] → [System Monitor]
menu.

7)

Check that there is no error for the mounted
module.
If there is no error, the screen on the left is
displayed.

(To the next page)
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(From the previous page)
8)

If there is any error for the mounted module,
double-click the erroneous module to check
the error history of the module detailed
information and enter in the checklist.
Also, check with the user.
Click the Close button to close the system
monitor dialog box.

(6) Before setting RUN/STOP/RESET switch of the CPU to be removed to STOP,
check with the administrator.

12 - 7

(7) After entering the file content of the program memory in the checklist, select all
programs, parameters (only for PLC/network), device comments, initial device
values and so on, and check [Also read the remaining reserved capacity for writes
during RUN]. Then, save the project after reading from the PLC.
*

Please change the intelligent function module parameters (hereafter referred
to as intelligent parameters) to non-device data because they can be read.

(1) Click!

Write all save destinations and file names to frames
Circle either of [Applicable/Not applicable]
Program memory [SaveD:\Program_memory_read
destination:
Parameter
Program
[Applicable/Not applicable]

Intelligent parameter
[Applicable/Not applicable]

Device data

Initial device value
[Applicable/Not applicable]

INIT

(To the next page)
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1)

Click the [Online] → [Read from PLC] menu.

2)

Set the target memory
memory/Device memory].

3)

In the [Program memory] field in the checklist,
enter file names, whether there is any
parameter, and so on.

to

]
Program

Comment
COMMENT

[Program

(From the previous page)
4)

From the file selection, select (check) all
programs, parameters
(PLC/Network/Remote password/Switch
setting), device comments (global/local), and
initial device values.
*

Select non-device data.
button of the program.

5)

Click the

6)

Check [Also read the remaining reserved
area for online change].

7)

Click the Execute button.

8)

If the dialog on the left is displayed,
double-click and select the model name of
the actual device mounted on the target
system.

9)

Click the OK button.

10) Click the OK button.

(To the next page)
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(From the previous page)
11) A dialog box that asks whether to save
changes is displayed. Click the Yes for All
button.

12) When the read is completed, the dialog box
on the left is displayed. Click the OK
button.

13) Close the Read from PLC dialog box.
14) Click the [Project] → [Save as] menu to name
the project.

(14) Click!

(To the next page)
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(From the previous page)
15) Enter the save destination in the [Program memory] field in the QnU(D)(E)(H)CPU Replacement
Checklist.
Write all save destinations and file names to frames
Circle either of [Applicable/Not applicable]
Program memory [SaveD:\Program_mD:\Program_memory_read
destination: D:\Program_memory_read]
emory_read
Parameter
Program
Program
[Applicable/Not applicable]
MAIN
Intelligent parameter
[Applicable/Not applicable]

Device data

Initial device value
[Applicable/Not applicable]

INIT
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Comment
COMMENT

(8) Select device data in the program memory and name a file. (Example: DEVICE)
Click the "Default" button in "Device data" to select X and Y ( ), as well.
After reading from PLC, confirm that there is the data and then save the project.

(1) Click!

1)

Click the [Online] → [Read from PLC] menu.

2)

Set the target memory to [Program
memory/Device memory] and click the
button of the device memory.

3)

Click the Default button.

4)

The message box on the left is displayed.
Click the Yes button.

5)

Select a device data and name a device data
name.
Device data name: DEVICE (example)

(To the next page)
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(From the previous page)
6)

Check that all the current devices (except for
the retentive timer) are selected ( ).

7)

Click the OK button to read from PLC.

8)

Select the read file.

9)

Confirm that the device data exists.

10) Close the Read from PLC dialog box, and
then click the [Project] → [Save] menu to
save the project.
(10) Click!

11) Enter the device data name in the [Device data] field in the QnU(D)(E)(H)CPU Replacement
Checklist.
Write all save destinations and file names to frames
Circle either of [Applicable/Not applicable]
Program memory [Save destination:
D:\Program_memory_read
¥
Parameter
Program
Program
[Applicable/Not applicable]
MAIN
Intelligent parameter
[Applicable/Not applicable]

Device data
DEVICE
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]
Comment
COMMENT

(9) If a file register exists in the standard RAM, enter the file name and file size (in
bytes) in the checklist, read the entire range into the same project and then save
it.

(1) Click!

1)

Click the [Online] → [Read from PLC] menu.

2)

Set the target memory to [Standard RAM].
Check that the file register exists.

3)

Select a file and click the

button.

Check that the entire range is selected and
click the OK button.

4)

(To the next page)
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Check the file size.

(From the previous page)
5)

Enter the file name and file size in the [Standard RAM] field in the QnU(D)(E)(H)CPU Replacement
Checklist.
Standard RAM
File register
MAIN

File size
2048

byte

Note) Use the same project as the program memory.
Before write to PLC, ensure that the destination
and the file name are correct. Writing to the PLC
shall be done to the standard RAM.

6)

Click the
PLC.

Execute

button to read from

7)

After closing the Read from PLC dialog box,
click the [Project] → [Save] menu to save the
project.

(7) Click!

(10) If files exist in the standard RAM, after entering the file contents in the checklist,
start up new GX Works2, read the files in the same way as reading the program
memory from PLC, and save it with another project name.
However, if they are device comments or likewise, and there is no same file as
that in the program memory, there is no problem in saving in the same project as
in (7).
1)

(1) Click!

(To the next page)
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Click the [Online] → [Read from PLC] menu.

(From the previous page)
2)

3)

Enter the file names and others in the [Standard ROM] field in the QnU(D)(E)(H)CPU Replacement
Checklist.
Standard ROM [Save destination:
Program
Parameter
[Applicable/Not applicable]
MAIN

]
Comment
COMMENT

Initial device value
INIT

File name

Intelligent parameter
[Applicable/Not applicable]

Use the checklist and others to check whether these files are same as those in the program memory
(7).
If no same files as in the program memory exist, save in the same project as in (7) after reading from
PLC, and then enter the project name in the checklist.
Standard ROM [Save
destination:
D:\Program_memory_read
D:¥プログラ
ムメ モリ
読出し
Comment
Parameter
[Applicable/Not applicable]
COMMENT
Intelligent parameter
[Applicable/Not applicable]

File name

4)

Set the target memory to [Standard RAM]
and check for the file.

(To the next page)
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]

(From the previous page)

* If there exist the same files as in the program memory, follow the procedures below
1)

Start up new GX Works2.

2)

Set the target memory to [Standard ROM]
and read from PLC in the same way as for
the program memory.

3)

Click the [Project] → [Save as] menu to newly
save the project.

(2) Click!

Enter the project name in the checklist.
Standard ROM [Save destination: D:\Standard_rom_read
Program
Comment
Parameter
[Applicable/Not applicable]
MAIN
COMMENT
Intelligent parameter
[Applicable/Not applicable]

]
Initial device value
INIT

File name

4)

(11) If a memory card is used or if files exist, after entering the file contents in the
checklist, start up new GX Works2, read the files in the same way as in reading
the program memory from PLC, and save it with another project name.
However, if it is a file register or likewise, and there is no same file as that in the
program memory, it is possible to save them to the same project as in (7).
1)
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Check if files exist, and if they do, perform the
same procedure as in (10).

(12) From GX Works2, run [Online] → [Program memory batch transfer] and check
whether the content of the program cache memory matches that of the program
memory.
*

If the contents do not match, or if the user cannot check due to the CPU version, a
message "Do you transfer...?" will

appear. Then, click the

Yes

button to

perform the batch transfer.
1)

Click the [Online] → [Program Memory Batch
Download] menu.

2)

Check whether the content of the program
cache memory matches that of the program
memory and, if it does, click the OK
button.
Otherwise, click the Yes button so that the
content of the program cache memory will
match that of the program memory.

If it matches

If it does not match

(To the next page)
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(From the previous page)

(13) When replacing the QnUCPU module, use the "CPU module replacement"
function to back up the module to a memory card.
1)

Click the [Online] → [PLC Module Change]
→ [Create Backup Data] menu.

2)

In "Data for backup", select data to be backed
up from "Program memory", "Standard RAM"
or "Standard ROM".
* "Default backup data" is selected by default.
It cannot be changed.
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3)

Click the Execute button.
The data backup starts.

4)

When the backup is normally completed, the
[Status] screen changes as in the image on
the left.

12.1.3 Replacement
(1) In the checklist, enter the SERIAL number and MAC address (only for the CPU
board with Ethernet enabled) on the side of, or under the face plate of, the CPU to
be mounted.
Module to be mount ed
SERIAL No.
(production information)
100921102685014-B

MAC address

MAC ADD.
08007045BB00

SERIAL No.

Write the confirmed SERIAL and
MAC address to the check sheet.

(2) Set the RUN/STOP/RESET switch of the CPU to be mounted to "STOP". Also,
mount the battery connector at the bottom of the module.

Set to STOP.

Mount the
connector.

(3) Before powering OFF the programmable controller, check with the administrator.
(4) Remove the target CPU from the base and, in the checklist, enter the SERIAL
number and MAC address (only for the CPU board with Ethernet enabled) on the
side or under the face plate.
(5) If an identification seal is put, move it to the CPU to be mounted.
(6) If a memory card is mounted on the removed CPU, move it on the CPU to be
mounted.
(7) Mount the target CPU on the base in the mounting panel and, if it is to be fixed
with screws, tighten the screws.
(8) Confirm again that the RUN/STOP/RESET switch of the mounted CPU is set to
"STOP".
(9) Before powering ON the programmable controller, check with the administrator.
*

An error may be displayed on the CPU, but please continue with the task.
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12.1.4 Data Restoration
(1) Check the product information of the corresponding module in the GX Works2
system monitor, and enter in the check sheet.

4)

1)

Click the [Diagnostics] → [System monitor]
menu to display the system monitor dialog
box.

2)

Click the Product Information List button.

3)

The product information list dialog box is
displayed. Check the product information
(serial number, etc.) of the corresponding
module.

Enter the product information in the [Product information of the CPU (replacement)] field in the
QnU(D)(E)(H)CPU Replacement Checklist.
face plate of the CPU to be mounted, to the right column.

Rep lace ment

5)

9

Set the RUN/STOP /RESE T switch of the CPU to be moun t to "STOP ". Also, connec t the battery conne ctor at the bottom the modu le.

10

Have the customer turn OFF the power sup ply of the programm able controller.

11

Remove the target CPU from the base, and write the SERIAL number and MAC address (only for the CPU board with Ethernet

P roduc t in fo rm a tio n o f th e
C P U (m o d ule to be m o un ted )

1306200 00000000 -B

enabled), which are on the side or under the face plate, to the right column.

12

If the customer's identification label is attached, move it to the CPU to be mounted.

13

If a memory card is mounted on the removed CPU, move it on the CPU to be mounted.

14

Mount the target CPU on the base in the mounting panel and, if it is to be fixed with screws , tighten the screws .

15

Confirm agai n that the RUN/STOP/RESET switch of the mounted CPU is set to "STOP".

16

Have the customer turn ON the power supply of the programm able controller.

Error description
before replacement

Close the product information list dialog box and the system monitor dialog box.
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(2) Format the program memory/device memory, standard RAM, and standard ROM
to be used for the PLC memory.
At this point, check whether it is necessary to allocate the system area and, if it is,
configure the settings.
However, because this area is set only when formatting, if you are not sure, there
is no problem leaving it as the default.
1)

Click the [Online] → [PLC Memory Operation]
→ [Format PLC Memory] menu.

2)

Since the Format the PLC memory dialog
box is displayed, set the target memory to
either "Program memory" or "Device
memory".

3)

Select the format.

*

Set the system area if it is necessary to
allocate the area.
If it is not necessary, select "Do not create a
user setting system area (only the required
field)".

4)

Click the Execute button.

5)

The message box on the left is displayed.
Click the Yes button.
The program memory or device memory is
formatted.

(To the next page)
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(From the previous page)
6)

Format the target memory "standard RAM" or
"Standard ROM" as with "Program
memory/Device memory".

7)

Close the Format the PLC memory dialog
box.

(3) Select "Include latches" and clear the CPU to be mounted from the PLC memory.
1)

Click the [Online] → [PLC Memory Operation]
→ [Clear PLC Memory] menu.

2)

The Clear the PLC memory dialog box is
displayed. Select "Include latches".

3)

Click the Execute button.

4)

The message box on the left is displayed.
Click the Yes button.
The PLC memory is cleared.

5)
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Close the Clear the PLC memory dialog box.

(4) To the program memory/device memory in the PLC, write the files saved earlier
(except the device memory) such as parameters and programs by referring to the
[Program memory] field in the checklist.

(1) Click!

1)

Click the [Project] → [Open] menu.

2)

Open the project saved in (6) in 12.1.2.

*

Be careful not to open a wrong project.

3)

Click the [Online] → [Write to PLC] menu.

4)

The Write to PLC dialog box is displayed. Set
the
target
memory
to
"Program
memory/Device memory".

5)

Click the [File selection] tab and select
programs, parameters and so on (except for
the device memory) by referring to the
"Program memory" field in the checklist.

6)

Click the
PLC.

(3) Click!
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Execute

button to write to the

(5) To the standard RAM in the PLC, write the files saved earlier referring to the
[Standard RAM] field in the checklist.
1)

Click the [Online] → [Write to PLC] menu.

2)

The Write to PLC dialog box is displayed.

(1) Click!

Set the target memory to [Standard RAM].

3)

Check the write range ((The number of bytes
checked during PLC read ÷ 2) - 1) and click
button for the file register.
the
Select a file by referring to the [Standard
RAM] field in the attached checklist.

4)

Click the OK button and then click the
Execute button to write to the PLC.

(6) To the standard ROM in the PLC, write only the stored files by referring to the
[Standard ROM] field in the checklist.
Open the project saved in (10) of 12.1.2 and write the stored files to the PLC by
referring to the [Standard ROM] field in the attached checklist.
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(7) For the memory card, verify all the files with those in the PLC by referring to the
[Memory card] field in the checklist.

(1)

1)

As in (4), open the project saved in "(11)" in
12.1.2.

2)

Click the [Online] → [Verify with PLC] menu.

3)

The Verify PLC dialog box is displayed.
Set the target memory to [Memory card
(SRAM), (Flash) or (ATA)].
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4)

Refer to the [Memory card] field in the
checklist and select the same data in the
verify source and destination.

5)

Click the Execute button to verify the data
in the PLC.

6)

Confirm that there is no mismatch.

(8) Check with the administrator and set the clock if needed.
1)

Click the [Online] → [Set Clock] menu.

2)

The Clock setting dialog box is displayed.

(1) Click!

Set the year/month/day, time, and day of the
week.
3)

(9) Before

powering

OFF/ON

Click the Set button.

theprogrammable

controller,

check

with

the

administrator.
Power OFF the programmable controller once, and then turn ON the power again.
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(10) Select "Detail" for the device memory and click "Default" in the "Device detailed
setting". Then,after confirming that S (Step relay) is deselected, write to the PLC
and verify the data.
<<* Deselect S in the device setting.>>
(A verification error may occur for the SM, SD or refresh device.)
1)

As in (4), open the project saved in (8) of
12.1.2.

2)

Click the [Online] → [Write to PLC] menu.

3)

The Write to PLC dialog box is displayed.

(1) Click!

Set the target memory
memory/Device memory].

(To the next page)
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to

[Program

4)

Use the file selection to select files for the
device memory.

*

Be careful not to select wrong file names.

5)

Click the

6)

Click the Default button.

7)

The message box on the left is displayed.
Click the Yes button.

8)

Check that the step relay (S) is deselected
( ).

9)

Click the
PLC.

button.

Execute

button to write to the

(From the previous page)
10) As in (7), click the [Online] → [Verify PLC]
menu.
(10) Click!

11) The Verify PLC dialog box is displayed.
Set the target memory
memory/Device memory].

to

[Program

12) Select a file by referring to the [Device data]
field in the attached checklist.
13) Click the Execute button to verify the data
in the PLC.

14) Confirm that the device data matches.
*

The SM, SD and device used for link refresh
may be mismatched.

(11) If SFC is used for the program, reset the CPU.
→

If there is data being processed, malfunction may occur because SFC starts
up from the initial step.

→

If there is necessary data outside the latch range, select only that device and
write it to the PLC.

A different icon appears.

1)

Check if an SFC program is used.

2)

If an SFC program is used, reset the CPU.
(a) Push down the RUN/STOP/RESET switch on
the front of the CPU towards the RESET side
for one second or more.
(b) Remove the hand from the switch after
ERR.LED flashes and then turns off.

(To the next page)
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(12) When using the "CPU module replacement" function to restore data, follow the
procedure below:
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1)

Click the [Online] → [CPU Module Change]
→ [Restore] menu.

2)

Click the Execute button.
The data restoration starts.

3)

Once the restoration is normally completed,
the [Status] screen is displayed as in the
image on the left.

12.1.5 Operation Check
(1) Check that there is no error for the CPU. Also, check that there is no error for the
module mounted on the system monitor.
1)

Click the [Diagnostics] → [PLC Diagnostics]
menu.

2)

Click the Clear History button.

3)

The message box on the left is displayed.
Click the Yes button.

4)

Confirm that the error history has
disappeared and then close the PLC
diagnostics dialog box.

(1) Click!

(2) Before setting RUN/STOP/RESET switch of the CPU to RUN, check with the
administrator.
*

The user should have checked the start-up procedure of the system. (Some
applications may require to reset again → RUN.)

(3) Check that there is no error for the CPU. If any faults are found in the replacement,
return the removed CPU to the original place.
In the LED on the front of the CPU, check that there is no error for the CPU.
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Appendix 1 Online Program Change

This section describes the operation to change programs or data (Online Program
Change) when the programmable controller CPU is in the RUN status.
There are two types of Online Program Changes: online change of a program in unit of
ladder block and the one in unit of files.
When performing online program change, have a good understanding of the following
and the descriptions in Appendix 1.3 and operate carefully.

WARNING

● When data change, program change, or status control is performed from a
personal computer to a running programmable controller, configure an
interlock circuit outside the programmable controller system to ensure that
the entire system will always operate safely.
Furthermore, for the online operations performed from a personal
computer to a programmable controller CPU, predetermine the system’s
corrective actions in case of a communication error caused by poor cable
connection, etc.

CAUTION

● When performing online operations (program change while a
programmable controller CPU is running, forced input/output operation,
operating status changes such as RUN-STOP, and remote control
operation) for the running programmable controller CPU from a personal
computer, read the manual carefully and ensure sufficient safety before
operation.
When changing a program while a programmable controller CPU is RUN
(online program change), a problem such as program corruption may
occur depending on operating conditions. Fully understand the
precautions described in this section before use.
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Appendix

Appendix 1.1 Online Program Change in Unit of Ladder Blocks

[Purpose of setting]
To change a part of a program when the programmable controller CPU is in the RUN
status.
[Operating procedure]
Check that the program matches the one on the programmable controller CPU using
the Verify with PLC function in advance.
If the part to be written does not match with the program on the programmable
controller CPU, online program change cannot be performed.
1.
2.

Change or modify the program.
Select [Conversion] → [Conversion (Online Program Change)] ( Shift ＋ F4 )
to execute online change. *

*:

With the following setting, online program change can be executed by selecting
[Conversion] (or pressing

F4 ). This setting is useful if programs are always

changed by online change.
<Setting>
Select the [Tool] → [Option] → [Program Common] tab screen, and select
"Execute online change after conversion" in the online program change setting.

[Description]
Online program change can be performed when the mode is Write Mode or Monitor
(Write Mode).
When the programmable controller CPU is in the STEP-RUN status, online program
change is not allowed.
An attempt to execute online program change will display the following dialog box.
Carefully read the displayed message and execute online change.

Click the Yes button to write the changed program to the programmable controller CPU.
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POINT
 When performing Online program change to a programmable controller CPU
for the first time, or an error occurs during Online program change, check the
programs with the Verify with PLC function.
 When the number of steps exceeds the writable range for online change as
NOP instructions exist
When the number of steps exceeds the writable range for online change as
NOP instructions exist after a ladder block, select "Do not shift the program
forward" before executing online change. For setting to move programs
forward, refer to the GX Works2 Operating Manual.
When changing the step 0 (LD X1) of the following program to LD X3, if "Shift
the program forward" is selected, online program change cannot be performed.
Ladder mode
List mode
X1
0 LD X1
0
M0
1 OUT MO
2 NOP
X2
3 NOP
601
M10
600 NOP
601 LD X2
602 OUT M10
When programs are shifted forward
Online program change cannot be performed because steps 0 to 600 are the
target.
When programs are not shifted forward
Online program change can be performed because steps 0 to 1 are the target.
 For precautions for and restrictions on label programs, refer to the GX Works2
Operating Manual.
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Appendix 1.2 Online Program Change in Unit of Files

[Purpose of setting]
To execute batch writing of programs and data in unit of files when the programmable
controller CPU is in the RUN status.
[Operating procedure]
[Online] － [Write to PLC]
[Description]
Data such as sequence programs and device comments can be written with online
program change.
The data that can be written with Online program change differs depending on the
write target memory.
For details, refer to the following manual.
 QCPU User's Manual (Function Explanation, Program Fundamentals)
An attempt to execute online program change in unit of files will display the following
dialog box.
Read and understand precautions shown as messages and execute online change.

Click the Yes button to write the data specified on the Write to PLC screen to the
programmable controller CPU.
POINT
 When the capacity of the programmable controller CPU is not enough, switch
the programmable controller CPU to STOP status, delete unnecessary
programs written in it, and then write the program using the Write to PLC
function.
 After online change of a SFC program is executed in unit of files, the CPU
module the program is initialized and starts up.
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Appendix1.3 Precautions for Online Program Change
Precautions for online change are described below.
(1) Precautions for using rise, fall, or SCJ instruction
1) Fall instruction
Even if the execution condition for a fall instruction in an online changed
ladder *1 is not satisfied (in continuity state), the fall instruction is executed.
For fall instructions, refer to the programming manual of each series. The
following are examples of the instructions.
Fall instruction: PLF, LDF, ANDF, ORF, MEF, FCALLP, EFCALLP, and XCALL
ON/OFF status of contact
(Conductive status at online
Rise instruction
Fall instruction
change)
OFF
Not executed
Executed
ON
Not executed
Not executed
*1: When a new ladder block is inserted without changing existing
programs, the added program is written together with the next ladder
block to the programmable controller CPU. (If the next ladder block
does not exist, the previous ladder block is written together.)
Thus online program change may not be completed at a time
depending on the number of program steps of the added program and
the previous or next one. In this case, reduce the number of steps
written at a time and perform online program change in several times.
*2:

The execution of fall instruction can be disabled from Online Program
Change setting, which is displayed by selecting "Tool option".

<Example>
Programs added by pasting
and inserting a row
Programs on the left is also
written to the programmable
controller

2) Rise instruction
When writing is completed, even if the execution condition for a start-up
execution instruction (PLS instruction / P instruction) is ON, the start-up
execution instruction is not executed.
When the execution condition turns OFF → ON again, the start-up
execution instruction is executed.
3) SCJ instruction
When writing is completed, if the execution condition for SCJ instruction is
ON, the instruction executes a jump to the specified pointer without waiting
for 1 scan.
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POINT
When online program change to a QCPU (Q mode) or QnACPU module is
completed, even if the execution condition for a fall instruction is not OFF, the fall
instruction is executed. This phenomenon can be avoided using EGF instruction.
For details, refer to version "I" or later of the following manual.
 QCPU (Q mode) / QnACPU Programming Manual (Common Instructions).
How to confirm the manual version: Check the revision history of the manual.
Print date
June 2004

* Manual number
SH (name) -080021-I

Revision

Manual version

(2) Precautions for Q/AnA series
Precautions for online change are described below.
Item
Online program change to
another station
During boot operation
Online program
change to the built-in
RAM (QnA series)
Online program
change in the backup
mode (redundant
CPU)
Deletion of a
corresponding device from
a program
Number of steps can be
written in online program
change

Online program change
while low-speed execution
type programs are running

Description
 Online program change to another station is possible via MELSECNET (II,
/10, H) or Ethernet.
 When performing online change to the built-in RAM during a boot operation,
after the status is switched to STOP, write the changed program to the IC
memory card.
 Online change during boot operation in the backup mode is performed on the
program memory and transfer source drive of both systems (connective
system and target system).
(The transfer source drive can be a memory card (RAM or ROM) or standard
ROM.)
 When the corresponding device no more exists in the program due to
deletion in an OUT instruction or device number change, the output status is
retained.
Select [Debug] → [Forced input output registration/cancellation] and forcibly
turn OFF coil outputs unnecessary in control.
When the number of program steps after editing (addition / deletion) is within
512, the program can be written.
However, if a new program is added by pasting or inserting a row without
changing existing programs, the maximum number of steps cannot be written at
a time.
In this case, reduce the number of steps written at a time and perform online
program change in several times.
In addition, be careful of modifications as follows.
When step 2 of the program is modified and step 540 is added, online program
change cannot be performed because steps 2 to 540 are the target to be
written at a time.
In this case, perform online program change for each modification.
If low-speed execution type programs are running, online change starts when
the execution of all the programs is completed. During online change, the
execution of low-speed execution type programs is suspended.
However, if "PRG TIME OVER(5010)" keeps occurring while a low-speed
execution type program is executed, online program change cannot be
performed.
In this case, set the programmable controller CPU to STOP, and increase the
constant scan time and low-speed program execution time in the PLC
Parameter setting, then execute online program change again.
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Item
Description
Reserved area for online change
For Q series
 If the currently set number of secured steps is exceeded during online
program change, the following dialog box is displayed. Set a new number of
reserved steps.
 When the number of secured steps is set to 0 on the dialog box below, only
sequence programs which exceed the secured range will be written.
 When performing online change to a sequence program protected by a
password, the Input Disable Password dialog box is displayed.
Disable the password before executing online program change.
Online change cannot be executed without disabling the password.
 The number of secured steps newly set on the following dialog box is not
displayed on the <<Program>> tab of the Write to PLC screen.

When connecting to a Basic model QCPU function version A, steps for online
change are automatically secured and the above dialog box is not displayed.
Redundant CPU
When re-securing steps for online program change in the backup mode, the
maximum number of steps is based on either the capacity of the control system
or that of the standby system, whichever is smaller.
Example) When the empty capacity of control system is 100 steps and the
empty capacity of standby system is 50 steps
The maximum number of steps which can be reserved for online
program change again is 50.
For system configured with a redundant CPU
Backup mode
Online change is performed on both systems (connective system and target
system).
However, if the target system fails (communication cannot be established with
the target system), online program change is not performed on either of the
systems.
Separate
Online change is only performed on the programmable controller CPU specified
mode/debug mode
in the redundant CPU setting field on the Transfer Setup screen.
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Appendix 1.4 Actions to Be Taken When Online Change Is Not Properly Completed

[Description]
The following error message may be displayed during online program change because
of timeout of the check time. Follow the message to take actions.
(1) If the following dialog box is displayed, the program on GX Works2 is not
converted but the program on the programmable controller CPU may be
changed.
In this case, convert the program on GX Works2 and verify it against the
program on the programmable controller CPU to confirm that these programs
match.
If the programs do not match, write the program to the programmable controller
CPU using the Write to PLC function to match them.

(2) The following dialog box may be displayed if the time check time set in Transfer
Setup is short.
Select [Online] - [Transfer Setup] and set a longer time check time on the screen.
During online program change, time check is carried out at intervals of 90
seconds even if the time check time set on the Transfer Setup screen is less
than 90 seconds. Set a time check time longer than 90 seconds.
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Appendix 2 Index Modification
Appendix 2.1 Index Modification Overview
(1) Index modification is an indirect setting using an index register.
When index modification used in a sequence program, the device to be used is
indicated by the directly specified device number plus the content of the index
register. For example, when D2Z2 is specified and the content of Z2 is 3, the
target device is D(2 + 3) = D5.
(2) Only Universal model QCPUs allow modification with 32-bit values as well as
16-bit values.
Appendix 2.2 16-bit Index Modification
(1) Modifying with 16-bit values
Each index register can be set to a value between -32768 to 32767.
The following is an example of index modification.
Store -1 to Z0.
Store data
"D10Z0 = D {10 + (-1)} = D9"
to D0.
Index modification

(2) Devices to which index modification can be made
With the exception of the restrictions noted below, index modification can be
made to devices used with contacts, coils, basic instructions, and application
instructions.
(a) Devices to which index modification cannot be made
Device
K, H
E
$
.
FX, FY, FD
P
I
Z
S
TR
BL

Description
32-bit constant
Floating-point data
Character string data
Bit-specified word device
Function device
Pointers used as labels
Interrupt pointers used as labels
Index register
Step relay
SFC transition device *1
SFC block device *1

*1: SFC transition device and SFC block device are devices for SFC.
For how to use, refer to the following manual.
 QCPU (Q mode) / QnACPU Programming Manual (SFC)
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(b) Devices to which index modification is not allowed
Device

Description

Application example

T

 Only Z0 and Z1 can be used for
timer contacts and coils

C

 Only Z0 and Z1 can be used for
counter contacts and coils

REMARKS
There is no restriction on index register numbers used for the current values of
timers and counters.
Timer setting value

Timer current value

Counter setting value

Counter current value

(3) The following are examples of index modifications and actual process devices.
(When Z0 = 20, Z1 = -5)
Ladder example

Actual process device

Description

Converts K20 to hexadecimal

Description

Hexadecimal
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Appendix 2.3 32-bit Index Modification (Universal Model QCPU Only)
For 32-bit index modification, the following two options are available as
specification methods of index registers.
 Specifying the range of index registers used for 32-bit index modification.
 Specifying 32-bit index modification using "ZZ".
POINT
32-bit index modification using "ZZ" is allowed only for the CPU modules
described below.
 QnU(D)(H)CPU whose the first five digits of the serial number are "10042" or
later.
 QnUDE(H)CPU
(1) Specifying the range of index registers used for 32-bit index modification
(a) Devices to which index modification is not allowed
Each index register can be set to a value between -2147483648 to
2147483647.
The following is an example of index modification.
Stores 40000 to Z0.
Stores data "ZR10Z0 =
ZR{10 + 40000} =
ZR40010" to D0.
Index modification

(b) Specification method
For modification with a 32-bit value, specify the start number of the index
registers to be used in the Device setting of the PLC Parameter setting of GX
Works2.

POINT
When the start number of the index registers to be used is changed in the Device
setting of the PLC Parameter setting, do not change the parameter only or do not
write only the parameter into the programmable controller. Be sure to write the
parameter into the programmable controller together with the program.
Forcibly writing the parameter causes CAN'T EXE.PRG. error (Error code: 2500).
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(c) Devices to which index modification can be made
Index modification can be made only to devices described below.
Device
ZR
D
W

Description
File register in the serial number access
method
Extended data register
Extended link register

(d) Range of usable index registers
The following table shows the range of usable index registers for 32-bit index
modification.
For 32-bit index modification, the specified index register (Zn) and the next
index register (Zn+1) are used. Be sure not to overlap index registers to be
used.
Set value
Z0
Z1
Z2
Z3
Z4
Z5
Z6
Z7
Z8
Z9

Index registers to be used
Z0, Z1
Z1, Z2
Z2, Z3
Z3, Z4
Z4, Z5
Z5, Z6
Z6, Z7
Z7, Z8
Z8, Z9
Z9, Z10

Set value
Z10
Z11
Z12
Z13
Z14
Z15
Z16
Z17
Z18
Z19

Index registers to be used
Z10, Z11
Z10, Z11
Z12, Z13
Z13, Z14
Z14, Z15
Z15, Z16
Z16, Z17
Z17, Z18
Z18, Z19
Cannot be used.

(e) The following are examples of index modifications and actual process
devices.
(When Z0 (32 bits) = 100000, Z2 (16 bits) = -20)
Ladder example

Actual process device

Description

(2) Specifying 32-bit index modification using "ZZ"
(a) By using "ZZ" like "ZR0ZZ4", 32-bit index modification can be specified with a
desired index register.
The following is an example of 32-bit index modification using "ZZ".
100000 to Z4 and Z5
Modifies ZR with 32 bits (Z4 and Z5).
It shows ZR (0 + 100000) → ZR100000.
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(b) Specification method
To enable 32-bit index modification using "ZZ", set "Use ZZ" in "Indexing
Setting for ZR Device" in the PLC Parameter setting of GX Works2.

(c) Devices to which index modification can be made
Index modification can be made only to devices described below.
Device

Description
File register in the serial number access
method
Extended data register
Extended link register

ZR
D
W

(d) Range of usable index registers
The following table shows the range of usable index registers for 32-bit index
modification using "ZZ".
For 32-bit index modification using "ZZ", specify in a format of ZRmZZn.
Specifying in the format of ZRmZZn modifies the device number ZRm with a
32-bit value in Zn and Zn+1.
"ZZ"
specification*1
ZZ0
ZZ1
ZZ2
ZZ3
ZZ4
ZZ5
ZZ6
ZZ7
ZZ8
ZZ9

*1:

Index registers to be used
Z0, Z1
Z1, Z2
Z2, Z3
Z3, Z4
Z4, Z5
Z5, Z6
Z6, Z7
Z7, Z8
Z8, Z9
Z9, Z10

"ZZ"
*1
specification
ZZ10
ZZ11
ZZ12
ZZ13
ZZ14
ZZ15
ZZ16
ZZ17
ZZ18
ZZ19

Index registers to be used
Z10, Z11
Z10, Z11
Z12, Z13
Z13, Z14
Z14, Z15
Z15, Z16
Z16, Z17
Z17, Z18
Z18, Z19
Cannot be used.

indicates the target device name (ZR, D, or W) to be modified.
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(e) The following are examples of 32-bit index modifications with "ZZ" and actual
process devices.
(When Z0 (32 bits) = 100000, Z2 (16 bits) = -20)
Ladder example

Actual process device

Description

(f)

Functions which allow modification with "ZZ"
The following list shows functions of GX Works2 which allow 32-bit index
modification using "ZZ".
No.
1
2
3
4
5
6

Function name and description
Device specification in program instruction
Entry data monitor
Device test
Executional conditioned device test
Monitor condition setting
Sampling trace
(Trace point (device specification), Trace target device)

POINT
ZZn cannot be used alone as a device like "DMOV K100000 ZZ0". When setting
a value in an index register for 32-bit index modification using "ZZ", set it in Zn (Z0
to Z19).
ZZn alone cannot be input to each function.
For details, refer to QCPU User's Manual (Function Explanation, Program
Fundamentals) and QCPU Programming Manual (Common Instructions).
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Appendix 2.4 Index Modification to Extended Data Registers (D) or Extended Link Registers (W)
(Universal Model QCPU)
Like index modification to data registers (D) and link registers (W) which are
internal user devices, index modification to extended data registers (D) or
extended link registers (W) is allowed in device specification.
Index modification inside
an internal user device
User program

D device image
Internal
user device

Extended
data register

Index modification inside
an extended data register

(a) Index modification where the device number crosses over the boundary
between the internal user device and the extended data register (D) or
extended link register (W)
The specification of index modification where the device number crosses
over the boundary between the internal user device and the extended data
register (D) or extended link register (W) cannot be made. If device range
check is enabled for index modification, an error occurs.
(Error code: 4101)
Index modification inside
an internal user device
User program

D device image
Internal
user device

Extended
data register
Index modification crossing over
the boundary between the internal
user device and the extended data
register is not allowed.
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(b) Index modification where the device number crosses over the boundary
among the file register (ZR), extended data register (D), and extended link
register (W)
Index modification where the device number crosses over the boundary
among the file register (ZR), extended data register (D), and extended link
register (W) will not cause an error.
However, if the result of index modification to a file register (ZR), extended
data register (D), or extended link register (W) changes the file register range,
an error occurs. (Error code: 4101)
An error is not detected in index
modification crossing over the
boundary between the file register
and the extended data register (D).

User program

File register file
File register
(8 K points)
Extended data
register (D)
(8 K points)
Extended link
register (W)
(8 K points)

An error is not detected in index
modification crossing over the
boundary between the extended
data register (D) and extended link
register (W).
An error is detected if the result of
index modification exceeds the
range of the file register file.
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Appendix 2.5 Other Index Modifications
(1) Bit data
Index modification to a device number with digit specification is allowed.
However, index modification to a digit specification is not allowed.

Acceptable because it is index
modification to a device number
If Z2 = 3, it will be X (0 + 3) = X3.

Not acceptable because it is index
modification to a digit specification

(2) For an intelligent function module device *1, index modification to both the start I/O
number of intelligent function module and the buffer memory address is allowed.

If Z1 = 2 and Z2 = 8, it will be
U(10 + 2)\G(0 + 8) = U12\G8.

(3) For a link direct device *1, index modification to both the network number and the
device number is allowed.

If Z1 = 2 and Z2 = 8, it will be
J(1 + 2)\K4X(0 + 8) = J3\K4X8.
*1: For intelligent function module devices and link direct devices, refer to the
following manuals.
 QCPU User's Manual (Function Explanation, Program Fundamentals)
 QnACPU Programming Manual (Fundamentals)
(4) For a cyclic transmission area device *1, index modification to both the start I/O
number of CPU module and the CPU shared memory address is allowed.

If Z1 = 2 and Z2 = 8, it will be
U3E(0 + 2)\G(0 + 8) = U3E2\G8.

*2: For cyclic transmission area devices, refer to the following manual.
 QCPU User's Manual (Function Explanation, Program Fundamentals)
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(5) 32-bit index modification to extended data registers (D) or extended link registers
(W)
(Universal model QCPU)
For index modification to extended data registers (D) or extended link registers
(W), the following 2 options are available as specification methods of index
registers as in the case of index modification to file registers (ZR).
 Specifying the range of index registers used for 32-bit index modification.
 Specifying 32-bit index modification using "ZZ".

Appendix 2.6 Precautions
(1) Index modification between FOR to NEXT instructions
Pulse output is possible between FOR to NEXT instructions by using an edge
relay (V).
However, pulse output using the PLS/PLF/pulse conversion (P) instruction is
not allowed.
[When an edge relay is used]
(M0Z1 provides normal pulse output.)

[When no edge relay is used]
(M0Z1 does not provide normal pulse
output.)

REMARKS
The ON/OFF information of X0Z1 is stored in the edge relay V0Z1.
For example, the ON/OFF information of X0 is stored in V0, and that of X1 in V1.
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(2) Index modification in CALL instruction
Pulse output is possible in CALL instruction by using an edge relay (V).
However, pulse output using the PLS/PLF/pulse conversion (P) instruction is
not allowed.
[When an edge relay is used]
(M0Z1 provides normal pulse output.)

[When no edge relay is used]
(M0Z1 does not provide normal pulse output.)

(3) Device range check in index modification
(a) Other than Universal model QCPU
Device range check is not carried out for index modification.
Thus if the result of an index modification is out of the device range specified
by the user, no error occurs and the data is written in another device.
(However, if the result of an index modification is out of the range of user
devices and the data is written in a system device, an error occurs.
(Error code: 1103))
Carefully create programs with index modifications.
(b) Universal model QCPU
Device range check is carried out for index modification.
In addition, device range check can be disabled in the PLC Parameter setting
of GX Works2.
(4) Changing the index modification range from 16 bits to 32 bits or from 32 bits to 16
bits
When changing the index modification range from 16 bits to 32 bits or from 32 bits
to 16 bits, review index modifications in the program.
For 32-bit index modification, the specified index register (Zn) and the next index
register (Zn+1) are used. Be sure not to overlap index registers to be used.
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Appendix 3 Questions and Answers regarding Personal Computer
This section describes basic knowledge regarding personal computer as questions
and answers. Use the information as necessary.
Q1. What happens if the resolution of the display is less than 800 × 600?
A1. "Icons", which should be displayed at the top end of the screen, may not be
displayed and operations using the "icons" are not possible.
The screen is designed to display all "icons" in the resolution specified in the
manual.

Q2. What is operating environment?
A2. It means the combination of hardware configuration and basic software which can
make full use of GX Works2. Models of personal computers of which operations
are confirmed by Mitsubishi are described in "Models of personal computers of
which operations are confirmed" (PLC-D-375) of Mitsubishi Electric FA Global
Website.
[Programmable controller (Q, QnA, A)] → [Product Details] → [Models of personal
computers of which operations are confirmed]
http://www.nagoya.melco.co.jp/details/plc/confirm/index_j.htm
(Basically, the product operates in the operating environment described in this
manual.)

Q3. What kind of phenomenon occurs when the CPU is Pentium

R

133MHz or lower?

A3. When the CPU is Pentium 133MHz or lower, as the processing speed is slow
and it takes a long time to display a screen after an operation, which interferes
with smooth operations.
R
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Appendix 4 Questions and Answers regarding GX Works2
This section describes questions and answers to solve problems in using GX Works2.
Q1. During editing of a ladder diagram, each ladder is sometimes enclosed in a white
frame depending on the type of the video card (card which for stores characters,
figures, and pictures to be displayed as data). How can I remove the frame?
A1. Change setting as follows on the "Control panel" of
Windows 2000/Windows XP/Windows Vista /Windows 7.
<Operating procedure>
(1) Open the "Control panel".
↓
(2) Open "System".
↓
(3) Open the "Performance" tab.
↓
(4) Press the "Graphics" button.
↓
(5) Set the "Hardware acceleration" setting to the next to "None" (second mark).
R

R

R

R

R

Q2. What should I do if error messages "Can not allocate Share memory" and
"Initialization failed" are displayed at the start-up of GX Works2?
A2. Restart GX Works2. Alternatively, restart
Windows 2000/Windows XP/Windows Vista /Windows 7/Windows 8 and
then start GX Works2.
R

R

R

R

R

R

Q3. Why does it take a long time since Setup.exe is started until the dialog box is
displayed?
A3. It may take a long time if a resident program such as antivirus software is running.
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Q4. Are there any matters to keep in mind if commercially available antivirus software
application is installed in the personal computer?
A4. 1) When antivirus software is started
(1) As the initialization process of the software at start-up takes some time,
other applications launched from the "Startup" folder may not run properly.
In addition, the computer may not accept operations for a while after the
antivirus software is contained in the system tray because of the
initialization process.
These phenomena vary depending on specifications of the use
environment (CPU, memory, etc.).
It has been confirmed that they are likely to occur when the CPU is
Pentium 100 MHz or lower.
R

(2) If the antivirus software is running on Windows Me, be sure to close the
antivirus software before installation of the product.
If the installation of GX Works2 is started with the antivirus software in the
"real-time" monitoring mode, the following dialog box is displayed after 2
to 3 seconds.
R

_delis
エラーが発生しました。このまま続けるには，「無視」を
クリックして作業中のデータを新しいファイルに保存してください。「閉じる」を
クリックすると，このプログラムは終了します。

閉じる(C)

無視(I)

Close the error dialog box, uninstall the product, and then reinstall the
product.
2) Effects on the system
When the antivirus software is running, the software places burden on the
system as it inspects files.
Thus, depending on the use environment, every operation, such as start-up of
an application, may take a long time.
These phenomena vary depending on specifications of the use environment
(CPU, memory, etc.).
It has been confirmed that they are likely to occur when the CPU is Pentium
100 MHz or lower.
R
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3) Effects on applications
If an application does not start up or run properly after installation of the
antivirus software or has a problem of the same sort, follow the steps below to
check the operation.
(1) Uninstall the antivirus software, restart the system, and check how the
application runs again. If the problem still occurs, it is considered not to be
caused by the influence of the antivirus software.
Contact the technical support of the application.
(2) If the application properly runs after the uninstallation of the antivirus
software, install the software again and switch the software to custom
monitoring mode. In addition, remove or place checkmarks in checkboxes
for specifying file extension and monitoring function setting.
If the system does not start up properly even after taking steps (1) and (2),
reinstall Windows
95/Windows 98/Windows Me/WindowsNT Workstation4.0/Windows
2000 Professional and the application.
R

R
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R

R

R

Appendix 5 Warranty
Please confirm the following product warranty details before using this product.

1. Gratis warranty period and gratis warranty range
If any failure found to be the responsibility of Mitsubishi occurs during use of the product within the gratis warranty period,
the product shall be repaired at no cost via the sales representative or Mitsubishi Service Company.
However, if repairs require traveling overseas from a domestic location or traveling to a remote island or an equivalent
remote location, expenses to send an engineer will be solely at the customer's discretion.
[Gratis warranty period]
The gratis warranty period of the product shall be for 36 months after the date of purchase or delivery to a designated
place.
Note that after manufacture and shipment from Mitsubishi, the maximum distribution period shall be 6 months, and the
longest gratis warranty term after manufacturing shall be eighteen 42 months. The gratis warranty period of repair parts
shall not exceed the gratis warranty term before repairs.
[Gratis warranty range]
(1) The range shall be limited to normal use within the usage state, usage methods and usage environment, etc., which
follow the conditions and precautions, etc., given in the instruction manual, user's manual and caution labels on the
product.
(2) Even within the gratis warranty term, repairs shall be charged for in the following cases.
1) Failure occurring from inappropriate storage or handling, carelessness or negligence by the user. Failure
caused by the user's hardware or software design.
2) Failure caused by unapproved modifications, etc., to the product by the user.
3) When the Mitsubishi product is assembled into a user's device, Failure that could have been avoided if
functions or structures, judged as necessary in the legal safety measures the user's device is subject to or as
necessary by industry standards, had been provided.
4) Failure that could have been avoided if consumable parts (battery, backlight, fuse, etc.) designated in the
instruction manual had been correctly serviced or replaced.
5) Failure caused by external irresistible forces such as fires or abnormal voltages, and failure caused by force
majeure such as earthquakes, lightning, wind and water damage.
6) Failure caused by reasons unpredictable by scientific technology standards at time of shipment from Mitsubishi.
7) Any other failure found not to be the responsibility of Mitsubishi or that admitted not to be so by the user.

2. Onerous repair period after discontinuation of production
(1) Mitsubishi shall accept onerous product repairs for 7 years after production of the product is discontinued.
Discontinuation of production shall be notified with Mitsubishi Technical Bulletins, etc.
(2) Product supply (including spare parts) is not available after production is discontinued.

3. Overseas service
Overseas, repairs shall be accepted by Mitsubishi's local overseas FA Center. Note that the repair conditions at each FA
Center may differ.

4. Exclusion of loss in opportunity and secondary loss from warranty liability
Regardless of the gratis warranty period, Mitsubishi shall not be liable for compensation of damages caused by any cause
found not to be the responsibility of Mitsubishi, loss in opportunity, lost profits incurred to the user by failures of Mitsubishi
products, special damages and secondary damages whether foreseeable or not, compensation for accidents, and
compensation for damages to products other than Mitsubishi products and other tasks.

5. Changes in product specifications
The specifications given in the catalogs, manuals or technical documents are subject to change without prior notice.

6. Conditions of use for the product
(1) Mitsubishi MELSEC programmable controller shall be used in conditions where any problem, fault or failure occurring
in the product, if any, shall not lead to any major or serious accident and where the backup and fail-safe functions are
systematically provided outside of the product for the case of any problem, fault or failure occurring in the product.
(2) The programmable controller has been designed and manufactured for the purpose of being used in general
industries. Thus Mitsubishi does not authorize the use of the product in Nuclear Power Plants and any other power
plants operated by Power companies, and/or any other cases in which the public could be affected if any problem or
fault occurs in the product or the use of the product in railway companies, national security or defense organizations,
and/or any other cases in which establishment of a special quality assurance system is required.
Notwithstanding the above, Mitsubishi may authorize use of the product in one or more of these applications, provided
that the usage of the product is limited only for the specific applications agreed to by Mitsubishi and provided further
that the user agrees that no special quality assurance is required.
In addition, if the user is considering the use of the product for aircraft or aerospace, medical applications, train
equipment, transport equipment, incineration and fuel devices, manned transportation, equipment for recreation and
amusement, and safety devices, and/or other applications where there is a significant risk of injury to the public or
property and especially high reliability is required for safety and control systems, the user shall contact the Mitsubishi
representative to exchange necessary specification documents.
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Appendix 6 Programmable Controller Fault Investigation Report
/

/

(Month/Day/Year)

Programmable controller fault report / investigation request
Be sure to attach the document to the product to be sent.
No.

Item
Model

2

Product number /
Version

3

Number of modules

6

7

Enter the proper name (of the report's
recipient).

14

Person in
charge

Company
name
Person in
charge
Company
name
Person in
charge
Contact for
inquiries

15

17

16

(1) 4

(2) 5

(3) 6

(1) Attached report
(2) Repair slip required
(3) Not necessary

8

Report

9

Request number

10

Construction
number

11

Arrival number

12

Branch in charge

No.

13

Place of
occurrence

5

Company
name

No.

Prepar
ed by

4

Customer
name

1

Description

Item

Description
(1) Return after repair
(2) No need to return
(3) Return after
investigation without
repair
(Company name)

Handling of
the product
Address to
return the
product after
repair /
investigation
Date of
occurrence
Date of
installation
Operation
period

(Address)
/
/

18

Ambient
temperature

(1) Normal (2) High (3) Low
(4) Others (
)°C

19

Memory in
use

(1) RAM

20

System
configuration

Appendix

Sales area code

Item

Fault description

22

Usage conditions of
surrounding devices

(SV/MC/INV)

23

Stage of occurrence

(1) Installation and adjustment

Timing of
occurrence
Frequency of
occurrence

(1) During energization
(2) During power-on
(4) At program change
(5) Random
(1) Always
(2) Only once
(4) ( ) times each month week day cycle
(1) Pressing RESET switch
(2) Power OFF/ON
(4) Rewriting program
(5) Rewriting parameters
(7) Repair of wiring
(8) Reinstallation of module

Appendix

25
26

Process for recovery

(2) ROM

(1) Yes (2) No

Description

21

24

/
(Month/Day/Year)
/
(Month/Day/Year)

(2) In operation
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(1) Yes (2) No

(3) Others ( )
(3) During operation
(6) Others ( )
(3) In each operation
(5) Others ( )
(3) Restarting the system
(6) Module replacement
(9) Others ( )

Items to be checked on CPU
No.
27
28
29

Item
Error message (code) (time)
Detailed error information
Other error histories

30

Saving of error histories
LED lighting status

31
32
33

Connection to peripheral (personal
computer)
Backups of programs, parameters,
device memories, and others
Saving of system information

Description
(

Check:  (File name:
.csv)
MODE :
ON (Color:
) Flash
RUN
:
ON
Flash
ERR.
:
ON
Flash
USER
:
ON
Flash
BAT.
:
ON
Flash
BOOT :
ON
Flash
RS232 :
Possible
Not possible
USB
:
Possible
Not possible
Check: 
Check:  (File name:

Other information

Appendix - 26

.csv)

)(

/

/

OFF
OFF
OFF
OFF
OFF
OFF

,

:

:

)

Appendix 7 QCPU Replacement Checklist
Appendix 7.1 Qn(H)CPU Replacement Checklist (One Document for Each Machine)

Preparation

Work

Item

No.

Check

1

Write the date, operator, panel name, and CPU model name to the right column.

2

Write the switch setting of the CPU to be removed and whether there is a memory card to the right column.

Year:

3

Attach a panel name label to the surface of the CPU to be removed.

Operator:

4

Connect GX Developer to the CPU to be removed, and set the PLC type and transfer setup to "PLC Side/F: CPU Module".

Panel name:

5

Check that there is no error for the CPU to be removed. In addition, create a new project after starting up GX Developer and use
the system monitor to check that there is no error for the mounted module.
If some error occurred, write the error code and the error step to the right column and contact the user.

6

Have the user set the RUN/STOP switch of the CPU to remove to "STOP".

Data backup

(2) If the intelligent parameter is used, read it from PLC after saving the project above, and save the project again.
(3) Select device data and initial device value in the CPU and assign it a file name. (Example: DEVICE; Write to the next page)
Click the [Default] button in [Device data]. (Scroll the screen to ensure that all devices are selected) After reading from PLC,
confirm that there is the data and then save the project.
7

(4) If a file register or a local device exists in the CPU standard RAM, write the file name to the next page, read the entire range
into the same project and then save it.
(5) If the file exists in the CPU standard ROM, start up a project newly, as above, read the files, and save it using another project
name. Write the project name and file contents to the next page.

Replacement

(6) If a memory card is used, read the files and save them using another project as above. However, when an SRAM card and a
file register or local device are used, if the same file name is not used, it is possible to save them to the same project as in (1).
Write the file contents to the next page.
8

Write the SERIAL number, which is on the side of the module to be mounted, to the right column.

9

Set the RUN/STOP switch of the CPU to be mounted to STOP, and set other switches as described. Mount the Q6BAT
connector.

10

Have the user turn OFF the power supply of the programmable controller.

11

Remove the target CPU from the base, and write the SERIAL number on the side to the right column.

12

If the user's identification label is attached to it, move the label to the CPU to be mounted.

13

If a memory card is mounted on the removed CPU, move it on the CPU to be mounted.

14

Mount the target CPU on the base in the mounting panel and, if it is to be fixed with screws, tighten the screws.

15

Confirm that the key switch of the mounted CPU is set to "STOP" and that other switch settings are as in the check sheet.

16

Have the user turn ON the power supply of the programmable controller.

17

Check the product information of the relevant module in GX Developer system monitor, and write it to the right column.
(1) Format the program memory/device memory, and standard RAM to be used for the PLC memory. At this point, consult the
user whether it is necessary to reserve the system area, and if it is, configure the setting. However, because this area is only set
when it is formatted, if the user is not sure, do not configure it. [ ] K steps
(2) Select [Include latches] and clear the CPU to be mounted from the PLC memory.
(3) Change reserved steps for online program change. Ask the user the capacity of the reserved steps for online program change
in advance. Reserved step: [ ] steps

Data restoration

18

(4) To the PLC's program memory/device memory, write the files saved earlier (except the device memory) such as parameters
and programs to the PLC, by referring to the next page.

CPU model name Q CPU
Settings of switch etc.

Module to be mounted
SERIAL No.
(production information)
Module to remove
SERIAL No.
(production information)

Product information of
the CPU (replacement)
0000000000-

Error description
before replacement

(5) To the PLC's standard RAM, write the files saved earlier such as a file register and a local device to the PLC, by referring to the
next page.
(6) To the PLC's standard ROM, start up the saved project, refer to the next page, and write only the stored files to the PLC (flash
ROM).
(7) To the memory card, verify all the files against those in the PLC by referring to the next page.

Operation check

(8) Consult the user and, if needed, set the clock.
19

Reset the CPU.

20

To program memory/device memory, click the [Default] button in the [Device data], write PLC's device memory (except "S" (step
relay)) to the CPU and verify the PLC. <<* Unset "S" in the device setting.>>
The SM, SD or link device may have a verify error.

21

If SFC is used for the user's program, consult the user and reset the CPU again.
→ This is because the existing intermediary data may cause malfunction since SFC starts up from the initial step.
→ If there is necessary data for the user outside the latch range, select only that device and write it to the PLC.

22

Check that there is no error for the CPU. Also, check that there is no error for the module mounted on the system monitor.

23

Check the error history and, if no user error exists, clear the error history.

24

Have the user set the RUN/STOP switch of the mounted CPU to "RUN".
* The user should have checked the start-up procedure of the system. (Some applications may require to reset again →
RUN.)

25

If the relevant CPU is connected to a GOT additionally, power OFF and ON the GOT.

26

Check that there is no error for the CPU.
If the user finds the replacement faulty, return the removed CPU to the original place.
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Date:

Memory card: Applicable/Not applicable

(1) Read all programs in the CPU program memory, parameters (PLC/network), and device comments from PLC, and save the
project. Write the project name and file contents to the next page.

Month:

Remarks

Write all project names and file names to frames
Circle either of [Applicable/Not applicable]
Program memory [Project name:
Parameter

Program

]
Device comment

Initial device value

[Applicable/Not applicable]

Intelligent parameter
[Applicable/Not applicable]

Device data

File name

Note 1) Before writing to the
PLC, ensure that the
file register, local
device, and name
are correct.
Note 2) A verification error for
some special device
(SM/SD) and link
fresh device (on a
target station) data
may occur during
PLC verification.

Standard RAM
File register

Note) Use the same project as the program memory.
Before write to PLC, ensure that the destination and the
file name are correct. Writing to the PLC shall be done to
the standard RAM.

Local device

Standard ROM [Project name:
Parameter

Program

]
Device comment

[Applicable/Not applicable]

Intelligent parameter
[Applicable/Not applicable]

File name
Memory card [Project name:
Memory card name

]

File name
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Initial device value

Appendix 7.2 QnU(D)(E)(H)CPU Replacement Checklist (One ocument for Each Machine)

Preparation

Work

Item

No.

Check

Year:

Month:

1

Write the date, operator, panel name, and CPU model name to the right column.

2

Write the switch setting of the CPU to be removed and whether there is a memory card to the right column.

3

Attach a panel name label to the surface of the CPU to be removed.

Panel name:

(1) Start new GX Works2, connect it to the CPU to be removed, select the PLC series (QCPU (Q mode)), and configure the
transfer setup to "Programmable Controller Side I/F: CPU Module". * PLC direct connection

CPU model name Q

4

Operator:

(2) Delete the program "MAIN" from the project data.

5

Check that there is no error for the CPU to be removed, and use the system monitor to check that there is no error for the
mounted module. If some error occurred, write the error code and the error step to the right column and consult the customer.

6

Have the customer set the RUN/STOP/RESET switch of the CPU to remove to "STOP".
(1) Write file contents in the program memory to the next page. Select all of the program range, parameters (PLC/Network/Remote
password/Switch setting/Intelligent function module parameters), global device comment, and initial device values. Select [Also read
the remaining reserved step capacity for online program change] in the program "details" to read from PLC. Finally, save the project (in
a single file format). (If the "Select read module model name" dialog appears after the "Execution" of the read from PLC, select the
implemented model.) Write the save destination to the next page. * Read data other than device data.
(2) Select device data (device memory) in the program memory. Select the device memory "details", and click "Default" on the
"Device data detailed setting". (Scroll the screen to ensure that all available devices are selected) Assign a file name for a device
data name. (Example: DEVICE; Write to the next page)
After the read from PLC, confirm that there is the data and then save the project.
(3) If a file register exists in the standard RAM, write the file name and file size (in bytes) to the next page, read the entire range
into the identical project and then save it. (Select "details" to select the entire range.)

Memory card: Applicable/Not applicable

(4) Delete the device memory "MAIN" from the project data.

Data backup

CPU

Settings of switch etc.

(3) Delete global device comments from the project data.

7

Date:

Module to be mounted
SERIAL No.
(production information)

(4) If files exist in the standard ROM, write the file content to the next page, start up new GX Works2, read the files in a similar way
to the above 4-(1) and its following steps, and save them using another project name. However, if it is device comments or
likewise, and there is no similar file to the program memory, the user can save them to the same project as in (1).
(5) If a memory card is used or files exist, write the file content to the next page, start up new GX Works2, read the files in a similar
way to the above 4-(1) and its following steps, and then save it using another project name. However, if it is a file register or
likewise, and there is no similar file to the program memory, the user can save them to the same project as in (1).
(6) From GX Works2, run [Online] → [Program memory batch transfer] and check whether the content of the program cache

Replacement

memory matches that of the program memory.
* If it does not, or if the user cannot check the whether or not it does depending on the CPU version, a message "Do you
transfer...?" may appear. Then, click the "Yes" button to perform the batch transfer so that they will match.
8

Write the SERIAL number and MAC address (only for the CPU board with Ethernet enabled), which are on the side or under the
face plate of the CPU to be mounted, to the right column.

9

Set the RUN/STOP/RESET switch of the CPU to be mounted to "STOP". Also, connect the battery connector at the bottom of the
module.

10

Have the customer turn OFF the power supply of the programmable controller.

11

Remove the target CPU from the base, and write the SERIAL number and MAC address (only for the CPU board with Ethernet
enabled), which are on the side or under the face plate, to the right column.

12

If the customer's identification label is attached, move it to the CPU to be mounted.

13

If a memory card is mounted on the removed CPU, move it on the CPU to be mounted.

14

Mount the target CPU on the base in the mounting panel and, if it is to be fixed with screws, tighten the screws.

15

Confirm again that the RUN/STOP/RESET switch of the mounted CPU is set to "STOP".

16

Have the customer turn ON the power supply of the programmable controller.

17

Check the product information of the mounted CPU in GX Works2 system monitor, and write it to the right column.

Module to remove
SERIAL No.
(production information)

Product information of the
CPU (module to be mounted)

Error description
before replacement

(1) Format the program memory, standard RAM, and standard ROM to be used for the PLC memory. At this point, consult the
user whether it is necessary to reserve the system area, and if it is, configure the setting. However, because this area is only set
when it is formatted, if the customer is not sure, leave it as the default. [ ] K steps
(2) Select "Include latches" and clear the CPU to be mounted from the PLC memory.

Operation
check

Data restoration

18

(3) To the PLC's program memory/device memory, write the files saved earlier (except the device memory) such as parameters
and programs to the PLC, by referring to the next page.
(4) To the PLC's standard RAM, write the files stored before by referring to the next page.
(5) To the PLC's standard ROM, write only the stored files by referring to the next page.
(6) To the memory card, verify all the files against those in the PLC by referring to the next page.
(7) Consult the customer and, if needed, set the clock.

19

Have the customer turn OFF/ON the power supply of the programmable controller.

20

To the PLC's program memory/device memory, select the device memory "Details", and click "Default" on the "Device data
detailed setting". Confirm that "S" (Step relay) is deselected, write to the PLC, and verify it.
<<* Unset "S" in the device setting.>>
The SM, SD or link fresh device may have a verify error.

21

If SFC is used for the user's program, consult the customer and reset the CPU again.
→ This is because the existing intermediary data may cause malfunction since SFC starts up from the initial step.
→ If there is necessary data for the user outside the latch range, select only that device and write it to the PLC.

22

Check that there is no error for the CPU and use the system monitor to check that there is no error for the mounted module.

23

Check the error history and, if no customer error exists, clear the error history.

24

Have the customer set the RUN/STOP/RESET switch of the mounted CPU to "RUN".
* The user should have checked the start-up procedure of the system. (Some applications may require to reset again → RUN.)

25

Check that there is no error for the CPU. If the user finds the replacement faulty, return the removed CPU to the original place.
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Remarks

Write all project names and file names to frames
Circle either of [Applicable/Not applicable]
Program memory [Project name:
Parameter
Program

]
Program

Comment

[Applicable/Not applicable]

Intelligent parameter
[Applicable/Not applicable]

Device data

Initial device value
[Applicable/Not applicable]

File name

Standard RAM
File size

File register

byte

Note) Use the same project as the program memory.
Before write to PLC, ensure that the destination
and the file name are correct. Writing to the PLC
shall be done to the standard RAM.

Standard ROM [Save destination:
Parameter

]

[Applicable/Not applicable]

File name

Intelligent parameter
[Applicable/Not applicable]

Memory card [Save destination:

]

Memory card name
File name
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Appendix 8 Reference Material for Cart Conveying System Training Machine
The following describes how to check problems and how to take corrective actions in the practical training in
cart conveying system (Section 6.8).
<Fault example 1>
The cart does not move forward. (No.9 terminal of I/O signal disconnection
terminal block is OFF)
(1) Checking the normal operation → Press the start-up switch.
(2) Assuming the failure → Turn OFF the No.9 terminal.
(3) Producing faulty operation → Press the start-up switch. (It will not operate
properly.)
(4) Investigating the cause of faulty operation → Find the cause of the faulty
operation by ladder monitor.
(5) Restoring the normal condition → Turn ON the No.9 terminal.
<Fault example 2>
The cart does not stop at the position of inspection sensor (No.7 terminal of
I/O signal disconnection terminal block is OFF)
(1) Checking the normal operation → Press the start-up switch.
(2) Assuming the failure → Turn OFF the No.7 terminal.
(3) Producing faulty operation → Press the start-up switch. (It will not operate
properly.)
(4) Investigating the cause of faulty operation → Find the cause of the faulty
operation by ladder monitor.
(5) Restoring the normal condition → Turn ON the No.7 terminal.
<Fault example 3>
The cart does not move backward.
(1) Checking the normal operation → Press the start-up switch.
(2) Assuming the failure → Turn ON X3.
(3) Producing faulty operation → Press the start-up switch. (It will not operate
properly.)
(4) Investigating the cause of faulty operation → Find the cause of the faulty
operation by ladder monitor.
(5) Restoring the normal condition → Turn OFF X3.
<Fault example 4>
The cart does not stop at the workpiece set position.
(1) Checking the normal operation → Press the start-up switch.
(2) Assuming the failure → Turn ON X2.
(3) Producing faulty operation → Press the start-up switch. (It will not operate
properly.)
(4) Investigating the cause of faulty operation → Find the cause of the faulty
operation by ladder monitor.
(5) Restoring the normal condition → Turn OFF X2.

Appendix - 31

Appendix 9 Buffer Memory Access Instruction (Abstract from MELSEC-Q/L Programming Manual (Common
Instructions))
Appendix 9.1 Reading One-word or Two-word Data from an Intelligent Function Module (FROM(P), DPRO(P))

means FROM/DFRO.
Command

FROM, DFRO

n1

n2

D

n3

n1

n2

D

n3

Command

FROMP, DFROP
n1: Start I/O number

*1

P

of the intelligent function module (BIN 16 bits)

n2: Start address of the buffer memory in which data to be read is stored (BIN 16 bits)

D : Start number of the devices where the read data will be stored (BIN 16/32 bits)
n3: Number of data blocks to be read (BIN 16 bits)

Setting
data
n1
n2
D

n3

Internal device
Bit
Word





R, ZR

J\
Bit

Word

U\G

Zn

Constants
K, H



－


Others
U

－
－
－

*1: Specify the first three digits of the start I/O number in four-digit hexadecimal notation.

(1) Function
(a) FROM
Reads the data in n3 words from the buffer memory address specified by n2
of the intelligent function module specified by n1 and stores it in the device
specified by D and later.
Intelligent function module
buffer memory

Device specified by D

CPU module

n3 words

n3 points

(b) DFRO
Reads the data in (n3 × 2) words from the buffer memory address specified
by n2 of the intelligent function module specified by n1 and stores it in the
device specified by D and later.
Intelligent function module
buffer memory

CPU module
Device specified by D

(n3×2) words
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(n3×2) points

POINT
Data read from intelligent function modules is also possible with the use of an
intelligent function module device.
For intelligent function module devices, refer to the user's manual (Function
Explanation, Program Fundamentals) of the CPU module to be used.

(2) Error
In the following cases, an operation error occurs, the error flag (SM0) turns on and
an error code is stored in SD0.
Error
code
1402
1412
2110
4101

Q00J/
Q00/
Q01

Error description
An error is detected in the intelligent function module at the
instruction execution.
Cannot communicate with the intelligent function module at the
instruction execution.
The I/O number specified by n1 does not indicate an intelligent
function module.
The range of n3 points (2 × n3 points for DFRO) from the device
specified by D exceeds the specified device range.
The address specified by n2 is outside the buffer memory range.
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QnH QnPH QnPRH QnU LCPU

















































(3) Program example
(a) The following program reads CH1 digital output value of the Q68ADV at I/O
numbers 040 to 04F to D0 when X0 is turned on. (reads data by 1 word from
the buffer memory address 11)
[Ladder mode]

[List mode]
Step

Instruction

Device

(a) The following program reads the current feed value of axis 1 of the QD75P4
at I/O numbers 040 to 05F to D0 and D1 when X0 is turned on. (reads data
by two word from the buffer memory address 800)
[Ladder mode]

[List mode]
Step

Instruction

Device

REMARKS
1. Specify the first three digits of the start I/O number in four-digit hexadecimal
notation as n1.

Power
supply

Start I/O number of
I/O assignment setting
Specify K4 and H4 for read start I/O number.
CPU module

Power
supply

Built-in
I/O

Built-in
CC-Link

Start I/O number of
I/O assignment setting
Specify K6 and H6 for read start I/O number.

2. QCPU and LCPU offer automatic interlock of FROM and DFRO instructions.
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Appendix 9.2 Writing One-word or Two-word Data to an Intelligent Function Module (TO(P), DTO(P))

means TO/DTO.
Command

TO, DTO

n1

n2

S

n3

n1

n2

S

n3

Command

TOP, DTOP

n1: Start I/O number

*1

P

of the intelligent function module (BIN 16 bits)

n2: Start address of the area where data is written (BIN 16 bits)

S : Start number of the data to be written or the devices in which the data is stored (BIN 16/32 bits)
n3: Number of data blocks to be written (BIN 16 bits)

Setting
data
n1
n2
S

n3

Internal device
Bit
Word





R, ZR

J\
Bit

U\G

Word

Zn



－


Constants
K, H





Others
U

－
－
－

*1: Specify the first three digits of the start I/O number in four-digit hexadecimal notation.

(1) Function
(a) TO
Writes the data stored in n3 points from the device specified by

S

to the

buffer memory address specified by n2 and later of the intelligent function
module specified by n1.

Device specified by S

Intelligent function module
buffer memory

CPU module

n3 points

When a constant is designated to

S

n3 words

, writes the same data (value designated

to S ) to the area of n3 words starting from the specified buffer memory. (A
value between -32768 and 32767 or 0H and FFFFH can be designated to S .)
Intelligent function module
buffer memory

CPU module
(When 5 is specified for S)
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n3 words
(Write the same data)

(b) DTO
Writes the data stored in (n3 × 2) points from the device specified by S to
the buffer memory address specified by n2 and later of the intelligent function
module specified by n1.

Device specified by S

Intelligent function module
buffer memory

CPU module

(n3×2)
words

(n3×2) points

When a constant is designated to S , writes the same data (value designated
to S ) to the area of (n3 × 2) words starting from the specified buffer memory.
(A value between -2147483648 and 2147483647 or 0H and FFFFFFFFH can
be designated to

S

.)
Intelligent function module
buffer memory

CPU module

(When 70000 is specified for S )
(n3×2) words
(Write the same data)

POINT
Data write to intelligent function modules is also possible with the use of an
intelligent function module device.
For intelligent function module devices, refer to the user's manual (Function
Explanation, Program Fundamentals) of the CPU module to be used.

(2) Error
In the following cases, an operation error occurs, the error flag (SM0) turns on and
an error code is stored in SD0.
Error
code
1402
1412
2110
4101

Q00J/
Q00/
Q01

Error description
An error is detected in the intelligent function module at the
instruction execution.
Cannot communicate with the intelligent function module at the
instruction execution.
The I/O number specified by n1 does not indicate an intelligent
function module.
The range of n3 points (2 × n3 points for DTO) of data from the
device specified by S exceeds the specified device range.
The address specified by n2 is outside the buffer memory range.
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QnH QnPH QnPRH QnU LCPU

















































(3) Program example
(a) The following program sets the CH1 and CH2 of the Q68ADV at I/O numbers
040 to 04F to "A/D conversion disabled" when X0 is turned on. (writes "3" to
the buffer memory address 0.)
[Ladder mode]

[List mode]
Step

Instruction

Device

(b) The following program sets the positioning address/movement amount of axis
1 of the QD75P4 at I/O numbers 040 to 05F to 0 when X0 is turned on.
(writes 0 to the buffer memory addresses 2006 and 2007.)
[Ladder mode]

[List mode]
Step

Instruction

Device

REMARKS
1. Specify the first three digits of the start I/O number in four-digit hexadecimal
notation as n1.

Power
supply

Start I/O number of
I/O assignment setting
Specify K4 and H4 for read start I/O number.

CPU module

Power
supply

Built-in Built-in
I/O
CC-Link

Start I/O number of
I/O assignment setting
Specify K6 and H6 for read start I/O number.

2. QCPU and LCPU offer automatic interlock of TO and DTO instructions.
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Appendix 10: High Performance Model QCPU Replacement Procedure
Use Qn(H)CPU Replacement Checklist described in Appendix 7.1 together.
POINT
This QCPU replacement procedure describes a referential procedure for a scenario
where the following application programs are installed.
<Application programs>
 All of the program memory, standard RAM, standard ROM and memory cards
are used
 Intelligent parameters (set via GX Configurator) are used.
 An SFC program is used
Appendix 10.1 Preparation
(1) Enter the date, operator, panel name, and CPU model name in QnU(H)CPU
Replacement Checklist.
(2) In the checklist, enter the switch setting of the CPU to be removed and whether
there is a memory card.
Settings of switch etc.

Check the memory card

Memory card: Applicable/Not applicable

Check the switch

(3) For identification, attach a panel name label on the surface of the CPU to be
removed, as needed.
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Appendix 10.2 Data Backup
(1) Connect GX Works2 to the CPU to be removed, and set the PLC type and
transfer setup to "Programmable Controller Side I/F: CPU Module".

(3) Click!

1)

Connect the CPU with a personal computer
using an RS-232C or USB cable.

2)

Start up GX Works2.

3)

Click the [Online] → [Read from PLC] menu.

4)

Set the PLC series to [QCPU(Q Mode)] and
click the OK button.

5)

Select PC side I/F.

6)

Select the cable used for connection and
click the OK button.
* In this case, we use USB connection as
an example for description.

(To the next page)
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(From the previous page)
7)

Set PLC side I/F to the PLC Module.

8)

Click the Connection Test button.

9)

If properly connected, the screen on the left is
displayed. Click the OK button.
If not properly connected, the following
screen is displayed. Check the connection
and conduct the communication test again.

10) Click the OK button.

11) The Read from PLC dialog box is displayed.
Click the Close button.
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(2) Check that there is no error for the CPU to be removed. In addition, create a new
project after starting up GX Works2 and use the system monitor to check that
there is no error for the mounted module.
1)

Click the [Diagnostics] → [PLC Diagnostics]
menu.

2)

Check for errors.

③
(1) クリック!
Click!

If there is no error, the screen on the left is
displayed.

3)

If there is any error, click the
Error JUMP and Error Help buttons to
enter the error details in the check sheet.
Also, check with the user.
Click the Close button to close the PLC
diagnostics dialog box.

4)

Click!
③(4) クリック!

(To the next page)
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Click the [Diagnostics] → [System Monitor]
menu.

(From the previous page)
5)

Check that there is no error for the mounted
module.
If there is no error, the screen on the left is
displayed.
If there is any error for the mounted module,
check with the user.
Click the Close button to close the system
monitor dialog box.

(3) Set the RUN/STOP switch of the CPU to be removed to "STOP".

(4) Choose all the programs, parameters (only for PLC/network), and device
comments, select [Also read the remaining reserved capacity for online program
change] in the program tab, read from PLC, and enter the project name and file
contents in the checklist.

(1)

Click!

1)

Click the [Online] → [Read from PLC] menu.

2)

Set the target memory
memory/Device memory].

(To the next page)
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to

[Program

(From the previous page)
3)

From file selection, click "Parameter +
Program".
*

Even if the intelligent parameter exists,
do not select it.
button of the program.

4)

Click the

5)

Select [Also read the remaining reserved step
capacity for online program change].

6)

Click the OK button.

7)

After the display returns to the Read from
PLC dialog box, click the Execute button.

8)

The message box is displayed. Click the
Yes for All button.

9)

When the read is completed, the dialog box
on the left is displayed. Click the OK
button.

(To the next page)
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(From the previous page)
10) Close the Read from PLC dialog box.
From the project data list, double-click
"Program settings" → "No execution type" →
"(program name)".
The read program is displayed.

11) After reading from PLC, click the [Project] →
[Save as] menu to name the project.
* Be careful not to forget the save location.
(11)

Click!

12) In the "Program memory" field in the
Qn(H)CPU Replacement Checklist, enter the
project name and file contents (files read).
Also, enter whether or not there is a
parameter.

Write all project names and file names to frames
Circle either of [Applicable/Not applicable]
Program memory [Project name:
Parameter

Program

]
Device comment

[Applicable/Not applicable]

Intelligent parameter
[Applicable/Not applicable]
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Initial device value

Enter

(5) If the intelligent parameter is used, save the project, read from PLC, and save the
project again.
1)

Confirm that the intelligent parameter is used.

2)

Select the intelligent parameter.

3)

Click the Execute button.

4)

Close the Read from PLC dialog box, and
then click the [Project] → [Save] menu to
save the project.

(4) Click!

5)

Enter whether the intelligent parameter is selected in [Intelligent parameter] field in Qn(H)CPU
Replacement Checklist.
Write all project names and file names to frames
Circle either of [Applicable/Not applicable]
Program memory [Project name:
Parameter

Program

]
Device comment

[Applicable/Not applicable]

Intelligent parameter
[Applicable/Not applicable]

Enter
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Initial device value

(6) Select a device data and initial device value in the CPU and name a file.
Click the [Default] button in the [Device data] tab. (Scroll down to confirm that all
the devices (including X/Y) are selected.)
After reading from PLC, confirm that there is the data and then save the project.

(1) Click!

1)

Click the [Online] → [Read from PLC] menu.

2)

Set the target memory
memory/Device memory].

3)

Select device data and an initial device value
(if any).

4)

Press the
memory.

5)

Click the Default button.

(To the next page)
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to

[Program

button for the device

(From the previous page)
6)

The message box on the left is displayed.
Click the Yes button.

7)

Check that all the devices (except the
retentive timer) are selected ( ).

8)

Name a device data name.
Example of device data name: DEVICE

6)

Click the
PLC.

Execute

button to read from

10) Select the read file.
11) Confirm that the device data exists.

12) Close the Read from PLC dialog box, and
then click the [Project] → [Save] menu to
save the project.
(11)

Click!

(To the next page)
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(From the previous page)

13) Enter the device data name and initial device value name in [Device data] and [Program memory]
fields in Qn(H)CPU Replacement Checklist.
Write all project names and file names to frames
Circle either of [Applicable/Not applicable]
Program memory [Project name:
Parameter

Program

]
Device comment

[Applicable/Not applicable]

Initial device value

Enter

Intelligent parameter
[Applicable/Not applicable]

Note 1) Before writing to the
PLC
th t th

File nam

Device data

(7) If a file register exists in the CPU standard RAM, enter the file name and file size
(in bytes) in the checklist, read the entire range into the identical project and then
save it.

(1) Click!

1)

Click the [Online] → [Read from PLC] menu.

2)

Set the target memory to [Standard RAM].
Check that the file register exists.

(To the next page)
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(From the previous page)
3)

4)

Select a file and check that the entire range is
selected.

Enter the file name and file size in the [Standard RAM] field in Qn(H)CPU Replacement Checklist.
y
g
PLC verification.

Standard RAM
File register

File size
byte

Standard ROM [Project name:
]
Program
Parameter

Note) Use the same project as the program memory.
Before write to PLC, ensure that the destination
and the file name are correct. Writing to the PLC
shall be done to the standard RAM.

Device comment

Enter

Initial device value

5) Click the Execute button to read from PLC.

6)

(6)

Click!
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Close the Read from PLC dialog box, and
then click the [Project] → [Save] menu to
save the project.

(8) If the file exists in the CPU standard RAM, start up a project newly, as above, read
the files, and save it as another project.
(1) Click!

1)

Click the [Online] → [Read from PLC] menu.

2)

Set the target memory to [Standard RAM]
and check for the file.

1)

Click the [Project] → [New] menu.

2)

Set the PLC series and PLC type and click
the OK button.

* If the file exists, the tasks are as follows:

(1) Click!

(To the next page)
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(From the previous page)
3)

The message box on the left is displayed.
Click the No button.

4)

A new project starts up.

5)

Click the [Online] → [Read from PLC] menu
and set the target memory to [Standard
ROM].

6)

From the file selection, select all of the
program, parameters (PLC/Network/Remote
password/Switch setting), and global device
button for the
comments and click the
program.
*

7)

(To the next page)
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Even if the intelligent parameter exists, do
not select it.

Select [Also read the remaining reserved step
capacity for online program change] to read
from PLC.

(From the previous page)
8)

After reading from PLC, click the [Project] →
[Save as] menu to name the project.

(8) Click!

9)

In the [Standard ROM] field in the Qn(H)CPU Replacement Checklist, enter the project name, file
names and whether one or more parameters exist.
Standard ROM [Project name:
Program
Parameter

]
Device comment

Initial device value

[Applicable/Not applicable]

記入
Enter

Intelligent parameter
[Applicable/Not applicable]

10) If the intelligent parameter exists, select "Online" → "Read from PLC" and set the target memory to
[Standard ROM].
11) Select the intelligent parameter and read
from PLC.

12) Close the Read from PLC dialog box, and
then click the [Project] → [Save] menu to
save the project.
(12) Click!

13) Enter whether the intelligent parameter is selected in [Intelligent parameter] field in Qn(H)CPU
Replacement Checklist.
Standard ROM [Project name:
Program
Parameter

]
Device comment

Initial device value

[Applicable/Not applicable]

Intelligent parameter

Enter
記入

[Applicable/Not applicable]
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(9) If you use a memory card, read the files and save them as another project as
above.
However, when an SRAM card and a file register or local device are used, if the
same file name is not used, it is possible to save them to the same project as in
(4).
Enter the file content in the checklist.

(1) Click!

3)

1)

Click the [Online] → [Read from PLC] menu.

2)

Set the target memory to [Memory card
(SRAM), (Flash) or (ATA)].

Enter the file names in [Memory card] field in Qn(H)CPU Replacement Checklist.
Memory card [Project name:

]

Memory card name

記入
Enter

Q2MEM-

4)

Check if the file names are the same as those in (4).

Program memory [Project name:

]

Device comment

Program

Parameter
[Applicable/Not applicable]

Initial device value

MAIN

Intelligent parameter
[Applicable/Not applicable]

Check whether they are the same

Memory card [Project name:
Memory card name

]
MAIN

Q2MEM-

(To the next page)
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(From the previous page)
5)

Click the [Project] → [New] menu.

6)

Set the PLC series and PLC type and click
the OK button.

7)

A new project starts up.

8)

Click the [Online] → [Read from PLC] menu.

9)

Set the target memory to [Memory card
(SRAM), (Flash) or (ATA)].

(5) Click !

(8) Click!

(To the next page)
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(From the previous page)
10) Read the files.
*

If a file register exists, check that the
entire range is selected.

11) If "The parameters and device memory..."
screen is displayed, click the OK button.

12) Read only the file register.
13) Close the Read from PLC dialog box.

14) After reading from PLC, click the [Project] →
[Save as] menu to newly save the project.

(14) Click!

15) Enter the project name in the [Memory card] field in Qn(H)CPU Replacement Checklist.
Memory card [Project name:
Memory card name

]

Fil
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Enter

Appendix 10.3 Replacement
(1) Enter the SERIAL number on the side or front (N/A in some cases) of the module
to be mounted in the checklist.

(2) Set the RUN/STOP switch of the CPU to be mounted to "STOP", and set other
switches in the same way as for the removed CPU. Also mount the battery
connector.

(3) Turn OFF the power supply of the programmable controller.
(4) Remove the target CPU from the base and enter the SERIAL number on the side
or front in the checklist.
(5) If an identification label is put, move it to the CPU to be mounted.
(6) If a memory card is mounted on the removed CPU, move it on the CPU to be
mounted.
(7) Mount the target CPU on the base in the mounting panel and, if it is to be fixed
with screws, tighten the screws.
(8) Confirm that the RUN/STOP/RESET switch of the mounted CPU to "STOP" and
that other switch settings are as in the check sheet.
(9) Turn ON the power supply of the programmable controller.
*

An error may be displayed for the CPU, but please continue with the task.
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Appendix 10.4 Data Restoration
(1) Check the product information of the corresponding module in the GX Works2
system monitor, and enter in the check sheet.

4)

1)

Click the [Diagnostics] → [System monitor]
menu to display the system monitor dialog
box.

2)

Click the Product Information List button.

3)

The product information list dialog box is
displayed. Check the product information
(serial number, etc.) of the corresponding
module.

Enter the product information in the [Product information of the CPU (replacement)] field in Qn(H)CPU
Replacement Checklist.
Replacement

face plate of the CPU to be mounted, to the right column.
9

Set the RUN/STOP/RESET switch of the CPU to mount to "STOP". Also, connect the battery connector at the bottom the module.

10

Have the customer turn OFF the power supply of the programmable controller.

11

Remove the target CPU from the base, and write the SERIAL number and MAC address (only for the CPU board with Ethernet
enabled), which are on the side or under the face plate, to the right column.

12

If the customer's identification label is attached, move it to the CPU to be mounted.

13

If a memory card is mounted on the removed CPU, move it on the CPU to be mounted.

14

Mount the target CPU on the base in the mounting panel and, if it is to be fixed with screws, tighten the screws.

15

Confirm again that the RUN/STOP/RESET switch of the mounted CPU is set to "STOP".

16

Have the customer turn ON the power supply of the programmable controller.

17

Check the product information of the mounted CPU in GX Works2 system monitor, and write it to the right column.

Product information of the
CPU (module to be mounted)

E rror description
before rep lacem en t

(1) Format the program memory, standard RAM, and standard ROM to be used for the PLC memory. At this point, consult the
user whether it is necessary to reserve the system area, and if it is, configure the setting. However, because this area is only set
when it is formatted, if the customer is not sure, leave it as the default. [ ] K steps
(2) Select "Include latches" and clear the CPU to be mountedfrom the PLC memory.
18

(3) To the PLC's program memory/device memory, write the files saved earlier (except the device memory) such as parameters

Enter

5)

Close the product information list dialog box and the system monitor dialog box.
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(2) Format the program memory/device memory, and standard RAM to be used for
the PLC memory.
At this point, check whether it is necessary to allocate the system area and, if it is,
configure the settings.
However, because this area is set only when formatting, if you are not sure, there
is no need to configure it.
1)

Click the [Online] → [PLC Memory Operation]
→ [Format PLC Memory] menu.

2)

The Format the PLC memory dialog box is
displayed. Set the target memory to
"Program memory".

3)

Select the format.

*

Set the system area if it is necessary to
allocate the area.

4)

Click the Execute button.

5) The message box on the left is displayed. Click
the Yes button.
The program memory or device memory is
formatted.

(To the next page)
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(From the previous page)
6)

Set the target memory to [Standard RAM],
and format it likewise.

7)

Close the Format the PLC memory dialog
box.

(3) Select "Include latches" and clear the CPU to be mounted from the PLC memory.
1)

Click the [Online] → [PLC Memory Operation]
→ [Clear PLC Memory] menu.

2)

The Clear the PLC memory dialog box is
displayed. Select "Include latches".

3)

Click the Execute button.

4)

The message box on the left is displayed.
Click the Yes button.
The PLC memory is cleared.

5)
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Close the Clear the PLC memory dialog box.

(4) To the program memory/device memory of the PLC, write the files saved earlier
(except for the device memory) such as parameters and programs by referring to
the checklist.

(1) Click!

1)

Click the [Project] → [Open] menu.

2)

Open the project saved in (4) to (7) items in
Appendix 10.2.

*

Be careful not to open a wrong project.

3)

Click the [Online] → [Write to PLC] menu.

4)

The Write to PLC dialog box is displayed. Set
the
target
memory
to
"Program
memory/Device memory".

5)

Click the [File selection] tab and select
programs, parameters and so on (except for
the device memory) by referring to the
"Program memory" field in the checklist.

6)

Click the Execute button to write to PLC.

*

If there is no device comment, the message
box on the left is displayed. Click the OK
button.

(3) Click!

(4) Select!
(5) Select!
(6) Click!
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(5) To the PLC's standard RAM, write the files saved earlier such as a file register
(check the capacity: write range ((The number of bytes checked during PLC read
÷ 2) - 1) by referring to the [Standard RAM] field in the checklist.
1)

Click the [Online] → [Write to PLC] menu.

2)

The Write to PLC dialog box is displayed.

(1) Click!

Set the target memory to [Standard RAM].

3)

Check the write range ((The number of bytes
checked during PLC read ÷ 2) - 1) and click
button for the file register.
the
Select a file by referring to the [Standard
RAM] field in the attached checklist.

*

Be careful not to select a wrong file.

4)

Click the OK button and then click the
Execute button to write to PLC.
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(6) For the standard ROM, start up the project to which data was saved, refer to the
[Standard ROM] field in the checklist and write only the stored files to PLC.
1)

As in (4), open the project saved in (8) of
Appendix 10.1.2.

2)

Click the [Online] → [Write to PLC] menu.

3)

The Online data operation (Write) screen is
displayed.

(1) Click!

Set the target memory to [Standard ROM].
4)

Refer to the [Standard ROM] field in the
attached checklist and write the stored files to
PLC.

5)

The message box on the left is displayed.
Click the Yes button.
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(7) For the memory card, verify all the files with those in the PLC by referring to the
[Memory card] field in the checklist.

(1) Click!

1)

As in (4), open the project saved in (9) of
Appendix 10.2.

2)

Click the [Online] → [Verify with PLC] menu.

3)

The Online data operation (Verify) screen is
displayed.
Set the target memory to [Memory card
(SRAM), (Flash) or (ATA)].

4)

Refer to the [Memory card] field in the
checklist and select the same data in the
verify source and destination.

*

If a file register exists, check that the entire
range is selected.

5)

Click the Execute button to verify the data
in the PLC.

6)

Confirm that there is no mismatch.
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(8) If needed, set the clock.
1)

Click the [Online] → [Set Clock] menu.

2)

The Clock setting dialog box is displayed.

(1) Click!

Set the year/month/day, time, and day of the
week.
3)

Click the Set button.

(9) Reset the CPU.
Push down the switch to the reset position, and then return it to the original central
position.
* An error may be displayed for the CPU, but please continue with the task.
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(10) To program memory/device memory, write the device memory (except "S" (step
relay)) to the CPU in the PLC after clicking the [Default] button in the [Device data]
tab and verify the data. <<* Unset "S" in the device setting.>>
(A verification error may occur for the SM, SD or refresh device .)
1)

As in (4), open the project saved in (6) of
Appendix 10.2.

2)

Click the [Online] → [Write to PLC] menu.

3)

The Write to PLC dialog box is displayed.

(1) Click!

Set the target memory
memory/Device memory].

(3) Set!

(5) Click!
(4) Select!

to

[Program

4)

Use the file selection to select the read
device data and initial device value.

*

Be careful not to select wrong device data.

5)

Click the

6)

Check that the step relay (S) is deselected
( ).

7)

Click the Default button.

8)

The message box on the left is displayed.
Click the Yes button.

(To the next page)
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button.

(From the previous page)
9)

Click the OK button to write to PLC.

10) As in (7), click the [Online] → [Verify with
PLC] menu.
(10) Click!

11) The Verify PLC dialog box is displayed.
Set the target memory
memory/Device memory].

to

[Program

12) Refer to the [2) Device data] field in the
attached checklist and select the same data
in the verify source and destination.
*

Be careful not to select a wrong device data.

13) Click the Execute button to verify the data
in the PLC.

14) Confirm that the device matches.
*
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The SM, SD or refresh device may be
mismatched.

(11) If SFC is used for the program, please check and reset the CPU again.
1)

Check if SFC is used.

2)

If SFC is used, check and reset the CPU
again.

*

If an error is displayed for the CPU, reset it.

A different icon appears.
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Appendix 10.5 Operation Check
(1) Check that there is no error for the CPU. Also, check that there is no error for the
module mounted on the system monitor.
1)

Click the [Diagnostics] → [PLC Diagnostics]
menu.

2)

The PLC diagnostics dialog box is displayed.
Check for an error. (The screen on the left is
displayed when there is no error.)

3)

If there is any error, click the
Error JUMP and Error Help buttons to
check the error.

(1) Click!
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(2) Check the error history and, if no current error exists, clear the error history.
1)

Click the [Diagnostics] → [PLC Diagnostics]
menu.

2)

The PLC diagnostics dialog box is displayed.
Click the Clear History button.

3)

The message box on the left is displayed.
Click the Yes button.

4)

Confirm that the error history has been
deleted and then close the dialog box.

(1) Click!

(3) Set the RUN/STOP switch of the mounted CPU to RUN.
(4) If the corresponding CPU is connected to the GOT, turn ON → OFF the power
supply to the GOT.
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(5) Check that there is no error for the CPU. If any faults are found in the replacement,
return the removed CPU to the original place.
(a) As in 1) to 3) in (2) of Appendix 10.2, check that there is no error.
(b) If any faults are found in the replacement (including errors), return the
removed CPU to the original place.
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MEMO
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Service Network (Mitsubishi Electric System & Service Co., Ltd.)
Hokkaido Branch
Niigata Equipment Service Station
Hokuriku Branch
Keiji Equipment Service Station
Kansai Equipment & Electric Affiliate

Kita-Nippon Branch
Himeji Equipment Service Station
Chugoku-Shikoku Branch

Tokyo Equipment & Electric Affiliate
Kanagawa Equipment Service Station

Kanetsu Equipment Service Station

Shizuoka Equipment Service Station

Chubu Branch

Shikoku Branch
Okayama Equipment Service Station

Kyushu Branch
Nagasaki Equipment Service Station

Microsoft, Windows, Windows Vista, Windows NT, Windows XP, Windows Server, Visio, Excel, PowerPoint, Visual Basic,
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PC98-NX is a registered trademark of NEC Personal Computers, Ltd.
SD logo and SDHC logo are registered trademarks or trademarks of SD-3C, LLC.
MODBUS is a registered trademark of Schneider Automation Inc.
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