Engineering Software

GX Developer Version 8
Operating Manual
(SFC)

-SW8D5C-GPPW-E
SAFETY PRECAUTIONS

(Always read these instructions before using this product.)

Before using this product, thoroughly read this manual and the relevant manuals introduced in this manual and pay careful attention to safety and handle the products properly.

The precautions given in this manual are concerned with this product. For the safety precautions of the programmable controller system, refer to the User’s Manual for the CPU module.

In this manual, the safety precautions are ranked as "WARNING" and "CAUTION".

![WARNING]
Indicates that incorrect handling may cause hazardous conditions, resulting in death or severe injury.

![CAUTION]
Indicates that incorrect handling may cause hazardous conditions, resulting in minor or moderate injury or property damage.

Note that the CAUTION level may lead to serious consequences according to the circumstances. Always follow the precautions of both levels because they are important for personal safety.

Please save this manual to make it accessible when required and always forward it to the end user.

[Design Precautions]

![WARNING]
- When data change, program change, or status control is performed from a personal computer to a running programmable controller, create an interlock circuit outside the programmable controller to ensure that the whole system always operates safely.
  Furthermore, for the online operations performed from a personal computer to a programmable controller CPU, the corrective actions against a communication error due to such as a cable connection fault should be predetermined as a system.

![CAUTION]
- The online operations performed from a personal computer to a running CPU module (especially program change, forced output operation, and operating status change) have to be executed after the manual has been carefully read and the safety has been ensured.
  Failure to do so may cause a miss operation which results in machine damage or an accident.
• CONDITIONS OF USE FOR THE PRODUCT •

(1) Mitsubishi programmable controller ("the PRODUCT") shall be used in conditions;
   i) where any problem, fault or failure occurring in the PRODUCT, if any, shall not lead to any major or serious accident; and
   ii) where the backup and fail-safe function are systematically or automatically provided outside of the PRODUCT for the case of any problem, fault or failure occurring in the PRODUCT.

(2) The PRODUCT has been designed and manufactured for the purpose of being used in general industries.
MITSUBISHI SHALL HAVE NO RESPONSIBILITY OR LIABILITY (INCLUDING, BUT NOT LIMITED TO ANY AND ALL RESPONSIBILITY OR LIABILITY BASED ON CONTRACT, WARRANTY, TORT, PRODUCT LIABILITY) FOR ANY INJURY OR DEATH TO PERSONS OR LOSS OR DAMAGE TO PROPERTY CAUSED BY the PRODUCT THAT ARE OPERATED OR USED IN APPLICATION NOT INTENDED OR EXCLUDED BY INSTRUCTIONS, PRECAUTIONS, OR WARNING CONTAINED IN MITSUBISHI'S USER, INSTRUCTION AND/OR SAFETY MANUALS, TECHNICAL BULLETINS AND GUIDELINES FOR the PRODUCT.
("Prohibited Application")

Prohibited Applications include, but not limited to, the use of the PRODUCT in;

• Nuclear Power Plants and any other power plants operated by Power companies, and/or any other cases in which the public could be affected if any problem or fault occurs in the PRODUCT.
• Railway companies or Public service purposes, and/or any other cases in which establishment of a special quality assurance system is required by the Purchaser or End User.
• Aircraft or Aerospace, Medical applications, Train equipment, transport equipment such as Elevator and Escalator, Incineration and Fuel devices, Vehicles, Manned transportation, Equipment for Recreation and Amusement, and Safety devices, handling of Nuclear or Hazardous Materials or Chemicals, Mining and Drilling, and/or other applications where there is a significant risk of injury to the public or property.

Notwithstanding the above, restrictions Mitsubishi may in its sole discretion, authorize use of the PRODUCT in one or more of the Prohibited Applications, provided that the usage of the PRODUCT is limited only for the specific applications agreed to by Mitsubishi and provided further that no special quality assurance or fail-safe, redundant or other safety features which exceed the general specifications of the PRODUCTS are required. For details, please contact the Mitsubishi representative in your region.
### REVISIONS

* The manual number is given on the bottom left of the back cover.

<table>
<thead>
<tr>
<th>Print Date</th>
<th>Manual Number</th>
<th>Revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feb., 2003</td>
<td>SH(NA)-080374E-A</td>
<td>First edition</td>
</tr>
<tr>
<td>Jun., 2004</td>
<td>SH(NA)-080374E-B</td>
<td>Correction, Section 1.1, 1.2</td>
</tr>
<tr>
<td>Apr., 2005</td>
<td>SH(NA)-080374E-C</td>
<td>Correction, About Manuals, 1.1</td>
</tr>
<tr>
<td>Aug., 2005</td>
<td>SH(NA)-080374E-D</td>
<td>Correction, Section 3.7, 3.11</td>
</tr>
<tr>
<td>Mar., 2006</td>
<td>SH(NA)-080374E-E</td>
<td>Correction, Section 3.7, 3.8, 3.14.1, 6.2.1</td>
</tr>
<tr>
<td>Oct., 2006</td>
<td>SH(NA)-080374E-F</td>
<td>Correction, Section 3.7, 6.1</td>
</tr>
<tr>
<td>Apr., 2007</td>
<td>SH(NA)-080374E-G</td>
<td>Correction, Section 1.2, 3.9.2, 3.9.3, 3.13.2</td>
</tr>
<tr>
<td>Jul., 2007</td>
<td>SH(NA)-080374E-H</td>
<td>Addition, Section 3.12.5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Correction, Section 3.12.5 to 3.12.13 are changed to 3.12.6 to 3.12.14.</td>
</tr>
<tr>
<td>Jun., 2008</td>
<td>SH(NA)-080374E-I</td>
<td>Correction, Section 1.1</td>
</tr>
<tr>
<td>Dec., 2008</td>
<td>SH(NA)-080374E-J</td>
<td>Correction, About Manuals, 1.2</td>
</tr>
<tr>
<td>Apr., 2009</td>
<td>SH(NA)-080374E-K</td>
<td>Correction, Section 2.1</td>
</tr>
<tr>
<td>Jan., 2010</td>
<td>SH(NA)-080374E-L</td>
<td>Addition, CONDITIONS OF USE FOR THE PRODUCT, Section 3.12.5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Correction, SAFETY PRECAUTIONS, INTRODUCTION, About Manuals, Section 1.1, 1.2, 2.4, 3.1.2, 3.2, 3.4.1, 3.5, 3.7, 3.8, 3.9, 3.10, 3.12.1, 3.12.6, 3.12.10, 3.12.12, 3.14.1, 3.14.4, 4.1, 4.3, 6.2.1, 3.12.4 changed to 3.12.2, 3.12.5 changed to 3.12.4</td>
</tr>
</tbody>
</table>

Japanese Manual Version SH-080357-P

This manual confers no industrial property rights or any rights of any other kind, nor does it confer any patent licenses. Mitsubishi Electric Corporation cannot be held responsible for any problems involving industrial property rights which may occur as a result of using the contents noted in this manual.

© 2003 MITSUBISHI ELECTRIC CORPORATION
INTRODUCTION

Thank you for choosing the Mitsubishi MELSOFT series Integrated FA software. Read this manual and make sure you understand the functions and performance of MELSEC series programmable controller thoroughly in advance to ensure correct use.

CONTENTS

SAFETY PRECAUTIONS.................................................................................................................. A- 1
CONDITIONS OF USE FOR THE PRODUCT................................................................................ A- 2
REVISIONS..................................................................................................................................... A- 3
INTRODUCTION............................................................................................................................. A- 4
CONTENTSS................................................................................................................................. A- 4
About Manuals ................................................................................................................................... A- 7

1. OVERVIEW 1- 1 to 1- 3

1.1 Product Overview and Features ................................................................................................. 1- 1
1.2 Abbreviations and Generic Terms in This Manual ................................................................. 1- 3

2. PRECAUTIONS FOR CREATING SFC PROGRAMS 2- 1 to 2-11

2.1 Precautions for Use of the ACPU ............................................................................................ 2- 1
2.2 Precautions for Use of the Motion Controller ......................................................................... 2- 5
2.3 Precautions for Use of the QnACPU ....................................................................................... 2- 6
2.4 Precautions for Use of the Q/LCPU ....................................................................................... 2- 6
2.5 Precautions for Use of the FXCPU ......................................................................................... 2- 7

3. SFC PROGRAM EDITING 3- 1 to 3-80

3.1 SFC Program Editing Outline Procedure ............................................................................... 3- 1
   3.1.1 SFC Program Editing Outline Procedure (for ACPU) ......................................................... 3- 1
   3.1.2 SFC Program Editing Procedure Outline (for Q/L/QnACPU) ............................................ 3- 4
   3.1.3 SFC Program Editing Procedure Outline (for FXCPU) .................................................... 3- 6
3.2 SFC Diagram Symbol List ...................................................................................................... 3- 7
3.3 SFC Diagram Editing Basic Screen ....................................................................................... 3-11
3.4 Creating/Modifying the SFC Diagram .................................................................................... 3-13
   3.4.1 (1) Writing an SFC Diagram ............................................................................................... 3-13
   3.4.1 (2) Deleting the SFC Diagram ............................................................................................ 3-38
   3.4.1 (3) Changing the Step Attribute ......................................................................................... 3-39
   3.4.2 Cutting/Copying and Pasting the SFC Diagram ................................................................. 3-40
   3.4.3 Sorting the SFC Diagram .................................................................................................. 3-43
   3.4.4 Redisplaying the SFC Diagram ......................................................................................... 3-44
3.5 Creating the Operation Outputs/Transition Conditions ........................................................ 3-45
3.6 Creating the SFC Comments .................................................................................................. 3-46
   3.6.1 Creating SFC Comments .................................................................................................. 3-46
   3.6.2 Editing the Note for Operation Output ............................................................................. 3-48
3.7 Setting the Block Information ................................................................................................. 3-49
3.8 Display the Block List ............................................................................................................. 3-51
3.9 SFC-Related Parameter Settings ............................................................................................ 3-53
   3.9.1 SFC Setting in PLC Parameters ....................................................................................... 3-53
   3.9.2 Setting the Block Parameters .......................................................................................... 3-54
   3.9.3 SFC Program Setting ....................................................................................................... 3-55
   3.9.4 SFC Program Capacity Check ......................................................................................... 3-56

A - 4

A - 4
3.10 Conversion Operation ................................................................. 3-58
3.11 Instructions for Online SFC Program Writing......................... 3-59
3.12 Making Searches/Replacements ............................................... 3-60
  3.12.1 Searching for a Device/Instruction ....................................... 3-61
  3.12.2 (1) Searching for the Step No./Block No. (SFC Diagram) ... 3-62
  3.12.2 (2) Searching for the Step No./Block No. (Zoom) ............. 3-63
  3.12.3 Searching for a Character String ....................................... 3-63
  3.12.4 Searching for a Device Comment ....................................... 3-64
  3.12.5 Searching for a Jump by Step No. ....................................... 3-64
  3.12.6 Replacing the Devices ....................................................... 3-65
  3.12.7 Replacing the Instructions .................................................. 3-65
  3.12.8 Changing the Open/Close Contacts .................................... 3-65
  3.12.9 Replacing the Character String ......................................... 3-65
  3.12.10 Replacing the Step No. ...................................................... 3-66
  3.12.11 Changing the Note Type ................................................. 3-67
  3.12.12 Searching for Contacts/Coils .......................................... 3-67
  3.12.13 Searching for the Device Use Status ................................ 3-68
  3.12.14 Changing the T/C Set Values .......................................... 3-68
  3.12.15 Changing between SFC and Ladder Programs ................. 3-80
3.13 Providing Displays .................................................................... 3-69
  3.13.1 Displaying the Step/Transition Comments ......................... 3-69
  3.13.2 Displaying the Alias in the SFC Diagram ......................... 3-71
  3.13.3 Displaying the Device Comments ....................................... 3-72
  3.13.4 Displaying Notes .............................................................. 3-72
  3.13.5 Displaying the Alias for Devices ....................................... 3-72
  3.13.6 Changing the Operation Outputs/Transition Conditions to the Ladder Mode/List Mode .......... 3-73
  3.13.7 Displaying in MELSAP-L Format ....................................... 3-74
  3.13.8 Displaying the Reference Window .................................... 3-74
  3.13.9 Opening multiple Windows .............................................. 3-75
3.14 Setting the SFC Diagram Display ........................................... 3-76
  3.14.1 Setting the SFC Diagram Display ....................................... 3-76
  3.14.2 Setting the Zoom Partition ............................................... 3-77
  3.14.3 Setting the Contacts ....................................................... 3-78
  3.14.4 Setting the SFC Setting Options ....................................... 3-79
3.15 Changing between SFC and Ladder Programs ....................... 3-80

4. MONITORING ............................................................................. 4-1 to 4-7
  4.1 SFC Diagram Monitor .......................................................... 4-1
  4.2 Transition Watchdog Monitor ............................................... 4-3
  4.3 Transition Condition and Operation Output Ladder Monitor ...... 4-4
  4.4 All Block Batch Monitor and Active Step Monitor .................. 4-6
  4.5 Block List Monitor .............................................................. 4-7

5. DEBUGGING (STEP RUN) .......................................................... 5-1 to 5-4
# 6. PRINTING THE SFC DIAGRAMS

6.1 SFC Diagram Print Setting ................................................................. 6-1
6.2 SFC Diagram Printing Examples.......................................................... 6-2
   6.2.1 SFC Diagram Printing Examples (when A or Q/L/QnACPU is used) ......................... 6-2
   6.2.2 SFC Diagram Printing Examples (when the FXCPU is used) ........................................... 6-11

| INDEX | Index- 1 to Index- 2 |
About Manuals

The manuals related to this product are shown below. Refer to the following table when ordering required manuals.

### Related Manuals

<table>
<thead>
<tr>
<th>Manual Name</th>
<th>Manual Number (Model Code)</th>
</tr>
</thead>
<tbody>
<tr>
<td>GX Developer Version 8 Operating Manual (Startup)</td>
<td>SH-080372E (13JU40)</td>
</tr>
<tr>
<td>Explains the system configuration, installation method and start-up procedure of GX Developer. (Sold separately)</td>
<td></td>
</tr>
<tr>
<td>GX Developer Version 8 Operating Manual</td>
<td>SH-080373E (13JU41)</td>
</tr>
<tr>
<td>Explains operation methods such as creating, printing, monitoring, and debugging programs using GX Developer. (Sold separately)</td>
<td></td>
</tr>
<tr>
<td>Type MELSAP-II (SFC) Programming Manual</td>
<td>IB-66361 (13JF40)</td>
</tr>
<tr>
<td>Explains the programming method, specifications and functions and so on required for creating SFC programs. (Sold separately)</td>
<td></td>
</tr>
<tr>
<td>MELSEC-Q/L/QnA Programming Manual (SFC)</td>
<td>SH-080041 (13JF60)</td>
</tr>
<tr>
<td>Explains the programming method, specifications, functions and so on required for creating SFC programs. (Sold separately)</td>
<td></td>
</tr>
<tr>
<td>PROGRAMMING MANUAL</td>
<td>JY992D48301</td>
</tr>
<tr>
<td>THE FX SERIES OF PROGRAMMABLE CONTROLLER (FX0, FX0S, FX1N, FX, FX2C, FX2N, FX3NC)</td>
<td>Explains the programming method, specifications and functions and so on required for creating SFC programs for micro PLC. (Sold separately)</td>
</tr>
<tr>
<td>PROGRAMMING MANUAL II</td>
<td>JY992D88101 (09R512)</td>
</tr>
<tr>
<td>THE FX SERIES OF PROGRAMMABLE CONTROLLER (FX1S, FX1N, FX2N, FX3NC)</td>
<td>Explains the programming method, specifications and functions and so on required for creating SFC programs for micro PLC. (Sold separately)</td>
</tr>
<tr>
<td>PROGRAMMING MANUAL - Basic &amp; Applied Instructions Edition</td>
<td>JY997D16601 (09R517)</td>
</tr>
<tr>
<td>FX3U/FX3UC SERIES PROGRAMMABLE CONTROLLERS</td>
<td>Explains the programming method, specifications and functions and so on required for creating SFC programs for micro PLC. (Sold separately)</td>
</tr>
</tbody>
</table>

**REMARK**

The Operating Manuals are included on the CD-ROM of the software package in a PDF file format. Manuals in printed form are sold separately for single purchase. Order a manual by quoting the manual number (model code) listed in the table above.
1. OVERVIEW

1.1 Product Overview and Features

Overview

This manual describes the editing and monitoring operations of the SFC functions among the functions of GX Developer (unless otherwise specified, the product GX Developer herein is its English version 8.) For the functions other than the SFC functions and the specifications related to SFC programs, refer to the corresponding manuals given in "Related Manuals".

The following SFC functions are supported by GX Developer.

<table>
<thead>
<tr>
<th>CPU Compatible</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>MELSAP-II</td>
<td>• ACPU</td>
</tr>
<tr>
<td></td>
<td>• Motion controller*¹</td>
</tr>
<tr>
<td></td>
<td>• QCPU (A mode)</td>
</tr>
<tr>
<td>MELSAP3</td>
<td>• QnACPU</td>
</tr>
<tr>
<td></td>
<td>• Qn(H)CPU (Q mode)</td>
</tr>
<tr>
<td></td>
<td>• QCPU (Q mode)</td>
</tr>
<tr>
<td>FX series SFC</td>
<td>FX0, FX0N, FX1, FX2C, FX1S, FX3G, FX3U, FXINC, FXGNC, FX2NC</td>
</tr>
</tbody>
</table>

*1: The motion controller can use the SFC functions like the ACPU, with the exception of the SFC symbol [SV].
Features

GX Developer-supported SFC (MELSAP-II/MELSAP3/SFC for FX series) has the following features.

SFC is one of the methods that can be used for programming the A series and Q/L/QnA series and FX series CPUs and it stands for Sequential Function Chart. By clearly representing the operating sequence of machinery/equipment controlled by the CPU, this new language makes it easy to grasp the system as a whole, and makes programming easier. In contrast to the case where a program represented by ladders is entirely executed every scan, only the minimum required part of a program may be run if it is written in the SFC format.

1. Many useful editing functions
   (1) The function keys, tool buttons, menu bar and so on improve programming operations.
   (2) You can easily cut and paste your SFC diagrams between two or more window.

2. A wealth of monitoring functions
   (1) Monitoring an SFC diagram for the active steps of an SFC program.
   (2) Monitoring a ladder diagram for the active devices of operation outputs and transition conditions.
   (3) Displaying a list of all blocks and batch-monitoring the active states of the blocks.
   (4) Automatic scrolling enables the track monitoring of the active step.

3. Many useful test functions
   (1) Ease of forced ON/OFF and present value changing of the specified devices
   (2) Forced start/stop and temporary stop of the specified blocks

4. Comment editing and printing choices
   (1) Comments can be written to each step of each SFC diagram.
   (2) You can select printing according to your application, e.g. SFC diagram with operation outputs and transition conditions appended, with SFC comments appended, or just the diagram itself.

Windows is either a trademark or registered trademark of Microsoft Corporation in the United States. Other company and product names herein are either the trademarks or registered trademarks of their respective owners.
1.2 Abbreviations and Generic Terms in This Manual

This manual uses the generic terms and abbreviations listed in the following table to discuss the software packages and programmable controller CPUs. Corresponding module models are also listed if needed.

<table>
<thead>
<tr>
<th>Generic terms and abbreviations</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SFC</td>
<td>Generic term for MELSAP-II, MELSAP3 and SFC for FX series.</td>
</tr>
<tr>
<td>Basic model QCPU</td>
<td>Generic term for Q00JCPU, Q00CPU and Q01CPU.</td>
</tr>
<tr>
<td>High Performance model QCPU</td>
<td>Generic term for Q02(H)CPU, Q06CPU, Q12CPU and Q25CPU.</td>
</tr>
<tr>
<td>Universal model QCPU</td>
<td>Generic term for Q00UCPU, Q00CPU, Q01UCPU, Q02UCPU, Q03UDECPU, Q03UDCPU, Q04UDCPU, Q04UDECPU, Q06UDCPU, Q06UDECPU, Q10UDCPU, Q10UDECPU, Q13UDCPU, Q13UDECPU, Q20UDCPU, Q20UDECPU, Q26UDCPU and Q26UDECPU.</td>
</tr>
<tr>
<td>Process CPU</td>
<td>Generic term for Q02PHCPU, Q06PHCPU, Q12PHCPU and Q25PHCPU.</td>
</tr>
<tr>
<td>Redundant CPU</td>
<td>Generic term for Q12PRHCPU and Q25PRHCPU.</td>
</tr>
<tr>
<td>Q CPU (Q mode)</td>
<td>Generic term for Q00J, Q00U, Q00U, Q01, Q01U, Q02(H), Q02PH, Q02U, Q03U, Q03UD, Q04UD, Q04UDE, Q06, Q06UDE, Q06UD, Q06UDEH, Q10, Q10UDE, Q12H, Q12PH, Q12PRH, Q13UD, Q13UDE, Q20UD, Q20UDEH, Q25H, Q25PH, Q25PH, Q25PRH, Q26UD and Q26UDECPU.</td>
</tr>
<tr>
<td>Q CPU (A mode)</td>
<td>Generic term for Q02(H)CPU-A and Q06CPU-A.</td>
</tr>
<tr>
<td>LPCU</td>
<td>Generic term for L02CPU and L26CPU-BT.</td>
</tr>
<tr>
<td>QnACPU</td>
<td>Generic term for programmable controller CPUs usable with the MELSEC-QnA.</td>
</tr>
<tr>
<td>ACPU</td>
<td>Generic term for programmable controller CPUs usable with the MELSEC-A. In this manual, the QCPU (A mode) and motion controller are also included. (Note that GX Developer does not support the A1, A2, A3, A3H, A3M, A52G, A73 and A0J2.)</td>
</tr>
<tr>
<td>FXCPU</td>
<td>Generic term for programmable controller CPUs usable with the MELSEC-F.</td>
</tr>
<tr>
<td>GX Developer</td>
<td>Generic product name for SW8D5C-GPPW-E, SW8D5C-GPPW-EA, SW8D5C-GPPW-EV and SW8D5C-GPPW-EVA product types.</td>
</tr>
<tr>
<td>GPPQ</td>
<td>SWIVD-GPPQ</td>
</tr>
<tr>
<td>GPPA</td>
<td>SWIVD-GPPA</td>
</tr>
<tr>
<td>GPPA</td>
<td>SWIVD-GPPA</td>
</tr>
<tr>
<td>Software package for motion controller</td>
<td>Generic term for software packages for motion controller which allow SFC programs to be edited.</td>
</tr>
</tbody>
</table>
# 2. PRECAUTIONS FOR CREATING SFC PROGRAMS

This chapter gives precautions for creating SFC programs with GX Developer.

## 2.1 Precautions for Use of the ACPU

<table>
<thead>
<tr>
<th>Item</th>
<th>GX Developer</th>
<th>GPPA</th>
</tr>
</thead>
<tbody>
<tr>
<td>User microcomputer program</td>
<td>• Cannot be created. • Erased if another format file that is read includes a microcomputer program other than an SFC program.</td>
<td>• The A0J2H, AnS, AnSH and AnNCPUs allow SFC and microcomputer programs to exist together.</td>
</tr>
<tr>
<td>SFC capacity</td>
<td>• The parameter setting of the microcomputer capacity must be made. However, since the capacity is not checked at the time of creation, checking operation is needed to make sure that the SFC capacity is within the microcomputer capacity range. (Refer to POINT.)</td>
<td>• A program can be created within the parameter-set &quot;microcomputer capacity&quot; and SFC-set &quot;block count&quot; ranges.</td>
</tr>
<tr>
<td>Maximum block count setting</td>
<td>• A program can be created as desired within the maximum number of blocks (256 blocks). • For another format write or PLC write, write up to the largest existing block number as a set value. However, write &quot;32&quot; when the existing blocks are within 32.</td>
<td>• Up to which block of the maximum number of blocks (256 blocks) will be created must be set on the SFC diagram editing screen. (Default value: 32)</td>
</tr>
<tr>
<td>CPU type change (QnA→ACPU)</td>
<td>• As the CPU type is changed with the parameter setting of the microcomputer capacity remaining unchanged from &quot;0k bytes&quot;; the microcomputer capacity setting must be changed after CPU type changing.</td>
<td>(Without QnA→ACPU conversion function for SFC program)</td>
</tr>
<tr>
<td>Hold step</td>
<td>• Representation of hold step SC</td>
<td>• Representation of hold step S</td>
</tr>
</tbody>
</table>

*Different in only representation method and identical in function.

<table>
<thead>
<tr>
<th>Block start step</th>
<th>A block start step is also handled as a single step and a step comment appears when SFC comment indication is given.</th>
<th>The comment displayed at the block start step is the block title of the start destination block.</th>
</tr>
</thead>
</table>

*A program printed is as displayed on the screen.*
## PRECAUTIONS FOR CREATING SFC PROGRAMS

<table>
<thead>
<tr>
<th>Item</th>
<th>GX Developer</th>
<th>GPPA</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>SFC comment creation</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• SFC comments may either be created simultaneously with SFC diagram creation or during comment editing.</td>
<td>• SFC comments are created in the SFC diagram writes mode.</td>
</tr>
<tr>
<td></td>
<td>• SFC comments are handled as common comments, and device comments can be created with a block title specified as &quot;BLm&quot;, a step comment as &quot;BLmSn&quot;, and a transition comment as &quot;BLmTRn&quot;.</td>
<td>• As SFC comments are handled in SFC diagrams only, they cannot be handled as device comments.</td>
</tr>
<tr>
<td><strong>Block title</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Can be edited up to 32 characters.</td>
<td>• Can be edited up to 24 characters.</td>
</tr>
<tr>
<td></td>
<td>• When the block title is reread after another format write or PC write, a character string of more than 24 characters are erased.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• The block title is not read if the file stored without SFC comment copying being performed for a renaming or copying operation on GPPA is read in another format. (The block title is read if it is read in another format after making re-conversion on GPPA.)</td>
<td></td>
</tr>
<tr>
<td><strong>Note for operation output</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Each coil instruction of an operation output can be annotated.</td>
<td>• An operation output cannot be annotated.</td>
</tr>
<tr>
<td></td>
<td>• When written to GPPA in another format, the note for operation output is not written.</td>
<td></td>
</tr>
<tr>
<td><strong>Creating and displaying an SFC diagram for stepless selection branches and selective couplings</strong></td>
<td>Not allowed</td>
<td>Allowed (Refer to POINT.)</td>
</tr>
</tbody>
</table>

### POINT

**SFC capacity**

After creating a SFC diagram and performing a conversion operation, perform the following operation to check that the existing SFC program capacity is within the preset microcomputer capacity.

**[Operating procedure]**

**[Tools]—[Set SFC information]—[Program capacity check]**

**[Screen]**

![Check of SFC program capacity](image)

If "SFC program capacity is beyond the microcomputer cap." appears on the right of Result of check, PLC write or another format write cannot be performed as it will result in an error.

Change the microcomputer capacity setting to a value equal to or greater than the "Created SFC program capacity".
• Creating and displaying a SFC diagram including stepless selective branch or selective coupling

When a SFC diagram includes stepless selective branch or selective coupling, the following message appears.

<When displaying or printing a SFC program that are incorrectly displayed>

If either above message appears, take the following corrective actions.
1. Modify the program with SW IVD-GPPA. (Refer to POINT (1) in this section.)
2. Re-create a program with GX Developer. (Refer to POINT (2) in this section.)
(1) Modifying the program with SWIPD-GPPA

1. Display all SFC diagrams in GX Developer and check blocks that are incorrectly displayed.
2. Modify the program with SWIPD-GPPA.
   Enter a dummy step/transition for the incorrectly displayed SFC diagram.
   The following figure shows the types of SFC diagrams that are incorrectly displayed in GX Developer and actions against them.

   (Modification example)

   ![Diagram showing examples of modifications](image)

   (When adding a dummy step) (When changing to jump transition)

3. Read the modified program to GX Developer.
   Always check operations for the modified program.

(2) Re-creating a program with GX Developer

When a SFC diagram is incorrectly displayed, it is displayed in partially corrupted.
Re-create the corrupt part.
### 2.2 Precautions for Use of the Motion Controller

<table>
<thead>
<tr>
<th>Item</th>
<th>GX Developer</th>
<th>Software Package for Motion Controller</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step attribute</td>
<td>• Since the step attribute is not supported, a step read in another format is an ordinary step ( ). However, since an operation output program is read intact, no influence is given to its operations. • Since an operation output program cannot be created automatically in the system, an equivalent program must be created by the user.</td>
<td>• Supported.</td>
</tr>
<tr>
<td>Others</td>
<td>With the exception of the step attribute ( ), the precautions are the same as those for use of the ACPU.</td>
<td></td>
</tr>
</tbody>
</table>
2.3 Precautions for Use of the QnACPU

<table>
<thead>
<tr>
<th>Item</th>
<th>GX Developer</th>
<th>Software Package for Motion Controller</th>
</tr>
</thead>
<tbody>
<tr>
<td>SFC comments</td>
<td>• SFC comments are handled as common comments.</td>
<td>• SFC comments are handled as program-by-program comments.</td>
</tr>
<tr>
<td></td>
<td>• When another format file write is performed from GX Developer to GPPQ, the file is divided into a program file and a comment file and therefore renaming and other operations are needed on GPPQ.</td>
<td></td>
</tr>
<tr>
<td>SFC diagram pattern</td>
<td>• If an SFC diagram created is redisplayed in a different pattern, verifying that diagram may result in a mismatch. Example: Created → Redisplayed. A mismatch occurs if the above SFC diagram is redisplayed or project-read, &quot;converted&quot;, and verified.</td>
<td>Same specifications as those of GX Developer.</td>
</tr>
<tr>
<td></td>
<td>• A mismatch occurs if the above SFC diagram is redisplayed or project-read, and &quot;converted&quot;, and verified.</td>
<td></td>
</tr>
</tbody>
</table>

2.4 Precautions for Use of the Q/LCPU

There are no specific precautional restrictions for the SFC program editing of the Q/LCPU.
2.5 Precautions for Use of the FXCPU

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| FX SFC programming        | • The FXCPU uses stepladder instructions (STL, RET) to control the sequence of a process. These stepladder instructions can also be expressed as SFC diagrams.  
                            • GX Developer (SW5D5C-GPPW-E or later) and later versions support this FX SFC programming.  
                            • For details of the FXCPU SFC programming method, refer to the programming manual of each CPU.  
                            • The method of expressing FX series stepladder instructions in GX Developer differs from that of FXGP (DOS) and FXGP (WIN).  
                            For details, refer to the GX Developer operating manual.                                                                                                                                                                                                 |
| Steps and states          | In GX Developer, an SFC process is called a "step". In the programming material and other programming software for the FXCPU, an SFC process is called a "state". Both "steps" and "states" indicate SFC processes.                                                                                   |

Relationship between a STL diagram and an SFC diagram

A stepladder instruction and an SFC diagram are essentially the same. In an actual program, they are expressed as follows. (This is different to a screen display.)

<STL diagram>

<STL diagram>

- M8002 SET S 0
- S 0 X000 SET S 20
- S 20 Y023 Y021 Advance
- X011 SET S 21
- S 21 Y021 Y023 Reverse
- X012 SET S 22
- S 22 T 0 K 50
- X013 SET S 23
- S 23 Y023 Y021 Advance
- X014 SET S 24
- S 24 Y021 Y023 Reverse
- X012 SET S 0
- S 0 RET End of stepladder
- END

Circuit not belonging to SFC (ladder block)

Initial step

Advance

Reverse

Pause timer

Advance

Reverse

End of stepladder
## Precautions for Creating SFC Programs

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Step number** (state (S) number) | States S0 to S9 are called initial steps (states). They are always used as the first block No. of an SFC block.  
  Consequently, when the FXCPU is used, up to 10 (S0-S9) SFC blocks can be created.  
  S10 and higher numbers can be used as general step numbers. However, the maximum  
  number of steps per block is 512.  
  You cannot use step (state) numbers more than once. |
| **Ladder block**                | A sequence circuit that programs the outside of a step (state) is called a ladder block.  
  A ladder block operates in the same way as a general ladder program. |
| **Number of branches in a flow** | The number of circuits in the case of one parallel branch or selective branch is limited to 8 circuits per branch.  
  However, if there are many parallel branches or selective branches, the overall number of  
  circuits is limited to 16 circuits per initial step.  
  <Note> 8 circuits per branch (parallel or selective) max  
  Total of 16 circuits max  
  You cannot perform a transition or reset operation from confluence lines or a step prior to  
  confluence to a separation step.  
  Create a dummy step and be sure to perform the transition or reset operation from the  
  branch line to a separation step. |
| **Role of a block list and block type** | In the case of the FXCPU, when writing a block list it is necessary to select either a ladder block or an SFC block.  
  Regarding stepladder blocks contained in STL (stepladder instruction), it is possible to  
  make a type change to an SFC block later. |
### Jump attribute

- A jump has two kinds of attributes, which are changed according to the particular purpose.
  - Jump to another step or another flow (step attribute: [None])
  - Reset jump for a self-step (state) (step attribute: [R])

For a jump, \( \downarrow \) is input as the initial value. A change to \( \uparrow \) is made using the step attribute of the [SFC symbol] dialog box.

- If the jump destination is in a different SFC block, the jump destination mark will not appear at that jump destination step.

### Handling a RET instruction

- The RET instruction of a stepladder instruction is automatically written from the end of the SFC block to the part connected to the ladder block. Consequently, you cannot input a RET instruction to an SFC block or a ladder block. (Does not appear on the screen either.)

- Note that in the case of the following ladder program, if you change over to the SFC program, then change back to the ladder program, the number of program steps in the RET instruction part will decrease.

### Transition comment

Transition comments cannot be used in the case of FX SFC.

### Transition condition number

The transition condition number is valid only in an SFC diagram.

For this reason, if you change over to a ladder program, this number does not continue. Consequently, if you change back to SFC a program that you changed to a ladder, the transition number will change.
## 2 PRECAUTIONS FOR CREATING SFC PROGRAMS

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can change a ladder program to a SFC program, or vice-versa, by setting [Project] → [Edit Data] → [Change program type].</td>
<td></td>
</tr>
</tbody>
</table>

- **Precautions to observe when changing a ladder program to an SFC program**

  If a ladder program that uses a stepladder (STL, RET) instruction cannot be converted to a SFC block, it will change to a ladder block.

  In this case, the message "Ladder block!", which indicates the incompletion of the change, will appear in the block type box of the block list.

  **[Ladders that cannot be changed]**
  
  1. When there is no initial step
  2. When the number of steps used in one block exceeds 512
  3. When a branch or confluence is incorrect
  4. When the transition conditions are programmed in the same circuit as that of the operation outputs (See figure below)

  ![Diagram of ladder program modification](image)

  **Correction method:** Insert a dummy step after the parallel branch, and modify the program to jump to another step in dummy step.

  - **Statements are deleted.**
  - **Notes added to STL, RET, OUT S, SET S and RST S are not converted.** (They are deleted.)

  **[Ladders in which a change error occurs]**
  
  1. When there is a circuit defect
  2. When there is an instruction code error
  3. When a step (state) number is used more than once

- **Method of treating stepladder (STL, RET) instructions that cannot be changed to SFC blocks**

  Method (1) First, modify the ladder program, then change it to SFC.

  Method (2) In the case of a simple modification, first convert SFC ("Ladder block!" incomplete condition).

  After modifying the program in ZOOM of the ladder block, change the block type to "SFC block" by means of [Edit] → [Block information].
### Program type change

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Program type change** | • Precautions to observe when changing an SFC program into a ladder program [SFC that cannot be changed]
  (1) When an unregistered (blank) block exists in the block list (when blocks are not contiguous)
  (2) When ladder blocks are contiguous
  (3) When there are unconverted blocks
• Method of treating SFC that cannot be converted into a ladder program
  Display the block list, then execute [Convert] → [Convert block (all blocks)], end the arranging of the block list and the conversion of unconverted parts, then once again set a program type change. |

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Compatibility of project data** | • A project that was stored as an SFC program using the GX Developer (SWD5C-GPPW-E or later) or a later version cannot be read using a version prior to the GX Developer (SW4D5C-GPPW-E or earlier), which is not compatible with the FX SFC.
• If the project of an SFC program is read using a version prior to the GX Developer (SW4D5C-GPPW-E or earlier), it is treated as the project of a non-supported CPU, and an error message is displayed.
• If it is necessary to share the project with an incompatible version, change it to a ladder program using [Project] → [Edit data] → [Change program type], then save the project. |

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| **PC type change** | • When the FXCPU is selected: This CPU supports only a PC type change to the FXCPU.
• For ACPU, QCPU (A mode): These CPUs do not support a PC type change to the FXCPU. |

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| **PC write/read/compare** | • Precautions to observe when writing a program
  (1) When writing an SFC program, be sure to write the entire step range. (You cannot perform a partial write operation.)
  (2) You cannot perform a write operation if there is an unconverted block, there is an unregistered (blank) block in the list, or the ladder blocks are contiguous.
  Execute [Convert] → [Convert block (all blocks)], then re-write the program.
  (3) Program change during RUN, a timer or a counter set value change in the online mode (write during RUN) are not supported. |

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| **PC write/read/compare** | • Precautions to observe when reading a program
  (1) When reading a program, be sure to read the entire step range. (You cannot perform a partial read operation.)
  (2) If you cannot change a read program into an SFC block, register it in the block list as a ladder block. |

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| **PC write/read/compare** | • Precautions to observe when comparing programs
  (1) When comparing programs, be sure to use the entire range. (You cannot perform a partial comparison.)
  (2) The transition number on the SFC screen is not stored in the PC, so it is not the object of comparison.
  (3) The contents of block type and also unconverted blocks are not the object of comparison. |

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Writing/reading/comparing other format files** | • Notes and statements cannot be read/written to files of other formats (FXGP (WIN), FXGP (DOS)).
• For other precautions, refer to "PC read/write/compare". |
3. SFC PROGRAM EDITING

3.1 SFC Program Editing Outline Procedure

3.1.1 SFC Program Editing Outline Procedure (for ACPU)

1) GX Developer start

(To create new program)

Creation of new project
Setting of PLC series, PLC type and project name

Parameter setting
Set the microcomputer capacity by setting the memory capacity in the PLC parameter.

Addition of new edit data
Newly add program type "SFC" as edit data.

SFC option setting
Set the reference window, a jump to start destination block, and automatic scroll monitoring.

Select the language.

Set the number of contact columns displayed.

Set the SFC display column.

(To create new program)

SFC write
Write SFC diagram from block 0.

2) Open the project.

(To modify the existing program)

(Refer to POINT 1.)

(Refer to POINT 2.)
1) Conversion operation
   Block information
   Write the transition condition/
   operation output program
   step-by-step.
   (To create another block)
   Check the SFC program capacity.
   Save the project.

2) Read the block to be modified.
   Write, insert, delete
   SFC diagram modifying operation
   Step-by-step operation output/
   transition condition correcting
   operation
   Conversion operation
   Block information

Write
Write the SFC diagrams and SFC
comments to the specified block.
Display the specified block.
When creating a new SFC program, you need to make the parameter setting of the microcomputer capacity and perform a new edit data adding operation. Perform the following operation before SFC diagram editing.

1) Parameter setting of microcomputer capacity

- Set the microcomputer capacity and perform the operation of Check → OK → End setup.

2) Addition of new edit data

- Choose Program at Data type, change Program type to "SFC", and click the OK button. The following window then appears.

Choosing Yes enables an SFC diagram to be edited under the data name of "MAIN-SFC".
3.1.2 SFC Program Editing Procedure Outline (for Q/L/QnACPU)

1) GX Developer start
   (To create new program)

   Creation of new project
   Set the PLC series, PLC type and project name, and set the program type to “SFC”.

   SFC parameter setting
   Set the SFC program start mode, block 0 start condition, and output mode at block deactivation.

   Other parameter settings
   Set the other parameters as required.

   Block parameter setting
   Set the "Periodic Execution Block No.", "Act at Block Multi-Activated" and "Act at Step Multi-Activated".

   SFC program setting

   SFC option setting
   Set the reference window, a jump to start destination block, and automatic scroll monitoring.

   Toolbar setting
   Set the toolbar display for "SFC".

2) Open the project.
   (To modify the existing program)
1) Select the language.
   Set the number of contact columns displayed.
   Set the SFC display column.

(To create new program)

SFC write
Write SFC diagram from block 0.
Conversion operation
SFC information register setting
Write the transition condition/operation output program step-by-step.

(To create another block)

Save the project.

(To modify the existing program)

Read the block to be modified.
Write, insert, delete
SFC diagram modifying operation
Step-by-step operation output/transition condition correcting operation
Conversion operation
SFC information register setting, modification

**POINT**

This outline procedure is given for your reference.
You can perform the operations in any order without following the above procedure.
3.1.3 SFC Program Editing Procedure Outline (for FXCPU)

**GX Developer startup**

(When newly created)

- **New creation of project**
  - Set PC series, PC type, and project name, and use "SFC" as program type.

- **SFC optional settings**
  - Set reference window and auto scroll monitor.

- **Block list registration**
  - Register ladder block in block 0.
    - (Block information setting)

**Ladder program write/modification**

**Conversion operation**

- **Block list registration**
  - Register SFC block in block 1.
    - (Block information setting)

- **Transition condition/operation output program write/modification for each step**

**Conversion operation**

- **Block list registration**
  - Register SFC block in blank block.
    - (Block information setting)

If there is an unconverted block, or there is an unregistered (blank) block in the block list, execute [Convert] [Convert block (all blocks)] while the block list is displayed, then end the arranging of the block list and the conversion of unconverted parts.

**POINT**

This outline procedure is for reference only.
You may perform each operation in an arbitrary sequence.
The following table lists symbols used in SFC programs. A block is an operation sequence, which starts at an initial step and ends at an end step. The smallest units of operations are steps and transitions. Further, transition conditions and operation outputs are represented in ladder diagrams using the zoom of the display function or in instruction lists.

### [A series SFC diagram symbol list]

<table>
<thead>
<tr>
<th>Class</th>
<th>Name</th>
<th>Symbol</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step</td>
<td>Initial step</td>
<td></td>
<td>One step in each block</td>
</tr>
<tr>
<td></td>
<td>Step</td>
<td>![symbol]</td>
<td>Max. 254 steps. in each block (i=1 to 254)</td>
</tr>
<tr>
<td></td>
<td>Block start step</td>
<td>![symbol]</td>
<td>Number of steps in each block (more than one step may be provided for the same block)</td>
</tr>
<tr>
<td></td>
<td>END step</td>
<td>![symbol]</td>
<td>More than one step may be provided in each block.</td>
</tr>
<tr>
<td>Transition</td>
<td>Series transition</td>
<td>![symbol]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Selective branch</td>
<td>![symbol]</td>
<td>(Left end) (Middle) (Right end)</td>
</tr>
<tr>
<td></td>
<td>Selective coupling</td>
<td>![symbol]</td>
<td>(Left end) (Middle) (Right end)</td>
</tr>
<tr>
<td></td>
<td>Parallel branch</td>
<td>![symbol]</td>
<td>(Left end) (Middle) (Right end)</td>
</tr>
<tr>
<td></td>
<td>Parallel coupling</td>
<td>![symbol]</td>
<td>(Left end) (Middle) (Right end)</td>
</tr>
<tr>
<td></td>
<td>Jump transition</td>
<td>![symbol]</td>
<td>(j=jump destination step)</td>
</tr>
</tbody>
</table>
### [Q/L/QnA series SFC diagram symbol list]

<table>
<thead>
<tr>
<th>Class</th>
<th>Name</th>
<th>SFC Diagram Symbol</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step</strong></td>
<td><strong>Initial step</strong></td>
<td>[ ] 0</td>
<td>Any one of these steps in one block</td>
</tr>
<tr>
<td></td>
<td><strong>Dummy initial step</strong></td>
<td>[ ] 0</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Coil hold initial step</strong></td>
<td>[ ] 0</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Operation hold step (without transition check) initial step</strong></td>
<td>[ ] 0</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Operation hold step (with transition check) initial step</strong></td>
<td>[ ] 0</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Reset initial step</strong></td>
<td>[ ] i Sn</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Initial step</strong></td>
<td>[ ] i</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Dummy initial step</strong></td>
<td>[ ] i</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Coil hold initial step</strong></td>
<td>[ ] i</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Operation hold step (without transition check) initial step</strong></td>
<td>[ ] i</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Operation hold step (with transition check) initial step</strong></td>
<td>[ ] i</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Reset initial step</strong></td>
<td>[ ] i Sn</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Step</strong></td>
<td>[ ] i</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Dummy step</strong></td>
<td>[ ] i</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Coil hold step</strong></td>
<td>[ ] i</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Operation hold step (without transition check)</strong></td>
<td>[ ] i</td>
<td>Including initial step, max. 512 steps in one block</td>
</tr>
<tr>
<td></td>
<td><strong>Operation hold step (with transition check)</strong></td>
<td>[ ] i</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Reset step</strong></td>
<td>[ ] i Sn</td>
<td>m = Start destination block number</td>
</tr>
<tr>
<td></td>
<td><strong>Block start step (with end check)</strong></td>
<td>[ ] i Bm</td>
<td>n = Reset destination step number</td>
</tr>
<tr>
<td></td>
<td><strong>Block start step (without end check)</strong></td>
<td>[ ] i Bm</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>END step</strong></td>
<td>[ ]</td>
<td>Multiple steps can be provided in one block</td>
</tr>
<tr>
<td>Class</td>
<td>Name</td>
<td>SFC Diagram Symbol</td>
<td>Quantity</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------</td>
<td>--------------------</td>
<td>----------</td>
</tr>
<tr>
<td>Series transition</td>
<td></td>
<td>+ a</td>
<td></td>
</tr>
<tr>
<td>Selective branch</td>
<td></td>
<td>a — b — n</td>
<td></td>
</tr>
<tr>
<td>Selective branch-parallel branch</td>
<td></td>
<td>a — b</td>
<td></td>
</tr>
<tr>
<td>Selective coupling</td>
<td></td>
<td>+ a — b</td>
<td></td>
</tr>
<tr>
<td>Selective coupling-parallel branch</td>
<td></td>
<td>+ a — b</td>
<td></td>
</tr>
<tr>
<td>Parallel branch</td>
<td></td>
<td>+ a</td>
<td></td>
</tr>
<tr>
<td>Parallel coupling</td>
<td></td>
<td>+ a</td>
<td></td>
</tr>
<tr>
<td>Parallel coupling-parallel branch</td>
<td></td>
<td>+ a</td>
<td></td>
</tr>
<tr>
<td>Parallel coupling-selective branch</td>
<td></td>
<td>+ a — b</td>
<td></td>
</tr>
<tr>
<td>Parallel coupling-selective coupling</td>
<td></td>
<td>+ a — b</td>
<td></td>
</tr>
<tr>
<td>Jump</td>
<td></td>
<td>a — j</td>
<td></td>
</tr>
</tbody>
</table>
### [FX series SFC diagram symbol list]

<table>
<thead>
<tr>
<th>Class</th>
<th>Name</th>
<th>Symbol</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ladder</td>
<td>Ladder block</td>
<td>![LD]</td>
<td>Max 11 in block list</td>
</tr>
<tr>
<td>Step</td>
<td>Initial step</td>
<td>![i]</td>
<td>1 in each block (i=0-9)</td>
</tr>
<tr>
<td></td>
<td>Step</td>
<td>![i/? i]</td>
<td>Max 512 in each block (i=10-999)</td>
</tr>
<tr>
<td>Transition</td>
<td>Series transition</td>
<td>![? \</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Selective branch</td>
<td>![ Left end Middle Right end]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Selective coupling</td>
<td>![ Left end Middle Right end]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Parallel branch</td>
<td>![ Left end Middle Right end]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Parallel coupling</td>
<td>![ Left end Middle Right end]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Jump transition</td>
<td>![ i j (j=jump destination step)]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Reset jump</td>
<td>![i \ j (j=Reset jump destination step)]</td>
<td></td>
</tr>
</tbody>
</table>
3.3 SFC Diagram Editing Basic Screen

(1) Whole screen make-up

1) Area for displaying the project name being edited, the number of steps used, the block number being displayed and so on

2) Menu names on the menu bar

3) Icons on the toolbar

4) Project list display

5) SFC diagram editing area

6) Operation output/transition condition program editing area (Zoom side)

7) Edited CPU type

8) Edit mode (overwrite/insert)
(2) SFC diagram editing screen make-up

- The Zoom-side display shows the operation output/transition condition at the cursor position in the SFC diagram.
- Some menus that may be selected/operated change depending on whether the cursor is on the SFC diagram side or on the Zoom side.
- Perform the following operation to show the SFC chart in the specified block.
  1. Move the cursor from [View] \(\rightarrow\) [Display block list] \(\rightarrow\) any display block position, and press the [Enter] key.
  2. Choose [View] \(\rightarrow\) [Display block list] \(\rightarrow\) any block position, and double-click that position.
  3. Choose [Find/Replace] \(\rightarrow\) [Find step no./block no.] \(\rightarrow\) any block No., and specify it.
  4. Press the space key on the block starting step in the SFC chart.
  5. Move the cursor from [Window] \(\rightarrow\) data name, and press the [Enter] key.
  6. Move the cursor from [Window] \(\rightarrow\) data name, and double-click it.
3.4 Creating/Modifying the SFC Diagram

3.4.1 (1) Writing an SFC Diagram

An SFC diagram may be created in any of the following four methods.

1. Starting from the tool button on the toolbar
2. Starting from the function key
3. Starting from the menu on the toolbar
4. Starting from pressing the Enter key

Performing any of the above operations shows the Enter SFC symbol window.

Enter data by the operations given on the pages that follow.
(1-1) Operation starting from the tool button (when A or Q/L/QnACPU is used)

Write (overwrite) operation example

1) Step (□) / (×)

- **Diagram symbol**
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click [ ] and choose a new diagram symbol.

- **Step number**
  The system automatically assigns lower to higher step numbers in the order of entry.
  When you will use the step numbers automatically assigned by the system, you can omit the "step number" input operation.
  At a dummy step, you can create an operation output program if it is marked "×", which will change to "□" automatically after the program is created.

- **Step attribute**
  When adding a step attribute, click [ ] and choose the attribute you want to add.
  When you chose the reset step (R) as a step attribute, enter the reset destination step number after making selection.
• Comment creation
You can enter a comment of up to 32 characters.
The comment created can be displayed by "step/transition comment display" operation in the display menu.

2) Block start step ( \( \downarrow, \uparrow \) )

• Diagram symbol
The diagram symbol name selected appears.
To change the diagram symbol selected, click ↓ and choose a new diagram symbol.

• Start destination block number
Enter the start destination block number.

• Step number
The system automatically assigns lower to higher step numbers in the order of entry.
When you will use the step numbers automatically assigned by the system, you can omit the "step number" input operation.

• Comment creation
You can enter a comment of up to 32 characters.
The comment created can be displayed by "step/transition comment display" operation in the display menu.
3) Series transition (− −)

• Diagram symbol
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click and choose a new diagram symbol.

• Transition condition number
  The system automatically assigns lower to higher transition condition numbers in the order of entry.
  When you will use the transition condition numbers automatically assigned by the system, you can omit the "transition condition number" input operation.

• Comment creation
  You can enter a comment of up to 32 characters.
  The comment created can be displayed by "step/transition comment display" operation in the display menu.
4) Selective branch (→)

• Diagram symbol
The diagram symbol name selected appears.
To change the diagram symbol selected, click ▼ and choose a new diagram symbol.

• Number of branches
Enter the number of branch line columns.
If it is “1”, you can omit the input operation.

5) Parallel branch (⇒)

• Diagram symbol
The diagram symbol name selected appears.
To change the diagram symbol selected, click ▼ and choose a new diagram symbol.

• Number of branches
Enter the number of branch line columns.
If it is “1”, you can omit the input operation.
6) Selective coupling

- Diagram symbol
  The diagram symbol name selected appears. To change the diagram symbol selected, click and choose a new diagram symbol.

- Number of couplings
  Enter the number of coupling line columns. If it is "1", you can omit the input operation.

7) Parallel coupling

- Diagram symbol
  The diagram symbol name selected appears. To change the diagram symbol selected, click and choose a new diagram symbol.

- Number of couplings
  Enter the number of coupling line columns. If it is "1", you can omit the input operation.
### POINTS

- **Input method used when a branch and a coupling are used together in a single transition condition**
  
  1) **For Q/L/QnACPU**

  When a branch and a coupling are used together in a single transition condition, reserve an area for one step using "|" (vertical line) and then enter the branch and coupling symbols.

  **Example 1:**
  
  ![Example 1](image1)

  **Example 2:**
  
  ![Example 2](image2)

  2) **For ACPU**

  As a branch and a coupling cannot be used together in a single transition condition, enter a dummy step.

  **Example 1:**
  
  ![Example 1](image3)

  **Example 2:**
  
  ![Example 2](image4)

- **For branch/coupling line entry, entering the number of branches/couplings as "-n" creates them from right to left.**
8) Jump transition (↑ →)

- Diagram symbol
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click down and choose a new diagram symbol.

- Jump destination step number
  Enter the jump destination step number.
  Clicking the OK button changes the indication of the step specified as the jump destination from ( ) to ( )..

9) End step (↓ →)
10) Rule write

- To write a rule, click \( \frac{2}{3} / \frac{2}{3} / \frac{2}{3} / \frac{2}{3} \) and drag from the first position to the last position of the rule entry.

**POINT**

If you write a rule over the existing step/transition, the step/transition symbol and operation output/transition condition sequence program are not erased.

11) Row insert

12) Column insert

13) Row delete

14) Column delete
Write (insert) operation example

When an SFC diagram is created by a write (insert) operation, insertion results are as described below on an SFC diagram symbol basis. Note that step/transition condition number changing, simultaneous SFC comment creation and so on can be performed as in the write (overwrite) operation.

1) Step ( □ )

- Point the cursor to a desired position and click the SFC symbol (step) to insert a step in the cursor position.
- When you insert a step over "|" (vertical line) without changing the step number, the lowest free number of the existing SFC diagram is assigned.
- When the insert position is within a branch ladder, "|" (vertical line) is automatically inserted into another branch.

2) Series transition ( - )

- Point the cursor to a desired position and click to insert a transition in the cursor position.
- When you insert a transition over "|" (vertical line) without changing the transition condition number, the lowest free number of the existing SFC diagram is assigned.
- When the insert position is within a branch ladder, "|" (vertical line) is automatically inserted into another branch.
3) Selective branch (→)

4) Parallel branch (→)

5) Selective coupling

6) Parallel coupling

**POINTS**

- Entering "-n" as the number of branches/couplings enters them from right to left.
  Example: Number of couplings "1"

- Inserting a branch/coupling may generate an SFC diagram that cannot be converted.
  In this case, correct the SFC diagram with the edit function (cut and paste) and then perform a conversion operation.
(1-2) Operation starting from the tool button (when the FXCPU is used)

Write (overwrite) operation example

1) Register a ladder block in block list No.0.

![Block information setting dialog box]

2) Creating a ladder circuit

![Ladder circuit diagram]
3) Register an SFC block in block list No.1.
Block list display: Double-click [View] → [Display block list], or [Program] in the project list → [MAIN].

Double-click

Select "SFC block".

Complete
3 SFC PROGRAM EDITING

POINTS

• Block list

(1) When the FXCPU is used, first register "Ladder block" or "SFC block" in the block list, then start to create the program.

Register the block list from the top.

<table>
<thead>
<tr>
<th>No.</th>
<th>Block title</th>
<th>Block type</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Initial selection circuit</td>
<td>- Ladder block</td>
</tr>
<tr>
<td>1</td>
<td>Auto operation start step</td>
<td>- SFC block</td>
</tr>
<tr>
<td>2</td>
<td>Mechanizing No.1</td>
<td>- SFC block</td>
</tr>
<tr>
<td>3</td>
<td>Mechanizing No.2</td>
<td>- SFC block</td>
</tr>
<tr>
<td>4</td>
<td>Mechanizing No.3</td>
<td>- SFC block</td>
</tr>
<tr>
<td>5</td>
<td>Product control circuit</td>
<td>- Ladder block</td>
</tr>
</tbody>
</table>

(2) You cannot change to a ladder program or write to the PC if there is an unconverted block or unregistered (blank) block in the block list, or the ladder blocks are contiguous.

Display the block list, execute [Convert] → [Convert block (all blocks)], then end the arranging of the block list and the conversion of unconverted parts.

(3) Circuits that cannot be changed into SFC blocks

If you attempt to change an existing ladder circuit, for example, into SFC, the change sometimes fails to take place because of some kind of error, even when the circuit contains a stepladder (STL) instruction.

In this case, the circuit is registered as "Ladder block!" in block type, that is, as a ladder block to which the "!" mark is appended.

After changing the contents of the circuit, change the type of block to SFC block using [Edit] → [Block information].

Circuit that could not be changed into SFC block
4) Step ()

- Diagram symbol
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click and choose a new diagram symbol.

- Step number
  A step number is a number that the system automatically assigns in ascending input sequence over the range of S10-S999. (The upper limit differs depending upon the PC type. Also, the maximum number of steps per block is 512.)
  If the step number automatically assigned by the system is satisfactory, you can omit the "step number" input operation.
  S0-S9 are assigned to the beginning of the SFC block as the initial blocks, so you cannot input them to a general step position.
  You cannot input a step number more than once.
  When the FXCPU is used, dummy steps are also treated in the same way as general steps, however there is no need to create an operation output program.

- Step attribute
  When the FXCPU is used, the step has no attribute apart from when a "JUMP" symbol is set.

- Comment creation
  You can enter a comment of up to 32 characters.
  The comment created can be displayed by "step/transition comment display" operation in the display menu.
5) Series transition ( - )

- **Diagram symbol**
  The diagram symbol name selected appears. To change the diagram symbol selected, click and choose a new diagram symbol.

- **Transition condition number**
  The system automatically assigns lower to higher transition condition numbers in the order of entry. When you will use the transition condition numbers automatically assigned by the system, you can omit the "transition condition number" input operation. When the FXCPU is used, the transition condition number is valid only on the SFC diagram. For this reason, this number does not continue when a change is made to a ladder program.

- **Comment creation**
  When the FXCPU is used, transition comments are not supported.
6) Selective branch (→ )

- Diagram symbol
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click ▼ and choose a new diagram symbol.

- Number of branches
  Enter the number of branch line columns.
  If it is "1", you can omit the input operation.

7) Parallel branch (→ →)

- Diagram symbol
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click ▼ and choose a new diagram symbol.

- Number of branches
  Enter the number of branch line columns.
  If it is "1", you can omit the input operation.
8) Selective coupling

- Diagram symbol
  The diagram symbol name selected appears. To change the diagram symbol selected, click \( \text{ } \) and choose a new diagram symbol.

- Number of couplings
  Enter the number of coupling line columns. If it is "1", you can omit the input operation.

9) Parallel coupling

- Diagram symbol
  The diagram symbol name selected appears. To change the diagram symbol selected, click \( \text{ } \) and choose a new diagram symbol.

- Number of couplings
  Enter the number of coupling line columns. If it is "1", you can omit the input operation.
POINTS

• Input method used when a branch and a coupling are used together in a single transition condition

As a branch and a coupling cannot be used together in a single transition condition, enter a dummy step.

When the FXCPU is used, there is no symbol called "dummy step", so input a general step. There is no need to input a control output circuit, and so on, in a dummy step.

Example 1)

Example 2)

• For branch/coupling line entry, entering the number of branches/couplings as "-n" creates them from right to left.

POINTS

Branch number

The number of circuits in the case of one parallel branch or selective branch is limited to 8 circuits per branch.

However, if there are many parallel branches or selective branches, the overall number of circuits is limited to 16 circuits per initial step.

You cannot perform a transition or reset operation from confluence lines or a step prior to confluence to a separation step.

Create a dummy step and be sure to perform the transition or reset operation from the branch line to a separation step.
10) Jump transition ( ▶ )

- **Diagram symbol**
  The diagram symbol name selected appears. To change the diagram symbol selected, click and choose a new diagram symbol.

- **Jump destination step number**
  Enter the jump destination step number. Clicking the OK button changes the indication of the step specified as the jump destination from ( ▶ ) to ( ▼ ). When the FXCPU is used, if the jump destination is in another SFC block, the step of the jump destination is displayed as ( ▶ ).

- **Step attribute**
  In the case of a general jump, select [None].

11) Reset jump transition ( ▼ )

- **Diagram symbol**
  Select "JUMP" as the diagram symbol.

- **Jump destination step number**
  Input the step number to be reset. (Normally input the step number immediately prior to the jump destination.)

- **Step attribute**
  In the case of a reset jump, select [R].
12) Rule write

- To write a rule, click and drag from the first position to the last position of the rule entry.

**POINT**

If you write a rule over the existing step/transition, the step/transition symbol and operation output/transition condition sequence program are not erased.

13) Row insert

14) Column insert

15) Row delete

16) Column delete
Write (insert) operation example

When an SFC diagram is created by a write (insert) operation, insertion results are as described below on an SFC diagram symbol basis. Note that step/transition condition number changing, simultaneous SFC comment creation and so on can be performed as in the write (overwrite) operation.

1) Step (square)

- Point the cursor to a desired position and click the SFC symbol (step) to insert a step in the cursor position.
  When you insert a step over "|" (vertical line) without changing the step number, the lowest free number of the existing SFC diagram is assigned.

- When the insert position is within a branch ladder, "|" (vertical line) is automatically inserted into another branch.

2) Series transition (vertical line)

- Point the cursor to a desired position and click to insert a transition in the cursor position.
  When you insert a transition over "|" (vertical line) without changing the transition condition number, the lowest free number of the existing SFC diagram is assigned.

- When the insert position is within a branch ladder, "|" (vertical line) is automatically inserted into another branch.
3) Selective branch ( ——— )

4) Parallel branch ( ——— )

5) Selective coupling

6) Parallel coupling

**POINTS**

- Entering "-n" as the number of branches/couplings enters them from right to left. Example: Number of couplings "1"
  
  ![Diagram]

- Inserting a branch/coupling may generate an SFC diagram that cannot be converted.
  In this case, correct the SFC diagram with the edit function (cut and paste) and then perform a conversion operation.
(2) Operation starting from the function key

1) The SFC symbols are assigned to the following function keys.

### Step

<table>
<thead>
<tr>
<th>SFC symbol</th>
<th>Function key</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>□ / □</td>
<td>F5</td>
<td>A, Q/L/QnACPU only</td>
</tr>
<tr>
<td></td>
<td>F6</td>
<td>Q/L/QnACPU only</td>
</tr>
<tr>
<td></td>
<td>Shift + F6</td>
<td>A, Q/L/QnA only</td>
</tr>
<tr>
<td></td>
<td>F8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>F7</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Shift + F5</td>
<td></td>
</tr>
</tbody>
</table>

### Transition or branch/coupling

<table>
<thead>
<tr>
<th>SFC symbol</th>
<th>Function key</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>F5</td>
<td></td>
</tr>
<tr>
<td></td>
<td>F6</td>
<td></td>
</tr>
<tr>
<td></td>
<td>F7</td>
<td></td>
</tr>
<tr>
<td></td>
<td>F8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>F9</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Shift + F9</td>
<td></td>
</tr>
</tbody>
</table>

### Rule entry

<table>
<thead>
<tr>
<th>SFC symbol</th>
<th>Function key</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Alt + F5</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Alt + F7</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Alt + F8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Alt + F9</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Alt + F10</td>
<td>Ctrl + F9</td>
</tr>
</tbody>
</table>

2) Operation procedure

- **Step/transition/branch/coupling entry**
  1. Press the function key.
  2. Since the window as was shown when the tool button was clicked appears, refer to the tool button operation procedure and enter the required items.
  3. Press the **Enter** key.

- **Rule entry**
  1. Press the function key.
  2. Using the arrow keys, move the cursor to the first position of a branch/coupling.
  3. Hold down the **Shift** key and move the cursor with the arrow keys.
  4. Move the cursor to the last position of the branch/coupling and release your hand from the key.
(3) Operation starting from the menu on the toolbar
   • Step/transition/branch/coupling entry
     1) Click [Edit] on the toolbar.
     2) Move the cursor to [SFC symbol] in the edit menu.
     3) Click the SFC symbol to be entered.
     4) Since the window as was shown when the tool button was clicked appears, refer to the tool button operation procedure and enter the required items.
     5) Press the Enter key.

   • Rule entry
     1) Click [Edit] on the toolbar.
     2) Move the cursor to [Edit the line] in the edit menu.
     3) Click the branch/coupling line to be entered.
     4) Drag from the first position to the last position of the entry.

(4) Operation starting from the Enter key
   1) Press the Enter key.
   2) Since the window as was shown when the tool button was clicked appears, refer to the tool button operation procedure and enter the required items.
   3) Press the Enter key.

POINT
Operation starting from the Enter key is a method useful for entry of steps ( ) and transitions ( ) consecutively in the column direction.
3.4.1 (2) Deleting the SFC Diagram

This section explains how to delete the existing SFC diagram symbols.

(1) Operation using the tool button to delete
   1) Specifying the area and making deletion

   ![Diagram](image)

   (Drag)

   2) Deleting the branch/coupling/vertical line only

   ![Diagram](image)

   (Drag)

(2) Operation using the function key to delete
   - Hold down the **Shift** key and choose the deletion area with the arrow keys.
   - Press the **Delete** key.

(3) Operation to delete from the menu on the toolbar
   - With the mouse, drag over the area to be deleted.
   - Click [Cut] in the edit menu.

**POINT**

Performing the [Undo] operation after making a deletion returns to the status immediately prior to the deletion.

- Tool button : Click ![Tool Button]
- Function key : **Ctrl** + **Z**
- Menu : Click [Undo] in the edit menu.
3.4.1 (3) Changing the Step Attribute

This section describes how to change the step attribute in the existing SFC diagram. The step attribute can be changed by any of the following tool button clicking, menu operation and key pressing.

<table>
<thead>
<tr>
<th>Tool Button</th>
<th>Key Pressing</th>
<th>Menu</th>
<th>Description</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Ctrl + 1" /></td>
<td>Ctrl + 1</td>
<td>1) Editing ↓ 2) Step attribute setting ↓ 3) Choose a new attribute.</td>
<td>• Makes the preset step attribute invalid.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Ctrl + 2" /></td>
<td>Ctrl + 2</td>
<td></td>
<td>• Changes the preset step attribute to SC.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Ctrl + 3" /></td>
<td>Ctrl + 3</td>
<td></td>
<td>• Changes the preset step attribute to SE.</td>
<td>Q/L/QnACPU only</td>
</tr>
<tr>
<td><img src="image" alt="Ctrl + 4" /></td>
<td>Ctrl + 4</td>
<td></td>
<td>• Changes the preset step attribute to ST.</td>
<td>Q/L/QnACPU only</td>
</tr>
<tr>
<td><img src="image" alt="Ctrl + 5" /></td>
<td>Ctrl + 5</td>
<td></td>
<td>• Changes the preset step attribute to R and sets the reset destination step No. • When it has already been set to R, changes the reset destination step No.</td>
<td>Q/L/QnACPU only</td>
</tr>
</tbody>
</table>

**POINT**

If the step attribute has been changed, the existing operation output sequence program remains unchanged.
3.4.2 Cutting/Copying and Pasting the SFC Diagram

This section provides the operation to cut/copy and paste the SFC diagram.

(1) Specifying the area, cutting or copying the SFC diagram, and pasting it

[Operation procedure]
1. Choose [Edit]→[Write mode] or \( F2 \).
2. Click the first position of the SFC diagram to be cut, and move the cursor.

3. Drag over the area to be cut or copied.
The specified area is highlighted.

4. When cutting, choose [Edit]→[Cut] or \( Ctrl \)+X, or when copying, choose [Edit]→[Copy] or \( Ctrl \)+C to cut the ladder in the specified area.

5. Click the position where the cut (copied) SFC diagram will be applied, and move the cursor.
6. When you choose [Edit] → [Paste] or Ctrl + V, the Paste data window appears. Make pasting choices.

1) Action and TR data
2) Step and TR comments
3) No change the step and TR number when it is pasted

1) Selection of whether or not the operation output/transition condition sequence program is also pasted simultaneously.
2) Selection of whether or not the original step/transition condition number is changed.
3) Selection of whether or not the step/transition comment is also pasted simultaneously.

POINT

"Not changing" the original step/transition condition number is useful for a moving operation.

7. When you selected "not to" change the original step/transition condition number but the pasting destination already has the same step/transition condition number, the following window appears.

Choosing Yes executes pasting after the system has assigned a new number by reassigning lower to higher free numbers to the step/transition condition numbers of the pasting destination SFC diagram. Choosing No suspends pasting.
8. When the first position of the cut or copied SFC diagram is a step and its pasting position is a transition position, or vice versa, the following window appears.

![Window](image)

When this window has appeared, click the OK button, move the pasting position one row higher or lower, then perform a pasting operation again.

9. After the pasting operation is over, make conversion.
   Note that a conversion error occurs if a branch/coupling is incorrect after pasting. Therefore, make conversion after performing the SFC diagram editing operation.

![Diagram](image)

**POINTS**

- Cutting/copying and pasting between different blocks in the same program can be executed by displaying the corresponding blocks by performing [Window] → [Tile vertically] or [Tile horizontally] operation.
- Cutting/copying and pasting between different projects can be executed after opening the corresponding projects by performing [Project] → [Start new GX Developer session] operation.
- Copying of an operation output/transition condition sequence program should be done within approx. 2k steps.
3.4.3 Sorting the SFC Diagram

This operation reassigns the step/transition numbers of the created SFC diagram.

[Operation procedure]
[Tools] → [Sort] or 

[Setting items]
1) Sorting Order
   Specify whether the step/transition numbers are in an ascending or descending order.
2) Change START block number
   Specify whether the start destination block number is to be changed or not.
3) Set START block number
   When you have selected "Change", enter a new block number.
4) [Execute] button
   Executes sorting as set on the above screen.

POINTS
• The result of executing sorting by specifying an ascending or descending order is as follows.
  (When ascending order is specified)  (When descending order is specified)

  *Immediately after sorting, a "Undo" operation can be performed only once.
  *is step "0" if you specify either the ascending or descending order.

• The SFC devices (e.g. BLm\Sn, BLm\TRn) used with the operation outputs/transition conditions are not the objects of sorting.
  Sort them by performing a device number changing operation or the like.
3.4.4 Redisplaying the SFC Diagram

[Setting purpose]
This operation is performed to return the unconverted SFC diagram being edited to the status immediately prior to editing, or to top-shift or left-shift the freed row or column of the "|" (vertical line)/branch/coupling line.

[Operation procedure]
[View]→ [Review SFC]

1) Top-shift redisplaying example

2) Left-shift redisplaying example

3) Unconverted SFC diagram redisplaying example

4) After-conversion SFC diagram optimizing display
3.5 Creating the Operation Outputs/Transition Conditions

When creating an operation output/transition condition program, move the cursor to the corresponding step/transition in the SFC diagram and click the Zoom side. The subsequent operations are the same as in the ladder or list creating method. For detailed operations, refer to the SW5D5C-GPPW-E(V) Operating Manual.

**POINTS**

- There are instructions which cannot be used with operation outputs/transition conditions.
  
  - For more information, refer to the "Type MELSAP-II (SFC) Programming Manual" for the ACPU or to the "MELSECNET-Q/L/QnA Programming Manual (SFC)" for the Q/L/QnACPU.

- As a transition condition, only one dummy coil (\(-\text{Tran}\)-) may be entered for the coil instruction.
  
  - To enter it, click \(\frac{\text{Tran}}{\text{Tran}}\) or \(\frac{\text{Tran}}{\text{Tran}}\) and click the OK button.
  
  - \(\text{Tran}\) is entered automatically.

- For entry in list representation, enter only the contact instruction and the dummy coil (\(-\text{Tran}\)-) need not be entered.

- For the ACPU, no transition condition can be entered into the block starting step. The condition entered is ignored if the SFC program is executed after write to the programmable controller CPU, and execution transits to the next step at the END step processing of the start destination block. Note that the following guidance appears when the transition condition is entered or the SFC chart is converted.

  - **When the transition condition is entered in the ladder/list**

    - **MELSOFT series GX Developer**

      ![Image](image1.png)

      - The edited program has a transition condition directly under the block starting step. This transition condition will be disregarded even if the SFC program is executed after the PLC write.

  - **When the SFC chart is converted**

    - **MELSOFT series GX Developer**

      ![Image](image2.png)

      - The program block(6, transition3) has transitionals directly under the block starting step. This transition condition will be disregarded even if the SFC program is executed after the PLC write.

  - **Instructions that cannot be used in the case of the FXCPU**

    - **Ladder blocks**: RET, END
    - **Steps**: MC, MCR
      - STL, RET (step ladder instruction)
      - SET S*, OUT S*, RST S*
        (transition instruction with stepladder)
      - END, FEND
      - P/I, CJ, SRET, IRET
    - **Transition conditions**: P/I
      - STL, RET (stepladder instruction)
      - Coil instructions and output instructions other than the TRAN symbol
3.6 Creating the SFC Comments

An SFC comment is a generic name for a "step comment" attached to each step of the created SFC diagram and a "transition comment" attached to each transition. In addition, a "block title" is available as a comment related to SFC diagrams. This section explains how to create and correct SFC comments and block titles.

3.6.1 Creating SFC Comments

You can create an SFC comment when entering an SFC symbol. Also, you can create a block title when converting the SFC diagram. This section describes how to create/correct only comment data after SFC diagram creation.

(1) Performing operation on the SFC diagram editing screen

[Operation procedure]

[Edit] → [Documentation] → [Comment] → Move the cursor to the editing position → Enter

Alternatively, → Right-double-click at the editing position.

[Setting screen]
3 - SFC PROGRAM EDITING

POINTS

• Select an SFC diagram symbol in the SFC diagram to perform SFC comment creation/correction.
  Select a ladder symbol on the Zoom side to perform device comment creation/correction.
• In this operation, a block title cannot be created/corrected.
• About block comments
  SAP3
  When performing file write (write to GX Developer format or other format file) and then PLC write, data will disappear unless a comment file is written.
  SAP2
  When performing write to other format, data will disappear unless a comment file is written.
• If you have created a block title of 25 or more characters on SAP2, performing PLC write or write to other format file will delete the 25th and latter characters.
• When the FXCPU is used
  Create a block title by displaying the block list, then executing [Edit] → [Block information]. If you write to an FXGP (DOS) format file when a step comment that consists of more than 16 characters has been created, the 17th and subsequent characters will be deleted.

(2) Performing operation on the device comment editing screen

[Operation procedure]
[Device comment] in project list → [COMMENT]
[Setting screen]

1) Device name
  Specify the device which will be commented.
  When creating an SFC comment, specify the device name as indicated below.
  • A, Q, L, QnA series
    Block title : BLm
    Step comment : BLm\Sn
    Transition comment : BLm\TRn
    m: Block number
    n: Step/transition number
  • FX series
    Block title : BL0-BL24
    Step comment : S0-S999 (device comment corresponding to state S)
3.6.2 Editing the Note for Operation Output

This section provides the operation performed to annotate an operation output ladder. For full information on notes, refer to GX Developer Operating Manual.

[Operation procedure]
[Edit] → [Documentation] → [Note] → Move the cursor to the editing position → Enter
Alternatively, → Right-double-click at the editing position.

[Setting screen]

1) Select Embedded note or Separate note.
For the ACPU, only separate note is available.
2) Note editing area
3) OK button
Determines the entered note.

POINTS
• When creating a note on the ACPU and writing it in another format, that note is not written to the GPPA.
• After editing a note, always perform a conversion operation.
The data created will not remain if you do not make conversion.
3.7 Setting the Block Information

[Setting purpose]
This operation is performed to set the block information of the corresponding block at the time of a conversion operation after creation of an SFC diagram.

[Operation procedure]
• SFC diagram creation → F4 (F4)
• [Edit] → [Block information] or Q L QnA A FX

[Setting screen]

For the ACPU

For the Q/L/QnACPU

Enter a device into each item.
Entering an unnecessary item is dispensable.
The Q/L/QnACPU can set block statements in a program.
1) Check this item to set block statements in the program.
2) A block statement can be input up to 10 lines and 64 characters in each line.
3) Check this item to write block statements together with the program.

POINT
• For the function and operation of each item, refer to the "MELSAP-II (SFC) Programming Manual" for the ACPU or to the "MELSEC-Q/L/QnA Programming Manual (SFC)" for the Q/L/QnACPU.
• The set block title stored as a device comment of device BLm.
• A block title/alias can be created and changed by entering a device name "BLm" on the device comment-editing screen. (Refer to Section 3.6.1).
• When putting a block title for each program, create comments by program. For details of the creating method, refer to the GX Developer Operating Manual.
• When using the Q/L/QnACPU and inputting a block statement, convert the SFC diagram in advance.
• When changing the PLC type of the project in which block statements are created to the PLC type not compatible with a block statement, the created block statements will be deleted.
### POINT

- **About merging block statements when reading a SFC program from a programmable controller**
  When reading the SFC program without block statements from a programmable controller, the block statements in the project will be disappeared. To prevent block statements from disappearing, select "Merge peripheral statement/note" when reading from the programmable controller. Note that block statements cannot be merged in the project using labels.

- **When writing a project to a GPPQ format file, the block statements in the project will be deleted.**

- **When Performing either of the following operations, "Use block statement" is automatically checked.**
  (1) Use block statement
  (2) Checking "Include block statement in program when written to PLC"

When the FXCPU is used

![Block information setting](image)

1) Input the block title of the ladder block or SFC block.
   You can create or change a block title as a device comment of BLm using the same operation.

2) Be sure to specify either an SFC block or a ladder block according to the contents of the program to be written.

### POINT

- **If the STL instruction exists in a ladder block, the message "Ladder block!", which indicates a conversion error, will be displayed in the block type of block list.**

- **If an incomplete ladder block is described by the STL instruction, you can modify the contents using the zoom screen, then change the block to "SFC block" in "Block Type" of the block information setting.**

- **Regarding errors that can occur during a block type change**
  In the following cases, an error is displayed, and the change process is interrupted.
  1) If SFC conversion is not possible
  2) If the initial step does not exist
  3) If a number of blocks are generated when the program in a block is SFC-converted.
3.8 Display the Block List

Show the currently edited SFC program in a list form to monitor it or to perform block-by-block editing, e.g., cut and paste. In the block list, you can perform the following.

- Block information setting/correction
- Batch copy between blocks
- Jump to SFC diagram display in the specified block
- SFC monitoring in the block list (A, Q/L/QnA only)
- (Batch) Conversion of unconverted blocks

[Operation procedure]
[View] → [Display block list]

[Block list screen]

When the ACPU is used

When the Q/L/QnACPU is used

When the FXCPU is used
1) Lists the block information in order of block number. Using the scroll bar, [Page Up] / [Page Down] or [ ] / [ ] key, you can change the displayed blocks.

2) Indicates whether the corresponding blocks have been converted or not.
   - : Already converted
   * : Not yet converted

3) Displays the block statement for the selected block.

4) Clicking the button displays the Block information setting screen for the selected block.

5) Display the block program type. (FXCPU only)
   "SFC block" or "Ladder block" is displayed.
   If a ladder circuit that contains a STL instruction cannot be changed to an SFC block, add the "!" mark so that the display is "Ladder block!".
3.9 SFC-Related Parameter Settings

Among the parameter settings made for operating the Q/L/QnACPU, this section explains the setting of parameters related to SFC programs.

3.9.1 SFC Setting in PLC Parameters

<table>
<thead>
<tr>
<th>Q</th>
<th>L</th>
<th>QnA</th>
<th>A</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>x</td>
<td>x</td>
</tr>
</tbody>
</table>

This section gives the operation performed to set the SFC-related parameters using the PLC parameters.

[Operation procedure]

[Parameter] in the project list → [PLC parameter] → <<SFC setting>> tab

[Setting screen]

1) SFC program start mode
   Set an initial start or resume start to start the SFC program.

2) Start conditions
   Set autostart block 0/do not autostart block 0 at the initial start of the SFC program.

3) Output mode when the block is stopped
   Set whether a stop is made by turning off the coil outputs which were turned on by the OUT instruction or by keeping them on (latched) when a stop request is sent to any block.

[Item explanation]

1) SFC program start mode
   - Set an initial start or resume start to start the SFC program.

2) Start conditions
   - Set autostart block 0/do not autostart block 0 at the initial start of the SFC program.

3) Output mode when the block is stopped
   - Set whether a stop is made by turning off the coil outputs which were turned on by the OUT instruction or by keeping them on (latched) when a stop request is sent to any block.
3.9.2 Setting the Block Parameters

This section provides how to set the block parameters.

[Operation procedure]
[Tools] → [Set SFC information] → [Block parameter]
[Setting screen]

[Item explanation]
1) Periodic execution block
   All blocks from the set block number onward are periodic execution blocks.
   To process all blocks every scan, leave the input area blank.
   Enter the execution interval within the range 1 to 65535 (ms) in 1ms increments.
2) Act at block multi-activated
   If a start request is made from another block while a block in the designated
   range is active, an error occurs and CPU operation stops.
   The operation mode in the event of a double start for blocks outside the
   designated range is "Wait".
   To set "Wait" for all blocks, leave the first and last input areas blank.
3) Act at step multi-activated
   If a double start occurs with respect to any step in the range for which "Waiting
   blocks" is designated, operation is suspended until the corresponding step
   becomes inactive.
   If a double start occurs with respect to any step in the range for which "Stop
   blocks" is designated, an error occurs and CPU operation stops.
   If a double start occurs with respect to a step outside the specified range, a
   forced transition is executed.
3.9.3 SFC Program Setting

Set whether the SFC program file being edited is to be a "Normal SFC Program" or a "Control SFC program".

[Operation procedure]
[Tools] → [Set SFC information] → [SFC type]

[Setting screen]

When Control SFC program is selected, an SFC program can be created for block 0 only.

Note that if a block start step ( , ) is designated in block 0, an error occurs when the program is executed and CPU operation stops.

* Basic model QCPU and Universal model QCPU are incompatible.
3.9.4 SFC Program Capacity Check

Check the capacity of the program file being edited.

[Operation procedure]
[Tools] → [Set SFC information] → [SFC program capacity check]
[Setting screen]

When the ACPU is used

Check of SFC program capacity

1) Setting parameter value of microcomputer capacity
   2.0 Kbytes

2) Created SFC program capacity
   0.7 Kbytes

3) Result of check: Check OK.

OK

When the FXCPU is used

Check of SFC program capacity

1) Program capacity set by parameters
   800 Step

2) Created SFC program capacity
   1 Step

3) Result of check: Check OK.

OK
[Item explanation]
1) Program capacity set by the parameter.
   Displays the maximum value permitted for programming.
2) Created SFC program capacity
   Displays the SFC program amount for the converted part.
3) Result of check
   If the converted SFC program is within the maximum value, [Check OK] will be displayed.
   If the maximum value is exceeded, an error message will be displayed.
3.10 Conversion Operation

The following types of conversions are available according to SFC diagram editing and operation output/transition condition editing.

<table>
<thead>
<tr>
<th>Item</th>
<th>SFC Diagram Editing</th>
<th>Operation Output/Transition Condition Editing</th>
<th>Conversion Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conversion (F4)</td>
<td>———</td>
<td>〇</td>
<td>* Only one operation output/transition condition being edited is converted.</td>
</tr>
<tr>
<td>Conversion (All programs being edited)</td>
<td>〇</td>
<td>〇</td>
<td>* All programs being edited are batch-converted.</td>
</tr>
<tr>
<td>Conversion writing during RUN (A, Q/L/QnA only)</td>
<td>———</td>
<td>〇</td>
<td>* The operation output/transition condition being edited is written during RUN.</td>
</tr>
<tr>
<td>Block conversion (F4)</td>
<td>〇</td>
<td>———</td>
<td>* Only one SFC diagram block being edited is converted.</td>
</tr>
<tr>
<td>Block conversion (F4)</td>
<td>〇</td>
<td>———</td>
<td>* All SFC diagram blocks being edited are batch-converted.</td>
</tr>
</tbody>
</table>

(1) When conversion is completed normally
The Block information setting screen (refer to Section 3.7) is displayed. When the Block information setting screen is closed, "***" on the title bar, which indicates "Not yet converted", is disappeared and conversion is completed.

(2) When an error occurs
The Convert error screen is displayed. Check errors and details. This screen can be displayed by selecting [Convert] → [Display convert error].

[Setting screen]
[Item explanation]

1) Program name
   Select a program to be displayed.

2) [Details]/[All blocks]
   Switch the screen display.

3) Jump
   The SFC diagram is displayed, which contains the error selected in the error display area.
   The cursor moves to the error step.

4) Error display area
   The following contents are displayed.

<table>
<thead>
<tr>
<th>Item</th>
<th>Display content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Convert error (All blocks)</td>
<td>Block number which contains conversion errors</td>
</tr>
<tr>
<td>Block number</td>
<td></td>
</tr>
<tr>
<td>Error items</td>
<td>Number of errors in the block</td>
</tr>
<tr>
<td>Convert error (Detail)</td>
<td>Error step</td>
</tr>
<tr>
<td>Error step</td>
<td>Step number of the conversion error</td>
</tr>
<tr>
<td>Error detail</td>
<td>Explanation of the error</td>
</tr>
</tbody>
</table>

POINT

• When an error related to a branch or transition is detected, it may be located in the SFC program following the error step. Display the SFC diagram using Jump button, check the program around the cursor, and correct the program.

• For the ACPU, make an "SFC program capacity check" after conversion operation to make sure that the existing SFC program is within the microcomputer capacity. For full information, refer to Section 2.1.

3.11 Instructions for Online SFC Program Writing

This section provides instructions for writing the operation outputs/transition conditions of an SFC program to the CPU during RUN.

(1) Two or more operation outputs/transition conditions cannot be written during RUN at the same time.
   Perform an online writing operation every time a correction has been made.

(2) An SFC diagram cannot be written during RUN.
   After creating or modifying an SFC diagram, STOP the CPU and write the diagram using "Write" in the online menu.
**POINT**

(1) The method of writing the operation output and transition condition during RUN is the same as the "write during RUN" operation for the circuit. For details of the operation method, refer to the GX Developer Operating Manual.

(2) For other precautions concerning online change, refer to GX Developer Operating Manual.

3.12 Making Searches/Replacements

<table>
<thead>
<tr>
<th>Q</th>
<th>L</th>
<th>QnA</th>
<th>A</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
</tr>
</tbody>
</table>

**POINT**

For a search/replacement made in an SFC program, the object area changes with the "searching direction" specified.

<table>
<thead>
<tr>
<th>Block 0</th>
<th>Block 1</th>
<th>Block 2</th>
<th>Block n</th>
</tr>
</thead>
<tbody>
<tr>
<td>a) Downward from top</td>
<td>b) Downward from cursor position</td>
<td>c) Upward from cursor position</td>
<td></td>
</tr>
<tr>
<td>1)</td>
<td>2)</td>
<td>1)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>1)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>2)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>2)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>n)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>n)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>n)</td>
</tr>
</tbody>
</table>

* When a search/replacement is to be performed in an SFC program after a search has been made in another program, all blocks will be searched. When making searches/replacements in an SFC program within the "specified range (step range)"*, specify the step numbers (e.g. [ ] ) of the SFC diagram.
3.12.1 Searching for a Device/Instructions

This operation searches for the specified device or instruction to find the operation output/transition condition of the corresponding block it is used. The cursor moves to the step or transition in the SFC diagram being used, and at the same time, the operation output/transition condition sequence program appears. The operation method is the same as in the ladder mode. For details of the operation method, refer to the GX Developer Operating Manual.
3.12.2 (1) Searching for the Step No./Block No. (SFC Diagram)

[Setting purpose]
This operation is performed to show the specified block on the screen by specifying the block No. and step No./transition No. when the cursor is in the SFC diagram.

[Operation procedure]
[Find/Replace] → [Find step no./block no.]

[Setting screen]

1) Block number
Enter the block No. to be searched for.

2) Step/Transition
Specify the cursor position after a search is over.

3) Find button
Click this button to show the SFC diagram in the specified block.

POINTS
- This operation is valid only when the cursor is on the SFC diagram side.
- When the cursor is in the SFC diagram, pressing any "number" key shows the following window.

Clicking the OK button or pressing the Enter key allows the cursor to move to the specified step in the SFC diagram currently displayed.
Also, turning on the block no. radio button enables a block search.
3.12.2 (2) Searching for the Step No./Block No. (Zoom)

[Setting purpose]
This operation is performed to search for the step No. in the operation output/transition condition sequence program being displayed when the cursor is on the Zoom side.
Alternatively, the specified block

[Operation procedure]
[Find/Replace] → [Find step no./block no.]

[Setting screen]

![Find step no. / block no.]

1) Step No./block No. input box
Enter the step No. or block No. to be searched for.
2) Search destination
Select the displayed operation output/transition condition or block as a search destination.
3) [OK] button
Click this button to show the ladder of the specified sequence program step No. when the step No. is specified.
When the block is specified, the SFC diagram in the specified block appears.

3.12.3 Searching for a Character String

This operation searches for the specified character string to find it is used as an SFC comment or an operation output note. (A device comment will not be searched for.)
The cursor moves to the step or transition in the SFC diagram being used, and at the same time, the operation output/transition condition sequence program appears.
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the GX Developer Operating Manual.
### 3.12.4 Searching for a Device Comment

<table>
<thead>
<tr>
<th>Q</th>
<th>L</th>
<th>QnA</th>
<th>A</th>
<th>FX</th>
</tr>
</thead>
</table>

This operation searches for a device comment or label comment of the device being used in the program.

The operation method is the same as in the ladder mode.

For details of the operation method, refer to the GX Developer Operating Manual.

### 3.12.5 Searching for a Jump by Step No.

[Setting purpose]

This operation is performed to search for a jump by specifying the jump destination step number.

![Diagram of SFC program with jumps and step numbers]

[Operation procedure]

1) Jump destination step number input box
   - Enter the jump destination step number of the jump to be searched for.

2) **Find** button
   - Click this button to show the jump which specifies the jump destination step number specified in the jump destination step number input box.

**POINT**

When the cursor is on a step, selecting [Find jump step] from the menu searches for a jump which specifies the step number on the cursor.

(When the cursor is not on a step, selecting [Find jump step] from the menu shows the Find jump step screen.)
3.12.6 Replacing the Devices

This operation replaces the devices and character string constants used in the operation outputs/transition conditions.
Note that if you specify "Include SFC block information find targets" for the A or Q/L/QnA series, the devices used in the block information of the corresponding blocks will also be replaced.
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the GX Developer Operating Manual.

3.12.7 Replacing the Instructions

This operation replaces the instructions used in the operation outputs/transition conditions of the corresponding block.
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the GX Developer Operating Manual.

3.12.8 Changing the Open/Close Contacts

This operation replaces the open contacts of the devices used in the operation outputs/transition conditions of the corresponding block with close contacts and the close contacts with open contacts.
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the GX Developer Operating Manual.

3.12.9 Replacing the Character String

This operation replaces the character string of an SFC comment or a note created for operation output.
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the GX Developer Operating Manual.
3.12.10 Replacing the Step No.

[Setting purpose]
This operation is performed to replace the jump designation step number in the corresponding block or the reset destination step number.

[Operation procedure]
[Find/Replace] → [Replace step no.]

[Setting screen]

1) Block no.
   Enter the first block No. to be replaced.

2) JUMP number
   Specify this to replace the jump destination step number at the jump transition. To replace it, enter the old and new step numbers.

3) Reset number (Only for Q/L/QnACPU)
   Specify this to replace the reset destination step number at the reset step. To replace it, enter the old and new step numbers.

4) Next button
   Searches for the next target instruction without replacing the step on the cursor.

5) Replace button
   Replaces the step on the cursor and searches for the next target instruction.

6) Replace all button
   Replaces all target steps in the search range.

POINT
After replacement, always perform a conversion operation because the step number is in an unconverted status. An error check is also made at the time of conversion.
3.12.11 Changing the Note Type

This operation replaces the type of the note created for the operation output with "Embedded" or "Separate".
For the ACPU, you cannot change the note type since it is fixed to "Peripheral".
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the GX Developer Operating Manual.

3.12.12 Searching for Contacts/Coils

This operation lists where the specified devices are used in the operation outputs/transition conditions and block information.
The symbols displayed represent the following.

© Step field
• S : Step
• TR : Transition
© Sequence step field
• a : Block Active bit (for ACPU)
  Block START/END bit (for QnACPU)
• t : Step transition bit (for A, Q/L/QnA)
• c : Block clear bit (for ACPU)
  Continues transition bit (for QnACPU)
• s : Block stop bit (for ACPU)
  Block PAUSE/RSTARA bit (for QnACPU)
• m : PAUSE mode bit (for QnACPU)
• r : Active step number register (for ACPU)
  Number of active steps register (for QnACPU)

The operation method is the same as in the ladder mode.
For details of the operation method, refer to the GX Developer Operating Manual.
3.12.13 Searching for the Device Use Status

This operation lists how the devices are used device-by-device (e.g. X, Y, M, D). A device search also covers devices used in the block information, and if they are used in the block information alone, they are shown as being used as contacts. The operation method is the same as in the ladder mode. For details of the operation method, refer to the GX Developer Operating Manual.

3.12.14 Changing the T/C Set Values

This operation changes the set values of the timers/counters used in the operation outputs inside the block being displayed. (The T/C set values in different blocks cannot be changed at the same time.) The operation method is the same as in the ladder mode. For details of the operation method, refer to the GX Developer Operating Manual.
3.13 Providing Displays

3.13.1 Displaying the Step/Transition Comments

<table>
<thead>
<tr>
<th>Q</th>
<th>L</th>
<th>QnA</th>
<th>A</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**[Setting purpose]**
This operation is performed to show the created SFC diagram with SFC comments.

**[Operation procedure]**
1. Choose [View] → [Display comment of step and TR] (Ctrl + F5).

2. The SFC comments appear on the screen.

![SFC Diagram](image)

3. Choose [View] → [Display comment of step and TR] (Ctrl + F5) again to remove the comments.

![SFC Diagram with Comments](image)
3. When the SFC comments are being shown, choosing [View] → [Display comment of step and TR] (Ctrl + F5) hides the SFC comments.

**POINT**

- This operation is valid only when the cursor is on the SFC diagram side.
- When the FXCPU is used, only the step comment is valid.
3.13.2 Displaying the Alias in the SFC Diagram

**[Setting purpose]**
This operation is performed to show the created alias on the SFC diagram creation screen.

**[Operation procedure]**
1. Choose [View] → [Display alias of step and TR] (Alt + Ctrl + F6).

![Diagram 1]

2. The Alias in the SFC diagram appears on the screen.

![Diagram 2]

3. When the alias are being shown, choosing [View] → [Display alias of step and TR] (Alt + Ctrl + F6) hides the alias.

**POINT**
- The Alias cannot be used for the project in which "Use label" is selected.
- Create alias on the device comment-editing screen. Aliases are not written if they are created on the ACPU and written to a GPPA format file.
- This operation is valid only when the cursor is on the SFC diagram side.
- When the FXCPU is used, transition comments are not supported.
3.13.3 Displaying the Device Comments

This operation shows the operation output/transition condition sequence program with device comments.
This operation is valid only when the cursor is on the Zoom side (operation output/transition condition side).
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the GX Developer Operating Manual.

3.13.4 Displaying Notes

This operation shows the operation output/transition condition sequence program with notes.
The operation method is the same as in the ladder mode.
This operation is valid only when the cursor is on the Zoom side (operation output/transition condition side).
For details of the operation method, refer to the GX Developer Operating Manual.

3.13.5 Displaying the Alias for Devices

This operation changes the devices in the operation output/transition condition sequence program to aliases.
This operation is valid only when the cursor is on the Zoom side (operation output/transition condition side).
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the GX Developer Operating Manual.
3.13.6 Changing the Operation Outputs/Transition Conditions to the Ladder Mode/List Mode

This operation changes the edit mode of the operation output/transition condition sequence program.
This operation is valid only when the cursor is on the Zoom side (operation output/transition condition side).
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the GX Developer Operating Manual.
3.13.7 Displaying in MELSAP-L Format

SFC programs created in MELSAP3 format can be displayed in MELSAP-L format by selecting [View] → [MELSAP-L format].
For the operation of programs in MELSAP-L format, see the GX Developer Operating Manual (MELSAP-L).

The following restrictions apply when SFC programs created or modified in MELSAP3 format are displayed in MELSAP-L format.
If the operating output included notes, contacts and/or comparison operation instructions, the corresponding portions are displayed in "???." in MELSAP-L format.
The portions of operating output displayed in "???." cannot be modified. For details, refer to section 2.4 of the GX Developer Operating Manual (MELSAP-L).

3.13.8 Displaying the Reference Window

This setting is used when you wish to open the Zoom panel (ladder program) of other transition condition/operating output without closing the Zoom panel of the currently displayed transition condition/operating output.

[Operation Procedure]
Move the cursor to the transition condition/operating output you wish to see, and then select [View] → [Display the reference window].

[Example of Screen]
The screen below shows the split display obtained when [Window] → [Tile horizontally] is selected after setting the step 1 transition condition in the reference window.
3.13.9 Opening multiple Windows

[Setting purpose]
This operation is performed to tile two or more different operation outputs/transition conditions to check or monitor the program.

[Operation procedure]
Hold down [Ctrl] and double-click the step or transition of the SFC diagram whose window will be opened.

[Screen]
(When making a new window)
A new window appears every time operation is performed.

(When not making a new window)
The display is changed within a single window.

**POINT**
Set whether a new window is made or not in the "Reference window" of [Tools] → [Set SFC information] → [Option].
3.14 Setting the SFC Diagram Display

3.14.1 Setting the SFC Diagram Display

<table>
<thead>
<tr>
<th>Q</th>
<th>L</th>
<th>QnA</th>
<th>A</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>○</td>
<td>○</td>
<td>○</td>
<td>○</td>
<td>○</td>
</tr>
</tbody>
</table>

[Setting purpose]
This operation is performed to set the number of branches that can be edited/displayed when the SFC diagram is edited/read.

[Operation procedure]
[View] → [Raw of SFC]

[Setting screen]

<table>
<thead>
<tr>
<th>SFC Display column number</th>
<th>OK</th>
<th>Cancel</th>
</tr>
</thead>
<tbody>
<tr>
<td>Col number</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td>Line number</td>
<td>30K</td>
<td></td>
</tr>
</tbody>
</table>

[Item explanation]
1) Col number
Enter the number of columns (number of branches).
The number that may be input is any of 1 to 32 for the ACPU, any of 1 to 32 for the Q/L/QnACPU, or 1 to 16 for the FXCPU.
Entering the number of columns automatically shows the number of rows that may be entered.

2) [OK] button
Click this button when the setting is complete.

POINT
This operation is valid only when the cursor is in the SFC diagram.
### 3.14.2 Setting the Zoom Partition

**[Setting purpose]**
This operation is performed to set how to split the operation output/transition condition ladder displayed.

**[Operation procedure]**
[View] → [Zoom setting]

**[Setting screen]**

Choosing vertical partition or horizontal partition provides the corresponding one of the following displays. Note that when operation outputs/transition conditions are being displayed, clicking the partition display shows only the SFC diagram.

- **Horizontal partition (ladder)**
- **Horizontal partition (list)**
- **Vertical partition (ladder)**
- **Vertical partition (list)**
3.14.3 Setting the Contacts

[Setting purpose]
This operation is performed to set the number of contacts displayed in the operation output/transition condition ladder which has appeared on the right of the SFC diagram.
You can set "9 contacts" or "11 contacts" when "Below" is specified for Zoom partition.
You can set "5 contacts" or "11 contacts" when "Right" is specified for Zoom partition.

[Operation procedure]
[View] → [Set the contact at right]

[Setting screen]
The following screen is displayed when "Right" is specified for Zoom partition.
3.14.4 Setting the SFC Setting Options

[Setting purpose]
This operation is performed to set how to open windows during SFC program editing or for monitoring.

[Operation procedure]
[Tools] → [Set SFC information] → [Option]

[Setting screen]

1) Reference window
Set whether or not the operation output/transition condition sequence program windows will be tiled.

2) Zoom mode at block START step (A, Q/L/QnA only)
Set whether or not a jump will be made to the start destination block when the cursor moves to the block start step.

3) Auto scroll monitor setting (A, Q/L/QnA only)
Set whether or not the window of the start destination block will be opened for monitoring when the active step transits to the block start step during SFC diagram monitoring.
If GX Developer is minimized, you cannot open the start destination block window.
If the block started while GX Developer was minimized, the block that was monitored prior to minimization will be monitored after minimization is canceled.

4) Step transition watchdog monitor setting
Sets whether or not steps that do not move within the specified monitoring period will be monitored.
To execute transition monitoring, set the name of the program to be monitored, specify the block, and set the monitoring period.
If you set "Stop watchdog monitoring at detection", transition monitoring will stop when a non-transition step is detected.
3.15 Changing between SFC and Ladder Programs

[Setting purpose]
This operation is used when an SFC program is to be changed to a ladder program, or when an existing ladder program is to be changed into an SFC program.

[Operation procedure]
[Project] → [Edit Data] → [Change program type]

[Setting screen]

1) 2)

[Item explanation]
1) Ladder
Changes the currently displayed SFC program into a ladder program. You can edit the changed program as a ladder program.

2) SFC
Changes the currently displayed ladder program into an SFC program. You can edit the changed program as an SFC program.

3) [OK] button
Click this button at the end of setting work.

POINT
For precautions concerning changeover, refer to section 2.5 "Precautions for Use of the FXCPU".
4. MONITORING

4.1 SFC Diagram Monitor

This operation is used to monitor the operation and control status of the programmable controller CPU with SFC diagrams and to conduct test operations.

[Operation procedure]
- When monitoring
  [Online] → [Monitor] → [Monitor mode] or ![F3](
- When stopping monitoring
  [Online] → [Monitor] → [Stop monitor] or ![Alt]+![F3](
- When resuming monitoring
  [Online] → [Monitor] → [Start monitor] or ![F3](

[Screen]

1) During SFC diagram monitoring, steps are shown as follows.
   - (blue) : Active step
   - (yellow) : Step specified as a hold step and being in a hold status
     (For the Q/L/QnACPU only. Shown as an inactive step for the ACPU.)
   - : Inactive step

2) Shown on the Zoom side is the operation output/transition condition ladder of the step or transition at the cursor position on the SFC diagram side.
3) When there is a block start step, the monitor destination block can be changed by moving the cursor to the block start step and pressing the space key. To monitor a block which has no block start step, show the block list and double-click the monitor destination block No. field. Alternatively, type the monitor destination block No., show the "Find step no. / block no." window, and make a block search.

<table>
<thead>
<tr>
<th>POINTS</th>
</tr>
</thead>
</table>
| • Automatic scroll monitoring  
  When the active step has gone off the screen, redisplay it on the screen by automatic scrolling.  
  To perform automatic scrolling, click \( \text{Auto scroll monitor} \) or choose [Online] \( \rightarrow \) [Monitor] \( \rightarrow \) [Auto scroll monitor].  
  • Automatic scroll monitoring of multiple steps active in series due to operation hold steps, for example, shows the active step closest to the initial step.  
  • When using the auto scroll monitor, you can use the SFC option setting "Auto scroll monitor setting" to automatically display the start destination block. If GX Developer is minimized, the start destination block window will not open.  
  If the block started while GX Developer was minimized, the block that was monitored prior to minimization will be monitored after minimization is canceled. (Refer to section 3.14.4.)  
  • During monitoring, you cannot edit SFC diagrams.  
  • During editing, you cannot monitor SFC diagrams.  
  • If you open the write or monitoring write screen during automatic scrolling, automatic scroll monitoring stops. When you resume monitoring, automatic scroll monitoring also resumes. |


4.2 Transition Watchdog Monitor

The following is an explanation of the transition watchdog monitor function that monitors steps from which the program does not proceed to the next step after the lapse of the specified period.

[Operation procedure]
[Tools] → [Set SFC information] → [Option] → Step transition watchdog monitor setting → Execute monitoring (refer to sub-section 4.1).

[Screen]

- When the step transition watchdog monitor is set, and the system detects a step from which a transition does not occur despite the lapse of the specified period, the above dialog box appears.
- However, the display on the above dialog box is sometimes delayed beyond the specified period depending upon the capacity of the SFC program and the environment under which the computer operates.
- When you click [Jump], the step concerned in the SFC diagram appears.
- For details of the step transition watchdog monitor setting operation, refer to section 3.14.4.
- If you check "Stop watchdog monitoring at detection" when setting the step transition watchdog monitor, the monitor will stop each time a non-transition step is detected, however normal monitoring will continue.
4.3 Transition Condition and Operation Output Ladder Monitor

This operation is used to monitor a ladder for the step or transition condition at the cursor position in an SFC diagram.

[Screen]

1) Ladder monitor
During monitoring, ON/OFF of a contact or coil or the present value of a device is shown and it changes with the programmable controller operating status.

The ON and OFF states of a ladder are as shown below.

```
OFF: [ ] [ ] [ ] [ ]
ON: [ ] [ ] [ ] [ ]

*: Only the contact-equivalent compare instructions and coil-equivalent SET, RST, PLS, PLF, SFT, SFTP, MC, FF, DELTA and DELTAP are supported. (FF, DELTA and DELTAP are the instructions of the Q/L/QnA series.)
```

Note that the display is held at a stop of monitoring and is updated on resumption of monitoring.

2) Present value
The present value of a word device appears.

The present value can be changed between decimal and hexadecimal.

This change can be made by performing [Online] → [Monitor] → [Change current value monitor] operation.

If a double word monitored is 10 or more characters, it is shown in a smaller character size.

The present value can be displayed as a double word or real number according to the data type used in the instruction.
3) Device test

- Holding down \texttt{Shift} and double clicking (\texttt{Enter}) a contact on the ladder monitor screen forces ON/OFF to change to the opposite status.
- Holding down \texttt{Shift} and double-clicking (\texttt{Enter}) a word device being monitored shows the following Present value change dialog box.

\begin{center}
\textbf{Present value change}
\end{center}

After entering a new value, click the \texttt{Set} button.

- The present value of the double word instruction (e.g. DMOV, DFRO) is displayed as a double word.
- Confirm the value of a double word by device batch monitor or device registration monitor.
- When the cursor is on the Zoom side, right-clicking the mouse shows the device test or device registration monitor menu.
- Perform a test or registration monitor operation for the device which is not on the window being displayed.

\begin{center}
\textbf{Device test}
\end{center}
4.4 All Block Batch Monitor and Active Step Monitor

This operation is used to monitor the active/inactive states of all blocks in a list form and to monitor the step active/inactive states of the specified block from the block list in a list form.

[Operation procedure]
[Online] → [Monitor] → [All block batch monitor]

[Screen]

* indication: The corresponding block is active.
— indication: The corresponding block is inactive.

To monitor the specified block for step active/inactive states, click the field of the block to be monitored, and click the [Active step monitor] button.

* indication: The corresponding step is active.
— indication: The corresponding step is inactive.
After resetting the programmable controller CPU, if you carry out monitoring without having put the system in a RUN condition even once, the monitoring result will be blank.

If you stop the programmable controller CPU and perform monitoring, the status at the time the system was stopped will be displayed as the result of monitoring.

### 4.5 Block List Monitor

This operation is used to show and monitor a block list.

**[Operation procedure]**

[View] → [Display block list] → ![F3]

**[Screen]**

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Start of blocks 1, 2</td>
<td>M100</td>
<td>M101</td>
<td>M102</td>
<td>M103</td>
<td>0400</td>
</tr>
<tr>
<td>2</td>
<td>Machining process handling block</td>
<td>M110</td>
<td>M111</td>
<td>M112</td>
<td>M113</td>
<td>0410</td>
</tr>
<tr>
<td>3</td>
<td>Finishing start block</td>
<td>M120</td>
<td>M121</td>
<td>M122</td>
<td>M123</td>
<td>0420</td>
</tr>
</tbody>
</table>

- The block No. fields of active blocks are highlighted.
- When block information has been set, the status of the corresponding block can be confirmed in the block information.
- To switch the specified block to SFC diagram monitor during monitoring, double-clicking in the field of the corresponding block switches to the SFC diagram display of the specified block.

**POINT**

Active registers cannot be monitored.
This chapter explains debugging to step-run an SFC program. If you select the FX series, debugging is effective only when a ladder logic test tool (LLT) of GX Simulator (SW2D5C-LLT-E or later) or later versions is connected.

**[Operation procedure]**

[Online] → [Debug] → [Debug] → Change CPU to "STEP-RUN" → [Each item operation]

Choosing debug shows the following window.

Choosing [Yes] places the CPU in the "STEP-RUN" status and you can start any item operation of debugging. To cancel debugging and return to "RUN", click [Debug] during debugging.

**[Screen]**
[Item explanation]

- Block break (A, QnA only)
  This operation forces an active block into a break.

- All block cancel
  The specified break points registered to the CPU are canceled.

- All block register (QnACPU only)
  When all blocks have been specified to be registered, all active blocks are
  batch-placed into a break.

- Specify block
  When blocks are specified, the specified blocks are forced into a break.
  You can specify up to 16 blocks for the ACPU or up to 64 blocks for the
  QnACPU.
  Click "■" in the select field to change it to "○", and enter the block number.
  If you change "■" to "○" after block number entry, that block will not be the
  object of break.

POINTS

- When a break is established for the specified block, the following window
  appears.

- When break points have been set for the QnACPU, executing the end step
  automatically places the blocks into a break.
  Note that no message is given to indicate that a break is established.
- If you are using the FXCPU, you can perform the same operation as that of a
  block break by operating the initial state with the step break.
● Step break

This operation specifies the block number and step number to end a single step run for test (step) operation.

If you are using the FXCPU, block number is not specified.

• All step cancel

The specified break points registered to the CPU are canceled.

• Specify step

Enter the block number and step number to be set as a break point and the number of cycles (times).

Set the number of cycles in the range 1 to 255.

When the preset step of the block is activated the number of times specified as the number of cycles during step run, a single step run ends and the step is put into a break.

POINT

When a break is established for the specified block, the following window appears.

If you are using a QnACPU and a break point is set, a break will automatically occur when you execute an end step. Note that in this case no display appears to indicate the occurrence of the break.

If you are using the FXCPU, you can perform the same operation as that of a block break by operating the initial state with the step break.
Block run
- The block currently being displayed is forced to be active.
- When the corresponding block is in a break status, the run resumes from the step in a break status.
- When the corresponding block is inactive, the block is forced to start and the run starts from the initial step.

Step run
- Moving the cursor to the step to be started and choosing "step run" forces steps from the specified step on to be active.
- Independently of whether the corresponding block is active or inactive, a forced run starts from the specified step.
- When the specified step is in a break, the break is canceled and the forced run starts.

1 step run
- Moving the cursor to the step to be run and choosing "1 step run" tests only the specified step.
- A single cycle ends when the specified step is run, the transition condition holds, and a transition occurs to the next step.

POINTS
- For the QnACPU, any step can be run independently of whether the corresponding block is active or inactive.
- For the ACPU, only the step which was placed in a break status by a step break operation may be run.

Block forced stopping (QnACPU only)
- This operation forces the currently displayed block to be inactive.

Step forced stopping (QnACPU only)
- Moving the cursor to the step to be forced to an end and choosing "Step forced stopping" forces the specified step to end (be inactive).
- If there is no active step in the corresponding block at the forced end of the specified step, that block is ended.

Reset stored step (QnACPU only)
- In this operation, the step within the currently displayed block which has been set to coil hold, operation hold (without transition check) or operation hold (with transition check) and is in a hold status is forced to be reset and inactive.
- When the specified step is not in a hold status or is not a hold step, the operation is ignored and a forced reset is not executed.

Run all block (ACPU only)
- All blocks put in a break by a block break are activated and steps from the one in a break are forced to run.
6. PRINTING THE SFC DIAGRAMS

6.1 SFC Diagram Print Setting

[Operation procedure]
[Project] → [Print] → Choose "SFC"

[Setting screen]

1) SFC diagram print item
   The items checked in the corresponding check boxes is printed.

2) Option
   The items checked in the corresponding check boxes is added.
   Some additional information items cannot be selected according to the print items.

3) Setting
   Set the number of print columns on a single page.
   The diagram is printed with automatic magnification/reduction specified according to the set number of columns.

   Action/Transition contacts
   Choose "Indication the same", "5 contacts", "9 contacts" or "11 contacts".

   Specify the number of lines of the device comment
   When "Device comments" in "Option" is checked, the number of device comment lines to be printed can be specified in the combo box.

4) Program selection
   Choose the program name to be printed.

5) Print range
   Set all area (all blocks) or the specified blocks.

---

Q L QnA A FX
○ ○ ○ ○ ○ ○
6.2 SFC Diagram Printing Examples

6.2.1 SFC Diagram Printing Examples (when A or Q/L/QnACPU is used)

This section shows examples of SFC diagrams printed.
Note that according to the number of branches/couplings and the number of steps, an SFC diagram is printed on two or more pages with a position indicating numeral printed at top right of each page.

(1) SFC diagram printing examples
• Additional information (not selected)
• Additional information (only device comment selected)

<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Machining operation output block</th>
<th>Normal SFC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start</td>
<td>M110</td>
<td>Trans M11</td>
<td>Pause M13</td>
</tr>
<tr>
<td>Pause md</td>
<td>M114</td>
<td>Active D110</td>
<td>Continue M115</td>
</tr>
</tbody>
</table>

0 Machining preparation

0 Standard goods roughing start

1 Left side drilling

1 Left side drilling completion

2 Part surface roughing

3 Standard goods finishing start

4 Part surface finishing

5 Start PB ON standby

6 Dummy step

7 Special goods A machining start

7 Special goods A pre-machining

8 Pre-machining completion

9 ID machining completion

10 83 Painting process block start

12 Special goods B machining start

11 Special goods B pre-machining

13 Pre-machining completion

14 Painting completion

15 Correcting No. 1 process work

16 Correcting inspec tion process

17 Part defective detection

18 Correcting completion

19 Correcting result OK

22 Correcting result NG
• Additional information (all selected)

<table>
<thead>
<tr>
<th>Block No.</th>
<th>1</th>
<th>Title</th>
<th>Machining operation output block</th>
<th>Normal SFC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Act/stop</td>
<td>M110</td>
<td>Trans</td>
<td>M111</td>
<td>Stop</td>
</tr>
<tr>
<td>Stop md</td>
<td>M114</td>
<td>Act reg</td>
<td>D110</td>
<td>Continue M115</td>
</tr>
</tbody>
</table>

(1, 1)
(2) Block list printing example

When the ACPU or FXCPU is used

<table>
<thead>
<tr>
<th>No.</th>
<th>Title/Information register</th>
<th>Block activation</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Start of blocks 1, 2</td>
<td>BL1  BL2</td>
</tr>
<tr>
<td></td>
<td>Act : M100</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Clear : M103</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Reg : D100</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Trans : M101</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Stop : M102</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Machining process handling block</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Act : M110</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Clear : M113</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Reg : D110</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Trans : M111</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Finishing start block</td>
<td>BL1</td>
</tr>
<tr>
<td></td>
<td>Act : M120</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Clear : M123</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Reg : D120</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Trans : M122</td>
<td></td>
</tr>
</tbody>
</table>

When the Q/L/QnACPU is used

<table>
<thead>
<tr>
<th>No.</th>
<th>Title/Statement/Information register</th>
<th>Block activation</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Start of blocks 1, 2</td>
<td>BL1  BL2</td>
</tr>
<tr>
<td></td>
<td>Function</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Initialize each data</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Parameter</td>
<td></td>
</tr>
<tr>
<td></td>
<td>X100, X101, M100</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Return Value</td>
<td></td>
</tr>
<tr>
<td></td>
<td>D1000</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Start : M0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Pause : M2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Active : D0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Transition : M1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Pause Mode : M3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Continuous : M4</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Machining process handling block</td>
<td>BL3  BL4</td>
</tr>
<tr>
<td></td>
<td>Start : M10</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Pause : M12</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Active : D10</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Transition : M11</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Pause Mode : M13</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Continuous : M14</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Finishing start block</td>
<td>BL5  BL6</td>
</tr>
<tr>
<td></td>
<td>Start : M20</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Pause : M22</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Active : D20</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Transition : M21</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Pause Mode : M23</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Continuous : M24</td>
<td></td>
</tr>
</tbody>
</table>
(3) Comment list printing example

<table>
<thead>
<tr>
<th>Block No.</th>
<th>0</th>
<th>Title</th>
<th>Start of blocks 1, 2</th>
<th>Clear</th>
<th>M103</th>
</tr>
</thead>
<tbody>
<tr>
<td>Act</td>
<td>M100</td>
<td>Trans</td>
<td>M101</td>
<td>Clear</td>
<td>M103</td>
</tr>
<tr>
<td>Stop</td>
<td>M102</td>
<td>Register</td>
<td>D100</td>
<td>Clear</td>
<td>M103</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>s0</td>
<td>Machined part insertion pusher</td>
</tr>
<tr>
<td>s1</td>
<td>machined part chucking</td>
</tr>
<tr>
<td>s2</td>
<td>Unloading carrier movement</td>
</tr>
<tr>
<td>s3</td>
<td>Finished part unloading</td>
</tr>
<tr>
<td>s4</td>
<td></td>
</tr>
<tr>
<td>s5</td>
<td>Finishing part picking</td>
</tr>
<tr>
<td>s6</td>
<td></td>
</tr>
<tr>
<td>s7</td>
<td></td>
</tr>
<tr>
<td>s8</td>
<td></td>
</tr>
</tbody>
</table>
(4) Operation output/transition condition (ladder) printing example

<table>
<thead>
<tr>
<th>Block No.</th>
<th>0</th>
<th>Title</th>
<th>Start of blocks 1, 2</th>
<th>Normal SFC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Act/stop</td>
<td>M100</td>
<td>Trans</td>
<td>M101</td>
<td>Stop</td>
</tr>
<tr>
<td>Stop md</td>
<td></td>
<td>Act reg</td>
<td>D100</td>
<td>Continue</td>
</tr>
</tbody>
</table>

s0  Machined part insertion pusher

s1  machined part chucking

s2  Unloading carrier movement
s4  Finished part unloading

s5  Finishing part picking

6 - 8  PRINTING THE SFC DIAGRAMS
(5) Operation output/transition condition (list) printing example

<table>
<thead>
<tr>
<th>Block No.</th>
<th>0</th>
<th>Title</th>
<th>Start of blocks 1, 2</th>
<th>Normal SFC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Act/stop</td>
<td>M100</td>
<td>Trans</td>
<td>M101</td>
<td>Stop</td>
</tr>
<tr>
<td>Stop md</td>
<td>Act reg</td>
<td>D100</td>
<td>Continue</td>
<td></td>
</tr>
</tbody>
</table>

s0 Machined part insertion pusher

<table>
<thead>
<tr>
<th>Step</th>
<th>Instruction</th>
<th>Device</th>
<th>Device comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>SM1036</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>OUT</td>
<td>Y70</td>
<td>Pusher advance output</td>
</tr>
</tbody>
</table>

s1 machined part chucking

<table>
<thead>
<tr>
<th>Step</th>
<th>Instruction</th>
<th>Device</th>
<th>Device comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>SM1036</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>OUT</td>
<td>Y71</td>
<td>Pusher return output</td>
</tr>
<tr>
<td>2</td>
<td>OUT</td>
<td>Y72</td>
<td>Chuck advance output</td>
</tr>
</tbody>
</table>

s2 Unloading carrier movement

<table>
<thead>
<tr>
<th>Step</th>
<th>Instruction</th>
<th>Device</th>
<th>Device comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>SM1036</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>OUT</td>
<td>Y78</td>
<td>Unloading carrier advance output</td>
</tr>
</tbody>
</table>

s4 Finished part unloading

<table>
<thead>
<tr>
<th>Step</th>
<th>Instruction</th>
<th>Device</th>
<th>Device comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>SM1036</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>OUT</td>
<td>Y7B</td>
<td>Unloading carrier return output</td>
</tr>
</tbody>
</table>

s5 Finishing part picking

<table>
<thead>
<tr>
<th>Step</th>
<th>Instruction</th>
<th>Device</th>
<th>Device comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>SM1036</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>OUT</td>
<td>Y79</td>
<td>Unchucking</td>
</tr>
<tr>
<td>2</td>
<td>OUT</td>
<td>Y7A</td>
<td>Finishing part picking</td>
</tr>
<tr>
<td>3</td>
<td>OUT</td>
<td>T0</td>
<td>Picking processing time</td>
</tr>
<tr>
<td></td>
<td></td>
<td>K20</td>
<td></td>
</tr>
</tbody>
</table>
(6) Block parameter printing example

<table>
<thead>
<tr>
<th>Block parameter</th>
<th>[MAIN-SFC]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Periodic exec Blk</td>
<td>After[ ]</td>
</tr>
<tr>
<td>Execution interval</td>
<td>[ ]ms</td>
</tr>
<tr>
<td>Action at BL multi-act</td>
<td>Stop [ ]-[ ]</td>
</tr>
<tr>
<td>Action at step Multi-activated</td>
<td>Waiting [ ]-[ ]</td>
</tr>
<tr>
<td></td>
<td>Stop [ ]-[ ]</td>
</tr>
</tbody>
</table>
This section shows examples of SFC diagrams printed. Note that according to the number of branches/couplings and the number of steps, an SFC diagram is printed on two or more pages with a position indicating numeral printed at top right of each page.

(1) SFC diagram printing examples
- Additional information (not selected)
**Additional information (Only device comment selected)**

<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Auto operation start step</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Initial setup

- 0
- 5
- 7
- 12
- 17

- 10
- 15
- 16
- 20
- 24

- 11
- 14
- 17
- 21
- 25

- 12
- 18
- 22
- 26
- 29
MELSOFT

PRINTING THE SFC DIAGRAMS

- Additional information (all selected)

<table>
<thead>
<tr>
<th>Block No.</th>
<th>1</th>
<th>Title</th>
<th>Auto operation start step</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Initial setup</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>SET Y200 Auto operation i n progress</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>TJ10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>MJ1 Condition n 0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>Standard assy/ma chining</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>MJ2 Condition n 1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>Standard assy/ma chining</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>X011 Output L</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>X110 Output K</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>X111 Output L</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>X114 Output O</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### (2) Block list printing example

<table>
<thead>
<tr>
<th>NO.</th>
<th>Title</th>
<th>Block type</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Initial drive circuit</td>
<td>Ladder block</td>
</tr>
<tr>
<td>1</td>
<td>machining operation output block</td>
<td>SFC block</td>
</tr>
<tr>
<td>2</td>
<td>inspection process</td>
<td>SFC block</td>
</tr>
<tr>
<td>3</td>
<td>Material supply</td>
<td>SFC block</td>
</tr>
<tr>
<td>4</td>
<td>Conveying control</td>
<td>SFC block</td>
</tr>
</tbody>
</table>
### (3) Comment list printing example

<table>
<thead>
<tr>
<th>Block No.</th>
<th>1</th>
<th>Title</th>
<th>Auto operation start step</th>
</tr>
</thead>
<tbody>
<tr>
<td>s1</td>
<td></td>
<td>Initial setp</td>
<td></td>
</tr>
<tr>
<td>s10</td>
<td></td>
<td>Standard assy/machining 1</td>
<td></td>
</tr>
<tr>
<td>s11</td>
<td></td>
<td>Standard assy/machining 2</td>
<td></td>
</tr>
<tr>
<td>s12</td>
<td></td>
<td>Standard assy/machining 3</td>
<td></td>
</tr>
<tr>
<td>s13</td>
<td></td>
<td>Standard assy/machining 4</td>
<td></td>
</tr>
<tr>
<td>s14</td>
<td></td>
<td>St. assy/machining 5 (aux)</td>
<td></td>
</tr>
<tr>
<td>s15</td>
<td></td>
<td>Condition1 assy/machining</td>
<td></td>
</tr>
<tr>
<td>s16</td>
<td></td>
<td>Condition2 assy/machining 1</td>
<td></td>
</tr>
<tr>
<td>s17</td>
<td></td>
<td>Condition2 assy/machining 2</td>
<td></td>
</tr>
<tr>
<td>s18</td>
<td></td>
<td>Condition2 assy/machining 3</td>
<td></td>
</tr>
<tr>
<td>s19</td>
<td></td>
<td>Condition2 assy/machining 4</td>
<td></td>
</tr>
<tr>
<td>s20</td>
<td></td>
<td>Condition3 assy/machining 1</td>
<td></td>
</tr>
<tr>
<td>s21</td>
<td></td>
<td>Condition3 assy/machining 2</td>
<td></td>
</tr>
<tr>
<td>s22</td>
<td></td>
<td>Condition3 assy/machining 3</td>
<td></td>
</tr>
<tr>
<td>s23</td>
<td></td>
<td>Condition3 assy/machining 4</td>
<td></td>
</tr>
<tr>
<td>s24</td>
<td></td>
<td>Condition4 assy/machining 1</td>
<td></td>
</tr>
<tr>
<td>s25</td>
<td></td>
<td>Condition4 assy/machining 2</td>
<td></td>
</tr>
<tr>
<td>s26</td>
<td></td>
<td>Condition4 assy/machining 3</td>
<td></td>
</tr>
<tr>
<td>s27</td>
<td></td>
<td>Condition4 assy/machining 4</td>
<td></td>
</tr>
<tr>
<td>s28</td>
<td></td>
<td>Cond.4 Assy/machining(sort)</td>
<td></td>
</tr>
<tr>
<td>s29</td>
<td></td>
<td>Cond.4 Assy/machining(sort)</td>
<td></td>
</tr>
</tbody>
</table>
(4) Ladder block/Operation output/transition condition (ladder) printing example

<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Initial selection circuit</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

LD

X001

Condition
n 0

2

Y001
(5) Ladder block/Operation output/transition condition (list) printing example

<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Initial selection circuit</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

LD

<table>
<thead>
<tr>
<th>Step</th>
<th>Instruction</th>
<th>Device</th>
<th>Device comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>X001</td>
<td>Condition 0</td>
</tr>
<tr>
<td>1</td>
<td>OUT</td>
<td>Y001</td>
<td></td>
</tr>
<tr>
<td>Block No.</td>
<td>1</td>
<td>Title</td>
<td>Auto operation start step</td>
</tr>
<tr>
<td>-----------</td>
<td>---</td>
<td>------------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>s1</td>
<td></td>
<td>Initial setup</td>
<td></td>
</tr>
<tr>
<td>s10</td>
<td></td>
<td>Standard assy/machining</td>
<td></td>
</tr>
<tr>
<td>s11</td>
<td></td>
<td>Standard assy/machining</td>
<td></td>
</tr>
<tr>
<td>s12</td>
<td></td>
<td>Standard assy/machining</td>
<td></td>
</tr>
<tr>
<td>s13</td>
<td></td>
<td>Standard assy/machining</td>
<td></td>
</tr>
<tr>
<td>s14</td>
<td></td>
<td>St. assy/machining 5 (aux)</td>
<td></td>
</tr>
<tr>
<td>s15</td>
<td></td>
<td>Condition1 assy/machining</td>
<td></td>
</tr>
<tr>
<td>s16</td>
<td></td>
<td>Condition2 assy/machining</td>
<td></td>
</tr>
<tr>
<td>s17</td>
<td></td>
<td>Condition2 assy/machining</td>
<td></td>
</tr>
</tbody>
</table>

### Step 0
- **Instruction**: SET
- **Device**: Y000
- **Device comment**: Auto operation in progress

### Step 1
- **Instruction**: LD
- **Device**: X010
- **Device comment**: Output A

### Step 2
- **Instruction**: OUT
- **Device**: M100

### Step 3
- **Instruction**: LD
- **Device**: X011
- **Device comment**: Output L

### Step 4
- **Instruction**: OUT
- **Device**: M111
- **Device comment**: Output K

### Step 5
- **Instruction**: LD
- **Device**: X001
- **Device comment**: Condition 0

### Step 6
- **Instruction**: OUT
- **Device**: Y001

### Step 7
- **Instruction**: OUT
- **Device**: Y001

### Step 8
- **Instruction**: OUT
- **Device**: M114
- **Device comment**: Output O

### Step 9
- **Instruction**: OUT
- **Device**: M115
- **Device comment**: Output J

### Step 10
- **Instruction**: OUT
- **Device**: M115

### Step 11
- **Instruction**: OUT
- **Device**: M116
- **Device comment**: Output Q
<table>
<thead>
<tr>
<th>Step</th>
<th>Instruction</th>
<th>Device</th>
<th>Device comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>M0</td>
<td>TRAN0</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
INDEX

[A]
Active step monitor ......................................... 4- 6
All block batch monitor ................................... 4- 6

[B]
Block information setting ................................ 3-49
Block list .......................................................... 3-26
Block list display ............................................... 3-51
Block list monitor ............................................... 4- 7
Block number search (SFC diagram side) ... 3-62
Block number search (Zoom side)................ 3-63
Block parameters ............................................ 3-54

[C]
Character string replacement ....................... 3-65
Character string search .................................. 3-63
Contact/coil search ........................................ 3-67
Contact/coil use list ....................................... 3-67
Conversion operation .................................... 3-58

[D]
Debugging (step run) ..................................... 5- 1
Device alias display...................................... 3-72
Device comment display ................................ 3-72
Device comment search ................................ 3-64
Device replacement ....................................... 3-65
Device search............................................... 3-61
Device test.................................................... 4- 5
Device use list ............................................... 3-68
Device use search ........................................ 3-68
Displaying in MELSAP-L Format.................... 3-74
Displaying the Reference Window................. 3-74

[E]
Edit data, adding new .................................... 3- 3
Enter key, operation starting from ............. 3-37

[F]
Function key, operation starting from .......... 3-36

[H]
Horizontal partition contact count setting .... 3-77

[I]
Instruction replacement .................................. 3-65
Instruction search .......................................... 3-61

[J]
Jump step search.......................................... 3-64

[L]
Label display (operation output) .................... 3-72
Label display (SFC diagram) ....................... 3-71
Ladder mode/list mode switching .................. 3-73

[M]
Microcomputer capacity.............................. 3- 3
Multiple windows, opening ......................... 3-75

[N]
Note display ............................................... 3-72
Note editing.................................................. 3-48
Note type changing .................................... 3-67

[O]
Open/Close contact changing ....................... 3-65
Operation output, note display for .......... 3-73
Operation output/transition condition creation .................................................. 3-45
Operation output/transition condition ladder monitor ............................................ 4- 4
Operation output/transition condition switching to ladder mode/list mode ........... 3-73

[P]
PLC parameters, SFC setting ....................... 3-53
Printing examples (when A or Q/QnACPU is used) .............................................. 6- 2
Printing examples (when the FXCPU is used) ................................................. 6-11

[S]
SFC comment creation ................................ 3-46
SFC comment display ................................ 3-69
SFC diagram copying ................................ 3-40
SFC diagram creating method ...................... 3-13
SFC diagram deleting method ...................... 3-38
SFC diagram equipment name display .......... 3-71
SFC diagram monitor .................................. 4- 1
SFC diagram print setting ......................... 6- 1
SFC diagram redisplay ................................ 3-44
SFC diagram sorting .................................. 3-43
SFC diagram symbols (A series) .................. 3- 7
SFC diagram symbols (Q/L/QnA series)........ 3-8
SFC display column setting ....................... 3-76
SFC parameter setting ................................ 3-53

SFC program setting ........................................... 3-55
SFC program writing, online ......................... 3-58
SFC setting, option setting ............................... 3-79
Step attribute changing ................................. 3-39
Step number replacement ............................... 3-66
Step number search (SFC diagram side) ............... 3-62
Step number search (Zoom side) ....................... 3-63
Step run .............................................................. 5-1
Step/transition comment display .................... 3-69

[T]
T/C set value changing ................................. 3-68
Timer/counter set value changing ..................... 3-68
Toolbar menu, operation starting from .............. 3-36
Tool button, operation starting from (when A or
Q/L/QnACPU is used) ......................................... 3-14
Tool button, operation starting from (when the
FXCPU is used) .................................................. 3-24
Transition watchdog monitor ......................... 4-3
Transition watchdog timer ............................. 3-79

[Z]
Zoom partition setting ....................................... 3-77
Specifications subject to change without notice.

When exported from Japan, this manual does not require application to the Ministry of Economy, Trade and Industry for service transaction permission.