MITSUBISHI

GPP Function software for Windows
SW5D5C-GPPW-E

Operating Manual (SFC)

MELSEC
Mitsubishi Programmable Logic Controller
Before using this product, please read this manual and the relevant manuals introduced in this manual carefully and pay full attention to safety to handle the product correctly.

The instructions given in this manual are concerned with this product. For the safety instructions of the programmable controller system, please read the CPU module user's manual.

In this manual, the safety instructions are ranked as "DANGER" and "CAUTION".

![DANGER](image)

Indicates that incorrect handling may cause hazardous conditions, resulting in death or severe injury.

![CAUTION](image)

Indicates that incorrect handling may cause hazardous conditions, resulting in medium or slight personal injury or physical damage.

Note that the CAUTION level may lead to a serious consequence according to the circumstances. Always follow the instructions of both levels because they are important to personal safety.

Please save this manual to make it accessible when required and always forward it to the end user.

[Design Instructions]

<table>
<thead>
<tr>
<th>DANGER</th>
</tr>
</thead>
<tbody>
<tr>
<td>● When data change, program change or status control is to be made from a peripheral device to the running PLC, configure up an interlock circuit in the outside of the PLC system to ensure that the whole system will always operate safely. Also, determine corrective actions to be taken for the system when a communication error occurs due to a cable connection fault or the like in online operation performed from the peripheral device to the PLC CPU.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CAUTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>● Online operation performed with a peripheral device connected to the running CPU module (especially program change, forced output or operating status change) should be started after carefully reading the manual and fully ensuring safety. Not doing so can cause machine damage or accident due to miss operation.</td>
</tr>
<tr>
<td>Print Date</td>
</tr>
<tr>
<td>------------</td>
</tr>
</tbody>
</table>

This manual confers no industrial property rights or any rights of any other kind, nor does it confer any patent licenses. Mitsubishi Electric Corporation cannot be held responsible for any problems involving industrial property rights which may occur as a result of using the contents noted in this manual.

© 2000 MITSUBISHI ELECTRIC CORPORATION
INTRODUCTION

Thank you for choosing the Mitsubishi MELSEC Series General-Purpose Programmable Controller. Before using the equipment, please read this manual carefully to use the product to its optimum. A copy of this manual should be forwarded to the end user.

CONTENTS

1. OVERVIEW 1-1 to 1-4
   1.1 Product Overview and Features .............................................................................................................. 1-1
   1.2 Abbreviations and Generic Names Used in This Manual ........................................................................ 1-3

2. PRECAUTIONS FOR CREATING SFC PROGRAMS 2-1 to 2-10
   2.1 Precautions for Use of the ACPU ............................................................................................................ 2-1
   2.2 Precautions for Use of the Motion Controller ........................................................................................ 2-3
   2.3 Precautions for Use of the QnACPU ....................................................................................................... 2-4
   2.4 Precautions for Use of the Qn(H)CPU .................................................................................................... 2-4
   2.5 Precautions for Use of the FXCPU .......................................................................................................... 2-5

3. SFC PROGRAM EDITING 3-1 to 3-78
   3.1 SFC Program Editing Outline Procedure ................................................................................................ 3-1
       3.1.1 SFC Program Editing Outline Procedure (for ACPU) ...................................................................... 3-1
       3.1.2 SFC Program Editing Procedure Outline (for Q/QnACPU) ............................................................. 3-4
       3.1.3 SFC Program Editing Procedure Outline (for FXCPU).................................................................... 3-6
   3.2 SFC Diagram Symbol List ....................................................................................................................... 3-7
   3.3 SFC Diagram Editing Basic Screen ........................................................................................................ 3-11
   3.4 Creating/Modifying the SFC Diagram ..................................................................................................... 3-13
       3.4.1 (1) Writing an SFC Diagram ............................................................................................................. 3-13
       3.4.1 (2) Deleting the SFC Diagram .......................................................................................................... 3-38
       3.4.1 (3) Changing the Step Attribute ........................................................................................................ 3-39
       3.4.2 Cutting/Copying and Pasting the SFC Diagram ............................................................................... 3-40
       3.4.3 Sorting the SFC Diagram .................................................................................................................. 3-43
       3.4.4 Redisplaying the SFC Diagram ........................................................................................................ 3-44
   3.5 Creating the Operation Outputs/Transition Conditions........................................................................... 3-45
   3.6 Creating the SFC Comments .................................................................................................................. 3-46
       3.6.1 Creating SFC Comments .................................................................................................................. 3-46
       3.6.2 Editing the Note for Operation Output .............................................................................................. 3-48
   3.7 Setting the Block Information ................................................................................................................ 3-49
   3.8 Display the Block List ............................................................................................................................. 3-51
   3.9 SFC-Related Parameter Settings ............................................................................................................ 3-53
       3.9.1 SFC Setting in PLC Parameters ....................................................................................................... 3-53
       3.9.2 Setting the Block Parameters .......................................................................................................... 3-54
       3.9.3 SFC Program Setting ....................................................................................................................... 3-55
       3.9.4 SFC Program Capacity Check ........................................................................................................ 3-56
6. PRINTING THE SFC DIAGRAMS

6.1 SFC Diagram Print Setting ................................................................. 6-1
6.2 SFC Diagram Printing Examples.......................................................... 6-2
  6.2.1 SFC Diagram Printing Examples (when A or Q/QnACPU is used)..... 6-2
  6.2.2 SFC Diagram Printing Examples (when the FXCPU is used)....... 6-11

INDEX

Index-1 to Index-2
About Manuals

The following manuals are also related to this product. In necessary, order them by quoting the details in the tables below.

### Related Manuals

<table>
<thead>
<tr>
<th>Manual Name</th>
<th>Manual Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>GPP Function Software for Windows SW5D5C-GPPW-E(V) SW5D5C-LLT-E(V) Operating Manual (Start-up)</td>
<td>IB-0800093</td>
</tr>
<tr>
<td></td>
<td>(13J974)</td>
</tr>
<tr>
<td>GPP Function Software for Windows SW5D5C-GPPW-E(V) Operating Manual</td>
<td>SH-080062</td>
</tr>
<tr>
<td></td>
<td>(13J975)</td>
</tr>
<tr>
<td>GPP Function Software for Windows SW4D5C-GPPW-E(V) SW4D5C-LLT-E(V) Starting GPPW(Guidebook)</td>
<td>IB-0800057</td>
</tr>
<tr>
<td></td>
<td>(13J966)</td>
</tr>
<tr>
<td>MELSAP-II (SFC) Programming Manual</td>
<td>IB-66361</td>
</tr>
<tr>
<td></td>
<td>(13JF40)</td>
</tr>
<tr>
<td>QCPU (Q mode)/QnA CPU Programming Manual (SFC)</td>
<td>SH-080041</td>
</tr>
<tr>
<td></td>
<td>(13JF60)</td>
</tr>
</tbody>
</table>
1. OVERVIEW

1.1 Product Overview and Features

Overview

This manual describes the editing and monitoring operations of the SFC functions among the functions of Type SW5D5C-GPPW-E GPP Function Software Package (hereafter referred to as "GPPW"). For the functions other than the SFC functions and the specifications related to SFC programs, refer to the corresponding manuals given in "Related Manuals".

The following SFC functions are supported by GPPW.

<table>
<thead>
<tr>
<th>CPU Compatible</th>
<th>CPU Compatible</th>
</tr>
</thead>
<tbody>
<tr>
<td>MELSAP-II</td>
<td>• ACPU</td>
</tr>
<tr>
<td></td>
<td>• Motion controller*</td>
</tr>
<tr>
<td></td>
<td>• Qn(H)CPU-A (A mode)</td>
</tr>
<tr>
<td></td>
<td>If the CPU type (series) differs, the specifications and functions are the same.</td>
</tr>
<tr>
<td>MELSAP3</td>
<td>• QnACPU</td>
</tr>
<tr>
<td></td>
<td>• Qn(H)CPU (Q mode)</td>
</tr>
<tr>
<td></td>
<td>If the CPU type (series) differs, the specifications and functions are the same.</td>
</tr>
<tr>
<td>FX series SFC</td>
<td>FX0, FX1S, FX2N, FX1, FX2, FX2C,</td>
</tr>
<tr>
<td></td>
<td>FX1S, FX1N, FX2N, FX2NC</td>
</tr>
<tr>
<td></td>
<td>If the CPU type (series) differs, the specifications and functions are the same.</td>
</tr>
</tbody>
</table>

*The motion controller can use the SFC functions like the ACPU, with the exception of the SFC symbol SV.
Features

GPPW-supported SFC (MELSAP II/MELSAP3/SFC for FX series) has the following features.

SFC is one of the methods that can be used for programming the A series and QCPU (Q mode)/QnA series and FX series CPUs and it stands for S equential F unction C hart.
By clearly representing the operating sequence of machinery/equipment controlled by the CPU, this new language makes it easy to grasp the system as a whole, and makes programming easier.
In contract to the case where a program represented by ladders is entirely executed every scan, only the minimum required part of a program may be run if it is written in the SFC format.

1. Many useful editing functions
   (1) The function keys, tool buttons, menu bar and so on improve programming operations.
   (2) You can easily cut and paste your SFC diagrams between two or more windows.

2. A wealth of monitoring functions
   (1) Monitoring an SFC diagram for the active steps of an SFC program.
   (2) Monitoring a ladder diagram for the active devices of operation outputs and transition conditions.
   (3) Displaying a list of all blocks and batch-monitoring the active states of the blocks.
   (4) Automatic scrolling enables the track monitoring of the active step.

3. Many useful test functions
   (1) Ease of forced ON/OFF and present value changing of the specified devices
   (2) Forced start/stop and temporary stop of the specified blocks

4. Comment editing and printing choices
   (1) Comments can be written to each step of each SFC diagram.
   (2) You can select printing according to your application, e.g. SFC diagram with operation outputs and transition conditions appended, with SFC comments appended, or just the diagram itself.

Windows is either a trademark or registered trademark of Microsoft Corporation in the United States.
Other company and product names herein are either the trademarks or registered trademarks of their respective owners.
1.2 Abbreviations and Generic Names Used in This Manual

In this manual, the GPP Function Software Packages and PLC CPU modules are represented by the following generic names and abbreviations. When the corresponding type must be specified, its module type is provided.

<table>
<thead>
<tr>
<th>Abbreviation/Generic Name</th>
<th>Description/Corresponding Module</th>
</tr>
</thead>
<tbody>
<tr>
<td>QCPU</td>
<td>Generic name for PLC CPUs of MELSEC-Qn(H)CPU (Q mode) which allow SFC programs to be edited</td>
</tr>
<tr>
<td>Qn(H)CPU-A</td>
<td>Generic name for PLC CPUs of MELSEC-Qn(H)CPU-A (A mode) which allow SFC programs to be edited. Described as the ACPU in this manual.</td>
</tr>
<tr>
<td>ACPU</td>
<td>Generic name for PLC CPUs usable with the MELSEC-A. In this manual, the Qn(H)CPU-A (A mode) and motion controller are also included. (Note that GPPW does not support the A1, A2, A3, A3H, A3M, A52G, A73 and A0J2.)</td>
</tr>
<tr>
<td>QnACPU</td>
<td>Generic name for PLC CPUs usable with the MELSEC-QnA.</td>
</tr>
<tr>
<td>FXCPU</td>
<td>Generic name for PLC CPUs usable with the MELSEC-QnA.</td>
</tr>
<tr>
<td>GPPA</td>
<td>SRXV-GPPA</td>
</tr>
<tr>
<td></td>
<td>VD-GPPA</td>
</tr>
<tr>
<td>GPPQ</td>
<td>VD-GPPQ</td>
</tr>
<tr>
<td>GPPW</td>
<td>SW5DSC-GPPW</td>
</tr>
<tr>
<td>SFC</td>
<td>Generic name for MELSAP-II, MELSAP3 and SFC for FX series</td>
</tr>
<tr>
<td>Software package for motion controller</td>
<td>Generic name for software packages for motion controller which allow SFC programs to be edited</td>
</tr>
</tbody>
</table>
2. PRECAUTIONS FOR CREATING SFC PROGRAMS

This chapter gives precautions for creating SFC programs with GPPW.

2.1 Precautions for Use of the ACPU

<table>
<thead>
<tr>
<th>Item</th>
<th>GPPW</th>
<th>GPPA</th>
</tr>
</thead>
</table>
| User microcomputer program  | • Cannot be created.  
                              | • Erased if another format file that is read includes a microcomputer program other than an SFC program. | • The A0J2H, AnS, AnSH and AnNCPUs allow SFC and microcomputer programs to exist together. |
| SFC capacity                | • The parameter setting of the microcomputer capacity must be made. However, since the capacity is not checked at the time of creation, checking operation is needed to make sure that the SFC capacity is within the microcomputer capacity range. (Refer to POINT.) |
|                             | • A program can be created within the parameter-set "microcomputer capacity" and SFC-set "block count" ranges. |
| Maximum block count setting | • A program can be created as desired within the maximum number of blocks (256 blocks).  
                              | • For another format write or PLC write, write up to the largest existing block number as a set value. However, write "32" when the existing blocks are within 32. |
|                             | • Up to which block of the maximum number of blocks (256 blocks) will be created must be set on the SFC diagram editing screen. (Default value: 32) |
| CPU type change (QnA→ACPU)  | • As the CPU type is changed with the parameter setting of the microcomputer capacity remaining unchanged from "0k bytes"; the microcomputer capacity setting must be changed after CPU type changing.  
                              | (Without QnA→ACPU conversion function for SFC program) |
| Hold step                   | • Representation of hold step                                      | • Representation of hold step                                      |
|                             | [SC]                                                                | [S]                                                                |

*Different in only representation method and identical in function.

A block start step is also handled as a single step and a step comment appears when SFC comment indication is given.

The comment displayed at the block start step is the block title of the start destination block.

* A program printed is as displayed on the screen.
## 2. PRECAUTIONS FOR CREATING SFC PROGRAMS

<table>
<thead>
<tr>
<th>Item</th>
<th>GPPW</th>
<th>GPPA</th>
</tr>
</thead>
</table>
| **SFC comment creation** | • SFC comments may either be created simultaneously with SFC diagram creation or during comment editing.  
• SFC comments are handled as common comments, and device comments can be created with a block title specified as "BLm", a step comment as "BLm:Sn", and a transition comment as "BLm:TRn". | • SFC comments are created in the SFC diagram writes mode.  
• As SFC comments are handled in SFC diagrams only; they cannot be handled as device comments. |
| **Block title** | • Can be edited up to 32 characters.  
• When the block title is reread after another format write or PC write, a character string of more than 24 characters are erased.  
• The block title is not read if the file stored without SFC comment copying being performed for a renaming or copying operation on GPPA is read in another format. (The block title is read if it is read in another format after making re-conversion on GPPA.) | • Can be edited up to 24 characters. |
| **Note for operation output** | • Each coil instruction of an operation output can be annotated.  
• When written to GPPA in another format, the note for operation output is not written. | • An operation output cannot be annotated. |
| **Creating and displaying an SFC diagram for stepless selection branches and selective couplings** | Not allowed  
A correct display cannot be obtained when the SFC diagram created by GPPA contains stepless selective branches and selective couplings. | Allowed* |

### POINT

*: Example of stepless selective branches and selective couplings are shown below.

![Diagram](image-url)
2. PRECAUTIONS FOR CREATING SFC PROGRAMS

POINT

After creating a SFC diagram and performing a conversion operation, perform the following operation to check that the existing SFC program capacity is within the preset microcomputer capacity.

[Operating procedure]

[Tools]→[Set SFC information]→[Program capacity check]

[Screen]

If "SFC program capacity is beyond the microcomputer cap." appears on the right of Result of check, PLC write or another format write cannot be performed as it will result in an error.

Change the microcomputer capacity setting to a value equal to or greater than the "Created SFC program capacity".

2.2 Precautions for Use of the Motion Controller

<table>
<thead>
<tr>
<th>Item</th>
<th>GPPW</th>
<th>Software Package for Motion Controller</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step attribute</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>SV</strong></td>
<td></td>
<td>• Supported.</td>
</tr>
<tr>
<td>Others</td>
<td></td>
<td>With the exception of the step attribute <strong>SV</strong>, the precautions are the same as those for use of the ACPU.</td>
</tr>
</tbody>
</table>
2.3 Precautions for Use of the QnACPU

<table>
<thead>
<tr>
<th>Item</th>
<th>GPPW</th>
<th>Software Package for Motion Controller</th>
</tr>
</thead>
<tbody>
<tr>
<td>SFC comments</td>
<td>• SFC comments are handled as common comments.</td>
<td>• SFC comments are handled as program-by-program comments.</td>
</tr>
<tr>
<td></td>
<td>• When another format file write is performed from GPPW to GPPQ, the file is divided into a program file and a comment file and therefore renaming and other operations are needed on GPPQ.</td>
<td></td>
</tr>
<tr>
<td>SFC diagram pattern</td>
<td>• If an SFC diagram created is redisplayed in a different pattern, verifying that diagram may result in a mismatch. Example: Created Redisplayed A mismatch occurs if the above SFC diagram is redisplayed or project-read, &quot;converted&quot;, and verified.</td>
<td>• Same specifications as those of GPPW.</td>
</tr>
<tr>
<td></td>
<td>A mismatch occurs if the above SFC diagram is redisplayed or project-read, and &quot;converted&quot;, and verified.</td>
<td></td>
</tr>
</tbody>
</table>

2.4 Precautions for Use of the Qn(H)CPU

There are no specific precautional restrictions since the SFC program editing of the QnCPU is made only with GPPW.
2.5 Precautions for Use of the FXCPU

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| FX SFC programming            | • The FXCPU uses stepladder instructions (STL, RET) to control the sequence of a process.  
                                | These stepladder instructions can also be expressed as SFC diagrams.  
                                | • SW5DS5C-GPPW-E and later versions support this FX SFC programming.  
                                | • For details of the FXCPU SFC programming method, refer to the programming manual of each CPU.  
                                | • The method of expressing FX series stepladder instructions in GPPW differs from that of FXGP (DOS) and FXGP (WIN).  
                                | For details, refer to the SW5DS5C-GPPW-E operating manual.  

| Steps and states              | In GPPW, an SFC process is called a "step".  
                                | In the programming material and other programming software for the FXCPU, an SFC process is called a "state".  
                                | Both "steps" and "states" indicate SFC processes.  

A stepladder instruction and an SFC diagram are essentially the same.  
In an actual program, they are expressed as follows. (This is different to a screen display.)
### 2. PRECAUTIONS FOR CREATING SFC PROGRAMS

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step number (state (S) number)</td>
<td>States S0 to S9 are called initial steps (states). They are always used as the first block No. of an SFC block. Consequently, when the FXCPU is used, up to 10 (S0-S9) SFC blocks can be created. S10 and higher numbers can be used as general step numbers. However, the maximum number of steps per block is 512. You cannot use step (state) numbers more than once.</td>
</tr>
<tr>
<td>Ladder block</td>
<td>A sequence circuit that programs the outside of a step (state) is called a ladder block. A ladder block operates in the same way as a general ladder program.</td>
</tr>
<tr>
<td>Number of branches in a flow</td>
<td>The number of circuits in the case of one parallel branch or selective branch is limited to 8 circuits per branch. However, if there are many parallel branches or selective branches, the overall number of circuits is limited to 16 circuits per initial step. You cannot perform a transition or reset operation from confluence lines or a step prior to confluence to a separation step. Create a dummy step and be sure to perform the transition or reset operation from the branch line to a separation step.</td>
</tr>
<tr>
<td>Role of a block list and block type</td>
<td>In the case of the FXCPU, when writing a block list it is necessary to select either a ladder block or an SFC block. Regarding stepladder blocks contained in STL (stepladder instruction), it is possible to make a type change to an SFC block later.</td>
</tr>
</tbody>
</table>
## 2. PRECAUTIONS FOR CREATING SFC PROGRAMS

### Jump attribute

- A jump has two kinds of attributes, which are changed according to the particular purpose.
  - \( \text{L} \) Jump to another step or another flow (step attribute: \([\text{None}]\))
  - \( \downarrow \) Reset jump for a self-step (state) (step attribute: \([\text{R}]\))

For a jump, \( \text{L} \) is input as the initial value. A change to \( \downarrow \) is made using the step attribute of the [SFC symbol] dialog box.

- If the jump destination is in a different SFC block, the jump destination mark will not appear at that jump destination step.

### Handling a RET instruction

- The RET instruction of a stepladder instruction is automatically written from the end of the SFC block to the part connected to the ladder block. Consequently, you cannot input a RET instruction to an SFC block or a ladder block. (Does not appear on the screen either.)

- Note that in the case of the following ladder program, if you change over to the SFC program, then change back to the ladder program, the number of program steps in the RET instruction part will decrease.

### Transition comment

Transition comments cannot be used in the case of FX SFC.

### Transition condition number

The transition condition number is valid only in an SFC diagram. For this reason, if you change over to a ladder program, this number does not continue. Consequently, if you change back to SFC a program that you changed to a ladder, the transition number will change.
2. PRECAUTIONS FOR CREATING SFC PROGRAMS

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can change a ladder program to a SFC program, or vice-versa, by setting [Project] → [Edit Data] → [Change program type].</td>
<td></td>
</tr>
</tbody>
</table>

- Precautions to observe when changing a ladder program to an SFC program
  - If a ladder program that uses a stepladder (STL, RET) instruction cannot be converted to a SFC block, it will change to a ladder block.
  - In this case, the message "Ladder block!", which indicates the incompletion of the change, will appear in the block type box of the block list.

[Ladders that cannot be changed]

1. When there is no initial step
2. When the number of steps used in one block exceeds 512
3. When a branch or confluence is incorrect
4. When the transition conditions are programmed in the same circuit as that of the operation outputs (See figure below)

Modification

1. When there is a circuit defect
2. When there is an instruction code error
3. When a step (state) number is used more than once

- Method of treating stepladder (STL, RET) instructions that cannot be changed to SFC blocks

Method (1) First, modify the ladder program, then change it to SFC.
Method (2) In the case of a simple modification, first convert SFC ("Ladder block!") (incomplete condition).

After modifying the program in ZOOM of the ladder block, change the block type to "SFC block" by means of [Edit] → [Block information].

(Ladder that cannot be changed to SFC) Transition conditions modified to independent circuit block
## 2. PRECAUTIONS FOR CREATING SFC PROGRAMS

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Program type change** | Precautions to observe when changing an SFC program into a ladder program [SFC that cannot be changed]  
(1) When an unregistered (blank) block exists in the block list (when blocks are not contiguous)  
(2) When ladder blocks are contiguous  
(3) When there are unconverted blocks  
Method of treating SFC that cannot be converted into a ladder program  
Display the block list, then execute [Convert] → [Convert block (all blocks)], end the arranging of the block list and the conversion of unconverted parts, then once again set a program type change. |
| **Compatibility of project data** |  
A project that was stored as an SFC program using the SWD5C-GPPW-E or a later version cannot be read using a version prior to the SW4D5C-GPPW-E, which is not compatible with the FX SFC.  
If the project of an SFC program is read using a version prior to the SW4D5C-GPPW-E, it is treated as the project of a non-supported CPU, and an error message is displayed.  
If it is necessary to share the project with an incompatible version, change it to a ladder program using [Project] → [Edit data] → [Change program type], then save the project. |
| **PC type change** | When the FXCPU is selected: This CPU supports only a PC type change to the FXCPU.  
For ACPU, QCPU (A mode): These CPUs do not support a PC type change to the FXCPU. |
| **PC write/read/compare** | Precautions to observe when writing a program  
(1) When writing an SFC program, be sure to write the entire step range. (You cannot perform a partial write operation.)  
(2) You cannot perform a write operation if there is an unconverted block, there is an unregistered (blank) block in the list, or the ladder blocks are contiguous. Execute [Convert] → [Convert block (all blocks)], then re-write the program.  
(3) Program change during RUN, a timer or a counter set value change in the online mode (write during RUN) are not supported. |
| **PC write/read/compare** | Precautions to observe when reading a program  
(1) When reading a program, be sure to read the entire step range. (You cannot perform a partial read operation.)  
(2) If you cannot change a read program into an SFC block, register it in the block list as a ladder block. |
| **Writing/reading/comparing other format files** | Precautions to observe when comparing programs  
(1) When comparing programs, be sure to use the entire range. (You cannot perform a partial comparison.)  
(2) The transition number on the SFC screen is not stored in the PC, so it is not the object of comparison.  
(3) The contents of block type and also unconverted blocks are not the object of comparison. |
| **Writing/reading/comparing other format files** | Notes and statements cannot be read/written to files of other formats (FXGP (WIN), FXGP (DOS)).  
For other precautions, refer to "PC read/write/compare". |
3. SFC PROGRAM EDITING

3.1 SFC Program Editing Outline Procedure

3.1.1 SFC Program Editing Outline Procedure (for ACPU)

1. Create new project:
   - Creation of new project
   - Setting of PLC series, PLC type, and project name

2. Parameter setting:
   - Set the microcomputer capacity by setting the memory capacity in the PLC parameter.

3. Addition of new edit data:
   - New program type “SFC” as edit data.

4. SFC option setting:
   - Set the reference window, a jump to start destination block, and automatic scroll monitoring.
   - Select the language.
   - Set the number of contact columns displayed.
   - Set the SFC display column.

5. SFC write:
   - Write SFC diagram from block 0.

6. Modify existing program:
   - Open the project.
   - SFC write
   - Refer to POINT 1.
   - Refer to POINT 2.
1) Conversion operation

Block information

Write the transition condition/operation output program step-by-step.

To create another block

Check the SFC program capacity.

Save the project.

2) Read the block to be modified.

Write, insert, delete SFC diagram modifying operation

Step-by-step operation output/transition condition correcting operation

Conversion operation

Block information
POINTS

- When creating a new SFC program, you need to make the parameter setting of the microcomputer capacity and perform a new edit data adding operation.
  Perform the following operation before SFC diagram editing.

  1) Parameter setting of microcomputer capacity
     [Parameter of Project data list] → [PLC parameter] → Memory capacity

     Set the microcomputer capacity and perform the operation of Check → OK → End setup.

  2) Addition of new edit data
     [Project] → [Edit data] → [New]

     Choose Program at Data type, change Program type to “SFC”, and click the OK button. The following window then appears.

     Choosing Yes enables an SFC diagram to be edited under the data name of "MAIN-SFC".
3. SFC PROGRAM EDITING

3.1.2 SFC Program Editing Procedure Outline (for Q/QnACPU)

- **GPPW start**
- **Creation of new project**
  - Set the PLC series, PLC type and project name, and set the program type to "SFC".
- **SFC parameter setting**
  - Set the SFC program start mode, block 0 start condition, and output mode at block deactivation.
- **Other parameter settings**
  - Set the other parameters as required.
- **Block parameter setting**
  - Set the "Periodic Execution Block No.", "Act at Block Multi-Activated" and "Act at Step Multi-Activated".
- **SFC program setting**
- **SFC option setting**
  - Set the reference window, a jump to start destination block, and automatic scroll monitoring.
- **Toolbar setting**
  - Set the toolbar display for "SFC".

**A**

**Q/QnA**

**FX**

×  O  ×
3. SFC PROGRAM EDITING

1) Select the language.

Set the number of contact columns displayed.

Set the SFC display column.

(To create new program)

SFC write
Write SFC diagram from block 0.

Conversion operation

SFC information register setting

Write the transition condition/operation output program step-by-step.

(To modify the existing program)

Read the block to be modified.

Write, insert, delete
SFC diagram modifying operation

Step-by-step operation output/transition condition correcting operation

Conversion operation

SFC information register setting, modification

Display the specified block.

Point
This outline procedure is given for your reference.
You can perform the operations in any order without following the above procedure.

Save the project.
3. SFC PROGRAM EDITING

3.1.3 SFC Program Editing Procedure Outline (for FXCPU)

- GPPW startup
- New creation of project
  - Set PC series, PC type, and project name, and use "SFC" as program type.
- SFC optional settings
  - Set reference window and auto scroll monitor.
- Block list registration
  - Register ladder block in block 0.
    (Block information setting)
- Ladder program write/modification
- Conversion operation
- Block list registration
  - Register SFC block in block 1.
    (Block information setting)
- Transition condition/operation output program write/modification for each step
- Conversion operation

If there is an unconverted block, or there is an unregistered (blank) block in the block list, execute [Convert] [Convert block (all blocks)] while the block list is displayed, then end the arranging of the block list and the conversion of unconverted parts.

POINT
This outline procedure is for reference only.
You may perform each operation in an arbitrary sequence.
3. SFC PROGRAM EDITING

3.2 SFC Diagram Symbol List

The following table lists symbols used in SFC programs. A block is an operation sequence, which starts at an initial step and ends at an end step. The smallest units of operations are steps and transitions. Further, transition conditions and operation outputs are represented in ladder diagrams using the zoom of the display function or in instruction lists.

<table>
<thead>
<tr>
<th>Class</th>
<th>Name</th>
<th>Symbol</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step</td>
<td>Initial step</td>
<td>![InitialStepSymbol]</td>
<td>One step in each block</td>
</tr>
<tr>
<td></td>
<td>Step</td>
<td>![StepSymbol]</td>
<td>Max. 254 steps. in each block (i=1 to 254)</td>
</tr>
<tr>
<td></td>
<td>Block start step</td>
<td>![BlockStartSymbol]</td>
<td>Number of steps in each block (more than one step may be provided for the same block)</td>
</tr>
<tr>
<td></td>
<td>END step</td>
<td>![EndSymbol]</td>
<td>More than one step may be provided in each block.</td>
</tr>
<tr>
<td>Series transition</td>
<td>![SeriesTransitionSymbol]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Selective branch</td>
<td>![SelectiveBranchSymbol]</td>
<td>(Left end) (Middle) (Right end)</td>
<td></td>
</tr>
<tr>
<td>Selective coupling</td>
<td>![SelectiveCouplingSymbol]</td>
<td>(Left end) (Middle) (Right end)</td>
<td></td>
</tr>
<tr>
<td>Transition</td>
<td>Parallel branch</td>
<td>![ParallelBranchSymbol]</td>
<td>(Left end) (Middle) (Right end)</td>
</tr>
<tr>
<td></td>
<td>Parallel coupling</td>
<td>![ParallelCouplingSymbol]</td>
<td>(Left end) (Middle) (Right end)</td>
</tr>
<tr>
<td></td>
<td>Jump transition</td>
<td>![JumpTransitionSymbol]</td>
<td>(i=jump destination step)</td>
</tr>
</tbody>
</table>
## 3. SFC PROGRAM EDITING

### [QnA series SFC diagram symbol list]

<table>
<thead>
<tr>
<th>Class</th>
<th>Name</th>
<th>SFC Diagram Symbol</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Initial step</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dummy initial step</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Coil hold initial step</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Operation hold step (without transition check) initial step</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Operation hold step (with transition check) initial step</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Reset initial step</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Step</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Initial step</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dummy initial step</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Coil hold initial step</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Operation hold step (without transition check) initial step</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Operation hold step (with transition check) initial step</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Reset initial step</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Step</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dummy step</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Coil hold step</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Operation hold step (without transition check)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Operation hold step (with transition check)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Reset step</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Block start step (with end check)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Block start step (without end check)</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- **Step**
  - Initial step
  - Dummy initial step
  - Coil hold initial step
  - Operation hold step (without transition check) initial step
  - Operation hold step (with transition check) initial step
  - Reset initial step
- **Step**
  - Initial step
  - Dummy initial step
  - Coil hold initial step
  - Operation hold step (without transition check) initial step
  - Operation hold step (with transition check) initial step
  - Reset initial step
- **Step**
  - Step
  - Dummy step
  - Coil hold step
  - Operation hold step (without transition check)
  - Operation hold step (with transition check)
  - Reset step
  - Block start step (with end check)
  - Block start step (without end check)

- **Step**
  - Any one of these steps in one block
  - Up to a total of 31 steps in one block
  - Including initial step, max. 512 steps in one block

---

3 - 8
<table>
<thead>
<tr>
<th>Class</th>
<th>Name</th>
<th>SFC Diagram Symbol</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Series transition</td>
<td>a</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Selective branch</td>
<td>a b n</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Selective branch-parallel branch</td>
<td>a b</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Selective coupling</td>
<td>a b</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Selective coupling-parallel branch</td>
<td>a b</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Parallel branch</td>
<td>a</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Parallel coupling</td>
<td>a</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Parallel coupling-parallel branch</td>
<td>a b</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Parallel coupling-selective branch</td>
<td>a b</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Parallel coupling-selective coupling</td>
<td>a b</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Jump</td>
<td>a i</td>
<td></td>
</tr>
</tbody>
</table>

More than one block end may be provided in one block.
[FX series SFC diagram symbol list]

<table>
<thead>
<tr>
<th>Class</th>
<th>Name</th>
<th>Symbol</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ladder</td>
<td>Ladder block</td>
<td>[ ] LD</td>
<td>Max 11 in block list</td>
</tr>
<tr>
<td>Step</td>
<td>Initial step</td>
<td>[ ] i</td>
<td>1 in each block (i=0-9)</td>
</tr>
<tr>
<td></td>
<td>Step</td>
<td>[ ] i/ [ ] i</td>
<td>Max 512 in each block (i=10-999)</td>
</tr>
<tr>
<td>Transition</td>
<td>Series transition</td>
<td>[ ]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Selective branch</td>
<td>[ ]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Selective coupling</td>
<td>[ ]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Parallel branch</td>
<td>[ ]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Parallel coupling</td>
<td>[ ]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Jump transition</td>
<td>[ ]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Reset JUMP</td>
<td>[ ]</td>
<td></td>
</tr>
</tbody>
</table>
3. SFC PROGRAM EDITING

3.3 SFC Diagram Editing Basic Screen

(1) Whole screen make-up

1) Area for displaying the project name being edited, the number of steps used, the block number being displayed and so on
2) Menu names on the menu bar
3) Icons on the toolbar
4) Project list display
5) SFC diagram editing area
6) Operation output/transition condition program editing area (Zoom side)
7) Edited CPU type
8) Edit mode (overwrite/insert)
(2) SFC diagram editing screen make-up

POINTS
- The Zoom-side display shows the operation output/transition condition at the cursor position in the SFC diagram.
- Some menus that may be selected/operated change depending on whether the cursor is on the SFC diagram side or on the Zoom side.
3.4 Creating/Modifying the SFC Diagram

3.4.1 (1) Writing an SFC Diagram

An SFC diagram may be created in any of the following four methods.

1. Starting from the tool button on the toolbar
2. Starting from the function key
3. Starting from the menu on the toolbar
4. Starting from pressing the Enter key

Performing any of the above operations shows the Enter SFC symbol window.

Enter data by the operations given on the pages that follow.
(1-1) Operation starting from the tool button (when A or Q/QnACPU is used)

Write (overwrite) operation example

1) Step (□) / (◼)

- Diagram symbol
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click ▼ and choose a new diagram symbol.

- Step number
  The system automatically assigns lower to higher step numbers in the order of entry.
  When you will use the step numbers automatically assigned by the system, you can omit the “step number” input operation.
  At a dummy step, you can create an operation output program if it is marked "□", which will change to "◼" automatically after the program is created.

- Step attribute
  When adding a step attribute, click ▼ and choose the attribute you want to add.
  When you chose the reset step (R) as a step attribute, enter the reset destination step number after making selection.
• Comment creation
You can enter a comment of up to 32 characters.
The comment created can be displayed by "step/transition comment display" operation in the display menu.

2) Block start step (  )

• Diagram symbol
The diagram symbol name selected appears.
To change the diagram symbol selected, click and choose a new diagram symbol.

• Start destination block number
Enter the start destination block number.

• Step number
The system automatically assigns lower to higher step numbers in the order of entry.
When you will use the step numbers automatically assigned by the system, you can omit the "step number" input operation.

• Comment creation
You can enter a comment of up to 32 characters.
The comment created can be displayed by "step/transition comment display" operation in the display menu.
3) Series transition (†)

- Diagram symbol
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click ◄ and choose a new diagram symbol.

- Transition condition number
  The system automatically assigns lower to higher transition condition numbers in the order of entry.
  When you will use the transition condition numbers automatically assigned by the system, you can omit the "transition condition number" input operation.

- Comment creation
  You can enter a comment of up to 32 characters.
  The comment created can be displayed by "step/transition comment display" operation in the display menu.
3. SFC PROGRAM EDITING

4) Selective branch (→)

- Diagram symbol
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click and choose a new diagram symbol.

- Number of branches
  Enter the number of branch line columns.
  If it is "1", you can omit the input operation.

5) Parallel branch (→)

- Diagram symbol
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click and choose a new diagram symbol.

- Number of branches
  Enter the number of branch line columns.
  If it is "1", you can omit the input operation.
6) Selective coupling ( )

- Diagram symbol
  The diagram symbol name selected appears. To change the diagram symbol selected, click and choose a new diagram symbol.

- Number of couplings
  Enter the number of coupling line columns. If it is "1", you can omit the input operation.

7) Parallel coupling ( )

- Diagram symbol
  The diagram symbol name selected appears. To change the diagram symbol selected, click and choose a new diagram symbol.

- Number of couplings
  Enter the number of coupling line columns. If it is "1", you can omit the input operation.
3. SFC PROGRAM EDITING

POINTS

* Input method used when a branch and a coupling are used together in a single transition condition

1) For Q/QnACPU

When a branch and a coupling are used together in a single transition condition, reserve an area for one step using "|" (vertical line) and then enter the branch and coupling symbols.

Example 1:

- Area for 1 step

Example 2:

- Area for 1 step

2) For ACPU

As a branch and a coupling cannot be used together in a single transition condition, enter a dummy step.

Example 1:

Example 2:

- Area for 1 step

* For branch/coupling line entry, entering the number of branches/couplings as "-n" creates them from right to left.
8) Jump transition (획기)

• Diagram symbol
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click ▼ and choose a new diagram symbol.

• Jump destination step number
  Enter the jump destination step number.
  Clicking the OK button changes the indication of the step specified as the jump destination from (획기) to (획기).

9) End step (획기)
10) Rule write

- To write a rule, click and drag from the first position to the last position of the rule entry.

<table>
<thead>
<tr>
<th>POINT</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you write a rule over the existing step/transition, the step/transition symbol and operation output/transition condition sequence program are not erased.</td>
</tr>
</tbody>
</table>

11) Row insert

12) Column insert

13) Row delete

14) Column delete
Write (insert) operation example

When an SFC diagram is created by a write (insert) operation, insertion results are as described below on an SFC diagram symbol basis. Note that step/transition condition number changing, simultaneous SFC comment creation and so on can be performed as in the write (overwrite) operation.

1) Step (□)

- Point the cursor to a desired position and click the SFC symbol (step) to insert a step in the cursor position.
- When you insert a step over "|" (vertical line) without changing the step number, the lowest free number of the existing SFC diagram is assigned.
- When the insert position is within a branch ladder, "|" (vertical line) is automatically inserted into another branch.

2) Series transition (↑)

- Point the cursor to a desired position and click the SFC symbol (transition) to insert a transition in the cursor position.
- When you insert a transition over "|" (vertical line) without changing the transition condition number, the lowest free number of the existing SFC diagram is assigned.
- When the insert position is within a branch ladder, "|" (vertical line) is automatically inserted into another branch.
3. SFC PROGRAM EDITING

3) Selective branch (-----)

4) Parallel branch (-----)

5) Selective coupling

6) Parallel coupling

POINTS

- Entering "-n" as the number of branches/couplings enters them from right to left. Example: Number of couplings "1"

- Inserting a branch/coupling may generate an SFC diagram that cannot be converted. In this case, correct the SFC diagram with the edit function (cut and paste) and then perform a conversion operation.
(1-2) Operation starting from the tool button (when the FXCPU is used)

Write (overwrite) operation example

1) Register a ladder block in block list No.0.

<table>
<thead>
<tr>
<th>No</th>
<th>Block title</th>
<th>Block type</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Double-click

Select "ladder block".

2) Creating a ladder circuit

LD 0 → X0

LD 0 → X0

LD 0 → X0
3) Register an SFC block in block list No.1.
   Block list display: Double-click [View] → [Display block list], or [Program] of [Project data list] then [MAIN].

Double-click

Select "SFC block".

Complete
3. SFC PROGRAM EDITING

POINTS

- Block list

1. When the FXCPU is used, first register "Ladder block" or "SFC block" in the block list, then start to create the program.

Register the block list from the top.

<table>
<thead>
<tr>
<th>No.</th>
<th>Block title</th>
<th>Block type</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Initial selection circuit</td>
<td>Ladder block</td>
</tr>
<tr>
<td>1</td>
<td>Auto operation start step</td>
<td>SFC block</td>
</tr>
<tr>
<td>2</td>
<td>Machining No.1</td>
<td>SFC block</td>
</tr>
<tr>
<td>3</td>
<td>Machining No.2</td>
<td>SFC block</td>
</tr>
<tr>
<td>4</td>
<td>Machining No.3</td>
<td>SFC block</td>
</tr>
<tr>
<td>5</td>
<td>Product control circuit</td>
<td>Ladder block</td>
</tr>
</tbody>
</table>

2. You cannot change to a ladder program or write to the PC if there is an unconverted block or unregistered (blank) block in the block list, or the ladder blocks are contiguous.

Display the block list, execute [Convert] → [Convert block (all blocks)], then end the arranging of the block list and the conversion of unconverted parts.

<table>
<thead>
<tr>
<th>No.</th>
<th>Block title</th>
<th>Block type</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Initial selection circuit</td>
<td>Ladder block</td>
</tr>
<tr>
<td>1</td>
<td>Auto operation start step</td>
<td>SFC block</td>
</tr>
<tr>
<td>2</td>
<td>Machining No.1</td>
<td>SFC block</td>
</tr>
<tr>
<td>3</td>
<td>Machining No.2</td>
<td>SFC block</td>
</tr>
<tr>
<td>4</td>
<td>Machining No.3</td>
<td>SFC block</td>
</tr>
<tr>
<td>5</td>
<td>Product control circuit</td>
<td>Ladder block</td>
</tr>
</tbody>
</table>

3. Circuits that cannot be changed into SFC blocks

If you attempt to change an existing ladder circuit, for example, into SFC, the change sometimes fails to take place because of some kind of error, even when the circuit contains a stepladder (STL) instruction.

In this case, the circuit is registered as "Ladder block!" in block type, that is, as a ladder block to which the "!" mark is appended.

After changing the contents of the circuit, change the type of block to SFC block using [Edit] → [Block information].
4) Step ( □ )

• Diagram symbol
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click ▼ and choose a new diagram symbol.

• Step number
  A step number is a number that the system automatically assigns in ascending input sequence over the range of S10-S999. (The upper limit differs depending upon the PC type. Also, the maximum number of steps per block is 512.)
  If the step number automatically assigned by the system is satisfactory, you can omit the "step number" input operation.
  S0-S9 are assigned to the beginning of the SFC block as the initial blocks, so you cannot input them to a general step position.
  You cannot input a step number more than once.
  When the FXCPU is used, dummy steps are also treated in the same way as general steps, however there is no need to create an operation output program.

• Step attribute
  When the FXCPU is used, the step has no attribute apart from when a "JUMP" symbol is set.

• Comment creation
  You can enter a comment of up to 32 characters.
  The comment created can be displayed by "step/transition comment display" operation in the display menu.
5) Series transition (¶)

- **Diagram symbol**
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click the selected symbol and choose a new diagram symbol.

- **Transition condition number**
  The system automatically assigns lower to higher transition condition numbers in the order of entry.
  When you will use the transition condition numbers automatically assigned by the system, you can omit the "transition condition number" input operation.
  When the FXCPU is used, the transition condition number is valid only on the SFC diagram. For this reason, this number does not continue when a change is made to a ladder program.

- **Comment creation**
  When the FXCPU is used, transition comments are not supported.
6) Selective branch (→)

- Diagram symbol
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click ▼ and choose a new diagram symbol.

- Number of branches
  Enter the number of branch line columns.
  If it is “1”, you can omit the input operation.

7) Parallel branch (→)

- Diagram symbol
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click ▼ and choose a new diagram symbol.

- Number of branches
  Enter the number of branch line columns.
  If it is “1”, you can omit the input operation.
3. SFC PROGRAM EDITING

8) Selective coupling (串接)

- Diagram symbol
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click and choose a new diagram symbol.

- Number of couplings
  Enter the number of coupling line columns.
  If it is "1", you can omit the input operation.

9) Parallel coupling (并联)

- Diagram symbol
  The diagram symbol name selected appears.
  To change the diagram symbol selected, click and choose a new diagram symbol.

- Number of couplings
  Enter the number of coupling line columns.
  If it is "1", you can omit the input operation.
### Points

- **Input method used when a branch and a coupling are used together in a single transition condition**

  As a branch and a coupling cannot be used together in a single transition condition, enter a dummy step.

  When the FXCPU is used, there is no symbol called "dummy step", so input a general step. There is no need to input a control output circuit, and so on, in a dummy step.

  **Example 1)**

  ![Diagram 1](image1)

  **Example 2)**

  ![Diagram 2](image2)

- **For branch/coupling line entry, entering the number of branches/couplings as "-n" creates them from right to left.**

### Points

- **Branch number**

  The number of circuits in the case of one parallel branch or selective branch is limited to 8 circuits per branch.

  However, if there are many parallel branches or selective branches, the overall number of circuits is limited to 16 circuits per initial step.

  ![Diagram 3](image3)

  **Example)**

  ![Diagram 4](image4)

  You cannot perform a transition or reset operation from confluence lines or a step prior to confluence to a separation step.

  Create a dummy step and be sure to perform the transition or reset operation from the branch line to a separation step.
10) Jump transition (\(\uparrow\) \(\downarrow\))

- **Diagram symbol**
  The diagram symbol name selected appears. To change the diagram symbol selected, click \(\downarrow\) and choose a new diagram symbol.

- **Jump destination step number**
  Enter the jump destination step number. Clicking the \(\text{OK}\) button changes the indication of the step specified as the jump destination from (\(\square\)) to (\(\uparrow\)). When the FXCPU is used, if the jump destination is in another SFC block, the step of the jump destination is displayed as (\(\uparrow\)).

- **Step attribute**
  In the case of a general jump, select [None].

11) Reset jump transition (\(\downarrow\))

- **Diagram symbol**
  Select "JUMP" as the diagram symbol.

- **Jump destination step number**
  Input the step number to be reset. (Normally input the step number immediately prior to the jump destination.)

- **Step attribute**
  In the case of a reset jump, select [R].
12) Rule write

To write a rule, click and drag from the first position to the last position of the rule entry.

POINT
If you write a rule over the existing step/transition, the step/transition symbol and operation output/transition condition sequence program are not erased.

13) Row insert

14) Column insert

15) Row delete

16) Column delete
Write (insert) operation example

When an SFC diagram is created by a write (insert) operation, insertion results are as described below on an SFC diagram symbol basis. Note that step/transition condition number changing, simultaneous SFC comment creation and so on can be performed as in the write (overwrite) operation.

1) Step (⿵)

- Point the cursor to a desired position and click the SFC symbol (step) to insert a step in the cursor position.
- When you insert a step over " | " (vertical line) without changing the step number, the lowest free number of the existing SFC diagram is assigned.
- When the insert position is within a branch ladder, "|" (vertical line) is automatically inserted into another branch.

2) Series transition (ｨ)

- Point the cursor to a desired position and click  to insert a transition in the cursor position.
- When you insert a transition over " | " (vertical line) without changing the transition condition number, the lowest free number of the existing SFC diagram is assigned.
- When the insert position is within a branch ladder, "|" (vertical line) is automatically inserted into another branch.
3. SFC PROGRAM EDITING

3) Selective branch (öne)

4) Parallel branch (öne)

5) Selective coupling

6) Parallel coupling

**POINTS**

- Entering "-n" as the number of branches/couplings enters them from right to left.
  Example: Number of couplings "1"

- Inserting a branch/coupling may generate an SFC diagram that cannot be converted.
  In this case, correct the SFC diagram with the edit function (cut and paste) and then perform a conversion operation.
(2) Operation starting from the function key
1) The SFC symbols are assigned to the following function keys.

<table>
<thead>
<tr>
<th>Step</th>
<th>SFC symbol</th>
<th>Function key</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>[Step]</td>
<td>F5</td>
<td>A, Q/QnACPU only</td>
</tr>
<tr>
<td></td>
<td></td>
<td>F6</td>
<td>QnACPU only</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Shift + F6</td>
<td>A, Q/QnA only</td>
</tr>
<tr>
<td></td>
<td></td>
<td>F8</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>F7</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Shift + F5</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Transition or branch/coupling</th>
<th>SFC symbol</th>
<th>Function key</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>[Transition or branch/coupling]</td>
<td>F5</td>
<td>F6</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Alt + F5</td>
<td>Alt + F7</td>
</tr>
</tbody>
</table>

2) Operation procedure
• Step/transition/branch/coupling entry
  1) Press the function key.
  2) Since the window as was shown when the tool button was clicked appears, refer to the tool button operation procedure and enter the required items.
  3) Press the Enter key.

• Rule entry
  1) Press the function key.
  2) Using the arrow keys, move the cursor to the first position of a branch/coupling.
  3) Hold down the Shift key and move the cursor with the arrow keys.
  4) Move the cursor to the last position of the branch/coupling and release your hand from the key.
(3) Operation starting from the menu on the toolbar
   • Step/transition/branch/coupling entry
     1) Click [Edit] on the toolbar.
     2) Move the cursor to [SFC symbol] in the edit menu.
     3) Click the SFC symbol to be entered.
     4) Since the window as was shown when the tool button was clicked appears,
        refer to the tool button operation procedure and enter the required items.
     5) Press the [Enter] key.

   • Rule entry
     1) Click [Edit] on the toolbar.
     2) Move the cursor to [Edit the line] in the edit menu.
     3) Click the branch/coupling line to be entered.
     4) Drag from the first position to the last position of the entry.

(4) Operation starting from the [Enter] key
   1) Press the [Enter] key.
   2) Since the window as was shown when the tool button was clicked appears, refer
      to the tool button operation procedure and enter the required items.
   3) Press the [Enter] key.

POINT
Operation starting from the [Enter] key is a method useful for entry of steps (□) and transitions (↓) consecutively in the column direction.
3. SFC PROGRAM EDITING

3.4.1 (2) Deleting the SFC Diagram

This section explains how to delete the existing SFC diagram symbols.

(1) Operation using the tool button to delete

1) Specifying the area and making deletion

   ![Diagram](image1)

   (Drag)

2) Deleting the branch/coupling/vertical line only

   ![Diagram](image2)

   (Drag)

(2) Operation using the function key to delete

   - Hold down the Shift key and choose the deletion area with the arrow keys.

   - Press the Delete key.

(3) Operation to delete from the menu on the toolbar

   - With the mouse, drag over the area to be deleted.

   - Click [Cut] in the edit menu.

POINT

Performing the [Undo] operation after making a deletion returns to the status immediately prior to the deletion.

- Tool button : Click

- Function key : Ctrl + Z

- Menu : Click [Undo] in the edit menu.
3. SFC PROGRAM EDITING

3.4.1 (3) Changing the Step Attribute

This section describes how to change the step attribute in the existing SFC diagram. The step attribute can be changed by any of the following tool button clicking, menu operation and key pressing.

<table>
<thead>
<tr>
<th>Tool Button</th>
<th>Key Pressing</th>
<th>Menu</th>
<th>Description</th>
<th>Remarks</th>
</tr>
</thead>
</table>
| [Ctrl + 1]  |             | 1) Editing
             ↓                     | • Makes the preset step attribute invalid. |
| [Ctrl + 2]  |             | 2) Step attribute setting
             ↓                     | • Changes the preset step attribute to SC. |
| [Ctrl + 3]  |             | 3) Choose a new attribute. | • Changes the preset step attribute to SE. |
| [Ctrl + 4]  |             | | • Changes the preset step attribute to ST. |
| [Ctrl + 5]  |             | | • Changes the preset step attribute to R and sets the reset destination step No. |
|             |              |     | • When it has already been set to R, changes the reset destination step No. |

Q/QnACPU only

POINT

If the step attribute has been changed, the existing operation output sequence program remains unchanged.
3.4.2 Cutting/Copying and Pasting the SFC Diagram

This section provides the operation to cut/copy and paste the SFC diagram.

(1) Specifying the area, cutting or copying the SFC diagram, and pasting it

[Operation procedure]

1. Choose [Edit]→[Write mode] or (F2) or (Ctrl)+(F2).
2. Click the first position of the SFC diagram to be cut, and move the cursor.

3. Drag over the area to be cut or copied. The specified area is highlighted.

4. When cutting, choose [Edit]→[Cut] or (Ctrl)+(X), or when copying, choose [Edit]→[Copy] or (Ctrl)+(C) to cut the ladder in the specified area.

5. Click the position where the cut (copied) SFC diagram will be applied, and move the cursor.
6. When you choose [Edit] → [Paste] or 
\[Ctrl\] + \[V\], the Paste data window appears. Make pasting choices.

1) Selection of whether or not the operation output/transition condition sequence program is also pasted simultaneously.
2) Selection of whether or not the original step/transition condition number is changed.
3) Selection of whether or not the step/transition comment is also pasted simultaneously.

POINT
"Not changing" the original step/transition condition number is useful for a moving operation.

7. When you selected "not to" change the original step/transition condition number but the pasting destination already has the same step/transition condition number, the following window appears.

Choosing [Yes] executes pasting after the system has assigned a new number by reassigning lower to higher free numbers to the step/transition condition numbers of the pasting destination SFC diagram. Choosing [No] suspends pasting.
8. When the first position of the cut or copied SFC diagram is a step and its pasting position is a transition position, or vice versa, the following window appears.

![Message Window]

When this window has appeared, click the OK button, move the pasting position one row higher or lower, then perform a pasting operation again.

9. After the pasting operation is over, make conversion.
   Note that a conversion error occurs if a branch/coupling is incorrect after pasting. Therefore, make conversion after performing the SFC diagram editing operation.

![Diagram with branches]

**POINTS**

- Cutting/copying and pasting between different blocks in the same program can be executed by displaying the corresponding blocks by performing [Window] → [Tile vertically] or [Tile horizontally] operation.
- Cutting/copying and pasting between different projects can be executed after opening the corresponding projects by performing [Project] → [Start new GPPW session] operation.
- Copying of an operation output/transition condition sequence program should be done within approx. 2k steps.
This operation reassigns the step/transition numbers of the created SFC diagram.

**[Operation procedure]**

**[Tools]** → [Sort] or

**[Setting screen]**

1) **Sorting Order**
   - Specify whether the step/transition numbers are in an ascending or descending order.

2) **Change START block number**
   - Specify whether the start destination block number is to be changed or not.

3) **Set START block number**
   - When you have selected "Change", enter a new block number.

4) **Execute** button
   - Executes sorting as set on the above screen.

**POINTS**

- The result of executing sorting by specifying an ascending or descending order is as follows.
  (When ascending order is specified)  (When descending order is specified)
  
  * Immediately after sorting, a "Undo" operation can be performed only once.
  *  is step "0" if you specify either the ascending or descending order.

- The SFC comments do not move and remain attached to the step and transition numbers. After sorting, corrections must be made by cutting and pasting the SFC comments.

- The SFC devices (e.g. BLm\Sn, BLn\TRn) used with the operation outputs/transition conditions are not the objects of sorting.
  Sort them by performing a device number changing operation or the like.
3.4.4 Redisplaying the SFC Diagram

[Setting purpose]
This operation is performed to return the unconverted SFC diagram being edited to the status immediately prior to editing, or to top-shift or left-shift the freed row or column of the "|" (vertical line)/branch/coupling line.

[Operation procedure]
[View] → [Review SFC]

1) Top-shift redisplaying example

2) Left-shift redisplaying example

3) Unconverted SFC diagram redisplaying example

4) After-conversion SFC diagram optimizing display
3. SFC PROGRAM EDITING

3.5 Creating the Operation Outputs/Transition Conditions

When creating an operation output/transition condition program, move the cursor to the corresponding step/transition in the SFC diagram and click the Zoom side. The subsequent operations are the same as in the ladder or list creating method. For detailed operations, refer to the SW5D5C-GPPW-E(V) Operating Manual.

POINTS

- There are instructions which cannot be used with operation outputs/transition conditions. For more information, refer to the "MELSAP II (SFC) Programming Manual" for the ACPU or to the "QCPU(Qmode)/QnACPU Programming Manual (SFC)" for the QCPU and QnACPU.
- As a transition condition, only one dummy coil (\([\text{Tran}]\)) may be entered for the coil instruction. To enter it, click \(\text{Tran}\) or \(\text{Tran}\) and click the [OK] button. \([\text{Tran}]\) is entered automatically.
- For entry in list representation, enter only the contact instruction and the dummy coil (\([\text{Tran}]\)) need not be entered.
- Instructions that cannot be used in the case of the FXCPU

| Ladder blocks | RET, END |
| Steps         | MC, MCR |
|               | STL, RET (step ladder instruction) |
|               | SET S*, OUT S*, RST S* (transition instruction with stepladder) |
|               | END, FEND |
|               | P/I, CJ, SRET, IRET |
| Transition conditions | P/I |
|               | STL, RET (stepladder instruction) |
|               | Coil instructions and output instructions other than the TRAN symbol |
3.6 Creating the SFC Comments

An SFC comment is a generic name for a “step comment” attached to each step of the created SFC diagram and a “transition comment” attached to each transition. In addition, a “block title” is available as a comment related to SFC diagrams. This section explains how to create and correct SFC comments and block titles.

3.6.1 Creating SFC Comments

You can create an SFC comment when entering an SFC symbol. Also, you can create a block title when converting the SFC diagram. This section describes how to create/correct only comment data after SFC diagram creation.

(1) Performing operation on the SFC diagram editing screen

[Operation procedure]

[Edit] → [Documentation] → [Comment] → Move the cursor to the editing position → Enter

Alternatively, → Right-double-click at the editing position.

[Setting screen]
Select an SFC diagram symbol in the SFC diagram to perform SFC comment creation/correction.

Select a ladder symbol on the Zoom side to perform device comment creation/correction.

In this operation, a block title cannot be created/corrected.

About block comments

SAP3
When performing file write (write to GPPW format or other format file) and then PLC write, data will disappear unless a comment file is written.

SAP2
When performing write to other format, data will disappear unless a comment file is written.

If you have created a block title of 25 or more characters on SAP2, performing PLC write or write to other format file will delete the 25th and latter characters.

When the FXCPU is used
Create a block title by displaying the block list, then executing [Edit] \[Block information]. If you write to an FXGP (DOS) format file when a step comment that consists of more than 16 characters has been created, the 17th and subsequent characters will be deleted.

(2) Performing operation on the device comment editing screen

[Operation procedure]
Device comment in project data list \rightarrow COMMENT

[Setting screen]

1) Device name
Specify the device which will be commented.
When creating an SFC comment, specify the device name as indicated below.

- A, Q, OnA series
  Block title : BLm
  Step comment : BLm\Sn
  Transition comment : BLm\TRn
  m: Block number
  n: Step/transition number

- FX series
  Block title : BL0-BL24
  Step comment : S0-S999 (device comment corresponding to state S)
3. SFC PROGRAM EDITING

3.6.2 Editing the Note for Operation Output

This section provides the operation performed to annotate an operation output ladder. For full information on notes, refer to THE SW5D5C-GPPW-E(V) Operating Manual.

[Operation procedure]
[Edit] → [Documentation] → [Note] → Move the cursor to the editing position → Enter
Alternatively, → Right-double-click at the editing position.

[Setting screen]

1) Select Embeddec note or Separate note.
   For the ACPU, only separate note is available.
2) Note editing area
3) [OK] button
   Determines the entered note.

POINTS
- When creating a note on the ACPU and writing it in another format, that note is not written to the GPPA.
- After editing a note, always perform a conversion operation.
   The data created will not remain if you do not make conversion.
3. SFC PROGRAM EDITING

3.7 Setting the Block Information

[Setting purpose]
This operation is performed to set the block information of the corresponding block at the time of a conversion operation after creation of an SFC diagram.

[Operation procedure]
- SFC diagram creation ➔ (F4)
- [Edit] ➔ [Block information]

[Setting screen]

For ACPU

Block information setting

- Block no.: 0
- Block title:
  - Block Active bit
  - Stop transition bit
  - Block Clear bit
  - Block Skip bit
  - Active step no.

For QnACPU

Block information setting

- Block no.: 0
- Block title:
  - Block START/END bit
  - Block transition bit
  - Block PAUSE/RESTART bit
  - Pause mode bit
  - Number of active steps register
  - Continue transition bit

Enter a device into each item.
No device may be entered into an unnecessary item.

POINTS
- For the function and operation of each item, refer to the "MELSAP II (SFC) Programming Manual" for the ACPU or to the "QCPU(Qmode)/QnACPU Programming Manual (SFC)" for the Q/QnACPU.
- A block equipment name can be created by entering a device name "BLm" during device comment editing.
  Also, a block title can be created/changed by the same operation as a device comment of BLm.
When the FXCPU is used

1) Input the block title of the ladder block or SFC block.
   You can create or change a block title as a device comment of BLm using the same operation.

2) Be sure to specify either an SFC block or a ladder block according to the contents of the program to be written.

POINTS

- If an STL instruction exists in a ladder block, the message "Ladder block!", which indicates a conversion error, will be displayed in the block type of block list.
- If an incomplete ladder block is described by an STL instruction, you can modify the contents using the zoom screen, then change the block to "SFC block" in "Block Type" of the block information setting.
- Regarding errors that can occur during a block type change
   In the following cases, an error display appears, and the change process is interrupted.
   1) If SFC conversion is not possible
   2) If the initial step does not exist
   3) If a number of blocks are generated when the program in a block is SFC-converted.
3. SFC PROGRAM EDITING

3.8 Display the Block List

Show the currently edited SFC program in a list form to monitor it or to perform block-by-block editing, e.g. cut and paste.

[Operation procedure]
[View] → [Display block list]
[Block list screen]

When the A or A/QnACPU is used

<table>
<thead>
<tr>
<th>No</th>
<th>Block title</th>
<th>Active</th>
<th>Transition</th>
<th>Close</th>
<th>Stop</th>
<th>Register</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Start of blocks 1, 2</td>
<td>0</td>
<td>M1</td>
<td>M2</td>
<td>M3</td>
<td>00</td>
</tr>
<tr>
<td>1</td>
<td>Monitoring process handling</td>
<td>1</td>
<td>M11</td>
<td>M12</td>
<td>M13</td>
<td>010</td>
</tr>
<tr>
<td>2</td>
<td>Finishing start block</td>
<td>2</td>
<td>M30</td>
<td>M31</td>
<td>M32</td>
<td>020</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td>9</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td>13</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td></td>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td></td>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td></td>
<td>16</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
<td>17</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td></td>
<td>18</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

When the FXCPU is used

<table>
<thead>
<tr>
<th>No</th>
<th>Block title</th>
<th>Block type</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Operation selection</td>
<td>Ladder block</td>
</tr>
<tr>
<td>1</td>
<td>Auto operation</td>
<td>Ladder block</td>
</tr>
<tr>
<td>2</td>
<td>Auto operation assistance</td>
<td>Ladder block</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
1) One screen displays 32 blocks.
   Using the scroll bar, [Page Up] / [Page Down] or [ ] / [ ] key, you can change the displayed blocks.
2) Indicates whether the corresponding blocks have been converted or not.
   ─ : Already converted
   * : Not yet converted
3) Display the block program type. (FXCPU only)
   "SFC block" or "Ladder block" is displayed.
   If a ladder circuit that contains a STL instruction cannot be changed to an SFC block, add the "!" mark so that the display is "Ladder block!".

---

**POINTS**

In the SFC block list, you can perform the following.
1) Block information setting/correction
2) Batch copy between blocks
3) Jump to SFC diagram display in the specified block
4) SFC monitoring in the block list
5) (Batch) Conversion of unconverted blocks
3.9 SFC-Related Parameter Settings

Among the parameter settings made for operating the Q/QnACPU, this section explains the setting of parameters related to SFC programs.

3.9.1 SFC Setting in PLC Parameters

This section gives the operation performed to set the SFC-related parameters using the PLC parameters.

[Operation procedure]
PLC parameters in project data list → SFC setting of QnA parameter settings

[Setting screen]

[Item explanation]
1) SFC program start mode
   Set an initial start or resume start to start the SFC program.
2) Start conditions
   Set autostart block 0/do not autostart block 0 at the initial start of the SFC program.
3) Output mode when the block is stopped
   Set whether a stop is made by turning off the coil outputs which were turned on by the OUT instruction or by keeping them on (latched) when a stop request is sent to any block.
3.9.2 Setting the Block Parameters

This section provides how to set the block parameters.

[Operation procedure]
[Tools] → [Set SFC information] → [Block parameter]
[Setting screen]

1) Periodic execution block
All blocks from the set block number onward are periodic execution blocks.
To process all blocks every scan, leave the input area blank.
Enter the execution interval within the range 1 to 65535 (ms) in 1ms increments.

2) Act at block multi-activated
If a start request is made from another block while a block in the designated range is active, an error occurs and CPU operation stops.
The operation mode in the event of a double start for blocks outside the designated range is "Wait".
To set "Wait" for all blocks, leave the first and last input areas blank.

3) Act at step multi-activated
If a double start occurs with respect to any step in the range for which "Waiting blocks" is designated, operation is suspended until the corresponding step becomes inactive.
If a double start occurs with respect to any step in the range for which "Stop blocks" is designated, an error occurs and CPU operation stops.
If a double start occurs with respect to a step outside the specified range, a forced transition is executed.
3. SFC PROGRAM EDITING

1. The block parameter settings are common to all blocks. They cannot be set for individual blocks.

3.9.3 SFC Program Setting

Set whether the SFC program file being edited is to be a "Normal SFC Program" or a "Control SFC program".

[Operation procedure]
[Tools] → [Set SFC information] → [SFC type]
[Setting screen]

[Item explanation]
When Control SFC program is selected, an SFC program can be created for block 0 only.
Note that if a block start step (■, ■) is designated in block 0, an error occurs when the program is executed and CPU operation stops.
3.9.4 SFC Program Capacity Check

Check the capacity of the program file being edited.

[Operation procedure]
- [Tools] → [Set SFC information] → [SFC program capacity check]

[Setting screen]

When the ACPU is used

1) SFC program start mode
   - Initial start
   - Resume start

2) Start conditions
   - Auto start block 0
   - Do not auto start block 0

3) Output mode when the block is stopped
   - Run off
   - Keep on

When the PXCPU is used

Result of program capacity check (for converted SFC)

- Program capacity set by parameter
  - Step
- Created SFC program capacity
  - Step

Result of check: Check OK
[Item explanation]
1) Program capacity set by the parameter.
   Displays the maximum value permitted for programming.
2) Created SFC program capacity
   Displays the SFC program amount for the converted part.
3) Result of check
   If the converted SFC program is within the maximum value, [Check OK] will be displayed.
   If the maximum value is exceeded, an error message will be displayed.
3.10 Conversion Operation

The following types of conversions are available according to SFC diagram editing and operation output/transition condition editing.

<table>
<thead>
<tr>
<th>Item</th>
<th>SFC Diagram Editing</th>
<th>Operation Output/Transition Condition Editing</th>
<th>Conversion Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conversion (F4)</td>
<td></td>
<td>• Only one operation output/transition condition being edited is converted.</td>
<td></td>
</tr>
<tr>
<td>Conversion (All programs being edited)</td>
<td></td>
<td>• All programs being edited are batch-converted.</td>
<td></td>
</tr>
<tr>
<td>Conversion writing during RUN (A, Q/QnA only)</td>
<td></td>
<td>• The operation output/transition condition being edited is written during RUN.</td>
<td></td>
</tr>
<tr>
<td>Block conversion (F4)</td>
<td></td>
<td>• Only one SFC diagram block being edited is converted.</td>
<td></td>
</tr>
<tr>
<td>Block conversion (F4)</td>
<td></td>
<td>• All SFC diagram blocks being edited are batch-converted.</td>
<td></td>
</tr>
<tr>
<td>Block conversion error</td>
<td></td>
<td>• The block No.'s in SFC diagram conversion error and the number of errors are displayed.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• A detailed error is displayed per block specified.</td>
<td></td>
</tr>
</tbody>
</table>

**POINT**
For the ACPU, make an "SFC program capacity check" after conversion operation to make sure that the existing SFC program is within the microcomputer capacity. For full information, refer to Section 2.1.

3.11 Instructions for Online SFC Program Writing

This section provides instructions for writing the operation outputs/transition conditions of an SFC program to the CPU during RUN.

1. Two or more operation outputs/transition conditions cannot be written during RUN at the same time. Perform an online writing operation every time a correction has been made.

2. An SFC diagram cannot be written during RUN. After creating or modifying an SFC diagram, STOP the CPU and write the diagram using "Write" in the online menu.
3. SFC PROGRAM EDITING

3.12 Making Searches/Replacements

**POINT**

For a search/replacement made in an SFC program, the object area changes with the "searching direction" specified.

<table>
<thead>
<tr>
<th>Block</th>
<th>a) Downward from top</th>
<th>b) Downward from cursor position</th>
<th>c) Upward from cursor position</th>
</tr>
</thead>
<tbody>
<tr>
<td>Block 0</td>
<td>1)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Block 1</td>
<td>2)</td>
<td>1)</td>
<td></td>
</tr>
<tr>
<td>Block 2</td>
<td>3)</td>
<td>2)</td>
<td>2)</td>
</tr>
<tr>
<td>Block n</td>
<td>n)</td>
<td>n)</td>
<td>n)</td>
</tr>
</tbody>
</table>

* When a search/replacement is to be performed in an SFC program after a search has been made in another program, all blocks will be searched. When making searches/replacements in an SFC program within the "specified range (step range)", specify the step numbers (e.g. □ □) of the SFC diagram.
3. SFC PROGRAM EDITING

3.12.1 Searching for a Device

This operation searches for the specified device to find the operation output/transition condition of the corresponding block it is used. The cursor moves to the step or transition in the SFC diagram being used, and at the same time, the operation output/transition condition sequence program appears. The operation method is the same as in the ladder mode. For details of the operation method, refer to the SW5DSC-GPPW-E Operating Manual.

3.12.2 Searching for an Instruction

This operation searches for the specified instruction to find the operation output/transition condition of the corresponding block it is used. The cursor moves to the step or transition in the SFC diagram being used, and at the same time, the operation output/transition condition sequence program appears. The operation method is the same as in the ladder mode. For details of the operation method, refer to the SW5DSC-GPPW-E Operating Manual.

3.12.3 Searching for a Character String

This operation searches for the specified character string to find it is used as an SFC comment or an operation output note. (A device comment will not be searched for.) The cursor moves to the step or transition in the SFC diagram being used, and at the same time, the operation output/transition condition sequence program appears. The operation method is the same as in the ladder mode. For details of the operation method, refer to the SW5DSC-GPPW-E Operating Manual.
3.12.4 (1) Searching for the Step No./Block No. (SFC Diagram)

[Setting purpose]
This operation is performed to show the specified block on the screen by specifying the block No. and step No./transition No. when the cursor is in the SFC diagram.

[Operation procedure]
[FIND/REPLACE] → [Find step No./block No.]

[Setting screen]

1) Block number
Enter the block No. to be searched for.

2) Step/Transition
Specify the cursor position after a search is over.

3) [Find] button
Click this button to show the SFC diagram in the specified block.

POINTS
- This operation is valid only when the cursor is on the SFC diagram side.
- When the cursor is in the SFC diagram, pressing any "number" key shows the following window.

Clicking the [OK] button or pressing the [Enter] key allows the cursor to move to the specified step in the SFC diagram currently displayed.
Also, turning on the block no. radio button enables a block search.
3. SFC PROGRAM EDITING

3.12.4 (2) Searching for the Step No./Block No. (Zoom)

[Setting purpose]
This operation is performed to search for the step No. in the operation output/transition condition sequence program being displayed when the cursor is on the Zoom side. Alternatively, the specified block

[Operation procedure]
[Find/Replace] → [Find step no./block no.]

[Setting screen]

1) Step No./block No. input box
Enter the step No. or block No. to be searched for.

2) Search destination
Select the displayed operation output/transition condition or block as a search destination.

3) [OK] button
Click this button to show the ladder of the specified sequence program step No. when the step No. is specified.
When the block is specified, the SFC diagram in the specified block appears.
3. SFC PROGRAM EDITING

3.12.5 Replacing the Devices

This operation replaces the devices and character string constants used in the operation outputs/transition conditions.
Note that if you specify "Include SFC block information find targets", the devices used in the block information of the corresponding blocks will also be replaced.
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the SW5D5C-GPPW-E Operating Manual.

3.12.6 Replacing the Instructions

This operation replaces the instructions used in the operation outputs/transition conditions of the corresponding block.
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the SW5D5C-GPPW-E Operating Manual.

3.12.7 Changing the Open/Close Contacts

This operation replaces the open contacts of the devices used in the operation outputs/transition conditions of the corresponding block with close contacts and the close contacts with open contacts.
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the SW5D5C-GPPW-E Operating Manual.

3.12.8 Replacing the Character String

This operation replaces the character string of an SFC comment or a note created for operation output.
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the SW5D5C-GPPW-E Operating Manual.
3. SFC PROGRAM EDITING

3.12.9 Replacing the Step No.

[Setting purpose]
This operation is performed to replace the jump designation step number in the corresponding block or the step number at the hold step reset destination.

[Operation procedure]
[Find/Replace] → [Replace step no.]

[Setting screen]

[Item explanation]
1) Block no.
   Enter the first block No. to be replaced.
2) JUMP number
   Specify whether the jump destination number is to be replaced or not, and if it is to be replaced, enter the old and new step numbers.
3) Reset number (Only for Q/QnACPU)
   Specify whether the step number at the hold step reset destination is to be replaced or not, and if it is to be replaced, enter the old and new step numbers.
4) Next button
   Searches for the next target instruction without replacing the step on the cursor.
5) Replace button
   Replaces the step on the cursor and searches for the next target instruction.
6) Replace all button
   Replaces all target steps in the search range.

POINT
After replacement, always perform a conversion operation because the step number is in an unconverted status. An error check is also made at the time of conversion.
### 3.12.10 Changing the Note Type

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>○</td>
<td>○</td>
<td>×</td>
</tr>
</tbody>
</table>

This operation replaces the type of the note created for the operation output with "Embedded" or "Separate".

For the ACPU, you cannot change the note type since it is fixed to "Peripheral".

The operation method is the same as in the ladder mode.

For details of the operation method, refer to the SW5D5C-GPPW-E Operating Manual.

### 3.12.11 Searching for Contacts/Coils

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>○</td>
<td>○</td>
<td>○</td>
</tr>
</tbody>
</table>

This operation lists where the specified devices are used in the operation outputs/transition conditions and block information.

The symbols displayed represent the following.

- **Step field**
  - S : Step
  - TR : Transition

- **Sequence step field**
  - a : Block Active bit (for ACPU)
  - Block START/END bit (for QnACPU)
  - t : Step transition bit (for A, Q/QnA)
  - c : Block clear bit (for ACPU)
  - Continues transition bit (for QnACPU)
  - s : Block stop bit (for ACPU)
  - Block PAUSE/RSTARA bit (for QnACPU)
  - m : PAUSE mode bit (for QnACPU)
  - r : Active step number register (for ACPU)
  - Number of active steps register (for QnACPU)

The operation method is the same as in the ladder mode.

For details of the operation method, refer to the SW5D5C-GPPW-E Operating Manual.
3.12.12 Searching for the Device Use Status

This operation lists how the devices are used device-by-device (e.g. X, Y, M, D). A device search also covers devices used in the block information, and if they are used in the block information alone, they are shown as being used as contacts.

The operation method is the same as in the ladder mode.

For details of the operation method, refer to the SW5D5C-GPPW-E Operating Manual.

3.12.13 Changing the T/C Set Values

This operation changes the set values of the timers/counters used in the operation outputs inside the block being displayed. (The T/C set values in different blocks cannot be changed at the same time.)

The operation method is the same as in the ladder mode.

For details of the operation method, refer to the SW5D5C-GPPW-E Operating Manual.
3. SFC PROGRAM EDITING

3.13 Providing Displays

3.13.1 Displaying the Step/Transition Comments

[Setting purpose]
This operation is performed to show the created SFC diagram with SFC comments.

[Operation procedure]
1. Choose [View] → [Display comment of step and TR] (Ctrl + F5).
2. The SFC comments appear on the screen.

![Diagram of SFC program with comments](image-url)
3. When the SFC comments are being shown, choosing [View] → [Display comment of step and TR] ([Ctrl] + [F5]) hides the SFC comments.

**POINT**

- This operation is valid only when the cursor is on the SFC diagram side.
- When the FXCPU is used, only the step comment is valid.
3. SFC PROGRAM EDITING

3.13.2 Displaying the Label in the SFC Diagram

[Setting purpose]
This operation is performed to show the created label on the SFC diagram creation screen.

[Operation procedure]
1. Choose [View] → [Display label of step and TR] (Alt + Ctrl + F6).

2. The Label in the SFC diagram appear on the screen.

3. When the label are being shown, choosing [View] → [Display label of step and TR] (Alt + Ctrl + F6) hides the label.

POINTS
• Create label on the device comment-editing screen.
  Labels are not written if they are created on the ACPU and written to a GPPA format file.
• This operation is valid only when the cursor is on the SFC diagram side.
• When the FXCPU is used, transition comments are not supported.
3.13.3 Displaying the Device Comments

This operation shows the operation output/transition condition sequence program with device comments.
This operation is valid only when the cursor is on the Zoom side (operation output/transition condition side).
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the SW5DSC-GPPW-E Operating Manual.

3.13.4 Displaying Notes

This operation shows the operation output/transition condition sequence program with notes.
The operation method is the same as in the ladder mode.
This operation is valid only when the cursor is on the Zoom side (operation output/transition condition side).
For details of the operation method, refer to the SW5DSC-GPPW-E Operating Manual.

3.13.5 Displaying the Label for Devices

This operation changes the devices in the operation output/transition condition sequence program to labels.
This operation is valid only when the cursor is on the Zoom side (operation output/transition condition side).
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the SW5DSC-GPPW-E Operating Manual.
3. SFC PROGRAM EDITING

3.13.6 Changing the Operation Outputs/Transition Conditions to the Ladder Mode/List Mode

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
</tbody>
</table>

This operation changes the edit mode of the operation output/transition condition sequence program.

This operation is valid only when the cursor is on the Zoom side (operation output/transition condition side).

The operation method is the same as in the ladder mode.

For details of the operation method, refer to the SW5D5C-GPPW-E Operating Manual.
3. SFC PROGRAM EDITING

3.13.7 Opening multiple Windows

[Setting purpose]
This operation is performed to tile two or more different operation outputs/transition conditions to check or monitor the program.

[Operation procedure]
Hold down [Ctrl] and double-click the step or transition of the SFC diagram whose window will be opened.

[Screen]
(When making a new window)
A new window appears every time operation is performed.

(When not making a new window)
The display is changed within a single window.

POINT
Set whether a new window is made or not in the "Reference window" of [Tools] → [Set SFC information] → [Option].
3. SFC PROGRAM EDITING

3.14 Setting the SFC Diagram Display

3.14.1 Setting the SFC Diagram Display

[Setting purpose]
This operation is performed to set the number of branches that can be edited/displayed when the SFC diagram is edited/read.

[Operation procedure]
[View] → [Raw of SFC]

[Setting screen]

![Setting screen image]

[Item explanation]
1) Col number
   Enter the number of columns (number of branches).
   The number that may be input is any of 1 to 22 for the ACPU or any of 1 to 32 for the QnACPU FXCPU: 1 to 16.
   Entering the number of columns automatically shows the number of rows that may be entered.

2) OK button
   Click this button when the setting is complete.

POINT
This operation is valid only when the cursor is in the SFC diagram.
3.14.2 Setting the Zoom Partition

[Setting purpose]
This operation is performed to set how to split the operation output/transition condition ladder displayed.

[Operation procedure]
[View] → [Zoom setting]

[Setting screen]

Choosing vertical partition or horizontal partition provides the corresponding one of the following displays.

Note that when operation outputs/transition conditions are being displayed, clicking the partition display shows only the SFC diagram.

- Horizontal partition (ladder)
- Horizontal partition (list)

- Vertical partition (ladder)
- Vertical partition (list)
3.14.3 Setting the Number of Contacts for Horizontal Partition

[Setting purpose]
This operation is performed to set the number of contacts displayed in the operation output/transition condition ladder which has appeared on the right of the SFC diagram.

[Operation procedure]
[View] → [Set the contact at right]

[Setting screen]

[POINTS]
• This operation is valid only when "Right" is specified for Zoom partition setting.
• When "Below" is specified for Zoom partition, the number of contacts displayed is fixed to "11 contacts".
3. SFC PROGRAM EDITING

3.14.4 Setting the SFC Setting Options

[Setting purpose]
This operation is performed to set how to open windows during SFC program editing or for monitoring.

[Operation procedure]
[Tools] → [Set SFC information] → [Option]

[Setting screen]

[Item explanation]
1) Reference window
Set whether or not the operation output/transition condition sequence program windows will be tiled.

2) Zoom mode at block START step (A, Q/QnA only)
Set whether or not a jump will be made to the start destination block when the cursor moves to the block start step.

3) Auto scroll monitor setting (A, Q/QnA only)
Set whether or not the window of the start destination block will be opened for monitoring when the active step transits to the block start step during SFC diagram monitoring.

If GPPW is minimized, you cannot open the start destination block window.
If the block started while GPPW was minimized, the block that was monitored prior to minimization will be monitored after minimization is canceled.

4) Step transition watchdog monitor setting
Sets whether or not steps that do not move within the specified monitoring period will be monitored.

To execute transition monitoring, set the name of the program to be monitored, specify the block, and set the monitoring period.

If you set “Stop watchdog monitoring at detection”, transition monitoring will stop when a non-transition step is detected.
3.15 Changing between SFC and Ladder Programs

[Setting purpose]  
This operation is used when an SFC program is to be changed to a ladder program, or when an existing ladder program is to be changed into an SFC program.

[Operation procedure]  
[Project] → [Edit Data] → [Change program type]

[Setting screen]

1) Ladder  
Changes the currently displayed SFC program into a ladder program. You can edit the changed program as a ladder program.

2) SFC  
Changes the currently displayed ladder program into an SFC program. You can edit the changed program as an SFC program.

3) OK button  
Click this button at the end of setting work.

POINT  
For precautions concerning changeover, refer to 2.5 "Precautions for Use of the FXCPU".
4. MONITORING

4.1 SFC Diagram Monitor

This operation is used to monitor the operation and control status of the PLC CPU with SFC diagrams and to conduct test operations.

[Operation procedure]

- When monitoring
  [Online] → [Monitor] → [Monitor mode] or (F3)

- When stopping monitoring
  [Online] → [Monitor] → [Stop monitor] or (Alt+F3)

- When resuming monitoring
  [Online] → [Monitor] → [Start monitor] or (F3)

[Screen]

1) During SFC diagram monitoring, steps are shown as follows.
   - (blue): Active step
   - SC (yellow): Step specified as a hold step and being in a hold status
     (For the Q/QnACPU only. Shown as an inactive step for the ACPU.)
   - : Inactive step

2) Shown on the Zoom side is the operation output/transition condition ladder of the step or transition at the cursor position on the SFC diagram side.
3) When there is a block start step, the monitor destination block can be changed by moving the cursor to the block start step and pressing the space key. To monitor a block which has no block start step, show the block list and double-click the monitor destination block No. field. Alternatively, type the monitor destination block No., show the "Find step no. / block no." window, and make a block search.

<table>
<thead>
<tr>
<th>POINTS</th>
</tr>
</thead>
</table>
| • Automatic scroll monitoring  
When the active step has gone off the screen, redisplay it on the screen by automatic scrolling.  
To perform automatic scrolling, click or choose [Online] → [Monitor] → [Auto scroll monitor].  
• Automatic scroll monitoring of multiple steps active in series due to operation hold steps, for example, shows the active step closest to the initial step.  
• When using the auto scroll monitor, you can use the SFC option setting "Auto scroll monitor setting" to automatically display the start destination block. If GPPW is minimized, the start destination block window will not open.  
If the block started while GPPW was minimized, the block that was monitored prior to minimization will be monitored after minimization is canceled. (Refer to sub-section 3.14.4.)  
• During monitoring, you cannot edit SFC diagrams.  
• During editing, you cannot monitor SFC diagrams.  
• If you open the write or monitoring write screen during automatic scrolling, automatic scroll monitoring stops. When you resume monitoring, automatic scroll monitoring also resumes. |
4.2 Transition Watchdog Monitor

The following is an explanation of the transition watchdog monitor function that monitors steps from which the program does not proceed to the next step after the lapse of the specified period.

[Operation procedure]

[Tools] → [Set SFC information] → [Option] → Step transition watchdog monitor setting → Execute monitoring (refer to sub-section 4.1).

[Screen]

- When the step transition watchdog monitor is set, and the system detects a step from which a transition does not occur despite the lapse of the specified period, the above dialog box appears. However, the display on the above dialog box is sometimes delayed beyond the specified period depending upon the capacity of the SFC program and the environment under which the computer operates.

- When you click [JUMP], the step concerned in the SFC diagram appears.

- For details of the step transition watchdog monitor setting operation, refer to sub-section 3.14.4.

- If you check "Stop watchdog monitoring at detection" when setting the step transition watchdog monitor, the monitor will stop each time a non-transition step is detected, however normal monitoring will continue.
4.3 Transition Condition and Operation Output Ladder Monitor

This operation is used to monitor a ladder for the step or transition condition at the cursor position in an SFC diagram.

[Screen]

1) Ladder monitor
   During monitoring, ON/OFF of a contact or coil or the present value of a device is shown and it changes with the PLC operating status.
   The ON and OFF states of a ladder are as shown below.

   OFF: [ ] [ ] [ ] [ ] [ ]
   ON: [ ] [ ] [ ] [ ] [ ]

   *: Only the contact-equivalent compare instructions and coil-equivalent SET, RST, PLS, PLF, SFT, SFTP, MC, FF, DELTA and DELTAP are supported.
   (FF, DELTA and DELTAP are the instructions of the QnA series.)

   Note that the display is held at a stop of monitoring and is updated on resumption of monitoring.

2) Present value
   The present value of a word device appears.
   The present value can be changed between decimal and hexadecimal.
   This change can be made by performing [Online] → [Monitor] → [Change current value monitor] operation.
   If a double word monitored is 10 or more characters, it is shown in a smaller character size.
   The present value can be displayed as a double word or real number according to the data type used in the instruction.
3) Device test

- Holding down \[\text{Shift}\] and double clicking (\[\text{Enter}\]) a contact on the ladder monitor screen forces ON/OFF to change to the opposite status.
- Holding down \[\text{Shift}\] and double-clicking (\[\text{Enter}\]) a word device being monitored shows the following Present value change dialog box.

![Present value change dialog box]

After entering a new value, click the \[\text{Set}\] button.

- The present value of the double word instruction (e.g. DMOV, DFRO) is displayed as a double word.
- Confirm the value of a double word by device batch monitor or device registration monitor.
- When the cursor is on the Zoom side, right-clicking the mouse shows the device test or device registration monitor menu.
- Perform a test or registration monitor operation for the device which is not on the window being displayed.

![Device test dialog box]
4.4 All Block Batch Monitor and Active Step Monitor

This operation is used to monitor the active/inactive states of all blocks in a list form and to monitor the step active/inactive states of the specified block from the block list in a list form.

[Operation procedure]
[Online] → [Monitor] → [All block batch monitor]

[Screen]

* indication: The corresponding block is active.
— indication: The corresponding block is inactive.

To monitor the specified block for step active/inactive states, click the field of the block to be monitored, and click the [Active step monitor] button.

* indication: The corresponding step is active.
— indication: The corresponding step is inactive.
After resetting the PLC CPU, if you carry out monitoring without having put the system in a RUN condition even once, the monitoring result will be blank. If you stop the PLC CPU and perform monitoring, the status at the time the system was stopped will be displayed as the result of monitoring.

4.5 Block List Monitor

This operation is used to show and monitor a block list.

[Operation procedure]

[View] → [Display block list] → (F3)

[Screen]

<table>
<thead>
<tr>
<th>No.</th>
<th>Block title</th>
<th>a Active</th>
<th>b Transition</th>
<th>c Clear</th>
<th>d Stop</th>
<th>e Register</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Start of blocks 1, 2</td>
<td>M100</td>
<td>M101</td>
<td>M102</td>
<td>M103</td>
<td>0400</td>
</tr>
<tr>
<td>2</td>
<td>Machine process handling bl</td>
<td>M110</td>
<td>M111</td>
<td>M112</td>
<td>M113</td>
<td>0410</td>
</tr>
<tr>
<td>2</td>
<td>Finishing start block</td>
<td>M120</td>
<td>M121</td>
<td>M122</td>
<td>M123</td>
<td>0410</td>
</tr>
</tbody>
</table>

- The block No. fields of active blocks are highlighted.
- When block information has been set, the status of the corresponding block can be confirmed in the block information.
- To switch the specified block to SFC diagram monitor during monitoring, double-clicking in the field of the corresponding block switches to the SFC diagram display of the specified block.

**POINT**

Active registers cannot be monitored.
MEMO
This chapter explains debugging to step-run an SFC program. If you select the FX series, debugging is effective only when a ladder logic test tool (LLT) of SW5DSC-LLT-E or later versions is connected.

[Operation procedure]
[Online] → [Debug] → [Debug] → Change CPU to "STEP-RUN" → [Each item operation]

Choosing debug shows the following window.

Choosing [Yes] places the CPU in the "STEP-RUN" status and you can start any item operation of debugging.
To cancel debugging and return to "RUN", click [Debug] during debugging.

[Screen]
5 - 2

5. DEBUGGING (STEP RUN)

[Item explanation]

- **Block break (A, Q/QnA only)**
  This operation forces an active block into a break.

- **All block cancel**
  The specified break points registered to the CPU are canceled.

- **All block register (Q/QnACPU only)**
  When all blocks have been specified to be registered, all active blocks are batch-placed into a break.

- **Specify block**
  When blocks are specified, the specified blocks are forced into a break.
  You can specify up to 16 blocks for the ACPU or up to 64 blocks for the QnACPU.
  Click "●" in the select field to change it to "○", and enter the block number.
  If you change "●" to "○" after block number entry, that block will not be the object of break.

**POINTS**

- When a break is established for the specified block, the following window appears.

- When break points have been set for the Q/QnACPU, executing the end step automatically places the blocks into a break.
  Note that no message is given to indicate that a break is established.
- If you are using the FXCPU, you can perform the same operation as that of a block break by operating the initial state with the step break.
5. DEBUGGING (STEP RUN)

- **Step break**
  This operation specifies the block number and step number to end a single step run for test (step) operation.
  If you are using the FXCPU, block number is not specified.

  ![Step Break Window]

  - **All step cancel**
    The specified break points registered to the CPU are canceled.
  - **Specify step**
    Enter the block number and step number to be set as a break point and the number of cycles (times).
    Set the number of cycles in the range 1 to 255.
    When the preset step of the block is activated the number of times specified as the number of cycles during step run, a single step run ends and the step is put into a break.

  ![POINT Window]

  **POINT**
  When a break is established for the specified block, the following window appears.

  - If you are using a Q/QnACPU and a break point is set, a break will automatically occur when you execute an end step. Note that in this case no display appears to indicate the occurrence of the break.
  - If you are using the FXCPU, you can perform the same operation as that of a block break by operating the initial state with the step break.
5. DEBUGGING (STEP RUN)

- **Block run**
  - The block currently being displayed is forced to be active.
  - When the corresponding block is in a break status, the run resumes from the step in a break status.
  - When the corresponding block is inactive, the block is forced to start and the run starts from the initial step.

- **Step run**
  - Moving the cursor to the step to be started and choosing "step run" forces steps from the specified step on to be active.
  - Independently of whether the corresponding block is active or inactive, a forced run starts from the specified step.
  - When the specified step is in a break, the break is canceled and the forced run starts.

- **1 step run**
  - Moving the cursor to the step to be run and choosing "1 step run" tests only the specified step.
  - A single cycle ends when the specified step is run, the transition condition holds, and a transition occurs to the next step.

---

### POINTS

- For the Q/QnACPU, any step can be run independently of whether the corresponding block is active or inactive.
- For the ACPU, only the step which was placed in a break status by a step break operation may be run.

---

- **Block forced stopping (Q/QnACPU only)**
  - This operation forces the currently displayed block to be inactive.

- **Step forced stopping (Q/QnACPU only)**
  - Moving the cursor to the step to be forced to an end and choosing "Step forced stopping" forces the specified step to end (be inactive).
  - If there is no active step in the corresponding block at the forced end of the specified step, that block is ended.

- **Reset stored step (Q/QnACPU only)**
  - In this operation, the step within the currently displayed block which has been set to coil hold, operation hold (without transition check) or operation hold (with transition check) and is in a hold status is forced to be reset and inactive.
  - When the specified step is not in a hold status or is not a hold step, the operation is ignored and a forced reset is not executed.

- **Run all block (ACPU only)**
  - All blocks put in a break by a block break are activated and steps from the one in a break are forced to run.
6. PRINTING THE SFC DIAGRAMS

6.1 SFC Diagram Print Setting

[Operation procedure]
[Project] → [Print] → Choose "SFC"

[Setting screen]

[Item explanation]
1) SFC diagram print item
   The items checked in the corresponding check boxes is printed.
2) Option
   The items checked in the corresponding check boxes is added.
   Some additional information items cannot be selected according to the print items.
3) Setting
   Set the number of print columns on a single page.
   The diagram is printed with automatic magnification/reduction specified according to the set number of columns.
4) Select program
   Choose the program name to be printed.
5) Print range
   Set all area (all blocks) or the specified blocks.
This section shows examples of SFC diagrams printed. Note that according to the number of branches/couplings and the number of steps, an SFC diagram is printed on two or more pages with a position indicating numeral printed at top right of each page.

(1) SFC diagram printing examples
• Additional information (not selected)
### Additional Information (Only Device Comment Selected)

<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Machining Operation Output Block</th>
<th>Normal SFC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start</td>
<td>M110</td>
<td>Trans M11</td>
<td>Pause M13</td>
</tr>
<tr>
<td>Pause md</td>
<td>M114</td>
<td>Active D110</td>
<td>Continue M115</td>
</tr>
</tbody>
</table>

- **0** Standard goods roughing start
- **5** Dummy step
- **0** Start PB on standby
- **1** Left side drilling
- **1** Left side drilling completion
- **3** Standard goods finishing start
- **4** Part surface finishing
- **4** Finish machining completion
- **7** Special goods A machining start
- **7** Special goods A machining completion
- **8** Pre-machining completion
- **11** Special goods B machining start
- **11** Special goods B machining completion
- **12** Special goods B machining detection
- **12** B3 Painting process block start
- **14** Painting completion
- **16** Correct on inspection process
- **19** Correct on result OK
- **22** Correct on result NG

(1, 1)
### Additional information (all selected)

<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Machining operation output block</th>
<th>Normal SFC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Act/stop</td>
<td>M110</td>
<td>Trans</td>
<td>M111</td>
</tr>
<tr>
<td>Stop md</td>
<td>M114</td>
<td>Act reg</td>
<td>D110</td>
</tr>
</tbody>
</table>

\[
(1, 1)
\]
### (2) Block list printing example

<table>
<thead>
<tr>
<th>No.</th>
<th>Title/Information register</th>
<th>Block activation</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Start of blocks 1, 2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Act : M100</td>
<td>Trans : M101</td>
</tr>
<tr>
<td></td>
<td>Clear : M103</td>
<td>Stop : M102</td>
</tr>
<tr>
<td></td>
<td>Reg : D100</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Machining process handling block</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Act : M110</td>
<td>Trans : M111</td>
</tr>
<tr>
<td></td>
<td>Clear : M113</td>
<td>Stop : M112</td>
</tr>
<tr>
<td></td>
<td>Reg : D110</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Finishing start block</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Act : M120</td>
<td>Trans : M121</td>
</tr>
<tr>
<td></td>
<td>Clear : M123</td>
<td>Stop : M122</td>
</tr>
<tr>
<td></td>
<td>Reg : D120</td>
<td></td>
</tr>
</tbody>
</table>
(3) Comment list printing example

<table>
<thead>
<tr>
<th>Block No.</th>
<th>0</th>
<th>Title</th>
<th>Start of blocks 1, 2</th>
<th>Clear</th>
<th>M103</th>
</tr>
</thead>
<tbody>
<tr>
<td>Act</td>
<td>M100</td>
<td>Trans</td>
<td>M101</td>
<td>Clear</td>
<td>M103</td>
</tr>
<tr>
<td>Stop</td>
<td>M102</td>
<td>Register</td>
<td>D100</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>s0</td>
<td>Machined part insertion pusher</td>
</tr>
<tr>
<td>s1</td>
<td>machined part chucking</td>
</tr>
<tr>
<td>s2</td>
<td>Unloading carrier movement</td>
</tr>
<tr>
<td>s3</td>
<td></td>
</tr>
<tr>
<td>s4</td>
<td>Finished part unloading</td>
</tr>
<tr>
<td>s5</td>
<td>Finishing part picking</td>
</tr>
<tr>
<td>s6</td>
<td></td>
</tr>
<tr>
<td>s7</td>
<td></td>
</tr>
<tr>
<td>s8</td>
<td></td>
</tr>
</tbody>
</table>

6 - 6
6. PRINTING THE SFC DIAGRAMS

(4) Operation output/transition condition (ladder) printing example

<table>
<thead>
<tr>
<th>Block No.</th>
<th>0</th>
<th>Title</th>
<th>Start of blocks 1, 2</th>
<th>Normal SFC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Act/stop</td>
<td>M100</td>
<td>Trans</td>
<td>M101</td>
<td>Stop</td>
</tr>
<tr>
<td>Stop md</td>
<td>Act reg</td>
<td>D100</td>
<td>Continue</td>
<td></td>
</tr>
</tbody>
</table>

s0  Machined part insertion pusher

s1  machined part chucking

s2  Unloading carrier movement

---

6 - 7
6. PRINTING THE SFC DIAGRAMS

s4 Finished part unloading

s5 Finishing part picking

SM1036

Unloading carrier return output

Unchucking

Finishing part picking

Picking processing time
6. PRINTING THE SFC DIAGRAMS

(5) Operation output/transition condition (list) printing example

<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Start of blocks 1, 2</th>
<th>Normal SFC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Act/stop</td>
<td>M100</td>
<td>Trans M101</td>
<td>Stop M103</td>
</tr>
<tr>
<td>Stop md</td>
<td>Act reg D100</td>
<td></td>
<td>Continue</td>
</tr>
</tbody>
</table>

s0  Machined part insertion pusher

<table>
<thead>
<tr>
<th>Step</th>
<th>Instruction</th>
<th>Device</th>
<th>Device comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>SM1036</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>OUT</td>
<td>Y70</td>
<td>Pusher advance output</td>
</tr>
</tbody>
</table>

s1  machined part chucking

<table>
<thead>
<tr>
<th>Step</th>
<th>Instruction</th>
<th>Device</th>
<th>Device comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>SM1036</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>OUT</td>
<td>Y71</td>
<td>Pusher return output</td>
</tr>
<tr>
<td>2</td>
<td>OUT</td>
<td>Y72</td>
<td>Chuck advance output</td>
</tr>
</tbody>
</table>

s2  Unloading carrier movement

<table>
<thead>
<tr>
<th>Step</th>
<th>Instruction</th>
<th>Device</th>
<th>Device comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>SM1036</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>OUT</td>
<td>Y78</td>
<td>Unloading carrier advance output</td>
</tr>
</tbody>
</table>

s4  Finished part unloading

<table>
<thead>
<tr>
<th>Step</th>
<th>Instruction</th>
<th>Device</th>
<th>Device comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>SM1036</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>OUT</td>
<td>Y78</td>
<td>Unloading carrier return output</td>
</tr>
</tbody>
</table>

s5  Finishing part picking

<table>
<thead>
<tr>
<th>Step</th>
<th>Instruction</th>
<th>Device</th>
<th>Device comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>SM1036</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>OUT</td>
<td>Y79</td>
<td>Unchucking</td>
</tr>
<tr>
<td>2</td>
<td>OUT</td>
<td>Y7A</td>
<td>Finishing part picking</td>
</tr>
<tr>
<td>3</td>
<td>OUT</td>
<td>T0</td>
<td>Picking processing time</td>
</tr>
</tbody>
</table>
### (6) Block parameter printing example

<table>
<thead>
<tr>
<th>Block parameter</th>
<th>[MAIN-SFC]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Periodic exec Blk</td>
<td>After[ ]</td>
</tr>
<tr>
<td>Execution interval</td>
<td>[ ]ms</td>
</tr>
<tr>
<td>Action at BL multi-act</td>
<td>Stop [ ]-[ ]</td>
</tr>
<tr>
<td>Action at step Multi-activated</td>
<td>Waiting [ ]-[ ]</td>
</tr>
<tr>
<td></td>
<td>Stop [ ]-[ ]</td>
</tr>
</tbody>
</table>
This section shows examples of SFC diagrams printed. Note that according to the number of branches/couplings and the number of steps, an SFC diagram is printed on two or more pages with a position indicating numeral printed at top right of each page.

(1) SFC diagram printing examples
- Additional information (not selected)
6. PRINTING THE SFC DIAGRAMS

- Additional information (all selected)

<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Auto operation start step</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Initial setp</td>
<td>(1, 1)</td>
</tr>
</tbody>
</table>

0

- \[ \text{SET \ Y000} \]
  - Auto operation 1
  - n progress

0

- \[ \text{M1} \]
- Condition n 0

0

- Standard
  - assy/ma
  - chining
- Y010

0

- \[ \text{N100} \]
- Output A

- \[ \text{M1} \]
- Condition n 1

- \[ \text{M1} \]
- Standard
  - assy/ma
  - chining
- X011

0

- \[ \text{N111} \]
- Output L

0

- \[ \text{N110} \]
- Output K

0

- \[ \text{M114} \]
- St. assy
  - /machine
  - ng 5 (au
  - n)
6. PRINTING THE SFC DIAGRAMS

(2, 1)
### (2) Block list printing example

<table>
<thead>
<tr>
<th>NO.</th>
<th>Title</th>
<th>Block type</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Initial drive circuit</td>
<td>Ladder block</td>
</tr>
<tr>
<td>1</td>
<td>machining operation output block</td>
<td>SFC block</td>
</tr>
<tr>
<td>2</td>
<td>inspection process</td>
<td>SFC block</td>
</tr>
<tr>
<td>3</td>
<td>Material supply</td>
<td>SFC block</td>
</tr>
<tr>
<td>4</td>
<td>Conveying control</td>
<td>SFC block</td>
</tr>
</tbody>
</table>
## (3) Comment list printing example

<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Auto operation start step</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step</th>
<th>Comment</th>
<th>Dev Lbl</th>
</tr>
</thead>
<tbody>
<tr>
<td>s1</td>
<td>Initial setp</td>
<td></td>
</tr>
<tr>
<td>s10</td>
<td>Standard assy/machining 1</td>
<td></td>
</tr>
<tr>
<td>s11</td>
<td>Standard assy/machining 2</td>
<td></td>
</tr>
<tr>
<td>s12</td>
<td>Standard assy/machining 3</td>
<td></td>
</tr>
<tr>
<td>s13</td>
<td>Standard assy/machining 4</td>
<td></td>
</tr>
<tr>
<td>s14</td>
<td>St. assy/machining 5 (aux)</td>
<td></td>
</tr>
<tr>
<td>s15</td>
<td>Condition1 assy/machining</td>
<td></td>
</tr>
<tr>
<td>s16</td>
<td>Condition2 assy/machining 1</td>
<td></td>
</tr>
<tr>
<td>s17</td>
<td>Condition2 assy/machining 2</td>
<td></td>
</tr>
<tr>
<td>s18</td>
<td>Condition2 assy/machining 3</td>
<td></td>
</tr>
<tr>
<td>s19</td>
<td>Condition2 assy/machining 4</td>
<td></td>
</tr>
<tr>
<td>s20</td>
<td>Condition3 assy/machining 1</td>
<td></td>
</tr>
<tr>
<td>s21</td>
<td>Condition3 assy/machining 2</td>
<td></td>
</tr>
<tr>
<td>s22</td>
<td>Condition3 assy/machining 3</td>
<td></td>
</tr>
<tr>
<td>s23</td>
<td>Condition3 assy/machining 4</td>
<td></td>
</tr>
<tr>
<td>s24</td>
<td>Condition4 assy/machining 1</td>
<td></td>
</tr>
<tr>
<td>s25</td>
<td>Condition4 assy/machining 2</td>
<td></td>
</tr>
<tr>
<td>s26</td>
<td>Condition4 assy/machining 3</td>
<td></td>
</tr>
<tr>
<td>s27</td>
<td>Condition4 assy/machining 4</td>
<td></td>
</tr>
<tr>
<td>s28</td>
<td>Cond.4 Assy/machining(sort)</td>
<td></td>
</tr>
<tr>
<td>s29</td>
<td>Cond.4 Assy/machining(sort)</td>
<td></td>
</tr>
</tbody>
</table>
(4) Ladder block/Operation output/transition condition (ladder) printing example

<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Initial selection circuit</th>
</tr>
</thead>
<tbody>
<tr>
<td>LD</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Block No. 0

Y001

Condition

X001

Y001

Condition
6. PRINTING THE SFC DIAGRAMS

<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Auto operation start step</th>
</tr>
</thead>
<tbody>
<tr>
<td>s1</td>
<td>Initial setup</td>
<td></td>
</tr>
<tr>
<td>s10</td>
<td>Standardassy/machining 1</td>
<td></td>
</tr>
<tr>
<td>s11</td>
<td>Standardassy/machining 2</td>
<td></td>
</tr>
<tr>
<td>s12</td>
<td>Standardassy/machining 3</td>
<td></td>
</tr>
</tbody>
</table>
6. PRINTING THE SFC DIAGRAMS

```
<table>
<thead>
<tr>
<th>t0</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>M0</td>
</tr>
<tr>
<td>Cond</td>
</tr>
<tr>
<td>n 0</td>
</tr>
<tr>
<td>[TRAN]</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>t1</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>M1</td>
</tr>
<tr>
<td>Cond</td>
</tr>
<tr>
<td>n 1</td>
</tr>
<tr>
<td>[TRAN]</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>t2</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>X001</td>
</tr>
<tr>
<td>Cond</td>
</tr>
<tr>
<td>n 0</td>
</tr>
<tr>
<td>[TRAN]</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>t3</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>X001</td>
</tr>
<tr>
<td>Cond</td>
</tr>
<tr>
<td>n 0</td>
</tr>
<tr>
<td>[TRAN]</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>t4</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
</tr>
<tr>
<td>1</td>
</tr>
</tbody>
</table>
```
### (5) Ladder block/Operation output/transition condition (list) printing example

<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Initial selection circuit</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**LD**

<table>
<thead>
<tr>
<th>Step</th>
<th>Instruction</th>
<th>Device</th>
<th>Device comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>X001</td>
<td>Condition 0</td>
</tr>
<tr>
<td>1</td>
<td>OUT</td>
<td>Y001</td>
<td></td>
</tr>
</tbody>
</table>
### 6. PRINTING THE SFC DIAGRAMS

<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Auto operation start step</th>
</tr>
</thead>
<tbody>
<tr>
<td>s1</td>
<td>Initial setup</td>
<td></td>
</tr>
</tbody>
</table>

**Step** | **Instruction** | **Device** | **Device comment** |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>SET</td>
<td>Y000</td>
<td>Auto operation in progress</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>s10</th>
<th>Standard assy/machining 1</th>
<th></th>
</tr>
</thead>
</table>

**Step** | **Instruction** | **Device** | **Device comment** |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>X010</td>
<td></td>
</tr>
<tr>
<td></td>
<td>OUT</td>
<td>M100</td>
<td>Output A</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>s11</th>
<th>Standard assy/machining 2</th>
<th></th>
</tr>
</thead>
</table>

**Step** | **Instruction** | **Device** | **Device comment** |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>X011</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>OUT</td>
<td>M111</td>
<td>Output L</td>
</tr>
<tr>
<td>2</td>
<td>OUT</td>
<td>M110</td>
<td>Output K</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>s12</th>
<th>Standard assy/machining 3</th>
<th></th>
</tr>
</thead>
</table>

**Step** | **Instruction** | **Device** | **Device comment** |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>X001</td>
<td>Condition 0</td>
</tr>
<tr>
<td>1</td>
<td>OUT</td>
<td>Y001</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>s13</th>
<th>Standard assy/machining 4</th>
<th></th>
</tr>
</thead>
</table>

**Step** | **Instruction** | **Device** | **Device comment** |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>LD</td>
<td>X012</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>OUT</td>
<td>M115</td>
<td>Output J</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>s14</th>
<th>St. assy/machining 5 (aux)</th>
<th></th>
</tr>
</thead>
</table>

**Step** | **Instruction** | **Device** | **Device comment** |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>OUT</td>
<td>M114</td>
<td>Output O</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>s15</th>
<th>Condition1 assy/machining</th>
<th></th>
</tr>
</thead>
</table>

**Step** | **Instruction** | **Device** | **Device comment** |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>OUT</td>
<td>M115</td>
<td>Output J</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>s16</th>
<th>Condition2 assy/machining 1</th>
<th></th>
</tr>
</thead>
</table>

**Step** | **Instruction** | **Device** | **Device comment** |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>OUT</td>
<td>M116</td>
<td>Output Q</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>s17</th>
<th>Condition2 assy/machining 2</th>
<th></th>
</tr>
</thead>
</table>
## 6. PRINTING THE SFC DIAGRAMS

<table>
<thead>
<tr>
<th>Step</th>
<th>Instruction</th>
<th>Device</th>
<th>Device comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>t0</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>t1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>t2</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>t3</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>t4</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>t5</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>t6</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>t7</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>t8</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>t9</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- **t0**
- **t1**
- **t2**
- **t3**
- **t4**
- **t5**
- **t6**
- **t7**
- **t8**
- **t9**
INDEX

[A]
  Active step monitor ........................................... 4- 6
  All block batch monitor ........................................ 4- 6

[B]
  Block information setting .................................. 3-49
  Block list .......................................................... 3-26
  Block list display ................................................ 3-51
  Block list monitor ................................................ 4- 7
  Block number search (SFC diagram side) .............. 3-61
  Block number search (Zoom side) ......................... 3-62
  Block parameters ................................................ 3-54

[C]
  Character string replacement ................................ 3-63
  Character string search ......................................... 3-60
  Contact/coil search .............................................. 3-65
  Contact/coil use list ............................................. 3-65
  Conversion operation .......................................... 3-58

[D]
  Debugging (step run) ............................................ 5- 1
  Device comment display ....................................... 3-70
  Device label display ............................................ 3-70
  Device replacement ............................................. 3-63
  Device search .................................................... 3-60
  Device test ........................................................ 4- 5
  Device use list ................................................... 3-66
  Device use search ............................................... 3-66

[E]
  Edit data, adding new ......................................... 3- 3
  Enter key, operation starting from ....................... 3-37

[F]
  Function key, operation starting from .................. 3-36

[H]
  Horizontal partition contact count setting .......... 3-75

[I]
  Instruction replacement ....................................... 3-63
  Instruction search ................................................ 3-60

[L]
  Label display (operation output) ......................... 3-70
  Label display (SFC diagram) ................................ 3-69
  Ladder mode/list mode switching ......................... 3-71

[M]
  Microcomputer capacity ..................................... 3- 3
  Multiple windows, opening .................................. 3-72

[N]
  Note display ..................................................... 3-70
  Note editing ..................................................... 3-48
  Note type changing ............................................. 3-65

[O]
  Open/Close contact changing .............................. 3-63
  Operation output, note display for ..................... 3-71
  Operation output/transition condition creation .... 3-45
  Operation output/transition condition
    ladder monitor .................................................. 4- 4
  Operation output/transition condition switching to
    ladder mode/list mode ........................................ 3-71

[P]
  PLC parameters, SFC setting ................................ 3-53
  Printing examples ................................................
    (when A or Q/QnACPU is used) ......................... 6- 2
  Printing examples ................................................
    (when the FXCPU is used) ................................. 6-11

[S]
  SFC comment creation ........................................ 3-46
  SFC comment display .......................................... 3-67
  SFC diagram copying .......................................... 3-40
  SFC diagram creating method .............................. 3-13
  SFC diagram deleting method ............................... 3-38
  SFC diagram equipment name display .................... 3-69
  SFC diagram monitor ........................................... 4- 1
  SFC diagram print setting .................................. 6- 1
  SFC diagram redisplay ........................................ 3-44
  SFC diagram sorting .......................................... 3-43
  SFC diagram symbols (A series) ......................... 3- 7
  SFC diagram symbols (QnA series) ......................... 3- 8
  SFC display column setting ................................... 3-73
SFC parameter setting................................. 3-53
SFC program setting................................. 3-55
SFC program writing, online ....................... 3-58
SFC setting, option setting......................... 3-76
Step attribute changing.............................. 3-67
Step number replacement............................ 3-64
Step number search (SFC diagram side)......... 3-61
Step number search (Zoom side).................... 3-62
Step run.................................................. 5-1
Step/transition comment display.................. 3-67

[T]
T/C set value changing............................... 3-66
Timer/counter set value changing................ 3-66
Toolbar menu, operation starting from ........ 3-36
Tool button, operation starting from
  (when A or Q/QnACPU is used)........ 3-14
Tool button, operation starting from
  (when the FXCPU is used).............. 3-24
Transition watchdog monitor...................... 4-3
Transition watchdog timer......................... 3-76

[Z]
Zoom partition setting............................... 3-74
<table>
<thead>
<tr>
<th>MODEL</th>
<th>SW5D5C-GPPW-E-SFC</th>
</tr>
</thead>
<tbody>
<tr>
<td>CODE</td>
<td>13J976</td>
</tr>
<tr>
<td>CD</td>
<td>SH(NA)-080063-A(0002)MEE</td>
</tr>
</tbody>
</table>

When exported from Japan, this manual does not require application to the Ministry of International Trade and Industry for service transaction permission.

Specifications subject to change without notice.