# How to read this guide

The following shows the symbols used in this Quick start guide with descriptions and examples.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="Checkmark.png" alt="Point" /></td>
<td>This symbol explains information you need to know.</td>
<td>Select [View] → [Comment] (Ctrl key + F5 key). The comment display/hide setting can be switched.</td>
</tr>
<tr>
<td><img src="TextBox.png" alt="Reference" /></td>
<td>This symbol describes the references of manuals and pages for more details.</td>
<td>For details, refer to the following manual. <a href="#">QnUCPU User’s Manual (Function Explanation, Program Fundamentals): SH-080807ENG</a></td>
</tr>
<tr>
<td><img src="Exclamation.png" alt="Caution" /></td>
<td>This symbol describes content that must be noted in operation.</td>
<td>When mounting the module, the power must be turned OFF.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Menu names on the menu bar ([ ] → [ ] shows drop-down menus.)</td>
<td>Select [Project] → [New project].</td>
</tr>
<tr>
<td><img src="Button.png" alt="Button" /></td>
<td>Buttons on the screen</td>
<td><img src="OK.png" alt="OK button" /></td>
</tr>
<tr>
<td><img src="Key.png" alt="Key" /></td>
<td>Keys on the keyboard</td>
<td><img src="F4.png" alt="F4 key" /></td>
</tr>
<tr>
<td>( )</td>
<td>Another procedure corresponding to a drop-down menu (icons and keys on the keyboard)</td>
<td>Select [Online] → [Monitor] → [Monitor mode] (F3 key) ( ).</td>
</tr>
<tr>
<td>&lt; &gt;</td>
<td>Tab names on the screen</td>
<td>&lt;Program common&gt; tab</td>
</tr>
</tbody>
</table>
## Generic terms

The following explains the terms used in this Quick start guide.

<table>
<thead>
<tr>
<th>Generic term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Programmable controller system</td>
<td>Combination of the power supply module, the CPU module, the I/O modules, and the base unit.</td>
</tr>
<tr>
<td>Sequence control</td>
<td>Consecutively processes each control step based on the fixed order or procedure.</td>
</tr>
<tr>
<td>QnACPU</td>
<td>General term for the programmable controller CPU available in MELSEC-QnA.</td>
</tr>
<tr>
<td>GX Developer</td>
<td>Application software to create sequence programs and communicate with the programmable controllers.</td>
</tr>
<tr>
<td>CPU module</td>
<td>The core module to unify the controls of the programmable controllers. Q02UCPU is used in this Quick start guide.</td>
</tr>
<tr>
<td>Power supply module</td>
<td>Supplies electricity to each module, including the CPU module and the I/O modules.</td>
</tr>
<tr>
<td>Base unit</td>
<td>The unit that mounts the power supply module, the CPU module, and the I/O modules.</td>
</tr>
<tr>
<td>Building block</td>
<td>A method to organize one system by combining necessary elements. Elements such as the power supply module, the CPU module, the I/O modules, and the base unit are combined in the programmable controller system.</td>
</tr>
<tr>
<td>Limit switch</td>
<td>A switch to suspend mobile objects on both sides of a moving apparatus for safety reasons.</td>
</tr>
<tr>
<td>Relay</td>
<td>Breaks/connects the electricity with electrical switching.</td>
</tr>
<tr>
<td>Contactor</td>
<td>Generally called an electromagnetic contactor to break circuits and switch the heater.</td>
</tr>
<tr>
<td>Solenoid valve</td>
<td>An electromagnet with a direct/alternating current solenoid valve. Connected to the output side of the programmable controller.</td>
</tr>
<tr>
<td>Ground</td>
<td>Prevents electric shocks and malfunctions.</td>
</tr>
<tr>
<td>Control panel</td>
<td>Transfers signals to other equipment. Combines such elements as breakers, switches, protection equipment, relays, and programmable controllers. Receives signals from switches and sensors, and supply electricity to operate motors and solenoid valves of the machines and equipment.</td>
</tr>
<tr>
<td>Isolation transformer</td>
<td>A two-winding transformer. The primary and secondary coil are wound separately to protect the secondary load.</td>
</tr>
<tr>
<td>Contact</td>
<td>An input used when creating a sequence program.</td>
</tr>
<tr>
<td>Coil</td>
<td>An output used when creating a sequence program.</td>
</tr>
<tr>
<td>Device</td>
<td>A location to store data such as ON/OFF, numeric values, and character strings in the programmable controller.</td>
</tr>
<tr>
<td>Internal relay</td>
<td>Breaks/connects the sequence circuit by switching ON/OFF.</td>
</tr>
<tr>
<td>Sequence program</td>
<td>A program to perform sequence control.</td>
</tr>
<tr>
<td>Project</td>
<td>Indicates a GX Developer project in this Quick start guide. Consists of programs, device comments, and parameters.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Setup information necessary to operate the programmable controller system. Modules and the network are set by writing parameters to the CPU module.</td>
</tr>
<tr>
<td>PLC parameter</td>
<td>Setup information for modules, devices, and programs used in the programmable controller system.</td>
</tr>
<tr>
<td>Step number</td>
<td>Numbers attached in order from the start of instruction in the sequence program.</td>
</tr>
<tr>
<td>Logical operations</td>
<td>One of the basic operation methods in programming. Logical operations consist of three basic operations: logical AND, logical OR, and logical NOT.</td>
</tr>
<tr>
<td>Debug</td>
<td>An operation in which programmers search for and correct bugs in the sequence program.</td>
</tr>
</tbody>
</table>
Introduction

This Quick start guide explains the basic procedures for the first-time use of the Mitsubishi programmable controller MELSEC-Q series CPU module (CPU module). You can easily understand how to use the programmable controller with this manual.

Reference

- Precautions
  Read "SAFETY PRECAUTIONS" in the QCPU User's Manual carefully and use the programmable controllers safely.

- Types of CPU modules
  This Quick start guide explains the usage examples for Universal model QCPU. For the usage of other CPU modules, refer to the following manuals and be aware of the differences.

  QCPU User’s Manual (Hardware Design, Maintenance and Inspection): SH-080483ENG

  Qn(H)/QnPH/QnPRHCPU User’s Manual (Function Explanation, Program Fundamentals): SH-080808ENG

  QnUCPU User’s Manual (Function Explanation, Program Fundamentals): SH-080807ENG

  QCPU Programming Manual (Common Instructions): SH-080809

  QnACPU Programming Manual (Common Instructions): SH-080810

Caution

This Quick start guide explains operations in the programmable controller system described in "② System Configuration" (P.9). Read the manuals referred in the following page when you design or manage the system.

Introduction of related manuals (P.6)
Programmable controllers

The programmable controllers perform sequence control and logical operations by switching the output of output equipment ON/OFF according to the command signal from the input equipment.

<Input equipment> <Programmable controller> <Output equipment>

Push-button switch

Power

Operation

Memory

Data

Program

Input interface

Output interface

Power

Creating and debugging programs

Input module

CPU module

Output module

Personal computer

Other equipment is shown below.

<Examples of input equipment>

Limit switch

Input relay

Switch

<Examples of output equipment>

Contactor

Solenoid valve
Programmable controller usage example

This example shows the programmable controller system in a beverage plant.

The following explains the procedure for putting bottles in a case.

1. When the switch is turned ON, the "IN OPERATION" lamp is lit, and the conveyor is set in operation.
2. When the conveyor brings a bottle case to a particular position, the sensor senses it.
3. When the bottle case is sensed, the stopper operates to stop it.
4. The lifter goes up, the arm moves forward, and the lifter goes down to put bottles in the case.
5. One is added to the value in the product counter.
6. When the CPU module concludes that the above procedure is completed, the stopper goes down to let the cases flow.

Repeat procedures 2 to 6.
Introduction of related manuals

This Quick start guide explains the basic procedures for introducing programmable controllers. Read the following manuals to use each module with a full understanding according to your purpose.

■ Learning about programmable controllers

- QCPU User's Manual (Hardware Design, Maintenance and Inspection) . . . . .SH-080483ENG
  This manual explains specifications, settings, and maintenance methods for the CPU module, the power supply module, and the base unit.

- Qn(H)/QnPH/QnPRHCPU User's Manual (Function Explanation, Program Fundamentals) . . . .SH-080808ENG

- QnUCPU User's Manual (Function Explanation, Program Fundamentals) . . .SH-080807ENG
  This manual explains the functions of the CPU modules, and about devices and parameters that are the basic knowledge necessary for programming.

- I/O Module Type Building Block User's Manual . . . . . . .SH-080042
  This manual explains specifications and functions for the input module and the output module.

■ Learning about programming

- QCPU Programming Manual (Common Instructions) . . . . . . .SH-080809

- QnACPU Programming Manual (Common Instructions) . . . . . .SH-080810
  This manual explains the instructions used in programming.

■ Learning about programming tools (software)

- GX Developer Version 8 Operating Manual (Startup) . . . . . .SH-080372E
  This manual explains the installation method for GX Developer Version 8.

- GX Developer Version 8 Operating Manual . . . . . . .SH-080373E
  This manual explains operation methods including program creation, parameter setting, writing/reading programs, and debugging.
Using programmable controllers

The programmable controllers are installed with procedures as shown below.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td><strong>Preparing for Operation (P.8)</strong></td>
</tr>
<tr>
<td></td>
<td>Preparing the necessary equipment.</td>
</tr>
<tr>
<td>2.</td>
<td><strong>System Configuration (P.9)</strong></td>
</tr>
<tr>
<td></td>
<td>Introducing equipment used for operations in this Quick start guide.</td>
</tr>
<tr>
<td>3.</td>
<td><strong>Mounting Modules (P.10)</strong></td>
</tr>
<tr>
<td></td>
<td>Mounting the CPU module and other modules on the base unit.</td>
</tr>
<tr>
<td>4.</td>
<td><strong>Wiring Modules (P.11)</strong></td>
</tr>
<tr>
<td></td>
<td>Wiring the power supply module, the CPU module, and the I/O modules.</td>
</tr>
<tr>
<td>5.</td>
<td><strong>Checking Power Supply (P.13)</strong></td>
</tr>
<tr>
<td></td>
<td>Turning ON the system to check the condition of the CPU module.</td>
</tr>
<tr>
<td>6.</td>
<td><strong>Programming (P.14)</strong></td>
</tr>
<tr>
<td></td>
<td>Creating a program with GX Developer.</td>
</tr>
<tr>
<td>7.</td>
<td><strong>Writing Programs (P.21)</strong></td>
</tr>
<tr>
<td></td>
<td>Writing a program created with GX Developer to the CPU module.</td>
</tr>
<tr>
<td>8.</td>
<td><strong>Checking Operation (P.25)</strong></td>
</tr>
<tr>
<td></td>
<td>Executing the program by running the CPU module. Checking that ON/OFF inputs correspond to ON/OFF outputs.</td>
</tr>
</tbody>
</table>
Preparing for Operation

Preparing the necessary equipment

1. Programmable controller
2. Personal computer
3. GX Developer Version 8
4. USB cable
5. Lamp
6. Switch

Explanations for each module are on the next page

Windows-based PC

USB mini B type

Install *

* GX Developer Version 8 needs to be installed in your personal computer in advance.

Reference

- GX Developer, the design and maintenance tool for Mitsubishi programmable controller, is necessary to set up programmable controllers and create sequence programs.
- For the installation and operation of GX Developer, refer to the following manuals.
  - GX Developer Version 8 Operating Manual (Startup): SH-080372E
  - GX Developer Version 8 Operating Manual: SH-080373E
- Compatible GX Developer version
  - The CPU module used and its functions differ in each version of GX Developer. For the compatible GX Developer version, refer to the following manual.
# System Configuration

## System configuration example

This Quick start guide explains the following system configuration as an example. Inputs and outputs are configured as switches and lamps respectively.

* Wires to the power supply module and the power of the I/O modules are omitted.

<table>
<thead>
<tr>
<th>No.</th>
<th>Name</th>
<th>Model</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Base unit</td>
<td>Q33B</td>
</tr>
<tr>
<td>2</td>
<td>Power supply module</td>
<td>Q62P</td>
</tr>
<tr>
<td>3</td>
<td>CPU module</td>
<td>Q02UCPU</td>
</tr>
<tr>
<td>4</td>
<td>Input module</td>
<td>QX40</td>
</tr>
<tr>
<td>5</td>
<td>Output module</td>
<td>QY40P</td>
</tr>
<tr>
<td>6</td>
<td>Connection cable (USB cable)</td>
<td>MR-J3USBCBL3M</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(USB A type - USB mini B type)</td>
</tr>
</tbody>
</table>
Mounting Modules

Mount prepared modules on the base unit.

A battery connector must be installed when using the CPU module for the first time.

**Caution**

The power supply must be disconnected when mounting modules.

### Mounting modules

1. Insert a module fixing projection into a module fixing hole on the base unit.

2. Push the module in the direction of arrow until it clicks.

---

**Point**

- Installing a battery in the CPU module

1. Open the cover at the bottom of the CPU module.

2. Insert the connector of battery into the connector of CPU module.

3. Close the cover at the bottom of the CPU module.

---
Wiring Modules

Wire the power supply module, the input module, and the output module.

**Caution**

The power supply must be disconnected when wiring modules.

**Reference**

For details of wiring precautions, refer to the following manual.

QCPU User's Manual (Hardware Design, Maintenance and Inspection): SH-080483ENG

### Wiring the power supply module

The following shows an example of wiring the power line and the ground wire to the base unit.

1. Connect the 100VAC power supply to the power input terminals.
2. Connect the LG and FG terminals.

![Power supply module diagram](image)

### Wiring the input module

The following shows an example of wiring the input module (QX40).

Switch 1
Signal: X0

Switch 2
Signal: X1

Switch 3
Signal: X2

![Input module diagram](image)
Wiring the output module

The following shows an example of wiring the output module (QY40P).

Point

Wire the power supply lines separately for the I/O equipment and the programmable controller as shown below.
Checking Power Supply

Check that the power supply runs normally after configuring the system, mounting modules, and wiring.

Operating procedure

1. Check before turning ON the power supply.
   - Wiring of the power supply
   - Power supply voltage

2. Set the CPU module to STOP.
   Set the switch on the front of the CPU module to STOP.

3. Supply power.

4. Check that the power supply runs normally.
   Check the front LEDs on each module.
   The following shows the normal state of the LEDs.
   ① Power supply module: "POWER" LED lights in green.
   ② CPU module: "MODE" LED lights in green.

Construction of the system is complete.
Turn OFF the power supply.

Point

● Troubleshooting
   ① When the "POWER" LED, "MODE" LED are OFF or flashing, refer to the following page.
   Troubleshooting (P.28)
   ② When a parameter or program is not written to the CPU module, the "ERR." LED flashes red, but it is not a problem at this stage.
6 Programming

Create a program (sequence program) for sequence control.

**"Devices" and "instruction symbols" in programming**

Combine "devices" and "instruction symbols" to create a sequence program.

1. Devices

Devices include bit devices and word devices.

1. Bit device: handles one-bit information such as ON/OFF of a switch or a lamp.

![ON/OFF of a switch and ON/OFF of a lamp]

**Examples of bit device**

<table>
<thead>
<tr>
<th>Device name</th>
<th>Device symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input</td>
<td>X</td>
<td>Receives a signal from an external device as a switch.</td>
</tr>
<tr>
<td>Output</td>
<td>Y</td>
<td>Outputs a signal to an external device such as a lamp</td>
</tr>
<tr>
<td>Internal relay</td>
<td>M</td>
<td>Temporarily saves data status in programs.</td>
</tr>
<tr>
<td>Timer (contact)</td>
<td>T</td>
<td>Used to measure time (when the set time comes, the contact is set to ON).</td>
</tr>
<tr>
<td>Counter (contact)</td>
<td>C</td>
<td>Used to count the number of times the input condition turns from OFF to ON (when the counter reaches the set number, the contact is set to ON).</td>
</tr>
</tbody>
</table>

2. Word device: handles 16-bit information such as numeric values and character strings.

![Numeric value and Character string]

**Examples of word device**

<table>
<thead>
<tr>
<th>Device name</th>
<th>Device symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data register</td>
<td>D</td>
<td>Registers numeric values and character strings.</td>
</tr>
<tr>
<td>Timer (current value)</td>
<td>T</td>
<td>Used to measure time (stores the current value of measuring time).</td>
</tr>
<tr>
<td>Counter (current value)</td>
<td>C</td>
<td>Used to count the number of times the input condition turns from OFF to ON (stores the current value of the counter).</td>
</tr>
</tbody>
</table>
2. Instruction symbols

The following shows the basic instructions of sequence control.

<table>
<thead>
<tr>
<th>Instruction symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Open contact: Conducts when an input signal is set to ON.</td>
</tr>
<tr>
<td>2</td>
<td>Closed contact: Conducts when an input signal is set to OFF.</td>
</tr>
<tr>
<td>3</td>
<td>Coil output: Outputs data to a specified device.</td>
</tr>
</tbody>
</table>

Creating a program

Create a sequence program.

The following shows how to create a sequence program with basic devices and instruction symbols for sequence control.

The following devices and instruction symbols are used.

- Input: X device
- Output: Y device
- Instruction symbols: 1, 2, 3

Create a program that performs the following controls.

- When the X0 and X1 switches are turned ON, the Y10 output lamp turns ON.
- When the X2 switch is turned ON, the Y1E and Y1F output lamps turn OFF.

The following explains the procedure to create this sequence program.
Starting GX Developer

Operating procedure

Select [Start] → [All Programs] → [MELSOFT Application] → [GX Developer].

After starting, the GX Developer main screen is displayed.

Creating a new project

Operating procedure

1. Select [Project] → [New project] (Ctrl key + N key) ( ).
2. Select QCPU (Q mode).
3. Select the QCPU to be used (Q02UCPU in this manual).
4. Click the OK button.

A project tree is displayed.
A ladder screen is displayed.
Entering a sequence program

Operating procedure

1. Enter X0.
   ① Click \( \text{F5} \) (F5 key).
   ② Enter device X0.
   ③ Click the OK button.

2. Enter X1.
   ① Click \( \text{F6} \) (F6 key).
   ② Enter device X1.
   ③ Click the OK button.

3. Enter Y10.
   ① Click \( \text{F7} \) (F7 key).
   ② Enter device Y10.
   ③ Click the OK button.

Coil Y10 is displayed.
4. Enter $X^2$.

- Click $F1$ (PS key).
- Enter device $X2$.
- Click the OK button.

5. Enter $Y_{1E}$.

- Click $F7$ (PS key).
- Enter device $Y1E$.
- Click the OK button.

Coil $Y1E$ is displayed.

6. Draw a line.

- Click $F10$ (PS key).
- Drag and drop in the direction of the arrow.
7. Enter \(Y1F\).

**Converting a program**

Define the contents of the entered ladder block.

**Operating procedure**

Perform the conversion to align entered ladders. When completed, the gray display turns to white.

[Before conversion]

[After conversion]

The programming is completed.
Saving a project

A program is saved in unit of project.
Save the created project with a name.

Operating procedure

1. Select [Project] → [Save as] ( ).

The "Save the project with a new name" screen is displayed.

2. Specify the save location.
3. Enter the name and title of the project.
4. Click the Save button.

The specified project does not exist.

Do you wish to create a new project?

Yes  No

5. Click the Yes button.

The project is saved.
7 Writing Programs

Write the program to the CPU module.

- Connecting the CPU module and the personal computer

Connect the CPU module and the USB port of the personal computer with a USB cable.

- Turning ON the programmable controllers

Turn ON the power supply module, the input module, and the output module.

- Setting GX Developer and the programmable controller connection

Operating procedure

1. Select [Online] → [Transfer setup].

The "Transfer Setup" screen is displayed.

2. Double-click "Serial USB".

To the next page
The "PC side I/F Serial setting" screen is displayed.

3. Select "USB".

4. Click the OK button.

When properly connected, the connection completion message is displayed.

5. Click "PLC module".

6. Click "No specification".

7. Click the Connection test button.

8. Click the OK button.

* When the screen on the right is displayed, check the system and the settings.

Troubleshooting (P.28)

The connection setting is completed.
Formatting the CPU module

Before writing the program, format the CPU module to set it to the initial status.

Operating procedure

1. Select [Online] → [Format PLC memory].

The "Format PLC memory" screen is displayed.

2. Select "Program memory/Device memory" from "Target memory".

3. Click the **Execute** button.

4. Click the **Yes** button.

5. Click the **OK** button.

The CPU module format is completed.

Click the **Close** button to close the "Format PLC memory" screen.

Point

When data such as programs and parameters are already stored in the CPU module, they are deleted. Thus the necessary data should be read from the programmable controller CPU and saved as a project before executing the Format PLC memory function.
Writing programs to the CPU module

Operating procedure

1. Select [Online] → [Write to PLC] ( ).

The "Write to PLC" screen is displayed.

2. Click "Param+Prog".
3. "Program" and "Parameter" are checked.

4. Click the button.

When the Write to PLC function is properly executed, the following message is displayed.

5. Click the button.

The program writing is completed.

Click to close the "Write to PLC" screen.

Point

- PLC parameter
  The PLC parameter is necessary to start the CPU module. The default values are used in this system configuration.
  For details of setting parameters, refer to the following manuals.
  Qn(H)/QnPH/QnPRH CPU User's Manual (Function Explanation, Program Fundamentals): SH-080808ENG
Checking Operation

Execute the program written to the CPU module to check the operation.
Check the program operation with the switches and lamps or the monitor function of GX Developer.

Executing the program written to the programmable controller CPU

Use the "RESET/STOP/RUN" switch on the front of the CPU module for the operation.
The usage of the RESET/STOP/RUN switch
- RUN : Executes the sequence program operation.
- STOP : Stops the sequence program operation.
- RESET: Performs the hardware reset, operation error reset, and operation initialization.

Operating procedure

1. Resetting the CPU module

1. Check the LED status before resetting the CPU module.
   - MODE: Green: ON
   - RUN : OFF
   - ERR.: Red: Flashing slow

2. Tilt the "RESET/STOP/RUN" switch toward "RESET" on the front of the CPU module.
   (for over a second)

3. After the flash, "ERR." LED turns OFF, then release the switch.

4. The switch returns to "STOP", and the resetting is completed.

Reference

When the flashing "ERR." LED does not turn OFF, refer to the following page.
Troubleshooting (P.28)
2. Executing the program

Using switches and lamps to check the operation

Check the program operation by turning the switches and lamps ON/OFF. If all of the switches (X0, X1, X2) are OFF right after the execution of the program, the output lamp Y10 stays OFF and the output lamp Y1E and the output lamp Y1F stay ON due to the instructions from the created program.

1. Operation check 1
   Turn ON the switch X0. → The output lamp Y10 stays OFF and the output lamp Y1E and Y1F stay ON.

2. Operation check 2
   Turn ON the switch X1. → The output lamp Y10 turns ON.

3. Operation check 3
   Turn ON the switch X2. → The output lamp Y1E and Y1F turn OFF.

Checking the operation in GX Developer

Check the program operation by using the monitor mode on the GX Developer screen, where the status of switches and lamps can be operated and checked.

Operating procedure

1. Set the operating program display screen to the monitor mode.

   Select [Online] → [Monitor] → [Monitor mode] (key).
Execute the monitor to display the "Monitor status" screen.

The ON/OFF status of bit devices can be checked on the ladder screen. Contacts/outputs set to ON are displayed in blue. Right after the program execution, bit devices X02, Y1E, and Y1F are lit blue due to the instructions from the program.

2. Operation check 1

① Double-click X0 while pressing the Shift key → X0 turns ON.

3. Operation check 2

② Double-click X1 while pressing the Shift key → X1 turns ON. Y10 turns ON.

4. Operation check 3

③ Double-click X2 while pressing the Shift key → X2 turns ON. Y1E and Y1F turn OFF.

Point

While pressing the Shift key, double-click devices set to ON in Operation checks 1 and 2 to turn them OFF.
Troubleshooting

When modules do not run normally, refer to the following troubleshooting information.

■ Programmable controller troubleshooting

1. First, check the following points.
   1) The ON/OFF status of the power supply
   2) The mounting condition of the power supply module, the CPU module, and the I/O modules
   3) The LED on the front of the CPU module

2. Check the problem and respond according to the following list.

<table>
<thead>
<tr>
<th>Problem</th>
<th>Check</th>
<th>Action</th>
</tr>
</thead>
</table>
| The "POWER" LED is OFF after turning ON the power supply module. | Is the power supply module properly wired and mounted? | Wire and mount the module properly.  
Mounting Modules (P.10)  
Wiring Modules (P.11) |
| The "ERR." LED on the CPU module is flashing red. | Are programs and PLC parameters written to the CPU module? | Write programs and parameters to the CPU module.  
Writing Programs (P.21) |
| | If the CPU has several programs, are they registered to the PLC parameter? | If there are several programs, register them in the program setting of the PLC parameter, and write the parameters to the CPU module.  
If several programs are not needed, delete unnecessary data, or execute the Format PLC memory function before writing data to the programmable controller CPU.  
GX Developer Version 8  
Operating Manual: SH-080373E |
| | | Other than above Handle by checking for errors following "Checking errors in the CPU module" (P.30) in this manual. |
| The "BAT" LED on the CPU module is ON or flashing. | Is the battery properly connected? | Properly connect the battery.  
Mounting Modules (P.10) |

Reference

For details of the troubleshooting, refer to the following manual.

QCPU User's Manual (Hardware Design, Maintenance and Inspection):
SH-080483ENG
## Troubleshooting when using GX Developer

Check the problem and respond according to the following list.

<table>
<thead>
<tr>
<th>Problem</th>
<th>Check</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>The CPU module cannot communicate with the personal computer (GX Developer).</td>
<td>Is the correct cable used?</td>
<td>Check the cables. [GX Developer Version 8 Operating Manual: SH-080373E]</td>
</tr>
<tr>
<td>(Communication error message)</td>
<td>Is the GX Developer transfer setup properly set?</td>
<td>Check the transfer setup. [Writing Programs (P.21)]</td>
</tr>
<tr>
<td></td>
<td>Is the USB driver properly installed?</td>
<td>Properly install the USB driver, referring the following manual.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>[GX Developer Version 8 Operating Manual (Startup): SH-080372E]</td>
</tr>
<tr>
<td>Programs cannot be written.</td>
<td>Has a write protect password been set in GX Developer?</td>
<td>Unlock the password. [GX Developer Version 8 Operating Manual: SH-080373E]</td>
</tr>
</tbody>
</table>
Checking errors in the CPU module

If a problem occurs, errors can be checked by diagnosing the programmable controller CPU in GX Developer.

Operating procedure

1. Select [Diagnostics] → [PLC diagnostics].

PLC Diagnostics screen (example)

2. Click the Help button.

(Present Error)

3. Click the Help button.

(Error log)

Help screen (example)

Current errors and corrective actions are displayed.
Frequently-used functions

This section explains functions frequently used in GX Developer.

- Clarifying programs <Comment>  (P.32)
  Device comment
  Statement
  Note

- Monitoring device values and status <Device monitor>  (P.37)
  Device batch monitor
  Entry data monitor

- Changing device values <Device test>  (P.41)
  Bit device forced ON/OFF
  Word device current value modification

- Changing running programs <Online program change>  (P.43)

- Checking errors <Error jump>  (P.44)

- Monitoring system status <System monitor>  (P.45)
Clarifying programs <Comment>

Use comments to clarify the contents of a program.

The followings are the three types of comment.

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
<th>Number of characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device comment</td>
<td>Describes roles and usage of each device.</td>
<td>32</td>
</tr>
<tr>
<td>Statement</td>
<td>Describes roles and usage of ladder blocks.</td>
<td>64</td>
</tr>
<tr>
<td>Note</td>
<td>Describes roles and usage of output instructions.</td>
<td>32</td>
</tr>
</tbody>
</table>

**Point**

Select [View] → [Comment] (Ctrl key + F5) key to switch the comment display/hide setting.

**Creating device comments**

Device comments can be entered from the list or on the ladder diagram.

<Input operation from the list>

**Operating procedure**

1. Double-click [COMMENT] under [Device comment] in the project list.

To the next page
Operating procedure

1. Select [Edit] → [Documentation] → [Comment] ( ).
2. Double-click the ladder symbol to enter a comment.
3. Enter a comment on the "Enter device comment" screen.
4. Click the OK button.
5. Select the [Comment] menu in the step 1 again to finish the operation.

Enter the start device number in "Device name".
Click the Display button.
Enter a comment in the "Comment" column.
When entering comments for other devices, enter a device number again as in the step 2.
Click X to close the screen.

<Input operation on the ladder diagram>
Entering comments when creating ladders

Operating procedure

1. Select [Tools] → [Options].
2. Check "Continues during command write" of "Comment input" in the <Program common> tab.
3. Click the OK button.

After the ladder input operation, the "Enter device comment" screen is displayed to enter a comment.
Creating statements

Operating procedure

1. Select [Edit] → [Documentation] → [Statement] ( ).

2. Double-click a ladder block to enter a statement.

3. Select “Embedded”.

4. Enter a statement on the "Enter line statements" screen.

5. Click the OK button.

6. Select the [Statement] menu in the step 1 again to finish the operation.

If a statement is entered, a program needs to be "converted" to reflect the input. For details on the conversion, refer to the following page.

Point

The followings are the two types of statement.

- Integrated (Embedded) statement
  Integrated statements can be written/read from the CPU module.

- Peripheral (Separate) statement
  The program memory capacity can be saved since peripheral statements are not written to the CPU module. "*" is prefixed to the peripheral statement in the program.
Creating notes

Operating procedure

1. Select [Edit] → [Documentation] → [Note] ( ).

2. Double-click the output instruction symbol to enter a note.

3. Select "Embedded".

4. Enter a note on the "Enter Note" screen.

5. Click the button.

6. Select the [Note] menu in the step 1 again to finish the operation.

7. Click to close the screen.

Point

The followings are the two types of note:

- Integrated (Embedded) note
  Integrated notes can be written to/read from the CPU module.

- Peripheral (Separate) note
  The program memory capacity can be saved since peripheral notes are not written to the CPU module. "**" is prefixed to the peripheral note in the program.
## Monitoring device values and status <Device monitor>

The followings are the two types of device monitor.

<table>
<thead>
<tr>
<th>Type</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device batch monitor</td>
<td>Used to monitor consecutive devices of one type.</td>
</tr>
<tr>
<td>Entry data monitor</td>
<td>Used to simultaneously monitor separately-located devices in the ladder or various devices on one screen.</td>
</tr>
</tbody>
</table>

- **Device batch monitor**

  Monitors consecutive devices by specifying the start device number.

### Operating procedure

1. Select [Online] → [Monitor] → [Monitor (Write mode)] (key).
2. Select [Online] → [Monitor] → [Device batch] ( ).
3. Enter the start device number to be monitored on the "Device batch monitor" screen.
4. Click the Start monitor button.

* The "Device batch monitor" screen can be displayed by selecting [Device batch] with a right click on the ladder screen.

To the next page
The values of devices and the ON/OFF status of contacts/coils are displayed.

- **Entry data monitor**

The device registration methods used to perform the Entry data monitoring are the specified device registration and the device registration with ladder monitor display.

**<Specified device registration>**

Register specified devices on the "Entry data monitor" screen.

**Operating procedure**

1. Select [Online] → [Monitor] → [Monitor (Write mode)] (F3 key) ( ).

2. Select [Online] → [Monitor] → [Entry data monitor] ( ).

*The "Entry data monitor" screen can be displayed by selecting [Entry data monitor] with a right click on the ladder screen.

3. Click the **Register devices** button on the "Entry data monitor" screen.

To the next page
The specified device is registered on the "Entry data monitor" screen.

The values of devices and the ON/OFF status of contacts/coils are displayed.

<Device registration with ladder monitor display>
Specify the range of the ladder diagram in the ladder monitor screen and register the devices in a batch.

*The "Entry data monitor" screen can be displayed by selecting [Entry data monitor] with a right click on the ladder screen.
*Set the "Entry data monitor" screen to the monitor stop status.

The ladder screen and the "Entry data monitor" screen are displayed horizontally.

Select [Window] → [Tile horizontally].

Click the start point of the ladder.

Click the end point of the ladder while pressing the `Shift` key (specify the range).

Register devices to the "Entry data monitor" screen.

Drag and drop the selected range to the "Entry data monitor" screen.

The values of the selected devices are monitored.

Click the Start monitor button.
Changing device values <Device test>

This function forces bit devices (such as X, Y, M, C) of the CPU module ON/OFF, or changes the current value of the word device (such as T, C, D) to the specified value.

- Bit device forced ON/OFF

Forcing bit devices (such as X, Y, M, C) of the CPU module ON/OFF.

Operating procedure

1. Select [Online] → [Monitor] → [Monitor (Write mode)] (F3 key)
2. Select [Online] → [Debug] → [Device test] (Alt key + F1 key).
3. Enter the device number to be forced ON/OFF.
4. Force the device ON/OFF
   - FORCE ON: Force the device ON.
   - FORCE OFF: Force the device OFF.
   - Toggle force: Force the device ON/OFF with each click.

Point

- Forcing a bit device ON/OFF with the key operation
  
  Double-click the specified bit device on the ladder monitor screen while pressing the Shift key to force it ON/OFF.
**Word device current value modification**

Changing the current value of the word device (such as T, C, D) in the CPU module to the specified value.

**Operating procedure**

1. Select [Online] → [Monitor] → [Monitor (Write mode)] (F3 key).
2. Select [Online] → [Debug] → [Device test] (ALT key + F1 key).
3. Enter the device number to be changed.
4. Enter the value to be changed.
5. Click the Set button.

* The "Device test" screen can be displayed by selecting [Device test] with a right click on the ladder screen.
## Changing running programs <Online program change>

This function writes only the modified ladder block to the CPU module while the CPU module is in the "RUN" status. A program can be written in a short time since this function does not transfer the whole program.

The following is an example of adding a contact to the ladder.

### Operating procedure

1. Select (Write mode) while displaying the ladder.

2. Add a contact. The ladder block is displayed in gray.

3. Select [Convert] → [Convert (Online change)] (Shift key + F4 key).

4. Click the button.

5. Click the button to close the screen.

When the online program change has been properly completed, the following message is displayed.

### Caution

The program in the CPU module and the program to be modified in GX Developer must be the same to perform the online program change. When you are not sure, verify the programs in advance or modify the ladder after performing the "Read from PLC" function.
Checking errors <Error jump>

Errors can be checked easily with the error jump function of PLC diagnostics.

### Operating procedure

1. Select [Diagnostics] → [PLC diagnostics] from the GX Developer menu.

2. Click the **Error Jump** button.

The cursor jumps to the step number of the sequence program corresponding to the selected error.
Monitoring system status <System monitor>

This function monitors the system status of the CPU module and other modules.

Operating procedure

Select menu [Diagnostics] → [System monitor].

The "System Monitor" screen is displayed.

<table>
<thead>
<tr>
<th>No.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Installed status: Displays the modules installed on the base unit.</td>
</tr>
<tr>
<td>2</td>
<td>Parameter status: Displays the parameter setting status written to the CPU module.</td>
</tr>
<tr>
<td>3</td>
<td>Status: Classifies error status of 1 by color.</td>
</tr>
<tr>
<td>4</td>
<td>Base: Displays the normal status in white and abnormal in red. Module: Displays the error status with the color in 3.</td>
</tr>
</tbody>
</table>
The information of each module can be checked from the “System Monitor” screen.

Double-click the CPU module. → The “PLC diagnostics” screen is displayed to check the operation status of the CPU module.

Double-click each module (except the CPU module and power supply module). → The “Module’s Detailed Information” screen is displayed to check the status of each module.
Windows is either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

The company names, system names and product names mentioned in this manual are either registered trademarks or trademarks of their respective companies.

In some cases, trademark symbols such as "TM" or "®" are not specified in this manual.

Precautions for Choosing the Products

This publication explains the typical features and functions of the Q Series programmable controllers and does not provide restrictions and other information on usage and module combinations. When using the products, always read product user manuals.

Mitsubishi Electric will not be held liable for damage caused by factors found not to be the cause of Mitsubishi Electric; opportunity loss or lost profits caused by faults in Mitsubishi Electric products; damage, secondary damage, accident compensation caused by special factors unpredictable by Mitsubishi; damages to products other than Mitsubishi Electric products; and to other duties.

⚠️ For safe use

- To use the products given in this publication properly, always read the manuals before starting to use them.
- The products have been manufactured as general-purpose parts for general industries, and have not been designed or manufactured to be incorporated in a device or system used in purposes related to human life.
- Before using the products for special purposes such as nuclear power, electric power, aerospace, medicine or passenger movement vehicles, consult with Mitsubishi.
- The products have been manufactured under strict quality control. However, when installing the products where major accidents or losses could occur if the products fail, install appropriate backup or fail-safe functions in the system.
<table>
<thead>
<tr>
<th>Country/Region</th>
<th>Sales office</th>
<th>Tel/Fax</th>
</tr>
</thead>
<tbody>
<tr>
<td>USA</td>
<td>MITSUBISHI ELECTRIC AUTOMATION, INC. 500 Corporate Woods Parkway, Vernon Hills, IL 60061, U.S.A.</td>
<td>Tel: +1-847-478-2100 Fax: +1-847-478-2253</td>
</tr>
<tr>
<td>Mexico</td>
<td>MITSUBISHI ELECTRIC AUTOMATION, INC. Mexico Branch Mariano Escobedo #69, Col. Zona Industrial, Tlaltenango Edo. Mexico, C.P.54030</td>
<td>Tel: +55-55-3067-7500</td>
</tr>
<tr>
<td>Brazil</td>
<td>MITSUBISHI ELECTRIC DO BRASIL COMÉRCIO E SERVIÇOS LTDA. Avenida Adelino Cardana, 293, 21 andar, Belo Horizonte, Barueri SP, Brazil</td>
<td>Tel: +55-11-4689-3000 Fax: +55-11-4689-3016</td>
</tr>
<tr>
<td>Germany</td>
<td>MITSUBISHI ELECTRIC EUROPE B.V. German Branch</td>
<td>Tel: +49-2102-486-0 Fax: +49-2102-486-1120</td>
</tr>
<tr>
<td>UK</td>
<td>MITSUBISHI ELECTRIC EUROPE B.V. UK Branch Traveillers Lane, Hattfield, Hertfordshire, AL10 8XB, U.K.</td>
<td>Tel: +44-1707-28-8780 Fax: +44-1707-27-8969</td>
</tr>
<tr>
<td>Ireland</td>
<td>MITSUBISHI ELECTRIC EUROPE B.V. Irish Branch Westgate Business Park, Ballymount, Dublin 24, Ireland</td>
<td>Tel: +353-1-4198800 Fax: +353-1-4198890</td>
</tr>
<tr>
<td>Italy</td>
<td>MITSUBISHI ELECTRIC EUROPE B.V. Italian Branch Centro Direzionale Colleoni-Palazzo Storia Viale Colleoni 7, 20864 Agrate Brianza (Milano) Italy</td>
<td>Tel: +39-039-60531 Fax: +39-039-6053-312</td>
</tr>
<tr>
<td>Spain</td>
<td>MITSUBISHI ELECTRIC EUROPE B.V. Spanish Branch Carretera de Rubí, 76-80 Apdo. 420, 08190 Sant Cugat del Vallés (Barcelona), Spain</td>
<td>Tel: +34-935-65-3131 Fax: +34-935-89-1579</td>
</tr>
<tr>
<td>France</td>
<td>MITSUBISHI ELECTRIC EUROPE B.V. French Branch 25, Boulevard des Bouvets, 92741 Nanterre Cedex, France</td>
<td>Tel: +33-1-55-68-55-68 Fax: +33-1-55-68-57-57</td>
</tr>
<tr>
<td>Czech Republic</td>
<td>MITSUBISHI ELECTRIC EUROPE B.V. Czech Branch Avenir Business Park, Radlicka 751/113e, 156 00 Praha 5, Czech Republic</td>
<td>Tel: +420-251-551-470 Fax: +420-251-551-471</td>
</tr>
<tr>
<td>Poland</td>
<td>MITSUBISHI ELECTRIC EUROPE B.V. Polish Branch ul. Krakowska 50, 32-083 Balice, Poland</td>
<td>Tel: +48-12-347-85-00 Fax: +48-12-630-47-01</td>
</tr>
<tr>
<td>Sweden</td>
<td>MITSUBISHI ELECTRIC EUROPE B.V. (Scandinavia) Fjellvägen 8, SE-22736 Lund, Sweden</td>
<td>Tel: +46-8-625-10-00 Fax: +46-46-39-70-18</td>
</tr>
<tr>
<td>Russia</td>
<td>MITSUBISHI ELECTRIC (RUSSIA) LLC St. Petersburg Branch Piskarevskiy pr. 2, bd 2, lt “Sch”, BC “Benua”, office 720; 190507 St. Petersburg, Russia</td>
<td>Tel: +7-812-633-3497 Fax: +7-812-633-3499</td>
</tr>
<tr>
<td>Turkey</td>
<td>MITSUBISHI ELECTRIC TURKEY A.Ş Umranıye Branch Senlik Mah. Kale Sok. No:41 34775 Umranıye - İstanbul, Turkey</td>
<td>Tel: +90-216-565-2500 Fax: +90-216-325-3095</td>
</tr>
<tr>
<td>UAE</td>
<td>MITSUBISHI ELECTRIC EUROPE B.V. Dubai Branch Dubai Silicon Oasis, P.O BOX 341241, Dubai, U.A.E.</td>
<td>Tel: +971-4-3724716 Fax: +971-4-3724721</td>
</tr>
<tr>
<td>South Africa</td>
<td>ADOKIT TECHNOLOGIES 20 Waterford Office Park, 189 Witkoppen Road, Fourways, South Africa</td>
<td>Tel: +27-11-658-8100 Fax: +27-11-658-8101</td>
</tr>
<tr>
<td>China</td>
<td>MITSUBISHI ELECTRIC AUTOMATION (CHINA) LTD. No.1386 Hengqiao Road, Mitsubishi Electric Automation Center, Shanghai, China</td>
<td>Tel: +86-21-2322-3000 Fax: +86-21-2322-3000</td>
</tr>
<tr>
<td>Taiwan</td>
<td>SETSUYO ENTERPRISE CO., LTD. 6F, No.105, Wupong 3rd Road, Wugu District, New Taipei City 24889, Taiwan</td>
<td>Tel: +886-2-2299-3499 Fax: +886-2-2299-2509</td>
</tr>
<tr>
<td>Korea</td>
<td>MITSUBISHI ELECTRIC AUTOMATION KOREA CO., LTD. 7F-9F, Gangseo Hangang Xi-tower A, 401, Yangcheon-ro, Gangseo-Gu, Seoul 07528, Korea</td>
<td>Tel: +82-2-3860-9530 Fax: +82-2-3664-8372</td>
</tr>
<tr>
<td>Singapore</td>
<td>MITSUBISHI ELECTRIC ASIA PTE. LTD. 307, Alexandra Road, Mitsubishi Electric Building, Singapore 159943</td>
<td>Tel: +65-6473-3208 Fax: +65-6476-7439</td>
</tr>
<tr>
<td>Thailand</td>
<td>MITSUBISHI ELECTRIC FACTORY AUTOMATION (THAILAND) CO., LTD. 12th Floor, SV City Building, Office Tower 1, No. 89/619 and 79 Rama 3 Road, Kwaeng Bangprongang, Khet Yannawa, Bangkok 10120, Thailand</td>
<td>Tel: +66-2682-6252 Fax: +66-2688-6070</td>
</tr>
<tr>
<td>Vietnam</td>
<td>MITSUBISHI ELECTRIC VIETNAM COMPANY LIMITED Hanoi Branch 6th Floor, Detech Tower, 8 Ton That Thuyet Street, My Dinh 2 Ward, Nam Tu Liem District, Hanoi, Vietnam</td>
<td>Tel: +84-4-3937-8075 Fax: +84-4-3937-8076</td>
</tr>
<tr>
<td>Malaysia</td>
<td>MITSUBISHI ELECTRIC SALES MALAYSIA SDN. BHD. Lot 11, Jalan 219, 46100 Potaling Jaya, Selangor Darul Ehsan, Malaysia</td>
<td>Tel: +60-3-7626-5000 Fax: +60-3-7568-3544</td>
</tr>
<tr>
<td>Indonesia</td>
<td>PT. MITSUBISHI ELECTRIC INDONESIA Gedung Jaya 11th Floor, Jl. MH. Thamrin No.12, Jakarta Pusat 10340, Indonesia</td>
<td>Tel: +62-21-3192-6461 Fax: +62-21-3192-3942</td>
</tr>
<tr>
<td>India</td>
<td>MITSUBISHI ELECTRIC INDIA PVT. LTD. Pune Branch Emerald House, EL-5, J Block, M.I.D.C., Bhosari, Pune-411026, Maharashtra, India</td>
<td>Tel: +91-20-2710-2000 Fax: +91-20-2710-2100</td>
</tr>
<tr>
<td>Australia</td>
<td>MITSUBISHI ELECTRIC AUSTRALIA P.T.Y. LTD. 348 Victoria Road, P.O. Box 11, Rydalmere, N.S.W 2116, Australia</td>
<td>Tel: +61-2-9684-7777 Fax: +61-2-9684-7245</td>
</tr>
</tbody>
</table>