Engineering Software

GX Works2 Version 1
Operating Manual
(Simple Project, Function Block)

-SW1DND-GXW2-E
-SW1DNC-GXW2-E
SAFETY PRECAUTIONS
(Always read these instructions before using this product.)

Before using this product, thoroughly read this manual and the relevant manuals introduced in this manual and pay careful attention to safety and handle the products properly. The precautions given in this manual are concerned with this product. For the safety precautions of the programmable controller system, refer to the User's Manual for the CPU module.

In this manual, the safety precautions are ranked as "WARNING" and "CAUTION".

WARNING
Indicates that incorrect handling may cause hazardous conditions, resulting in death or severe injury.

CAUTION
Indicates that incorrect handling may cause hazardous conditions, resulting in minor or moderate injury or property damage.

Note that the CAUTION level may lead to serious consequences according to the circumstances. Always follow the precautions of both levels because they are important for personal safety.

Please save this manual to make it accessible when required and always forward it to the end user.

[Design Instructions]

WARNING
● When data change, program change, or status control is performed from a personal computer to a running programmable controller, create an interlock circuit outside the programmable controller to ensure that the whole system always operates safely. Furthermore, for the online operations performed from a personal computer to a programmable controller CPU, the corrective actions against a communication error due to such as a cable connection fault should be predetermined as a system.
● To maintain the safety of the programmable controller system against unauthorized access from external devices via the network, take appropriate measures. To maintain the safety against unauthorized access via the Internet, take measures such as installing a firewall.

[Startup/Maintenance Instructions]

CAUTION
● The online operations performed from a personal computer to a running programmable controller CPU (Program change when a programmable controller CPU is RUN, operating status changes such as forced input/output operation and RUN-STOP switching, and remote control operation) must be executed after the manual has been carefully read and the safety has been ensured. When changing a program while a programmable controller CPU is RUN, it may cause a program corruption in some operating conditions. Fully understand the precautions described in Section 12.9 before use.
● The positioning test functions of OPR, JOG, inching or positioning data for QD75/LD75 positioning module must be executed with the programmable controller set to STOP after the manual has been carefully read and the safety has been ensured. Specially when executing the function on the network system, ensure the safety thoroughly since the machinery whose operation cannot be checked by an operator may be activated. The operation failure may cause the injury or machine damage.
● CONDITIONS OF USE FOR THE PRODUCT ●

(1) Mitsubishi programmable controller ("the PRODUCT") shall be used in conditions:
   i) where any problem, fault or failure occurring in the PRODUCT, if any, shall not lead to any major or serious accident; and
   ii) where the backup and fail-safe function are systematically or automatically provided outside of the PRODUCT for the case of any problem, fault or failure occurring in the PRODUCT.

(2) The PRODUCT has been designed and manufactured for the purpose of being used in general industries.
MITSUBISHI SHALL HAVE NO RESPONSIBILITY OR LIABILITY (INCLUDING, BUT NOT LIMITED TO ANY AND ALL RESPONSIBILITY OR LIABILITY BASED ON CONTRACT, WARRANTY, TORT, PRODUCT LIABILITY) FOR ANY INJURY OR DEATH TO PERSONS OR LOSS OR DAMAGE TO PROPERTY CAUSED BY the PRODUCT THAT ARE OPERATED OR USED IN APPLICATION NOT INTENDED OR EXCLUDED BY INSTRUCTIONS, PRECAUTIONS, OR WARNING CONTAINED IN MITSUBISHI’S USER, INSTRUCTION AND/OR SAFETY MANUALS, TECHNICAL BULLETINS AND GUIDELINES FOR the PRODUCT.
("Prohibited Application")
Prohibited Applications include, but not limited to, the use of the PRODUCT in;
• Nuclear Power Plants and any other power plants operated by Power companies, and/or any other cases in which the public could be affected if any problem or fault occurs in the PRODUCT.
• Railway companies or Public service purposes, and/or any other cases in which establishment of a special quality assurance system is required by the Purchaser or End User.
• Aircraft or Aerospace, Medical applications, Train equipment, transport equipment such as Elevator and Escalator, Incineration and Fuel devices, Vehicles, Manned transportation, Equipment for Recreation and Amusement, and Safety devices, handling of Nuclear or Hazardous Materials or Chemicals, Mining and Drilling, and/or other applications where there is a significant risk of injury to the public or property.

Notwithstanding the above, restrictions Mitsubishi may in its sole discretion, authorize use of the PRODUCT in one or more of the Prohibited Applications, provided that the usage of the PRODUCT is limited only for the specific applications agreed to by Mitsubishi and provided further that no special quality assurance or fail-safe, redundant or other safety features which exceed the general specifications of the PRODUCTs are required. For details, please contact the Mitsubishi representative in your region.
## REVISIONS

<table>
<thead>
<tr>
<th>Print date</th>
<th>Manual number</th>
<th>Revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>Nov. 2011</td>
<td>SH(NA)-080984ENG-A</td>
<td>First edition</td>
</tr>
</tbody>
</table>
| Jan. 2012  | SH(NA)-080984ENG-B | Model Addition  
FX3GC  
Correction  
Section 4.1 |
| May 2012   | SH(NA)-080984ENG-C | Model Addition  
Q02PH, Q06PH, Q12PH, Q12PRH, Q25PH, Q25PRH  
Correction  
GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL, Section 1.5.1, Section 2.3.4, Section 3.1.1, Appendix 3 |
| Sept. 2012 | SH(NA)-080984ENG-D | Correction  
GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL, Section 2.6, Section 3.1.4, Appendix 2 |
| Feb. 2013  | SH(NA)-080984ENG-E | Model Addition  
Q03UDV, Q04UDV, Q06UDV, Q13UDV, Q26UDV, L02S, L06, L26  
Addition  
Section 4.2.1  
Correction  
GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL, TERMS, Section 1.5.1, Section 2.3.3, Section 2.6, Section 3.1.1, Section 3.1.2, Section 4.2.2, Section 5.2, Appendix 2  
Modification  
Section 4.2 → Section 4.2.2 |
| May 2013   | SH(NA)-080984ENG-F | Model Addition  
L02S-P, L06-P, L26-P, FX3S  
Correction  
GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL, Section 2.3.3, Appendix 2 |
| Sept. 2013 | SH(NA)-080984ENG-G | Addition  
Section 4.2.1, Section 4.2.2  
Correction  
TERMS, Section 4.2.3  
Modification  
Section 4.2.1 → Section 4.2.3, Section 4.2.2 → Section 4.3, Section 4.3 to Section 4.6 → Section 4.4 to Section 4.7 |
| Dec. 2013  | SH(NA)-080984ENG-H | Correction  
Section 2.1 |
| Mar. 2014  | SH(NA)-080984ENG-I | Correction  
Section 2.6, Appendix 3 |
| Jun. 2014  | SH(NA)-080984ENG-J | Correction  
Section 4.2.1, Section 4.2.2, Section 4.2.3, Appendix 3 |
| Sept. 2014 | SH(NA)-080984ENG-K | Correction  
Section 5.3 |
| Mar. 2015  | SH(NA)-080984ENG-L | Correction  
Section 4.4 |
| Jan. 2018  | SH(NA)-080984ENG-M | Correction  
GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL |
<table>
<thead>
<tr>
<th>Print date</th>
<th>Manual number*1</th>
<th>Revision</th>
</tr>
</thead>
</table>
| Jun. 2018  | SH(NA)-080984ENG-N | Correction  
SAFETY PRECAUTIONS, Section 4.2.3 |

*1: The manual number is written at the bottom left of the back cover.

Japanese Manual Version SH-080983-P

This manual confers no industrial property rights or any rights of any other kind, nor does it confer any patent licenses. Mitsubishi Electric Corporation cannot be held responsible for any problems involving industrial property rights which may occur as a result of using the contents noted in this manual.

© 2011 MITSUBISHI ELECTRIC CORPORATION
INTRODUCTION

Thank you for purchasing the engineering software, MELSOFT series. Before using the product, thoroughly read this manual to develop full familiarity with the functions and performance to ensure correct use.

CONTENTS

SAFETY PRECAUTIONS .................................................................................. A - 1
CONDITIONS OF USE FOR THE PRODUCT .................................................. A - 2
REVISIONS ........................................................................................................ A - 3
INTRODUCTION .................................................................................................. A - 5
CONTENTS ......................................................................................................... A - 5
MANUALS .......................................................................................................... A - 8
GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL .................. A - 16
TERMS ............................................................................................................... A - 17

1 OVERVIEW OF FUNCTION BLOCKS

1.1 Function Blocks (FBs) ................................................................................. 1 - 2
1.2 Features of FBs .......................................................................................... 1 - 3
1.3 Labels ........................................................................................................ 1 - 4
1.4 Programming Flow with FBs ...................................................................... 1 - 5
   1.4.1 FB creation procedure ......................................................................... 1 - 5
   1.4.2 Sequence program creation procedure using FBs ......................... 1 - 7
1.5 Overview of Screen Configuration ............................................................. 1 - 8
   1.5.1 Main frame configuration ................................................................... 1 - 8
   1.5.2 Label setting editor ........................................................................... 1 - 10

2 CREATING FUNCTION BLOCKS

2.1 Creating Projects for FBs .......................................................................... 2 - 2
2.2 Creating New FB Data .............................................................................. 2 - 3
2.3 Setting Local Labels .................................................................................. 2 - 4
   2.3.1 Setting labels on Function/FB Label Setting screen. ......................... 2 - 4
   2.3.2 Classes ............................................................................................. 2 - 5
   2.3.3 Data types ....................................................................................... 2 - 6
   2.3.4 Selecting data types ........................................................................ 2 - 7
   2.3.5 Assigning devices automatically .................................................... 2 - 9
2.4 Creating FB Programs .............................................................................. 2 - 12
2.5 Converting FBs ....................................................................................... 2 - 13
2.6 Considerations when Creating FB Programs ........................................ 2 - 14
3 USING FUNCTION BLOCKS

3.1 Creating Sequence Programs with FBs
- Pasting FBs to sequence programs ......................................................... 3 - 2
- Creating input and output circuits of FB instances .................................. 3 - 6
- Aligning sequence program and FB program ......................................... 3 - 11
- Converting/compiling all sequence programs ......................................... 3 - 12
- Writing sequence programs to programmable controller CPU .................. 3 - 16

3.2 Checking Operations of Sequence Programs ....................................... 3 - 19

4 MANAGING AND EDITING FUNCTION BLOCKS

4.1 Reading FB Programs from Programmable Controller CPU .................. 4 - 2
4.2 Reusing FBs from Library (Project)
- Library (project) reusing procedure ....................................................... 4 - 3
- Exporting FBs to other project ............................................................. 4 - 4
- Importing FBs from other project ......................................................... 4 - 6
4.3 Copying FBs from Project ................................................................. 4 - 9
4.4 Changing FB Instance Names ............................................................ 4 - 10
4.5 Deleting Unnecessary FB Data from Projects ....................................... 4 - 11
4.6 Protecting FBs ................................................................................. 4 - 13
4.7 Searching/Replacing FB Instance Names ............................................ 4 - 16

5 USING FB LIBRARIES

5.1 Installing FB Library
- Obtaining FB Library ............................................................................. 5 - 2
- Installing FB Library ............................................................................. 5 - 2
5.2 Using FB Libraries .............................................................................. 5 - 3
5.3 Displaying Reference Manual ............................................................... 5 - 5
5.4 Uninstalling FB Library ....................................................................... 5 - 6

6 PROGRAM EXAMPLES USING FUNCTION BLOCKS

6.1 System Configuration of Program Examples ....................................... 6 - 2
6.2 Processing of Program Examples ......................................................... 6 - 3
6.3 Creating Program Examples ................................................................ 6 - 4

APPENDIX

Appendix 1 Character Strings that cannot be Used for Label Names and FB Data Names/Instance Names App - 2
### INDEX

<table>
<thead>
<tr>
<th>Appendix 2</th>
<th>Supported CPU modules</th>
<th>App - 5</th>
</tr>
</thead>
<tbody>
<tr>
<td>Appendix 3</td>
<td>Using FBs Created with GX Developer in GX Works2</td>
<td>App - 6</td>
</tr>
</tbody>
</table>
Related manuals are separately issued according to the purpose of their functions in GX Works2.

## Related manuals

The manuals related to this product are shown below. Refer to the following tables when ordering required manuals.

### 1) Operation of GX Works2

<table>
<thead>
<tr>
<th>Manual name</th>
<th>Manual number (Model code)</th>
</tr>
</thead>
<tbody>
<tr>
<td>GX Works2 Version 1 Operating Manual (Common)</td>
<td>SH-080779ENG (13JU63)</td>
</tr>
<tr>
<td>Explains the system configuration of GX Works2 and the functions common to Simple project and Structured project such as parameter setting, operation method for the online function. (Sold separately)</td>
<td></td>
</tr>
<tr>
<td>GX Works2 Version 1 Operating Manual (Simple Project)</td>
<td>SH-080780ENG (13JU64)</td>
</tr>
<tr>
<td>Explains methods for such as creating and monitoring programs in Simple project of GX Works2. (Sold separately)</td>
<td></td>
</tr>
<tr>
<td>GX Works2 Version 1 Operating Manual (Structured Project)</td>
<td>SH-080781ENG (13JU65)</td>
</tr>
<tr>
<td>Explains methods for such as creating and monitoring programs in Structured project of GX Works2. (Sold separately)</td>
<td></td>
</tr>
<tr>
<td>GX Works2 Version 1 Operating Manual (Intelligent Function Module)</td>
<td>SH-080921ENG (13JU69)</td>
</tr>
<tr>
<td>Explains methods of intelligent function module for such as parameter setting, monitoring programs, and predefined protocol support function in GX Works2. (Sold separately)</td>
<td></td>
</tr>
<tr>
<td>GX Works2 Beginner's Manual (Simple Project)</td>
<td>SH-080787ENG (13JZ22)</td>
</tr>
<tr>
<td>Explains fundamental methods for such as creating, editing, and monitoring programs in Simple project for users inexperienced with GX Works2. (Sold separately)</td>
<td></td>
</tr>
<tr>
<td>GX Works2 Beginner's Manual (Structured project)</td>
<td>SH-080788ENG (13JZ23)</td>
</tr>
<tr>
<td>Explains fundamental methods for such as creating, editing, and monitoring programs in Structured project for users inexperienced with GX Works2. (Sold separately)</td>
<td></td>
</tr>
</tbody>
</table>

### 2) Structured Programming

<table>
<thead>
<tr>
<th>Manual name</th>
<th>Manual number (Model code)</th>
</tr>
</thead>
<tbody>
<tr>
<td>MELSEC-Q/L/F Structured Programming Manual (Fundamentals)</td>
<td>SH-080782ENG (13JW06)</td>
</tr>
<tr>
<td>Explains the programming methods, types of programming languages, and other information required to create structured programs. (Sold separately)</td>
<td></td>
</tr>
<tr>
<td>MELSEC-Q/L/F Structured Programming Manual (Common Instructions)</td>
<td>SH-080783ENG (13JW07)</td>
</tr>
<tr>
<td>Explains the specifications and functions of common instructions such as sequence instructions, basic instructions, and application instructions, that can be used in structured programs. (Sold separately)</td>
<td></td>
</tr>
<tr>
<td>MELSEC-Q/L Structured Programming Manual (Application Functions)</td>
<td>SH-080784ENG (13JW08)</td>
</tr>
<tr>
<td>Explains the specifications and functions of application functions that can be used in structured programs. (Sold separately)</td>
<td></td>
</tr>
<tr>
<td>MELSEC-Q/L Structured Programming Manual (Special Instructions)</td>
<td>SH-080785ENG (13JW09)</td>
</tr>
<tr>
<td>Explains the specifications and functions of special instructions such as module dedicated instruction, PID control instruction, and built-in I/O function dedicated instruction, that can be used in structured programs. (Sold separately)</td>
<td></td>
</tr>
<tr>
<td>FXCPU Structured Programming Manual (Device &amp; Common)</td>
<td>JY997D26001 (09R925)</td>
</tr>
<tr>
<td>Explains the devices and parameters provided in GX Works2 for structured programming. (Sold separately)</td>
<td></td>
</tr>
<tr>
<td>FXCPU Structured Programming Manual (Basic &amp; Applied Instruction)</td>
<td>JY997D34701 (09R926)</td>
</tr>
<tr>
<td>Explains the sequence instructions provided in GX Works2 for structured programming. (Sold separately)</td>
<td></td>
</tr>
<tr>
<td>FXCPU Structured Programming Manual (Application Functions)</td>
<td>JY997D34801 (09R927)</td>
</tr>
<tr>
<td>Explains the application functions provided in GX Works2 for structured programming. (Sold separately)</td>
<td></td>
</tr>
</tbody>
</table>
3) Operation of iQ Works

<table>
<thead>
<tr>
<th>Manual name</th>
<th>Manual number (Model code)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Let’s start iQ Works Version 2</td>
<td>SH-081261ENG (13JZ79)</td>
</tr>
<tr>
<td>Explains fundamental methods for such as managing the system using MELSOFT Navigator and using system labels for users inexperienced with GX Works2.</td>
<td></td>
</tr>
<tr>
<td>(Sold separately)</td>
<td></td>
</tr>
</tbody>
</table>

The Operating Manuals are included on the DVD-ROM and CD-ROM of the software package in a PDF file format. Manuals in printed form are sold separately for single purchase. Order a manual by quoting the manual number (model code) listed in the table above.
Purpose of this manual

This manual explains the operations for creating sequence programs with function blocks (FB) in Simple project using the functions supported by GX Works2. Manuals for reference are listed in the following table according to their purpose. For information such as the content and number of each manual, refer to the list of 'Related manuals'.

1) Installation of GX Works2 and the USB driver

<table>
<thead>
<tr>
<th>Purpose</th>
<th>GX Works2 Installation Instructions</th>
<th>GX Works2 Version 1 Operating Manual</th>
</tr>
</thead>
<tbody>
<tr>
<td>Learning the operating environment and installation method</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Learning a USB driver installation method</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

2) Operation of GX Works2

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Simple Project</td>
<td>Structured Project</td>
</tr>
<tr>
<td>Learning all functions of GX Works2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Learning the project types and available languages in GX Works2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Learning the basic operations and operating procedures when creating a simple project for the first time</td>
<td>Details</td>
<td></td>
</tr>
<tr>
<td>Learning the basic operations and operating procedures when creating a structured project for the first time</td>
<td>Details</td>
<td></td>
</tr>
<tr>
<td>Learning the operations of available functions regardless of project type.</td>
<td>Details</td>
<td></td>
</tr>
<tr>
<td>Learning the functions and operation methods for programming</td>
<td>Details</td>
<td></td>
</tr>
<tr>
<td>Learning the operations and operating procedures when using function blocks (FBs) in Simple project</td>
<td>Details</td>
<td></td>
</tr>
<tr>
<td>Learning data setting methods for intelligent function module</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
3) Operations in each programming language
For details of instructions used in each programming language, refer to the section 4 and the section 5 on the following pages.

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Simple Project</td>
<td>Structured Project</td>
</tr>
<tr>
<td>Simple Project</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ladder Diagram</td>
<td>Outline</td>
<td>Details</td>
</tr>
<tr>
<td>Sequential Function Chart</td>
<td>Outline</td>
<td>Details</td>
</tr>
<tr>
<td>Structured Text</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Structured project</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ladder Diagram</td>
<td>Outline</td>
<td>Details</td>
</tr>
<tr>
<td>Sequential Function Chart</td>
<td>Outline</td>
<td>Details</td>
</tr>
<tr>
<td>Structured Ladder /FBD</td>
<td>Outline</td>
<td>Details</td>
</tr>
<tr>
<td>Structured Text</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*1: MELAP3 and FX series SFC only
### 4) Details of instructions in each programming language (for QCPU (Q mode)/LCPU)

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Fundamentals</td>
<td>Common Instructions</td>
<td>Special Instructions</td>
<td>Application Functions</td>
<td>Common Instruction</td>
</tr>
<tr>
<td><strong>All languages</strong></td>
<td>Learning details of programmable controller CPU error codes, special relays, and special registers</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Using Ladder Diagram</strong></td>
<td>Learning the types and details of common instructions</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Learning the types and details of instructions for intelligent function modules</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Learning the types and details of instructions for network modules</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Learning the types and details of instructions for the PID control function</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Using Sequential Function Chart</strong></td>
<td>Learning details of specifications, functions, and instructions of SFC (MELSAP3)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Using Structured Ladder/ FBD or Structured Text</strong></td>
<td>Learning the fundamentals for creating a structured program</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Learning the types and details of common instructions</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Learning the types and details of instructions for intelligent function modules</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Learning the types and details of instructions for network modules</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Learning the types and details of instructions for the PID control function</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Learning the types and details of application instructions</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## 5) Details of instructions in each programming language (for FXCPU)

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Fundamentals</td>
<td>Device &amp; Common</td>
<td>Sequence Instructions</td>
</tr>
<tr>
<td>Using Ladder Diagram</td>
<td>Learning the types and details of basic/ application instructions, descriptions of devices and parameters</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Using Sequential Function Chart</td>
<td>Learning details of specifications, functions, and instructions of SFC</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Using Structured Ladder/ FBD or Structured Text</td>
<td>Learning the fundamentals for creating a structured program</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Learning the descriptions of devices, parameters, and error codes</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Learning the types and details of sequence instructions</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Learning the types and details of application instructions</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
2.3.5 Assigning devices automatically

The device range to be automatically assigned to a label can be changed on the Device Label Automatic-Assign Setting screen.

Screen display

Select Tool — [Device Label Automatic-Assign Setting].

Operating procedure

1. Set the items on the screen.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Maximum number of characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Latch selection</td>
<td>Select when range of latch (1) or latch (2) is set on the PLC parameters.</td>
<td>30 characters</td>
</tr>
<tr>
<td>Device</td>
<td>Display the devices to be assigned automatically.</td>
<td>20 characters</td>
</tr>
<tr>
<td>Digit</td>
<td>Display whether the range of device assign setting is in decimal or hexadecimal.</td>
<td>20 characters</td>
</tr>
<tr>
<td>Assignment Range</td>
<td>Check to be assigned automatically.</td>
<td>30 characters</td>
</tr>
<tr>
<td>Start</td>
<td>Display the range of device points to be assigned automatically.</td>
<td>20 characters</td>
</tr>
<tr>
<td>End</td>
<td>Display the total points of each device range for VAR and VAR RETAIN.</td>
<td>30 characters</td>
</tr>
</tbody>
</table>

Screen display

Select Project view — "POV" — "FB_Per" — "(Function Block)" — "Local Label".

Operating procedure

1. Set the items on the screen.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Maximum number of characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>CmHi</td>
<td>Select a label view from the list displayed by clicking () or Section 2.3.3.</td>
<td>12 characters</td>
</tr>
<tr>
<td>Label Name</td>
<td>Specify a label name. For printable characters, refer to Section 1.2 App. 1.</td>
<td>55 characters</td>
</tr>
<tr>
<td>Data Type</td>
<td>Specify a data type from the Data Type Selection screen.</td>
<td>150 characters</td>
</tr>
<tr>
<td>Comment</td>
<td>Enter a comment. When &quot;VAR CONSTANT&quot; is selected for &quot;Data Type&quot;, and simple type is selected for &quot;Data Type&quot;, 150 characters.</td>
<td>150 characters</td>
</tr>
</tbody>
</table>
This manual also uses the following columns:

This explains notes requiring attention or useful functions relating to the information given on the same page.

**Symbols used in this manual**

The following shows the symbols used in this manual with descriptions and examples.

<table>
<thead>
<tr>
<th>No.</th>
<th>Symbol</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>①</td>
<td>[ ]</td>
<td>Menu name on a menu bar</td>
<td>[Project]</td>
</tr>
<tr>
<td>②</td>
<td>Toolbar icon</td>
<td></td>
<td></td>
</tr>
<tr>
<td>③</td>
<td>(Underline)</td>
<td>Screen name</td>
<td>Q Parameter Setting screen</td>
</tr>
<tr>
<td>④</td>
<td>&lt;&lt; &gt;&gt;</td>
<td>Tab name on a screen</td>
<td>&lt;&lt;PLC System&gt;&gt;</td>
</tr>
<tr>
<td>⑤</td>
<td>&quot; &quot;</td>
<td>Item name on a screen</td>
<td>&quot;Timer Limit Setting&quot;</td>
</tr>
<tr>
<td>⑥</td>
<td>Button on a screen</td>
<td></td>
<td>High Speed Interrupt Setting button</td>
</tr>
<tr>
<td>-</td>
<td>Keyboard key</td>
<td></td>
<td>[Call]</td>
</tr>
</tbody>
</table>
# GENERIC TERMS AND ABBREVIATIONS IN THIS MANUAL

The following are the generic terms/abbreviations of such as software packages and programmable controller CPUs used in this manual.

<table>
<thead>
<tr>
<th>Generic term and abbreviation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GX Works2</td>
<td>Generic product name for SWnDND-GXW2-E and SWnDNC-GXW2-E (n: version)</td>
</tr>
<tr>
<td>GX Developer</td>
<td>Generic product name for SWnD5C-GPPW-E, SWnD5C-GPPW-EA, SWnD5C-GPPW-EV, and SWnD5C-GPPW-EVA (n: version)</td>
</tr>
<tr>
<td>Personal computer</td>
<td>Generic term for personal computers on which Windows® operates</td>
</tr>
<tr>
<td>Basic model QCPU</td>
<td>Generic term for Q00J, Q00, and Q01</td>
</tr>
<tr>
<td>High Performance model QCPU</td>
<td>Generic term for Q02, Q02H, Q06H, Q12H, and Q25H</td>
</tr>
<tr>
<td>Process CPU</td>
<td>Generic term for Q02PHCPU, Q06PHCPU, Q12PHCPU, and Q25PHCPU</td>
</tr>
<tr>
<td>Redundant CPU</td>
<td>Generic term for Q12PRHCPU and Q25PRHCPU</td>
</tr>
<tr>
<td>Universal model QCPU</td>
<td>Generic term for Q00UJ, Q00U, Q01U, Q02U, Q03UD, Q03UDE, Q03UDV, Q04UDH, Q04UDEH, Q04UDV, Q06UDH, Q06UDEH, Q06UDV, Q10UDH, Q10UDEH, Q13UDH, Q13UDEH, Q13UDV, Q20UDH, Q20UDEH, Q26UDH, Q26UDEH, Q26UDV, Q50UDEH, and Q100UDEH</td>
</tr>
<tr>
<td>QCPU (Q mode)</td>
<td>Generic term for Basic model QCPU, High Performance model QCPU, Process CPU, Redundant CPU, and Universal model QCPU</td>
</tr>
<tr>
<td>LCPU</td>
<td>Generic term for L02S, L02S-P, L02, L02-P, L06, L06-P, L26, L26-P, L26-BT, and L26-PBT</td>
</tr>
<tr>
<td>FXCPU</td>
<td>Generic term for FX0S, FX0, FX0N, FX1, FX1S, FX1NC, FXU, FX2C, FX2N, FX2NC, FX3S, FX3G, FX9GC, FX3U, FX3UC</td>
</tr>
<tr>
<td>SFC</td>
<td>Generic term for MELSAP3, MELSAP-L, and FX series SFC</td>
</tr>
<tr>
<td>MELSOFT Library</td>
<td>Generic term for components (FB library, sample programs, drawing data) which provide easy operation of programmable controller related modules and GOTs, and various devices that are connected to them. Contact your local Mitsubishi representative to obtain components of MELSOFT Library.</td>
</tr>
<tr>
<td>FB</td>
<td>Abbreviation for a function block</td>
</tr>
</tbody>
</table>
## TERMS

The following are the terms used in this manual.

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual device</td>
<td>An actual device assigned to label after compiling a project with labels, or a device that is not described using a label</td>
</tr>
<tr>
<td>Common instruction</td>
<td>Generic term for sequence instructions, basic instructions, application instructions, data link instructions, multiple CPU dedicated instructions, and multiple CPU high-speed transmission dedicated instructions</td>
</tr>
<tr>
<td>Special instruction</td>
<td>Generic term for module dedicated instructions, PID control instructions, socket communication function instructions, built-in I/O function instructions, and data logging function instructions</td>
</tr>
<tr>
<td>Simple Project Without labels</td>
<td>Generic term for projects created using Ladder Diagram, Sequential Function Chart, Structured Text</td>
</tr>
<tr>
<td>Simple Project With labels</td>
<td>Generic term for projects created without selecting &quot;Use Label&quot; when creating new projects</td>
</tr>
<tr>
<td>Project without labels</td>
<td>Generic term for Simple projects that do not use labels</td>
</tr>
<tr>
<td>Project with labels</td>
<td>Generic term for Simple projects that use labels and Structured projects</td>
</tr>
<tr>
<td>Project with security</td>
<td>Generic term for projects whose securities are set</td>
</tr>
<tr>
<td>Utilization</td>
<td>To paste FB to a sequence program</td>
</tr>
<tr>
<td>Reuse</td>
<td>To use FB to other project</td>
</tr>
<tr>
<td>Library (project)</td>
<td>A project to be used as an FB library</td>
</tr>
<tr>
<td>FB instance</td>
<td>An FB pasted to a sequence program</td>
</tr>
<tr>
<td>Global label</td>
<td>A label which becomes effective for all program data when multiple program data items are created in a project</td>
</tr>
<tr>
<td>Local label</td>
<td>A label which becomes effective only for each program data</td>
</tr>
<tr>
<td>Structure</td>
<td>A data type which allows various device types (bit device, word device, etc.) to be stored in single aggregate (single data)</td>
</tr>
<tr>
<td>Array</td>
<td>A data type which allows the same device type to be stored in a consecutive area</td>
</tr>
</tbody>
</table>
1 OVERVIEW OF FUNCTION BLOCKS

This chapter explains features of FBs, overview of labels, and work flow for using FBs.

1.1 Function Blocks (FBs) 1 - 2
1.2 Features of FBs 1 - 3
1.3 Labels 1 - 4
1.4 Programming Flow with FBs 1 - 5
1.5 Overview of Screen Configuration 1 - 8
1.1 Function Blocks (FBs)

An FB is designed to convert a ladder block, which is used repeatedly in a sequence program, into a component to be utilized in a sequence program. FBs can be used in projects with labels. This manual explains FBs used in Simple projects. In the operation examples, Ladder Diagram is selected as a programming language, but Structured Text can also be selected. Note, however, that FXCPU Simple projects do not support Structured Text.
1.2 Features of FBs

■ Creating programs efficiently

Converting a standard program into a component as a single block enables the program to be utilized easily. As an easy utilization for a sequence program is possible, the efficiency of creating a large-scale program is improved. In addition, converting a program into a component improves program readability and eases editing and debugging.

■ Consistency of program quality

Converting a program into a component as an FB to utilize the program allows consistency of program quality, without relying on the technological skills of the program developers. In addition, programming mistakes which may occur at the time of utilization can be prevented.

■ Reducing program creation man-hours with FB libraries

With QCPU (Q mode)/LCPU, man-hours for creating a program can be reduced using FB libraries. There are FB libraries which support various devices such as CPU modules, analog input/output modules, and counter modules. FB libraries which support partner products are also supplied.

■ Programming languages according to the intended use are selectable

In Simple projects, Ladder Diagram or Structured Text can be selected as a programming language for FBs. The optimum programming language which meets the intended use can be selected to create FBs. FXCPU Simple project supports only Ladder Diagram.
A label is a character string which represents a device. Using labels allows a program to be created without considering devices in the program. Therefore, a program with labels can be easily utilized even for a system with different module configuration.

**Global labels and local labels**

There are two types of labels, global labels and local labels.

- **Global labels**
  Global labels are shared among all sequence programs in a project. A specific device can be assigned to a global label.

- **Local labels**
  Local labels are used only in a single sequence program. They cannot be shared even if local labels with the same name are set for multiple sequence programs. Different devices are assigned to local labels for each sequence program.
1.4 Programming Flow with FBs

This manual explains the operating procedures with examples of FBs used on QCPU (Q mode)/LCPU. For the instructions and functions which are available for FXCPU, refer to the following manuals. 

FXCPU user’s manuals and programming manuals

1.4.1 FB creation procedure

Operating procedure

1. Creating a project for FBs

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a project with labels.</td>
<td>Section 2.1</td>
</tr>
</tbody>
</table>

2. Creating new FB data

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create new FB data.</td>
<td>Section 2.2</td>
</tr>
</tbody>
</table>

3. Setting local labels

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set local labels to be used for the FB program.</td>
<td>Section 2.3</td>
</tr>
</tbody>
</table>

4. Creating an FB program

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create an FB program using labels.</td>
<td>Section 2.4</td>
</tr>
</tbody>
</table>

5. Converting FBs

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conversion finalizes the edited FB program content.</td>
<td>Section 2.5</td>
</tr>
</tbody>
</table>
Operations for created FBs
- Reading programs from programmable controller CPU (Section 4.1)
- Utilizing FBs (Section 4.2)
- Changing FB instance names (Section 4.4)
- Deleting FBs (Section 4.5)
- Protecting FBs (Section 4.6)
- Searching/replacing FB instance names and labels (Section 4.7)
1.4.2 Sequence program creation procedure using FBs

Operating procedure

1. Pasting FBs

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paste FBs to the sequence program.</td>
<td>Section 3.1.1</td>
</tr>
<tr>
<td>Paste FBs of the FB Library to the sequence program.</td>
<td>Chapter 5</td>
</tr>
</tbody>
</table>

2. Creating input/output circuits of an FB instance.

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create input and output circuits of the FB instance.</td>
<td>Section 3.1.2</td>
</tr>
</tbody>
</table>

3. Converting/compiling a sequence program

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Convert/compile the sequence program.</td>
<td>Section 3.1.4</td>
</tr>
</tbody>
</table>

4. Writing a program to a programmable controller CPU

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Write the sequence program to the programmable controller CPU.</td>
<td>Section 3.1.5</td>
</tr>
</tbody>
</table>

5. Checking the operation

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monitor the operation of the sequence program written to the programmable controller CPU.</td>
<td>Section 3.2</td>
</tr>
</tbody>
</table>
1.5 Overview of Screen Configuration

1.5.1 Main frame configuration

This section explains the screen configuration of the main frame (basic screen) of GX Works2 that is displayed when it is started up. The following is an example of a screen on which a work window and docked windows are displayed.
## Display contents

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title bar</td>
<td>Display a project name.</td>
<td>—</td>
</tr>
<tr>
<td>Menu bar</td>
<td>Display menu options for executing each function.</td>
<td>—</td>
</tr>
<tr>
<td>Toolbar</td>
<td>Display tool buttons for executing each function.</td>
<td>GX Works2 Version 1 Operating Manual (Simple Project)</td>
</tr>
<tr>
<td>Work window</td>
<td>A main screen used for operations such as programming, parameter setting, and monitoring.</td>
<td>GX Works2 Version 1 Operating Manual (Common)</td>
</tr>
<tr>
<td>Docking window</td>
<td>A sub screen to support operations performed on a work window.</td>
<td></td>
</tr>
<tr>
<td>Navigation</td>
<td>Display contents of a project in tree format.</td>
<td></td>
</tr>
<tr>
<td>Element Selection</td>
<td>Display a list of functions (such as FBs) used for programming.</td>
<td>Section 3.1.1</td>
</tr>
<tr>
<td>FB component</td>
<td>An FB registered as a component</td>
<td></td>
</tr>
<tr>
<td>Output</td>
<td>Display compilation and check results (errors and warnings).</td>
<td>GX Works2 Version 1 Operating Manual (Simple Project)</td>
</tr>
<tr>
<td>Cross Reference</td>
<td>Display cross reference results.</td>
<td></td>
</tr>
<tr>
<td>Device List</td>
<td>Display the device list.</td>
<td></td>
</tr>
<tr>
<td>Watch 1 to 4</td>
<td>A screen used for monitoring and changing current device values.</td>
<td>GX Works2 Version 1 Operating Manual (Common)</td>
</tr>
<tr>
<td>Intelligent function module</td>
<td>A screen used for monitoring intelligent function modules.</td>
<td></td>
</tr>
<tr>
<td>monitor 1 to 10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Find/Replace</td>
<td>A screen used for searching and replacing character strings in the project.</td>
<td></td>
</tr>
<tr>
<td>Debug</td>
<td>A screen used for setting the debug which uses the simulation function.</td>
<td></td>
</tr>
<tr>
<td>Status bar</td>
<td>Display information about a project being edited.</td>
<td>—</td>
</tr>
<tr>
<td>Sequence program</td>
<td>A program and local labels.</td>
<td>—</td>
</tr>
<tr>
<td>FB data</td>
<td>A program and local labels of FB.</td>
<td>—</td>
</tr>
<tr>
<td>FB instance (entity)</td>
<td>An FB pasted to a sequence program.</td>
<td>—</td>
</tr>
</tbody>
</table>
1.5.2 Label setting editor

This section explains the configurations of label setting editor.

- **Global Label Setting screen**
  Define labels that can be used for all sequence programs in the project.
  ([GX Works2 Version 1 Operating Manual (Simple Project)])

- **Local Label Setting screen**
  Define labels that can be used only for each sequence program.
  ([GX Works2 Version 1 Operating Manual (Simple Project)])

- **Function/FB Label Setting screen**
  Define labels that can be used only for FBs. ([GX Works2 Version 1 Operating Manual (Simple Project)])

*1: [Section 2.3]
2 CREATING FUNCTION BLOCKS

This chapter explains how to create FBs.
For the basic operations of GX Works2, refer to the following manuals.
☞ GX Works2 Version 1 Operating Manual (Common)
☞ GX Works2 Version 1 Operating Manual (Simple Project)

2.1 Creating Projects for FBs 2 - 2
2.2 Creating New FB Data 2 - 3
2.3 Setting Local Labels 2 - 4
2.4 Creating FB Programs 2 - 12
2.5 Converting FBs 2 - 13
2.6 Considerations when Creating FB Programs 2 - 14
2.1 Creating Projects for FBs

This section explains how to create a project with labels for creating FBs.

**Operating procedure**

1. **Select [Project] ⇒ [New].**
   The New Project screen is displayed.

   ![New Project Screen]

2. **Set the items on the screen.**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Series</td>
<td>Select a programmable controller series for the project.</td>
</tr>
<tr>
<td>Type</td>
<td>Select a programmable controller type used for the project.</td>
</tr>
<tr>
<td>Project Type</td>
<td>Select &quot;Simple Project&quot;.</td>
</tr>
<tr>
<td>Use Label</td>
<td>Select the item.</td>
</tr>
<tr>
<td>Language</td>
<td>Select a programming language to be used.</td>
</tr>
</tbody>
</table>

3. **Click the OK button.**
   A new project is created.

**Point**

- **Existing projects**
  FBs can be created in an existing project with labels.
  For a project without labels, select [Project] ⇒ [Change Project Type] to change the project to a project with labels, and create FBs.
This section explains how to create new FB data in a project with labels.

### Operating procedure

1. **Select [Project] ⇒ [Object] ⇒ [New]**
   - The New Data screen is displayed.

2. **Set the items on the screen.**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Types</td>
<td>Select &quot;Function Block&quot;.</td>
</tr>
<tr>
<td>Data Name</td>
<td>Enter a data name of an FB to be created with a maximum of 32 characters. For unusable characters, refer to Appendix 1.</td>
</tr>
<tr>
<td>Program Language</td>
<td>Select a programming language to be used. The programming languages available for FB creation in Simple projects are Ladder Diagram and Structured Text. FXCPU Simple projects support Ladder Diagram only.</td>
</tr>
</tbody>
</table>

3. **Click the OK button.**
   - The newly created FB data is added under "FB_Pool" on the Project view, and the FB editing screen is displayed on the work window.

---

**Point**

- Maximum number of data to be created
  
  Up to 800 FB data including other data types such as programs can be created.
2.3 Setting Local Labels

This section explains how to define labels to be used in an FB program.

2.3.1 Setting labels on Function/FB Label Setting screen

Set items such as label classes, label names, and data types.

**Screen display**

Select Project view ⇒ "POU" ⇒ "FB_Pool" ⇒ "(function block)" ⇒ "Local Label".

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Maximum number of characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Class</td>
<td>Select a label class from the list displayed by clicking . (Section 2.3.2)</td>
<td>—</td>
</tr>
<tr>
<td>Label Name</td>
<td>Enter a desired label name. For unusable characters, refer to Appendix 1.</td>
<td>32 (Input, output, input/output labels: 16)</td>
</tr>
<tr>
<td>Data Types</td>
<td>Specify a data type from the Data Type Selection screen displayed by clicking . (Section 2.3.4) It can also be entered directly.</td>
<td>128</td>
</tr>
<tr>
<td>Constant</td>
<td>Enter a constant value when &quot;VAR_CONSTANT&quot; is selected for &quot;Class&quot; and simple type is selected for &quot;Data Type&quot;.</td>
<td>128</td>
</tr>
<tr>
<td>Comment*1,*2</td>
<td>Enter a comment.</td>
<td>1024</td>
</tr>
</tbody>
</table>

*1: A new line can be inserted into a cell by pressing the + keys.
*2: Comments on a program editor can be displayed/hidden by selecting [View] ⇒ [Comment]/[Statement]/[Note].
2.3 Setting Local Labels

2.3.2 Classes

Class setting
When an item other than the class, such as a label name and data type, is set in a blank column, "VAR" is automatically set for "Class". Change it if necessary.

Characters that cannot be used for label names
Any of the following label names causes an error at compilation.
- A label name that includes a space.
- A label name that begins with a numeral.
- A label name which is same as the one used for devices.
For characters that cannot be used for label names, refer to Appendix 1.

When the local label setting of an FB is changed
When the local label setting of an FB pasted to a sequence program is changed, compile the program or all programs.
The change of input/output label is applied to the sequence program to which the FB is pasted at compilation. Note that the change is not applied when the FB instance name is not registered in the global label setting or local label setting.

Maximum number of input/output labels

The maximum number of input/output labels which can be used in an FB program differs according to the programming language.

When setting input/output labels with local label setting of FB, set within the number of the input/output labels shown in the following table.

<table>
<thead>
<tr>
<th>Programming language of FB</th>
<th>Applicable number of labels in an FB program</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Input</td>
</tr>
<tr>
<td>Ladder Diagram</td>
<td>1 to 24*1 (Including input/output labels)</td>
</tr>
<tr>
<td>Structured Text</td>
<td>0 to 253*2 (Including input/output labels)</td>
</tr>
</tbody>
</table>

*1: For input/output labels, each input label and output label is counted as one label.
*2: When pasting labels to a sequence program in Ladder Diagram, the applicable number of input/output labels is 1 to 24 (including input/output labels). Each input label and output label is counted as one label.

2.3.2 Classes

A class indicates the POU applicability and the usage of label.

Selectable classes differ according to the type of label setting editor.
The following table shows the selectable classes on the Function/FB Label Setting screen.

<table>
<thead>
<tr>
<th>Class</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VAR</td>
<td>An internal-variable label that can be used for FB programs.</td>
</tr>
<tr>
<td>VAR_CONSTANT</td>
<td>A constant label that can be used for FB programs.</td>
</tr>
<tr>
<td>VAR_RETAIN*1</td>
<td>A latch-type label that is used for FB programs.</td>
</tr>
<tr>
<td>VAR_INPUT</td>
<td>A label that is used for an input of FB program (input label). Its value cannot be changed in an FB program.</td>
</tr>
<tr>
<td>VAR_OUTPUT</td>
<td>A label that is used for an output of FB program (output label).</td>
</tr>
<tr>
<td>VAR_IN_OUT</td>
<td>A label that can be used for both input and output with the same name (input/output label). Its value can be changed in an FB program.</td>
</tr>
</tbody>
</table>

*1: Not supported by FXCPU.
2.3.3 Data types

Data types of label are shown in the following table. Note that applicable data types differ according to the programming language.

<table>
<thead>
<tr>
<th>Data type</th>
<th>Programming language</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Ladder Diagram</td>
</tr>
<tr>
<td>Bit</td>
<td>○</td>
</tr>
<tr>
<td>Word [signed]</td>
<td>○</td>
</tr>
<tr>
<td>Double word [signed]</td>
<td>○</td>
</tr>
<tr>
<td>Word [unsigned]/16-bit string</td>
<td>×</td>
</tr>
<tr>
<td>Double word [unsigned]/32-bit string</td>
<td>×</td>
</tr>
<tr>
<td>Single-precision real*1</td>
<td>○</td>
</tr>
<tr>
<td>Double-precision real*2</td>
<td>○</td>
</tr>
<tr>
<td>String*3</td>
<td>○</td>
</tr>
<tr>
<td>Time</td>
<td>×</td>
</tr>
<tr>
<td>Timer</td>
<td>○*4</td>
</tr>
<tr>
<td>Counter</td>
<td>○*4</td>
</tr>
<tr>
<td>Retentive timer*5</td>
<td>○*4</td>
</tr>
<tr>
<td>Pointer</td>
<td>○*4</td>
</tr>
</tbody>
</table>

*1 : For FXCPU, this item is supported by FX2N, FX2NC, FX3S, FX3G, FX3GC, FX3U, and FX3UC only.
*2 : Supported by Universal model QCPU/LCPU only.
*3 : For FXCPU, this item is supported by FX3U and FX3UC only.
*4 : The data type cannot be used as input/output labels when pasting an FB to a ladder program.
*5 : For FXCPU, this item is supported by FX1N, FX1NC, FX2N, FX2NC, FX3S, FX3G, FX3GC, FX3U, and FX3UC only.

For value ranges and details of each data type, refer to the following manuals.

- QCPU (Q mode)/LCPU
  - CPU user’s manuals (Function Explanation, Program Fundamentals)
  - MELSEC-Q/L Programming Manual (Common Instruction)

- FXCPU
  - FXCPU user’s manuals and programming manuals
2.3.4 Selecting data types

Selecting data type.
A data type can be specified by directly entering the type in text or selecting it on the Data Type Selection screen.

Operating procedure

1. Click on the data type entry field on the Function/FB Label Setting screen. The Data Type Selection screen is displayed.

2. Select a type for "Type Class".

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simple Types</td>
<td>Specify this to select a data type from basic types such as bit and word.</td>
</tr>
<tr>
<td>Structured Data Types</td>
<td>Specify this to select a data type from the defined structures.</td>
</tr>
<tr>
<td>Function Blocks</td>
<td>Specify this to select a data type from the defined function blocks.</td>
</tr>
</tbody>
</table>

3. On the "Libraries" field, select the reference source such as the defined structure that is used as the data type.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;ALL&gt;</td>
<td>Browse data types, structures, and function blocks defined in the project, and all libraries.</td>
</tr>
<tr>
<td>&lt;PROJECT&gt;</td>
<td>Browse data types, structures, and function blocks defined in the project. (Not displayed when &quot;Simple Types&quot; is selected.)</td>
</tr>
<tr>
<td>Standard Lib</td>
<td>Browse function blocks of application functions. (Not displayed when &quot;Simple Types&quot; or &quot;Structured Data Types&quot; is selected.)</td>
</tr>
</tbody>
</table>

4. On the "Data Type" field, select the data type, structure, or function block name.

5. Click the OK button when the setting is completed.
The settings are displayed on the "Data Type" column on the Function/FB Label Setting screen.
Setting arrays for data type

Define the data type as an array.
To define a data type as an array, set the items of "Array Element" on the Data Type Selection screen.

Operation

1. Click on the data type entry field on the Function/FB Label Setting screen.
The Data Type Selection screen is displayed.
2. Select "ARRAY" under "Array Element".
3. Enter the number of elements for "Element".
4. Set the data type of the array element in the same manner as setting the normal data type.

To change the offset
To change the offset ([Array start value]. [Array end value]) to a value other than 0, edit the offset value by directly entering the array declaration in text on the Function/FB Label Setting screen.

To change the array to a two- or three-dimensional array
When the programming language is ST, a two- or three-dimensional array can be set. Edit by directly entering the array declaration in text on the Function/FB Label Setting screen.

Point

- A label whose class is VAR_CONSTANT
  An array cannot be set for the data type. If an array is set, an error occurs at compilation.
- Offset values
  Minus values can be set for offset values.
- Using arrays in ladder programs
  The labels of two- or three-dimensional array and structure array cannot be used in ladder programs.
2.3.5 Assigning devices automatically

Devices are automatically assigned to labels when a program is compiled. The ranges of devices which are automatically assigned to labels can be changed on the Device/Label Automatic-Assign Setting screen. Set the ranges not to overlap with devices used in a sequence program.

QCPU (Q mode)/LCPU

Screen display

Select [Tool] ⇒ [Device/Label Automatic-Assign Setting].

Operating procedure

- Set the items on the screen.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Latch selection field</td>
<td>Select latch (1) or latch (2). This item can be selected when the range of latch (1) or latch (2) is set on the &lt;&lt;Device&gt;&gt; tab of PLC parameter.</td>
</tr>
<tr>
<td>Device</td>
<td>Display the devices to be assigned automatically.</td>
</tr>
<tr>
<td>Digit</td>
<td>Display whether the range of device assignment setting is in decimal or hexadecimal.</td>
</tr>
<tr>
<td>Assignment Selection</td>
<td>Select the device to be assigned automatically. Multiple devices can be set.</td>
</tr>
<tr>
<td>Assignment Range Start</td>
<td>Enter the range of device points to be assigned automatically.</td>
</tr>
<tr>
<td>Assignment Range End</td>
<td></td>
</tr>
<tr>
<td>Total Points</td>
<td>Display the total points of each device range for VAR and VAR RETAIN.</td>
</tr>
<tr>
<td>PLC Parameter Device Setting Range</td>
<td>Display the device point range set on the &lt;&lt;Device&gt;&gt; tab of PLC parameter. When the latch range is set, display the device point range with the latch range. Example: When D: 0 to 12287, latch D: 5000 to 6000 are set on the &lt;&lt;Device&gt;&gt; tab of PLC parameter, display range of D: 0 to 12287, range of latch D: 5000 to 6000.</td>
</tr>
</tbody>
</table>
FXCPU

Screen display

Select [Tool] ⇒ [Device/Label Automatic-Assign Setting].

Operating procedure

• Select the device type, and set the start and end addresses to be assigned automatically.
2.3 Setting Local Labels

2.3.5 Assigning devices automatically

Considerations of automatically assigned devices

- Considerations when changing automatically assigned devices
  All programs need to be compiled when the range of automatically assigned device is changed.
  Compiling all programs changes the device assignment to labels. Therefore, device values set before
  the program change remain on the device-assigned labels.
  For QCPU (Q mode)/LCPU, reset the programmable controller CPU, clear all device memories
  including latches, clear all file registers, then switch the programmable controller CPU to RUN for a
  precautionary measure.
  (GX Works2 Version 1 Operating Manual (Common))
  For the considerations for compiling all programs, refer to the following manual.
  (GX Works2 Version 1 Operating Manual (Simple Project))

- Assigning devices with the "Device/Label Automatic-Assign Setting" function
  Assign devices to labels with the "Device/Label Automatic-Assign Setting" function when a program
  is compiled.
  (GX Works2 Version 1 Operating Manual (Simple Project))
  The assigned devices can be checked with the cross reference function.
  (GX Works2 Version 1 Operating Manual (Common))
  Devices within the range set on the Device/Label Automatic-Assign Setting screen cannot be used in
  a program.

- Considerations when the multiple types of devices are assigned automatically (QCPU (Q mode)/LCPU)
  Refer to Considerations of compilation.
  (GX Works2 Version 1 Operating Manual (Simple Project))

- Device types and setting ranges
  The types of automatically assigned devices differ by the type of CPU.
  The setting ranges depend on the number of device points set in PLC parameter.
  For details of PLC parameter, refer to the following manual.
  (GX Works2 Version 1 Operating Manual (Common))

- Considerations when displaying the Device/Label Automatic-Assign Setting screen
  When displaying the Device/Label Automatic-Assign Setting screen, an error message may be
  displayed.
  In this case, terminate GX Works2, copy "vsflex8n.ocx" stored in the folder of GX Works2 installation
  destination to "C:\WINDOWS\system32" (for Windows® XP), and restart GX Works2.
2.4 Creating FB Programs

This section explains how to create an FB program using labels. Labels set on the Function/FB Label Setting screen and global labels can be used.

**Operating procedure**

1. Select Project view ⇒ "POU" ⇒ "FB_Pool" ⇒ "(function block)" ⇒ "Program".
   The FB editing screen is displayed.

2. Create an FB program.

For the program creation method, refer to the following manual.
GX Works2 Version 1 Operating Manual (Simple Project)
2.5 Converting FBs

For FB programs in Ladder Diagram, the edited content can be confirmed by converting the program.

Operating procedure

1. Select [Compile] ⇒ [Build] ( ).
   The Confirm Build Method screen is displayed.

2. Select "Convert the selected program" and click the  button.
   The edited content of the FB program is confirmed.
2.6 Considerations when Creating FB Programs

This section explains considerations for creating FB programs.

1) **Use of inline structured text in FB programs**

Function blocks using inline structured text programs cannot be used in function block programs.

2) **Use of actual devices**

Using labels is recommended for creating FB programs.

If an FB program which uses actual devices (X10, Y10, etc.) is used at multiple locations, the program may not operate normally.

In addition, if an FB program which uses actual devices for the OUT instruction is used at multiple locations, duplicated coil is resulted. Duplicated coil can be avoided with the SET/RST instruction.

3) **When using master control instructions**

When using a master control instruction in an FB program, use the MC instruction and the MCR instruction together.

4) **When using FBs for a sequence program to be executed multiple times in a single scan**

If an FB, which contains a rising instruction, falling instruction, or an instruction that requires multiple scans before the execution completion, is used in a sequence program to be executed multiple times in a single scan, the program may not operate normally.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Program to be executed multiple times in a single scan</td>
<td>• Fixed-cycle execution type program&lt;br&gt;• Interrupt program&lt;br&gt;• Subroutine program&lt;br&gt;• FOR-NEXT instruction program</td>
</tr>
</tbody>
</table>

| Unusable instructions for FBs which are used for above programs | Instruction which requires multiple scans before the execution completion (JP.READ/JP.WRITE instruction, SORT instruction, SP.FREAD/SP.FWRITE instruction, etc.)<br>Rising instruction (P instruction (such as MOVP instruction), PLS, etc.)<br>Falling instruction (PLF, LDF, ANDF, ORF, MEF, FCALLP, EFCALLP, etc.) |
5) **When using index registers in FB programs**

When using index registers in an FB program, a save program and a restore program are required to protect the index register values. Through a method that the index register value is set to 0 when its value is temporarily saved, an operation error, which is detected by the consistency check of index modification (whether if the device number exceeds the device range), can be prevented.

Example: When the values of index registers Z1 and Z2 are temporarily saved in the FB program before the execution of the program and the saved values of the index registers are restored after execution of the program.

Save the index register values in `index_reg_tmp` before execution of the program.

```
; Index register save
MOV Z1 index_reg_tmp[0]
MOV Z2 index_reg_tmp[1]
```

Set the index register values to "0".

```
; Index register clear
MOV K0 Z1
MOV K0 Z2
```

Run the program.

```
; Index register restore
MOV index_reg_tmp[0] Z1
MOV index_reg_tmp[1] Z2
```

Restore the values saved in `index_reg_tmp` after execution of the program to the index registers.
6) Specification of start I/O numbers of intelligent function modules

When accessing to the buffer memory or input/output signals of an intelligent function module, specify the start I/O number using an index register.

Receiving the start I/O number as an input variable enables a common FB to be used without changing the start I/O numbers of the multiple intelligent function modules whose mounting positions differ.

Example 1: When accessing the input/output signals of an intelligent function module
Using an index register enables access to the input/output signals of a target intelligent function module.

Example 2: When accessing the buffer memory of an intelligent function module.
1) Enter the start I/O number of the target intelligent function module to the index register.
2) Shift the value rightward 4 bits with the SFR instruction or use the quotient of the value divided by 16.
7) When transferring multiple bit data to a word type label

For a ladder program, a label does not allow digit specification (K4i.Counter, etc.)
When transferring multiple bit data to a word type label, use the BSET/BRST instruction or the WOR/WAND instruction to switch ON/OFF the individual bits of the target word data.

For QCPU (Q mode)/LCPU>

Set 1 (ON) to the first bit of int_WordData.

\[
\begin{align*}
\text{Set 0 (OFF) to the fifth bit of int_WordData.}
\end{align*}
\]

For FXCPU>

Set ON to the 0th bit and the 4th bit of int_WordData with the WOR instruction.

For the specification of the bit position, refer to the following table.

Set OFF to the 1st bit and the 5th bit of int_WordData with the WAND instruction.

For the specification of the bit position, refer to the following table.

<table>
<thead>
<tr>
<th>Bit position</th>
<th>(WOR instruction) Set a bit to ON</th>
<th>(WAND instruction) Set a bit to OFF</th>
</tr>
</thead>
<tbody>
<tr>
<td>0th bit</td>
<td>H0001</td>
<td>HFFFFE</td>
</tr>
<tr>
<td>1st bit</td>
<td>H0002</td>
<td>HFFFD</td>
</tr>
<tr>
<td>2nd bit</td>
<td>H0004</td>
<td>HFFFB</td>
</tr>
<tr>
<td>3rd bit</td>
<td>H0008</td>
<td>HFF7</td>
</tr>
<tr>
<td>4th bit</td>
<td>H0010</td>
<td>HFFEF</td>
</tr>
<tr>
<td>5th bit</td>
<td>H0020</td>
<td>HFFDF</td>
</tr>
<tr>
<td>6th bit</td>
<td>H0040</td>
<td>HFBF</td>
</tr>
<tr>
<td>7th bit</td>
<td>H0080</td>
<td>HFF7F</td>
</tr>
<tr>
<td>8th bit</td>
<td>H0100</td>
<td>HEFFF</td>
</tr>
<tr>
<td>9th bit</td>
<td>H0200</td>
<td>HFDF</td>
</tr>
<tr>
<td>10th bit</td>
<td>H0400</td>
<td>HFBF</td>
</tr>
<tr>
<td>11th bit</td>
<td>H0800</td>
<td>HFF7F</td>
</tr>
<tr>
<td>12th bit</td>
<td>H1000</td>
<td>HEFFF</td>
</tr>
<tr>
<td>13th bit</td>
<td>H2000</td>
<td>HDFFF</td>
</tr>
<tr>
<td>14th bit</td>
<td>H4000</td>
<td>HBFFF</td>
</tr>
<tr>
<td>15th bit</td>
<td>H8000</td>
<td>H7FFF</td>
</tr>
</tbody>
</table>
8) When handling multiple word data as an array

Input/output labels in an FB program do not allow an array to be used. In the following method, multiple data can be imported from a sequence program to an FB program.

Example: When loading values for six points from D1000

A) Set the following three labels in the label setting of FB program. Set int_Write_Array as an array.

<table>
<thead>
<tr>
<th>Class</th>
<th>Label Name</th>
<th>Data Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>VAR_INPUT</td>
<td>i_Write_Data</td>
<td>WordSigned</td>
</tr>
<tr>
<td>VAR_INPUT</td>
<td>i_Num_Write_Data</td>
<td>WordSigned</td>
</tr>
<tr>
<td>VAR_OUTPUT</td>
<td>FB_OK</td>
<td>Eii</td>
</tr>
<tr>
<td>VAR_OUTPUT</td>
<td>FB_ERROR</td>
<td>Eii</td>
</tr>
<tr>
<td>VAR</td>
<td>i_data1</td>
<td>Eii</td>
</tr>
</tbody>
</table>

B) In the sequence program, save values for six points to D devices from D1000.

<table>
<thead>
<tr>
<th>Device</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>D1000</td>
<td>1234H</td>
</tr>
<tr>
<td>D1001</td>
<td>2345H</td>
</tr>
<tr>
<td>D1002</td>
<td>3456H</td>
</tr>
<tr>
<td>D1003</td>
<td>4567H</td>
</tr>
<tr>
<td>D1004</td>
<td>5678H</td>
</tr>
<tr>
<td>D1005</td>
<td>6789H</td>
</tr>
</tbody>
</table>

C) For the input of an FB instance, specify D1000.

D) Using the BMOV instruction in the FB program, transfer values for six points from the input variable (i_Write_Data) to the array (int_Write_Array).

```
BMOV i_Write_Data int_Write_Array i_Num_Write_Data
```

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1234H</td>
<td>1234H</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2345H</td>
<td>2345H</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3456H</td>
<td>3456H</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4567H</td>
<td>4567H</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5678H</td>
<td>5678H</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6789H</td>
<td>6789H</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```
This chapter explains how to create a sequence program with FBs. For the basic operations and screen details of GX Works2, refer to the following manual.

GX Works2 Version 1 Operating Manual (Common)
3.1 Creating Sequence Programs with FBs

This section explains how to create a sequence program using FBs as components.

3.1.1 Pasting FBs to sequence programs

■ When calling an FB within a ladder program

On the pasted FB instance, label names of I/O variables and their corresponding data types are displayed.

Paste FBs from the Project view of the Navigation window or from the Element Selection window to a sequence program. When the FB is pasted, an FB instance name is registered to the local label or the global label as a label.

Operating procedure

1. Select an FB from the Project view of the Navigation window and move to a desired position on the sequence program with the drag-and-drop operation.

The Input FB Instance Name screen is displayed.

2. Click to select local label or global label to register the FB instance name.

3. Change the FB instance name if necessary.

When changing the name, avoid creating the same name in the same program.
4. Click the **OK** button.

The FB instance is displayed on the editing screen.

---

**Point**

- **FB instance name**
  - FB instance names can be changed later. ([Section 4.6](#))
  - A name can be set using up to 16 characters. Alphabets are case-sensitive.
  - Numeric characters cannot be used as the first character. For unusable characters, refer to Appendix 1.

- **Registering FB instance names to local label or global label**
  When an FB is pasted, an FB instance name is automatically registered as a label on the setting screen of the label selected in step 2.

- **Other pasting methods**
  FBs can also be pasted from the Element Selection window with the drag-and-drop operation. The Element Selection window is displayed by selecting `[View]` → `[Docking Window]` → `[Element Selection]`.

- **When the same FB is pasted repeatedly**
  Pasting an FB to a sequence program causes the file size to be increased. Pasting the same FB to one sequence program repeatedly also causes the size increase of the sequence program according to the number of times of pasting.
Display of FB instance

On the pasted FB instance, label names of I/O variables and their corresponding data types are displayed.

The following are the representation of data types.
- B: Bit
- W: Word [signed]
- D: Double word [signed]
- E: Single-precision real
- L: Double-precision real
- S: String
3.1 Creating Sequence Programs with FBs

3.1.1 Pasting FBs to sequence programs

When calling an FB within an ST program

By entering an FB name in an ST program, the FB can be called in the same manner as pasting an FB in a ladder program.

Operating procedure

- Enter an FB label name, input variable, and output variable in the ST program.
  Values must be specified for entered input variable and output variable.
  Note that entering of output variable can be omitted when a result of output variable is not required.

Example: When the defined FB is "TIMER"

[Details of defined FB]
FB label name: FB_TIMER
Input variable: Setting value 1 second, setting value 10 seconds, setting value 100 seconds, start, stop
Output variable: In operation, timer up 1, timer up 2

[Data entering example]
Enter data in the ST program as shown below.

FB_TIMER (Setting value 1 second: = X0, Setting value 10 seconds: = X1, Setting value 100 seconds: = X2, Start: = X3, Stop: = X4, In operation: = Y70, Timer up 1: = Y71, Timer up 2: = Y72);

The output of the FB can be obtained by specifying the output variable name with a 'period (.)' suffixed to the FB name.
Enter an instruction to obtain the output after performing the FB call.

Y70: = FB_TIMER. In operation;
3.1.2 Creating input and output circuits of FB instances

Create input and output circuits of the FB instance pasted to a sequence program.

Operating procedure

1. Select [Compile] ⇒ [Build].
   The Confirm Build Method screen is displayed.

2. Select "Convert the selected program", and click the OK button.
   The ladder block is converted, and lines are connected to the input labels and output labels of the FB instance.
3. Enter elements to the input circuit.

Enter elements in the same manner as creating normal ladder programs. Create a program meeting data type of input variable.

(Bit type)

If the data type of input variable is not a bit type, enter the device directly on the Enter Symbol screen.

(Other than bit type)

4. Enter elements to the output circuit in the same manner as the input circuit.

Edit the program other than FBs as necessary. After finishing the editing, convert/compile the program.
3 USING FUNCTION BLOCKS

### 3.1.2 Creating input and output circuits of FB instances

- **Number of contacts that can be created in input circuit and output circuit**
  
  By setting “Display Connection of Ladder Diagram”, the number of contacts occupied in input circuit or output circuit of an FB instance is determined as below.

<table>
<thead>
<tr>
<th>Setting of the number of displayed contacts</th>
<th>Number of contacts in input circuit</th>
<th>Number of contacts in output circuit</th>
</tr>
</thead>
<tbody>
<tr>
<td>9 contacts</td>
<td>3 contacts</td>
<td>2 contacts + 1 coil</td>
</tr>
<tr>
<td>11 contacts</td>
<td>4 contacts</td>
<td>3 contacts + 1 coil</td>
</tr>
<tr>
<td>13 contacts</td>
<td>5 contacts</td>
<td>4 contacts + 1 coil</td>
</tr>
<tr>
<td>17 contacts</td>
<td>7 contacts</td>
<td>6 contacts + 1 coil</td>
</tr>
<tr>
<td>21 contacts</td>
<td>9 contacts</td>
<td>8 contacts + 1 coil</td>
</tr>
</tbody>
</table>

Instructions that exceed the number of occupied contacts cannot be entered. When instructions cannot be placed by changing the number of displayed contacts, the ladder block is not displayed properly.

For the setting of the number of displayed contacts, refer to the following manual.

- GX Works2 Version 1 Operating Manual (Simple Project)

- **Comment**
  
  A comment can be entered on a program.

### Checkpoints

- **Device comment**
  
  Enter the function of the device.

- **Label comment**
  
  Enter the function of the label.

- **Statement**
  
  Enter the function of the ladder block.

- **Note**
  
  Enter the function of the output instruction.

- **Checking duplicated coils in the ladder programs**
  
  When the same devices are used in the source ladder program and the target FB, even if “Check duplicated coil” is selected under "Program Editor" ⇒ “Ladder/SFC” ⇒ “Enter ladder” in the option setting, the duplicated coils are not detected. Check the duplicated coils in the source ladder program and the target FB by the Cross reference function. The duplicated coils can be checked by clearing the item for "Program Check" under [Tool] ⇒ [Options] ⇒ “Compile” ⇒ "Basic Setting".

- **When using labels in a sequence program**
  
  When using labels in a sequence program, refer to the following manual.

  - GX Works2 Version 1 Operating Manual (Simple Project)
### Considerations for using FBs

1) **A single FB can be pasted to a single ladder block.**
   The output of an FB instance cannot be directly connect to the input of another FB instance. When connecting FBs each other, use a coil to initially receive the output of a single FB, and then connect the contact of the coil to the input of the other FB.

![Diagram of FB connection example](image)

2) **Wrapping lines cannot be created in the input and output circuits.**
   Insert a coil to receive the output and use the contact of the coil as the target instruction condition.

![Diagram of wrapping line example](image)

3) **Parallel connections cannot be created in the input or output circuit.** An error occurs when the program is converted.

![Diagram of parallel connection example](image)

4) **The data type of the input or output circuit of the FB instance, and the data type of the contact/coil/application instruction to be connected must be the same.** Using different data types at the connection causes an error at compilation.

5) **If the instance is not registered on the label setting screen when utilizing the FB to the ladder program, the information of FB name change and FB deletion are not applied to the label setting and the program.**
   In this case, delete the FB instance in the program manually, and utilize the FBs again.
6) When the label setting of FB is changed, compile the program or all programs. The change of input/output label is applied to the utilization destination ladder program at compilation. Note that the change is not applied when the FB instance is not registered in the global label setting or local label setting.

<Example of FB (before changing label setting)>

<Label setting of FB>

<Example of FB (after changing label setting)>

7) Function blocks using inline structured text programs cannot be used in programs other than Ladder Diagram.
3.1.3 Aligning sequence program and FB program

An alignment of a sequence program and an FB program allows a sequence program to be edited while checking the FB program.

**Operating procedure**

1. Move the cursor to the FB instance.

2. Select [View] ⇒ [Tile FB Horizontally].
   The sequence program and the FB program are displayed horizontally.
3.1.4 Converting/compiling all sequence programs

Convert/compile all sequence programs to be executed on a programmable controller CPU.

Operating procedure

1. Select [Compile] ⇒ [Rebuild All] ( ).
   The following message is displayed.
   Clear the check box if the duplicated coil check, ladder program check, and consistency (pairing) check are not performed after the compilation.

2. Click the button after reading and understanding the considerations described on the message.
   All programs are converted/compiled and the result is displayed on the Output window.
   By double-clicking the result (errors/warnings only), the corresponding error location in the program is displayed.
When a program is compiled with [Compile]
Since only programs that are not compiled are subjected to compilation, time required for compilation can be reduced. For considerations of compilation, refer to the following manual.

- GX Works2 Version 1 Operating Manual (Simple Project)

Program size after compilation
When compilation is executed, the FB is applied to a program as an internal processing of a sequence program, resulting in increase of the program size. The program size can be checked on the Memory Capacity Calculation Result screen.

Calculating memory size (QCPU(Q mode)/LCPU)
Data size required for writing a program to a programmable controller CPU can be checked on the Memory Capacity Calculation Result screen. Excess of the capacity when writing a program to a programmable controller CPU can be prevented by checking the memory size.

Operating procedure
1. Select [Tool] ⇒ [Confirm Memory Size].

The Confirm Memory Size screen is displayed.
2. **Set the items on the screen.**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target Memory/</td>
<td>Set the memory whose size is to be calculated, and memory card type. For</td>
</tr>
<tr>
<td>Memory Card Type</td>
<td>details of the memory card application, refer to the following manuals.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>File list</td>
<td>-</td>
</tr>
<tr>
<td>Target</td>
<td>Select data whose size is to be calculated.</td>
</tr>
</tbody>
</table>

3. **Click the** [Execute] **button.**

The **Memory Capacity Calculation Result** screen is displayed.

![Memory Capacity Calculation Result](image)

<For online calculation>

The offline calculation and online calculation can be switched.

For details of the Memory Capacity Calculation Result screen, refer to the following manual.

[GX Works2 Version 1 Operating Manual (Common)]
Calculating memory size (FXCPU)

Display sizes and capacities of program and symbolic information calculated offline. Displayed values are values when the program and parameters are written to a programmable controller CPU.

Operating procedure

- Select [Tool] ⇒ [Confirm Memory Size].

The Confirm Memory Size screen is displayed. For details, refer to the following manual.

GX Works2 Version 1 Operating Manual (Common)
3.1.5 Writing sequence programs to programmable controller CPU

Write created data to a programmable controller CPU or a memory card. Before writing data, set a communication route of a personal computer and programmable controller CPU with the connection destination setting. In addition, set the programmable controller CPU to the STOP status.

For details of connection destination setting, refer to the following manual.

GX Works2 Version 1 Operating Manual (Common)

Operating procedure

1. Select [Online] ⇒ [Write to PLC] ( ).

The Online Data Operation screen is displayed.
2. **Select the target data.**

Symbolic information must be selected. If symbolic information is not written, inconsistency may occur between the data on the project and the data written to the programmable controller CPU.

<table>
<thead>
<tr>
<th>Module Name/State Name</th>
<th>Title</th>
<th>Target</th>
<th>Detail</th>
<th>Last Change</th>
<th>Target Memory</th>
<th>Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>FXCPU</td>
<td>Symbolic Information</td>
<td>Program Memory(0)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>FXCPU</td>
<td>Program (Program File)</td>
<td>Program Memory(0)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>FXCPU</td>
<td>MAIN</td>
<td>Program Memory(0)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>FXCPU</td>
<td>Local Device Comment</td>
<td>Program Memory(0)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>FXCPU</td>
<td>Device Memory</td>
<td>Program Memory(0)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

3. **Click the [ ] Execute button.**

**Point**

- **Writing target for symbolic information**
  - When symbolic information is selected, the memory size for the symbolic information is required.
  - For QCPU/Q mode)/LCPU, the writing target for symbolic information can be changed to standard ROM or memory card (other than program memory or device memory), resulting that the capacity of program memory can be reserved.

- **Default writing target for symbolic information**
  - The default writing target for symbolic information can be set for each project.
  - Select [Tool] ⇒ [Options] ⇒ "Symbolic Information", and select a writing target from "Setting for Writing of Symbolic Information to PLC".

- **FXCPU**
  - Symbolic information can be read from/write to a programmable controller CPU in a project of FX3U/FX3UC version 3.00 or later only.
  - When a memory cassette to which the symbolic information has been written is used on an FXCPU other than FX3U/ FX3UC version 3.00 or later, the memory cassette can be used, however, the symbolic information cannot be read from the memory cassette. When the symbolic information is written to a memory cassette on an FXCPU other than FX3U/FX3UC version 3.00 or later, the symbolic information may be corrupted.
## Symbolic information

The symbolic information is data that store the program configuration such as labels and FBs. To restore these data included in the symbolic information when reading a program from the programmable controller CPU, write/read the symbolic information to/from the programmable controller CPU.

Data such as labels and FBs included in the symbolic information cannot be restored if only sequence programs are read.

The following table shows the program data included in the symbolic information.

<table>
<thead>
<tr>
<th>Item</th>
<th>Included data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Symbolic</td>
<td></td>
</tr>
<tr>
<td>information</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Global labels</td>
</tr>
<tr>
<td></td>
<td>POU</td>
</tr>
<tr>
<td></td>
<td>Programs</td>
</tr>
<tr>
<td></td>
<td>Local labels</td>
</tr>
<tr>
<td></td>
<td>FBs</td>
</tr>
<tr>
<td></td>
<td>Structures</td>
</tr>
</tbody>
</table>
3.2 Checking Operations of Sequence Programs

Execute the monitoring function to check the operation of the programs written to the programmable controller CPU. FB programs can also be monitored.

Operating procedure

• Select [Online] ⇒ [Monitor] ⇒ [Start Monitoring] ( ).

The monitoring starts.
Double-click the FB instance to monitor the FB program.

Double-click the FB instance.
3 - USING FUNCTION BLOCKS

Point

- **Change Instance (Function Block) screen**
  If monitoring is started on an FB program when FBs are used at multiple locations in a sequence program, the Change Instance (Function Block) screen is displayed. Select an instance.
  The screen can also be displayed by activating the FB program’s work window and selecting [Online] → [Monitor] → [Change Instance (Function Block)].

- **Ladder editing mode with option setting**
  When “Use the Switching Ladder Edit Mode (Read, Write, Monitor, Monitor (Write))” is selected in the option setting, the ladder programs cannot be edited when Start Monitoring is executed. Execute `monitor (write mode)` to edit the programs in the monitoring status.

---

GX Works2 Version 1 Operating Manual (Simple Project)
This chapter explains how to manage and edit FBs.
For the basic operations and screen details of GX Works2, refer to the following manual.
GX Works2 Version 1 Operating Manual (Common)

4.1 Reading FB Programs from Programmable Controller
    CPU 4 - 2
4.2 Reusing FBs from Library (Project) 4 - 3
4.3 Copying FBs from Project 4 - 9
4.4 Changing FB Instance Names 4 - 10
4.5 Deleting Unnecessary FB Data from Projects 4 - 11
4.6 Protecting FBs 4 - 13
4.7 Searching/Replacing FB Instance Names 4 - 16
4.1 Reading FB Programs from Programmable Controller CPU

Read FB programs from a programmable controller CPU. When reading FB programs, read symbolic information with a project with labels using the Read from PLC function. Before reading data, set a communication route of a personal computer and programmable controller CPU with the connection destination setting. For details of connection destination setting, refer to the following manual.

GX Works2 Version 1 Operating Manual (Common)

Operating procedure

1. Select [Online] ⇒ [Read from PLC].
   The Online Data Operation screen is displayed.

2. Select "Symbolic Information".

<table>
<thead>
<tr>
<th>Module Name/Data Name</th>
<th>Title/Project Name</th>
<th>Target</th>
<th>Detail</th>
<th>Last Change</th>
<th>Target Memory</th>
<th>Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>10000000 FXCPU</td>
<td>Symbolic Information</td>
<td></td>
<td></td>
<td>2011/03/08 12:05:46</td>
<td>Program Memory...</td>
<td>4718 Bytes</td>
</tr>
<tr>
<td>10000000 FXCPU</td>
<td>Symbolic Information</td>
<td></td>
<td></td>
<td>2011/03/08 12:05:46</td>
<td>Program Memory...</td>
<td>4718 Bytes</td>
</tr>
<tr>
<td>10000000 FXCPU</td>
<td>Symbolic Information</td>
<td></td>
<td></td>
<td>2011/03/08 12:05:46</td>
<td>Program Memory...</td>
<td>4718 Bytes</td>
</tr>
<tr>
<td>10000000 FXCPU</td>
<td>PLC/Communication</td>
<td></td>
<td></td>
<td>2011/03/08 12:05:46</td>
<td>Program Memory...</td>
<td>652 Bytes</td>
</tr>
<tr>
<td>10000000 FXCPU</td>
<td>Device Memory</td>
<td></td>
<td></td>
<td>2011/03/08 12:05:46</td>
<td>Device Memory</td>
<td>Device Data</td>
</tr>
</tbody>
</table>

3. Click the button.

Point:

- FXCPU
  For FXCPU projects with labels, created project data can be read from FX3u/FX3uc version 3.00 or later only.
4.2 Reusing FBs from Library (Project)

This section explains how to reuse the created FBs in another project. The created FB programs can be used as program assets in multiple projects by using the project files created in Simple project (with labels) as FB library.

4.2.1 Library (project) reusing procedure

The following shows the procedure for reusing the FBs in the created library (project) to other project.

Operating procedure

1. Creating a library (project).

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a Simple project (with labels).</td>
<td>GX Works2 Version 1</td>
</tr>
<tr>
<td>Name and save the project.</td>
<td>Operating Manual (Common)</td>
</tr>
<tr>
<td>Close the project.</td>
<td></td>
</tr>
</tbody>
</table>

2. Exporting FBs to a library (project).

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open the project that contains FBs to be reused.</td>
<td>GX Works2 Version 1</td>
</tr>
<tr>
<td></td>
<td>Operating Manual (Common)</td>
</tr>
<tr>
<td>Export FBs to the library (project).</td>
<td>Section 4.2.2</td>
</tr>
</tbody>
</table>

3. Acquiring FBs from the library (project).

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open the project to which FBs are to be used.</td>
<td>GX Works2 Version 1</td>
</tr>
<tr>
<td></td>
<td>Operating Manual (Common)</td>
</tr>
<tr>
<td>Acquire the FBs from the library (project).</td>
<td>Section 4.2.3</td>
</tr>
</tbody>
</table>
4.2.2 Exporting FBs to other project

Export the FBs which are created in the project being edited to other project using the Export FB to Library (Project) screen. Global labels and structures can be exported at the same time. An FB whose PLC type is different from that of the project being edited can be exported. However, FBs created with QCPU(Q mode)/LCPU project cannot be exported to FXCPU project, and vice versa.

Operating procedure

1. Select [Project] ⇒ [Library] ⇒ [Export FB to Library (Project)]

   The Export FB to Library (Project) screen is displayed.
2. Select FBs, global labels, and structures to be exported to the target project from the FB List.

   Click the [Dependent Element Selection] button to export the FBs or structures in the selected FBs at the same time.

3. Click the [Browse...] button to select the export target project.

4. Click the [OK] button.

   The selected FBs, global labels, and structures are exported to the target project.

- **Block password**
  
  An FB with a block password cannot be exported. Unlock the block password of the project being edited before export the FB.

  The block password of FB is unset to the export target project.

- **Considerations for "Indexing Setting for ZR Device"**
  
  FBs cannot be exported when the device set for "Indexing Setting for ZR Device" on the <<Device>> tab of PLC parameter is different between the target project and the project being edited.

  Set the same setting for "Indexing Setting for ZR Device" before exporting FBs.

  When an FB with the different start number of index register is exported, check the program using the index setting because the operation of the index setting may be changed.

- **When the data name of output target data is overlapped**
  
  When the data name of each export target FB, global label, or structure is overlapped, the existing data in the target project is overwritten and deleted.

  In this case, change the data name before exporting the data.
4.2.3 Importing FBs from other project

Import the FBs which are created in other project to the project being edited using the Import Library to Project screen. The global labels and the structures can be imported at the same time.
An FB whose PLC type is different from that of the project being edited can be imported.
However, FBs created with QCPU(Q mode)/LCPU project cannot be imported to FXCPU project, and vice versa.

Operating procedure

1. Select [Project] ⇒ [Library] ⇒ [Install].
   The Import Library to Project screen is displayed.

2. Select "Select Library (Project)" from the "Library List" combo box.

3. Click the Browse... button, and select the other project.

4. Click the Refresh FB List button.
   When the other project is modified, click the Refresh FB List button and update "FB List".
5. Select FBs, global labels, and structures to be imported to the editing project from the FB List.

Click the button to import the FBs or structures in the selected FBs at the same time.

![FB Selection Screen](image)

6. Click the OK button.

The imported FBs, global labels, and structures are displayed on the project view. For utilizing FBs, refer to Chapter 3.

**Point**

- **Considerations of "Indexing Setting for ZR Device"**
  FBs cannot be imported when the device set for "Indexing Setting for ZR Device" on the <<Device>> tab of PLC parameter is different between the source project and the project being edited.
  Set the same setting for "Indexing Setting for ZR Device", and import FBs.
  When an FB with the different start number of index register is imported, check the program using the index setting because the operation of the index setting may be changed.

- **When the data name of import source data is overlapped**
  When the data name of each import source FB, global label, or structure is overlapped, the existing data in the target project is overwritten and deleted.
  In this case, change the data name before importing the data.
### Setting the conversion method for inapplicable instructions

Set the conversion method when the FBs to be added contain instructions or devices which are not applicable to the target project.

#### Operating procedure

1. **Click the Conversion Method Setting button on the Install screen.**

   ![Conversion Method Setting](image)

   - **Item**: Conversion Method of Invalid Instructions and Devices
     - **Description**: Select the conversion method for the inapplicable instruction.

2. **Set the item on the screen.**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conversion Method of Invalid Instructions</td>
<td>Select the conversion method for the inapplicable instruction.</td>
</tr>
</tbody>
</table>

3. **Click the OK button.**

   The screen returns to the Install screen.
4.3 Copying FBs from Project

FBs can be reused by starting another GX Works2, and copying and pasting the FBs from the source project to the target project. This section explains how to reuse FBs in an existing project.

Operating procedure

1. Open the source project.

2. Start another GX Works2, and open the target project.
   If the programmable controller types differ between the two projects, match the programmable controller type. A programmable controller type can be changed by selecting [Project] ⇒ [Change PLC Type].

3. Move the FB data in the source project to "FB_Pool" in the target project with the drag-and-drop operation.

![Diagram showing FB data transfer from source to target project]

The FB data is copied to the project of the sequence program, and displayed on the Project view.

**Point**

- When reusing FBs created with GX Developer in GX Works2
  Open a project of GX Developer by selecting [Project] ⇒ [Open Other Data] ⇒ [Open Other Project].
  For considerations, refer to Appendix 3.
This section explains how to change the FB instance name of an FB pasted to a ladder program. The global label or local label need to be registered/changed to the same name as the changed FB instance name.

**Operating procedure**

1. Move the cursor to the FB instance.

2. Select [Edit] ⇒ [Edit FB Instance].
   The Edit FB Instance Name screen is displayed.

3. Enter a new FB instance name, and select "Change All" or "Change Only Selection FB".

4. Click the **OK** button.
   The FB instance name is changed.
   When "Change All" is selected, all the FB instances with the same name are changed.
   When "Change Only Selection FB" is selected, only the FB instance on the cursor position is changed.

5. Open the global label or local label setting screen, and register/change the label name to the same as the new FB instance name.
   If the program is compiled without registering/changes the label, a compilation error occurs.
4.5 Deleting Unnecessary FB Data from Projects

This section explains how to delete FB data from a project. FB instances and FB instance names registered to the global label or local label may be deleted at the same time.

**Operating procedure**

1. Select an FB to be deleted on the Project view.

2. Select [Project] ⇒ [Object] ⇒ [Delete].
   A confirmation message for deleting data is displayed.

3. Click the **Yes** button.
   A message for selecting the deletion method is displayed.
4. Select the deletion method, and click the **Yes** button.

The following are the targets to be deleted.

<table>
<thead>
<tr>
<th>Deletion method</th>
<th>Deletion target</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Delete the function block and the function block in the import target program&quot;</td>
<td>• FB data</td>
</tr>
<tr>
<td></td>
<td>• FB instance (including input circuits and output circuits)</td>
</tr>
<tr>
<td></td>
<td>• FB instance names registered on the label setting editor</td>
</tr>
<tr>
<td>&quot;Delete only function block&quot;</td>
<td>• FB data</td>
</tr>
</tbody>
</table>


4.6 Protecting FBs

Setting a block password protects created FB programs and disables browsing program contents. The following operations are disabled when a block password is set.
- Displaying and editing FB programs
- Editing FB local labels
- Copying data to other projects

**Operating procedure**

1. Select [Tool] ⇒ [Block Password].
   The Set Block Password screen is displayed.

   ![Set Block Password screen](image)

2. Select an FB to be protected, and click the Password Setting... button.
   The Change Block Password screen is displayed.

   ![Change Block Password screen](image)
3. Enter a password, and click the **OK** button.

On the "Registration Status" field of the Set Block Password screen, "Unlocked" is displayed.

![Set Block Password Screen]

4. Click the **OK** button.

The protection of the FB by the block password becomes effective when the project is saved and opened once again.

The lock marks are appended to the FB icons on the Project view.

![Project View with Locked FBs]

---

**Point**

- **Changing block passwords**

  To change a block password, simply set a new password for the POU to which a block password has already been set. However, the block password must be unlocked before changing it.
Unlocking block passwords

Unlock the block password.
Unlock of the block password is valid while the project is being opened. The lock status is restored when the project is opened again.

Operating procedure

1. Select [Tool] ⇒ [Block Password].

2. Select an FB to unlock the block password, and click the button. The Unlock Block Password screen is displayed.

3. Enter a password, and click the button. The block password is unlocked, and "Unlocked" is displayed on the "Registration Status" field of the Set Block Password screen.

Deleting block passwords

Delete the block password.

Operating procedure

1. Select [Tool] ⇒ [Block Password].

2. Select an FB to delete the block password, and click the button. The following message is displayed.

3. Click the button. The password is deleted.
4.7 Searching/Replacing FB Instance Names

FB instance names and labels can be searched/replaced. In this section, the search function is explained as an example.

Operating procedure

1. Select [Find/Replace] \(\Rightarrow\) [Find String].
   The Find/Replace screen is displayed.

2. Enter an FB instance name to be searched for "Find In", and click the button or the button.

   When the button is clicked, the cursor moves to the corresponding position.
   When the button is clicked, the search result is displayed. By double-clicking the row in the search result, the cursor jumps to the corresponding character string.
5 USING FB LIBRARIES

The FB Library is a collection of FBs and it is provided as MELSOFT Library. This chapter explains how to use the FB Library. For the overview of the FB Library, refer to the following manual.

GX Works2 Version 1 Operating Manual (Common)

Note that the FB Library is not supported by FXCPU.

5.1 Installing FB Library 5 - 2
5.2 Using FB Libraries 5 - 3
5.3 Displaying Reference Manual 5 - 5
5.4 Uninstalling FB Library 5 - 6
5.1 Installing FB Library

Install the FB Library.
Log onto the personal computer to which the FB Library is to be installed as a user with Administrator privilege, and install the FB Library.

5.1.1 Obtaining FB Library

Contact your local Mitsubishi representative to obtain the FB Library.

Point

- Compatible GX Works2 versions
  Install an FB library onto a personal computer on which GX Works2 Version 1.12N or a later is installed. Since compatible GX Works2 versions differ according to FB libraries, contact your local Mitsubishi representative for details.

5.1.2 Installing FB Library

Operating procedure

1. Decompress the installer file.

2. Double-click "setup.exe" in the decompressed folder.
   The installation is executed.
   Install the file according to the instructions on the screen.
   The FB Library and a reference manual are installed in the following folder.
   - When the installation path of GX Works2 is C:\Program Files\MELSOFT\GPPW2
     C:\Program Files\MELSOFT\GPPW2\MELSOFT\Library
5.2 Using FB Libraries

Import the installed FB libraries to a project.

**Operating procedure**

1. Select [Project] ⇒ [Library] ⇒ [Install].
   The Install screen is displayed.

2. Select a library from "Library List", and click the "Refresh FB List" button.
   "FB List" is updated.

3. Select FBs to be imported from "FB List".
4. Click the OK button.
   The imported FB library is displayed on the Project view.
   For the method for utilizing FBs, refer to Chapter 3.
   For the method for using FB libraries and the application of labels,
   refer to the FB library reference manual. (Section 5.3)

Point

● Editing FB libraries
   • Since a folder which contains FB library project files is for a system use, do not change the folder name or delete the
     folder. If the folder name is changed or the folder is deleted, a system malfunction may occur. In addition, do not
     store GX Works2 project files or any other files. For a location to which FB library project files are to be stored, refer
     to Section 5.1.2.
   • FB libraries (whose name starts with M+/P+) are read-only files. They can be deleted but cannot be edited. To edit a
     library, copy or paste FB library data after importing the library.

● Copying FB libraries
   FB library data can be copied or pasted even for projects with different programmable controller types as long as
   project types are identical.
5.3 Displaying Reference Manual

This section explains how to check the usage of the imported FB library and the application of labels.

Operating procedure

1. Select an FB from the Project view.

2. Right-click and select [Data Help] from the shortcut menu.
The reference manual of the selected FB data is displayed.

Point

Displaying reference manual from utilized FB
A reference manual can be displayed from the utilized FB of the FB library on the program. Select an FB on the project and press the key.
5.4 Uninstalling FB Library

This section explains how to uninstall the installed FB Library, using Windows® XP as an example.

Operating procedure

1. Select [Start] ⇒ [Control Panel] ⇒ [Add or Remove Programs].

2. Select "MELSOFT Library (Module Model)".

3. Click the **Remove** button.
   
   Uninstall the FB Library according to the instructions on the screen.
This chapter explains program examples using FBs.

6.1 System Configuration of Program Examples 6 - 2
6.2 Processing of Program Examples 6 - 3
6.3 Creating Program Examples 6 - 4
6.1 System Configuration of Program Examples

The following shows an example of system configuration. This system controls the operations of a conveyor using a CPU module, an input module, and an output module.

### Table: System Configuration

<table>
<thead>
<tr>
<th>No.</th>
<th>Category</th>
<th>Model name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Base unit</td>
<td>Q33B</td>
<td>-</td>
</tr>
<tr>
<td>2</td>
<td>Power supply module</td>
<td>Q62P</td>
<td>-</td>
</tr>
<tr>
<td>3</td>
<td>CPU module</td>
<td>Q02UCPU</td>
<td>-</td>
</tr>
<tr>
<td>4</td>
<td>Input module</td>
<td>QX40</td>
<td>Connect to the operation switch (X0) and sensor (X1).</td>
</tr>
<tr>
<td>5</td>
<td>Output module</td>
<td>QY40P</td>
<td>Connect to the conveyor driving relay (Y0) and buzzer (Y1).</td>
</tr>
</tbody>
</table>
When the number of boxes to be conveyed is set, and the operation switch is pressed, the conveyor starts to operate. When conveying the set number of boxes is completed, the conveyor stops. Buzzer sound is produced for three seconds when the operation is started and stopped.

Start

Turn the operation switch (X0) ON.

The buzzer (Y1) sounds for 3 seconds.

Operation of the conveyor (Y0) is started.

The sensor (X1) detects the conveyed boxes.

Count the number of conveyed boxes.

Has the set number of boxes been conveyed?

YES

The buzzer (Y1) sounds for 3 seconds again.

Operation of the conveyor (Y0) is stopped.

End

NO
6.3 Creating Program Examples

This section explains how to set FB local labels, and the examples of FB program and sequence program using FBs, based on the system configuration and processing aforementioned.

### Setting FB local labels

Set label names, classes, and data types as below.

<table>
<thead>
<tr>
<th>Class</th>
<th>Label name</th>
<th>Data type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>VAR_INPUT</td>
<td>FB_EN</td>
<td>Bit</td>
<td>Operation switch</td>
</tr>
<tr>
<td>VAR_INPUT</td>
<td>i_sensor</td>
<td>Bit</td>
<td>Sensor</td>
</tr>
<tr>
<td>VAR_OUTPUT</td>
<td>FB_ENO</td>
<td>Bit</td>
<td>FB is running</td>
</tr>
<tr>
<td>VAR_OUTPUT</td>
<td>FB_OK</td>
<td>Bit</td>
<td>Normal end</td>
</tr>
<tr>
<td>VAR_OUTPUT</td>
<td>o_conveyor</td>
<td>Bit</td>
<td>Conveyor</td>
</tr>
<tr>
<td>VAR_OUTPUT</td>
<td>o_buzzer</td>
<td>Bit</td>
<td>Buzzer</td>
</tr>
<tr>
<td>VAR_INPUT</td>
<td>i_counter</td>
<td>Word [signed]</td>
<td>Number of boxes to be conveyed</td>
</tr>
<tr>
<td>VAR</td>
<td>counter</td>
<td>Word [signed]</td>
<td>Remaining number of boxes to be conveyed</td>
</tr>
<tr>
<td>VAR</td>
<td>counter_end</td>
<td>Bit</td>
<td>Conveying completed</td>
</tr>
<tr>
<td>VAR</td>
<td>conveyor_end</td>
<td>Bit</td>
<td>Conveyor driving ended</td>
</tr>
<tr>
<td>VAR</td>
<td>timer1</td>
<td>Word [signed]</td>
<td>3-second measurement (operation start)</td>
</tr>
<tr>
<td>VAR</td>
<td>timer2</td>
<td>Word [signed]</td>
<td>3-second measurement (operation stop)</td>
</tr>
</tbody>
</table>

The following is a setting example displayed on the Function/FB Label Setting screen.

![Function/FB Label Setting screen](image)
6.3 Creating Program Examples

- **FB program example**

Create an FB program using labels which have been set. (Chapter 2)
6 PROGRAM EXAMPLES USING FUNCTION BLOCKS

Sequence program example using FBs

Paste FBs to a sequence program to create the input circuit and output circuit. (\textsuperscript{3} Chapter 3)
In the program example below, the number of boxes to be conveyed is six.

Sequence program example for increased number of conveyors

Converting conveyor control functions into components as FBs enables a sequence program to be easily altered when a conveyor which performs the same control is added.
The additional conveyor operation switch, sensor, conveyor driving relay, and buzzer are to be assigned X2, X3, Y2, and Y3 respectively.

In the program sample below, the number of boxes to be conveyed with the additional conveyor is 12.
APPENDIX

Appendix 1  Character Strings that cannot be Used for Label Names and FB Data Names/Instance Names  App - 2
Appendix 2  Supported CPU modules  App - 5
Appendix 3  Using FBs Created with GX Developer in GX Works2  App - 6
## Appendix 1  Character Strings that cannot be Used for Label Names and FB Data Names/Instance Names

Character strings used for application function names, common instruction names, special instruction names, instructions, etc. are called reserved words. These reserved words cannot be used for label names, FB data names, or FB instance names. If the character string defined as a reserved word is used, an error occurs during entry or compilation. The following tables show character strings that cannot be used for FB data names, FB instance names or label names.

<table>
<thead>
<tr>
<th>Category</th>
<th>Character string</th>
<th>FB data name/FB instance name</th>
<th>Label name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Class identifier</td>
<td>VAR, VAR_RETAIN, VAR_ACCESS, VAR_CONSTANT, VAR_CONSTANT_RETAIN, VAR_INPUT,</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>VAR_INPUT_RETAIN, VAR_OUTPUT, VAR_OUTPUT_RETAIN, VAR_EXTERNAL, VAR_EXTERNAL_CONSTANT, VAR_EXTERNAL_CONSTANT_RETAIN, VAR_EXTERNAL_RETAIN, VAR_GLOBAL, VAR_GLOBAL_CONSTANT, VAR_GLOBAL_CONSTANT_RETAIN, VAR_GLOBAL_RETAIN</td>
<td></td>
<td>×</td>
</tr>
<tr>
<td>Data type</td>
<td>BOOL, BYTE, INT, SINT, DINT, UINT, USINT, UDINT,</td>
<td></td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>ULINT, WORD, DWORD, LWORD, ARRAY, REAL, LREAL, TIME, STRING, TIMER, COUNTER,</td>
<td></td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>RETENTIVETIMER, POINTER, Bit, Word [Unsigned]/Bit String [16-bit], Double Word</td>
<td></td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>[Unsigned]/Bit String [32-bit], Word [Signed], Double Word [Signed], FLOAT</td>
<td></td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>(Single Precision), FLOAT (Double Precision), String, Time, Timer, Counter,</td>
<td></td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>Retentive Timer, Pointer</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Data type hierarchy</td>
<td>ANY, ANY_NUM, ANY_BIT, ANY_REAL, ANY_INT, ANY_DATE</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>ANY_SIMPLE, ANY16, ANY32</td>
<td>○</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SB, FX, FY, DX, DY, FD, TR, BL, , SG, UD, ZR, ZZ*1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Character string</td>
<td>Such as X0</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>recognized as device (Device name + Numerical)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ST operator</td>
<td>NOT, MOD</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>(., ) -</td>
<td>○</td>
<td></td>
</tr>
<tr>
<td>IL operator</td>
<td>LD, LDN, ST, STN, S, S1, R, R1, AND, ANDN, OR, ORN, OR, XOR, XORN, ADD, SUB,</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>MUL, DIV, GT, GE, EQ, NE, LE, LT, JMP, JMPC, JMC, CAL, CALC, CALCN, RET, RETC,</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>RETCN</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Application</td>
<td>LDI, LDP, LDF, ANI, ANDP, ANF, ANB, ORI, ORP, ORF, ORB, MPS, MRD, MPP, INV,</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td>instruction in GX</td>
<td>MEF, EGP, EGF, OUT(H), SET, RST, PLS, PLF, FF, DELTA(P), SFT(P), MC, MCR,</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Works2</td>
<td>STOP, PAGE, NOP, NOPLF</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SFC instruction</td>
<td>SFCP, SFCPEND, BLOCK, BEND, TRANL, TRANO, TRANA, TRANC, TRANCA, TRANOA, SEND,</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>TRANOC, TRANCO, STEP, STEP, STEPS, STEPS, STEPST, STEP, STEPS, STEPI, STEPD,</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>STEPS, STEPST, STEP, Tranj, TRANJ, TRANOCJ, TRANCJ, TRANCOJ, TRANCOCJ</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ST code body</td>
<td>RETURN, IF, THEN, ELSE, ELSIF, END_IF, CASE, OF, END_CASE, FOR, TO, BY, DO,</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>END_FOR, WHILE, REPEAT, UNTIL, END_REPEAT, EXIT, TYPE, END_TYPE, STRUCT, END_</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>STRUCT, RETAIN, VAR_ACCESS, END_VAR, FUNCTION, END_FUNCTION, FUNCTION_BLOCK,</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>END_FUNCTION BLOCK, STEP, INITIAL, STEP, END_STEP, TRANSITION, END_TRANSITION,</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>FROM, UNTILWHILE</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Appendix 1  Character Strings that cannot be Used for Label Names and FB Data Names/Instance Names

<table>
<thead>
<tr>
<th>Category</th>
<th>Character string</th>
<th>FB data name/FB instance name</th>
<th>Label name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function name in application function</td>
<td>Function names in application functions such as AND_E, NOT_E</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td>Function block name in application function</td>
<td>Function block names in application functions such as CTD, CTU</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td>Symbol</td>
<td>/, , ., ?, &lt;, &gt;, [ ], [ ], .., =, +=, %, !, ~, @, { }, &amp;, ^, ., tab character, ;, !, $, ×</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>Date and time literal</td>
<td>DATE, DATE_AND_TIME, DT, TIME, TIME_OF_DAY, TOD</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>Others</td>
<td>ACTION, END_ACTION, CONFIGURATION, END_CONFIGURATION, CONSTANT, F_EDGE, R_EDGE, AT, PROGRAM, WITH, END_PROGRAM, TRUE, FALSE, READ_ONLY, READ_WRITE, RESOURCE, ENDRESOURCE, ON, TASK, EN, ENO, BODY_CCE, BODY_FBD, BODY_IL, BODY_LD, BODY_SFC, BODY_ST, END_BODY, END_PARAMETER_SECTION, PARAM_FILE_PATH, PARAMETER_SECTION, SINGLE, RETAIN, INTERVAL</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>String that starts with K1 to K8</td>
<td>Such as K1AAA</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td>Address</td>
<td>Such as %IX0</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>Statement in Ladder Diagram</td>
<td>;FB BLK START, ;FB START, ;FB END, ;FB BLK END, ;FB IN, ;FB OUT, ;FB_NAME, ;INSTANCE_NAME, ;FB, ;INSTANCE</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>Common instruction</td>
<td>Such as MOV</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td>Windows® reserved word</td>
<td>COM1, COM2, COM3, COM4, COM5, COM6, COM7, COM8, COM9, LPT1, LPT2, LPT3, LPT4, LPT5, LPT6, LPT7, LPT8, LPT9, AUX, CON, PRN, NUL</td>
<td>×</td>
<td>○</td>
</tr>
</tbody>
</table>

**1:  Whether to handle a device name indexed with ZZ device as a reserved word depends on the parameter setting.
When Z device is specified for 32-bit index setting: Not handled as a reserved word.
When ZZ device is specified for 32-bit index setting: Handled as a reserved word.**
### Considerations for using labels

- In a function, the same name as the function cannot be used for a label.
- Inapplicable character strings differ between label names and data names such as FB data names and structure names. Therefore, if a label name which contains an FB data name or structure name is set when setting a label of instance or structure, an error may occur.
- A space cannot be used.
- A numeral cannot be used at the beginning of label name.
- A label name is not case-sensitive. An error may occur at compilation when the same label names with different cases (example: 'AAA' and 'aaa') are declared.
- In ST programs, the same label name can be used for a global label and local label by setting the following option.
  Select "Use the same label name in global label and local label" under [Tool] ⇒ [Options] ⇒ "Compile" ⇒ "Basic Setting".
- An underscore (_) cannot be used at the beginning or end of label name.
  Consecutive underscores (_) cannot be used for a data name or a label name.
- For Simple projects, function names and function block names in common instructions and application functions can be used.
# Appendix 2  Supported CPU modules

The following are the programmable controller CPUs with which the FBs can be used in GX Works2.

<table>
<thead>
<tr>
<th>Programmable controller series</th>
<th>Programmable controller type</th>
</tr>
</thead>
<tbody>
<tr>
<td>QCPU (Q mode)</td>
<td>Basic model QCPU (Q00J, Q00, Q01)</td>
</tr>
<tr>
<td></td>
<td>High-performance model QCPU (Q02, Q02H, Q06H, Q12H, Q25H)</td>
</tr>
<tr>
<td></td>
<td>Process CPU (Q02PH, Q06PH, Q12PH, Q25PH)</td>
</tr>
<tr>
<td></td>
<td>Redundant CPU (Q12PRH, Q25PRH)</td>
</tr>
<tr>
<td></td>
<td>Universal model QCPU (Q00UJ, Q00U, Q01U, Q02U, Q03UD, Q03UDV, Q04UDV, Q04UDEH, Q04UDV, Q06UDH, Q06UDV, Q10UDH, Q10UDEH, Q13UDH, Q13UDEH, Q13UDV, Q20UDH, Q20UDEH, Q26UDH, Q26UDEH, Q26UDV, Q50UDEH, Q100UDEH)</td>
</tr>
<tr>
<td>LCPU</td>
<td>L02S, L02S-P, L02, L02-P, L06, L06-P, L26, L26-P, L26-BT, L26-PBT</td>
</tr>
<tr>
<td>FXCPU</td>
<td>FX1S, FX1N, FX1NC, FX2N, FX2NC, FX3S, FX3G, FX3GC, FX3u, FX3uc</td>
</tr>
</tbody>
</table>
Appendix 3  Using FBs Created with GX Developer in GX Works2

FBs created with GX Developer can be used by selecting [Open Other Project] under [Project] ⇒ [Open Other Data], and open the project in GX Works2. Note that GX Works2 and GX Developer differ in the following points.

● Character strings that cannot be used for label names
  For unusable character strings with GX Developer, refer to the following manual.
  \(\text{GX Developer Version 8 Operating Manual}\)

● Usable instructions with ST programs
  Instruction names differ between GX Developer ST and GX Works2 ST.
  If compilation results in an error, change the relevant part to the instruction name of GX Works2.
  For the ST instructions of GX Developer and GX Works2, refer to the following.
  \(\text{GX Works2 Version 1 Operating Manual (Common)'s "ST instruction table for GX Works2 and GX Developer"}\)
  Alternatively, select "Use Dedicated Instruction for GX Developer, GX IEC Developer" under [Tool] ⇒ [Options] ⇒ "Project" ⇒ "Common Setting" ⇒ "Other Project Dedicated Instruction Setting".
"Enable calling function block and using inline ST" in the option setting

Depending on the selection status of "Enable calling function block and using inline ST" in "Enable calling function block and using inline ST" under [Tool] ⇒ [Options] ⇒ "Compile" ⇒ "Basic Setting", the program after compilation will differ.

When the option item is unselected, the program after the compilation matches with GX Developer, therefore, calling function blocks created with Structured Text from ladder programs and calling function blocks created with Ladder Diagram from ST programs are enabled.

Alternatively, when the option item is selected, calling an inline structured text and calling FBs from FB program are enabled.

However, the program after the compilation will be differ from that of GX Developer. Modify the program as necessary.

The differences with GX Developer are as follows:

<table>
<thead>
<tr>
<th>Difference</th>
<th>Operation in GX Developer and when option is not selected in GX Works2</th>
<th>Operation when the option is selected in GX Works2</th>
<th>Correction method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of steps after compilation</td>
<td>Since a temporary variable is assigned to the argument of FB, the number of steps will be increased after compilation.</td>
<td>Since an input/output variable is directly assigned to the argument of FB, the number of steps after the compilation will be decreased compared to that of GX Developer.</td>
<td>Check the influence of scan time due to decrease the number of steps.</td>
</tr>
<tr>
<td>Input variable</td>
<td>The value of an input variable can be changed in FB.</td>
<td>The value of an input variable cannot be changed in FB.</td>
<td>When changing the value of an input variable in FB, substitute the value to the label whose class is VAR.</td>
</tr>
<tr>
<td>Output variable</td>
<td>Initial value of output variable.</td>
<td>Initial value will be the value of device/label assigned to the argument.</td>
<td>When using the initial value, initialize the output variable in FB.</td>
</tr>
<tr>
<td>Connectable device</td>
<td>DY device can be connected.</td>
<td>DY device cannot be connected.</td>
<td>When output the value to DY device, modify the program.</td>
</tr>
<tr>
<td>Value of I/O variable</td>
<td>The value of input side of device/label is not changed. The operation result is returned only to device/label of the output side.</td>
<td>The value of input side and output side will be the same.</td>
<td>To make the value of device/label of input side not to be changed, modify the local label setting of the FB.</td>
</tr>
<tr>
<td>Connectable elements</td>
<td>Two or more contacts or the comparison operation contact can be connected to input side.</td>
<td>Two or more contacts or the comparison operation contact cannot be connected to input side.</td>
<td>When connecting two or more contacts or comparison operation contact to FB, modify the local label settings of the FB.</td>
</tr>
<tr>
<td>Connection of constant</td>
<td>A constant can be connected to input side.</td>
<td>A constant cannot be connected to input side.</td>
<td>When connecting a constant to I/O variable, modify the local label settings of the FB.</td>
</tr>
</tbody>
</table>

*1 : Output FB to other device/label once, and then output it to DY in a rung other than the FB is used as follows:

```
( 3 )

X0

B IN1

F B I

OUT 1 B

(Bit1)

(17)

BIT1

(DY1)
```

*2 : Use VAR_INPUT and VAR_OUTPUT instead of VAR_IN_OUT as follows:

```
( 2 )

[C110]

IN OUT1

INOUTW [CO10]

F B I

OUT [CO20]
```

```
( 2 )

[C110]

OUT

F B I

OUT [CO20]
```
**APPENDIX**

*3:  Use VAR_INPUT and VAR_OUTPUT instead of VAR_IN_OUT as follows:

```
  | x0 | x1 | x2 |
  |-----------------|
  | FB1_1 | FB1_0 |
  | FB3_1     |
```

*4:  Use VAR_INPUT and VAR_OUTPUT instead of VAR_IN_OUT as follows:

```
  | x0 | x1 | x2 |
  |-----------------|
  | K100           |
  | FB1_1 | FB1_0 |
```

[A]
Assigning devices automatically ........................................... 2-9
   FXCPU ................................................................. 2-10
   QCPU (Q mode)/LCPU ........................................... 2-9

[B]
block password .......................................................... 4-13
   Deleting .............................................................. 4-15
   Setting .................................................................... 4-13
   Unlocking ............................................................. 4-15

[C]
Calculating memory size (FXCPU) .................................... 3-15
Calculating memory size (QCPU(Q mode)/LCPU) ............. 3-13
Change Instance (Function Block) screen ......................... 3-20
Checking Operations of Sequence Programs ............. 3-19
Classes ...................................................................... 2-5
Comment .................................................................... 3-8
Compatible CPU ......................................................... App-5
Compile ...................................................................... 3-12
Considerations of automatically assigned devices ....... 2-11
Converting .................................................................. 2-13
Converting/compiling ............................................... 3-12
Creating Projects for FBs .......................................... 2-2
Creating Sequence program ......................................... 3-2

[D]
Data name ..................................................................... 2-3, 3-2, 3-4
   Character strings that cannot be used ....................... App-2
Data types ..................................................................... 2-6
Device/Label Automatic-Assign Setting ....................... 2-9
Docking window ........................................................ 1-9

[E]
Element Selection window ............................................... 1-9

[F]
FB .............................................................................. 1-2
   Create FBs .......................................................... 2-1
   Creating New FB Data ........................................ 2-3
   Programming Flow with FBs .................................. 1-5
   Protecting ............................................................. 4-13
   FB component ..................................................... 1-9
   FB data ..................................................................... 1-9
   Deleting ................................................................. 4-11
   FB instance .......................................................... 1-9
   Creating input and output circuits ......................... 3-6
   FB instance name ................................................ 3-2
      Changing .......................................................... 4-10
      Character strings that cannot be used ............... App-2
      Searching/Replacing ........................................ 4-16
   FB Label Setting screen ...................................... 1-10, 2-4
   FB Libraries .......................................................... 5-1
   Displaying the Reference Manual ......................... 5-5
   Importing to a project ........................................ 5-3
   Installing ............................................................... 5-2
   Obtaining ............................................................. 5-2
   Uninstalling .......................................................... 5-6
   FB Programs .......................................................... 2-12
      Aligning programs .......................................... 3-11
      Considerations ................................................ 2-14
      Converting ....................................................... 2-13
      Creating .......................................................... 2-12
      Reading from Programmable Controller CPU .... 4-2
   FBs ........................................................................ 3-9
      Considerations for using FBs ............................. 3-9
      Paste ................................................................. 3-2
   FBs Created with GX Developer ............................. App-6
   Function Blocks (FB) ............................................. App-1
   Features of FBs ..................................................... 1-3

[G]
Global labels ............................................................... 1-4

[L]
Label name .................................................................. 2-4, 3-2, 3-4
Labels .......................................................................... 1-4
   Character strings that cannot be used ....................... App-2
   Ladder editing mode ............................................... 3-20
   Local labels .......................................................... 1-4
   Setting ..................................................................... 2-4

[M]
Maximum number of input/output labels ....................... 2-5
Monitor ........................................................................ 3-19

[N]
Navigation window .......................................................... 1-9

[O]
Output window ........................................................... 3-12

[P]
password ..................................................................... 4-13
   Program examples .................................................. 6-1
   Program size after compilation ............................. 3-13

[R]
Read from PLC .......................................................... 4-2
   Rebuild All ........................................................... 3-12
   Reusing ................................................................. 3-2

[S]
Selecting data types ....................................................... 2-7
   Setting arrays for data type .................................. 2-8
Symbolic information ...................................................... 3-18
Default writing target ............................................... 3-17
Writing target ........................................................... 3-17

[U]
Utilizing ............................................................................. 4-9

[W]
Work window .................................................................... 1-9
Write to PLC ................................................................... 3-16
Writing sequence programs ........................................... 3-16
Specifications subject to change without notice.

When exported from Japan, this manual does not require application to the Ministry of Economy, Trade and Industry for service transaction permission.