SAFETY PRECAUTIONS

(Always read these instructions before using this product.)

Before using this product, thoroughly read this manual and the relevant manuals introduced in this manual and pay careful attention to safety and handle the products properly.

The precautions given in this manual are concerned with this product. For the safety precautions of the programmable controller system, refer to the User’s Manual for the CPU module.

In this manual, the safety precautions are ranked as "⚠️ WARNING" and "⚠️ CAUTION".

⚠️ WARNING Indicates that incorrect handling may cause hazardous conditions, resulting in death or severe injury.

⚠️ CAUTION Indicates that incorrect handling may cause hazardous conditions, resulting in minor or moderate injury or property damage.

Note that the ⚠️ CAUTION level may lead to serious consequences according to the circumstances. Always follow the precautions of both levels because they are important for personal safety.

Please save this manual to make it accessible when required and always forward it to the end user.

[Design Precautions]

⚠️ WARNING

● When data change, program change, or status control is performed from a personal computer to a running programmable controller, create an interlock circuit outside the programmable controller to ensure that the whole system always operates safely.

Furthermore, for the online operations performed from a personal computer to a programmable controller CPU, the corrective actions against a communication error due to such as a cable connection fault should be predetermined as a system.

⚠️ CAUTION

● The online operations performed from a personal computer to a running CPU module (especially program change, forced output operation, and operating status change) have to be executed after the manual has been carefully read and the safety has been ensured.

Failure to do so may cause a miss operation which results in machine damage or an accident.
• CONDITIONS OF USE FOR THE PRODUCT •

(1) Mitsubishi programmable controller ("the PRODUCT") shall be used in conditions;
   i) where any problem, fault or failure occurring in the PRODUCT, if any, shall not lead to any major or serious accident; and
   ii) where the backup and fail-safe function are systematically or automatically provided outside of the PRODUCT for the case of any problem, fault or failure occurring in the PRODUCT.

(2) The PRODUCT has been designed and manufactured for the purpose of being used in general industries. MITSUBISHI SHALL HAVE NO RESPONSIBILITY OR LIABILITY (INCLUDING, BUT NOT LIMITED TO ANY AND ALL RESPONSIBILITY OR LIABILITY BASED ON CONTRACT, WARRANTY, TORT, PRODUCT LIABILITY) FOR ANY INJURY OR DEATH TO PERSONS OR LOSS OR DAMAGE TO PROPERTY CAUSED BY the PRODUCT THAT ARE OPERATED OR USED IN APPLICATION NOT INTENDED OR EXCLUDED BY INSTRUCTIONS, PRECAUTIONS, OR WARNING CONTAINED IN MITSUBISHI'S USER, INSTRUCTION AND/OR SAFETY MANUALS, TECHNICAL BULLETINS AND GUIDELINES FOR the PRODUCT.
("Prohibited Application")

Prohibited Applications include, but not limited to, the use of the PRODUCT in;

• Nuclear Power Plants and any other power plants operated by Power companies, and/or any other cases in which the public could be affected if any problem or fault occurs in the PRODUCT.
• Railway companies or Public service purposes, and/or any other cases in which establishment of a special quality assurance system is required by the Purchaser or End User.
• Aircraft or Aerospace, Medical applications, Train equipment, transport equipment such as Elevator and Escalator, Incineration and Fuel devices, Vehicles, Manned transportation, Equipment for Recreation and Amusement, and Safety devices, handling of Nuclear or Hazardous Materials or Chemicals, Mining and Drilling, and/or other applications where there is a significant risk of injury to the public or property.

Notwithstanding the above, restrictions Mitsubishi may in its sole discretion, authorize use of the PRODUCT in one or more of the Prohibited Applications, provided that the usage of the PRODUCT is limited only for the specific applications agreed to by Mitsubishi and provided further that no special quality assurance or fail-safe, redundant or other safety features which exceed the general specifications of the PRODUCTs are required. For details, please contact the Mitsubishi representative in your region.
**REVISIONS**

*The manual number is given on the bottom left of the back cover.*

<table>
<thead>
<tr>
<th>Print Date</th>
<th><em>Manual Number</em></th>
<th>Revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feb., 2003</td>
<td>SH(NA)-080375E-A</td>
<td>First edition</td>
</tr>
<tr>
<td>Jun., 2004</td>
<td>SH(NA)-080375E-B</td>
<td>Correction</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Abbreviations and Generic Terms in This Manual</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Chapter 1</td>
</tr>
<tr>
<td>Aug., 2005</td>
<td>SH(NA)-080375E-C</td>
<td>Correction</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Section 3.7, Section 3.11</td>
</tr>
<tr>
<td>Apr., 2007</td>
<td>SH(NA)-080375E-D</td>
<td>Correction</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Section 3.6.2, Section 3.12.5, Section 3.13.3</td>
</tr>
<tr>
<td>Jul., 2007</td>
<td>SH(NA)-080375E-E</td>
<td>Addition</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Abbreviations and Generic Terms in This Manual, Section 3.9.2, Section 3.9.3, Section 3.12.5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Correction</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Section 3.12.5 to 3.12.12 are changed to Section 3.12.6 to 3.12.13.</td>
</tr>
<tr>
<td>Dec., 2008</td>
<td>SH(NA)-080375E-F</td>
<td>Correction</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Abbreviations and Generic Terms in This Manual, Section 2.3</td>
</tr>
<tr>
<td>Jan., 2010</td>
<td>SH(NA)-080375E-G</td>
<td>Addition</td>
</tr>
<tr>
<td></td>
<td></td>
<td>CONDITIONS OF USE FOR THE PRODUCT</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Correction</td>
</tr>
<tr>
<td></td>
<td></td>
<td>SAFETY PRECAUTIONS, INTRODUCTION, About Manuals, Abbreviations and Generic Terms in This Manual, Chapter 1, Section 2.2, Section 2.3, Section 2.4, Section 3.4.5, Section 3.5, Section 3.7, Section 3.9, Section 3.9.2, Section 3.9.3</td>
</tr>
</tbody>
</table>

This manual confers no industrial property rights or any rights of any other kind, nor does it confer any patent licenses. Mitsubishi Electric Corporation cannot be held responsible for any problems involving industrial property rights which may occur as a result of using the contents noted in this manual.

© 2003 MITSUBISHI ELECTRIC CORPORATION
INTRODUCTION

Thank you for choosing the Mitsubishi MELSOFT series Integrated FA software. Read this manual and make sure you understand the functions and performance of MELSEC series programmable controller thoroughly in advance to ensure correct use.

CONTENTS

<table>
<thead>
<tr>
<th>Section</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAFETY INSTRUCTIONS</td>
<td>A - 1</td>
</tr>
<tr>
<td>CONDITIONS OF USE FOR THE PRODUCT</td>
<td>A - 2</td>
</tr>
<tr>
<td>REVISIONS</td>
<td>A - 3</td>
</tr>
<tr>
<td>INTRODUCTION</td>
<td>A - 4</td>
</tr>
<tr>
<td>CONTENTS</td>
<td>A - 4</td>
</tr>
<tr>
<td>About Manuals</td>
<td>A - 6</td>
</tr>
<tr>
<td>Abbreviations and Generic Terms in This Manual</td>
<td>A - 7</td>
</tr>
</tbody>
</table>

1. OVERVIEW 1 - 1 to 1 - 2

1.1 Features ........................................................................................................... 1 - 2

2. MELSAP-L FORMAT PROGRAMS 2 - 1 to 2 - 7

2.1 MELSAP-L Format SFC Diagrams ........................................................................ 2 - 1
2.2 Operation Output Instructions ........................................................................ 2 - 2
2.3 Instructions for Transition Conditions ........................................................... 2 - 3
2.4 Precautions to Observe When Creating Programs ............................................ 2 - 5

3. MELSAP-L PROGRAM EDITING METHOD 3 - 1 to 3 - 52

3.1 MELSAP-L Program Editing Outline Procedure .................................................. 3 - 1
3.2 List of SFC Diagram Symbols .............................................................................. 3 - 3
3.3 Basic SFC Diagram Editing Screen ...................................................................... 3 - 5
3.4 Creating/Modifying the SFC Diagram .................................................................. 3 - 7
  3.4.1 Writing an SFC diagram ................................................................................ 3 - 7
  3.4.2 Deleting the SFC diagram ........................................................................... 3 - 19
  3.4.3 Changing the step attribute ...................................................................... 3 - 20
  3.4.4 Cutting/Copying and pasting the SFC diagram ....................................... 3 - 21
  3.4.5 Sorting the SFC diagram ...................................................................... 3 - 24
  3.4.6 Redisplaying the SFC diagram .............................................................. 3 - 25
3.5 Creating Operation Outputs and Transition Conditions ..................................... 3 - 26
3.6 Comment Creation Method .................................................................................. 3 - 27
  3.6.1 Method of creating an SFC comment ......................................................... 3 - 27
  3.6.2 Method of creating a device comment ....................................................... 3 - 29
3.7 Setting the Block Information .......................................................................... 3 - 30
3.8 Displaying the Block List ................................................................................... 3 - 31
3.9 SFC-Related Parameter Settings ......................................................................... 3 - 32
  3.9.1 SFC setting in PLC parameters ............................................................... 3 - 32
  3.9.2 Setting the block parameters ................................................................. 3 - 33
  3.9.3 SFC program setting ................................................................................ 3 - 34
3.10 Conversion Operation ....................................................................................... 3 - 34
3.11 Instructions for Online SFC Program Writing .............................................................................. 3 - 35
3.12 Search and Replacement .................................................................................................................. 3 - 36
  3.12.1 Searching for a device .............................................................................................................. 3 - 36
  3.12.2 Searching for an instruction .................................................................................................... 3 - 37
  3.12.3 Searching for a character string ............................................................................................... 3 - 38
  3.12.4 Searching for the Step No./Block No. ..................................................................................... 3 - 38
  3.12.5 Searching for a device comment ............................................................................................... 3 - 39
  3.12.6 Replacing the devices ............................................................................................................... 3 - 39
  3.12.7 Replacing the instructions ........................................................................................................ 3 - 41
  3.12.8 Replacing the open/close contacts ............................................................................................ 3 - 43
  3.12.9 Replacing a character string ..................................................................................................... 3 - 44
  3.12.10 Replacing the Step No. .......................................................................................................... 3 - 45
  3.12.11 Listing contacts/coils used .................................................................................................... 3 - 46
  3.12.12 Searching for the device use status ....................................................................................... 3 - 46
  3.12.13 Changing the T/C set values ................................................................................................ 3 - 46
3.13 Providing Displays .......................................................................................................................... 3 - 47
  3.13.1 Displaying programs .................................................................................................................. 3 - 47
  3.13.2 Displaying the step/transition comments ............................................................................... 3 - 48
  3.13.3 Displaying an alias in the SFC diagram .................................................................................. 3 - 49
  3.13.4 Displaying a program in the MELSAP3 format ....................................................................... 3 - 50
3.14 Setting the SFC Diagram Display .................................................................................................. 3 - 51
  3.14.1 Setting the SFC diagram display .............................................................................................. 3 - 51
  3.14.2 Setting the SFC setting options ............................................................................................... 3 - 52
4. MONITORING AND TEST FUNCTIONS ......................................................................................... 4 - 1 to 4 - 7
  4.1 SFC Diagram Monitor .................................................................................................................... 4 - 1
  4.2 Transition Watchdog Monitor ....................................................................................................... 4 - 4
  4.3 All Block Batch Monitor and Active Step Monitor ...................................................................... 4 - 5
  4.4 Block List Monitor ......................................................................................................................... 4 - 6
  4.5 Device Test ................................................................................................................................... 4 - 7
5. PRINTING SFC DIAGRAMS ............................................................................................................. 5 - 1 to 5 - 7
  5.1 SFC Diagram Print Setting ........................................................................................................... 5 - 1
  5.2 SFC Diagram Printing Examples ................................................................................................ 5 - 2
INDEX ............................................................................................................................................... Index - 1 to Index - 2
About Manuals

The manuals related to this product are shown below. Refer to the following table when ordering required manuals.

<table>
<thead>
<tr>
<th>Manual Name</th>
<th>Manual Number (Model Code)</th>
</tr>
</thead>
<tbody>
<tr>
<td>GX Developer Version 8 Operating Manual (Startup)</td>
<td>SH-080372E (13JU40)</td>
</tr>
<tr>
<td>Explains the system configuration, installation method and start-up procedure of GX Developer.</td>
<td>(Sold separately)</td>
</tr>
<tr>
<td>GX Developer Version 8 Operating Manual</td>
<td>SH-080373E (13JU41)</td>
</tr>
<tr>
<td>Explains operation methods such as creating, printing, monitoring, and debugging programs using GX Developer.</td>
<td>(Sold separately)</td>
</tr>
<tr>
<td>GX Developer Version 8 Operating Manual (SFC)</td>
<td>SH-080374E (13JU42)</td>
</tr>
<tr>
<td>Explains the editing and monitoring operations of the SFC functions using GX Developer.</td>
<td>(Sold separately)</td>
</tr>
<tr>
<td>MELSEC-Q/L/QnA Programming Manual (MELSAP-L)</td>
<td>SH-080076 (13JF61)</td>
</tr>
<tr>
<td>Explains the necessary programming method, specifications and functions for creating programs using the MELSAP-L format.</td>
<td>(Sold separately)</td>
</tr>
</tbody>
</table>

REMARK

The Operating Manuals are included on the CD-ROM of the software package in a PDF file format. Manuals in printed form are sold separately for single purchase. Order a manual by quoting the manual number (model code) listed in the table above.
This manual uses the generic terms and abbreviations listed in the following table to discuss the software packages and programmable controller CPUs. Corresponding module models are also listed if needed.

<table>
<thead>
<tr>
<th>Generic terms and abbreviations</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MELSAP-L</td>
<td>Abbreviation for an SFC function in the MELSAP-L format.</td>
</tr>
<tr>
<td>MELSAP-II/3</td>
<td>Generic term for an SFC function in the MELSAP-II or MELSAP3 format.</td>
</tr>
<tr>
<td>SFC program</td>
<td>Generic term for a program in the MELSAP-L, MELSAP-II or MELSAP3 format.</td>
</tr>
<tr>
<td>Basic model QCPU</td>
<td>Generic term for Q00JCPU, Q00CPU and Q01CPU.</td>
</tr>
<tr>
<td>High Performance model QCPU</td>
<td>Generic term for Q02(H)CPU, Q06CPU, Q12HCPU and Q25HCPU.</td>
</tr>
<tr>
<td>Universal model QCPU</td>
<td>Generic term for Q00UJCPU, Q00UCPU, Q01UCPU, Q02UCPU, Q03UDCPU, Q03UDECPU, Q04UDHCPU, Q04UDEHCPU, Q06UDHCPU, Q06UDEHCPU, Q10UDHCPU, Q10UDEHCPU, Q13UDHCPU, Q13UDEHCPU, Q20UDHCPU, Q20UDEHCPU, Q26UDHCPU and Q26UDEHCPU.</td>
</tr>
<tr>
<td>Process CPU</td>
<td>Generic term for Q02PHCPU, Q06PHCPU, Q12PHCPU and Q25PHCPU.</td>
</tr>
<tr>
<td>Redundant CPU</td>
<td>Generic term for Q12PRHCPU and Q25PRHCPU.</td>
</tr>
<tr>
<td>QCPU (Q mode)</td>
<td>Generic term for Q00J, Q00UJ, Q00, Q00U, Q01, Q01U, Q02(H), Q02PH, Q02U, Q03UD, Q03UDE, Q04UDH, Q04UDEH, Q06H, Q06PH, Q06UDH, Q06UDEH, Q10UDH, Q10UDEH, Q12H, Q12PH, Q12PRH, Q13UDH, Q13UDEH, Q20UDH, Q20UDEH, Q25H, Q25PH, Q25PRH, Q26UDH and Q26UDEHCPU.</td>
</tr>
<tr>
<td>QCPU (A mode)</td>
<td>Generic term for Q02(H)CPU-A and Q06HCPU-A. Described as ACPU in the main text.</td>
</tr>
<tr>
<td>LCPU</td>
<td>Generic term for L02CPU and L26CPU-BT.</td>
</tr>
<tr>
<td>QnACPU</td>
<td>Generic term for programmable controller available with MELSEC-QnA.</td>
</tr>
<tr>
<td>ACPU</td>
<td>Generic term for programmable controller available with MELSEC-A. Including MOTION (SCPU). (However, GPPW does not support A1, A2, A3, AH3, A3M, A52G, A73, A0J2 and A3V.)</td>
</tr>
<tr>
<td>FXCPU</td>
<td>Generic term for programmable controller available with MELSEC-F.</td>
</tr>
<tr>
<td>GX Developer</td>
<td>Generic product name for SW8D5C-GPPW-E, SW8D5C-GPPW-EA, SW8D5C-GPPW-EV and SW8D5C-GPPW-EVA product types.</td>
</tr>
<tr>
<td>GPPQ</td>
<td>Abbreviation for an SW□IVD-GPPQ or SW□NX-GPPQ format software package.</td>
</tr>
<tr>
<td>GPPA</td>
<td>Abbreviation for an SW□SRXV-GPPA, SW□NX-GPPA or SW□IVD-GPPA format software package.</td>
</tr>
<tr>
<td>Software package for motion controller</td>
<td>Generic term for software packages for the motion controller which allow SFC programs to be edited.</td>
</tr>
</tbody>
</table>
1. OVERVIEW

This manual describes the editing and monitoring operations of the MELSAP-L format SFC functions (hereafter abbreviated to MELSAP-L), which are included in the functions of GX Developer (unless otherwise specified, the product GX Developer herein is its English version 8.)

For a description of functions other than MELSAP-L, and also the specifications of SFC programs, please refer to the relevant manuals indicated in "Related Manuals".

SFC means Sequential Function Chart.

MELSAP-L is a description format which is intended to promote efficiency of sequence program development and also to making program a part.

The machine control section can be created as a part by describing the flow of operation and the control of the machine separately, that is, by describing the operation sequence of the machine using MELSAP-L, and the control of the machine including the various interlocks using a sequence program (circuit/list).

The system is designed in such a way that output conditions, such as interlocks, cannot be described at the steps in MELSAP-L. This permits prompt rectification of trouble that occurs if an output fails to appear at a step despite the activation of the step.

(1) Creation using MELSAP-L + sequence program

(a) MELSAP-L side
   By creating an SFC program that is related to the interlock conditions, the flow of operation is easy to understand.

(b) Sequence program side
   By creating conditions regardless of the flow of operation, it can be created as a part.
(2) Description format in MELSAP-L

The description format inside the steps and transition conditions of MELSAP-L are as follows.

<Example>

Step

\[ \text{DMOV K10 W0} \]

Transition conditions

\[ \text{X0} \]

You cannot describe contact-equivalent instructions inside steps.

The PLC types that are compatible with MELSAP-L in the GX Developer are as follows.

- Basic model QCPU
- High Performance model QCPU
- Process CPU
- Redundant CPU
- Universal model QCPU
- LCPU

If the PLC type is changed to one other than mentioned above, the MELSAP-II or MELSAP3 format is used.

1.1 Features

The features of MELSAP-L are described below.

(1) The operation sequence and ON/OFF status of devices can be monitored on the same screen.

SFC diagram monitoring employs automatic scrolling, enabling the operation sequence and configuration at each step to be readily grasped.

In addition, programs (instructions) can be described directly on an SFC diagram, permitting the ON/OFF status of a contact and coil with two or more operation outputs and transition conditions to be monitored on the same screen.

(2) Highly operable editing functions

Editing by means of programming, cut & copy & paste can be done using the function keys, tool buttons, menu bars, and so on.

SFC diagram editing can also be done for other projects, programs and blocks. (Cut & copy & paste is intended for use between MELSAP-L programs.)

(3) The display format can be changed over according to the particular situation.

The display format of a MELSAP-L format program can changed over to the MELSAP3 format by the GX Developer display menu.

If you wish to display the transition conditions and operation outputs as a ladder, display them in the MELSAP3 format.
2. MELSAP-L FORMAT PROGRAMS

This section describes SFC programs in the MELSAP-L format.

2.1 MELSAP-L Format SFC Diagrams

In an SFC program created in the MELSAP-L format, each operation unit in a series of operations of the machine is expressed as one step, and instructions such as contacts and coils that perform actual control are set at each step.

In MELSAP3, the SFC diagram is divided into an SFC diagram that indicates the operation sequence, and a Zoom diagram that indicates detailed control for each transition condition. In MELSAP-L, on the other hand, control instructions are directly described and indicated on an SFC diagram.

MELSAP-L is a simple display format that does not display notes, device comments or contacts to the operation outputs (contact-equivalent instructions). Device comments can be set in this format.

If you use the MELSAP-L format to display an SFC program that contains notes and contacts to the operation outputs (contact-equivalent instructions) that were edited in the MELSAP3 format, "???.." will be displayed.

For details of the "???.." indication, refer to section 2.4.
2.2 Operation Output Instructions

(1) MELSAP-L format instructions

In MELSAP-L, operation output instructions are described in the following format.

<table>
<thead>
<tr>
<th>Instruction</th>
<th>Example of MELSAP-L format</th>
<th>Example of list format</th>
<th>Example of circuit symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output(o)</td>
<td>oY70</td>
<td>OUT Y70</td>
<td>![Circuit Symbol]</td>
</tr>
<tr>
<td>High speed timer (h)</td>
<td>hT0 K100</td>
<td>OUTH T0 K100</td>
<td>![Circuit Symbol]</td>
</tr>
<tr>
<td>Set (s)</td>
<td>sM100</td>
<td>SET M100</td>
<td>![Circuit Symbol]</td>
</tr>
<tr>
<td>Reset (r)</td>
<td>rM200</td>
<td>RST M200</td>
<td>![Circuit Symbol]</td>
</tr>
<tr>
<td>Instructions other than the above (o, h, s, r) are the same as in the list format.</td>
<td>MOV K100 D0</td>
<td>MOV K100 D0</td>
<td>![Circuit Symbol]</td>
</tr>
</tbody>
</table>

To put a number of operation outputs in parallel inside the same step, partition each output with a comma (,).

<table>
<thead>
<tr>
<th>MELSAP-L format</th>
<th>Circuit</th>
</tr>
</thead>
<tbody>
<tr>
<td>oY70,sM100,MOV K100, D0</td>
<td>![Circuit Diagram]</td>
</tr>
</tbody>
</table>

(2) Instructions that cannot be described at operation outputs

The following instructions cannot be input to operation outputs in MELSAP-L.

- NOP
- MPS, MRD, MPP
- Contact instruction
- Comparison operation instruction (=, <, >, etc.)

For details, refer to the MELSEC-Q/L/QnA Programming Manual (MELSAP-L).

(3) Precautions to observe when describing operation outputs

- Describe an instruction not requiring execution conditions (DI, EI, etc.) at the end of each operation output.

  Example: oY70, MOV D0 D100, DI  Correct
            DI, oY70, MOV D0 D100   Incorrect

- You can describe up to 24 instructions in one operation output.
### 2.3 Instructions for Transition Conditions

(1) MELSAP-L format instructions

In MELSAP-L, transition conditions are described in the following format.

<table>
<thead>
<tr>
<th>Instruction</th>
<th>Example of MELSAP-L format</th>
<th>Example of list format</th>
<th>Example of circuit symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open contacts (a)</td>
<td>aX0</td>
<td>LD X0</td>
<td><img src="X0" alt="Circuit Symbol" /></td>
</tr>
<tr>
<td>Close contacts (b)</td>
<td>bX10</td>
<td>LDI X10</td>
<td><img src="X10" alt="Circuit Symbol" /></td>
</tr>
<tr>
<td>Rise contacts (p)</td>
<td>pM100</td>
<td>LDP M100</td>
<td><img src="M100" alt="Circuit Symbol" /></td>
</tr>
<tr>
<td>Fall contacts (f)</td>
<td>fM200</td>
<td>LDF M200</td>
<td><img src="M200" alt="Circuit Symbol" /></td>
</tr>
<tr>
<td>Comparison operation instruction*1 (=, &lt;, &gt;, etc.)</td>
<td>= D0 K100</td>
<td>LD = D0 K100</td>
<td>![Circuit Symbol](D0 K100)</td>
</tr>
</tbody>
</table>

*1: For details of comparison operation instructions, refer to the MELSEC-Q/L Programming Manual (Common Instructions).

To connect contact instructions in series (AND), separate each instruction using "&". To connect contact instructions in parallel (OR), separate each instruction using " | ".

<table>
<thead>
<tr>
<th>MELSAP-L format</th>
<th>Circuit</th>
</tr>
</thead>
<tbody>
<tr>
<td>aX0 &amp; aX10</td>
<td>![Circuit](X0 X10)</td>
</tr>
<tr>
<td>aX0</td>
<td>aX10</td>
</tr>
</tbody>
</table>
If "&" and " | " exist together, "&" will take priority.
In order to increase the priority, use "( )".

<table>
<thead>
<tr>
<th>MELSAP-L format</th>
<th>Circuit</th>
</tr>
</thead>
<tbody>
<tr>
<td>aX0</td>
<td>aM0 &amp; aX1</td>
</tr>
<tr>
<td>(aX0</td>
<td>aM0) &amp; aX1</td>
</tr>
<tr>
<td>aX0 &amp; aX1</td>
<td>aM0 &amp; aM1</td>
</tr>
<tr>
<td>aX0 &amp; (aX1</td>
<td>aM0) &amp; aM1</td>
</tr>
</tbody>
</table>

(2) Instructions that cannot be described at transition conditions
• All instructions with the exception of contact instructions and comparison operation instructions
2.4 Precautions to Observe When Creating Programs

The precautions to observe when creating SFC programs using MELSAP-L are set out below.

1) When a program was made using MELSAP-L
   (a) PLC series other than QCPU (Q mode)/LCPU are not compatible with the MELSAP-L format.

   (b) You can select ladder, MELSAP3 or MELSAP-L for each program. However, you cannot specify MELSAP3 or MELSAP-L in units of SFC program blocks.

   (c) If a number of SFC programs (MELSAP-L format and MELSAP3 format) exist in the programmable controller CPU, only one program can be executed. (This does not apply to control STC programs.) If you wrote a number of SFC programs, set all but one of them in the standby program by means of a PLC parameter program setting.

   (d) You cannot input a contact or contact-equivalent instruction to an operation output.

   (e) The operation output/transition conditions per block can consist of up to 2k sequence steps. Each operation output or transition condition can consist of up to 512 sequence steps. When checking the number of sequence steps, display them in the MELSAP3 format.

   (f) Each operation output/transition condition program can be displayed using up to 32 characters in the case of an SFC diagram. If the number of characters exceeds 32, "..." is displayed at the 32nd character position. If you place the mouse cursor in the program display column, up to 256 characters can be displayed.*1 If 256 characters are exceeded, "..." appears at and after the 253rd character position.

   *1: Depending upon the resolution of the peripheral equipment (display), it may not always be possible to display up to 256 characters.

   (g) You cannot make notes.

   (h) You cannot display device comments on an SFC diagram. Edit and display device comments in the device comment creation dialog box.

   (i) If you change the PLC type to ACPU or QCPU (A mode), the MELSAP-II format will be activated.

   (j) If you change the PLC type to QnACPU, the MELSAP3 format will be activated.

   (k) If you attempt to make a project inquiry using a MELSAP-L format program as the inquiry source and a ladder program as the inquiry object, the inquiry will not take place. You can make an inquiry by using a ladder program as the inquiry source and a MELSAP-L format program as the inquiry object. You can make inquiries to both MELSAP-L and MELSAP3 format programs.
(2) If you use the MELSAP-L format to display a program created in the MELSAP3 format

If you display the following operation outputs and transition conditions in the MELSAP-L format, "???.." will appear.
- An operation output or transition condition containing a NOP instruction
- An operation output containing a contact or contact-equivalent instruction
- An operation output containing a note

If "???.." appears, change over to the MELSAP3 format, and check the circuit.
In the case of a circuit that exists in the MELSAP3 format, you cannot use the MELSAP-L format to amend or monitor the program, however the CPU will perform processing normally.
If you wish to amend or monitor a program in the MELSAP-L format after checking it in the MELSAP3 format, delete the program displayed as "???.." in the SFC symbol/program input window, then input it once again in the MELSAP-L format.

[Operation output created in the MELSAP3 format]

![Diagram of operation output created in MELSAP3 format]

[Display in MELSAP-L format]

![Diagram of display in MELSAP-L format]

An operation output containing a contact instruction created in the MELSAP3 format will appear as "???.." in the MELSAP-L format.
To amend or monitor a program in the MELSAP-L format, delete it then re-input it.

[Example of program in the MELSAP-L format]
The diagram below shows an example of the case in which the same program as a MELSAP3 format program is created in the MELSAP-L format.

![Diagram of example program in MELSAP-L format]

Create a dummy step.

Jump to the dummy step.
(3) Compatibility with GX Developer prior to GX Developer (SW4D5C-GPPW-E or earlier)

(a) If you read a MELSAP-L format program using the GX Developer (SW4D5C-GPPW-E), it will be displayed in the MELPAP3 format. Once you overwrite and save the program with the GX Developer (SW4D5C-GPPW-E), it will be displayed in the MELSAP-L format, even if you subsequently read it with the GX Developer (SW5D5C-GPPW-E or later). Once you change the PLC type into a type other than QCPU (Q mode) after reading it to the GX Developer (SW4D5C-GPPW-E), it will not be displayed in the MELSAP-L format, even if you subsequently read it with the GX Developer (SW5D5C-GPPW-E or later).

(b) If you wish to use a MELSAP-L format program in the GX Developer (SW3D5C-GPPW-E or later), first change the PLC type to ACPU or QnACPU then read the program. (The program will be read in the MELSAP-II format or the MELSAP3 format.)
3. MELSAP-L PROGRAM EDITING METHOD

3.1 MELSAP-L Program Editing Outline Procedure

1. GX Developer
   (To create new program)
   
   Creation of new project
   Set the PLC series, PLC type and project name, select the program format to "SFC", and check "MELSAP-L".

   SFC parameter setting
   Set the SFC program start mode, block 0 start condition, and output mode at block deactivation.

   Other parameter settings
   Set the other parameters as required.

   Block parameter setting
   Set the "Periodic Execution Block No.", "Act at Block Multi-Activated" and "Act at Step Multi-Activated".

   SFC program setting

   SFC option setting
   Set the jump to the start destination block, and also set the automatic scroll monitor and the transition monitor. Set the reference window, a jump.

   Toolbar setting
   Set the toolbar display for "SFC".

2. Open the project.
   (To modify the existing program)
1) Set the SFC display column.

(To create new program)

SFC write
Write SFC diagram from block 0.

Conversion operation

SFC information register setting

(To modify the existing program)

Read the block to be modified.

Write, insert, delete
SFC diagram modifying operation

Step-by-step operation output/transition condition correcting operation

SFC information register setting, modification

POINT
This outline procedure is given for your reference.
You can perform the operations in any order without following the above procedure.
### 3.2 List of SFC Diagram Symbols

Shown below is a list of symbols used in SFC programs.
A block indicates a series of operations that start at the initial step and end at the end step.
The minimum unit of operation is divided into a step and a transition. The operation output or transition condition is displayed using a MELSAP-L format instruction (program).

#### (1) List of MELSAP-L format SFC diagram symbols

<table>
<thead>
<tr>
<th>Class</th>
<th>Name</th>
<th>SFC Diagram Symbol</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initial step</td>
<td>dummy initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>coil hold initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>operation hold step (without transition check) initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>operation hold step (with transition check) initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>reset initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>dummy initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>coil hold initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>operation hold step (without transition check) initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>operation hold step (with transition check) initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>reset initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>Step</td>
<td>dummy initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>coil hold step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>operation hold step (without transition check) initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>operation hold step (with transition check) initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>reset initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>dummy step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>coil hold step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>operation hold step (without transition check) initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>operation hold step (with transition check) initial step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>reset step</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>block start step (with end check)</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>block start step (without end check)</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>block end</td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>

- **Max 31 steps in one block**
- *The initial step at top left (first row) of the SFC diagram is set to No.0
- **Max 512 steps in one block**
- *Step number (1 to 511)
- Including initial step, Max. 512 steps in one block

- **More than one block end may be provided in one block.**
### MELSAP-L PROGRAM EDITING METHOD

<table>
<thead>
<tr>
<th>Class</th>
<th>Name</th>
<th>SFC Diagram Symbol</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Series transition</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Selective branch</td>
<td></td>
<td><img src="image" alt="Selective branch" /></td>
<td></td>
</tr>
<tr>
<td>Selective branch-parallel</td>
<td>branch</td>
<td><img src="image" alt="Selective branch-parallel branch" /></td>
<td></td>
</tr>
<tr>
<td>Selective coupling</td>
<td></td>
<td><img src="image" alt="Selective coupling" /></td>
<td></td>
</tr>
<tr>
<td>Selective coupling-parallel branch</td>
<td></td>
<td><img src="image" alt="Selective coupling-parallel branch" /></td>
<td></td>
</tr>
<tr>
<td>Parallel branch</td>
<td></td>
<td><img src="image" alt="Parallel branch" /></td>
<td>a, b = Transition condition number</td>
</tr>
<tr>
<td>Parallel coupling</td>
<td></td>
<td><img src="image" alt="Parallel coupling" /></td>
<td></td>
</tr>
<tr>
<td>Parallel coupling-parallel branch</td>
<td></td>
<td><img src="image" alt="Parallel coupling-parallel branch" /></td>
<td></td>
</tr>
<tr>
<td>Parallel coupling-selective branch</td>
<td></td>
<td><img src="image" alt="Parallel coupling-selective branch" /></td>
<td></td>
</tr>
<tr>
<td>Parallel coupling-selective coupling</td>
<td></td>
<td><img src="image" alt="Parallel coupling-selective coupling" /></td>
<td></td>
</tr>
<tr>
<td>Jump</td>
<td></td>
<td><img src="image" alt="Jump" /></td>
<td>a = Transition condition number j = Jump destination number</td>
</tr>
</tbody>
</table>

**POINT**

If "?" is attached to the left side of the step number or transition condition number, it means that the operation output/transition condition program is not set. When you set the program, "?" is no longer displayed.
3.3 Basic SFC Diagram Editing Screen

(1) Overall configuration of screen

1) Title bar
2) Menu bar
3) Tool bar
4) Project data list
5) MELSAP-L editing screen
6) Block list screen
7) Status bar
(2) Configuration of MELSAP-L editing screen

1. Move the cursor from [View] → [Display block list] → any display block position, and press the [Enter] key.
2. Choose [View] → [Display block list] → any block position, and double-click that position.
3. Choose [Find/Replace] → [Find step no./block no.] → any block No., and specify it.
4. Press the space key on the block starting step in the SFC chart.
5. Move the cursor from [Window] → data name, and press the [Enter] key.
6. Move the cursor from [Window] → data name, and double-click it.
3.4 Creating/Modifying the SFC Diagram

3.4.1 Writing an SFC diagram

An SFC diagram may be created in any of the following four methods.

1. Starting from the tool button on the toolbar
2. Starting from the function key
3. Starting from the menu on the toolbar
4. Starting from pressing the Enter key on the SFC diagram.

Performing any of the above operations shows the Enter SFC symbol, enter program window.

POINT

The symbols that can be created in the SFC diagram are determined by the cursor position (line).

The step created in the first line automatically becomes the initial step.

You can create various kinds of steps or jumps in the 1 (multiple of 3) th line.

You can create a series transition line, selective branch or a parallel coupling in the 2 (multiple of 3) th line.

You can create a parallel branch or a selective coupling in the 3 (multiple of 3) th line.

However, if you create a selective branch or a parallel coupling in the 2 (multiple of 3) th line, a series transition will be created in the 3 (multiple of 3) th line.

You can create "|" (vertical line) in any position other than the 1st line.

The 1st line automatically becomes the initial step.

"." prevents a transition (excluding a jump) from being created.
(1) Operation method created from the tool button
(a) Write (overwrite) operation example
1) Step ( ✖ / ✖ )

- Diagram symbol
  "STEP" (DUMMY) appears.
  You can change the diagram symbol by clicking ✖

- Step number
  Numbers are automatically assigned in the input sequence (ascending order).
  If you wish to specify the step number, enter a number in the range 1 to 511.
  After creating an SFC diagram, you can re-assign numbers in sequence from top left to bottom right by sorting.
  When you input the operation output program to " ✖ " (dummy step), the display automatically switches to " ✖ " (step).

- Step attribute
  When you wish to add a step attribute, click ✖, then select the attribute.
  If you select the reset step "[R]" using the step attribute, enter the reset destination step number

- Comment
  You can enter up to 32 characters as a step comment.
  When you click [View] → [Display comment of step and TR] from the menu bar, the comment appears in the SFC diagram.

- Program
  Input the operation output coil and instruction.
  You can input a number of coils and instructions by partitioning them with commas (,).
  For details of instructions, refer to section 2.2.
  For details of the input method, refer to section 3.5.

- RUN write button
  You can perform a "write during RUN" operation by clicking this button.
  For details of a "write during RUN" operation, refer to section 3.11.
2) Block start step (  /  )

- Diagram symbol
  "BLOCK (BLOCK-S) appears.
  You can change the diagram symbol by clicking .

- Step number
  Numbers are automatically assigned in the input sequence (in ascending order).
  To specify a step number, enter a number in the range 1 to 511.
  After creating an SFC diagram, you can assign numbers once again in sequence from top left to bottom right by sorting.

- Blocks
  Enter the start destination block number

- Comment
  You can enter up to 32 characters as step characters.
  When you click [View] → [Display comment of step and TR] from the menu bar, the comment appears in the SFC diagram.

POINT
You can change the kind of step (diagram symbol) by either clicking of the diagram symbol in the SFC symbol/program input window, or by pressing a function key.
If you inadvertently click the wrong tool button, you can re-select the step without closing the SFC symbol/program input window.
3) Series transition (→)

- **Diagram symbol**
  "TR" is displayed.
  You can change the diagram symbol by clicking (not shown).

- **Transition condition number**
  Numbers are automatically assigned in the input sequence (in ascending order).
  To specify a transition condition number, enter a number in the range 1 to 511.
  After creating an SFC diagram, you can assign numbers once again in sequence from top left to bottom right by sorting.

- **Comment**
  You can enter up to 32 characters as a transition comment.
  When you click [View] → [Step/Display comment of step and TR] from the menu bar, the comment appears in the SFC diagram.

- **Program**
  Enter the transition condition program (contact and comparison operation instructions).
  You can input a number of contacts and instructions using "&" (AND) or "|" (OR).
  For details of contacts and instructions, refer to section 2.3.
  For details of the input method, refer to section 3.5.

- **RUN write button**
  You can perform a "write during RUN" operation by clicking this button.
  For details of a "write during RUN" operation, refer to section 3-11.

4) Selective branch (→)

- **Diagram symbol**
  "D" appears.
  You can change the diagram symbol by clicking (not shown).

- **Number of branches**
  Enter the number of branch lines.
  You can create branch lines equal in number to the entered value, in a single operation.
  The initial value is "1".
5) Parallel branch (——)

- Diagram symbol
  "==D" appears.
  You can change the diagram symbol by clicking.

- Number of branches
  Enter the number of branch lines.
  You can create parallel branches equal in number to the entered value, in a single operation.
  The initial value is "1".

6) Selective coupling(____)

- Diagram symbol
  "==C" appears.
  You can change the diagram symbol by clicking.

- Number of couplings
  Enter the number of coupling lines.
  You can create couplings equal in number to the entered value, in a single operation.
  The initial value is "1".
7) Parallel coupling (-----)

• Diagram symbol
  "==C" appears.
  You can change the diagram symbol by clicking ▼

• Number of branches
  Enter the number of branch lines.
  You can create parallel couplings equal in number to the entered value, in a
  single operation.
  The initial value is "1".

POINTS

• Input method used when a branch and a coupling are used together in a single
  transition condition

1) For Q/QnACPU

  When a branch and a coupling are used together in a single transition
  condition, reserve an area for one step using "|" (vertical line) and then enter
  the branch and coupling symbols.

  Example 1:

  ![Diagram example 1]

  Area for 1 step

  Example 2:

  ![Diagram example 2]

  Area for 1 step

• For branch/coupling line entry, entering the number of branches/couplings as "-n"
  creates them from right to left.
8) Jump transition ( → )

- Diagram symbol
  You can change the diagram symbol by clicking ▼.

- Jump destination step number
  Enter the step number of the jump destination.
  When you click the **OK** button, the display of the step ( □ ) specified at the jump destination changes to ( □ ).

9) End step ( □ )

10) Rule write

- To write a rule, click □ / □ / □ / □ and drag from the first position to the last position of the rule entry.

**POINT**
If you write a rule over the existing step/transition, the step/transition symbol and operation output/transition condition sequence program are not erased.
11) Row insert

[Edit] [Insert line]

12) Column insert

[Edit] [Insert row]

13) Row delete

[Edit] [Delete line]

14) Column delete

[Edit] [Delete row]
(b) Write (insert) operation example

When an SFC diagram is created by a write (insert) operation, insertion results are as described below on an SFC diagram symbol basis.

Note that step/transition condition number changing, simultaneous SFC comment creation and so on can be performed as in the write (overwrite) operation.

1) Step ( )

- Point the cursor to a desired position and click the SFC symbol (step) to insert a step in the cursor position.
  - If you do not change the step number when inserting by overwriting on "|" (vertical line), the lowest vacant number will be assigned.
  - When the insert position is within a branch ladder, "|" (vertical line) is automatically inserted into another branch.

2) Series transition ( )

- Point the cursor to a desired position and click to insert a transition in the cursor position.
  - If you do not change the transition condition number when inserting by overwriting on "|" (vertical line), the lowest vacant number will be assigned.
  - When the insert position is within a branch ladder, "|" (vertical line) is automatically inserted into another branch.
3) Selective branch ( )

4) Parallel branch ( )

5) Selective coupling ( )

6) Parallel coupling ( )

POINTS

- Entering "-n" as the number of branches/couplings enters them from right to left.
  Example: Number of couplings "1"

- Inserting a branch/coupling may generate an SFC diagram that cannot be converted.
  In this case, correct the SFC diagram with the edit function (cut and paste) and then perform a conversion operation.
(2) Operation starting from the function key
   (a) The SFC symbols are assigned to the following function keys.

   [Step]
   | SFC symbol |   |   |   |   |   |
   | F5 | F6 | Shift + F6 | F8 | F7 | Shift + F5 |

   [Transition or branch/coupling]
   | SFC symbol |   |   |   |   |   |
   | F5 | F6 | F7 | F8 | F9 | Shift + F9 |

   [Rule entry]
   | SFC symbol |   |   |   |   |   |
   | Alt + F5 | Alt + F7 | Alt + F8 | Alt + F9 | Alt + F10 |

(b) Operation procedure
- Step/transition/branch/coupling entry
  1) Press the function key.
  2) Since the window as was shown when the tool button was clicked appears, refer to the tool button operation procedure and enter the required items.
  3) Press the [Enter] key.

- Rule entry
  1) Press the function key.
  2) Using the arrow keys, move the cursor to the first position of a branch/coupling.
  3) Hold down the [Shift] key and move the cursor with the arrow keys.
  4) Move the cursor to the last position of the branch/coupling and release your hand from the key.
(3) Operation starting from the menu on the toolbar
   (a) Step/transition/branch/coupling entry
      1) Click [Edit] on the toolbar.
      2) Move the cursor to [SFC symbol] in the edit menu.
      3) Click the SFC symbol to be entered.
      4) Since the window as was shown when the tool button was clicked appears,
         refer to the tool button operation procedure and enter the required items.
      5) Press the Enter key.

(b) Rule entry
   1) Click [Edit] on the toolbar.
   2) Move the cursor to [Edit the line] in the edit menu.
   3) Click the branch/coupling line to be entered.
   4) Drag from the first position to the last position of the entry.

(4) Operation starting from the Enter key
   1) Press the Enter key.
   2) Since the window as was shown when the tool button was clicked appears, refer
      to the tool button operation procedure and enter the required items.
   3) Press the Enter key.

POINT
Operation starting from the Enter key is a method useful for entry of steps (□) and transitions (↑) consecutively in the column direction.
3.4.2 Deleting the SFC diagram

This section explains how to delete the existing SFC diagram symbols.

(1) Operation using the tool button to delete
   (a) Specifying the area and making deletion

   ![Diagram showing deletion process](image)

   Drag

   (b) Deleting the branch/coupling/vertical line only

   ![Diagram showing deletion process](image)

   Drag

(2) Operation using the function key to delete
   • Hold down the [Shift] key and choose the deletion area with the arrow keys.
   • Press the [Delete] key.

(3) Operation to delete from the menu on the toolbar
   • With the mouse, drag over the area to be deleted.
   • Click [Cut] in the edit menu.

**POINT**

Performing the [Undo] operation after making a deletion returns to the status immediately prior to the deletion.

- Tool button : Click [Tool]
- Function key : [Ctrl] + [Z]
- Menu : Click [Undo] in the edit menu.
### 3.4.3 Changing the step attribute

This section describes how to change the step attribute in the existing SFC diagram. The step attribute can be changed by any of the following tool button clicking, menu operation and key pressing.

<table>
<thead>
<tr>
<th>Tool Button</th>
<th>Key Pressing</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Tool Button 1" /></td>
<td>Ctrl + 1</td>
<td>1) Editing&lt;br&gt;2) Step attribute setting&lt;br&gt;3) Choose a new attribute.</td>
<td>• Makes the preset step attribute invalid.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Tool Button 2" /></td>
<td>Ctrl + 2</td>
<td>1) Editing&lt;br&gt;2) Step attribute setting&lt;br&gt;3) Choose a new attribute.</td>
<td>• Changes the preset step attribute to <strong>SC</strong>.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Tool Button 3" /></td>
<td>Ctrl + 3</td>
<td>1) Editing&lt;br&gt;2) Step attribute setting&lt;br&gt;3) Choose a new attribute.</td>
<td>• Changes the preset step attribute to <strong>SE</strong>.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Tool Button 4" /></td>
<td>Ctrl + 4</td>
<td>1) Editing&lt;br&gt;2) Step attribute setting&lt;br&gt;3) Choose a new attribute.</td>
<td>• Changes the preset step attribute to <strong>ST</strong>.</td>
</tr>
</tbody>
</table>
| ![Tool Button 5](image5.png) | Ctrl + 5 | 1) Editing<br>2) Step attribute setting<br>3) Choose a new attribute. | • Changes the preset step attribute to **R** and sets the reset destination step No.  
• When it has already been set to **R**, changes the reset destination step No. |

**POINT**

If the step attribute has been changed, the existing operation output sequence program remains unchanged.
3.4.4 Cutting/Copying and pasting the SFC diagram

This section provides the operation to cut/copy and paste the SFC diagram.

(1) Specifying the area, cutting or copying the SFC diagram, and pasting it

[Operation procedure]
1. Choose [Edit] → [Write mode] or F2.
2. Click the first position of the SFC diagram to be cut, and move the cursor.
3. Drag over the area to be cut or copied. The specified area is highlighted.
4. When cutting, choose [Edit] → [Cut] or [Ctrl+X], or when copying, choose [Edit] → [Copy] or [Ctrl+C] to cut the ladder in the specified area.
5. Click the position where the cut (copied) SFC diagram will be applied, and move the cursor.
6. When you choose [Edit] → [Paste] or (Ctrl + V), the Paste data window appears. Make pasting choices.

   ![Paste data window](image)

1) Selection of whether or not the operation output/transition condition sequence program is also pasted simultaneously.
2) Selection of whether or not the original step/transition condition number is changed.
3) Selection of whether or not the step/transition comment is also pasted simultaneously.

**POINT**

"Not changing" the original step/transition condition number is useful for a moving operation.

7. When you selected "not to" change the original step/transition condition number but the pasting destination already has the same step/transition condition number, the following window appears.

   ![Error window](image)

Choosing **Yes** executes pasting after the system has assigned a new number by reassigning lower to higher free numbers to the step/transition condition numbers of the pasting destination SFC diagram.

Choosing **No** suspends pasting.
8. When the first position of the cut or copied SFC diagram is a step and its pasting position is a transition position, or vice versa, the following window appears.

When this window has appeared, click the OK button, move the pasting position one row higher or lower, then perform a pasting operation again.

9. After the pasting operation is over, make conversion.
   Note that a conversion error occurs if a branch/coupling is incorrect after pasting. Therefore, make conversion after performing the SFC diagram editing operation.

POINTS

• Cutting/copying and pasting between different blocks in the same program can be executed by displaying the corresponding blocks by performing [Window] → [Tile vertically] or [Tile horizontally] operation.
• Cutting/copying and pasting between different projects can be executed after opening the corresponding projects by performing [Project] → [Start new GX Developer session] operation.
• Copying of an operation output/transition condition sequence program should be done within approx. 2k steps.
3.4.5 Sorting the SFC diagram

This operation reassigns the step/transition numbers of the created SFC diagram.

[Operation procedure]
  [Tools] → [Sort] or 

[Setting screen]

![Sorting step numbers](image)

1) 

2) 

3) 

4) 

[Setting items]

1) Sorting Order
   Specify whether the step/transition numbers are in an ascending or descending order.

2) Change START block number
   Specify whether the start destination block number is to be changed or not.

3) Set START block number
   When you have selected “Change”, enter a new block number.

4) [Execute] button
   Executes sorting as set on the above screen.

POINT

• The result of executing sorting by specifying an ascending or descending order is as follows.

  (When ascending order is specified)        (When descending order is specified)

  ![Sorting result](image)

  * Immediately after sorting, a "Undo" operation can be performed only once.
  * ❌ is step "0" if you specify either the ascending or descending order.

• The SFC devices (e.g. BLm\Sn, BLm\TRn) used with the operation outputs/transition conditions are not the objects of sorting.
  Sort them by performing a device number changing operation or the like.
3.4.6 Redisplaying the SFC diagram

[Setting purpose]
This operation is performed to return the unconverted SFC diagram being edited to the status immediately prior to editing, or to top-shift or left-shift the freed row or column of the "|" (vertical line)/branch/coupling line.

[Operation procedure]
[View]→[Review SFC]

1) Top-shift redisplaying example

2) Left-shift redisplaying example

3) Unconverted SFC diagram redisplaying example

4) After-conversion SFC diagram optimizing display
3.5 Creating Operation Outputs and Transition Conditions

Input the operation output and transition condition program from the SFC symbol/program input window when creating an SFC diagram. After creating the SFC diagram, you can re-display the SFC symbol/program input window by double-clicking the pertinent step/transition, and change the program. For details of the method of describing operation output/transition instructions, refer to sub-sections 2.2 and 2.3. For details of instructions that can be used, refer to the MELSECQ/L/QnA Programming Manual (MELSAP-L).

(1) Entering operation outputs
When entering an o, h, s or r instruction at the operation output, do not enter a space between the instruction and the device name.
Example: oY1 ○
o_X1 ×

In the case of a timer or counter, enter a space between the device name and the set value.
Example: oTO_K30 ○
oTOK30 ×

In the case of another instruction, enter spaces between the instruction, device name, set value, and so on, as in the list format.
Example: MOV_K100_D0 ○
MOVK100D0 ×

There is no need to make any distinction between upper case and lower case letters when entering an instruction.
By pressing the [OK] button, o, h, s and r will become lower case letters, and other letters will be set to upper case letters, automatically.
Example: If you enter "AX1" or "ax1" as an instruction, "aX1" will appear after you click the [OK] button.

(2) Transition conditions
If you enter the a, b, p or f instruction in a transition condition, do not enter a space between the instruction and the device name.
Example: aX1 Correct
a_X1 Incorrect

In the case of a comparison operation instruction, enter spaces between the instruction, device name, set value, and so on, as in the list format.
Example: =_K1000_D10 Correct
=K1000D10 Incorrect

"( )", which indicates the priority sequence of "&" and "|", is optimized (necessary part only) after being entered.
Example: When entering: (aX0 & bX1) |(aX3 & bX4)
After entering: aX0 & bX1 |aX3 & bX4
Because "&" takes priority over "|", "( )" is unnecessary.
3.6 Comment Creation Method

In MELSAP-L, the comments that can be created are broadly divided into the following two kinds.
- SFC comments
- Device comments

The term "SFC comment" is a generic term that refers to a "step comment" that is added to each step of an SFC diagram, and a "transition comment" that is added to each transition line.

The term "device comment" is a comment that is added to each device as in the case of a circuit.

The method of creating SFC comments and device comments is described below.

3.6.1 Method of creating an SFC comment

You can create an SFC comment from the SFC symbol/Enter program window when creating an SFC diagram. The method of creating and modifying comment data alone after creating an SFC diagram is set out below.

(1) Using the SFC diagram editing screen

[Operation procedure]

[Edit] → [Documentation] → [Comment] → Double-click at the editing position.

[Setting screen]
(2) Using the device comment editing screen

[Operation procedure]
Project data list device comment → COMMENT

[Setting screen]

1) Device name
Specifies the device for creating a comment.
When creating an SFC comment, specify the device name as follows.
Step comment: BLm\Sn
Transition comment: BLm\TRn
(m= Block number, n= Step/transition condition number)

POINT
If you enter "BLm" (m= Block number) as the device name, you can create or modify the block title.
For details of block titles, refer to section 3.7.
3.6.2 Method of creating a device comment

There are two methods of creating a device comment, a method of creating it from the comment input window after creating an SFC diagram, and a method of creating it from the comment editing screen.

Note, however, that a device comment does not appear on the SFC diagram editing screen.

You can display the alias to be added to the device on the SFC diagram editing screen.

(1) Using the SFC diagram editing screen
   [Operation procedure]
   [Tool] → [Option] → Program common tab → Check [Continues during command write] device comment input box → Double-click the editing position on the SFC diagram → Set SFC symbol/program input window to [OK].
   [Setting screen]
   ![Device Comment Input Screen]

   1) Device
   The device name used for the operation output/transition condition at the editing position is displayed.

(2) Using the device comment editing screen
   When creating a device comment from the device comment editing screen, use the same operation procedure as that for the circuit.
   For details of operation, refer to the GX Developer Operating Manual.

**POINT**
- The Alias cannot be used for the project in which "Use label" is selected.
- You cannot create an alias for each device, from an SFC diagram. Create the device name from the device comment editing screen of (2).
- You cannot display a created device comment on an SFC diagram. When you click [View] → [Display alias of step and TR] menu, the displayed program device name changes over to the alias. (Refer to sub-section 3.13.3.)
3.7 Setting the Block Information

[Setting purpose]
This operation is performed to set the block information of the corresponding block at the time of a conversion operation after creation of an SFC diagram.

[Operation procedure]
• SFC diagram creation → (F4)
• [Edit] → [Block information] or

[Setting screen]

Enter a device into each item.
No device may be entered into an unnecessary item.

POINT
• For details of the function and contents of each item, refer to the MELSEC-Q/L/QnA Programming Manual (MELSAP-L).
• The set block title stored as a device comment of device BLm.
• A block title/alias can be created and changed by entering a device name "BLm" on the device comment-editing screen. (Refer to Section 3.6.1).
• When putting a block title for each program, create comments by program. For details of the creating method, refer to GX Developer Operating Manual.
3.8 Displaying the Block List

You can display a list of blocks of the SFC program being edited. You can perform editing such as cut & paste in monitor or block units.

[Operation procedure]
[View] → [Display block list]
[Block list screen]

1) One screen displays 32 blocks.
   Using the scroll bar, Page Up / Page Down or ↑ / ↓ key, you can change the displayed blocks.
2) Indicates whether the corresponding blocks have been converted or not.
   – : Already converted
   * : Not yet converted

POINT
In the SFC block list, you can perform the following.
1) Block information setting/correction
2) Batch copy between blocks
3) Jump to SFC diagram display in the specified block
4) SFC monitoring in the block list
5) (Batch) Conversion of unconverted blocks
3.9 SFC-Related Parameter Settings

Among the parameter settings made for operating the QCPU(Q mode)/LCPU, this section explains the setting of parameters related to SFC programs.

3.9.1 SFC setting in PLC parameters

This section gives the operation performed to set the SFC-related parameters using the PLC parameters.

[Operation procedure]
PLC parameters in project data list → SFC setting

[Setting screen]

[Item explanation]
1) SFC program start mode
   Set an initial start or resume start to start the SFC program.
2) Start conditions
   Set autostart block 0/do not autostart block 0 at the initial start of the SFC program.
3) Output mode when the block is stopped
   Set whether a stop is made by turning off the coil outputs which were turned on by the OUT instruction or by keeping them on (latched) when a stop request is sent to any block.
3.9.2 Setting the block parameters

This section provides how to set the block parameters. This setting is not available for Basic model QCPU, Universal model QCPU, and LCPU.

[Operation procedure]
[Tools] → [Set SFC information] → [Block parameter]

[Setting screen]

[Item explanation]
1) Periodic execution block
   - All blocks from the set block number onward are periodic execution blocks.
   - Do not set periodic execution blocks when processing all blocks with each scan.
   - Enter the execution interval within the range 1 to 65535 (ms) in 1ms increments.

2) Act at block multi-activated
   - Set the operation mode at block multi-activated.
   - For blocks in the specified range, the operation mode at block multi-activated is set to "Stop".
   - For blocks outside the specified range, the operation mode at block multi-activated is set to "standby".
   - Do not set this item if all blocks are to be set in "standby" mode.

3) Act at step multi-activated
   - Set the operation mode at step multi-activated within the range of block units.
   - Regarding blocks specified as "waiting blocks", the operation mode at step multi-activated is set to "transition".
   - Regarding blocks specified as "stop blocks", the operation mode at step multi-activated is set to "stop".
   - Do not set this item if all blocks are to be set in "standby" mode.
3.9.3 SFC program setting

Set whether the SFC program file being edited is to be a "Normal SFC Program" or a "Control SFC program". This setting is not available for Basic model QCPU, Universal model QCPU, and LCPU.

[Operation procedure]
[Tools] → [Set SFC information] → [SFC type]

[Setting screen]

![SFC program type setting](image)

[Item explanation]
Selects whether to make the SFC program a normal SFC type or a control SFC type.
When Control SFC type is selected, an SFC program can be created for block 0 only.
Note that if a block start step (□, □) is designated in block 0, an error occurs when the program is executed and CPU operation stops.

3.10 Conversion Operation

With MELSAP-L, if only the operation outputs/transition conditions are edited, a conversion operation is unnecessary.

<table>
<thead>
<tr>
<th>Item</th>
<th>Conversion Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conversion (all programs being edited)</td>
<td>• All programs being edited are batch-converted.</td>
</tr>
<tr>
<td>Block conversion (F4)</td>
<td>• Only one SFC diagram block being edited is converted.</td>
</tr>
<tr>
<td>Block conversion (All blocks being edited)</td>
<td>• All SFC diagram blocks being edited are batch-converted.</td>
</tr>
</tbody>
</table>
| Block conversion error                   | • The block No's in SFC diagram conversion error and the number of errors are displayed  
                                           • A detailed error is displayed per block specified. |
3.11 Instructions for Online SFC Program Writing

This section provides instructions for writing the operation outputs/transition conditions of an SFC program to the CPU during RUN.

- If you create operation outputs/transition conditions alone in the overwrite mode after converting an SFC diagram, the [RUN write] button in the SFC symbol/program input window will be active.

- When you click the [RUN write] button, a "write during RUN" operation takes place. You cannot simultaneously write operation outputs/transit conditions for more than one point while a "write during RUN" operation is taking place. Perform a "write during RUN" operation for each operation output/transition condition.

- If you select "Write during RUN (while programmable controller is running)" or "Write if PLC STOP" when making a "write during RUN" setting by selecting [Tool] → [Option] → <<Program common>>, you can also write data to the CPU by pressing the [OK] button in the SFC symbol/program input window.

- The "write during RUN" method used is the normal "write during RUN" method.

- To execute "Write during RUN", display the SFC diagram/program input window, then press [Shift] + [F4]. (The same result can be achieved by pressing the [F4] button followed by the [OK] button.)

- You cannot execute "Write during RUN" using an SFC diagram. After creating or modifying an SFC diagram, stop the CPU then select the [Online] → [Write to PLC] menus and write data to programmable controller.

- You cannot execute "Write during RUN" in the insertion mode.

For other precautions concerning online change, refer to GX Developer Operating Manual.
3.12 Search and Replacement

The method of searching for and replacing devices and instructions in MELSAP-L is described below.

**POINT**

- If you use the MELSAP-L format to display an SFC program created in the MELSAP3 format, instructions that cannot be input using MELSAP-L will be displayed as "???.", however they can be found. If you wish to replace instructions that are displayed as "???.", replace them all together using "all replace". If you replace one instruction at a time, a replacement error will occur.
- If you display a program containing a note (created in the MELSAP3 format) in the MELSAP-L format, "???." will appear, preventing you from carrying out a search or replacement operation.
- For a search/replacement made in an SFC program, the object area changes with the "searching direction" specified.

<table>
<thead>
<tr>
<th>Block 0</th>
<th>Block 1</th>
<th>Block 2</th>
<th>Block n</th>
</tr>
</thead>
<tbody>
<tr>
<td>1)</td>
<td>2)</td>
<td>3)</td>
<td>n)</td>
</tr>
</tbody>
</table>

* When a search/replacement is to be performed in an SFC program after a search has been made in another program, all blocks will be searched. When making searches/replacements in an SFC program within the "specified range (step range)", specify the step numbers (e.g. 1 2 3) of the SFC diagram.

### 3.12.1 Searching for a device

This operation searches for the specified device to find the output/transition condition of the name block under which it is used.

Move the cursor to the step/transition of the SFC diagram used by the device.

The operation method is the same as in the ladder mode.

For details of the operation method, refer to the GX Developer Operating Manual.
3.12.2 Searching for an instruction

This operation searches for the specified instruction to find the operation output/transition condition under which the corresponding block is used. Move the cursor to the step/transition of the SFC diagram in which the instruction is used.

**[Operation procedure]**

[Find/Replace] → [Instruction] or 

**[Setting screen]**

1) **Instruction**
   
   Specifies the name of the instruction to be found.
   
   A search can be performed using a normal instruction name and the following MELSAP-L format instruction names.
   
   a (open contacts)..............LD, AND, OR
   
   b (close contacts) .............LDI, ANI, ORI
   
   p (rise contacts) ................LDP, ANDP, ORP
   
   f (fall contacts) ..................LDF, ANDF, ORF
   
   o (output) ..........................OUT, OUTH, SET, RST
   
   h (high speed timer) .........OUTH
   
   s (set) ................................SET
   
   r (reset) .............................RST
   
   2) **Find direction**
      
      Sets the search direction.
      
      For details of the search direction for each setting, refer to section 3.12.

   3) **Find Next** button
      
      Clicking this button causes a search for the next object instruction to take place.

**POINT**

A pulse type instruction (+P, MOVP, etc.) is the object of a search, even if "P" has been removed from the instruction name.

Example: Search specification "MOV" → Search object "MOV", "MOVP"
3.12.3 Searching for a character string

This operation searches for the specified character string to see if it is used as an SFC comment (step comment, transition comment). (Device comments are not included.) Move the cursor to the step/transition of the SFC diagram in which the character string is used.

The operation method is the same as in the ladder mode.

For details of the operation method, refer to the GX Developer Operating Manual.

3.12.4 Searching for the Step No./Block No.

[Setting purpose]
This operation is performed to show the specified block on the screen by specifying the block No. and step No./transition No. when the cursor is in the SFC diagram.

[Operation procedure]
[Find/Replace] → [Find step no./block no.]

[Setting screen]

1) Block number
   Enter the block No. to be searched for.

2) Step/Transition
   Specify the cursor position after a search is over.

3) [Find] button
   Click this button to show the SFC diagram in the specified block.

[Item explanation]
1) Block number
   Enter the block No. to be searched for.

2) Step/Transition
   Specify the cursor position after a search is over.

3) [Find] button
   Click this button to show the SFC diagram in the specified block.

POINTS
When the cursor is in the SFC diagram, pressing any "number" key shows the following window.

Clicking the [OK] button or pressing the [Enter] key allows the cursor to move to the specified step in the SFC diagram currently displayed.
Also, turning on the block no. radio button enables a block search.
3.12.5 Searching for a device comment

This operation searches for a device comment or label comment of the device being used in the program.
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the GX Developer Operating Manual.

3.12.6 Replacing the devices

[Setting Purpose]
This operation is performed to replace character string constants used in operation outputs/transition conditions and SFC block information.

[Operation procedure]
[Find /Replace] → [Replace device]

[Setting screen]

![Setting screen]

[Item explanation]
1) Earlier device
Specify the device and character string constant to be replaced.
2) New device
Specify the new device and character string.
3) No. of substitutions
Set the number of substitution points from the devices set using the old device setting.
You can specify the number of substitution points in either decimal or hexadecimal notation.
4) Move comments and aliases.
   Set whether or not to simultaneously move comments and aliases added to
devices.
5) Include SFC block information in find targets
   Set whether or not to include devices set in the block information of each
block.
6) Find direction
   Set the search direction.
   For details of the search direction under to each setting, refer to sub-section
3.12.
7) [Find Next] button
   Searches for the next target device without replacing the device at the location
of the cursor.
8) [Replace] button
   Replaces the device at the location of the cursor, then replaces the next target
device.
9) [Replace all] button
   Replaces all of the devices in the search area.
10) Instruction list
    Displays programs that include the devices to be replaced, when "Find Next"
or "Replace" is executed.
    The devices to be replaced are highlighted.

---

**POINT**

- You cannot replace a bit device with a word device, or vice-versa.
  It is possible to make an expansion specification, but digits, indices and indirect
  modification cannot be done.

Examples of expansion specification, and word/bit device replacement targets

<table>
<thead>
<tr>
<th>Source</th>
<th>Target</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>X0 → J1\GO</td>
<td>Replacement possible</td>
<td>X0 → D0</td>
</tr>
<tr>
<td>D0.1 → U10\GO...</td>
<td>Replacement possible</td>
<td>X0 → K4X0.....</td>
</tr>
<tr>
<td>D0 → D0.5.........</td>
<td>Replacement possible</td>
<td>D0 → D0.5......</td>
</tr>
<tr>
<td>X0 → D1.1.........</td>
<td>Replacement possible</td>
<td></td>
</tr>
</tbody>
</table>

- When replacing other program devices, refer to section 3.12.
- If a range specification exists, only range specification of the currently open
  program will be effective. Other programs will be replaced from the first one.
- If, after replacing a device that is used in the SFC block information, you cannot
  use the device, an error will be displayed and replacement will be interrupted.
3.12.7 Replacing the instructions

[Setting purpose]
This operation is performed to replace the instructions used in the operation output/transition condition of each block.

[Operation procedure]
[Find/Replace] → [Replace instruction]

[Setting screen]

1) Earlier instruction
Specify the instruction to be replaced.
You can also specify the instruction by using a MELSAP-L format instruction name.
For details of MELSAP-L format instruction names, refer to section 3.12.2.

2) New Instruction
Specify the new instruction.
You can also specify the instruction by using an instruction name in the MELSAP-L format.

3) Find direction
Set the search direction.
For details of the search direction under each setting, refer to sub-section 3.12.

4) Find Next button
Searches for the next target instruction without replacing the instruction at the location of the cursor.

5) Replace button
Replaces the instruction at the location of the cursor, then searches for the next target instruction.

6) Replace all button
Replaces all of the target instructions in the search area.

7) Instruction list
Display programs that include the instructions to be replaced, when "Find next" or "Replace" is executed.
The instructions to be replaced are highlighted.
• You can also specify an instruction + device when inputting an instruction.
• You cannot execute when the instruction format resulting from replacement is logically invalid.
• When you wish to replace instructions in another program, refer to sub-section 3.12.
• If a constant had been set in a device when you replaced an instruction that handles 16 bits (words) with an instruction that handles 32 bits (double words) by means of an instruction replacement, the constant will be transformed as follows.
  Negative constant of K (Example: K-1) → sign-expanded (K-1)
  In the case of H, a constant whose sign bit is ON (Example: HFFFF) →
  Constant for which sign expansion does not take place (H0000FFFF)
Example: MOV K-1 D0 (MOV is replaced by DMOV) DMOV K-1 D0
  MOV K-200 D0 (MOV is replaced by DMOV) DMOV K-200 D0
  MOV HFFFF D0 (MOV is replaced by DMOV) DMOV H0000FFFF D0
Alternatively, when replacing an instruction that handles 32 bits with one that handles 16 bits, the upper 16 bits are discarded.
Example: DMOV K-1 D0 (DMOV is replaced by MOV) MOV K-1 D0
  DMOV K150000 D0 (DMOV is replaced by MOV) MOV K18928 D0
  DMOV HFFFFFFFF D0 (DMOV is replaced by MOV) MOV HFFFF D0
3.12.8 Replacing the open/close contacts

[Setting purpose]
This operation replaces the open contacts of a device used under the transition condition of each block with close contacts, and the close contacts with open contacts.

[Operation procedure]
[Find/Replace] → [Change over open/close contact]

[Setting screen]

[Item explanation]
1) Device
Specify the device whose open/close contacts you wish to change over.
2) Number of substitutes
Set the number of point at which open/close contacts are to be changed over continuously, from the specified device.
3) Find direction
Set the search direction.
For details of the search direction under each setting, refer to sub-section 3.12.
4) [Find Next] button
Searches for the next target point without replacing the open/close contacts at the location of the cursor.
5) [Replace] button
Replaces the open/close contacts at the location of the cursor and then searches for the next target point.
6) [Replace all] button
Replaces all of the target contacts in the search range.
7) Instruction list
Displays programs that include the contacts to be replaced, when "Find Next" or "Replace" is executed.
The contacts to be replaced are highlighted.
3.12.9 Replacing a character string

This operation replaces the character string of an SFC comment.
The operation method is the same as in the ladder mode.
For details of the operation method, refer to the GX Developer Operating Manual.
3.12.10 Replacing the Step No.

[Setting purpose]
This operation is performed to replace the jump destination step number and the reset destination step number of each block.

[Operation procedure]
[Find/Replace] → [Replace step no.]

[Setting screen]

![Replace step number](image)

1) Block no.
Enter the first block No. to be replaced.

2) JUMP number
Set this number when replacing the jump destination step number of a jump transition.
When replacing a step number, enter the replacement source and the step number after replacement.

3) Reset number (Only for QCPU(Q mode))
Set this number when replacing the reset destination step number of a reset step.
When replacing a step number, enter the replacement source and the step number after replacement.

4) Next button
Searches for the next target instruction without replacing the step on the cursor.

5) Replace button
Replaces the step on the cursor and searches for the next target instruction.

6) Replace all button
Replaces all target steps in the search range.

[Item explanation]

1) Block no.
Enter the first block No. to be replaced.

2) JUMP number
Set this number when replacing the jump destination step number of a jump transition.
When replacing a step number, enter the replacement source and the step number after replacement.

3) Reset number (Only for QCPU(Q mode))
Set this number when replacing the reset destination step number of a reset step.
When replacing a step number, enter the replacement source and the step number after replacement.

4) Next button
Searches for the next target instruction without replacing the step on the cursor.

5) Replace button
Replaces the step on the cursor and searches for the next target instruction.

6) Replace all button
Replaces all target steps in the search range.

POINT
After replacement, always perform a conversion operation because the step number is in an unconverted status. An error check is also made at the time of conversion.
3.12.11 Listing contacts/coils used

This operation lists where the specified devices are used in the operation outputs/transition conditions and block information. The symbols displayed represent the following.

"Step"
- S:n = Used as the operation output of step n.
- TR:n = Used as transition condition n.

"Sequence step"
- a = Used as the block start end bit of the applicable block.
- t = Used as the step transition bit of the applicable block.
- c = Used as the continuous transition bit of the applicable block.
- s = Used as the block pause/restart bit of the applicable block.
- m = Used as the pause mode bit of the applicable block.
- r = Used as the number of active step registers of the applicable block.

The operation method is the same as in the ladder mode. For details of the operation method, refer to the GX Developer Operating Manual.

3.12.12 Searching for the device use status

This operation lists how the devices are used device-by-device (e.g. X, Y, M, D). A device search also covers devices used in the block information, and if they are used in the block information alone, they are shown as being used as contacts. The operation method is the same as in the ladder mode. For details of the operation method, refer to the GX Developer Operating Manual.

3.12.13 Changing the T/C set values

This operation changes the set values of the timers/counters used in the operation outputs inside the block being displayed. (The T/C set values in different blocks cannot be changed at the same time.) The operation method is the same as in the ladder mode. For details of the operation method, refer to the GX Developer Operating Manual.
3.13 Providing Displays

3.13.1 Displaying programs

[Setting purpose]
This operation displays the operation output/transition condition program in the created SFC diagram.

[Operation procedure]
1. Select [View] → [Display program] ([Ctrl]+[Alt]+[F8]).

2. The operation output/transition condition program appears on the screen.

3. If you select [View] → [Display program] ([Ctrl]+[Alt]+[F8]) when the program is displayed, the program will disappear from the screen. Under the initial settings, the program is displayed.
3.13.2 Displaying the step/transition comments

[Setting purpose]
This operation displays created SFC comments.

[Operation procedure]
1. Choose [View] → [Display comment of step and TR] (Ctrl + F5).

2. The SFC comments appear on the screen.

3. When the SFC comments are being shown, choosing [View] → [Display comment of step and TR] (Ctrl + F5) hides the SFC comments.
3.13.3 Displaying an alias in the SFC diagram

[Setting purpose]
This operation replaces a device name in the program with a created alias and then displays it.

[Operation procedure]
1. Choose [View] → [Display alias of step and TR] (Alt+Ctrl+F6).

2. The alias replaces the device name on the display screen.
The alias is displayed in the form "instruction alias".
If an alias is not set in a device, the program remains displayed.

3. When the alias are being shown, choosing [View] → [Display alias of step and TR] (Alt+Ctrl+F6) hides the alias.
3.13.4 Displaying a program in the MELSAP3 format

By selecting [View] → [MELSAP3 format], you can use the MELSAP3 format to display a program created in the MELSAP-L format. No restrictions occur when you change to a MELSAP3 format display. For details of performing operations in the MELSAP3 format, refer to the GX Developer Operating Manual (SFC).

The following restrictions occur if you use the MELSAP-L format to display an SFC program created or modified in the MELSAP3 format.

• If an operation output contains a note, contact or comparison operation instruction, "???.." will appear when you display the program in the MELSAP-L format. You cannot modify an operation output that was displayed as "???..". (Refer to section 2.4.)
3.14 Setting the SFC Diagram Display

3.14.1 Setting the SFC diagram display

[Setting purpose]
This operation is performed to set the number of branches that can be edited/displayed when the SFC diagram is edited/read.

[Operation procedure]
[View] → [Raw of SFC]

[Setting screen]

1) Col number
Enter the number of columns (number of branches).
The number that may be input is any of 1 to 32.
Entering the number of columns automatically shows the number of rows that may be entered.

2) [OK] button
Click this button when the setting is complete.
3.14.2 Setting the SFC setting options

[Setting purpose]
This operation is used to set details when editing or monitoring an SFC program.

[Operation procedure]
[Tool] → [Set SFC information] → [Option]

[Setting screen]

1) Reference window
This window is used to display or not display several operation output/transition condition sequence program windows alongside each other in the MELSAP-II/3 format.
This setting cannot be made in the MELSAP-L format.

2) Zoom mode at block START step
Sets whether or not a jump will be made to the start destination block when the cursor moves to the block start step.

3) Auto scroll monitor setting
Sets whether or not the start destination block window will be opened and monitored when the active step moves to the block start step during monitoring of automatic scrolling.
If GX Developer is minimized, you cannot open the start destination block window.
If the block started while GX Developer was minimized, the block that was monitored prior to minimization will be monitored after minimization is canceled.

4) Step transition watchdog monitor setting
Sets whether or not steps that do not move within the specified monitoring period will be monitored.
To carry out transition monitoring, set the name of the program to be monitored, specify the block, and set the monitoring period.
If you set "Stop watchdog monitoring at detection", transition monitoring will stop when a non-transition step is detected.
MELSAP-L has the following monitoring and test functions.

[Monitoring]
• SFC diagram monitor
• All-block batch monitor
• Block list monitor
• Device batch monitor
• Device registration monitor
• Buffer memory batch monitor
• Program list monitor
• Interrupt program list monitor

[Test]
• Device test

An explanation of monitoring and testing in MELSAP-L is set out below. For details of operating the device batch monitor, device registration monitor, buffer memory batch monitor, program list monitor, and interrupt program list monitor functions, refer to the GX Developer operating manual.

4.1 SFC Diagram Monitor

This operation is used to monitor the operation and control status of the programmable controller CPU with SFC diagrams and to conduct test operations.

[Operation procedure]
● When monitoring
  [Online] → [Monitor] → [Monitor mode] or \( F3 \)
● When stopping monitoring
  [Online] → [Monitor] → [Stop monitor] or \( Alt + F3 \)
● When resuming monitoring
  [Online] → [Monitor] → [Start monitor] or \( F3 \)
1) When monitoring, screen is automatically divided into two display areas.  
(Left and right on the screen)  
The SFC diagram monitor area that indicates the active steps is displayed on the left side of the screen.  
The current value monitor area for word devices is displayed on the right side of the screen.  
The dividing line between the left and right parts of the screen can be moved.

2) During SFC diagram monitoring, steps are shown as follows.  
[Symbol]  (blue) : Active step  
[Symbol]  (yellow) : Step specified as a hold step and being in a hold status  
[Symbol]  : Inactive step

3) During monitoring, the bit device output status of the operation output is highlighted as shown below.

<table>
<thead>
<tr>
<th>Bit device output status</th>
<th>Example of a display during monitoring</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coil output</td>
<td>qY70, sM0</td>
</tr>
<tr>
<td>When bit device to be reset is OFF</td>
<td>rM0</td>
</tr>
<tr>
<td>Continuity status of the timer, high speed timer and counter</td>
<td>oT0 K30, hT10 K100, oC1 K5</td>
</tr>
<tr>
<td>When the timer, high speed timer and counter are in the time-up or count-up status</td>
<td>oT0 K30, hT10 K100, oC1 K5</td>
</tr>
<tr>
<td>When the bit device in the application instruction is ON (Excluding the digital specification bit device)</td>
<td>BCD, K4Y20</td>
</tr>
</tbody>
</table>
4) For the transition condition, when the contacts go into a continuity status, the corresponding display is highlighted.

Example:

- When open contact X1 is ON : aX1
- When close contact X2 is OFF : bX2
- When comparison operation instruction D0 = D100 : \( \text{D0 D100} \)

However, the character string data comparison instruction ($ =, $>, etc.) is not highlighted.

5) The current value monitor area displays the current value of the word device on the SFC diagram monitor screen. It displays the step number/transition condition number of the word device whose current value is being monitored.

- Step No. : ---[S n]---
- Transition No. : ---[TR n]---

You cannot register a device in the device registration monitor from the current value monitor by drag-and-drop.

6) You can change the block to be monitored, by means of the following operation.
- Select block start step and input space key.
- When the setting "Jump to start block" was made by the option setting "Zoom mode at block start step", click the OK button in the dialog box that appears when you select the block start step. (Refer to section 3.14.2.)
- Display the block list, then double-click the block number (Refer to section 3.8.)
- Specify the block to be monitored by step number/block number detection. (Refer to section 3.12.4.)

**POINT**

- When you set the auto scroll monitor function, the active steps are displayed continuously.
  
  To perform automatic scroll monitoring, click \([\text{Cycle}]\), or select [Online] → [Monitor] → [Auto scroll monitor].

- Automatic scroll monitoring of multiple steps active in series due to operation hold steps, for example, shows the active step closest to the initial step.

- When performing automatic scroll monitoring, you can automatically set the start destination block by means of the "Auto scroll monitor setting". If GX Developer is minimized, the start destination block window will not open. If the block started while GX Developer was minimized, the block that was monitored prior to minimization will be monitored after minimization is canceled. (Refer to section 3.14.2.)

- During monitoring, you cannot edit SFC diagrams.
- During editing, you cannot monitor SFC diagrams.
- If you open the write or monitoring screen during automatic scrolling, automatic scroll monitoring stops. When you resume monitoring, automatic scroll monitoring also resumes.
4.2 Transition Watchdog Monitor

The following is an explanation of the transition watchdog monitor function that monitors steps from which the program does not proceed to the next step after the lapse of the specified period.

[Operation procedure]
[Tool] → [Set SFC information] → [Option] → [Step transition watchdog monitor setting] → Carry out monitoring (refer to section 4.1).

[Screen]

• When the step transition watchdog is set, and the system detects a step from which a transition does not occur despite the lapse of the specified period, the above dialog box appears. However, the display on the above dialog box is sometimes delayed beyond the specified period depending upon the capacity of the SFC program and the environment under which the computer operates.
• When you click [JUMP], the step concerned in the SFC diagram appears.
• For details of the step transition watchdog monitor setting operation, refer to section 3.14.2.
• If you check "Stop watchdog monitoring at detection" when setting the step transition watchdog monitor, the monitor will stop each time a non-transition step is detected, however normal monitoring will continue.
4.3 All Block Batch Monitor and Active Step Monitor

This operation is used to monitor the active/inactive states of all blocks in a list form and to monitor the step active/inactive states of the specified block from the block list in a list form.

**[Operation procedure]**

- **[Online]** → **[Monitor]** → **[All block batch monitor]**

**[Screen]**

![Screen Image]

* indication: The corresponding block is active.
— indication: The corresponding block is inactive.

To monitor the specified block for step active/inactive states, click the field of the block to be monitored, and click the **[Active step monitor]** button.

![Screen Image]

* indication: The corresponding step is active.
— indication: The corresponding step is inactive.

After resetting the programmable controller CPU, if you carry out monitoring without having put the system in a RUN condition even once, the monitoring result will be blank.

If you stop the programmable controller CPU and perform monitoring, the status at the time the sequencer was stopped will be displayed as the result of monitoring.
4.4 Block List Monitor

This operation is used to show and monitor a block list.

**[Operation procedure]**

[View] → [Display block list] → ![F3]

**[Screen]**

- The block No. fields of active blocks are highlighted.
- When block information has been set, the status of the corresponding block can be confirmed in the block information.
- To switch the specified block to SFC diagram monitor during monitoring, double-clicking in the field of the corresponding block switches to the SFC diagram display of the specified block.

**POINT**

Active registers cannot be monitored.
4.5 Device Test

An explanation of the device testing operation in MELSAP-L is set out below.

[Operation procedure]
[Online] → [Debug] → [Device test] or 

[Screen]

• To forcibly turn the bit device ON or OFF, input the device, and click
  **FORCE ON** / **FORCE OFF** / **Toggle force**.

• To change a word device or the current value of the buffer memory, specify the device or buffer memory, then enter the value to be set and click **Set**.

• You can start a device test either by using **Shift** + double-clicking (Enter) the operation output or transition condition of the SFC diagram monitor, or by using the right click menu.

• The current value display of a double word instruction (DMOV, DFRO, etc.) is displayed as a double word.

Check the value of a double word using the device batch monitor or the device registration monitor.
5. PRINTING SFC DIAGRAMS

5.1 SFC Diagram Print Setting

[Setting purpose]
This operation is used to set the object of printing such as a block list, comment list, and so on.

[Operation procedure]
Select [Project] → [Print] → <<MELSAP-L>>

[Screen]

[Item explanation]
1) SFC diagram print item
The items checked in the corresponding check boxes is printed.

2) Option
The items checked in the corresponding check boxes is added.
Some additional information items cannot be selected according to the print items.

3) Setting
Set the number of print columns on a single page.
The diagram is printed with automatic magnification/reduction specified according to the set number of columns.

4) Select program
Choose the program name to be printed.

5) Print range
Set all area (all blocks) or the specified blocks.
5.2 SFC Diagram Printing Examples

This sub-section shows printing examples of an SFC diagram, block list, comment list and block parameters.

(1) SFC diagram printing example
When you print an SFC diagram, the printout is divided into a number of pages depending upon the number of branches and couplings, and the number of steps. A number that indicates the position is printed at top right of each page.
When there is no added information

<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Conveyor control block</th>
<th>Normal SFC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start</td>
<td>M100</td>
<td>Trans M101</td>
<td>Pause M102</td>
</tr>
<tr>
<td>Pause</td>
<td>M103</td>
<td>Active D100</td>
<td>Continue M104</td>
</tr>
</tbody>
</table>

(1, 1)
• When there is added information (programs, device comments)

<table>
<thead>
<tr>
<th>Block No.</th>
<th>0</th>
<th>Title</th>
<th>Conveyor control block</th>
<th>Normal SFC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start</td>
<td>0</td>
<td>M100</td>
<td>Trans</td>
<td>M101</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Pause</td>
</tr>
<tr>
<td>Pause nd</td>
<td>0</td>
<td>M103</td>
<td>Active</td>
<td>D100</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Continue</td>
</tr>
</tbody>
</table>

(1, 1)

- Operation permission wait
- Operation permission switch ON
  - x00
- Work carrier detection wait
  - Work carrier detection
  - x2
- Buzzer output
  - y10, y70 x30
  - Buzzer output end
  - y70

- -> B6 CO
  - Product counter reset
    - Product counter reset
    - x0
  - Conveyor operation
    - x71
    - Product detection
      - x3
    - Product counter
      - x00 x6
- Product count end
  - x10 & x31
  - Conveyor stop
    - y71
  - y8
- x00000

- Work carrier control block start
  - 8

- x00000

5 - 4
(2) Block list printing example

<table>
<thead>
<tr>
<th>No.</th>
<th>Title/Information register</th>
<th>Block activation</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Conveyor control block</td>
<td>BL1</td>
</tr>
<tr>
<td></td>
<td>Start : M100</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Pause : M102</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Active : D100</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Work carrier control block</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Start : M200</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Pause : M202</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Active : D200</td>
<td></td>
</tr>
</tbody>
</table>

(3) Comment list printing example

The printed comment list is divided into step comments and transition comments.

- **Step comments**

<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Conveyor control block</th>
<th>Normal SFC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start</td>
<td>M100</td>
<td>Trans</td>
<td>M101</td>
</tr>
<tr>
<td>Pause md</td>
<td>M103</td>
<td>Active</td>
<td>M100</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Trancond</th>
<th>Comment</th>
<th>Dev Lbl</th>
</tr>
</thead>
<tbody>
<tr>
<td>t0</td>
<td>Operation permission switch ON</td>
<td></td>
</tr>
<tr>
<td>t1</td>
<td>Work carrier detection</td>
<td></td>
</tr>
<tr>
<td>t2</td>
<td>Buzzer output end</td>
<td></td>
</tr>
<tr>
<td>t3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>t4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>t5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>t6</td>
<td>Product detection</td>
<td></td>
</tr>
<tr>
<td>t7</td>
<td>Product detection</td>
<td></td>
</tr>
<tr>
<td>t8</td>
<td>Product count end</td>
<td></td>
</tr>
<tr>
<td>t9</td>
<td>Stop switch ON</td>
<td></td>
</tr>
<tr>
<td>t10</td>
<td>Jump to product count</td>
<td></td>
</tr>
<tr>
<td>t11</td>
<td></td>
<td></td>
</tr>
<tr>
<td>t12</td>
<td></td>
<td></td>
</tr>
<tr>
<td>t13</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Transition comments

<table>
<thead>
<tr>
<th>Block No.</th>
<th>Title</th>
<th>Normal SFC</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Start</td>
<td>Pause</td>
</tr>
<tr>
<td></td>
<td>Trans</td>
<td>Active</td>
</tr>
<tr>
<td></td>
<td>Continue</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Transaction</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>TR0</td>
<td>Operation error switch ON</td>
</tr>
<tr>
<td>TR1</td>
<td>Work carrier detection</td>
</tr>
<tr>
<td>TR2</td>
<td>Buzzer output end</td>
</tr>
<tr>
<td>TR3</td>
<td></td>
</tr>
<tr>
<td>TR4</td>
<td></td>
</tr>
<tr>
<td>TR5</td>
<td>Product detection</td>
</tr>
<tr>
<td>TR6</td>
<td>Product detection</td>
</tr>
<tr>
<td>TR7</td>
<td>Product count end</td>
</tr>
<tr>
<td>TR8</td>
<td>Stop switch ON</td>
</tr>
<tr>
<td>TR9</td>
<td>Jump to product count</td>
</tr>
<tr>
<td>TR10</td>
<td></td>
</tr>
<tr>
<td>TR11</td>
<td></td>
</tr>
<tr>
<td>TR12</td>
<td></td>
</tr>
<tr>
<td>TR13</td>
<td></td>
</tr>
</tbody>
</table>

(4) Block parameter printing example

<table>
<thead>
<tr>
<th>Block parameter</th>
<th>[MAIN]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Periodic exec Blk</td>
<td>[ ] After</td>
</tr>
<tr>
<td>Execution interval</td>
<td>[ ] ms</td>
</tr>
<tr>
<td>Action at BL multi-act</td>
<td>Stop [ ]-[ ]</td>
</tr>
<tr>
<td>Action at step Multi-activated</td>
<td>Waiting [ ]-[ ]</td>
</tr>
<tr>
<td></td>
<td>Stop [ ]-[ ]</td>
</tr>
</tbody>
</table>
**INDEX**

**[A]**
- Active step monitor ......................................... 4- 5
- All block batch monitor ................................... 4- 5

**[B]**
- Block list monitor ............................................ 4- 6
- Block parameters .......................................... 3-33

**[C]**
- Changing the Step attribute .......................... 3-20
- Changing the T/C set values .......................... 3-46
- Changing Timer/counter set values ................. 3-46
- Contact/coil use list ....................................... 3-46
- Conversion operation .................................... 3-34
- Copying the SFC diagram ............................... 3-21
- Creating an SFC comment .............................. 3-27
- Creating Operation Outputs and Transition Conditions ...................................................... 3-26
- Creating the SFC diagram ............................... 3- 7
- Cutting the SFC diagram ............................... 3- 21

**[D]**
- Deleting the SFC diagram............................... 3-19
- Device test...................................................... 4- 7
- Device use list ............................................... 3-46
- Displaying a program in the MELSAP3 format ................................................................. 3-50
- Displaying programs ....................................... 3-47
- Displaying Step_transition comment ............. 3-48
- Displaying the block list ................................. 3-31
- Displaying the device label ........................... 3-49
- Displaying the alias ....................................... 3-49
- Displaying the alias in the SFC Diagram ....... 3-49
- Displays SFC comments .................................. 3-48

**[I]**
- Instructions for online SFC program writing . 3-35
- Instructions for Transition Conditions .......... 2- 3

**[M]**
- MELSAP-L format SFC diagram ..................... 2- 1
- Modifying the SFC diagram ............................ 3- 7

**[O]**
- Operation method created from the tool button ......................................................................... 3- 8
- Operation output instructions ....................... 2- 2
- Operation starting from the **Entry** key ....... 3-18
- Operation starting from the function key ...... 3-17
- Operation starting from the menu on the toolbar ....................................................................... 3-18

**[P]**
- Pasting the SFC diagram ................................ 3-21
- Precautions ...................................................... 2- 5
- Printing examples .......................................... 5- 2

**[R]**
- Redisplaying the SFC diagram ..................... 3-25
- Replacing the Open/Close contacts.............. 3-43
- Replacing a character string ......................... 3-44
- Replacing the devices .................................... 3-39
- Replacing the instructions ............................ 3-41
- Replacing the Step No................................... 3-45

**[S]**
- Searching for a character string .................. 3-38
- Searching for a device ................................. 3-36
- Searching for a device comment ................. 3-39
- Searching for an instruction ........................ 3-37
- Searching for the block No ............................ 3-38
- Searching for the device use status ............ 3-46
- Searching for the Step No. .......................... 3-38
- Setting the block information ...................... 3-30
- Setting the SFC diagram display ................ 3-51
- Setting the SFC setting options ................. 3-52
- SFC diagram monitor .................................... 4- 1
- SFC diagram print setting ......................... 5- 1
- SFC diagram symbols .................................. 3- 3
- SFC program setting ..................................... 3-34
- SFC setting in PLC parameter ................. 3-32
- SFC-related parameter settings ............... 3-32
- Sorting the SFC diagram ............................. 3-24
- Step transition watchdog monitor ............. 4- 4
MITSUBISHI ELECTRIC CORPORATION
HEAD OFFICE: TOKYO BUILDING, 2-7-3 MARUNOUCHI, CHIYODA-KU, TOKYO 100-8310, JAPAN
NAGOYA WORKS: 1-14, YADA-MINAMI 5-CHOME, HIGASHI-KU, NAGOYA, JAPAN

When exported from Japan, this manual does not require application to the Ministry of Economy, Trade and Industry for service transaction permission.

Specifications subject to change without notice.