• SAFETY PRECAUTIONS •

(Always read these instructions before using this equipment.)

Before using this product, please read this manual and the relevant manuals introduced in this manual carefully and pay full attention to safety to handle the product correctly.

The instructions given in this manual are concerned with this product. For the safety instructions of the programmable controller system, please read the CPU module user’s manual.

In this manual, the safety instructions are ranked as “DANGER” and “CAUTION”.

⚠️ DANGER

Indicates that incorrect handling may cause hazardous conditions, resulting in death or severe injury.

⚠️ CAUTION

Indicates that incorrect handling may cause hazardous conditions, resulting in medium or slight personal injury or physical damage.

Note that the ⚠️ CAUTION level may lead to a serious consequence according to the circumstances. Always follow the instructions of both levels because they are important to personal safety.

Please save this manual to make it accessible when required and always forward it to the end user.

[Design Instructions]

⚠️ DANGER

- For data change, program change, and status control made to the PLC which is running from a Personal computer, configure the interlock circuit externally so that the system safety is ensured. The action to be taken for the system at the occurrence of communication errors caused by such as loose cable connection must be determined for online operation of PLC from Personal computers.

⚠️ CAUTION

- Be sure to read the manual careful and exercise an appropriate amount of caution connecting to PLC CPU and performing online operations (PLC CPU program change during RUN, forced input/output operation, RUN-STOP or other operation condition changes, remote control operation) while the personal computer is operating.

Regarding the PLC CPU program change during RUN (Write during RUN), the program may be corrupted or have other problems depending on operation conditions. Exercise the appropriate amount of caution with regard to the Caution points in section 16.9.
Revisions

*The manual number is given on the bottom left of the back cover.

<table>
<thead>
<tr>
<th>Print Date</th>
<th>*Manual Number</th>
<th>Revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jun, 2000</td>
<td>IB(NA)-0800134-A</td>
<td>First edition</td>
</tr>
</tbody>
</table>
| Sep, 2000  | IB(NA)-0800134-B | • The Windows-based software products were integrated into the Mitsubishi MELSOFT Integrated Software series from the Mitsubishi MELSEC general-purpose PLC series.  
• The software package names (GPP Function, Logic test function (LLT), etc.) were standardized as the product names (GX Developer, GX Simulator, etc.).  
• Addition of the description of label programming  
• Addition of the description of MELSECNET/H remote I/O  
• Addition of the description of Ethernet diagnostics  
• Addition of the description of instruction help  
• Addition of the description of list monitoring |
| Dec, 2000  | IB(NA)-0800134-C | Added functions related to SW6D5C-GPPW-E 6.05F. (See Appendix 14 for details.) |

**Addition**

Abbreviations and terms in This Manual, Section 1.1, 3.2.1, 5.1, 5.1.2, 5.1.9, 6.4.14, 6.4.15, 13.2.2, 13.2.3, 14.5.2, 14.5.3, 15.12, 15.13, 16.3, 17.5.1, 20.2, APPENDICES 9, APPENDICES 14

**Correction**

Section 2.2, 2.4, 4.2, 6.4.5, 6.4.7, 10.5, 16.2.1(2), 16.2.3(2), APPENDICES 2.2, APPENDICES 2.3, APPENDICES 2.4

This manual confers no industrial property rights or any rights of any other kind, nor does it confer any patent licenses. Mitsubishi Electric Corporation cannot be held responsible for any problems involving industrial property rights which may occur as a result of using the contents noted in this manual.

© 2000 MITSUBISHI ELECTRIC CORPORATION
INTRODUCTION

Thank you for choosing the Mitsubishi MELSOFT series Integrated FA software. Read this manual and make sure you understand the functions and performance of MELSEC series sequencer thoroughly in advance to ensure correct use. Please make this manual available to the end user.

SAFETY PRECAUTIONS..............................................................................................................................A - 1
REVISIONS....................................................................................................................................................A - 2
CONTENTS....................................................................................................................................................A - 3
About Manuals .............................................................................................................................................A - 13
How the manual describes the explanation is shown below .................................................................A - 14
Abbreviations and Terms in This Manual..................................................................................................A - 16

## CONTENTS

### Chapter 1  GENERAL DESCRIPTION  1-  1 to 1- 13

1.1  Functions Lists ........................................................................................................................................ 1-  3
1.2  FX Series Programming ........................................................................................................................ 1- 11
1.3  Basic Key Specifications........................................................................................................................ 1- 13

### Chapter 2  SYSTEM CONFIGURATION  2-  1 to 2-  10

2.1  Connection from the Serial Port ............................................................................................................. 2-  1
2.2  Connection from the Interface Boards.................................................................................................... 2-  4
2.3  System Equipment Lists ......................................................................................................................... 2-  5
2.4  Precautions for Handling Project on the Earier Versions ...................................................................... 2-  8
   2.4.1  When handling a project on GX Developer (SW4D5-GPPW-E) or earlier..................................... 2-  8
   2.4.2  When handling a project on GX Developer (SW5D5-GPPW-E) or earlier..................................... 2-  9
   2.4.3  Handling a Project in GX Developer (SW6D5-GPPW-E 6.04E or Older)..................................... 2- 10

### Chapter 3  COMMON OPERATIONS  3-  1 to 3- 23

3.1  List of Shortcut Keys and Access Keys.................................................................................................. 3-  1
3.2  Project Designation................................................................................................................................. 3-  5
   3.2.1  Saving a project............................................................................................................................. 3-  6
   3.2.2  Opening a project............................................................................................................................. 3-  9
3.3  Cut, Copy, and Paste............................................................................................................................. 3- 10
   3.3.1  Cut and paste ............................................................................................................................... 3- 10
   3.3.2  Copy and paste ............................................................................................................................. 3- 12
   3.3.3  Notes on cutting, copying and pasting network parameters.......................................................... 3- 14
3.4  Toolbar ................................................................................................................................................... 3- 16
3.5  Status Bar............................................................................................................................................... 3- 17
3.6  Zooming in on or out of the Edit Screen................................................................................................ 3- 18
3.7  Project Data List..................................................................................................................................... 3- 19
3.8  Comment Display................................................................................................................................... 3- 21
3.9  Statement Display.................................................................................................................................. 3- 21
3.10  Note Display......................................................................................................................................... 3- 21
3.11  Alias Display......................................................................................................................................... 3- 22

A - 3
Chapter 4  INITIALIZATION  4-  1 to 4- 29

4.1 Creating a Project ....................................................................................................................................... 4-  1
4.2 Opening the Existing Project File .................................................................................................................. 4-  3
4.3 Closing a Project File ..................................................................................................................................... 4-  5
4.4 Saving a Project ............................................................................................................................................. 4-  5
4.5 Saving a Project with a New Name .................................................................................................................. 4-  6
4.6 Deleting a Project ......................................................................................................................................... 4-  6
4.7 Verifying Data in Projects ............................................................................................................................. 4-  7
4.8 Copying a Project .......................................................................................................................................... 4-  9
4.9 Adding Data to a Project ................................................................................................................................. 4- 11
4.10 Copying Data within a Project ...................................................................................................................... 4- 12
4.11 Deleting Data in a Project ............................................................................................................................. 4- 14
4.12 Renaming Data in a Project ............................................................................................................................ 4- 15
4.13 Changing the Ladder and SFC with each other............................................................................................ 4- 16
4.14 Changing the PLC Type of a Project ............................................................................................................. 4- 17
4.15 Reading Other Format Files ......................................................................................................................... 4- 18
  4.15.1 Reading GPPQ, GPPA, FXGP(DOS) or FXGP(WIN) files........................................................................... 4- 18
  4.15.2 Reading a MELSEC MEDOC format file (Printout) .................................................................................. 4- 22
  4.15.3 Reading a MELSEC MEDOC format file ................................................................................................ 4- 23
4.16 Exporting GPPQ, GPPA, FXGP(DOS) or FXGP(WIN) Files ................................................................. 4- 25
4.17 Starting Multiple Projects ............................................................................................................................ 4- 29
4.18 Existing GX Developer .................................................................................................................................. 4- 29

Chapter 5  STANDARDIZING THE PROGRAMS  5-  1 to 5- 30

5.1 Label programming ........................................................................................................................................ 5-  1
  5.1.1 Label programming sequence ................................................................................................................... 5-  6
  5.1.2 Label programming input method ............................................................................................................ 5-  7
  5.1.3 Making global variable/local variable setting .......................................................................................... 5-  9
  5.1.4 Making automatic device setting ............................................................................................................ 5- 13
  5.1.5 Deleting External ..................................................................................................................................... 5-14
  5.1.6 All deletion ............................................................................................................................................... 5-14
  5.1.7 Importing device comments .................................................................................................................... 5-15
  5.1.8 Exporting to device comments ............................................................................................................... 5-16
  5.1.9 Converting label programs into actual programming (Compile) ............................................................ 5-18
  5.1.10 Displaying the Device Program ........................................................................................................... 5-20
5.2 About Macros ............................................................................................................................................... 5-21
  5.2.1 Registering a macro .................................................................................................................................. 5-23
  5.2.2 Utilizing a macro ....................................................................................................................................... 5-25
  5.2.3 Deleting a macro ....................................................................................................................................... 5-27
  5.2.4 Displaying macro ...................................................................................................................................... 5-28
Chapter 6  CREATING CIRCUIT  6-  1 to 6- 50

6.1 Restrictions on Circuit Creation .............................................................................................................. 6- 7
6.1.1 Restrictions in circuit display window .................................................................................................... 6- 7
6.1.2 Restrictions in circuit edit window ......................................................................................................... 6- 8
6.2 Creating and Editing Circuits .................................................................................................................... 6- 12
6.2.1 Inputting contacts and application instructions .................................................................................... 6- 12
6.2.2 Inputting lines (vertical and horizontal) ............................................................................................... 6- 14
6.2.3 Deleting contacts and application instructions .................................................................................... 6- 16
6.2.4 Deleting connecting lines .................................................................................................................... 6- 17
6.2.5 Inserting and deleting in circuit blocks ............................................................................................... 6- 18
6.2.6 Inserting NOPs .................................................................................................................................... 6- 20
6.2.7 Deleting NOPs .................................................................................................................................... 6- 20
6.2.8 Cutting, copying and pasting circuits ................................................................................................... 6- 21
6.2.9 Undo the last operation ........................................................................................................................ 6- 23
6.2.10 Returning to the status after ladder conversion .................................................................................. 6- 24

6.3 Changing T/C Setting Values .................................................................................................................... 6- 25
6.4 Find and Replace ..................................................................................................................................... 6- 27
6.4.1 Finding a device ...................................................................................................................................... 6- 29
6.4.2 Finding an instruction ............................................................................................................................ 6- 31
6.4.3 Finding a step No. .................................................................................................................................... 6- 32
6.4.4 Finding a character string ...................................................................................................................... 6- 33
6.4.5 Finding a contact/coil ............................................................................................................................. 6- 35
6.4.6 Finding data .......................................................................................................................................... 6- 36
6.4.7 Replacing a device ............................................................................................................................... 6- 37
6.4.8 Replacing an instruction ........................................................................................................................ 6- 39
6.4.9 Changing A and B contacts .................................................................................................................. 6- 41
6.4.10 Replacing a character string .............................................................................................................. 6- 42
6.4.11 Replacing the module’s first I/O number ............................................................................................ 6- 44
6.4.12 Changing the statement or note type ................................................................................................. 6- 45
6.4.13 Replacing data .................................................................................................................................... 6- 46
6.4.14 Searching for a contact coil ................................................................................................................ 6- 47
6.4.15 Searching for a device-use instruction ............................................................................................... 6- 49

Chapter 7  CREATING INSTRUCTION LIST  7-  1 to 7- 11

7.1 Common Notes on Instruction List Creation ............................................................................................ 7- 1
7.2 Creating a Program Instruction list .......................................................................................................... 7- 3
7.2.1 Inputting a contact or application instruction ...................................................................................... 7- 3
7.2.2 Changing the existing program in overwrite mode .............................................................................. 7- 4
7.2.3 Inserting or adding the existing program ............................................................................................. 7- 5
7.2.4 Deleting the existing program list ........................................................................................................ 7- 6
7.2.5 Inserting NOPs ..................................................................................................................................... 7- 7
7.2.6 Deleting NOPs ..................................................................................................................................... 7- 7
7.3 Find and Replace ..................................................................................................................................... 7- 8
7.3.1 Finding a device ..................................................................................................................................... 7- 8
7.3.2 Finding an instruction ............................................................................................................................ 7- 8
7.3.3 Finding a step No. .................................................................................................................................. 7- 8
7.3.4 Finding a character string ................................................................................................................ 7- 8
7.3.5 Finding a contact/coil ......................................................................................................................... 7- 8
7.3.6 Replacing a device ............................................................................................................................. 7- 8
7.3.7 Replacing an instruction ..................................................................................................................... 7- 8
7.3.8 Changing an A or B contact ................................................................................................................ 7- 9
7.3.9 Replacing a character string ............................................................................................................. 7- 9
7.3.10 Change module start address ......................................................................................................... 7- 9
7.3.11 Changing the statement or note type ............................................................................................... 7- 9
7.3.12 Searching for a contact coil ........................................................................................................... 7- 9
7.3.13 Searching for an instruction using a device .................................................................................... 7- 9
7.4 Display .................................................................................................................................................... 7- 10
7.4.1 Displaying a Alias ............................................................................................................................. 7- 10
7.5 Switching Read and Write Modes ....................................................................................................... 7-11
7.5.1 Switching to read mode ................................................................................................................... 7-11
7.5.2 Switching to write mode .................................................................................................................. 7-11
7.5.3 Switching to circuit mode ................................................................................................................ 7-11
7.6 Changing T/C Setting Values ............................................................................................................. 7-11

Chapter 8 CONVERSION 8- 1 to 8- 2

8.1 Converting an Edit Program ............................................................................................................. 8- 1
8.2 Converting Multiple Edit Programs .................................................................................................. 8- 1

Chapter 9 SETTING DEVICE COMMENTS 9- 1 to 9-28

9.1 Points to be Noted before Comment Creation with GX Developer ................................................... 9- 1
9.1.1 Editing comments only on peripheral devices ................................................................................ 9- 4
9.1.2 Writing to ACPU/GPPA file ............................................................................................................ 9- 6
9.1.3 Reading from ACPU/GPPA file ....................................................................................................... 9- 7
9.1.4 Writing to QCPU(Q mode) QnACPU/GPPQ file ............................................................................. 9- 9
9.1.5 Reading from QCPU(Q mode) QnACPU ......................................................................................... 9- 9
9.1.6 Writing to FXCPU/FXGP(DOS), FXGP(WIN) file ....................................................................... 9-10
9.1.7 Reading from FXCPU/FXGP(DOS), FXGP(WIN) file .................................................................... 9-11
9.2 List of Device Comments .................................................................................................................. 9-12
9.3 Common Comments and Comments by Program .......................................................................... 9-13
9.4 Creating Device Comments ............................................................................................................. 9-16
9.4.1 Creating device comments on the device comment edit window .................................................. 9-16
9.4.2 Creating device comments for the created circuit ........................................................................ 9-18
9.4.3 Creating device comments after creating a circuit ....................................................................... 9-19
9.4.4 Editing comments on the ladder editing screen .......................................................................... 9-20
9.5 Deleting Device Comments ............................................................................................................ 9-21
9.5.1 Deleting all device comments and Alias ....................................................................................... 9-21
9.5.2 Deleting display device comments and Alias ............................................................................... 9-21
9.6 Setting Comment Types .................................................................................................................. 9-22
9.7 Setting Comment Ranges ................................................................................................................ 9-24

Chapter 10 SETTING STATEMENTS AND NOTES 10- 1 to 10-20

10.1 About the Statements/Notes ........................................................................................................ 10- 1
10.2 About Merging Operation Procedure ........................................................................................... 10- 6
Chapter 11  SETTING DEVICE MEMORY (DWR SETTING) 11- 1 to 11- 6

11.1 Device Memory ............................................................... 11- 1
11.2 Device Value Input .......................................................... 11- 2
11.3 All Clear .............................................................................. 11- 5
    11.3.1 Clearing all devices ................................................... 11- 5
    11.3.2 Clearing all display devices ....................................... 11- 5
11.4 Making Fill Settings ....................................................... 11- 6

Chapter 12  SETTING DEVICE INITIALIZATION VALUES 12- 1 to 12- 2

Chapter 13  SETTING THE PARAMETERS 13- 1 to 13- 24

13.1 Setting the PLC Parameters ............................................... 13- 3
    13.1.1 Common Notes on Parameters .................................. 13- 4
    13.1.2 PLC Parameter Item Lists ........................................ 13- 7
    13.1.3 Explanations for PLC Parameter Setting Screen .......... 13- 14
13.2 Setting the Network Parameters ...................................... 13- 15
    13.2.1 About items common to the Network parameters ........ 13- 16
    13.2.2 Network parameter item lists .................................... 13- 18
    13.2.3 Explanation for network parameter setting screen ....... 13- 23
13.3 Setting the Remote Password .......................................... 13- 24

Chapter 14  PRINT 14- 1 to 14- 37

14.1 Setting Up a Printer ....................................................... 14- 2
14.2 Setting a Page Layout ..................................................... 14- 4
14.3 Previewing a Print Image ................................................ 14- 7
14.4 Printing ............................................................................ 14- 9
14.5 Setting the Details for Printing ....................................... 14- 12
    14.5.1 Creating a title ...................................................... 14- 12
### Chapter 15 OTHER FUNCTIONS

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>15.1 Checking Programs</td>
<td>15-1</td>
</tr>
<tr>
<td>15.2 Merging Programs</td>
<td>15-3</td>
</tr>
<tr>
<td>15.3 Checking Parameters</td>
<td>15-6</td>
</tr>
<tr>
<td>15.4 All-clearing the Parameters</td>
<td>15-7</td>
</tr>
<tr>
<td>15.5 IC Memory Card (GX Developer → IC Memory Card)</td>
<td>15-8</td>
</tr>
<tr>
<td>15.5.1 Reading the data of the IC memory card</td>
<td>15-10</td>
</tr>
<tr>
<td>15.5.2 Writing data to the IC memory card</td>
<td>15-11</td>
</tr>
<tr>
<td>15.6 Intelligent Function Utility</td>
<td>15-12</td>
</tr>
<tr>
<td>15.7 Transferring ROM Data</td>
<td>15-14</td>
</tr>
<tr>
<td>15.7.1 ROM reading, writing, and verification</td>
<td>15-20</td>
</tr>
<tr>
<td>15.7.2 Writing to files in ROM format</td>
<td>15-22</td>
</tr>
<tr>
<td>15.8 Batch-Deleting the Unused Device Comments</td>
<td>15-24</td>
</tr>
<tr>
<td>15.9 Customizing Keys</td>
<td>15-25</td>
</tr>
<tr>
<td>15.10 Changing the Display Color</td>
<td>15-26</td>
</tr>
<tr>
<td>15.11 Setting Options</td>
<td>15-27</td>
</tr>
<tr>
<td>15.12 Displaying Multiple Windows</td>
<td>15-35</td>
</tr>
<tr>
<td>15.13 Opening a Specific Project Using a Shortcut</td>
<td>15-36</td>
</tr>
<tr>
<td>15.14 Starting the Ladder Logic Test Tool</td>
<td>15-37</td>
</tr>
<tr>
<td>15.15 Outline of Help Function</td>
<td>15-37</td>
</tr>
</tbody>
</table>

### Chapter 16 CONNECTING A PLC

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>16.1 Specifying the Connection Target</td>
<td>16-1</td>
</tr>
<tr>
<td>16.1.1 When accessing the own station</td>
<td>16-1</td>
</tr>
<tr>
<td>16.1.2 When accessing the other station</td>
<td>16-4</td>
</tr>
<tr>
<td>16.1.3 Accessing multiple CPUs</td>
<td>16-10</td>
</tr>
<tr>
<td>16.1.3 (1) About access to other multiple CPU modules</td>
<td>16-10</td>
</tr>
<tr>
<td>16.1.3 (2) About network access via multiple CPUs</td>
<td>16-12</td>
</tr>
<tr>
<td>16.2 Making access via Ethernet, CC-Link, G4 module, C24 or telephone line</td>
<td>16-15</td>
</tr>
<tr>
<td>16.2.1 Setting method for communication via the ethernet board</td>
<td>16-15</td>
</tr>
<tr>
<td>16.2.1 (1) For A series</td>
<td>16-15</td>
</tr>
</tbody>
</table>
16.1 Executing PLC read/PLC write ........................................................................................................ 16- 52
16.2 Setting the read/write range for device data .................................................................................... 16- 58
16.3 Setting the program reading/writing range ...................................................................................... 16- 60
16.4 Setting the comment read/write range ............................................................................................ 16- 61
16.5 Write to PLC (Flash ROM) ............................................................................................................. 16- 68
16.6 Deleting Data in the PLC ................................................................................................................ 16- 69
16.7 Changing PLC Data Attributes ...................................................................................................... 16- 71
16.8 Reading/Writing PLC User Data ..................................................................................................... 16- 74
16.9 Writing PLC user data ..................................................................................................................... 16- 75
16.10 Concept of the Routing Parameters ............................................................................................... 16- 82

17.1 Monitoring, and Stopping/Resuming Monitoring ........................................................................... 17- 3
17.2 Monitoring/Stopping Monitoring in All Windows .......................................................................... 17- 6
17.3 Editing Programs During Ladder Monitoring ................................................................................ 17- 7
17.4 Switching Present Values Between Decimal and Hexadecimal .................................................... 17- 9
17.5 Batch Monitoring Devices/Buffer Memories .................................................................................. 17-10
17.5.1 Batch-monitoring the multi-CPU buffer memory ....................................................................... 17-14
17.6 Monitoring after Registering Devices ............................................................................................. 17-15
17.7 Setting Monitor Conditions/Stop Conditions ................................................................................ 17-18
17.8 Program List Monitor ...................................................................................................................... 17-20
17.9 Monitoring the Interrupt Program List ............................................................................................ 17-23
17.10 Measuring Scan Time ....................................................................................................................... 17-24
17.11 Executing Sampling Trace ............................................................................................................... 17-25
17.11.1 Setting execution & status display ............................................................................................. 17-26
17.11.2 Setting trace data ......................................................................................................................... 17-29
17.11.3 Setting trace conditions ............................................................................................................... 17-31
17.12 Monitoring the Ladders Registered ................................................................................................. 17-33
17.13 Deleting All Ladders Registered .................................................................................................... 17-34
Chapter 18  DEBUGGING PROGRAMS  18- 1 to 18- 18

18.1 Carrying Out a Device Test ................................................................. 18- 2
18.2 Registering/Canceling the Forced I/O ............................................. 18- 5
18.2.1 Registration to PLC CPU .............................................................. 18- 5
18.2.2 Registration/cancellation to remote I/O station .......................... 18- 6
18.3 Carrying Out Partial Operation ....................................................... 18- 7
18.4 Executing Step Run ......................................................................... 18- 11
18.5 Setting the Scan Range .................................................................... 18- 14
18.6 Operating the PLC Remotely .............................................................. 18- 16

Chapter 19  REGISTERING KEYWORD/PASSWORDS  19- 1 to 19- 10

19.1 Registering Keyword ......................................................................... 19- 1
19.1.1 Registering new keyword/changing keyword ............................. 19- 1
19.1.2 Canceling a keyword .................................................................... 19- 4
19.1.3 Releasing a keyword ................................................................... 19- 5
19.2 Registering Passwords ....................................................................... 19- 6
19.2.1 Register new passwords/changing passwords ............................. 19- 7
19.2.2 Delete the passwords ................................................................... 19- 9
19.2.3 Disable the passwords ................................................................. 19- 10

Chapter 20  PLC MEMORY  20- 1 to 20- 10

20.1 Clearing the PLC Memory ................................................................. 20- 1
20.1.1 All-clearing on ACPU memory .................................................... 20- 1
20.1.2 All-clearing the QCPU, QnACPU device memory .................... 20- 3
20.1.3 All-clearing an FXCPU memory.................................................. 20- 4
20.2 Formatting a QCPU (Q mode), QnACPU Memory ............................ 20- 6
20.3 Sorting the QCPU (Q mode), QnACPU Memory ............................... 20- 8
20.4 Setting for the PLC's Clock .............................................................. 20- 9

Chapter 21  DIAGNOSIS  21- 1 to 21- 48

21.1 Diagnosing the PLC ................................................................. 21- 1
21.1.1 Diagnosing an ACPU ................................................................. 21- 1
21.1.2 Diagnosing a QCPU (Q mode), QnACPU ................................. 21- 3
21.1.3 Diagnosing the QCPU (Q Mode) ................................................ 21- 5
21.1.4 Diagnosing an FXCPU ............................................................... 21- 7
21.2 Diagnosing a Network ................................................................. 21- 8
21.2.1 Testing a network ...................................................................... 21- 10
21.2.2 Performing a loop test ............................................................... 21- 11
21.2.3 Performing a setting confirmation test ...................................... 21- 12
21.2.4 Performing a station order confirmation test ............................ 21- 14
21.2.5 Performing a transmission test .................................................. 21- 16
21.2.6 Monitoring the error history ...................................................... 21- 17
21.2.7 Network monitor details ............................................................. 21- 19
21.2.8 Monitoring other station information ........................................ 21- 20
21.3 Running CC-Link Diagnostics ....................................................... 21- 23

A - 10
Chapter 22 SETTING A6TEL/Q6TEL/FX2N DATA 22-1 to 22-38

22.1 Function Setting Item List ................................................................. 22-2
22.2 Preparations for Connecting the Telephone Line ........................................ 22-3
  22.2.1 Making remote access/pager notice (for ACPU) .............................. 22-3
  22.2.2 Making remote access/pager notice (for QnACPU) ......................... 22-5
  22.2.3 Making remote access to FXCPU .................................................. 22-7
  22.2.4 Making Q6TEL-Q6TEL communication ...................................... 22-9
22.3 Making Initial Setting of Data .............................................................. 22-12
  22.3.1 Creating a phone number book ..................................................... 22-12
  22.3.2 Registering the AT command ....................................................... 22-16
  22.3.3 Registering A6TEL data ............................................................... 22-19
  22.3.4 Registering Q6TEL data ............................................................... 22-23
  22.3.5 Setting the FX PLC .................................................................... 22-28
22.4 Connecting/Disconnecting the Line ..................................................... 22-32
  22.4.1 Connecting the line automatically ................................................. 22-32
  22.4.2 Connecting the line via a switchboard (manual connection) .......... 22-36
  22.4.3 Disconnecting the line ................................................................. 22-38

Chapter 23 MXCHANGE CONVERSION FUNCTIONS 23-1 to 23-14

23.1 Function List ................................................................................... 23-1
23.2 General Procedure for Using the MXChange Conversion Functions .......... 23-2
23.3 Logging in to the Server .................................................................. 23-3
23.4 Logging off the Server ..................................................................... 23-5
23.5 MXChange Data Base Conversion ................................................... 23-6
23.6 Import from MXChange Tags ............................................................ 23-8
23.7 Export to MXChange Tags ............................................................... 23-10
23.8 MXChange Troubleshooting ............................................................. 23-14
Appendix 1 GPP Function Access Ranges in MELSECNET(II/10) Systems
1.1 Access Range with MELSECNET (II) ................................................................. Appendix-1
1.2 Access Range for an A Series Start ................................................................ Appendix-3
1.3 Access Range for a QnA Series Start ................................................................ Appendix-5
1.4 Access Range at a Q Series Start ....................................................................... Appendix-8
Appendix 2 MELSECNET/10 Board Access Range .................................................... Appendix-9
2.1 MELSECNET/10 Board ....................................................................................... Appendix-9
2.1.1 "A" series start .................................................................................................. Appendix-11
2.1.2 QnA series start ................................................................................................ Appendix-13
2.1.3 At Q series start ................................................................................................ Appendix-15
2.2 Access Range via an Ethernet Board ................................................................. Appendix-16
2.3 Access Range via CC-Link (AJ65BT-G4) ............................................................ Appendix-19
2.4 Access Range via Computer Link ...................................................................... Appendix-21
2.5 Access Range via Serial Communication .......................................................... Appendix-23
2.6 Access Range for Mixed System ......................................................................... Appendix-24
Appendix 3 Using Data of Other Applications .......................................................... Appendix-26
3.1 Using Excel Files as Device Comments ............................................................... Appendix-26
3.2 Using a Word File as a Device Comment ............................................................ Appendix-28
Appendix 4 Restrictions on PLC Type Change ........................................................ Appendix-30
Appendix 5 Examples of Wiring RS-232C Cable for Connection
of C24 and Personal computer .................................................................................. Appendix-39
5.1 A Series ............................................................................................................... Appendix-39
5.2 QnA Series .......................................................................................................... Appendix-41
5.3 Q Series ............................................................................................................... Appendix-43
Appendix 6 ROM Writer Wiring Examples ............................................................... Appendix-44
Appendix 7 PLC CPU Version Correspondence Chart ........................................... Appendix-45
7.1 About QnA series function versions .................................................................. Appendix-45
7.2 About Q4ARCPU function version .................................................................... Appendix-46
7.3 About the Q series function version .................................................................. Appendix-47
Appendix 8 Restrictions and Cautions ..................................................................... Appendix-48
Appendix 9 About SW D5-GPPW Compatibility ..................................................... Appendix-57
Appendix 10 GX Developer and LLT Operations ..................................................... Appendix-59
Appendix 11 Notes on FX Series Programming ...................................................... Appendix-60
11.1 Ladder Monitor Display .................................................................................... Appendix-60
11.2 Handling of Comments ..................................................................................... Appendix-63
Appendix 12 Instruction Conversion Lists ............................................................... Appendix-64
12.1 Instruction Conversion List for A ↔ Q/QnA Conversions .................................. Appendix-64
12.2 A Instruction Conversion List for FX Series Conversions ................................. Appendix-84
12.3 List of Instruction Conversions for Change between Q Series and A/QnA Series .... Appendix-97
Appendix 13 About the A6TEL/Q6TEL ............................................................... Appendix-100
13.1 A6TEL/Q6TEL Switch Settings ....................................................................... Appendix-100
13.2 How to Change the Proximate Mode of the Q6TEL ......................................... Appendix-103
Appendix 14 Functions Added to Update from Previous Version ............................... Appendix-104
Appendix 15 The strings which can not be used in label programming .................... Appendix-105
About Manuals

The following lists the manuals for this software package. Refer to the following table when ordering manuals.

Related Manuals

<table>
<thead>
<tr>
<th>Manual Name</th>
<th>Manual No. (Model Code)</th>
</tr>
</thead>
<tbody>
<tr>
<td>GX Developer Version6 GX Developer Version5 Operating Manual (Startup). Describes the system configuration, installation procedure, and start-up procedure of the SW5D5C-GPPW-E and SW5D5C-LLT-E software packages.</td>
<td>IB-0800133</td>
</tr>
<tr>
<td>GPP Function software for Windows SW4D5C-GPPW SW4D5F-GPPW SW4D5C-LLT Starting GPPW. Describes the following using illustrations for persons who use SW4D5C-GPPW and SW4D5C-LLT for the first time: installation procedure, start-up procedure, basic information, ladder creating and editing procedure, printing out procedure, monitoring procedure, and debugging procedure.</td>
<td>IB-0800057 (13J966)</td>
</tr>
<tr>
<td>Ladder Logic Test Function Software for Windows SW5D5C-LLT Operating Manual. This manual gives a product summary, device memory monitoring and setting/operating methods for machine simulation.</td>
<td>IB-0800118</td>
</tr>
<tr>
<td>GX Developer Version6 Operating Manual (SFC). Provides the program creation method, print-out method and so on using SW6D5-GPPW.</td>
<td>IB-0800135</td>
</tr>
<tr>
<td>Data Conversion Software Package for Windows SW0D5C-CNVW-E Operating Manual. Explains the data conversion method and other functions using SW0D5C-CNVW-E.</td>
<td>IB-0800004 (13J949)</td>
</tr>
<tr>
<td>GX Developer Version6 Manual (MELSAP-L). Provides the program creation method, print-out method and so on using SW6D5C-GPPW.</td>
<td>IB-0800136</td>
</tr>
</tbody>
</table>
5.11 Renaming Data in a Project

[Purpose] Renames the existing data in a project.

[Operating Procedure] Select [Project] → [Edit data] → [Rename].

[Dialog Box]

1) Data type
   Designates the data type (program, common comment, comments by program, device memory).

2) Data name before renaming
   Designates the data name before renaming.

3) Renamed data name
   Designates the new data name after renaming.
   The data name must be designated in up to 8 characters.

4) Title
   Displays the set title of the data.
   If necessary, the title can be edited and stored.
   It must be designated in up to 32 characters.

5) OK button
   Click this button after making necessary settings.

[Description]

POIINT
This operation cannot change the data name of comments by program to "COMMENT".
For changing the comments by program to the common comment (COMMENT), refer to "Setting Comment Types" (Section 9.6).
Symbols used in this manual, and the contents and examples of them are shown below.

<table>
<thead>
<tr>
<th>No.</th>
<th>Symbol</th>
<th>Contents</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>1)</td>
<td>[ ]</td>
<td>Menu name of menu bar</td>
<td>[Project]</td>
</tr>
<tr>
<td>2)</td>
<td></td>
<td>Icon in toolbar</td>
<td></td>
</tr>
<tr>
<td>3)</td>
<td>&lt;&lt; &gt;&gt;</td>
<td>Tab name of dialog box</td>
<td>&lt;&lt;Program common&gt;&gt;</td>
</tr>
<tr>
<td>4)</td>
<td></td>
<td>Command button in dialog box</td>
<td>[OK] button</td>
</tr>
</tbody>
</table>

The functions that cannot be operated on GX Developer are grayed (masked) and cannot be selected. There are the following reasons why they are not selectable.

1) The PLC CPU used does not have the functions
   For example, when the A1SCPU is chosen as the PLC type, it does not have the STEP-RUN function and therefore [Online] → [Debug] → [Debug] cannot be selected.
   To see if your PLC CPU has the operable functions, check the specifications in the PLC CPU user’s manual or the like.

2) The functions cannot be selected because they cannot be used with the currently operated function
   For example, when the monitor screen is open, PLC type change, connection setup, PLC data attribute change, data coupling, parameter check and all parameter clear cannot be performed.

Abbreviations and Terms in This Manual

This manual uses the abbreviations and terms listed in the following table to discuss the GX Developer Software Package and PLC module. In addition, the following table lists the names of modules whose names must be indicated explicitly.

<table>
<thead>
<tr>
<th>Abbreviation/Generic Term</th>
<th>Description/Target Module</th>
</tr>
</thead>
<tbody>
<tr>
<td>GX Developer</td>
<td>Generic product name of the product types SWnDSC-GPPW-E, SWnDSC-GPPW-EA, SWnDSC-GPPW-EV and SWnDSC-GPPW-EVA. (n denotes any of versions 0 to 6)</td>
</tr>
<tr>
<td>GX Developer (SWnDSC-GPPW-E)</td>
<td>When limited to the major version (n denotes the version number)</td>
</tr>
<tr>
<td>GX Developer (earlier than SWnDSC-GPPW-E)</td>
<td>When limited to earlier than the major version (n denotes the version number)</td>
</tr>
<tr>
<td>GX Developer (later than SWnDSC-GPPW-E)</td>
<td>When limited to later than the major version (n denotes the version number)</td>
</tr>
<tr>
<td>Abbreviation/Generic Term</td>
<td>Description/Target Module</td>
</tr>
<tr>
<td>---------------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>GX Simulator</td>
<td>Generic product name of the product types SWnD5C-LLT-E, SWnD5C-LLT-EA, SWnD5C-LLT-EV and SWnD5C-LLT-EVA. (n denotes any of versions 0 to 5)</td>
</tr>
<tr>
<td>GX Simulator (SWnD5C-LLT-E)</td>
<td>When limited to the major version (n denotes the version number)</td>
</tr>
<tr>
<td>GX Simulator (earlier than SWnD5C-LLT-E)</td>
<td>When limited to earlier than the major version (n denotes the version number)</td>
</tr>
<tr>
<td>GX Simulator (later than SWnD5C-LLT-E)</td>
<td>When limited to later than the major version (n denotes the version number)</td>
</tr>
<tr>
<td>ACPU</td>
<td>Generic term for PLC available with MELSEC-A including MOTION (SCPU) (However, GX Developer does not support A1, A2, A3, A3H, A3M, A52G, A73, A0J2 and A3V)</td>
</tr>
<tr>
<td>QCPU (A mode)</td>
<td>Generic term for Q02(H)-A and Q06H-A</td>
</tr>
<tr>
<td>QnACPU</td>
<td>Generic term for PLC available with MELSEC-QnA</td>
</tr>
<tr>
<td>QCPU (Q mode)</td>
<td>Generic term for Q02(H), Q06H, Q12H and Q25H</td>
</tr>
<tr>
<td>FXCPU</td>
<td>Generic term for PLC available with MELSEC-F (The target PLCs are FX0, FX0S, FX0N, FX1, FX, FX2, FX2C, FX1S, FX1N, FX2N and FX2NC.)</td>
</tr>
<tr>
<td>AnNCPU</td>
<td>A1NCPU, A2NCPU(S1), A3NCPU</td>
</tr>
<tr>
<td>AnACPU</td>
<td>A2ACPU(S1), A3A</td>
</tr>
<tr>
<td>AnUCPU</td>
<td>A2UCPU(S1), A2USCPU(S1), A2ASCPU(S1), A2ASCPU-S30, A2ASCPU-S60, A2USHCPU-S1, A3U, A4U</td>
</tr>
<tr>
<td>A series</td>
<td>For GX Developer PLC type selection by ACPU</td>
</tr>
<tr>
<td>QnA series</td>
<td>For GX Developer PLC type selection by QnACPU</td>
</tr>
<tr>
<td>Q series</td>
<td>For GX Developer PLC type selection by QCPU (Q mode)</td>
</tr>
<tr>
<td>FX series</td>
<td>For GX Developer PLC type selection by FXCPU</td>
</tr>
<tr>
<td>GPPA</td>
<td>SW SRXV-GPPA SW IVD-GPPA</td>
</tr>
<tr>
<td>GPPQ</td>
<td>SW IVD-GPPQ</td>
</tr>
<tr>
<td>MEDOC</td>
<td>MELSEC-MEDOC</td>
</tr>
<tr>
<td>FXGP(DOS)</td>
<td>SW1PC-FXGP/E/AT</td>
</tr>
<tr>
<td>FXGP(WIN)</td>
<td>SW0PC-FXGP/WIN-E</td>
</tr>
<tr>
<td>SFC</td>
<td>Generic term for MELSAP2/MELSAP3/MELSAP-L</td>
</tr>
<tr>
<td>Computer link</td>
<td>Unit</td>
</tr>
<tr>
<td>For A series</td>
<td>A1SJ71C24-R2, A1SJ71C24-R4, A1SJ71C24-PRF A2CCPUUC24(-PRF), A1SCPUUC24-R2</td>
</tr>
<tr>
<td>For AnU</td>
<td>A1SJ71UC24, A1SJ71UC24-R2, A1SJ71UC24-R4, A1SJ71UC24-PRF</td>
</tr>
<tr>
<td>Serial communication unit</td>
<td>For QnA series</td>
</tr>
<tr>
<td>C24</td>
<td>Computer link Unit, Serial Communication Unit</td>
</tr>
<tr>
<td>Q series-compatible E71</td>
<td>Generic term for QJ71E71 and QJ71E71-B2</td>
</tr>
<tr>
<td>Ethernet board</td>
<td>Ethernet PLC card, Ethernet I/F board</td>
</tr>
<tr>
<td>Control &amp; Communication Link</td>
<td>Control &amp; Communication Link</td>
</tr>
<tr>
<td>PLC</td>
<td>PROGRAMMABLE LOGIC CONTROLLER</td>
</tr>
<tr>
<td>Personal computer</td>
<td>Personal computer compatible with Windows® 95/98 and Windows NT® Workstation 4.0</td>
</tr>
<tr>
<td>Actual program</td>
<td>A program created in the label program and compiled. A program executable via the PLC CPU.</td>
</tr>
<tr>
<td>Actual device</td>
<td>The term &quot;actual device&quot; is used in this manual to differentiate a program created under a label name and one that has been compiled. (A compiled program to which device has been assigned.)</td>
</tr>
<tr>
<td>GSV</td>
<td>Q173CPU/Q172CPU Programming Software SW6RN-GSV13 Q173CPU/Q172CPU Programming Software SW6RN-GSV22P</td>
</tr>
</tbody>
</table>
1. GENERAL DESCRIPTION

Product Outline and Features

Outline
This section explains GX Developer (unless otherwise specified, the product name represented GX Developer will hereafter be its English version 6).
GX Developer is a software package having the following functions.

1. Program creation

2. Writing and reading to/from PLC

3. Monitoring (example: device batch monitoring)
   The circuit monitor, device monitor, and device registration monitor can be used for monitoring.

   | Device | +P | 6 | R | C | +B | A | 9 | 8 | +7 | 6 | 5 | 4 | +3 | 2 | 1 | 0 |
   |--------|----|---|---|---|----|---|---|---|---|---|---|---|---|---|---|---|---|
   | D01    | 0  | 0 | 0 | 0 | 0  | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 |
   | D02    | 0  | 0 | 0 | 0 | 0  | 0 | 0 | 1 | 0 | 0 | 1 | 0 | 1 | 0 | 0 | 0 | 0 |
   | D03    | 0  | 0 | 0 | 0 | 0  | 0 | 0 | 1 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 0 |

4. Debugging
   The created sequence program is written into PLC to test that the written sequence program operates normally.
   In addition, newly developed GX Simulator*1 (unless otherwise specified, the product name represented GX Simulator will hereafter be its English version 5) can be used to debug the program on a single personal computer.

5. Diagnostics PLC
   The current error status, error status or error log can be displayed to shorten the time required for error recovery.
   Also, system monitoring (QCPU (Q mode) only) provides in-depth information on the special functions. Therefore, if an error occurs, recovery work can be done in much shorter time.

*: The logic test function (LLT) is an independent function and may be purchased separately.
1 GENERAL DESCRIPTION

Features

GX Developer has the following features.

1. Common software
   GX Developer can create the data of the Q series, QnA series, A series (including the motion controller (SCPU)) and FX series, with their setting operations common, and is abbreviated to GPPA. Note that this does not apply to the A6GPP/A6PHP-compatible software package. Data can be converted into an SW -GPPQ GPP function software package (hereafter abbreviated to GPPQ) format file and edited on GPPA or GPPW. When the FX series is selected, data can be converted into a DOS version programming software (hereafter abbreviated to FXGP(DOS)) or SW0PC-FXGP/WIN programming software (hereafter abbreviated to FXGP(WIN)) format file and you can edit data on FXGP(DOS) or FXGP(WIN).

2. Advantages of Windows are utilized for dramatic improvements in operability
   Comment data created on Excel, Word or the like can be copied or pasted for data diversion.

3. Standardized programs
   (1) Label programming
      By using label programming to create sequence programs, you can create standard programs with labels without being conscious of device numbers. The programs created by label programming can be compiled for use as an actual program.
   (2) Macros
      By naming any ladder patterns (macro names) and registering them to a file (macro registration), merely entering simple instructions allows the registered ladder patterns to be read and the devices to be changed for data diversion.

4. Ease of setting access to another station
   As the connection target can be specified graphically, you can set access to another station easily if a complicated system has been configured.

5. Connection with PLC CPU in any of various methods
   (1) Via serial port
   (2) Via USB
   (3) Via MELSECNET/10(H) board
   (4) Via MELSECNET/II board
   (5) Via CC-Link board
   (6) Via Ethernet board
   (7) Via CPU board
   (8) Via AF board

6. Fully useful debugging functions
   (1) Use of the ladder logic test function (LLT) ensures much easier debugging.
      (a) There is no need to make connection with the PLC CPU.
      (b) There is no need to create a pseudo sequence program (debugging program).
   (2) Containing the explanations of CPU errors and special relays/special registers, Help is useful when an error has occurred online or when you want to know the contents of the special relays/special registers during programming.
   (3) If an error occurs during data creation, the corresponding message is displayed to indicate the cause of that error, substantially reducing data creation time.
### 1.1 Functions Lists

The GX Developer functions are listed below. The functions are divided into normally common functions (project, online, diagnosis, tool, window, help) and functions for objects to be edited and set (edit, search/replacement, conversion, display). In addition, there are executable and inexecutable functions depending on the CPU series.

#### POINTS
- The QCPU (A mode) and motion controller (SCPU) are described as the ACPU.
- Refer to the corresponding manuals for details of the motion controller and SFC.

#### (1) List of common functions
Fixed functions independent of the type of the object being edited or set

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Refer To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project (Common functions)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>New project</td>
<td>Creates a new project.</td>
<td>4.1</td>
</tr>
<tr>
<td>Open project</td>
<td>Opens an existing project.</td>
<td>4.2</td>
</tr>
<tr>
<td>Close project</td>
<td>Closes an open project.</td>
<td>4.3</td>
</tr>
<tr>
<td>Save</td>
<td>Saves the project.</td>
<td>4.4</td>
</tr>
<tr>
<td>Save as</td>
<td>Names and saves the project.</td>
<td>4.5</td>
</tr>
<tr>
<td>Delete project</td>
<td>Deletes an existing project.</td>
<td>4.6</td>
</tr>
<tr>
<td>Verify</td>
<td>Verifies data between projects.</td>
<td>4.7</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies data between projects.</td>
<td>4.8</td>
</tr>
<tr>
<td>Edit data</td>
<td></td>
<td></td>
</tr>
<tr>
<td>New</td>
<td>Adds data to a project.</td>
<td>4.9</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies data in a project.</td>
<td>4.10</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes data in a project.</td>
<td>4.11</td>
</tr>
<tr>
<td>Rename</td>
<td>Renames data in a project.</td>
<td>4.12</td>
</tr>
<tr>
<td>Change program type</td>
<td>Change the program type in the project</td>
<td>4.13</td>
</tr>
<tr>
<td>Change PLC type</td>
<td>Changes the PLC type.</td>
<td>4.14</td>
</tr>
<tr>
<td>Import file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import from GPPQ format file</td>
<td>Read a GPPQ file (QnA only)</td>
<td>4.15.1</td>
</tr>
<tr>
<td>Import from GPPA format file</td>
<td>Read a GPPA file (A only)</td>
<td>4.15.1</td>
</tr>
<tr>
<td>Import from FXGP(WIN) format file</td>
<td>Read a FXGP(WIN) file (FX only)</td>
<td>4.15.1</td>
</tr>
<tr>
<td>Import from FXGP(DOS) format file</td>
<td>Read a FXGP(DOS) file (FX only)</td>
<td>4.15.1</td>
</tr>
<tr>
<td>Import from Melsec Medoc format file (Print out)</td>
<td>Import from Melsec Medoc format file (Print out)</td>
<td>4.15.2</td>
</tr>
<tr>
<td>Import from Melsec Medoc format file</td>
<td>Import from Melsec Medoc format file</td>
<td>4.15.3</td>
</tr>
<tr>
<td>Import from MXChange tags</td>
<td>Imports tags from MXChange Server</td>
<td>23.6</td>
</tr>
<tr>
<td>Export file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export to GPPQ format file</td>
<td>Write a GPPQ files (QnA only)</td>
<td>4.16</td>
</tr>
<tr>
<td>Export to GPPA format file</td>
<td>Write a GPPA files (A only)</td>
<td>4.16</td>
</tr>
<tr>
<td>Export to FXGP(WIN) format file</td>
<td>Write a FXGP(WIN) files (FX only)</td>
<td>4.16</td>
</tr>
<tr>
<td>Export to FXGP(DOS) format file</td>
<td>Write a FXGP(DOS) files (FX only)</td>
<td>4.16</td>
</tr>
<tr>
<td>Export to MXChange tags</td>
<td>Exports comment to MXChange Server</td>
<td>23.7</td>
</tr>
<tr>
<td>Macro</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Registration macros</td>
<td>Registration macros</td>
<td>5.2.1</td>
</tr>
<tr>
<td>Macro utilize</td>
<td>Macro utilize</td>
<td>5.2.2</td>
</tr>
<tr>
<td>Delete macros</td>
<td>Delete macro instruction from the file (Except remote I/O)</td>
<td>5.2.3</td>
</tr>
<tr>
<td>Macro reference path</td>
<td>Set the macro instruction reference path (Except remote I/O)</td>
<td>5.2.4</td>
</tr>
<tr>
<td>Printer setup</td>
<td>Changes the printer settings.</td>
<td>14.1</td>
</tr>
<tr>
<td>Print</td>
<td>Prints data.</td>
<td>14</td>
</tr>
<tr>
<td>Start new GX Developer session</td>
<td>Restarts GX Developer.</td>
<td>4.17</td>
</tr>
<tr>
<td>Exit GX Developer</td>
<td>Exits GX Developer.</td>
<td>4.18</td>
</tr>
</tbody>
</table>

(To the next page)
### Online (Common functions)

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transfer setup</td>
<td>Designates a PLC destination from GX Developer.</td>
<td>16.1</td>
</tr>
<tr>
<td>Read from PLC</td>
<td>Reads data from PLC. (Except label program)</td>
<td>16.3</td>
</tr>
<tr>
<td>Write to PLC</td>
<td>Writes data to PLC.</td>
<td>16.3</td>
</tr>
<tr>
<td>Verify with PLC</td>
<td>Verifies data with PLC data.</td>
<td>16.4</td>
</tr>
<tr>
<td>Write to PLC (Flash ROM)</td>
<td>Writes the program memory to ROM. (Q only)</td>
<td>16.5.1</td>
</tr>
<tr>
<td>Delete PLC data</td>
<td>Deletes PLC data. (QnA only)</td>
<td>16.6</td>
</tr>
<tr>
<td>Change PLC data attributes</td>
<td>Changes PLC data attributes.</td>
<td>16.7</td>
</tr>
<tr>
<td>PLC user data</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Read PLC user data</td>
<td>Reads user data from the PLC. (Q only)</td>
<td>16.8.1</td>
</tr>
<tr>
<td>Write PLC user data</td>
<td>Writes user data to the PLC. (Q only)</td>
<td>16.8.2</td>
</tr>
<tr>
<td>Delete PLC user data</td>
<td>Deletes user data of the PLC. (Q only)</td>
<td>16.8.1</td>
</tr>
<tr>
<td>Monitor</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Monitor mode</td>
<td>Places the circle edit screen in monitor mode. (Except remote I/O)</td>
<td>17.1</td>
</tr>
<tr>
<td>Monitor (Write mode)</td>
<td>Sets the circuit (monitor write) mode. (Except remote I/O)</td>
<td>17.3</td>
</tr>
<tr>
<td>Start monitor (All windows)</td>
<td>Starts monitoring all open windows.</td>
<td>17.2</td>
</tr>
<tr>
<td>Stop monitor (All windows)</td>
<td>Stops monitoring all open windows.</td>
<td>17.2</td>
</tr>
<tr>
<td>Start monitor</td>
<td>Restarts the stopped monitor. (Except remote I/O)</td>
<td>17.1</td>
</tr>
<tr>
<td>Stop monitor</td>
<td>Stops the monitor. (Except remote I/O)</td>
<td>17.1</td>
</tr>
<tr>
<td>Change current value monitor</td>
<td>Displays the current device value of the circuit monitor in decimal form. (Except remote I/O)</td>
<td>17.4</td>
</tr>
<tr>
<td>Change current value monitor</td>
<td>Displays the current device value of the circuit monitor in hexadecimal form. (Except remote I/O)</td>
<td>17.4</td>
</tr>
<tr>
<td>Device batch</td>
<td>Monitors devices in batch mode.</td>
<td>17.5</td>
</tr>
<tr>
<td>Entry data monitor</td>
<td>Entry data mode</td>
<td>17.6</td>
</tr>
<tr>
<td>Buffer memory batch</td>
<td>Monitors the buffer memory in batch mode.</td>
<td>17.5</td>
</tr>
<tr>
<td>Monitor condition setup</td>
<td>Sets the monitor execution conditions. (QnA only)</td>
<td>17.7</td>
</tr>
<tr>
<td>Monitor stop condition setup</td>
<td>Sets the monitor stop conditions. (QnA only)</td>
<td>17.7</td>
</tr>
<tr>
<td>Program monitor list</td>
<td>Monitors a program list.</td>
<td>17.8</td>
</tr>
<tr>
<td>Interrupt program list</td>
<td>Lists the interrupt programs.</td>
<td>17.9</td>
</tr>
<tr>
<td>Scan time measurement</td>
<td>Measures the scan time. (Except remote I/O)</td>
<td>17.10</td>
</tr>
<tr>
<td>Entry ladder monitor</td>
<td>Entry the ladder block. (Except remote I/O)</td>
<td>17.12</td>
</tr>
<tr>
<td>Delete all entry ladder</td>
<td>Delete all entry ladder.</td>
<td>17.13</td>
</tr>
<tr>
<td>Debug (ladder)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Device test</td>
<td>Turns on or off the device or changes the value.</td>
<td>18.1</td>
</tr>
<tr>
<td>Forced input output registration/cancellation</td>
<td>This will register the forced input output of device X/Y</td>
<td>18.2</td>
</tr>
<tr>
<td>Debug</td>
<td>Executes/disables the debugging function. (Except remote I/O)</td>
<td>18</td>
</tr>
<tr>
<td>Skip execution</td>
<td>Makes settings for skip. (QnA, FX only)</td>
<td>18.5</td>
</tr>
<tr>
<td>Partial execution</td>
<td>Makes settings for partial operation. (Except remote I/O)</td>
<td>18.3</td>
</tr>
<tr>
<td>Step execution</td>
<td>Makes settings for step execution. (Except remote I/O)</td>
<td>18.4</td>
</tr>
<tr>
<td>Trace</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sampling trace</td>
<td>Execute sampling trace.</td>
<td>18.11</td>
</tr>
<tr>
<td>Remote operation</td>
<td>Operates the PLC remotely.</td>
<td>18.6</td>
</tr>
</tbody>
</table>
### Online (Common functions)

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Register keyword</td>
<td>Registers or changes the keyword.</td>
<td>19</td>
</tr>
<tr>
<td>Delete keyword</td>
<td>Cancels the keyword.</td>
<td>19</td>
</tr>
<tr>
<td>Disable keyword</td>
<td>Unlocks access by keywords.</td>
<td>19</td>
</tr>
<tr>
<td>Clear PLC memory</td>
<td>Clears the PLC memory cassette or device memory.</td>
<td>20.1</td>
</tr>
<tr>
<td>Format PLC memory</td>
<td>Formats the PLC memory.</td>
<td>20.2</td>
</tr>
<tr>
<td>Arrange PLC memory</td>
<td>Arranges the data area within the PLC memory.</td>
<td>20.3</td>
</tr>
<tr>
<td>Set clock</td>
<td>Sets the internal timer of the PLC.</td>
<td>20.4</td>
</tr>
</tbody>
</table>

### Diagnosis (Common functions)

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>PLC Diagnostics</td>
<td>Diagnoses the PLC.</td>
<td>21.1</td>
</tr>
<tr>
<td>Network diagnostics</td>
<td>Diagnoses the network.</td>
<td>21.2</td>
</tr>
<tr>
<td>CC-Link diagnostics</td>
<td>CC-Link diagnosticts</td>
<td>21.3</td>
</tr>
<tr>
<td>Ethernet diagnostics</td>
<td>Diagnoses Etheren.</td>
<td>21.4</td>
</tr>
<tr>
<td>System monitor</td>
<td>Monitors the system status of the PLC.</td>
<td>21.4</td>
</tr>
</tbody>
</table>

### Tool (Common functions)

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check program</td>
<td>Checks the program.</td>
<td>15.1</td>
</tr>
<tr>
<td>Marge data</td>
<td>Links data.</td>
<td>15.2</td>
</tr>
<tr>
<td>Check parameter</td>
<td>Checks the parameter.</td>
<td>15.3</td>
</tr>
<tr>
<td>Transfer ROM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Read</td>
<td>Reads data from ROM.</td>
<td>15.8.1</td>
</tr>
<tr>
<td>Write</td>
<td>Writes data to ROM.</td>
<td>15.8.1</td>
</tr>
<tr>
<td>Compare</td>
<td>Compares data with ROM data.</td>
<td>15.8.1</td>
</tr>
<tr>
<td>Write to file</td>
<td>Writes ROM data to files.</td>
<td>15.8.2</td>
</tr>
<tr>
<td>Delete unused comments</td>
<td>Delete the comments which isn’t used at program</td>
<td>15.9</td>
</tr>
<tr>
<td>Clear all parameters</td>
<td>Deletes parameters.</td>
<td>15.4</td>
</tr>
<tr>
<td>IC memory card</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Read IC memory card</td>
<td>Reads data from the IC memory card.</td>
<td>15.5.1</td>
</tr>
<tr>
<td>Write IC memory card</td>
<td>Writes data to the IC memory card.</td>
<td>15.5.2</td>
</tr>
<tr>
<td>Start ladder logic test</td>
<td>Starts the ladder logic test.</td>
<td>15.14</td>
</tr>
<tr>
<td>Set TEL data</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Connection</td>
<td>Connect the line for A6TEL/Q6TEL.</td>
<td>22.4</td>
</tr>
<tr>
<td>Disconnect</td>
<td>Disconnect the line.</td>
<td>22.4.3</td>
</tr>
<tr>
<td>TEL data</td>
<td>Set the report data of A6TEL or Q6TEL.</td>
<td>22.3.3</td>
</tr>
<tr>
<td>AT command</td>
<td>Entry the modem</td>
<td>22.3.2</td>
</tr>
<tr>
<td>Call book</td>
<td>Set the call book</td>
<td>22.3.1</td>
</tr>
<tr>
<td>Intelligent function utility</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Utility list</td>
<td>Shows the utility names required to edit the intelligent function unit parameters.</td>
<td>15.7</td>
</tr>
<tr>
<td>Session</td>
<td>Starts the intelligent function utility.</td>
<td>15.7</td>
</tr>
<tr>
<td>MXChange actions</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Log in</td>
<td>Log in MXChange Server.</td>
<td>23.3</td>
</tr>
<tr>
<td>Log off</td>
<td>Log off MXChange Server.</td>
<td>23.4</td>
</tr>
<tr>
<td>Change Password</td>
<td>Changes password in MXChange Server.</td>
<td>23.3</td>
</tr>
<tr>
<td>Customize keys</td>
<td>Changes key assignments for circuit symbol input.</td>
<td>15.9</td>
</tr>
<tr>
<td>Change display color</td>
<td>The display color is changed</td>
<td>15.10</td>
</tr>
<tr>
<td>Options</td>
<td>Sets the options.</td>
<td>15.11</td>
</tr>
<tr>
<td>Create start-up settings file</td>
<td>Creates a file to save initial settings of the project.</td>
<td>15.13</td>
</tr>
</tbody>
</table>

### Window (Common functions)

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cascade</td>
<td>Cascades windows.</td>
<td>15.12</td>
</tr>
<tr>
<td>Tile vertically</td>
<td>Tiles the windows vertically.</td>
<td>15.12</td>
</tr>
<tr>
<td>Tile horizontally</td>
<td>Tiles the windows horizontally.</td>
<td>15.12</td>
</tr>
<tr>
<td>Arrange icons</td>
<td>Arranges the icons in the lower part of the window.</td>
<td>15.12</td>
</tr>
</tbody>
</table>

### Help (Common functions)

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU error</td>
<td>Displays the description of each CPU error code.</td>
<td>15.15</td>
</tr>
<tr>
<td>Special relay/register</td>
<td>Displays the description of special relays or registers.</td>
<td>15.15</td>
</tr>
<tr>
<td>Key operation list</td>
<td>Displays the description of each key operation.</td>
<td>15.15</td>
</tr>
<tr>
<td>Product information</td>
<td>Displays product information (such as version number).</td>
<td>15.15</td>
</tr>
<tr>
<td>Connect to MELFANSweb</td>
<td>Connect to MELFANSweb</td>
<td>15.15</td>
</tr>
</tbody>
</table>
(2) Ladder editing function list
The following functions can be performed to edit the ladders and operation outputs/transition conditions.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Refer To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Reverses the last operation.</td>
<td>6.2.9</td>
</tr>
<tr>
<td>Cut</td>
<td>Moves the selected data to the Clipboard.</td>
<td>3.3.1</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the selected data to the Clipboard.</td>
<td>3.3.2</td>
</tr>
<tr>
<td>Paste</td>
<td>Pastes the contents of the Clipboard at the cursor position.</td>
<td>3.3.1</td>
</tr>
<tr>
<td>Insert line</td>
<td>Inserts a row at the cursor position.</td>
<td>6.2.5</td>
</tr>
<tr>
<td>Delete line</td>
<td>Deletes a row at the cursor position.</td>
<td>6.2.5</td>
</tr>
<tr>
<td>Insert row</td>
<td>Inserts a column at the cursor position.</td>
<td>6.2.5</td>
</tr>
<tr>
<td>Delete row</td>
<td>Deletes a column at the cursor position.</td>
<td>6.2.5</td>
</tr>
<tr>
<td>Insert NOP batch</td>
<td>Inserts NOP before a circuit block at the cursor position.</td>
<td>6.2.6</td>
</tr>
<tr>
<td>Delete NOP batch</td>
<td>Deletes all NOPs in the program at a time.</td>
<td>6.2.7</td>
</tr>
<tr>
<td>Draw line</td>
<td>Inserts a line.</td>
<td>6.2.2</td>
</tr>
<tr>
<td>Delete line</td>
<td>Deletes a line.</td>
<td>6.2.4</td>
</tr>
<tr>
<td>Change TC setting</td>
<td>Changes the setting value of the timer or counter.</td>
<td>6.3</td>
</tr>
<tr>
<td>Read mode</td>
<td>Places the circuit screen in the read mode.</td>
<td>6</td>
</tr>
<tr>
<td>Write mode</td>
<td>Places the circuit screen in write mode.</td>
<td>6</td>
</tr>
</tbody>
</table>

### Ladder symbol

- **Open contact**: Inserts at the cursor position. 6.2
- **Close project contact**: Inserts at the cursor position. 6.2
- **Open branch**: Inserts at the cursor position. 6.2
- **Close project branch**: Inserts at the cursor position. 6.2
- **Coil**: Inserts at the cursor position. 6.2
- **Application instruction**: Inserts at the cursor position. 6.2
- **Vertical line**: Inserts at the cursor position. 6.2
- **Horizontal line**: Inserts at the cursor position. 6.2
- **Delete vertical line**: Inserts at the cursor position. 6.2
- **Delete Horizontal line**: Inserts at the cursor position. 6.2
- **Rising pulse**: Inserts at the cursor position. (QnA, FX) 6.2
- **Falling pulse**: Inserts at the cursor position. (QnA, FX) 6.2
- **Rising pulse Open branch**: Inserts at the cursor position. (QnA, FX) 6.2
- **Falling pulse Close branch**: Inserts at the cursor position. (QnA, FX) 6.2
- **Invert operation results**: Inserts at the cursor position. (QnA, FX) 6.2
- **Convert operation results to rising pulse**: Inserts at the cursor position. (QnA, FX) 6.2
- **Convert operation results to falling pulse**: Inserts at the cursor position. (QnA, FX) 6.2

### Documentation

- **Comment**: Edits the comment at the cursor position. 9.4.4
- **Statement**: Edits the statement in the ladder at the cursor position. 10.3.1(1)
- **Note**: Edits the note in the ladder at the cursor position. 10.4.1(1)
- **Statement/Note block edit**: The statement and note under the program is edited by the batch. 10.5
### General Description

<table>
<thead>
<tr>
<th>Search/Replacement (Ladder editing functions)</th>
<th>Refer To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find device</td>
<td>6.4.1</td>
</tr>
<tr>
<td>Find instruction</td>
<td>6.4.2</td>
</tr>
<tr>
<td>Find step No.</td>
<td>6.4.3</td>
</tr>
<tr>
<td>Find character string</td>
<td>6.4.4</td>
</tr>
<tr>
<td>Find contact or coil</td>
<td>6.4.5</td>
</tr>
<tr>
<td>Finding data</td>
<td>6.4.6</td>
</tr>
<tr>
<td>Replace device</td>
<td>6.4.7</td>
</tr>
<tr>
<td>Replace instruction</td>
<td>6.4.8</td>
</tr>
<tr>
<td>Change open/close contact</td>
<td>6.4.9</td>
</tr>
<tr>
<td>Replace character string</td>
<td>6.4.10</td>
</tr>
<tr>
<td>Chang module start address</td>
<td>6.4.11</td>
</tr>
<tr>
<td>Replace statement/note type</td>
<td>6.4.12</td>
</tr>
<tr>
<td>Replacing data</td>
<td>6.4.13</td>
</tr>
<tr>
<td>Cross referense list</td>
<td>6.4.14</td>
</tr>
<tr>
<td>List of used devices</td>
<td>6.4.15</td>
</tr>
</tbody>
</table>

### Conversion (Ladder editing functions)

<table>
<thead>
<tr>
<th>Conversion (Ladder editing functions)</th>
<th>Refer To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Convert</td>
<td>8.1</td>
</tr>
<tr>
<td>Convert (All programs being edited)</td>
<td>8.2</td>
</tr>
<tr>
<td>Convert block (Online change)</td>
<td>16.9</td>
</tr>
</tbody>
</table>

### Display (Ladder editing functions)

<table>
<thead>
<tr>
<th>Display (Ladder editing functions)</th>
<th>Refer To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comment</td>
<td>3.8</td>
</tr>
<tr>
<td>Statement</td>
<td>3.9</td>
</tr>
<tr>
<td>Note</td>
<td>3.10</td>
</tr>
<tr>
<td>Device Label</td>
<td>3.11</td>
</tr>
<tr>
<td>Macro instruction format display</td>
<td>5.16</td>
</tr>
<tr>
<td>Comment format</td>
<td></td>
</tr>
<tr>
<td>4 × 8 characters</td>
<td>3.12</td>
</tr>
<tr>
<td>3 × 5 characters</td>
<td>3.12</td>
</tr>
<tr>
<td>Alias display format</td>
<td></td>
</tr>
<tr>
<td>Displayed instead of device</td>
<td>3.13.1</td>
</tr>
<tr>
<td>Displayed with device</td>
<td>3.13.2</td>
</tr>
<tr>
<td>Toolbar</td>
<td>3.4</td>
</tr>
<tr>
<td>Status bar</td>
<td>3.5</td>
</tr>
<tr>
<td>Zoom</td>
<td></td>
</tr>
<tr>
<td>50%</td>
<td>3.6</td>
</tr>
<tr>
<td>75%</td>
<td>3.6</td>
</tr>
<tr>
<td>100%</td>
<td>3.6</td>
</tr>
<tr>
<td>150%</td>
<td>3.6</td>
</tr>
<tr>
<td>Auto</td>
<td>3.6</td>
</tr>
<tr>
<td>Project data list</td>
<td>3.7</td>
</tr>
<tr>
<td>Instruction list</td>
<td>6</td>
</tr>
<tr>
<td>Elapsed time</td>
<td>22.4.1</td>
</tr>
</tbody>
</table>

### Device Comment Editing Function List

The following functions can be performed to edit device comments.

<table>
<thead>
<tr>
<th>Edit</th>
<th>Refer To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clear all (all devices)</td>
<td>9.5.1</td>
</tr>
<tr>
<td>Clear all (displayed devices)</td>
<td>9.5.2</td>
</tr>
<tr>
<td>Setup comment</td>
<td>9.6</td>
</tr>
<tr>
<td>Setup comment range</td>
<td>9.7</td>
</tr>
</tbody>
</table>
(4) Device memory setting function list
The following functions can be performed to set the device memory.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Refer To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clear all (all devices)</td>
<td>Deletes data of all devices.</td>
<td>11.3.1</td>
</tr>
<tr>
<td>Clear all (displayed devices)</td>
<td>Deletes the data of displayed devices.</td>
<td>11.3.2</td>
</tr>
<tr>
<td>FULL</td>
<td>Sets all data to the specified value.</td>
<td>11.4</td>
</tr>
</tbody>
</table>

(5) Label programming function list
The following functions are available for label program editing.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Refer To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto device setting</td>
<td>Setting auto device</td>
<td>5.1.4</td>
</tr>
<tr>
<td>Global variable setting</td>
<td>Setting global variable</td>
<td>5.1.3</td>
</tr>
<tr>
<td>Local variable setting</td>
<td>Setting local variable</td>
<td>5.1.3</td>
</tr>
<tr>
<td>Insert line</td>
<td>Inserts a line at the cursor position</td>
<td>5.1.3</td>
</tr>
<tr>
<td>Add line</td>
<td>Adds a line under the cursor position</td>
<td>5.1.3</td>
</tr>
<tr>
<td>Delete line</td>
<td>Delete a line from the cursor position</td>
<td>5.1.3</td>
</tr>
<tr>
<td>Delete all Auto External</td>
<td>Delete all Auto External</td>
<td>5.1.5</td>
</tr>
<tr>
<td>Delete all</td>
<td>Delete all variables</td>
<td>5.1.6</td>
</tr>
<tr>
<td>Auto device setting</td>
<td>Setting auto device</td>
<td>5.1.4</td>
</tr>
<tr>
<td>Global variable setting</td>
<td>Setting global variable</td>
<td>5.1.3</td>
</tr>
<tr>
<td>Import the device comment</td>
<td>Import the device comment (local label variables only)</td>
<td>5.1.7</td>
</tr>
<tr>
<td>Export the device comment</td>
<td>Export the device comment</td>
<td>5.1.8</td>
</tr>
<tr>
<td>Display device program</td>
<td>Switches the display/non-display of the device display screen.</td>
<td>5.1.10</td>
</tr>
<tr>
<td>Device program display mode</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Below</td>
<td>Display the zoom or the device screen at below</td>
<td>5.1.10</td>
</tr>
<tr>
<td>Right</td>
<td>Display the zoom or the device screen at right</td>
<td>5.1.10</td>
</tr>
<tr>
<td>Display step synchronization</td>
<td>Display step synchronization between label program and device program</td>
<td>5.1.10</td>
</tr>
<tr>
<td>Compile</td>
<td>Compile the label program</td>
<td>5.1.9</td>
</tr>
<tr>
<td>Compile (All programs being edited)</td>
<td>Compile the all the not compiled label programs</td>
<td>5.1.9</td>
</tr>
<tr>
<td>Compile (All programs)</td>
<td>Compile the all label programs</td>
<td>5.1.9</td>
</tr>
<tr>
<td>Compile option</td>
<td>Set compile option</td>
<td></td>
</tr>
<tr>
<td>Sort</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Label order</td>
<td>Sort by label</td>
<td>5.1.3</td>
</tr>
<tr>
<td>Device/Constant order</td>
<td>Sort by Device/Constant</td>
<td>5.1.3</td>
</tr>
<tr>
<td>Device type order</td>
<td>Sort by Device type</td>
<td>5.1.3</td>
</tr>
</tbody>
</table>
### SFC editing function list
The following functions can be performed to edit SFC.
For details, refer to the GX Developer Version6 operating manual (SFC manual).

<table>
<thead>
<tr>
<th>Edit (SFC editing functions)</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert line</td>
<td>Inserts a row at the cursor position.</td>
</tr>
<tr>
<td>Delete line</td>
<td>Deletes a row at the cursor position.</td>
</tr>
<tr>
<td>Insert row</td>
<td>Inserts a column at the cursor position.</td>
</tr>
<tr>
<td>Delete row</td>
<td>Deletes a column at the cursor position.</td>
</tr>
<tr>
<td>Edit the line</td>
<td></td>
</tr>
<tr>
<td>Vertical line</td>
<td>Writes a vertical line.</td>
</tr>
<tr>
<td>Selection divergence</td>
<td>Writes selective branch.</td>
</tr>
<tr>
<td>Simultaneous divergence</td>
<td>Writes a parallel branch.</td>
</tr>
<tr>
<td>Selection convergence</td>
<td>Writes a selective coupling.</td>
</tr>
<tr>
<td>Simultaneous convergence</td>
<td>Writes a parallel coupling.</td>
</tr>
<tr>
<td>Delete the line</td>
<td>Deletes the selective/parallel branch or selective/parallel coupling.</td>
</tr>
<tr>
<td>Change TC setting</td>
<td>Changes the setting value of the timer or counter.</td>
</tr>
<tr>
<td>Read mode</td>
<td>Places the circuit screen in the read mode.</td>
</tr>
<tr>
<td>Write mode</td>
<td>Places the circuit screen in write mode.</td>
</tr>
</tbody>
</table>

#### Step attribute

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>Set the normal (A/Q/QnA)</td>
</tr>
<tr>
<td>Stored coil</td>
<td>Set the stored coil (SC) type (A/Q/QnA)</td>
</tr>
<tr>
<td>Stored operation (without transition check)</td>
<td>Stored operation (without transition check) [SE] type (Q/QnA)</td>
</tr>
<tr>
<td>Stored operation (with transition check)</td>
<td>Set the stored operation (with transition check) [ST] type (Q/QnA)</td>
</tr>
<tr>
<td>Reset</td>
<td>Set the reset [R] type (Q/QnA)</td>
</tr>
</tbody>
</table>

#### SFC symbol

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Step</td>
<td>Inserts at the cursor position.</td>
</tr>
<tr>
<td>Block START step (with END check)</td>
<td>Inserts at the cursor position. (A/Q/QnA)</td>
</tr>
<tr>
<td>Block START step (without END check)</td>
<td>Inserts at the cursor position. (Q/QnA)</td>
</tr>
<tr>
<td>Jump</td>
<td>Inserts at the cursor position.</td>
</tr>
<tr>
<td>End step</td>
<td>Inserts at the cursor position.</td>
</tr>
<tr>
<td>Dummy step</td>
<td>Inserts at the cursor position.</td>
</tr>
<tr>
<td>Transition</td>
<td>Inserts at the cursor position.</td>
</tr>
<tr>
<td>Selection divergence</td>
<td>Inserts at the cursor position.</td>
</tr>
<tr>
<td>Simultaneous divergence</td>
<td>Inserts at the cursor position.</td>
</tr>
<tr>
<td>Selection convergence</td>
<td>Inserts at the cursor position.</td>
</tr>
<tr>
<td>Simultaneous convergence</td>
<td>Inserts at the cursor position.</td>
</tr>
<tr>
<td>Vertical line</td>
<td>Inserts at the cursor position.</td>
</tr>
</tbody>
</table>

#### Documentation

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Comment</td>
<td>Edit comment</td>
</tr>
<tr>
<td>Block information</td>
<td>Set the block information</td>
</tr>
</tbody>
</table>

#### Search/Replacement (SFC editing functions)

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Find device</td>
<td>Finds device.</td>
</tr>
<tr>
<td>Find instruction</td>
<td>Finds instruction.</td>
</tr>
<tr>
<td>Find step No./block No.</td>
<td>Finds the step number.</td>
</tr>
<tr>
<td>Find character string</td>
<td>Finds character string.</td>
</tr>
<tr>
<td>Replace device</td>
<td>Replaces a device.</td>
</tr>
<tr>
<td>Replace instruction</td>
<td>Replaces an instruction.</td>
</tr>
<tr>
<td>Change open/close contact</td>
<td>Replaces open/close contact.</td>
</tr>
<tr>
<td>Replace step No.</td>
<td>Replace the step number.</td>
</tr>
<tr>
<td>Replace character string</td>
<td>Replaces a character string.</td>
</tr>
<tr>
<td>Cross reference list</td>
<td>Finds whether the device is being used by a contact or coil.</td>
</tr>
<tr>
<td>List of used devices</td>
<td>Finds where the device is used.</td>
</tr>
</tbody>
</table>

(To the next page)
### Conversion (SFC editing functions)

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Convert (All programs being edited)</td>
<td>Converts the programs (not converted yet) in all windows.</td>
</tr>
<tr>
<td>Convert (block)</td>
<td>Convert the block data</td>
</tr>
<tr>
<td>Display convert error</td>
<td>Display the convert error</td>
</tr>
<tr>
<td>Display (SFC editing functions)</td>
<td></td>
</tr>
<tr>
<td>Display comment of step and TR</td>
<td>Displays the step and transition comment.</td>
</tr>
<tr>
<td>Display label of step and TR</td>
<td>Displays the step and transition label.</td>
</tr>
<tr>
<td>Row of SFC</td>
<td>Set the row number of SFC diagram.</td>
</tr>
<tr>
<td>Zoom setting</td>
<td></td>
</tr>
<tr>
<td>Below</td>
<td>Display the zoom ladder of list at below</td>
</tr>
<tr>
<td>Right</td>
<td>Display the zoom ladder of list at right</td>
</tr>
<tr>
<td>Split</td>
<td>Display the zoom ladder of list</td>
</tr>
<tr>
<td>Set the contact at right</td>
<td></td>
</tr>
<tr>
<td>5 contacts</td>
<td>Display 5 contacts at the line of ladder</td>
</tr>
<tr>
<td>11 contacts</td>
<td>Display 11 contacts at the line of ladder</td>
</tr>
<tr>
<td>Review SFC</td>
<td>Review SFC</td>
</tr>
<tr>
<td>Display block list</td>
<td>Display block list</td>
</tr>
<tr>
<td>MELSAP-L format</td>
<td>Change the SFC view format</td>
</tr>
<tr>
<td>Display the reference window</td>
<td>Display the reference window</td>
</tr>
</tbody>
</table>

### Online (Common functions)

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device test</td>
<td>Sets the device value.</td>
</tr>
<tr>
<td>Block brake (A/Q/QnA)</td>
<td>Block brake</td>
</tr>
<tr>
<td>Step brake</td>
<td>Step brake</td>
</tr>
<tr>
<td>Block run</td>
<td>Block run</td>
</tr>
<tr>
<td>Step run</td>
<td>Step run</td>
</tr>
<tr>
<td>1 step run</td>
<td>1 step run</td>
</tr>
<tr>
<td>Block forced stopping</td>
<td>Block forced stopping</td>
</tr>
<tr>
<td>Step forced stopping</td>
<td>Step forced stopping</td>
</tr>
<tr>
<td>Reset stored step</td>
<td>Reset stored step</td>
</tr>
<tr>
<td>Run all block</td>
<td>Run All Block</td>
</tr>
</tbody>
</table>
1.2 FX Series Programming

This section describes the main differences between the GX Developer operating environment and FX-dedicated programming software (DOS® version, Windows® version) operating environment and the points to be noted.

Target PLC:  
FX0, FX0S, FX0N, FX1, FX2, FX2C, FX1S, FX1N, FX2N, and FX2NC series  
In the selection of PLC type, select FXU/FX2C for FX, FX2 and FX2C  
See Section 2 for details on the system configuration and connection method.

Operating Environment
• Differences of main terms
  · Program file handling  
    GX Developer programming data is created in units of folders (directories) called the projects.  
    FXGP(DOS) and FXGP(WIN) do not have the concept of project, and program files are created in any folders (directories) for management.  
    For this reason, the program file names in FXGP(DOS) and FXGP(WIN) are project names in GX Developer.  
    For details on project specification, see Section 3.2.

  · Comments  
    (1) The number of characters that can be input may be different (see Appendix 11).  
    (2) The circuit comment is called the statement.  
    (3) The coil comment is called the note.

  · Parameter settings  
    Some setup screens have different names (see Section 13).

• Differences in operations
  · Step ladder instructions (STL, RET) are displayed in different ways (see Section 6.1.2).

  · Monitor display may be partially different (see Appendix 11).

  · Application instructions using the FNC. No. are not available.

  · Although FX PLC operates in the sequence program with no End instructions, END instructions are forceful input in GX Developer.
• Common items and others
  - Items that are available for only A series or QnA series are disabled and displayed in gray in the GX Developer operation screens.

  - Partial execution, step run, and step run debug functions cannot be used when FXCPU is connected. However, these debug functions can be used for debugging with a single personal computer when the GX Simulalor is connected (see Chapter 18 for details).

  - The program conversion function is provided for conversion from A to FX series and vice versa (see Section 4.13 and Appendix 4 for details).

  - The GX Developer FX series allows users to create only one program file. Because A series or QnA series allows users to create multiple program files, this manual may use screen examples including multiple program files when describing the function. However, when FX series is selected, only the main program is displayed on the screen.

  - The connection cable and RS-232C/RS-422 converter for FX PLC may be different from those for A or QnA series PLC (see Subsection 2 for details).

  - GX Developer is able to read from or write to FXGP(DOS) and FXGP(WIN) files basically. However, note that there are some exceptions (see Sections 4.14 and 4.15 and Chapter 9 for details).

  - SFC program of FX series is displayed as STL and RET instructions on the circuit edit screen of the GX Developer since the program is described as the step ladder instructions. It is possible to edit on the circuit.
1.3 Basic Key Specifications

The following table summarizes the purposes of the keys used with the GX Developer.

<table>
<thead>
<tr>
<th>Key Name</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Esc</td>
<td>Closes the window, interrupts execution, and selects instructions.</td>
</tr>
<tr>
<td>Tab</td>
<td>Enters a tab code and switches the target to which the cursor must be moved quickly.</td>
</tr>
<tr>
<td>Ctrl + Tab</td>
<td>Used in a combination with an alphanumeric key or a function key.</td>
</tr>
<tr>
<td>Shift</td>
<td>Selects a character at the Shift position.</td>
</tr>
<tr>
<td>Caps Lock</td>
<td>Switches upper-case and lower-case letters.</td>
</tr>
<tr>
<td>Alt</td>
<td>Selects the menu.</td>
</tr>
<tr>
<td>Back space</td>
<td>Deletes a character to the left of the cursor position.</td>
</tr>
<tr>
<td>Enter</td>
<td>Enters a carriage return.</td>
</tr>
<tr>
<td>Page Up</td>
<td>Scrolls down the circuit or list by page. (Scrolls a screen in minus direction.)</td>
</tr>
<tr>
<td>Page Down</td>
<td>Scrolls up the circuit or list by page. (Scrolls a screen in plus direction.)</td>
</tr>
<tr>
<td>Insert</td>
<td>Enters a space character at the cursor position.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes a character at the cursor position. (Clears all settings.)</td>
</tr>
<tr>
<td>Home</td>
<td>Moves the cursor to the home position.</td>
</tr>
<tr>
<td>Ctrl + Home</td>
<td>Moves the cursor or scrolls the circuit or list in unit of lines. ( Moves the cursor to step 0 in the mode.</td>
</tr>
<tr>
<td>Ctrl + End</td>
<td>Moves the cursor to the End instruction in the circuit mode.</td>
</tr>
<tr>
<td>Scroll Lock</td>
<td>Inhibits scroll-up and scroll-down.</td>
</tr>
<tr>
<td>Num Lock</td>
<td>Uses the Ten-key pad for numeric key input only.</td>
</tr>
</tbody>
</table>
2. SYSTEM CONFIGURATION

2.1 Connection from the Serial Port

The following system configuration is made up by connection from the serial port.

[Diagram showing various components and connections, including USB communication, serial port communication, CC-Link, MELSECNET, via modem, and GX Developer connections.]
**1: About the USB cable (QCPU (Q mode) compatible)**

1. Usable when Windows® 98 and USB driver have been installed.
2. Unusable for Windows® 95, Windows NT® Workstation 4.0.
3. Use of the USB cable allows only one PLC CPU to be connected.
4. Use the USB cable which conforms to the USB Standard Rev. 1.1.
5. Refer to POINT in Section 16.1 for precautions for and restrictions on using the USB cable to make communications.

**2: About the cable (QCPU (Q mode), QCPU (A mode) compatible)**

For communication in 115.2/57.6kbps
Fast communication cannot be made if the Personal computer used is not compatible with the communication speed of 115.2/57.6kbps.
If a communication error occurs, reduce the baud rate setting and restart communication.

The following cable has been confirmed by Mitsubishi Electric that it will work properly.

Using the cable of Mitsubishi Electric make

<table>
<thead>
<tr>
<th>RS-232 cable</th>
</tr>
</thead>
<tbody>
<tr>
<td>QC30R2 (when Personal computer connector is D-sub, 9-pin)</td>
</tr>
</tbody>
</table>

**3: About the converter/cable (ACPU, QnACPU, FXCPU compatible)**

1. Using the products of Mitsubishi Electric make

<table>
<thead>
<tr>
<th>Personal computer Side (RS-232C cable)</th>
<th>RS-232C/RS-422 Converter</th>
<th>PLC CPU Side (RS-422 cable)</th>
</tr>
</thead>
<tbody>
<tr>
<td>F2-232CAB-1</td>
<td>FX-232AW(C)</td>
<td>For ACPU, QnACPU, FX/FX2CPU/FX2CCPU</td>
</tr>
<tr>
<td>(when Personal computer connector is D-sub, 9-pin)</td>
<td></td>
<td>FX-422CAB (0.3m)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>FX-422CAB-150 (1.5m)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For FX0/FX0S/FX2N/FX1S/FX1N/FX2N/FX2NCPU</td>
</tr>
<tr>
<td></td>
<td></td>
<td>FX-422CABO (1.5m)</td>
</tr>
</tbody>
</table>
How to identify compatibility of the F2-232CAB and F2-232CAB-1 cables with the ACPU and QnACPU
Check the indication of the model label attached to the cable.

<table>
<thead>
<tr>
<th>Incompatible products</th>
<th>Compatible products (with indication of F/FX/A)</th>
</tr>
</thead>
<tbody>
<tr>
<td>F2-232CAB</td>
<td>F2-232CAB(F/FX/A)</td>
</tr>
<tr>
<td>Y990C******</td>
<td>Y990C******</td>
</tr>
<tr>
<td>F2-232CAB-1</td>
<td>F2-232CAB-1(F/FX/A)</td>
</tr>
<tr>
<td>Y990C******</td>
<td>Y990C******</td>
</tr>
</tbody>
</table>

*4: About the modems relayed
Use the straight cables supplied with the modems.

*5: About computer link
When the A series is used for communication via the C24/UC24, the program which uses V, Z (index qualification) cannot be monitored.
The following system configuration is made up by connection from the interface boards.
Refer to the corresponding board manuals for the way to connect the boards and install the drivers.

1: MELSECNET/10 board
If a communications error takes place, an error code is indicated in the least significant 4 digits.
Refer to the error code list of the MELSECNET/10 board manual.

2: CC-Link board
Accessible only when the CC-Link board is set as the local station.

3: Ethernet board
(1) The following Ethernet boards/cards have been confirmed by Mitsubishi Electric to operate properly.

<table>
<thead>
<tr>
<th>Maker Name</th>
<th>Model</th>
</tr>
</thead>
<tbody>
<tr>
<td>3COM make</td>
<td>Ethernet Link III LAN PC Card</td>
</tr>
<tr>
<td>Allied Telesis make</td>
<td>Center COM LA-PCM Ethernet PC Card</td>
</tr>
<tr>
<td>TDK make</td>
<td>10BASE-T LAN card (Model: LAN-CD021BX)</td>
</tr>
<tr>
<td>Allied Telesis make</td>
<td>RE2000 (ISA)</td>
</tr>
</tbody>
</table>
### 2.3 System Equipment Lists

(1) The following list indicates module connectable from the serial port.

<table>
<thead>
<tr>
<th>PLC Series</th>
<th>Module Name</th>
<th>Module Model</th>
</tr>
</thead>
<tbody>
<tr>
<td>A series</td>
<td>PLC CPU module</td>
<td>A0J2H, A1S(S1), A1FX, A1SJ, A1SH, A1SJH, A1N, A2C, A2CJ, A2N(S1), A2S(S1), A2SH(S1), A171SH, A172SH, A3N, A2A(S1), A3A, A2U(S1), A2US(S1), A2AS(S1), A2AS-S30, A2AS-S60, A2USH-S1, A3U, A4U, A173UH(S1), A273UH(S3), Q02(H)-A, Q06H-A</td>
</tr>
<tr>
<td></td>
<td>Computer link module*1</td>
<td>AJ71UC24, A1SJ71UC24-R2, A15SJ71UC24-PRF, A1XJ71C24-R2, A1SJ71C24-PRF, A1SCPUC24-R2, A2CCPUC24, A2CCPUC24-PRF</td>
</tr>
<tr>
<td></td>
<td>MELSECNET(II) data link remote I/O module</td>
<td>AJ72P25, AJ72R25</td>
</tr>
<tr>
<td></td>
<td>MELSECNET/B data link remote I/O module</td>
<td>AJ72T25B, A1SJ72T25B</td>
</tr>
<tr>
<td></td>
<td>MELSECNET/10 network remote I/O module</td>
<td>AJ72LP25, QJ72LP25, QJ72BR15</td>
</tr>
<tr>
<td></td>
<td>CC-Link G4 module</td>
<td>AJ65BT-G4, AJ65BT-G4-S3</td>
</tr>
<tr>
<td>QnA series</td>
<td>PLC CPU module</td>
<td>Q2A, Q2AS(H), Q2AS1, Q2AS(H)S1, Q3A, Q4A, Q4AR</td>
</tr>
<tr>
<td></td>
<td>CC-Link G4 module</td>
<td>AJ65BT-G4, AJ65BT-G4-S3</td>
</tr>
<tr>
<td>Q series</td>
<td>PLC CPU module</td>
<td>Q02(H), Q06H, Q12H, Q25H</td>
</tr>
<tr>
<td></td>
<td>Serial communication module*3</td>
<td>QJ71C24, QJ71C24-R2</td>
</tr>
<tr>
<td></td>
<td>MELSECNET/H network remote I/O module</td>
<td>QJ72LP25, QJ72BR15</td>
</tr>
<tr>
<td></td>
<td>G4 module</td>
<td>AJ65BT-G4-S3</td>
</tr>
<tr>
<td>FX series</td>
<td>PLC CPU module</td>
<td>FX(S), FXN, FX1, FX(N), FX1S, FX(N), FX2N(C)</td>
</tr>
</tbody>
</table>

(2) The following table indicates the modules which can be connected from the MELSECNET/10 or MELSECNET/H (MELSECNET/10 mode) (future plan) board.

<table>
<thead>
<tr>
<th>PLC Series</th>
<th>Module Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Q series</td>
<td>QJ71LP21, QJ71BR11, QJ71LP21-25</td>
</tr>
</tbody>
</table>

(3) The following table indicates the modules which can be connected from the MELSECNET/H board. (Future plan)

<table>
<thead>
<tr>
<th>PLC Series</th>
<th>Module Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Q series</td>
<td>QJ71LP21, QJ71BR11, QJ71LP21-25</td>
</tr>
</tbody>
</table>

(4) The following list indicates modules connectable from the CC-Link board.

<table>
<thead>
<tr>
<th>PLC Series</th>
<th>Module Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>A series</td>
<td>AJ61BT11, A1SJ61BT11</td>
</tr>
<tr>
<td>QnA series</td>
<td>AJ61BT11, A1SJ61BT11</td>
</tr>
<tr>
<td>Q series</td>
<td>QJ61BT11</td>
</tr>
</tbody>
</table>

(5) The following list indicates modules connectable from the Ethernet board.

<table>
<thead>
<tr>
<th>PLC Series</th>
<th>Module Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Q series</td>
<td>QJ71E71, QJ71E71-B2</td>
</tr>
</tbody>
</table>
*1: About the computer link module
Note that when the PLC CPU is accessed from the personal computer via the computer link module, the modules that may be connected directly with the personal computer are limited.
If the module cannot be connected directly with the personal computer, it may be usable as the "n"th module of multidropping.

<table>
<thead>
<tr>
<th>Type</th>
<th>Interface</th>
<th>1:1 Connection</th>
<th>Multidropping</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>First module</td>
<td>&quot;n&quot;th module</td>
</tr>
<tr>
<td>AJ71UC24</td>
<td>RS-232C</td>
<td>○</td>
<td>○</td>
</tr>
<tr>
<td></td>
<td>RS-422/485</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>AJ71C24-S6</td>
<td>RS-232C</td>
<td>○</td>
<td>○</td>
</tr>
<tr>
<td></td>
<td>RS-422</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>AJ71C24-S8</td>
<td>RS-232C</td>
<td>○</td>
<td>○</td>
</tr>
<tr>
<td></td>
<td>RS-422</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>A1SJ71UC24-R2</td>
<td>RS-232C</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td>A1SJ71C24-R2</td>
<td>RS-232C</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td>A1SJ71UC24-PRF</td>
<td>RS-232C</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td>A1SJ71C24-PRF</td>
<td>RS-232C</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td>A1SJ71UC24-R4</td>
<td>RS-422/485</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>A1SJ71C24-R4</td>
<td>RS-422/485</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>A1SCPUC24-R2</td>
<td>RS-232C</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td>A2CCPUC24</td>
<td>RS-232C</td>
<td>○</td>
<td>○</td>
</tr>
<tr>
<td></td>
<td>RS-422</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>RS-422/485</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>A2CCPUC24-PRF</td>
<td>RS-232C</td>
<td>○</td>
<td>○</td>
</tr>
<tr>
<td></td>
<td>RS-422</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>RS-422/485</td>
<td>×</td>
<td>×</td>
</tr>
</tbody>
</table>
*2: The following table indicates whether the interfaces may be connected to the personal computer when the PLC CPU is accessed from the personal computer via the serial communication module (QC24). If the module cannot be connected directly with the personal computer, it may be usable as the "n"th module of multidropping.

<table>
<thead>
<tr>
<th>Type</th>
<th>Interface</th>
<th>1:1 Connection</th>
<th>Multidropping</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>First module</td>
<td>&quot;n&quot;th module</td>
</tr>
<tr>
<td>AJ71QC24</td>
<td>RS-232C</td>
<td>○</td>
<td></td>
</tr>
<tr>
<td></td>
<td>RS-422/485</td>
<td>×</td>
<td>○</td>
</tr>
<tr>
<td>AJ71QC24N</td>
<td>RS-232C</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>RS-422/485</td>
<td>×</td>
<td>○</td>
</tr>
<tr>
<td>AJ71QC24-R2</td>
<td>RS-232C</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>RS-232C</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>AJ71QC24N-R2</td>
<td>RS-232C</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>RS-232C</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>AJ71QC24-R4</td>
<td>RS-422</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>RS-422/485</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>AJ71QC24N-R4</td>
<td>RS-422</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>RS-422/485</td>
<td>×</td>
<td>○</td>
</tr>
<tr>
<td>A1SJ71QC24</td>
<td>RS-232C</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>RS-422/485</td>
<td>×</td>
<td>○</td>
</tr>
<tr>
<td>A1SJ71QC24N</td>
<td>RS-232C</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>RS-422/485</td>
<td>×</td>
<td>○</td>
</tr>
<tr>
<td>A1SJ71QC24-R2</td>
<td>RS-232C</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>RS-232C</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>A1SJ71QC24N-R2</td>
<td>RS-232C</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>RS-232C</td>
<td>×</td>
<td>×</td>
</tr>
</tbody>
</table>

*3: The following table indicates whether the interfaces may be connected to the personal computer when the PLC CPU is accessed from the personal computer via the serial communication module (Q series). If the module cannot be connected directly with the personal computer, it may be usable as the "n"th module of multidropping.

<table>
<thead>
<tr>
<th>Type</th>
<th>Interface</th>
<th>1:1 Connection</th>
<th>Multidropping</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>First module</td>
<td>&quot;n&quot;th module</td>
</tr>
<tr>
<td>QJ71C24</td>
<td>RS-232C</td>
<td>○</td>
<td></td>
</tr>
<tr>
<td></td>
<td>RS-422/485</td>
<td>×</td>
<td>○</td>
</tr>
<tr>
<td>QJ71C24-R2</td>
<td>RS-232C</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td></td>
<td>RS-232C</td>
<td>×</td>
<td>×</td>
</tr>
</tbody>
</table>
2.4 Precautions for Handling Projects on the Earlier Versions

2.4.1 When handling a project on GX Developer (SW4D5-GPPW-E or earlier)

When handling the GX Developer created project on the version of GX Developer (SW4D5C-GPPW-E or earlier), observe the precautions below. Before handling the project, ensure to read them carefully.

About device memory:
1. When editing on GX Developer and the version of GX Developer (SW4D5C-GPPW-E or earlier), do not create multiple device memories. (Refer to Chapter 11 for device memories.)

Do not read the GX Developer created multiple device memories on the version of GX Developer (SW4D5C-GPPW-E or earlier). The data cannot be read correctly.

2. Do not read the GX Developer created device memory of 32 MB or more on the version of GX Developer (SW4D5C-GPPW-E or earlier).
2.4.2 When handling a project on SW5D5-GPPW-E or earlier

Observe the following precautions when handling the GX Developer created project on the version of GX Developer (SW5D5-GPPW-E or earlier). Read them carefully before handling the project.

1. About the parameters (for the QCPU (Q mode))
   For the data where any of the parameters of the following items has been set, the project cannot be read from the personal computer/PLC CPU on GX Developer (SW5D5-GPPW-E or earlier).

   [Items which cannot be read if set on GX Developer]
   • Multi PLC setting
   • I/O assignment (when multi PLC setting has been made)
   • Memory card of boot file setting → Standard ROM all data automatic write setting
   • Attached file format "CSV" of Ethernet ([E-mail settings] → [New setting])
   • "Local station 2, 3 setting" of CC-Link ([Operational setting] → Number of exclusive stations)
   • Scan mode setting "sync" of CC-Link (mode setting (in remote I/O network mode)
   • When the following network parameter is set
     (a) MNET/H (remote master)
   • When multi-CPU automatic refresh setting is made

2. About the remote password (for the QCPU (Q mode))
   (1) When the project having the remote password is read, the remote password setting does not appear in the project list of the screen.
      (Edit/change disabled)
   (2) If the project is saved after execution of parameter editing or the like, the remote password setting is not deleted.
   (3) When the PLC type is changed (including the case where the type is changed to other than the QCPU (Q mode)), the remote password file is not deleted.
   (4) When the [Online] PLC user data list is being displayed, the remote password file is not displayed.

3. About the remote I/O station project
   • The remote I/O station project cannot be read on GX Developer (SW5D5C-GPPW-E or earlier).
4. About the device comments (for QCPU (Q mode))
   (1) The range where comments may be handled is U0(YG0) to U1FF(YG65535).
   (2) Comment data created in U200 to U3FF and U3EYG0 to U3FFYG65335 cannot be edited, searched for, and replaced. Comment data are not deleted if a project is saved without comment data editing or similar operation being performed. However, when [Save as] or [Change PLC type] is performed, the comment data created in U200 to U3FF and U3EYG0 to U3FFYG65335 are deleted.

5. About the display scale factor specified
   GX Developer has the function to specify any scale factor in addition to 50, 75, 100 and 150%. Hence, when the project used on the version of GX Developer (SW5D5-GPPW-E or earlier) is to be saved on GX Developer, do not specify the display scale factor of other than 50, 75, 100 and 150%.
   If the project saved at the display scale factor of other than 50, 75, 100 and 150% is read on the GX Developer (SW5D5-GPPW-E or earlier), that project opens at the preset scale factor, but is displayed blank when the scale factor is changed with the zoom tool button. In that case, perform the following operation to change the display scale factor setting to any of 50, 75, 100 and 150%.
   [Operating Procedure]
   Select [View] → [Zoom], then select a magnification factor.

2.4.3 Handling a Project in GX Developer (SW6D5-GPPW-E 6.04E or Older)

The precaution given below applies when a project created in GX Developer SW6D5C-GPPW-E 6.05F is handled in an older version of GX Developer (SW6D5-GPPW-E 6.04E or older).
Carefully read the explanation below before handling the project.

1. About parameter (Applicable to the QCPU (Q mode))
   If the following parameter is set for the data, the project cannot be read from the personal computer/PLC CPU using GX Developer (SW6D5-GPPW-E 6.04E or older).
   [Item that makes the project unreadable if set in GX Developer (SW6D5-GPPW-E 6.05F)]
   (1) Network parameters → [Ethernet] → [Open settings] → "Protocol" → "TCP" → "Open system" → "MELSOFT connection"
3. COMMON OPERATIONS

This chapter describes the common key operations and screen operations in GX Developer and the common function operations in some modes.

3.1 List of Shortcut Keys and Access Keys

(1) List of shortcut keys
The following table lists the shortcut keys available with GX Developer.

<table>
<thead>
<tr>
<th>Shortcut Key</th>
<th>Tool Button</th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt + F4</td>
<td>–</td>
<td>Close</td>
<td>Closes the active window.</td>
</tr>
<tr>
<td>Ctrl + F6</td>
<td>–</td>
<td>Next window</td>
<td>Activates the next window.</td>
</tr>
<tr>
<td>Ctrl + N</td>
<td>–</td>
<td>Create project</td>
<td>Creates a new project.</td>
</tr>
<tr>
<td>Ctrl + O</td>
<td>–</td>
<td>Open project</td>
<td>Opens an existing project.</td>
</tr>
<tr>
<td>Ctrl + S</td>
<td>–</td>
<td>Save project</td>
<td>Saves the project.</td>
</tr>
<tr>
<td>Ctrl + P</td>
<td>–</td>
<td>Print</td>
<td>Prints the project.</td>
</tr>
<tr>
<td>Ctrl + Z</td>
<td>–</td>
<td>Undo</td>
<td>Reverts the previous operation.</td>
</tr>
<tr>
<td>Ctrl + X</td>
<td>–</td>
<td>Cut</td>
<td>Moves the selected data to the Clipboard.</td>
</tr>
<tr>
<td>Ctrl + C</td>
<td>–</td>
<td>Copy</td>
<td>Copies the selected data to the Clipboard.</td>
</tr>
<tr>
<td>Ctrl + V</td>
<td>–</td>
<td>Paste</td>
<td>Copies the contents of the Clipboard to the cursor position.</td>
</tr>
<tr>
<td>Ctrl + A</td>
<td>–</td>
<td>Select all</td>
<td>Selects all the edit objects.</td>
</tr>
<tr>
<td>Shift + Ins</td>
<td>–</td>
<td>Insert row</td>
<td>Inserts a row at the cursor position.</td>
</tr>
<tr>
<td>Shift + Del</td>
<td>–</td>
<td>Delete row</td>
<td>Deletes a row at the cursor position.</td>
</tr>
<tr>
<td>Ctrl + Ins</td>
<td>–</td>
<td>Insert column</td>
<td>Inserts a column at the cursor position.</td>
</tr>
<tr>
<td>Ctrl + Del</td>
<td>–</td>
<td>Delete column</td>
<td>Deletes a column at the cursor position.</td>
</tr>
<tr>
<td>Shift + F2</td>
<td>–</td>
<td>Read mode</td>
<td>Sets the read mode.</td>
</tr>
<tr>
<td>F2</td>
<td>–</td>
<td>Write mode</td>
<td>Sets the write mode.</td>
</tr>
<tr>
<td>GPPA</td>
<td>F5</td>
<td>Circuit symbol</td>
<td>Insert a at the cursor position.</td>
</tr>
<tr>
<td>GPPQ</td>
<td>–</td>
<td>Open contact</td>
<td>Inserts the contact a at the cursor position.</td>
</tr>
<tr>
<td>MEDOC</td>
<td>1</td>
<td>Close contact</td>
<td>Inserts the contact b at the cursor position.</td>
</tr>
<tr>
<td>GPPA</td>
<td>Shift + F5</td>
<td>Open branch</td>
<td>Inserts the contact a (open branch) at the cursor position.</td>
</tr>
<tr>
<td>GPPQ</td>
<td>F6</td>
<td>Close branch</td>
<td>Inserts the contact b (close branch) at the cursor position.</td>
</tr>
<tr>
<td>MEDOC</td>
<td>2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>GPPA</td>
<td>F6</td>
<td></td>
<td></td>
</tr>
<tr>
<td>GPPQ</td>
<td>Shift + F5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MEDOC</td>
<td>3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>GPPA</td>
<td>Shift + F6</td>
<td></td>
<td></td>
</tr>
<tr>
<td>GPPQ</td>
<td>–</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MEDOC</td>
<td>4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Shortcut Key</td>
<td>Tool Button</td>
<td>Function</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------</td>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>GPPA</td>
<td>F7</td>
<td>Coil</td>
<td>Inserts the coil (OUT) at the cursor position.</td>
</tr>
<tr>
<td>GPPQ</td>
<td>F7</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MEDOC</td>
<td>Shift</td>
<td></td>
<td></td>
</tr>
<tr>
<td>GPPA</td>
<td>F8</td>
<td>Application instruction</td>
<td>Inserts an application instruction at the cursor position.</td>
</tr>
<tr>
<td>GPPQ</td>
<td>F8</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MEDOC</td>
<td>Shift</td>
<td></td>
<td></td>
</tr>
<tr>
<td>GPPA</td>
<td>F10</td>
<td>Vertical line</td>
<td>Inserts a vertical line at the cursor position.</td>
</tr>
<tr>
<td>GPPQ</td>
<td>F10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MEDOC</td>
<td>Shift</td>
<td></td>
<td></td>
</tr>
<tr>
<td>GPPA</td>
<td>F9</td>
<td>Horizontal line</td>
<td>Inserts a horizontal line at the cursor position.</td>
</tr>
<tr>
<td>GPPQ</td>
<td>F9</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MEDOC</td>
<td>Ctrl</td>
<td>Delete vertical line</td>
<td>Deletes a vertical line at the cursor position.</td>
</tr>
<tr>
<td>GPPA</td>
<td>Ctrl</td>
<td></td>
<td></td>
</tr>
<tr>
<td>GPPQ</td>
<td>Ctrl</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MEDOC</td>
<td>Shift + F9</td>
<td>Delete horizontal line</td>
<td>Deletes a horizontal line at the cursor position.</td>
</tr>
<tr>
<td>Shift + F7</td>
<td>Alt</td>
<td>Leading pulse</td>
<td>Inserts a leading pulse at the cursor position.</td>
</tr>
<tr>
<td>Shift + F8</td>
<td>Alt</td>
<td>Trailing pulse</td>
<td>Inserts the trailing pulse at the cursor position.</td>
</tr>
<tr>
<td>Alt + F7</td>
<td>Alt + F8</td>
<td>Leading pulse open branch</td>
<td>Inserts the leading pulse (open branch) at the cursor pulse.</td>
</tr>
<tr>
<td>Alt + F8</td>
<td>Ctrl + Alt + F10</td>
<td>Trailing pulse open branch</td>
<td>Inserts the trailing pulse (open branch) at the cursor position.</td>
</tr>
<tr>
<td>Ctrl + Alt + F10</td>
<td>Alt + F5</td>
<td>Op result invert</td>
<td>Inserts the inverted Op result at the cursor position.</td>
</tr>
<tr>
<td>Ctrl + Alt + F5</td>
<td>Alt + F10</td>
<td>Op result leading pulse</td>
<td>Inserts the inverted Op result at the cursor position.</td>
</tr>
<tr>
<td>Ctrl + Alt + F5</td>
<td>F10</td>
<td>Op result trailing pulse</td>
<td>Inserts the Op result trailing pulse at the cursor position.</td>
</tr>
<tr>
<td>Alt + F10</td>
<td>F10</td>
<td>Insert line</td>
<td>Inserts a line.</td>
</tr>
<tr>
<td>Alt + F9</td>
<td>F4</td>
<td>Delete line</td>
<td>Deletes a line.</td>
</tr>
<tr>
<td>GPPA</td>
<td>F4</td>
<td>Convert</td>
<td>Converts the program.</td>
</tr>
<tr>
<td>GPPQ</td>
<td>Shift + F4</td>
<td>Convert (all edit programs)</td>
<td>Converts all programs being edit at a time.</td>
</tr>
<tr>
<td>MEDOC</td>
<td>Ctrl + Alt + F4</td>
<td>Convert (online change)</td>
<td>Converts the program and writes it to the CPU during running.</td>
</tr>
</tbody>
</table>
### Shortcut Key Tool Button

<table>
<thead>
<tr>
<th>Shortcut Key</th>
<th>Tool Button</th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + F5</td>
<td>–</td>
<td>Comment</td>
<td>Displays or hides comments.</td>
</tr>
<tr>
<td>Ctrl + F7</td>
<td>–</td>
<td>Statement</td>
<td>Displays or hides statements.</td>
</tr>
<tr>
<td>Ctrl + F8</td>
<td>–</td>
<td>Note</td>
<td>Displays or hides notes.</td>
</tr>
<tr>
<td>Ctrl + Alt + F6</td>
<td>–</td>
<td>Alias</td>
<td>Displays or hides Alias.</td>
</tr>
<tr>
<td>Alt + O</td>
<td>—</td>
<td>Project data list</td>
<td>Displays or hides the project data list.</td>
</tr>
<tr>
<td>Alt + F1</td>
<td>—</td>
<td>Instruction list</td>
<td>Switches circuit screen and list screen.</td>
</tr>
<tr>
<td>Alt + F3</td>
<td>—</td>
<td>Monitor</td>
<td>Monitors the screen.</td>
</tr>
<tr>
<td>Ctrl + F3</td>
<td>–</td>
<td>Monitor (all windows)</td>
<td>Monitors all circuits of the programs currently open.</td>
</tr>
<tr>
<td>Shift + F3</td>
<td>—</td>
<td>Monitor (write mode)</td>
<td>Sets the write mode during circuit monitoring.</td>
</tr>
<tr>
<td>Alt + F1</td>
<td>—</td>
<td>Start monitor</td>
<td>Starts (restarts) circuit monitoring.</td>
</tr>
<tr>
<td>Ctrl + Alt + F3</td>
<td>–</td>
<td>Stop monitor</td>
<td>Stops circuit monitoring.</td>
</tr>
<tr>
<td>Alt + 1</td>
<td>—</td>
<td>Stop monitor (all windows)</td>
<td>Stops monitoring of all circuits of the program currently open.</td>
</tr>
<tr>
<td>Alt + 2</td>
<td>—</td>
<td>Device test</td>
<td>Forcibly turns on or off the device and changes the current value.</td>
</tr>
<tr>
<td>Alt + 3</td>
<td>—</td>
<td>Skip</td>
<td>Performs a skip operation for a sequence program for which a range has been specified.</td>
</tr>
<tr>
<td>Alt + 4</td>
<td>—</td>
<td>Partial operation</td>
<td>Partially executes the sequence program.</td>
</tr>
<tr>
<td>Alt + 6</td>
<td>—</td>
<td>Run step</td>
<td>Performs step operation for the PLC.</td>
</tr>
<tr>
<td>Alt + 5</td>
<td>—</td>
<td>Remote operation</td>
<td>Performs remote operation.</td>
</tr>
</tbody>
</table>
(2) **Access key**

An access key is indicated by an alphabetic character shown at the end of each menu title to enable the user to select the menu with the keyboard.

Press **Alt** and **key** in order to highlight the [Project] menu. Press **key**, then the drop-down menu will be displayed.

Press **key** to save the project.
3.2 Project Designation

GX Developer sets a drive/path and a project name, but does not set the system name set like GPPA and GPPQ. This section compares and describes the differences between GX Developer and GPPA/GPPQ.

- Designation in GPPA

  ..\GPP\USR\system-name\machine-name

  Path name

- Designation in GPPQ

  ..\GPPQ\SYS\system-name\machine-name\file-name

  Path name

- Designation in GX Developer

  \project-name

  Path name

Corresponds to the machine name in GPPA or GPPQ.

- The GX Developer project path and project names can be designated as follows:

  Example

  1. C:\GPPW-program\main \data-1

  2. C:\factory-A \line-1

As shown above, the project can be saved in a desired folder.
3.2.1 Saving a project

[Purpose]
Designate a project name to read, save or delete a project, or to create a new project.

[Dialog Box]

[Description]
1) Project drive
Designates a drive in which the project has been saved or is to be saved.

2) button
Click this button to move to the folder one level upper than the current folder.

3) button
Click this button to list the names of folders and projects contained in the current folder.

4) button
Click this button to display the details of the folders and projects contained in the current folder such as the PLC types, creation dates, and title.

5) Double-click the icon to move to the folder one level upper than the current folder.

6) Drive/path
Designates the path of the folder where the project has been saved or is to be saved.
If you do not specify the drive/path (blank) but specify only the project name, the default drive/path is automatically created and the project is saved.
7) Project name
Designates a project name.
The following shows the characters and the number of characters that can be used to designate a drive path, project name, or data name.

- Number of characters
The total number of characters used for designating both the project path and the project name (8 or more characters may be set) is 150.

<Example>
C:\SW3D5GPPW\ABCDEFGHIJKLMNOPQRSTUVWXYZ

- Characters not available in A, QnA and FX series
/\>,<,*,,",",|; (; and \ can be set for drive designation only)
(: and \ are available only when the drive is specified.)
Any project name cannot be ended by a period (.)
(If a space is inserted after the project name, it is automatically deleted.)

8) Title
Sets the title for the project in up to 32 characters.

POINT
- If 8 or more characters have been entered for the project name in GX Developer SW3D5C-GPPW-E or later, those after the 8th character won’t be displayed when the project is read in an older version of GX Developer (SW2D5-GPPW-E or older).
- If the project name includes a space, GX Developer will not launch properly when the GPPW.gpj,***.gps file is double-clicked in Explorer. Launch GX Developer first, and then select [Project] and open the project using the [Open project] menu.
[Example]
Project name to be saved : TEST1
Title : Test program
Project location : A:\GPPW\GX Developer installation location : C:\MELSEC\GPPW

[Operating Procedure]
1. Select [Project] → [Save as].
2. Change the project drive from [-c-] to [-a-].
3. Type "GPPW" as the project path.
4. Type "TEST1" as a project name. Then, type "Test program" as the project title. Click the [Save] button, and the project will be saved in the designated folder.
3.2.2 Opening a project

[Example]
Name of project to be read: TEST1
Project save location: A:\GPPW\nGX Developer installation location: C:\MELSEC\GPPW

[Operating Procedure]
1. Select [Project] → [Open project].
2. Change the project drive from [-c-] to [-a-].

3. Double-click the “GPPW” folder icon in the list box to designate a project path.

4. Click the “TEST1” project icon in the list box to designate the name of a project to be read. Click the [Open] button, and the designated project will be opened.
3.3 Cut, Copy, and Paste

This section describes the common operations such as cutting, copying and pasting table data such as comments, parameters, etc. For details on how to cut, copy and paste the circuits, see Section 6.2.8.

3.3.1 Cut and paste

- Cutting and pasting the data
  The following example shows how to cut and paste the comments. Comments, parameters, and device memory can be cut and pasted through the same procedure.

[Operating Procedure]
1. Click the first cell of the comments to be cut, and the cursor will be positioned there.

<table>
<thead>
<tr>
<th>Device</th>
<th>Comment</th>
<th>Label</th>
</tr>
</thead>
<tbody>
<tr>
<td>02</td>
<td>Unit abnormal</td>
<td></td>
</tr>
<tr>
<td>01</td>
<td>Host data link condition</td>
<td></td>
</tr>
<tr>
<td>02</td>
<td>Parameter setting condition</td>
<td></td>
</tr>
<tr>
<td>03</td>
<td>Timer setting condition</td>
<td></td>
</tr>
<tr>
<td>04</td>
<td>Unit reset execute complete</td>
<td></td>
</tr>
<tr>
<td>05</td>
<td>Start data link</td>
<td></td>
</tr>
<tr>
<td>06</td>
<td></td>
<td></td>
</tr>
<tr>
<td>07</td>
<td></td>
<td></td>
</tr>
<tr>
<td>08</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

2. Confirm that the cursor is displayed, then drag the mouse over the range of the comments to be cut. The dragged comment cells are highlighted (the first cell in the range is not highlighted).

To change the designated range, click any cell in the comment column.

<table>
<thead>
<tr>
<th>Device</th>
<th>Comment</th>
<th>Label</th>
</tr>
</thead>
<tbody>
<tr>
<td>02</td>
<td>Unit abnormal</td>
<td></td>
</tr>
<tr>
<td>01</td>
<td>Host data link condition</td>
<td></td>
</tr>
<tr>
<td>02</td>
<td>Parameter setting condition</td>
<td></td>
</tr>
<tr>
<td>03</td>
<td>Timer setting condition</td>
<td></td>
</tr>
<tr>
<td>04</td>
<td>Unit reset execute complete</td>
<td></td>
</tr>
<tr>
<td>05</td>
<td>Start data link</td>
<td></td>
</tr>
<tr>
<td>06</td>
<td></td>
<td></td>
</tr>
<tr>
<td>07</td>
<td></td>
<td></td>
</tr>
<tr>
<td>08</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

3. Select [Edit] → [Cut] or click $\text{Ctrl} + \text{X}$, and the designated range of comments will be cut.
4. Click the first cell in the comment column where the comments are to be pasted, and the cursor will be positioned there.

<table>
<thead>
<tr>
<th>Device</th>
<th>Comment</th>
<th>Label</th>
</tr>
</thead>
<tbody>
<tr>
<td>00</td>
<td>Unit abnorm.</td>
<td></td>
</tr>
<tr>
<td>01</td>
<td>Abnormal data link condition</td>
<td></td>
</tr>
<tr>
<td>02</td>
<td></td>
<td></td>
</tr>
<tr>
<td>03</td>
<td></td>
<td></td>
</tr>
<tr>
<td>04</td>
<td>Start data link</td>
<td></td>
</tr>
<tr>
<td>05</td>
<td></td>
<td></td>
</tr>
<tr>
<td>06</td>
<td>Parameter setting complete</td>
<td></td>
</tr>
<tr>
<td>07</td>
<td></td>
<td></td>
</tr>
<tr>
<td>08</td>
<td>Other station condition</td>
<td></td>
</tr>
<tr>
<td>09</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

5. Confirm that the cursor ( ) is displayed, then select [Edit] → [Paste] or click (Ctrl + V).

The cut comments are pasted into the cells in the comment column starting from the designated cell.

- The cut, copy, and paste menus can also be selected from the popup menu displayed by clicking the right mouse mouse button.
3.3.2 Copy and paste

- Copying and pasting the data
  The following example shows how to copy and paste comments. Comments, parameters, and device memory can be copied and pasted through the same procedure.

[Operating Procedure]
1. Click the first cell of the comments to be copied, and the cursor will be positioned there.

2. Confirm that the cursor ( ) is displayed, then drag the mouse over the range of the comments to be copied.
   The dragged comment cells are highlighted (the first cell in the range is not highlighted).
   To change the designated range, click any cell in the comment column.

3. Click the first cell in the comment column where the comments are to be pasted, and the cursor will be positioned there.
4. Confirm that the cursor ( ) is displayed, then select [Edit] → [Paste] or click (Ctrl + V).

The copy comments are pasted into the cells in the comment column starting from the designated cell.

<table>
<thead>
<tr>
<th>Device</th>
<th>Comment</th>
<th>Label</th>
</tr>
</thead>
<tbody>
<tr>
<td>X0</td>
<td>Unit channel</td>
<td></td>
</tr>
<tr>
<td>X1</td>
<td>Host data link condition</td>
<td></td>
</tr>
<tr>
<td>X2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>X3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>X4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>X5</td>
<td>Start data link</td>
<td></td>
</tr>
<tr>
<td>X6</td>
<td></td>
<td></td>
</tr>
<tr>
<td>X7</td>
<td>Parameter setting condition</td>
<td></td>
</tr>
<tr>
<td>X8</td>
<td>Other station condition</td>
<td></td>
</tr>
<tr>
<td>X9</td>
<td>Unit reset receive complete</td>
<td></td>
</tr>
<tr>
<td>X0A</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**POINTS**

- The cut, copy, and paste menus can also be selected from the popup menu displayed by clicking the right mouse button.
- Notes on cut, copy and paste operations of parameters
  1. Only numeric characters can be pasted. (Alphabetic characters cannot be pasted.)
  2. The format conversion of the numeric value does not take place at a destination for pasting.

  <Example>
  Even when the network number (decimal) "10" is copied and pasted at the first I/O number (hexadecimal), it is not converted to "A."
3.3.3 Notes on cutting, copying and pasting network parameters

The following shows the areas in which you can cut, copy and paste network parameters and also the areas that prevent these operations.

<table>
<thead>
<tr>
<th>Prevent cut, copy and paste.</th>
<th>Allows cut, copy and paste.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allows cut, copy and paste.</td>
<td>Prevents cut, copy and paste.</td>
</tr>
<tr>
<td>Allows cut, copy and paste.</td>
<td>Allows cut, copy and paste.</td>
</tr>
<tr>
<td>Allows cut, copy and paste.</td>
<td>Allows cut, copy and paste.</td>
</tr>
<tr>
<td>Allows cut, copy and paste.</td>
<td>Allows cut, copy and paste.</td>
</tr>
<tr>
<td>Allows cut, copy and paste.</td>
<td>Allows cut, copy and paste.</td>
</tr>
<tr>
<td>Allows cut, copy and paste.</td>
<td>Allows cut, copy and paste.</td>
</tr>
<tr>
<td>Allows cut, copy and paste.</td>
<td>Allows cut, copy and paste.</td>
</tr>
<tr>
<td>Allows cut, copy and paste.</td>
<td>Allows cut, copy and paste.</td>
</tr>
<tr>
<td>Allows cut, copy and paste.</td>
<td>Allows cut, copy and paste.</td>
</tr>
</tbody>
</table>

---

[Table and Diagram as shown in the image]
POINTS

- When used together with MELSECNET(II), the L/R type is not changed even if lines in a local station are copied and pasted to a remote station (or vice versa).
- When some destination items allow paste but some prevent paste, parameter paste takes place only in the items allowing paste.
- When the data types of copy source and destination are not the same, an abnormal paste operation may result. For example, this problem occurs when data in the Point column is pasted in the Start column of the destination.
- Only numeric characters can be copied and pasted.
- Even when decimal data is cut, copied, and pasted in a hexadecimal column, it is not converted into hexadecimal data. However, when a decimal number "16" is copied into a hexadecimal column, it is handled as a decimal number "22."
3.4 Toolbar

The toolbar contains the menu items or the attributes of data types. To execute a menu item, move the cursor onto the icon, then click there. To display or hide the tool bar, select [View] → [Toolbar].

[Dialog Box]

1) Toolbar
   Click here to display or hide the toolbar.
   Click to display the toolbar and click / to hide the tool bar.

2) Customize
   Click this button to add/delete a tool button to/from the toolbar.
   By default, all the tool buttons are displayed on the toolbar.

3) OK button
   Click this button after making necessary settings.
3.5 Status Bar

The status bar is displayed at the bottom of the application window to indicate GX Developer status information.

To display or hide the status bar, select [View] → [Status bar].

<table>
<thead>
<tr>
<th>Description</th>
<th>1) Indicates the status of the mouse cursor position.</th>
<th>2) Indicates the CPU type.</th>
<th>3) Indicates the destination CPU.</th>
<th>4) Indicates the current mode.</th>
<th>5) Indicates the status of the <strong>Caps Lock</strong> key.</th>
<th>6) Indicates the status of the <strong>Num Lock</strong> key.</th>
<th>7) Indicates the status of the <strong>Scroll Lock</strong> key.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
3.6 Zooming in on or out of the Edit Screen

This section describes how to magnify (zoom in) or reduce (zoom out) the edit screen. The edit screen can be resized as necessary.

[Operating Procedure]
Select [View] → [Zoom], then select a magnification factor.
Or click \[\text{ ]} \] or \[\text{ ]} \] to get the same result.
When \[\text{ ]} \] on the tool bar is selected, the edit screen is magnified.
In contrast, when \[\text{ ]} \] is selected, the edit screen is reduced.

[Dialog Box]

Ladder mode

<table>
<thead>
<tr>
<th>Magnification</th>
</tr>
</thead>
<tbody>
<tr>
<td>150%</td>
</tr>
<tr>
<td>100%</td>
</tr>
<tr>
<td>75%</td>
</tr>
<tr>
<td>50%</td>
</tr>
<tr>
<td>Specify 75</td>
</tr>
<tr>
<td>Auto</td>
</tr>
</tbody>
</table>

List mode

<table>
<thead>
<tr>
<th>Magnification</th>
</tr>
</thead>
<tbody>
<tr>
<td>150%</td>
</tr>
<tr>
<td>100%</td>
</tr>
<tr>
<td>75%</td>
</tr>
<tr>
<td>50%</td>
</tr>
<tr>
<td>Specify 75</td>
</tr>
<tr>
<td>Auto</td>
</tr>
</tbody>
</table>

SFC mode

<table>
<thead>
<tr>
<th>Magnification</th>
</tr>
</thead>
<tbody>
<tr>
<td>150%</td>
</tr>
<tr>
<td>100%</td>
</tr>
<tr>
<td>75%</td>
</tr>
<tr>
<td>50%</td>
</tr>
<tr>
<td>Specify 75</td>
</tr>
<tr>
<td>Auto</td>
</tr>
</tbody>
</table>

[Description]
1) Specify
   Specify the scale factor within the range 50 to 150.

2) Auto
   The width of a ladder is automatically adjusted to display the whole ladder.
   In the ladder mode, the Columns setting is masked.
   In the list mode, Auto is masked.
   In the SFC mode, you can set the Columns within the range 1 to the maximum.

POINT
Refer to Section 2.4.2 for the precautions for and restrictions on using the GX Developer (SW5D5-GPPW-E) or earlier version to read the project where this function has been set.
3.7 Project Data List

A project data list contains project data according to the data types. To directly display the edit screen, double-click on project data. To display or hide the project data list, select [View] → [Project data list] or click $(\text{Alt} + \text{O})$.

To add, copy, delete or rename project data, click the target project data with the right mouse button. See Sections 4.9 to 4.12 for details on each operation. Data names except the parameters can also be deleted with the Delete key.

The project data list can be changed in size by floating it or can be hidden by clicking $\times$.
• You can change the edit screen from the toolbar.

1. Choose the data type.

   Click here.

2. Choose the data type you want to change.

   Click here.

3. Choose the data name.

   Click here.

4. Choose the data you want to show.

   Click here.

   POINT

   If you opened multiple programs, comments, etc. or if you started multiple GX Developers, the screen may be changed in color or shape (displayed improperly).

   In such a case, close the other applications or program and comment screens.
3.8 Comment Display

[Purpose]
Displays the created device comments on the circuit creation screen.

[Operating Procedure]
Select [View] → [Comment]

POINT
• When a common comment and a comment by program have been set for the same device, click <<Each program>> tab on the dialog box displayed by selecting [Tool] → [Option] tab to set a comment to be displayed. Refer to Section 15.11.
The comment from the GX Developer (SW3D5-GPPW-E) is displayed just beneath the circuit symbol.
(It will be printed out just beneath the circuit symbol, if printed out.) Only when monitored, is it displayed with one line spaced.

3.9 Statement Display

[Purpose]
Displays the created statement on the circuit creation screen.

[Operating Procedure]
Select [View] → [Statement]

POINT
• In the FXGP (DOS) and FXGP (WIN), "statement" is called the "circuit comment".

3.10 Note Display

[Purpose]
Displays the created notes on the circuit creation screen.

[Operating Procedure]
Select [View] → [Note]

POINT
• In the FXGP (WIN), "note" is called the "coil comment".
3.11 Alias Display

[Purpose]
Displays the Alias in circuit mode on the circuit creation screen.

[Operating Procedure]
Select [View] → [Alias]

POINT
• Create the Alias on the device comment edit screen.
  Device names created in A Series format will not be saved when written in a different file format.

3.12 Comment Format

[Purpose]
To display comments in the ladder mode in 4 × 8 characters or 3 × 5 characters.

[Operating Procedure]
[View] → [Comment format]
3.13 Alias format display

3.13.1 Replace device name and display

[Purpose]
Displays aliases in device display positions.

[Operating Procedure]
[View] → [Alias format display] → [Replace device name and display]

[Dialog Box]

3.13.2 Arrange with device and display

[Purpose]
Displays aliases above devices shown. (Displays devices and aliases together)

[Operating Procedure]
[View] → [Alias format display] → [Arrange with device and display]

[Dialog Box]

POINT
For timers/counters, if you set aliases to T0 and D0, respectively, in such an instruction as OUT T0 DO, the alias added to D0 (set value) does not appear.
4. INITIALIZATION

4.1 Creating a Project

[Purpose]
Designates the information required to create a project such as PLC series, PLC type and project name.

[Operating Procedure]
Select [Project] → [New project] or click Ctrl + N.

[Dialog Box]

[Description]
1) PLC series
   Designates the PLC series of the project by selecting from QCPU(Qmode), QnA series, QCPU(Amode), A series, MOTION(SCPU) and FX series.

2) PLC type
   Designates the CPU type to be used by selecting from the list.
   For FX and FX2, select FXU.
   When creating remote I/O parameters on the Q series, choose the QCPU (Q mode) as the PLC series and then select "Remote I/O" as the PLC type.

3) Program type
   Choose either of ladder program or SFC program. When creating an SFC on the A series, make the following settings.
   1. Set the microcomputer value in the memory capacity setting of PLC parameters.
   2. Choose SFC in the project type on the [Project][Edit data][New] screen. SFC is not compatible with label programming.
   Refer to Chapter 5 for the creating procedure.
4) Set project name
Designate a project name to save the created data.
When designating a project name before creating a program, check the checkbox.
The project name can be designated before and after program creation.
When designating the project name after data creation, use the [Save As] menu.
See Section 5.4 "Naming and Saving a Project."

5) Drive/path

6) Project name
See Section 3.2 for setting these fields.

7) Title

8) [OK] button
Click this button after making necessary settings.

POINTS
- The following lists the data and data names in new project creation.

| Program    | : MAIN            |
| Comment    | : COMMENT (common comment) |
| Parameter  | : PLC parameter   |
|            | : Network parameter (A series and QnA series only) |

- In addition, see Sections 4.9 and 11.2 for device memory, and Section 4.9 and Chapter 12 for device initial values (QnA series only).

- If multiple programs are being created or multiple GX Developers are running, the screen may not be displayed properly due to the shortage of the personal computer resources.
In this case, close GX Developers once or close other applications, if any.

- If you do not specify the drive/path (blank) but specify only the project name, the default drive/path is automatically created and the project is saved.
4.2 Opening the Existing Project File

[Purpose]
Reads the saved project file.

[Operating Procedure]
Select [Project] → [Open project] or click (Ctrl + O).

[Dialog Box]
For details on how to designate the drive/path, project name, and project title, see Section 3.2.2.
POINT

- When the existing project is opened, GX Developer starts in the screen status that the project was saved.
- GX Developer screen position and size.
- Ladder monitor, registration monitor, batch monitor status (when connected with CPU)
  However, the screen is not restored properly if the resolution is different.
- In GX Developer (SW3D5-GPPW-E Ver. 00A to SW5D5-GPPW-E Ver. 10B), 32-bit constants cannot be used for the third device in the DTO instruction of the ACPU. (Third device constants can have a maximum of 16 bits.)
  When the same data is also used in a version of GX Developer (other than SW3D5-GPPW-E Ver. 00A to SW5D5-GPPW-E Ver. 10B), the values displayed on the screen will become different. (Although data is saved in 32 bits internally, it becomes 16-bit data when the DTO instruction is edited in GPPA or a version of GX Developer between SW3D5-GPPW-E Ver. 00A and SW5D5-GPPW-E Ver. 10B. Caution is necessary.)

GX Developer (SW3D5-GPPW-E Ver. 00A to SW5D5-GPPW-E Ver. 10B) and GPPA can only handle 16-bit data. Therefore, when a program created in 32 bits is displayed in these applications, the screen will show only the lower 16 bits.

To align the values displayed in GX Developer and GPPA (regardless of versions), it is recommended that the 32-bit data be replaced using the DMOV instruction immediately before the DTO instruction.

<Example of program>
4.3 Closing a Project File

[Purpose]
Closes the active project file.

[Operating Procedure]
Select [Project] → [Close project].

[Description]
When no project name has been designated or data has been edited, you will be prompted to save change to the project when you select [Close project].
To save the change to the project, click the [Yes] button.
To close the project without saving it, click the [No] button.

For label programming
A dialog box appears if there are data being edited in global variable setting/local variable setting.
If you do not discard the edited data, click the [No] button, click the [Register] button on the global variable setting/local variable setting screen, and then close the project.

POINT
When saving the existing project with a name, an old project must exist.
(For example, if a project on an FD is opened and the FD is then removed, that project cannot be saved into another drive with a name.)

4.4 Saving a Project

[Purpose]
Saves the active project file with the designated name.

[Operating Procedure]
Select [Project] → [Save project] or click (Ctrl + S).

[Description]
Selecting [Save project] causes data to be written onto the existing project file.

For label programming
A dialog box appears if there are data being edited in global variable setting/local variable setting.
If you do not discard the edited data, click the [No] button, click the [Register] button on the global variable setting/local variable setting screen, and then save the project.
4.5 Saving a Project with a New Name

[Purpose]
Saves the active project with a new name.

[Operating Procedure]
Select [Project] → [Save as].

[Description]
Designate the project path, project name, and project title before saving the project.

For details, see Section 3.2.1.
A dialog box appears if there are data being edited in global variable setting/local variable setting.
If you do not discard the edited data, click the [No] button, click the [Register] button on the global variable setting/local variable setting screen, and then save the project.

POINT
When saving the existing project with a name, an old project must exist.
(For example, if a project on an FD is opened and the FD is then removed, that project cannot be saved into another drive with a name.)

4.6 Deleting a Project

[Purpose]
Deletes the unnecessary project files.

[Operating Procedure]
Select [Project] → [Delete project].

[Description]
Select the project to be deleted, then click the [Delete project] button.
4.7 Verifying Data in Projects

[Purpose]
Verifies data between the PLC projects of the same PLC type.

[Operating Procedure]
Select [Project] → [Verify].

[Dialog Box]

[Description]
1) List of source verify source data for verification
   Lists the current project data. Check the checkbox of a data name to select it.

2) List verify dest
   Lists the project data of a destination. Check the checkbox of a data name to select it.

3) Drive/path, Project name
   Sets a drive path for the project data to be verified. See Section 3.2 for details on how to set the path.

4) PLC type
   Displays the PLC type of the project.

5) [Execute] button
   Click this button after making necessary settings.

6) [Param+prog] button
   Selects only the parameter data and program data of a source.
[Operating Procedure]
1. Select a project name in the dialog box displayed by clicking the Browse button to designate a destination drive/path name and a project name.

2. Check a checkbox for source data name and a checkbox for destination data name to be verified.

3. Click the Execute button after making necessary settings.

POINT
- Multiple data can be selected in source and destination data for verification as shown below.
- For label programming
  Verify can be performed when the verify source and verify destination projects are label-programmed. Verify cannot be performed if the project of other than the label-programmed is specified as the verify destination.
- For remote I/O projects
  Verify can be performed when the verify source and verify destination projects are remote projects. You cannot select the project of other than the remote I/O project as the verify destination.
4.8 Copying a Project

[Purpose]
Copies data between projects. When the selected source data is already in the destination, the existing data in the destination is overwritten with the source data.

[Operating Procedure]
Select [Project] → [Copy].

[Dialog Box]

1) Drive/path name, Project name
Designates a drive path for project data to be copied.

2) PLC type
Displays the PLC type of the source project.

3) Source data list
Lists source data.

4) Execute button
Click this button after setting necessary settings.
[Operating Procedure]
1. Select a project in the dialog box displayed by clicking the [Browse] button to designate a source data drive/path name and a project name.

2. Check a checkbox for source data name.

3. Click the [Execute] button after making necessary settings.

**POINT**
- All the selected data will be copied.
  Source

- For label programming (Q/QnA series only)
The following table indicates the items which can be copied when label programming is specified at the copy source and/or copy destination.

<table>
<thead>
<tr>
<th>Copy Destination (Open project)</th>
<th>Copy Source (Copy source project)</th>
<th>Copy Selectable Items</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label program</td>
<td>Label programming</td>
<td>• Label program</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Local variable definition</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Global variable definition</td>
</tr>
<tr>
<td>Label program</td>
<td>Other than label programming</td>
<td>• Program converted into label program is read</td>
</tr>
<tr>
<td></td>
<td>(Actual program)</td>
<td>• Local variables are initialized.</td>
</tr>
<tr>
<td>Other than label programming</td>
<td>Label program</td>
<td>• Only actual program is read.</td>
</tr>
<tr>
<td>(Actual program)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- For remote I/O station program (Q series only)
The following table indicates the after-copy status when remote I/O station projects are specified at the copy source and/or copy destination.

<table>
<thead>
<tr>
<th>Copy Destination (Open project)</th>
<th>Copy Source (Copy source project)</th>
<th>Copy</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remote I/O</td>
<td>QCPU (Q mode)</td>
<td>The parameters of the copy source are copied to the project being edited. However, when the data selected is other than the parameters, the parameters of the copy source become defaults.</td>
</tr>
<tr>
<td></td>
<td>Other than QCPU (Q mode)</td>
<td>Copy cannot be performed.</td>
</tr>
<tr>
<td>QCPU (Q mode)</td>
<td>Remote I/O</td>
<td>Only parameters can be copied.</td>
</tr>
<tr>
<td>Other than QCPU (Q mode)</td>
<td>Remote I/O</td>
<td>Copy cannot be performed.</td>
</tr>
</tbody>
</table>
### 4.9 Adding Data to a Project

**[Purpose]**
Adds a program, common comment, comments by program, or device memory data to the project.

**[Operating Procedure]**
Select [Project] → [Edit data] → [New]

**[Dialog Box]**

![Dialog Box Image]

**[Description]**

1) **Data type**
Designates the type of the data to be added (program, common comment, comments by program, or device memory).
When the FXCPU is selected, only the comments by program or device memory may be added.

2) **Program type**
Choose either of ladder program or SFC program. When creating an SFC on the A series, make the following settings.
1. Set the microcomputer value in the memory capacity setting of PLC parameters.
2. Choose SFC in the project type on the [Project] → [Edit data] → [New] screen.

3) **Data name of the data to be added**
Designates the name of the data to be added.
If one of A series PLCs is set as the PLC type of the active project, the name is fixed as SUB1, SUB2, or SUB3. (If the PLC type is A4UCPU, comments by program, named SUB4, can also be added.)
Name of subprograms can be designated after completing memory capacity setting for parameters.
For Q/QnA series, the name should be designated within 8 characters.
For FX series, MAIN is designated as the name.

Characters that may be used to set a data name
- **For A series**
  The data name of the A series accepts only alphanumeric characters, - (hyphen) and _ (underline).
  In the A series, an error will occur if the data name is headed by a numeral.
- **For Q/QnA/FX series**
  Alphanumeric characters, kana, kanji, _, ^, $, ‹, ›, ‹, ›, (tilde), !, #, %, &, ( ), - , { }, @, * (apostrophe), ' (single quotation)
  Unusable characters
  An error will occur if any of " = | : ; , ¥ [ ] + * ? < > . / exists.
4) Title
   Designates the title of the data in up to 32 characters.

5) [OK] button
   Click this button after setting necessary settings.

POINT

- Multiple device memories/device comments can be created in a project.
4.10 Copying Data within a Project

[Purpose]
Copies the existing data within a project.

[Operating Procedure]
Select [Project] → [Edit data] → [Copy].

[Dialog Box]

[Description]
1) Data type
Designates the data type (program, common comment, comments by program, device memory).

2) Source data name
Designates the name of source data.

3) Destination data name
Designates the new data name.
If necessary, source data can also be overwritten onto an existing data.
The data name must be designated in up to 8 characters.

4) Title
Displays the set title of the data.
If necessary, the title can be edited and stored.
It must be designated in up to 32 characters.

5) [OK] button
Click this button after making necessary settings.
4.11 Deleting Data in a Project

[Purpose]
Deletes an existing data in a project.

[Operating Procedure]
Select [Project] → [Edit data] → [Delete].

[Dialog Box]

1) Data type
Designates the data type (program, common comment, comments by program, device memory).

2) Delete data name
Designates the name of the data to be deleted.

3) OK button
Click this button after making necessary settings.

[Description]
1) Data type
Designates the data type (program, common comment, comments by program, device memory).

2) Data to be deleted
Designates the name of the data to be deleted.

3) OK button
Click this button after making necessary settings.
4.12 Renaming Data in a Project

[Purpose]
Renames the existing data in a project.

[Operating Procedure]
Select [Project] → [Edit data] → [Rename].

[Dialog Box]

[Description]
1) Data type
Designates the data type (program, common comment, comments by program, device memory).

2) Data name before renaming
Designates the data name before renaming.

3) Renamed data name
Designates the new data name after renaming.
The data name must be designated in up to 8 characters.

4) Title
Displays the set title of the data.
If necessary, the title can be edited and stored.
It must be designated in up to 32 characters.

5) OK button
Click this button after making necessary settings.

POINT
This operation cannot change the data name of comments by program to "COMMENT".
For changing the comments by program to the common comment (COMMENT), refer to "Setting Comment Types" (Section 9.6).
4.13 Changing the Ladder and SFC with each other

[Purpose]
Sets when the existing ladder program is changed to the SFC program, and vice versa.

[Operating Procedure]
Select [Project] → [Edit Data] → [Change program type].

[Dialog Box]

[Description]
1) Ladder
   Changes the SFC program being displayed to the ladder program.
   After the changing operation has been completed, editing of the ladder program is enabled.

2) SFC
   Changes the ladder program being displayed to the SFC program.
   After the changing operation has been completed, editing of the SFC program is enabled.

3) [OK] button
   Click this button after making necessary settings.

POINTS
- For cautions on interchanging, refer to the GX Developer Version6 Operating Manual (SFC Version).
4.14 Changing the PLC Type of a Project

[Purpose]
Changes the type of the existing data or the data being edited so that it can be used with another type or PLC series.

[Operating Procedure]
Select [Project] → [Change PLC type].

[Dialog Box]

1) PLC series/PLC type
Designates the PLC series or PLC type to be changed.

2) OK button
Click this button after making necessary settings. After the OK button is clicked, the following dialog box appears.

[Description]

a) By clicking the [Confirm change] button, you can change the parameter and other settings while simultaneously confirming them. When changing the PLC type between FX and FX, you can make corrections to the PLC parameter capacity within the specification range of the PLC type after change.

POINTS

- For restrictions on changing each PLC series/PLC type, refer to the restrictions on PLC Change in Appendix 4.
- When reading a project from an FD or the like, you cannot make a PLC type change if there is no source project. When changing the PLC type, do not remove the FD or the like nor delete the project.
- Note that if SB and/or SW is used in CC-Link refresh setting, special module interrupt setting or the like, a Q → QnA change will cause the SB and/or SW in that part not to be refreshed or interrupt-processed.
- PLC type cannot be changed during the monitoring of the circuit or device data in batch.
- If you select Remote I/O of the QCPU (Q mode) in PLC type changing, the data of the conversion source are changed to defaults.
- Refer to Appendix 4 for label programming.
4.15 Reading Other Format Files

4.15.1 Reading GPPQ, GPPA, FXGP(DOS) or FXGP(WIN) files

[Purpose]
Reads the existing GPPQ, GPPA, FXGP(DOS), and FXGP(WIN) data into GX Developer. These data can be read according to the following procedure immediately after GX Developer is started.

[Operating Procedure]
Select [Project] \[Import file\] \[Import from GPPQ format file\] \[Import from GPPA format file\] \[Import from FXGP(WIN) format file\] \[Import from FXGP(DOS) format file\]

[Dialog Box]

[Description]
1) Drive/path, System name, Machine name
Designates the location of data created by GPPQ, GPPA, FXGP(DOS) or FXGP(WIN).
Enter a system name and a machine name for the data specified in the drive path. Clicking the [Browse] button shows the dialog box for choosing the system name and machine name. Double-click the file to be read to specify. When FXGP(DOS) or FXGP(WIN) data is read, a folder name is specified as the system name and a file name as a machine name. Also, specifying a file name from a root directory, the system name is left blank. For details, see Subsection 3.2.2.

2) Source data list
Displays data created by GPPQ, GPPA, FXGP(DOS), and FXGP(WIN). Check the checkbox of data names to be selected. The selected comments can be edited in the program common tab or the program tab.
3) **Param+prog** button/ **Select all** button
   - **Param+prog** button
     Selects only the parameter data and program data of a source.
   - **Select all** button
     Selects all data in a source data list.
     comment2 is selected as comments in A series, and the device memories of the same quantity as the number of data are displayed.
     The first data name is selected for comments and file registers in QnA series.

4) **Cancel all selections** button
   Cancels all the selected data.

5) **<<Common for programs>>** sheet (A series)
   Click **<<Common for programs>>** tab to set a range for common comments and read data.

   ![Diagram](image)

   For the setting method for each PLC series, refer to Chapter 9 "SETTING DEVICE COMMENTS".
6) «For each program>> sheet (A series)
Click «For each program>> tab to set a range for comments by program and read data.
(Except the FX series)

For the setting method for each PLC series, refer to Chapter 9 "SETTING DEVICE COMMENTS".

7) Merge peripheral Statement/Note
Refer to Section 10.2.

8) [Execute] button
Click this button after the setting is over.

[Setting Procedure]
• Data selection
  1. Set a drive/path for reading by GPPQ, GPPA, FX(DOS), or FX(WIN).
  2. Select a project name in the dialog box displayed by clicking the [Browse] button to designate a system name and machine name for the project to be read.
  3. Check the checkbox of data to be selected by using [Param+progl button, [Select all] button, or the mouse.
  4. Click the [Execute] button after making necessary settings.

• Canceling data selection
  (1) When canceling the selected data arbitrarily:
    • Clear the checkmark (✓) in the checkbox with the mouse or space key.
  (2) When canceling all the selected data:
    • Click the [Cancel all selection] button.
### Precautions for reading the other format files

<table>
<thead>
<tr>
<th>For A series</th>
<th>A6GPP, SW0S-GPPA format data</th>
<th>Read data with GX Developer after performing the corresponding format conversion with GPPA. For the operating methods, refer to Type SWC1SRXV/IVD-GPPA GPP Function Operating Manual (Details).</th>
</tr>
</thead>
<tbody>
<tr>
<td>For data selection</td>
<td>For device comment selection, you may only choose either comment 2 or comment 1.</td>
<td></td>
</tr>
<tr>
<td>For GX Developer format reading</td>
<td>Abandon the project data on GX Developer and read the other format file. The area in excess of the program capacity is deleted when read. For the PLC type which cannot use subprograms, subprograms are deleted when read.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>For QnA series</th>
<th>Ladder return positions</th>
<th>Returning places are different between GPPQ and GX Developer. Because of this, if the total of return sources and return destinations exceeds 24 lines in a single ladder block, the program is not displayed properly. Corrective action: Add SM400 (normally ON contact) to adjust the return positions.</th>
</tr>
</thead>
<tbody>
<tr>
<td>For data selection</td>
<td>For the device memory and file register, you may select only one data name for each item.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>For FX series</th>
<th>For data selection</th>
<th>Any item that does not exist in the source data is not displayed.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read range</td>
<td>For the A6GPP format, read the data after making conversion once with the FXGP(DOS) software. For the conversion method, refer to the SW1PC-FXGPEE/AT Software Operating Manual. The data will disappear if it includes microcomputer programs other than SFC programs.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>For FXGP(DOS) format</th>
<th>Files to be read</th>
<th>• Program file (.PMC) Parameter, program, comment, file register • Comment file (.COK) Comment • Device memory file Data register, file register, RAM file register, special register (.DMD, .DME, .DMF, .DMG)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Files not read</td>
<td>Circuit comment file (.COL), sampling trace file (.STA) Print title file (.PTL), comment file (.COH) Shared circuit file (.DAT)</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>For FXGP(WIN) format</th>
<th>Files to be read</th>
<th>• Program file (.PMW) Parameter, program, comment, file register • Comment file (.COW) Device comment, circuit comment, coil comment, Alias • Device memory file (.DMW) Data register, special register, RAM file register</th>
</tr>
</thead>
<tbody>
<tr>
<td>Files not read</td>
<td>Sampling trace file (.STW), print title file (.PTW) Registration monitor file (.RMW)</td>
<td></td>
</tr>
</tbody>
</table>

| Restrictions | • Device comment Up to 50 characters can be input for FXGP(WIN) device comments, but only the first 32 characters are read because the maximum number of character is 32 in GX Developer. • Statement Any number of characters can be input for FXGP(WIN) circuit comments, but only the first 64 characters are read because the maximum number of characters is 64 in GX Developer. • Note Any number of characters can be input for FXGP(WIN) coil comments, but only the first 32 characters are read because the maximum number of characters is 32 in GX Developer. |
4.15.2 Reading a MELSEC MEDOC format file (Printout)

[Purpose]
Reads the data output to a file with MELSEC MEDOC as print-out data.

[Operating Procedure]
[Project] → [Import file] → [Import from Melsec Medoc format file]

[Dialog Box]

[Description]
1) File name
The data output to a file with MELSEC MEDOC as print-out data will be read.
The MELSEC MEDOC data created with version Ver 2.3 or later will be read.

2) [OK] button
Click this button after the setting is over.

POINTS
- If print data created with the OS (MS-DOS) in other than English includes characters which cannot be handled by English Windows, reading the data to GX Developer may not show them correctly.
- The headers, parameters, programs and comments in the print-out data are read.
- The parameters read are only the memory capacity, latch range and timer/counter range (except the FX series).
- The instructions that cannot be converted are converted as abnormal instruction codes.
- When reading the MELSEC MEDOC data with GX Developer, always save it after adding the Printer Head (incompatible with the Small Header) on the MELSEC MEDOC side.

For the parameters, programs, etc., use the following table as reference.

<table>
<thead>
<tr>
<th>MELSEC MEDOC Print-out Data</th>
<th>Condition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Program</td>
<td>Any</td>
</tr>
<tr>
<td>Comment</td>
<td>Name (Name is to be printed out, Comment is not to be printed out) Any *1</td>
</tr>
<tr>
<td>Parameter</td>
<td>parameter          Any *1</td>
</tr>
<tr>
<td>Parameter</td>
<td>parameter          Any *1</td>
</tr>
</tbody>
</table>

Any *1: Only the print-out data for MAIN is valid.
Data existing in the print-out data for SUB is not read.

- Refer to Section 4.15.3.
4.15.3 Reading a MELSEC MEDOC format file

[Purpose]
Reads the data created with MELSEC MEDOC.

[Operating Procedure]
[Project] → [Import file] → [Import from Melsec Medoc format file]

[Dialog Box]

[Description]
1) File name
Choose the data created with MELSEC MEDOC.

2) OK button
Click this button after the setting is over.

POINTS
- If you want to read subprogram data but the subprogram memory capacity has not been set on the project side, an error occurs and the data is not read.
  Preset the memory capacity in the PLC parameter.
- Unconvertible instructions are converted as instruction code faults.
- The definition of a conversion error is displayed in the dialog box and can be saved in the file.
  The place where it will be saved is the drive/path where the data to be read is saved.
- Data having many statements cannot be displayed properly.
  Refer to Section 10.1.
- The MEMORY CAPACITY (Total memory-Sequence Program) parameter whose setting is step 0 in the sequence program created with MEDOC (PLC type: FX2N) will not be read properly.
- If you read the parameter where the set value devices are specified for the normal counters/timers other than the extended counters/extended timers in the sequence program created with MEDOC (PLC type: ACPU), the set value device numbers are deleted on GX Developer.
- A line-to-line statement headed by ";" results in a conversion error. Change ";" to another character to enable read.
- The following ladder created with MEDOC will not be displayed.

```
  X
 / \
X-X
```

- When the MELSECNETII parameters have been set with MELSEC MEDOC, they will be written as MELSECNETII mixed parameters if they are written to the PLC CPU with the latter half setting screen merely opened and no settings made.
  If a MEDOC format file is read with GX Developer, it is read as a MELSECNETII parameter file since the later half has not been set.
  Verifying the PLC and GX Developer data in this status will result in a verify mismatch.
- When starting GX Developer with Windows® 98, do not start the following application at the same time.
  BarClock
- An error will occur if Swedish special characters are included in the ASC instruction of the MEDOC data.
- If lines of only line feed have been created in the program created with MEDOC, conversion to GX Developer data will erase those lines.
- A line-to-line statement headed by "@Export:" results in a conversion error.
4.16 Exporting GPPQ, GPPA, FXGP(DOS) or FXGP(WIN) Files

[Purpose]
Saves GX Developer data in a GPPQ, GPPA, FXGP(DOS) or FXGP(WIN) file so that it can be read and edited as a GPPQ, GPPA, FXGP(DOS), or FXGP(WIN) file.

[Operating Procedure]
Select [Project] ➔ [Export file] ➔ [Export to GPPQ format file] ➔ [Export to GPPA format file] ➔ [Export to FXGP(WIN) format file] ➔ [Export to FXGP(DOS) format file]

[Dialog Box]

[Description]
1) Drive/path, System name, Machine name
Designates a drive/path for writing a GPPQ, GPPA, FXGP(DOS), or FXGP(WIN) file.
Enter a system name and a machine name for data specified in the project path.
When data is written to an FXGP(DOS) or FXGP(WIN) file, a folder name must be designated as a system name and a program file name as a machine name. See Section 3.2 for details on operating methods.

Characters that can be set for data name setting
For A series
You must not use any characters other than alphanumeric characters and -(hyphen).
The first character should be "alphabetic" (a numeral will result in an error).
For QnA/FX series

Alphanumeric characters, __, ^, $, –, (tilde), !, #, &, (apostrophe), (single quotation)

Unusable characters

An error will occur in presence of any of:
" = | : ; , ¥ [ ] + * ? < > . / (space)

2) Source data list

Selects data to be written to a GPPQ, GPPA, FXGP(DOS) or FXGP(WIN) file.
Check a checkbox of the data name to be selected.

3) [Param+Prog] button/ [Select all] button

- [Param+Prog] button
  Selects only the source parameter data and program data.
- [Select all selection] button
  Selects all the listed source data.

4) [Cancel all selection] button

Cancels all the selected data.

5) <<Common>> sheet (A series)

Click <<Common>> tab to set a range for common comments and write data.

For the setting method for each PLC series, refer to Chapter 9 "SETTING DEVICE COMMENTS".
6) **<<Local>> sheet (A series)**
   
   Click **<<Local>>** tab to set a range for comments by program and write data. (Except the FX series)

   ![Diagram of <<Local>> sheet]

   For the setting method for each PLC series, refer to Chapter 9 "SETTING DEVICE COMMENTS".

7) **[Execute] button**
   
   Click this button after making necessary settings.

[Operating Procedure]

- **Data selection**
  
  1. Designate a drive/path for the project to be written.
  
  2. Select a project name in the dialog box displayed by clicking the **[Browse]** button to designate a system name and machine name for the project to be written.
  
  3. Check the checkbox of data to be selected by using **Param+Prog** button, **[Select all selection]** button, or the mouse.
  
  4. When setting a range for comments to be written, set the details of the comment range. (See Chapter 9 for details on setting methods.)
  
  5. Click the **[Execute]** button after making necessary settings.

- **Canceling data selection**
  
  (1) Canceling the selected data arbitrarily

      - Clear the checkmark ✓ in the checkbox with the mouse or space key.

  (2) Canceling all the selected data

      - Click the **[Clear all selection]** button.
Precautions for writing the other format files

<table>
<thead>
<tr>
<th>For A series, QnA series</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Program name</strong></td>
</tr>
<tr>
<td><strong>Statement, note</strong></td>
</tr>
<tr>
<td><strong>Writing method</strong></td>
</tr>
</tbody>
</table>

For FX series

<table>
<thead>
<tr>
<th>For data selection</th>
<th>For FXGP(DOS) and FXGP(WIN), the following items to be written are displayed, respectively. Note that any item that does not exist in the source data is not displayed.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Write range</strong></td>
<td>For reading the A6GPP format data, read the data with GX Developer after making conversion once with the FXGP(DOS) software. For the conversion method, refer to the SW1PC-FXGPEE/AT Software Operating Manual. For reading the other format file, the file will disappear if it includes microcomputer programs other than SFC programs.</td>
</tr>
</tbody>
</table>

**For FXGP(DOS) format**

| Files to be written | • Program file (.PMC)  
Parameter, program, comment, file register  
• Comment file (.COK)  
Comment  
• Device memory file  
Data register, file register, RAM file register, special register (.DMD, DME, .DMF, .DMG) |
|--------------------|--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| Files not written  | Circuit comment file (.COL), sampling trace file (.STA)  
Print title file (.PTL), comment file (.COH)  
Shared circuit file (.DAT) |
| **Restrictions**   | • Device comment  
Up to 32 characters can be input for GX Developer device comments, but only the first 16 characters are written because the maximum number of character is 16 in FXGP(DOS).  
• Comment  
The maximum number of comments is 3400.  
• P, I statement  
P, I statement is not written. |

**For FXGP(WIN) format**

| Files to be written | • Program file (.PMW)  
Parameter, program, comment, file register  
• Comment file (.COW)  
Device comment, circuit comment, coil comment, Alias  
• Device memory file (.DMW)  
Data register, special register, RAM file register |
|--------------------|--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| Files not written  | Sampling trace file (.STW), print title file (.PTW)  
Registration monitor file (.RMW) |
| **Restrictions**   | • Alias  
A GX Developer Alias can be input in up to 8 characters, but only the alphanumeric characters and symbols (/ + - * / = . ? # % & : _) can be used in FXGP(WIN) (see Section 9.4.1). The Alias containing characters not written is deleted when writing the data.  
• P, I statement  
P, I statement is not written. |
4.17 Starting Multiple Projects

[Purpose]
Starts and reads multiple projects so that data can be edited (cut, copied and pasted) among the projects.

[Operating Procedure]
Select [Project] → [Start new GPPW session].

[Description]
Once the window is displayed, open the projects and edit data.

4.18 Existing GPPW

[Purpose]
Exits GPPW.

[Operating Procedure]
Select [Project] → [End GPPW] or click X.

[Description]
When no project name has been designated, clicking [End GPPW] causes a dialog box to be displayed for project name confirmation. Click the Yes button to save the changes to the project. For details on designating the project path and project name, see Section 3.2. Click the No button not to save the changes to the project.

POINTS

• When exiting GPPW by clicking X, click the button shown below.

• When closing only the open data without exiting GPPW, click X on the menu bar.
5. STANDARDIZING THE PROGRAMS

Programs can be standardized by using label programming or macros to create sequence programs. The creation and monitoring operations of ladders are identical to those of actual programs.

5.1 Label Programming

Label programming increases design efficiency.
- As creating a general program by label programming permits device assignment changes according to equipment makeup, it can be easily diverted to other programs.
- If you do not know equipment makeup, labels can be used for programming.
- When the equipment makeup has been determined, relating the labels and actual devices enables generation of an actual program easily.
- By merely specifying the label assignment method, you can make device assignment automatically by performing only compile operation, without being conscious of the device names/device numbers.
- The program can be monitored/debugged, without the label names being changed, ensuring efficient debugging.

Note that there are some restrictions on batch device monitoring and online program correction. For details, refer to the "instructions/restrictions on label programs" in this section.
Label creating procedure
The sample label programs (SAMPLE1, SAMPLE2) used in the following explanation are contained on the CD-ROM of this product. After installation of GX Developer, choose [Project] → [Open Project] to open the corresponding sample program. New label creating procedure (The program used is SAMPLE1.)
1. List up the I/O equipment. Temporarily determine the label names of the I/O equipment.

2. Set local variables.
Make setting to automatically assign constants or internal relays, data registers, etc. to the labels used in only the program created in above step 2. To make automatic assignment, leave the constant fields blank.

3. Set global variables.
(a) Set devices or constants to the labels of the I/O equipment or the labels used in multiple programs.

(b) Register the programs where the labels will be used. (Auto External) Also, to reflect the global variables on the local variables, click “○” under Au.
(c) The following screen gives an example of global variable setting reflected on the local variable setting screen.

4. Start programming.
   Start programming using the label names (such as I/O equipment and internal relays).

5. Compile.
   The actual program is generated.
   The number of steps in the actual program can be checked by selecting [View] → [Device program display mode].
   The screen below gives an example of circuit display. (See 5.1.10.)

You can write the generated actual program to the PLC to run the program.
The program can be debugged in the label programming description format (device names are displayed as labels).
Existing label program diverting procedure (The program used is SAMPLE2.) SAMPLE 2 is the program created by making the following modifications to SAMPLE1.

1. The device number of the I/O equipment was changed.
   PB1 was changed from X1 to X10.

2. The label of the I/O equipment was added.
   Operation ready

3. The constant was changed.
   The set value was changed from K1000 to K3000.

1. Open the existing label program project.
2. Add the label name in label programming.

3. Change the global variable setting.
   (a) After changing the device number assigned to the label of the I/O equipment, make registration again. Set the device and device type of the added label.

4. Change the local variable setting.
   Change K1000 of the set value to K3000.

5. Compile.
   After compilation, you can check the actual step counts of the program by clicking [View] → [Device program display mode] (See Section 5.1.10)
The following terms will be used in label programming.

<table>
<thead>
<tr>
<th>Project List</th>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual program</td>
<td>Program that can be executed by the PLC CPU. Compiled program when it is created by label programming.</td>
<td></td>
</tr>
<tr>
<td>Actual device</td>
<td>The term “actual device” is used in this manual to differentiate a program created under a label name and one that has been compiled. (A compiled program to which device has been assigned.)</td>
<td></td>
</tr>
<tr>
<td>Global variable</td>
<td>Label variable which is made valid for all label programs when multiple label programs were created in a project.</td>
<td></td>
</tr>
<tr>
<td>Local variable</td>
<td>Label variable which is made valid for only within individual programs. Set this variable one for one to each label program.</td>
<td></td>
</tr>
<tr>
<td>Label program</td>
<td>Sequence program where devices are described as labels.</td>
<td></td>
</tr>
<tr>
<td>Global label</td>
<td>Generic term for labels assigned in global variable setting.</td>
<td></td>
</tr>
<tr>
<td>Local label</td>
<td>Generic term for labels assigned in local variable setting.</td>
<td></td>
</tr>
<tr>
<td>Automatic device setting</td>
<td>Sets the D, W, ZR, M, B, T, ST, C and P device setting ranges. Set the automatically assigned device ranges on the auto device setting screen.</td>
<td></td>
</tr>
<tr>
<td>Compile</td>
<td>Operation which converts a label program into an actual program.</td>
<td></td>
</tr>
<tr>
<td>External variable</td>
<td>Variable where the label variable set on the global variable setting screen has been reflected on (registered to) the local label variable.</td>
<td></td>
</tr>
</tbody>
</table>

**Instructions/restrictions on label programs**

1. Label programming is compatible with ladders and lists but not with SFC and MELSAP-L.
2. Device comments displayed are those set on the global/local variable setting screen. Comments created on the device comment batch-edit screen are not displayed. You can set a comment of up to 64 characters but the number of characters that may be displayed is up to 32.
3. If the same label has been set to global and local variables, local variables have higher priority than global variables when they are displayed on the edit screen.
4. To modify a program that has been written to the PLC CPU, first modify its label program stored in the personal computer and then write it to the PLC. ([Read from PLC] cannot be used for label programming projects.)
5. Devices specified by label can be monitored via registration monitor. Devices cannot be monitored in batch.
6. Restrictions when performing a write during RUN
   (1) Edit within a range where global/local variables are set.
   (2) Write during RUN cannot be performed if the program/parameters in the personal computer do not match those in the PLC CPU. When compiling was executed, be sure to write the compiled result to the PLC.
5.1.1 Label programming sequence

The following flowchart shows a label programming procedure.

Start

Start GX Developer.  
......Refer to Section 4.1.

Choose [New project].  
......Refer to Section 4.1.

Specify "QCPU (Q mode)" or "QnACPU" as the PLC series.  
......Refer to Section 4.1.

Specify the PLC type.  
......Refer to Section 4.1.

Specify the "ladder or "label program" as the program type.  
......Refer to Section 4.1.

Free setting...  
Make automatic device setting.  
......Refer to Section 5.1.3.

Free setting...  
Make global variable setting.  
......Refer to Section 5.1.3.

Make local variable setting.  
......Refer to Section 5.1.3.

Create a label program.  
......Refer to Section 5.1.2.

Compile the label program.  
......Refer to Section 5.1.9.

Perform write to PLC.  
......Refer to Section 16.3.

End
5.1.2 Label program input method

Label programs can be created in the ladder/list mode. (Not in SFC mode)
The programming operation is identical to that in the ladder/list mode.
For details of the operation, refer to Section 6.2.
This section explains how to perform operation specific to label programming.

[Label input method example]
1. When entering a contact

2. When entering application instructions

[Operating Procedure]
There are terms (reserved words) which cannot be used as labels.
Refer to Appendix 15.
When entering a device name, do not include an apostrophe (‘).
[Number of steps in label program]

- The number of steps in the label program is indicated in parentheses ( ). When the label program is compiled, the number of steps in the actual program is displayed. (The screens below show that the number of steps has changed from 0 before compiling to 78 after compiling.) Basically, the number of steps increases after compiling. When writing a program to the PLC CPU, perform compiling and check the number of steps.

Label program (before compiling)

![Label program (before compiling)](image)

Number of steps before compiling

Label program (after compiling)

![Label program (after compiling)](image)

Number of steps after compiling

MOV aaa aaa
MOV aaa D0
MOV D0 aaa

Any of these is in 3 steps.

When the device which increases in the number of steps, e.g. U0¥G0, (MOV U0¥G0 aaa) is used, the number of steps is 4.

- When the instruction is headed by S., e.g. S.FWRITE, the number of steps is as given in the programming manual.

The pointer, EGP and EGF instructions are in 1 step.

POINT

When a label program is created using label names and actual devices together, making automatic device assignment may generate double coils. In this case, make a program check after compiling. Also, the device use list and contact/coil use list can be used to check the devices used. These lists are useful for device checking.
5.1.3 Making global variable/local variable setting

[Purpose]
Sets labels, device types, comments and others in a label program.

[Operating Procedure]
Local variable setting: Select [Edit] → [Local variable setting],
Global variable setting: Select [Edit] → [Global variable setting].

[Dialog Box]

Local variable setting screen

Global variable setting screen

<table>
<thead>
<tr>
<th>Local/global variable setting item list</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto External</td>
</tr>
<tr>
<td>Au</td>
</tr>
<tr>
<td>Label</td>
</tr>
<tr>
<td>Device/constant value</td>
</tr>
<tr>
<td>Device type</td>
</tr>
<tr>
<td>Comment</td>
</tr>
<tr>
<td>Global variable setting</td>
</tr>
</tbody>
</table>

[Description]
1) Label
Create a label within 16 characters.
Reserved words and actual device names are characters unusable as labels.
reserved word or actual device name displays a "An unusable device has been designated" or "The reserved word is used for label" dialog box. Set another label name.
The number of label creation lines for local/global variable setting is 5120.
Refer to Appendix 15 for reserved words.
2) Device/constant value
   Local variable setting: Set a numerical value when setting a constant. Leave the field blank when making automatic device assignment. Refer to Section 5.1.3 for automatic device setting.
   Global variable setting: Set an actual device/initial value.
   • Enter a constant value headed by K, H, E or """ to ensure that it can be identified as a decimal, hexadecimal, actual number or character string constant.
   • Device registerable qualifications are "bit designation" and "digit designation". "Indirect designation" and "index qualification" are unusable.

3) Device type
   Set any of bit, word device, double word, actual number, character string, array, timer, counter, retentive timer and pointer.
   Choosing a character string or array displays the following dialog box.

   Max. number of characters: The input range is 1 to 50 characters.
   Number of elements: The input range is 1 to 255.

4) Comment
   Set a comment within 64 characters.
   When comment addition/correction is made to any of the multiple labels which are the same (including all local/global variables), the latest comment is reflected on the data registered to the local/global variable setting and on the data on the label program edit screen.

5) Auto External
   The data of the labels, set values, device types and comments set in global variable setting are reflected on all the local variables or the specified local variables.
6) Au
   For registration
   Choosing “○” of the variable you want to register on the global variable setting screen and clicking the Register button reflects the label, set value, device type and comment settings on the local variable setting screen.
   For cancellation
   Choosing “●” of the variable you want to cancel on the global variable setting screen displays the following dialog box to delete the settings from the local variable setting screen.
   <Screen example>

```
<Screen example>
```

7) Edit operation
   [Insert line] button
   Used to insert a blank row in the current cell position.
   When you want to batch-insert multiple rows, choose cells equal to the number of rows you want to insert.
   Blank rows are inserted into the cell-selected range.
   [Add line] button
   Used to add a blank row under the current cell position.
   When you want to batch-add multiple rows, choose cells equal to the number of rows you want to add.
   Blank rows are added to under the top cell of the range-selected cells.
   [Delete line] button
   Used to delete the cell-selected range.

8) Global variable label setting
   Used to display the global variable setting screen.

9) Automatically assigned device display/hide
   Used to check how actual devices have been assigned to labels which are displayed on the local variable setting screen.
   Perform compile when displaying automatically assigned devices.
10) [Register] button
Click the Register button after you have terminated setting the labels, constant values, device types and others.
If any of the labels, constant values and device types is not set correctly, the following dialog box will appear and they cannot be registered.

Choosing the Error detail and clicking the Jump button shows the error location.

**POINT**
On the global/local variable setting screen, the settings can be sorted in the label order, device/constant order, or device type order. The sequence of sorting is as indicated below.
1. Symbols
2. Alphabets (upper-case letter)
3. Alphabets (lower-case letter)
5.1.4 Making automatic device setting

[Purpose]
Sets the automatically assigned device ranges when you want to assign devices automatically to local labels.

[Operating Procedure]
Select [Edit] → [Auto device setting].

[Dialog Box]

[Description]
1. For bit and word devices, use the radio buttons to choose the devices to be assigned automatically.

2. The maximum value of each device displayed is the value set for <<Device>> which is shown by choosing [PLC parameter] → <<Device>> tab. When 0 points have been set to <<Device>>, it is masked to disable setting on the automatic device setting screen.
When you want to set ST (retentive timer) or the like, make setting in <<Device>>.

3. The maximum number of ZR (file register) points is 32K and that of P (pointer) points is 4K.
5.1.5 Deleting External

[Purpose]
Deletes all External variables on the active local variable setting screen.

[Operating Procedure]
Select [Edit] → [Delete Auto External]

[Dialog Box]

5.1.6 All deletion

[Purpose]
Deletes all variables on the active local/global variable setting screen.

[Operating Procedure]
Select [Edit] → [Delete all]

[Dialog Box]
5.1.7 Importing device comments

[Purpose]
Imports the comments created on the device comment batch-edit screen to the label comments of the currently edited global variable setting.

[Operating Procedure]
Select [Edit] → [Import the device comment]

[Dialog Box]

[Purpose]
• Device comments may be imported to the global variable setting only. They cannot be imported to the label comments of the local variable setting.
• The label comments are not rewritten if there are no device comments for the devices assigned in the global variable setting.
• When common comments (COMMENT) and program-based comments exist in the device comments, the common comments have higher priority in importing.
5.1.8 Exporting to device comments

[Purpose]
Exports the label comments of the currently edited local/global variable setting to
the device comment batch-edit screen.

[Operating Procedure]
Select [Edit] → [Export the device comment]

[Dialog Box]

[Purpose]
- If 33 or more characters are set to a label comment, the 33rd and latter
  characters are deleted when it is exported to the device comment batch-edit
  screen.
- The device comments are not rewritten if there are no label comments.
- When the label comments of the local variables are exported, the reflection
  destinations of the label comments set in the local variable setting are the "copy
  source/display source of reference during comment edit" which are displayed by
  selecting [Tools] → [options] → "<<Each program>> tab.
The global variables are reflected on the common comments (COMMENT).
5  STANDARDIZING THE PROGRAMS

Global device setting

<table>
<thead>
<tr>
<th>Device</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>X0</td>
<td>Code</td>
</tr>
<tr>
<td>X1</td>
<td>Code</td>
</tr>
<tr>
<td>X2</td>
<td>Code</td>
</tr>
<tr>
<td>X3</td>
<td>Code</td>
</tr>
<tr>
<td>X4</td>
<td>Code</td>
</tr>
</tbody>
</table>

Local device setting

<table>
<thead>
<tr>
<th>Device</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>X0</td>
<td>Code</td>
</tr>
<tr>
<td>X1</td>
<td>Code</td>
</tr>
<tr>
<td>X2</td>
<td>Code</td>
</tr>
<tr>
<td>X3</td>
<td>Code</td>
</tr>
<tr>
<td>X4</td>
<td>Code</td>
</tr>
</tbody>
</table>

Common comments (COMMENT)

<table>
<thead>
<tr>
<th>Device</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>X0</td>
<td>Code</td>
</tr>
<tr>
<td>X1</td>
<td>Code</td>
</tr>
<tr>
<td>X2</td>
<td>Code</td>
</tr>
<tr>
<td>X3</td>
<td>Code</td>
</tr>
<tr>
<td>X4</td>
<td>Code</td>
</tr>
</tbody>
</table>

Reflection destinations of comments are governed by these settings.

Program-based comments (MAIN)

<table>
<thead>
<tr>
<th>Device</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>X0</td>
<td>Code</td>
</tr>
<tr>
<td>X1</td>
<td>Code</td>
</tr>
<tr>
<td>X2</td>
<td>Code</td>
</tr>
<tr>
<td>X3</td>
<td>Code</td>
</tr>
<tr>
<td>X4</td>
<td>Code</td>
</tr>
</tbody>
</table>

Common comments (COMMENT)

<table>
<thead>
<tr>
<th>Device</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>X0</td>
<td>Code</td>
</tr>
<tr>
<td>X1</td>
<td>Code</td>
</tr>
<tr>
<td>X2</td>
<td>Code</td>
</tr>
<tr>
<td>X3</td>
<td>Code</td>
</tr>
<tr>
<td>X4</td>
<td>Code</td>
</tr>
</tbody>
</table>
5.1.9 Converting label programs into actual programs (Compile)

[Purpose]
Converts programs created as ladders or lists into actual programs.

[Operating Procedure]
Select [Convert] → [Compile]
Select [Convert] → [Compile (All programs being edited)]
Select [Convert] → [Compile (All programs)]
Select [Convert] → [Compile option]

[Description]
- Compile can be executed when the global variable setting screen/local variable setting screen/ladder edit screen/list edit screen is active.
- How to identify whether a program has been compiled or not:
The program not yet compiled is indicated by "."
- Compiling option
When the compiling option is enabled, compiling is performed simultaneously upon conversion.
Do not check this option if a label program (circuit/list) is created before setting global/local variables.
If this option is enabled, an undefined label error will occur.
If an error occurs after compile, the following dialog box appears.

If errors have occurred over multiple programs, “Compile error (All program)” appears.
When there is only one error program, “Compile error (Detail)” appears.

**POINT**

Compile processing time
Compile is completed in about 5 seconds when 1000 lines of labels are compiled on a personal computer (Digital CELEBRIS GL 5133ST Pentium® 133MHz, memory 80M).
When 5000 lines are compiled, compile is completed in about 2 minutes 13 seconds.
5.1.10 Displaying the Device Program

[Purpose]
This setting is used when, after compiling, you wish to check the actual device
assigned to the label.

[Operating Procedure]
1. After compiling, select [View] → [Display device program].
2. Select [View] → [Device program display mode] → [Below] ([Right]).

[Setting Screen]
When splitting the circuit display to horizontally

![Circuit display horizontally split](image)

Label programming side  Actual device side

When splitting the list display vertically

![List display vertically split](image)

Label programming side  Actual device side

[Explanation of Items]
- When editing a program, do so on the label program side. Data cannot be edited on the actual device side.
- The label program panel and the actual device panel scroll separately.
- To synchronize the steps in the displayed program, select [View] → [Display step synchronization]. The panel without cursor scrolls in tandem with the panel with the cursor.
- When Display statement/note/comment is selected, the setting will be reflected in the label program side and the actual device side.
- The display positions of the label program panel and the actual device panel cannot be changed.
- Label program/actual device split display is available in the circuit/list mode and device registration monitor.

[Note]
If the number of characters in the label name differs from that in the device name, the loopback point will vary and the two sides of the circuit display may not become identical. Caution is necessary.
5.2 About Macros

By naming any ladder pattern (macro name) and registering it in a file (macro registration), you can read the registered ladder pattern, and change and utilize the devices (macro utilization) in actual programming.

1. Choose the program area to be registered as a macro.
2. Set the devices and so on to be registered.
3. Set the file name of the macro to be registered.

1. Specify the file name registered as a macro.
2. Set the devices to be changed.
Macro reference destination setting (Except the FX series)

If you have set a macro-registered file in macro reference destination setting, you can utilize the macro by entering a simple macro instruction.

![Diagram of macro reference setting]

Choose [View] → [Macro instruction format display] in the read mode allows the developed macro instruction to be represented in the M.Macro VD0 VD1 VD2... instruction format.

Any macro name may be set. (The macro instruction format display is compatible with the macros created with GX Developer (SW3D5-GPPW-E) or later.)

Note the following to provide the macro instruction format display properly.

1. Do not make corrections, deletions or the like to macro programs which utilize macros.
2. When a macro-utilized ladder is displayed with statements, do not utilize macros within MACROEND.
3. Do not change the utilized devices which have been specified as VDs. (The device numbers remain as utilized at first.)

POINTS

Choosing [View] → [Macro instruction format display] in the read mode allows the developed macro instruction to be represented in the M.Macro VD0 VD1 VD2... instruction format.

Any macro name may be set. (The macro instruction format display is compatible with the macros created with GX Developer (SW3D5-GPPW-E) or later.)

Note the following to provide the macro instruction format display properly.

1. Do not make corrections, deletions or the like to macro programs which utilize macros.
2. When a macro-utilized ladder is displayed with statements, do not utilize macros within MACROEND.
3. Do not change the utilized devices which have been specified as VDs. (The device numbers remain as utilized at first.)
5.2.1 Registering a macro

[Purpose]
Registers part of a program to a file as a macro instruction. The registered macro instruction can be used as an application instruction in a program.

[Operating Procedure]
[Project] → [Macro] → [Registration macros]

[Dialog Box]

1) Macro save
   Among the devices in the area-specified ladder block, specify the devices you want to change for macro utilization as variable devices VD0 to VD9. The following example shows the devices registered.
   
   If the devices have been commented, the comments are automatically set. Also, comments may be edited. (Setting can be made independently of the number of comment characters in the option.)

2) Option
   Set whether or not comments and statements will be registered together with the ladder for macro registration.
3) **Macro name**  
Set the drive/path and where the macro will be registered and the macro file name.  
The number of characters set to the title is within 32.

4) **Macro name displays area**  
The existing macro name appears.

5) **[Execute] button**  
Click this button after the setting is over.

The following devices may be registered to macros.

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Example</th>
<th>Device Registerability</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bit device</td>
<td></td>
<td></td>
</tr>
<tr>
<td>—</td>
<td>M0</td>
<td>○</td>
</tr>
<tr>
<td>Digit designation</td>
<td>K4M0</td>
<td>○</td>
</tr>
<tr>
<td>Word device</td>
<td></td>
<td></td>
</tr>
<tr>
<td>—</td>
<td>D0Z0</td>
<td>○</td>
</tr>
<tr>
<td>Indirect designation</td>
<td>@D0Z0</td>
<td>○</td>
</tr>
<tr>
<td>Bit designation</td>
<td>D0.1</td>
<td>○</td>
</tr>
<tr>
<td>Extended designation (J, U, BL)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bit</td>
<td>J1\B1Z0</td>
<td>○ (J1B1 also possible) (J1) not possible for unit No. only. (B1Z0, B1) not possible for device only.</td>
</tr>
<tr>
<td>Digit designation</td>
<td>J1\K1B1Z0</td>
<td>○ (J1K1B1 also possible) (J1) not possible for unit No. only. (K1B1Z0, K1B1) not possible for device only.</td>
</tr>
<tr>
<td>Word</td>
<td>J1\W0Z0</td>
<td>○ (J1W0 also possible) (J1) not possible for unit No. only. (W0Z0, W0) not possible for device only.</td>
</tr>
<tr>
<td>Indirect designation</td>
<td>@J1Z1\W0Z0</td>
<td>○ (J1, J1Z1) not possible for unit No. only. (W0Z0, W0) not possible for device only.</td>
</tr>
<tr>
<td>Bit designation</td>
<td>J1\W1.1</td>
<td>○ (J1) not possible for unit No. only. (W1.1) not possible for device only.</td>
</tr>
<tr>
<td>Designation with digit</td>
<td>K4M0, J1\K1B1Z0</td>
<td>(K4) not possible for designation with digit only.</td>
</tr>
<tr>
<td>Index qualification</td>
<td>D0Z0, J1\K1B1Z0</td>
<td>(Z0) not possible for index qualification only.</td>
</tr>
<tr>
<td>Constant</td>
<td>Integer/real number</td>
<td>K10, H10, E0.1</td>
</tr>
<tr>
<td>Character string</td>
<td>&quot;Abcd&quot;</td>
<td>×</td>
</tr>
<tr>
<td>Index</td>
<td>Z0</td>
<td>○</td>
</tr>
<tr>
<td>Pointer</td>
<td>P, I</td>
<td>○</td>
</tr>
<tr>
<td>Alias</td>
<td>○ Also possible for other than display/ Alias display.</td>
<td></td>
</tr>
</tbody>
</table>
5.2.2 Utilizing a macro

Macros that may be utilized are only those of the same series as the PLC series at the utilization destination. (Macros cannot be set if the PLC series is the same but the PLC type is different.) However, macros can be utilized between the A series and MOTION(SCPU).

[Purpose]
Reads the macro-registered ladder block from the file, changes the devices registered, and utilizes the macro in any position of a ladder.

[Operating Procedure]
[Project] → [Macro] → [Macro utilize]

[Dialog Box]

[Description]
1) Macro name
Specify the drive/path where the macro is registered.
The macro name can be specified from the Macro name displays area.

2) Macro name displays area
The macro file names registered appears.
Specify the macro name you want to utilize.
3) Utilize macro setting
   The devices specified as VD0 to VD9 for macro registration are changed to the
devices specified here. (Only the variable devices specified for macro
registration may be set.)

   The devices specified as VD0 to VD9 should be those equivalent to the devices
specified for macro registration.
   You cannot specify a bit device as a word device and vice versa.

   Specifying the first I/O number biases the X, Y and U device numbers by the
specified number.
   <Example>
   When the first I/O number specified is U[1F], the X and Y devices are biased by
   +1F0 and the U devices by +1F.

4) Statement(Macro information) type when utilize macro
   Select whether macro development will be made with Embedded/Separate Line
statement or without statements.
   If you have also registered statements during macro registration, development
will be made under the registered conditions independently of this setting.

5) [Execute] button
   Click this button after the setting is over.
   The macro-utilized ladder is inserted in a place before the ladder block at the
cursor position.

### POINTS

- A macro is utilized unchanged if it includes the instructions/devices that
cannot be used in the utilization destination project or the devices that are
outside the range.
  In that case, make a program check and correct the program.
- Macros created with GX Developer can be utilized. (QnA series only)
- The device names assigned to VD during macro utilization are added after
the statements. (For Embedded statement, the number of statement steps
increases.)
- If you have set "Save with device comments" during macro registration, the
  comment attached to the VD are utilized as comments.
  If the device comments used with the VD already exist in the existing
  program, they are overwritten by the comment of the VD.
- When utilizing macros after MACROEND, utilize them in the list mode.
5.2.3 Deleting a macro

[Purpose]
Deletes the user-created macro file.

[Operating Procedure]
[Project] → [Macro] → [Delete macros]

[Dialog Box]

[Description]
1) Directory name displays
   Specify the directory of the macro file to be deleted.
2) Macro file delete selection
   Choose the object of deletion from the sequence program, SFC (ACT) and SFC (TRN), and specify the macro file name to be deleted.

<table>
<thead>
<tr>
<th>Deletion Destination Folder</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sequence MAC</td>
<td>For sequence program</td>
</tr>
<tr>
<td>SFC (ACT) MAC. ACT</td>
<td>For SFC (operation output)</td>
</tr>
<tr>
<td>SFC (TRN) MAC. TRN</td>
<td>For SFC (transition condition)</td>
</tr>
</tbody>
</table>

3) Execute button
   Click this button after the setting is over.
5.2.4 Displaying macro references

[Purpose]
Enables GX Developer to use the macro data created by GPPQ.
For A series or FX series, this function cannot be used.

[Operating Procedure]
Select [Project] → [Macro] → [Macro reference path].

[Dialog Box]

1) Folder name list
Displays the macro names of a project designated in the Drive/path.

2) Macro file name list
Displays the macro files that can be referenced when the current drive/path is set for macro reference.

3) Drive/Path
Designates a drive/path for the macro to be referenced. (The machine name folder created by GPPQ must be designated here.)
Even though the folder name list contains the entries MAC, MAC.ACT and MAC.TRN, they cannot be designated because there is no macro file in them.
4) **Register** button
   Click this button to register macros in Macro reference path.
   The macros cannot be used unless they are registered in this field.

5) **Macro reference path**
   Up to five macro names with different drives/paths can be registered in this field.
   A maximum of 242 characters can be used to designate a drive/path. The number of characters of a drive/path listed in this reference field is 94 characters in large fonts and 103 characters in small fonts. Even when a macro name consists of more characters, it can be used though it cannot be displayed in this field.

6) **Cancel the registration** button
   Cancels the drive/paths displayed in Macro reference one by one.

7) **Cancel all registration** button
   Cancels all the drives/paths displayed in Macro reference at a time.

8) **Close** button
   Click this button after making necessary settings.
Once a macro reference is registered, its settings are not cleared even when GX Developer is terminated.

About macro instruction input

Normal macro

M.   *** MACRO:MAC

Variable device setting

VD0  VD1

Macro name

Enter  F4

D0.1
D1.1

(Ctrl + F7) (Statement display)

[MACRO:MAC]
VD0( ) M0
VD1( ) M1
VD2( ) Y70

Number of VDs

The device names assigned to the VD during macro utilization are added after the statements.
(For Embedded statement, the number of statement steps increases.)

First I/O number designation (Not possible for A series)

U.   *** UX

Max. 8 characters

Max. 10 variable devices (MAX:VD9)

First input I/O number (MAX:1FF)
6. CREATING CIRCUIT

POINTS

- When creating comments, statements, notes, and Alias for creating circuits, refer to the following table.
- Refer to Section 6.4 for finding and replacement.

<table>
<thead>
<tr>
<th></th>
<th>To edit</th>
<th>To display on edit window</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comment</td>
<td>Refer to Section 9.4.</td>
<td>Refer to Section 3.8.</td>
</tr>
<tr>
<td>Statement</td>
<td>Refer to Subsection 10.3.1 (1).</td>
<td>Refer to Section 3.9.</td>
</tr>
<tr>
<td>Note</td>
<td>Refer to Section 10.4.1.</td>
<td>Refer to Section 3.10.</td>
</tr>
<tr>
<td>Alias</td>
<td>Refer to Section 9.4.</td>
<td>Refer to Section 3.11.</td>
</tr>
</tbody>
</table>

(1) Circuit creation method
- Input instruction list representations (mnemonic language) with the keyboard.
- Use tool buttons on the tool bar.
- Use function keys.
- Use the tool bar menu.

Once the above operation is started, the following circuit input dialog box is displayed.

Click in the continuous input section so that the circuits or contacts can be input continuously without closing the circuit input dialog box.
(This function will not apply to MEDOC style.)
(2) Switching circuit and list modes (This operation also covers the SFC operation outputs and transition conditions.)
Used to switch the display modes of the edit window.
(a) When switching from circuit edit window to list edit window:
Select [View] → [Instruction list] or click \( \text{Alt} + \text{F1} \) to set the list mode.
(b) When switching from list edit window to circuit edit window:
Select [View] → [Ladder], or click \( \text{Alt} + \text{F1} \) to set the circuit mode.

(3) Switching read and write modes
(a) Read mode (to read a circuit)
Select [Edit] → [Read mode] or click \( \text{Shift} + \text{F2} \).
If a device to be read, step No., or instruction is designated directly with the keyboard in read mode, a desired part of the circuit can be read.

(b) Write mode (to edit a circuit)
Select [Edit] → [Write mode] or click \( \text{F2} \).
In write mode, sequence circuits can be edited (i.e., circuit creation or search and replacement can be performed.)
(4) Switching insert and write modes (Use Insert key to switch the mode.)

(a) Insert mode (Cursor: purple)
Used to insert contacts and application instructions into the existing circuits

1. Move the cursor to the following position.

2. Enter "MOV K1 DO" with the keyboard, and the circuit input dialog box will be displayed. The entered data is written to the device instruction text box.

3. Press Enter key and click OK button to make input in the edit window.

4. Press F4 key and click button for inputing.

(b) Overwrite mode (Cursor: blue)
Used to overwrite contacts and application instructions to the existing circuits

1. Move the cursor to the following position.

2. Enter "MOV K1 DO" with the keyboard, and the circuit input dialog box will be displayed. The entered data is written to the device instruction text box.

3. Press Enter key and click OK button to make input in the edit window.
(5) Instruction help

(1) If you do not know instructions and others at the time of ladder creation, you can enter instructions without looking at the programming manual. Instruction help of GX Developer has the following features.

1. You can choose and enter the intended instructions if you do not know them.
2. You can enter instructions if you do not know instruction names/descriptive expressions.
3. You can enter instructions if you do not know devices usable with the corresponding instructions.

(2) The following is the operating procedure for Instruction help.

Choose Instruction selection. Choose Instruction selection.

Enter character you want to search for.

Click Details.

Turn on to convert instruction into pulse.

After entering device, click [OK] button.

Click [OK] button.
(3) Restrictions on use of Instruction help
The A series dedicated instructions will be explained using the entry of the
PRN instruction as an example.

1. Entering method
When entering a dedicated instruction, repeat the procedure in "(2) The
following is the operating procedure for Instruction help," instruction by
instruction.

LEDA/LEDB PRN
SUB H80
SUB K6
LEDC D20
LEDC M0
LEDR

2. About the Detail instruction help screen
The Explanation field shows the explanation of LEDC instruction +
device entry.
CREATING CIRCUIT

Points

Tool buttons:
- Tool buttons vary from model to model in the CPU series.
- The key assignment can be changed by customizing the keys. Refer to Section 15.9 for details.

Function keys:
- How to read function key symbols shown on the tool buttons is shown below.

Inputting for low speed timers, high speed timers, integrating timers, and edge relays
- For Q/QnA series, input as follows.

Low speed timer

High speed timer

High-speed integrating timer

Edge relay

Read/write modes
- In the read mode, the sequence circuit cannot be edited.
- In the write mode, searching by direct inputting cannot be performed.
- The circuit input dialog box can also be displayed by double-clicking the cursor.
- The contact or application instruction can be changed by pressing function keys \((F5, F6, F7, F8)\).
  (If the key assignment is customized to MEDOC style, it is not possible to change the contact or application instruction by these function keys.)
- In the write mode, with the Ctrl key + arrow keys, the cursor position can be moved with the input dialog box opened.

Ladder/list modes:
- For switching from circuit edit window to list edit window
  Position the cursor at any contact on the circuit edit window and switch the screen. The circuit block where the cursor is positioned will be displayed at the top of the list edit window.
- For switching from list edit window to circuit edit window
  Position the cursor at any list on the list edit window and switch the screen. The circuit block where the cursor is positioned will be displayed at the top of the circuit edit window.
6.1 Restrictions on Circuit Creation

This section describes the restrictions of the circuit display window and circuit edit window.

6.1.1 Restrictions in circuit display window

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

1. The maximum number of lines on one screen is 12. (at 800 x 600 pixels, 50% reduced screen)

2. A created circuit block must be less than 24 lines. Excess lines cause an error.

3. A circuit line can consist of 11 contacts plus 1 coil.

4. The following table lists the number of comment characters.

<table>
<thead>
<tr>
<th></th>
<th>No. of Input Characters</th>
<th>No. of Characters Displayed in Circuit Window</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device comment</td>
<td>32 characters</td>
<td>All characters (8 characters x 4 lines) are displayed.</td>
</tr>
<tr>
<td>Statement</td>
<td>64 characters</td>
<td></td>
</tr>
<tr>
<td>Note</td>
<td>32 characters</td>
<td>All specified characters are displayed.</td>
</tr>
<tr>
<td>Alias</td>
<td>8 characters</td>
<td></td>
</tr>
</tbody>
</table>

*1: The number of device comment edit characters can be set to 16 characters or 32 characters. (see Section 15.11 for details.)

Note that only 16 characters can be used for writing data to PLC/GPPA files. Note that only 16 characters can be used for writing data to FXGP(DOS) files.
6.1.2 Restrictions in circuit edit window

1. The maximum number of edit lines per circuit block is 24.

2. The maximum number of edit lines (24 lines/circuit block) is 48.

3. Data up to 48 lines can be cut.
   The maximum block size is 124k steps.

4. Data up to 48 lines can be copied.
   The maximum block unit is 124k steps.

5. Data cannot be cut, copied and pasted in read mode.

6. Master control (MC) can not be edited and displayed.
   The MC symbol appears in the read or monitor mode.
   (It does not appear in the write mode.)

7. When a series circuit with 12 contacts or more is created on one line, excess contacts are automatically wrapped and continued to the next line.
   Symbols K0 to K99 are used for wrapping and the same number is used for OUT(→) and IN(>→).

8. No circuits can be inserted between the lines OUT(→) and IN(>→).

9. When the circuit write function is used, wrapping symbols are assigned sequence numbers even when they are not within the same circuit block.
   However, the circuit blocks read by the read function are assigned sequence wrapping numbers beginning with 0 during display.

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>☐</td>
<td>☐</td>
<td>☐</td>
</tr>
</tbody>
</table>
10. When an overwrite contact or coil extends over multiple contacts, the circuit cannot be edited in write (overwrite) mode.

<Example>

![Diagram of an instruction containing "[]= D0 D1 " (multiple contacts) cannot be overwritten at this position.]

When the above change is made, "[]= D0 D1 " must be input in write mode (insert mode), then "LD X0" must be deleted with the Delete key.

11. When wrapping occurs for contact insertion to the first line of the circuit, the contact cannot be inserted.

<Example>

![Diagram of neither contact nor column can be inserted in the first line of the circuit. Insertion is possible only when the second line and the after is free and no wrapping does not occur for insertion.]

12. Line insertion processing is not possible if the insertion position is within an instruction.

<Example>

![Diagram of if the cursor is at (1), line insertion position is line 2 which is the middle of the instruction. Accordingly, line insertion cannot be executed.]

13. Since circuit symbol insertion is processed by the combination of rite flush and line insertion processing, insertion may be impossible depending on the circuit configuration.

<Example>

![Diagram of if a circuit symbol is going to be inserted with the cursor at position (1), "The edit position is incorrect" occurs disabling circuit symbol insertion under the following conditions.
- No space between (1) and (2)
- Insertion at line (3)

Note: Position (2) is the closest position to the cursor position among the branch symbols and the coil-equivalent instructione.
14. When inserting vertical lines in write (overwrite) mode according to specified number of lines/connecting lines, input the column in the second line and after with [Ctrl] + [Insert] keys, then insert the contact or column to the left of X0.

15. When a vertical line extends over a circuit symbol in writing the line in write (overwrite mode) according to the specified number of lines/connecting lines, writing takes place skipping the circuit symbol.

<Example>

```
< D0 D1 >

A vertical line skips a circuit symbol.
```

In the circuit edit stage, a vertical line is written skipping the circuit symbol, but such a circuit cannot be converted. Make changes to prevent the vertical line from intersecting the circuit symbol, then perform circuit conversion.

16. When a circuit block consists of 2 lines or more and an instruction cannot be input in one line, the instruction must be wrapped as shown below for instruction input.

(Example) Input of ECALL abcdefg hP0 ZR12345Z1 ZR12345Z1 ZR12345Z1 ZR12345Z1 ZR12345Z1

```
<When no circuit can be created>
The instruction shown in the above example cannot be created in 1).
```

17. The instruction and device that can be input in the first line are shown below (for QnA series selection).

<Example>
U0\G12.1 → Use lines for one contact.
U0\G123.1 → Use lines for two contacts.

18. Create the steps of a single ladder block within approx. 4K steps.
NOP instructions in the ladder block are also included in the number of steps. This does not apply to the NOP instruction existing between ladder blocks.
19. The representations of FX series step ladder instructions and cautions on programming

- Conventional representations in FXGP(DOS) and FXGP(WIN)

```
Y000
SET M0
{MOV K3 D0}
M5
M6
M7
X000
SET S20
RET
```

- Representations in GX Developer and cautions on programming

```
STL S0
```

```
Y000
Y001
SET M0
{MOV K3 D0}
M5
M6
M7
X000
SET S20
RET
```

Though the FX series programming material gives descriptions using the above conventional representations, they must be given in a GPPW-specific style when the step ladder instructions are input by GX Developer.

*1: When the programming is made to create the zoom circuit for SFC program, STL/RET instruction need not to be input.

*2: Do not enter the contact to the coil instruction subsequently from the first coil instruction given immediately after STL instruction. (The circuit into which contact is input cannot be displayed in FXGP (DOS) and FXGP (WIN).

When entering contacts, enter from the base line.
6.2 Creating and Editing Circuits

### POINTS

Replacing
- **Replace (F4)**
  - Replaces the program under editing.
- **Replace (All programs under editing) (Ctrl + Alt + F4)**
  - Replaces all programs at a time under editing.
- **Replace (Write during RUN) (Shift + F4)**
  - Refer to Section 15.11.

Replacing SFC figures.
- Refer to the GX Developer Version6 Operating Manual for Windows (SFC Version)

### 6.2.1 Inputting contacts and application instructions

[Contact input procedure]
1. Move the cursor to an input position.

2. Enter the contact.
   - For input with list representation
     Enter "LD X1" with the keyboard.
   - For input with tool buttons
     Click [LD X1] and enter "LD X1" with the keyboard.
   - For input with function keys
     Press [F5] key with the keyboard to enter "X1".
   - For input with menu
     Select [Edit] → [Ladder symbol] → [Open contact], and enter "X1" with the keyboard.

3. Press [Enter] key and click [OK] button to make input in the edit window.

• The following shows the contacts that can be input with the tool buttons.

<table>
<thead>
<tr>
<th>Type</th>
<th>Contact tool button</th>
</tr>
</thead>
<tbody>
<tr>
<td>GPPA contact</td>
<td>![GPPA image]</td>
</tr>
<tr>
<td>GPPQ contact</td>
<td>![GPPQ image]</td>
</tr>
<tr>
<td>When FX series is selected</td>
<td>![FX series image]</td>
</tr>
</tbody>
</table>

[Application instruction input procedure]

1. Move the cursor to input position.
   The application instruction and device can be input to the following cursor position.

2. Enter the application instruction.
   • For input with list representation
     Enter "MOV X1 DO" with the keyboard.

3. Press Enter key and click OK button to make input in the edit window.

4. Press F4 key and click button for inputting.
6.2.2 Inputting lines (vertical and horizontal)

<table>
<thead>
<tr>
<th>POINT</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Start drawing a connecting line from the upper left position of the connecting line.</td>
</tr>
</tbody>
</table>

**[Drawing lines]**
1. Move the cursor to a connecting line input position.

2. Draw a line.
   - For input with tool buttons
     Click $\text{Alt} + F10$ and $F10$, and drag the cursor to draw a line.

   - For input with function keys
     Press $\text{Alt} + F10$ (Shift + F9) key to enter the number of vertical lines to be input in the vertical line input window.
     When the number of input lines is not designated, one vertical line is input.

   3. Press $F4$ key and click $\text{OK}$ button for inputting.

**[Drawing vertical line]**
1. Move the cursor to a vertical line input position.

2. Draw a vertical line.
   - For input with tool buttons
     Click $F10$ and Shift, and enter the number of vertical lines to be input in the vertical line input window.
     When the number of input lines is not designated, one vertical line is input.

   - For input with function keys
     Press $F10$ (Shift + F9) key to enter the number of vertical lines to be input in the vertical line input window.
     When the number of input lines is not designated, one vertical line is input.

   3. Press Enter key and click OK button to make input in the edit window.

   4. Press F4 key and click $\text{OK}$ button for inputting.
[Drawing horizontal line]

1. Move the cursor to a horizontal line input position.

2. Draw a horizontal line.
   • For input with tool buttons
     Click \( F_9 \), and enter the number of horizontal lines to be input in the horizontal line input window.
     When the number of input lines is not designated, one horizontal line is input.
   • For input with function keys
     Press \( F_9 \) key to enter the number of horizontal lines to be input in the horizontal line input window.
     When the number of input lines is not designated, one contact horizontal line is input.

3. Press \( \text{Enter} \) key and click \( \text{OK} \) button to make input in the edit window.

4. Press \( F_4 \) key and click \( \text{ barricade} \) button for inputting.

**POINT**

- Connecting lines cannot be input when the END line immediately follows the cursor-positioned line.
  In this case, press \( \text{Shift} + \text{Insert} \) keys simultaneously to make free space in advance.
6.2.3 Deleting contacts and application instructions

[Deleting procedure]
1. Move the cursor to a contact or an application instruction to be deleted.

   For deletion in insert mode, forward justification takes place for circuits.
   However, forward justification does not take place on the wrapped line.

[Deleting all programs created]
1. Move the cursor to the outside of the left base line at the top of the program.

2. Drag the cursor just before the END instruction.

6.2.4 Deleting connecting lines

[Deleting procedure]

1. Move the cursor to a connecting line to be deleted.

2. Delete the connecting line.
   - For deletion with tool buttons
     Click and drag the cursor through a line to be deleted.
   - For deletion with function keys
     Press \text{Alt} key + \text{F9} key $\rightarrow$ \text{Shift} key + arrow keys to move the cursor through a line to be deleted.
6.2.5 Inserting and deleting in circuit blocks

(1) For line insertion (in one-circuit block)
[Operating procedure]
1. Move the cursor to a line to be inserted.

2. Insert the line.
- For insertion with function keys
  Press [Shift] key + [Insert] key to insert a line.
- For insertion with menu
  Select [Edit] → [Insert Column] to insert a line.

(2) For line deletion (in one-circuit block)
[Operating procedure]
1. Move the cursor to a line to be deleted.

2. Delete the line.
- For deletion with function keys
  Press [Shift] key + [Delete] key to delete a line.
- For deletion with menu
  Select [Edit] → [Delete Column] to delete a line.
(3) For column insertion (in one-circuit block)
[Operating procedure]
1. Move the cursor to a column to be inserted.

2. Insert the column.
   - For insertion with function keys
     Press `Ctrl` key + `Insert` key to insert a column.
   - For insertion with menu
     Select [Edit] → [Insert] to insert a column.

(4) For column deletion (in one-circuit block)
[Operating procedure]
1. Move the cursor to a column to be deleted.

2. Delete the column.
   - For deletion with function keys
     Press `Ctrl` key + `Delete` key to delete a column.
   - For deletion with menu
     Select [Edit] → [Delete] to delete a column.
6.2.6 Inserting NOPs

[Purpose]
Inserts all NOPs (no operation instructions) to reserve space in a program for debugging.

[Operating Procedure]
Move the cursor to an insert line (at any location), then select [Edit] → [Insert NOP batch].

[Dialog Box]

[Description]
1) **Insert no. of NOP**
   Designates the number of NOPs to be inserted.

2) **Max. No. of NOPs which can be inserted**
   Displays the maximum number of NOPs that can be inserted.

3) **OK button**
   Click this button after making necessary settings.

6.2.7 Deleting NOPs

[Purpose]
Deletes NOPs (no operation instructions).

[Operating Procedure]
Select [Edit] → [Delete NOP batch].

[Description]
If the **OK** button is clicked on the confirmation dialog box, all NOP instructions from step 0 to the END instruction are deleted.
6.2.8 Cutting, copying and pasting circuits

(1) Pasting the circuits cut or copied by a specified range

[Operating procedure]
1. Set to the Write mode.
   Select [Edit] → [Write mode] or click (F2).

2. Specify the range of the cut/copied ladder.
   (1) When specifying the range
   Drag the mouse to specify the cut/copy range.
   The specified range is highlighted.
   (2) When not specifying the range (When cutting/copying only one contact)
      The contact, coil or the like at the cursor is the target of cutting/copying.
      At ladder mode editing, the line statement/P, I statement and END instruction cannot be cut/copied.

3. Cut or copy the specified range of circuit.
   • For cutting
     Select [Edit] → [Cut] or click (Ctrl + X).
   • For copying
     Select [Edit] → [Copy] or click (Ctrl + C).

4. Click the location in which the cut or copied circuit is to be pasted to set the cursor there.

5. Paste the circuit.
   Select [Edit] → [Paste] or click (Ctrl + V).
   On completion of circuit paste, the pasted part is grayed.

6. Press (F4) key and click button for inputting.
[Operating procedure]
1. Set to the Write mode.
   Select [Edit] → [Write mode] or click F2.

2. Specify the range of the cut/copied ladder block.
   (1) When moving the cursor to specify the range
   Click the position where the step number of the ladder block to be cut/copied is indicated, and drag the mouse vertically to specify the cut/copy range.
   (2) When making a search to set the range
   Highlight one or more ladder blocks to select the range, and specify the device, character string or the like you want to search.

3. Cut or copy the specified range of circuit block.
   • For cutting
     Select [Edit] → [Cut] or click Ctrl + X.
   • For copying
     Select [Edit] → [Copy] or click Ctrl + C.

4. Click any location within a circuit block at the lower stage of the location to be pasted to set the cursor there.

5. Paste the circuit.
   Select [Edit] → [Paste] or click Ctrl + V.
   The designated circuit is pasted at the designated location.

6. Press F4 key and click button for inputting.
6.2.9 Undo the last operation

[Purpose]
Cancels the last operation (cut, copy, or paste) and restores the previous state.

[Operating Procedure]
1. Select [Edit] → [Undo] or click \(\mathbf{U}\) immediately after cutting, copying or pasting the circuit.

   (1) The following states can be restored.
   - Line insertion, line deletion
   - Column insertion, column deletion
   - Connecting line input, connecting line deletion
   - Instruction input
   - Cut and paste within a specified range
   - Circuit deletion by [Delete] or [Back space] keys

   (2) The following states cannot be restored.
   - After circuit conversion
   - Abandoning the circuit not converted yet
   - Program change due to PLC reading, other format file reading, copying from another project
   - Replacement, inserting or deleting NOPs at a time, or TC setting value change
   - Search after cut or paste in units of circuit blocks
   - Errors due to cut, etc.
6.2.10 Returning to the status after ladder conversion

[Purpose]
Perform this operation at the time of ladder editing when you want to return to the status right after ladder conversion and perform reediting. This operation is enabled only in the ladder or SFC (ZOOM) mode. (Disabled in the list mode)

[Operating Procedure]
Select [Edit] → [Return to status after ladder conversion].
6.3 Changing T/C Setting Values

[Purpose]
Lists the setting values of timers and counters used in the program so that they can be changed at a time.
For SFC, the set values of the timers and counters within the block being displayed are changed.

[Operating Procedure]
Select [Edit] → [Change TC setting]

[Dialog Box]

[Description]
1) Device
Designates the timer(s) or counter(s) for which the current setting values must be changed.

2) [Display setup values] button
Click this button to display the current setting values of the timers or counters designated by device input.

3) Device, Setting value
Displays the current setting values of the designated timer(s) or counter(s).

4) Setting value after changing
Designates the setting value of the timer or counter for which the current setting value is to be changed.

5) Change contents copy destination
- Currently open program
  Changes the setting values of the timers and counters in the open program at present.
- Currently open program PLC program
  Changes the setting values of the timers and counters in the open program at present and writes them to the PLC.
  However, these setting values can be changed only between the constants.
6) Change button
Click this button for setting value change.

**POINTS**

- Setting values can be changed from constant (K) to indirect designation (D) and vice versa.
- For a high-speed counter of the FX series, setting value change between constant(K) and indirect designation(D) is not allowed in the online state. (same as write Online change)
- Devices with index modification cannot be designated.
- To input the changed setting value to a PLC, the setting value change must be made only between the constants.

<table>
<thead>
<tr>
<th>Original Value</th>
<th>Changed Value</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>K10</td>
<td>K1234</td>
<td>Can be set</td>
</tr>
<tr>
<td>K10</td>
<td>D10</td>
<td>Cannot be set</td>
</tr>
<tr>
<td>K10</td>
<td>ZR100</td>
<td>Cannot be set</td>
</tr>
<tr>
<td>ZR100</td>
<td>D100</td>
<td>Cannot be set</td>
</tr>
</tbody>
</table>

**About label program editing**

If the program to which TC set value changes will be made has already been compiled, you can perform TC set value changes by specifying the label devices where TC have been assigned.

When the program is not yet compiled, you cannot make label device-specified TC set value changes.

Select [Convert] → [Compile] to compile the program.

In label device-specified TC set value changes, only the data of the specified labels appear.

If TC set value changes not written to the PLC CPU are performed to the program already compiled, the program will be placed in an uncompiled status.

If TC set value changes made are also specified to be written to the PLC CPU, the program will not be put in an uncompiled status.
6.4 Find and Replace

POINT
Refer to the GX Developer Version 6 Operating Manual for Windows (SFC Version) for step No. and block No. finding and step No. replacement of SFC figures.

(1) Common operations for finding
(a) Find direction
   • From top to bottom
     Searching takes place from step 0 to the END instruction.
   • From cursor to bottom
     Searching takes place from cursor position to the END instruction.
   • From cursor to top
     Searching takes place from cursor position to step 0.
(b) Find Next button
    Click this button to search for the next device.

(2) Common operations for replacement
(a) Find direction
   • From top to bottom
     Searching takes place from step 0 to the END instruction.
   • From cursor to bottom
     Searching takes place from cursor position to the END instruction.
   • Range designation
     When a range to be replaced is designated, the step No. is set automatically.
     Click the radio button, and a step range to be found can be designated.
     A range to be replaced ranges from the head of a circuit block including a designated step No. to the end of the circuit block including the designated step No.
(b) Find Next button
    Click this button to search for the next target device without replacing a cursor-positioned device.
(c) Replace button
    Click this button to search for the next target device after replacing a cursor-positioned device.
(d) Replace all button
    Click this button to replace all the target devices in the designated search range.
(e) About replacement during label program editing
    Making replacement to an already compiled program puts the program in an uncompiled status.
    Select [Convert] → [Compile] to recompile the program.
(3) Find/replace of the other programs
   Click [Find Next] button in each find and replace to find and replace the other programs.

[Operating procedure]
1. Find and replace the current open programs.
2. Click [Find Next] button to find and replace the other programs.
   A prompt to ask for find and replace of the other programs is displayed one time only.
   In searching for and replacing the other programs, searching takes place in the following order.

   ![Diagram showing the order of searching]

(4) About replacement in label programming

<table>
<thead>
<tr>
<th></th>
<th>Local Variable Setting</th>
<th>Global Variable Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device replacement</td>
<td>Search/replacement is made on only the active local variable setting screen.</td>
<td>Search/replacement is made on only the global variable setting screen.</td>
</tr>
<tr>
<td></td>
<td>Auto External variables are only searched for. (Auto External variable replacement is made on the global variable setting screen.)</td>
<td></td>
</tr>
<tr>
<td>Character string replacement</td>
<td>Search/replacement is made on only the active local variable setting screen.</td>
<td>Search/replacement is made on only the global variable setting screen.</td>
</tr>
<tr>
<td></td>
<td>Note that Auto External variables are only searched for. (Auto External variable replacement is made on the global variable setting screen.)</td>
<td></td>
</tr>
</tbody>
</table>

- SFC programs will also be search and replacement targets.
- When there is no search program, search and replace terminates without displaying a message for searching for the other programs.
- When there remains a search program, searching for the program takes place automatically.
- When a range is designated for program replacement, this range specification is effective only for open programs. Searching in the other programs takes place from the beginning.

**POINT**
- Devices and character strings found and replaced are saved as a log. However, it is cleared when exiting GX Developer.
6.4.1 Finding a device

[Purpose]
Searches for a device in the program.
In A series and QnA series, it is possible to search in other programs in the project.

[Operating Procedure]
Select [Find/Replace] → [Find device] or click .

[Dialog Box]

[Description]
1) Device
Designates a device to be searched.
For label programming
When a label or device search is made in the ladder/list mode, only the completely matching character string of the label or device is searched for.

2) Find direction
Sets a search direction.
⊙ Find from top to bottom
  Searching takes place from step 0 to the END instruction.

⊙ Find from cursor bottom
  Searching takes place from the cursor position to the END instruction.

⊙ Find from cursor to top
  Searching takes place from the cursor position to step 0.
The following table shows device search examples.

<table>
<thead>
<tr>
<th>Device Specification</th>
<th>Search Device</th>
<th>Search Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>B0 ((k\ast\ast)B0(\ast\ast))</td>
<td>B0, K4B0, B0Z1, K4B0Z1</td>
<td></td>
</tr>
<tr>
<td>K4B0 (K4B0(\ast\ast))</td>
<td>K4B0, K4B0Z1</td>
<td></td>
</tr>
<tr>
<td>J12/B0 (J12(\ast\ast)&amp;(K\ast\ast)B0(\ast\ast))</td>
<td>J12/B0, J12B0Z1, J12Z2/K4B0, J12Z1/K4B0Z1</td>
<td></td>
</tr>
</tbody>
</table>

- If digit designation, e.g. K1X0, has been made in the BMOV/FMOV/FROM/TO instruction, X0 to XF included in K1 are to be searched for.
6.4.2 Finding an instruction

[Purpose]
Searches for an instruction in the program.

[Operating Procedure]
Select [Find/Replace] → [Find instruction] or click \(\text{Find}\).

[Dialog Box]

1) Instruction
Designates an instruction symbol and an instruction name for search. The following lists the symbols that can be designated.

[Description]
1) Instruction
Designates an instruction symbol and an instruction name for search. The following lists the symbols that can be designated.

### POINTS
- The following table shows instruction search examples.

<table>
<thead>
<tr>
<th>Instruction specification</th>
<th>Search instruction</th>
<th>Search example</th>
</tr>
</thead>
<tbody>
<tr>
<td>MOV</td>
<td>MOV(P)</td>
<td>MOV, MOV(P)</td>
</tr>
<tr>
<td>MOVVP</td>
<td>MOVP</td>
<td>MOVP</td>
</tr>
<tr>
<td>MOV D0 K4Y0</td>
<td>MOV(P) D0 Z**</td>
<td>MOV D0 K4Y0, MOV D0 D0Z1 K4Y0, MOV D0 K4Y0Z1, MOV D0 D0Z1 K4Y0Z1</td>
</tr>
<tr>
<td>MOV D0 K4Y0</td>
<td>K4Y0(Z**)</td>
<td>MOV D0 K4Y0, MOV D0 D0Z1 K4Y0, MOV D0 K4Y0Z1, MOV D0 D0Z1 K4Y0Z1</td>
</tr>
<tr>
<td>MOV D0 J1\W0</td>
<td>MOV D0(Z**)</td>
<td>MOV D0 J1\W0, MOV D0 D0Z1 J1\W0, MOV D0 D0 J1Z1\W0Z1, MOV D0 D0Z1 J1Z1\W0Z1</td>
</tr>
<tr>
<td>MOV D0 J1\W0</td>
<td>J1(Z**)\W0(Z**)</td>
<td>MOV D0 D0Z1 J1\W0, MOV D0 D0Z1 J1\W0, MOV D0 D0 D0Z1 J1Z1\W0Z1, MOV D0 D0Z1 J1Z1\W0Z1</td>
</tr>
</tbody>
</table>

- When searching for the other programs, see Section 6.4.1.
6.4.3 Finding a step No.

[Purpose]
Searches for and displays a step No. during inter-line statement or note editing.

[Operating Procedure]
Select [Find/Replace] → [Find step No.].

[Dialog Box]

1) Step No. text box
Designates a step No. to be used for search.

2) [OK] button
Click this button to display a circuit with a designated step No.

POINTS

• Step Nos. used for searching are saved as a log. However, it is cleared when exiting GX Developer.

• When searching for a step No. in another program, see Subsection 6.4.1.
6.4.4 Finding a character string

[Purpose]
Searches for a character string in the edit window for programs, device comments, or device memories.

[Operating Procedure]
On each edit window, select [Find/Replace] → [Find character string] or click [ ].

[Dialog Box]
Ladder/list edit window

Device comment edit window

Device memory edit window

Device memory edit window
[Description]
1) Find character
   Enter a character string to be searched for in up to 64 characters.

2) Device
   ⊗ Displaying devices
      Select this to search for only the devices being displayed in the window.

   ⊗ All devices
      Select this to search also those devices not displayed in the window.

3) Find target
   Select a button to designate a comment or Alias.

POINT

Device memory find direction
• Find from top to bottom
   Searching takes place from D0, W0, or R0 to the bottom.
6.4.5 Finding a contact/coil

[Purpose] Searches for a contact or coil corresponding to the device at the cursor position.

[Operating Procedure]
Select [Find/Replace] → [Find contact or coil]

[Dialog Box]

1) Contact or coil select
Choose the contact or coil.

2) Device text box
Set the device you want to search for.

3) [Find] button
Click this button to search for the specified device.
A search starts from the beginning of the program.
If there are two or more programs, the other programs will be searched.
6.4.6 Finding data

[Purpose]
Searches the set numerical data.

[Operating Procedure]
On the device memory edit window, select [Find/Replace] → [Find data].

[Dialog Box]

1) Find data
Enter the data to be searched for.

2) Device
○ Displaying devices
Select this to search for only the devices being displayed in the window.

○ All devices
Select this to search for also those devices not displayed in the window.

3) Find direction
Select a button to designate whether to search for devices from the beginning or at the cursor position.
○ From top to bottom
Searching takes place from D0, W0, or R0 to the bottom.

○ From cursor to bottom
Searching takes place from the cursor position to bottom.

POINT
Since the find and replace of a floating point and a fixed point are processed as actual data, a target of search may not be found due to a conversion error between the floating point/fixed point and the actual data.

Do not find and replace the floating point or fixed point after a 32-bit integer has been converted to a floating point. Find and replace in the input conditions.
6.4.7 Replacing a device

[Purpose]
Replaces a device or character string constant in the program currently being edited.

[Operating Procedure]
Select [Find/Replace] → [Replace device].

[Dialog Box]

[Description]
1) Previous device
Designates a device or character string constant (before change) to be replaced.

2) New device
Designates a device or character string constant (after change) for replacement.

3) No. of substitute
Designates the number of devices to be replaced among the devices designated by old device setting.
Alternatively, you can specify the substitute count in decimal or hexadecimal.
For label programming
When specifying by label, limit the number of replacement points to 1.

POINT
During label program editing, label comments do not move independently of the “Move comments and aliases” setting.
4) Move comments
Designates whether to move the comments and Alias attached to a device together.

5) Include SFC block information in find targets
Set whether the device set in the block information of each block will be replaced or not.

## POINTS

- **Device specification**
The following lists the devices that can be replaced.
  - Word device ➔ Word device
  - Bit device ➔ Bit device

- Though an extended specification can be given, digit, index, and indirect modifications cannot be made.
The table below lists the extended specification and word/bit device replacement examples

<table>
<thead>
<tr>
<th>Device</th>
<th>Replaceable</th>
<th>Device</th>
<th>Replaceable</th>
</tr>
</thead>
<tbody>
<tr>
<td>X0</td>
<td>J1\B0</td>
<td>X0</td>
<td>D0</td>
</tr>
<tr>
<td>D0</td>
<td>U10\G0</td>
<td>X0</td>
<td>K4X0</td>
</tr>
<tr>
<td>X0</td>
<td>D0.5</td>
<td>D0</td>
<td>D0.5</td>
</tr>
<tr>
<td>D0.1</td>
<td>D1.1</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- When replacing a device in other programs, see Subsection 6.4.1.
- When a replacement range is given, it is effective only for open programs at present and searching for the other programs takes place from the beginning.
- **Restrictions on FX series**
  Device replacement cannot take place between the 16-bit counters and 32-bit counters.
- The replacement of the device used in the SFC block information is suspended with an error indication if the new device will be unusable.
6.4.8 Replacing an instruction

[Purpose]
Replaces an instruction in the program currently being edited.

[Operating Procedure]
Select [Find/replace] \(\rightarrow\) [Replace instruction].

[Dialog Box]

[Description]
1) Earlier instruction
   Designates an instruction (before change) to be replaced.

2) New instruction
   Designates an instruction (after change) for replacement.
POINTS

1. An instruction plus device can be designated for instruction input. Only the circuit symbol can also be designated.
2. The replaced instruction is not executed unless it is logical.
3. The number of steps changes for instruction replacement.
4. The following shows the instruction replacement examples.

<table>
<thead>
<tr>
<th>Y90</th>
<th>MOV D0 D1</th>
<th>Replaceable</th>
</tr>
</thead>
<tbody>
<tr>
<td>M100</td>
<td>D1.1</td>
<td>Replaceable</td>
</tr>
<tr>
<td>J12/B5</td>
<td>U3/G123.5</td>
<td>Replaceable</td>
</tr>
<tr>
<td>B100</td>
<td>B100</td>
<td>Not replaceable</td>
</tr>
<tr>
<td>MOV D0 D1</td>
<td>X0</td>
<td>Not replaceable</td>
</tr>
</tbody>
</table>

- When replacing an instruction in other programs, see Section 6.4.1.
- The step numbers specified for the SFC operation outputs/transition conditions are those used when the SFC diagram is represented as an equivalent to a ladder.
- For the replacement of a 16 bit (word) handling instruction by a 32 bit (double word) handling instruction in instruction replacement, if a constant has been specified for the device, it will be changed as follows.

Negative constant of K (example: K-1) → Sign extension is made (K-1)
For H, constant whose bit corresponding to the sign is ON (example: HFFFF) → sign extension is not made and the constant is converted as it is (H0000FFFF)

Example: MOV K-1 D0  (MOV replaced by DMOV)  DMOV K-1 D0
          MOV K-200 D0 (MOV replaced by DMOV)  DMOV K-200 D0
          MOV HFFFF D0 (MOV replaced by DMOV)  DMOV H0000FFFF D0

For the replacement of a 32 bit handling instruction by a 16 bit handling instruction, the upper 16 bits are discarded.

Example: DMOV K-1 D0  (DMOV replaced by MOV)  MOV K-1 D0
          DMOV K150000 D0 (DMOV replaced by MOV)  MOV K18928 D0
          DMOV HFFFFFFFF D0 (DMOV replaced by MOV)  MOV HFFFF D0
6.4.9 Changing A and B contacts

[Purpose]
Changing the contacts (open contact/close contact) of the program currently being edited.

[Operating Procedure]
Select [Find/Replace] → [Change open/close contact].

[Dialog Box]

[Description]
1) Device
Designates a device for which contacts A and B are to be switched.

2) Number of substitutes
Designates the number of consecutive devices (including a designated device) for which contacts A and B are to be switched.
For label programming
For label programming, always set 1 point in the number of replacement points since replacement cannot be made if it is other than 1.
If you set 2 or more points, only 1 point is changed.

POINTS

- Device specification
  Extended specifications and bit No. modifications are valid for device specification, but index modifications are not valid.

- Device specification example
  X0, J1\B6, D0.5, U10\G0.3 → Can be specified
  X0Z3 → Cannot be specified
  (index modification is not possible.)

- The open contact and close contact of the following instructions can be switched.
  Open contact : LD, AND, OR, LDR, ANDP, ORP, EGP
  Close contact : LDI, ANI, ORI, LDF, ANDF, ORF, EGF

- When switching the open contact and close contact of other programs, see Section 6.4.1.

- The step numbers specified for the SFC operation outputs/transition conditions are those used when the SFC diagram is represented as an equivalent to a ladder.
6.4.10 Replacing a character string

**POINTS**
- The step numbers specified for the SFC operation outputs/transition conditions are those used when the SFC diagram is represented as an equivalent to a ladder.
- For a ladder, a statement or note is the target of search.
- For an SFC, a note or SFC comment is the target of search.

**[Purpose]**
Replaces the character string on each edit window for programs, device comments, or device memories.

**[Operating Procedure]**
On each edit window, select [Find/Replace] → [Replace character string].

**[Dialog Box]**
Ladder/list edit window

Device comment edit window

Device memory edit window
[Description]
1) Earlier character string
   Enter a character string to be replaced (statement before change) in up to 64 characters.

2) New character string
   Enter a character string for replacement (statement after change).

3) Device
   - Device under display
     Select this to replace only the devices being displayed in the window.
   - All devices (device comment only)
     Select this to replace also those devices not displayed in the window.

4) Find target
   Select a button to designate a comment or a Alias.

POINTS
   - Search with [Find Next] button
     Searches a device designated by earlier character string.
   - Search with [Replace] button
     Replaces for each device.
6.4.11 Replacing the module's first I/O number

[Purpose]
Changes the first I/O number of the FROM(P), TO(P), DFRO(P), DTO(P), RFRP or RTOP instruction.

[Operating Procedure]
Select [Find/Replace] → [Replace the module's first I/O number].

[Dialog Box]
The following screen shows a setting example for replacing the old module I/O number range of 0 to FF with the new module's first I/O No. of 30.

[Description]
1) Start
The input range is 0 to FFF0.

2) End
The input range is 0 to FFFF.
(Set a value greater than the value input in start.)

3) New module start address (HEX)
The input range is 0 to FFF0.

4) Find direction-Specified range
Set the replacement starting position and range.
The input range is 0 to 99999999.
If the starting step is greater than the end step, the Replace, Replace all and Close buttons are masked.

POINT
- Specify the I/O addresses in the same method as in entering the instruction.
- When replacing the module I/O No. of the G. device, choose [Find/Replace] → [Device replace].
6.4.12 Changing the statement or note type

[Purpose]
Changes the type of the statement or note currently being edited to the integrated or peripheral statement or note.
For details on the integrated/peripheral statement or note, see Sections 10.1.

[Operating Procedure]
Select [Search/Replace] → [Replace statement/note type].

[Dialog Box]

[Description]
1) Exchange target
   Designates a target to be replaced (statement or note).

2) Change contents
   ☑ Change in PLC [Included in program when written to PLC]
      Replaces a character string with an integrated statement or note.
      PLC write/read processing takes place automatically for the character string.

   ☑ Change in peripheral [Removed from program when written to PLC]
      Replaces a character string with a peripheral statement or note.
      PLC write/read processing does not take place for the character string.

[POINTS]
- Because only the peripheral statements and notes are set in A series, the statement and note types cannot be changed.
- When changing the statement or note type in other programs, see Subsection 6.4.1.
- The step numbers specified for the SFC operation outputs/transition conditions are those used when the SFC diagram is represented as an equivalent to a ladder.
- For an SFC, only the note will be changed. (There are no statements.)
6.4.13 Replacing data

[Purpose]
Replaces the set numerical data.

[Operating Procedure]
On the device memory edit window, select [Find/Replace] → [Replace data].

[Dialog Box]

1) Old data
Enter a numerical value to be replaced (statement before change).

2) New data
Enter a numerical data for replacement (statement after change).

3) Device
○ Displaying device
Select this to designate only the devices being displayed in the window (fixed).

POINTS
- Since the find and replace of a floating point and a fixed point are processed as actual data, a target of search may not be found due to a conversion error between the floating point/fixed point and the actual data. Do not find and replace the floating point or fixed point after a 32-bit integer has been converted to a floating point. Find and replace in the input conditions.
- A change mode cannot be replaced online.
6.4.14 Searching for a contact coil

[Purpose]
Lists the step(s), instructions, and locations in which the designated instruction has been used.

[Operating Procedure]
Select [Find/Replace] → [Cross reference list].

[Dialog Box]

[Description]
1) Find device
   Designates a device to be searched.

2) Target (only during label programming)
   Select label program or actual device.

3) Find options
   Sets the state of a search target.
   The search options (with digit, double word, etc.) make it possible to search for a device which has not been coded in the program but is actually used.
   ⊗ None
   ⊗ Searches for a designated device only.

   ⊗ Digit
   Searches for bit devices (including a designated device) with digits.

   ⊗ Double word
   Searches for word devices including a designated device and double word devices (including real numbers and indirect specifications).
4) Target the whole program
   For ladder
   Choose the program to be searched (by program, all programs).
   For SFC
   All programs: All programs in the project are searched.
   All blocks: All blocks of the SFC diagram being edited are searched.
   Inside block (SFC diagram): Only the block being displayed is searched.
   Inside block (Zoom diagram): Only the operation outputs/transition conditions being displayed are searched.

5) Comment
   Displays a comment assigned to a designated device.

6) Contact coil use list
   Block................ Lists the numbers with which the block No. designated in the SFC is used.
   Step ................. Lists the numbers with which the step No. designated in the SFC is used.
   Sequence step. Lists the step numbers in which the designated device has been used.
   Instruction ........ Lists the instructions in which the designated device has been used.
   Location ........... Indicates by * the byte positions in which the designated device has been used.
   (Example) .......... In the case of "MOV K4Y0 D0", the DO position is indicated by ".-.*."
   Program name. Lists the program names with which the specified device is used.
   Up to 500 items can be retrieved and displayed in this list.

7) [Jump] button
   Click any data in the contact coil use list, then click the [Jump] button to locate the cursor at the position where the corresponding contact coil is used within the sequence circuit.

<table>
<thead>
<tr>
<th>POINT</th>
</tr>
</thead>
<tbody>
<tr>
<td>The cross reference list function can be used even when unconverted circuits exist.</td>
</tr>
</tbody>
</table>
6.4.15 Searching for a device-use instruction

[Purpose]
Lists the device use conditions in a program on a specified device basis. Specifying the device displays the ladder symbol used, the frequency of use, and whether an error has occurred or not.

[Operating Procedure]
Select [Find/Replace] → [List of used device].

[Dialog Box]

[Description]
1) Target the whole program
   Click the radio button to display a device-use list for all programs in the project.

2) Specify the target program
   Designates a program to be searched.

3) Find device
   Designates the first device to be searched for.
   Clicking the / button moves the screen up or down by 512 points.
   (Clicking the scroll bar moves the screen by 512 points.)
   In a single search, 512 points shown in the display area are searched.
   When the cursor is on the device list, you can scroll the screen using [Ctrl]+[PageUp]/[PageDown].

4) Target (only during label programming)
   Select label program or actual device.
4) Device-use Instruction list
   Device........... Instruction lists devices in such a way that the device designated
   in the search device is listed first.
   Display........... Displays * when the device has been used in the source of the
   instruction.
   Display........... Displays * when the device has been used in the destination of
   the instruction.
   Count........... Indicates the frequency of coil usage.
   Error........... Displays "ERR" when the device has been used only in the
   source or the destination.
   Comment...... Displays a comment attached to the device.
   Clicking the scroll bar moves the screen by 512 points.

5) Specify whether all blocks or only the specified block will be searched.

6) Execute button
   Click this button after designating a search program or a search device.
   A device-use list contains the instructions used and their frequency in such a
   way that the device designated in the search device comes first.

POINTS
   • When ZR is designated, 8,192 devices (including the designated device as
     the first one) are searched.
     To display out-of-range devices, the devices must be designated again.
     Page scroll takes place within 8,192 devices listed.
   • When two or more windows are open, the result of comment editing on the
     device use list screen is reflected on other windows as soon as the window is
     switched to another.
   • If there is an unconverted ladder, the device use list function can be used.
   • For label program creation, this function does not support label devices.
     Make an "N/O","N/C" contact change after searching for a label device in the
     contact/coil use list.
7. CREATING INSTRUCTION LIST

This chapter describes how to create, modify and read the sequence programs.

7.1 Common Notes on Instruction List Creation

This section describes the common items and restrictions on Instruction list creation, Instruction list display window, and Instruction list edit window.

1. Instruction list input dialog box
   Input alphanumeric characters.

2. Program display area
   • Display does not depend on the number of END instructions.
     In addition, programs may be input after the END instructions.
     When a new Instruction list is created, the END instruction appears at the first line.
     No display takes place for NOP only.

3. Modification of existing Instruction list
   For creating a new instruction list, move the cursor to an incorrect instruction location in the input (overwrite) mode, then input a correct instruction there.
   For adding Instruction list, move the cursor to a line insert step in the input (insert) mode, then input an instruction.
   To switch input modes (overwrite and insert modes), press Insert key.

4. Deletion in units of instructions
   Move the line to be deleted, then press Delete key or Shift + Delete key.

5. The preceding or subsequent page of the current page can be displayed during a read/write operation.
   Click Page Up key to display the preceding page.
   Click Page Down key to display the subsequent page.

6. The following table lists the modes that can be used in Instruction list mode.

<table>
<thead>
<tr>
<th>Mode</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read mode</td>
<td>○</td>
</tr>
<tr>
<td>Write mode</td>
<td>○</td>
</tr>
<tr>
<td>Monitor mode</td>
<td>×</td>
</tr>
<tr>
<td>Monitor write mode</td>
<td>×</td>
</tr>
</tbody>
</table>

7. Circuit symbol buttons on the toolbar, monitor/write monitor, monitor start/stop, step run, partial run, skip are disabled.

8. Device comment display
   No device comments are displayed.
9. Display with statements or notes
   When statements or notes have been created, they are always displayed (fixed processing).
   In A series and FX series, no step numbers are displayed.
   In QnA series, step numbers are displayed.
   Statements and notes can be created in the same way as for operations on the circuit edit window
   (see Section 10.3.1 and 10.4.1 for details.)

10. SFC programs (only for QnA series)
    These programs cannot be edited but displayed.
    SFC programs in FX series are represented as an instruction words Instruction list by step ladder instructions.
7.2 Creating a Program Instruction list

Sequence programs are input by the Instruction list instructions. In addition, it is convenient to edit in the Instruction list mode the instructions that cannot be edited in the circuit mode. For details on how to switch the Instruction list mode, see Chapter 6.

7.2.1 Inputting a contact or application instruction

- For contact input (insert mode)
  1. Press `Insert` key to set the insert mode.
  2. Enter "LD X1", then the Instruction list input dialog box is displayed and entered data is displayed in the device instruction text box. Press `[Enter]` key to make input in the edit window.

- For application instruction input
  1. Enter "MOV K1 D0", then the Instruction list input dialog box is displayed with the entered data being displayed in the device instruction text box. Press `[Enter]` to make input in the edit window.

**POINTS**

Refer to Section 9.4.3 when creating a device comment right after writing the instruction.
7.2.2 Changing the existing program in overwrite mode

1. Confirm that the overwrite mode is indicated on the status bar. Press [Insert] key to switch the insert and overwrite modes.

2. Move the cursor onto the program to be corrected in overwrite mode. List input dialog box

   0  LD  X5
   1  OUT  Y30
   2  OUT  T0  K800
   6  SET  V0
   7  LD  T0
   8  OUT  C0  K3
   12  RST  T10
   16  LD  X3
   17  OUT  Y71
   18  OUT  T1  K100
   22  SET  V1
   23  OUT  Y40
   24  LD  T1
   25  OUT  C1  K6
   29  RST  T1
   31  LD  X2
   34  OUT  Y22
   35  OUT  T2  K1200
   39  SET  W2

3. Enter an instruction or device (LD M10) for correction, then the list input dialog box is displayed with the entered data being displayed in the device instruction text box. Press [Enter] key to make input in the edit window.

   Input alphanumeric characters.
7.2.3 Inserting or adding the existing program

1. Confirm that the insert mode is indicated on the status bar. Press Insert key to switch the insert and overwrite modes.

2. Move the cursor to the position to insert or add a program.

```
0 LD X2
1 OUT Y70
2 OUT T0 K600
6 SET W0
7 LD T0
8 OUT C0 K3
12 RST T0
16 LD X3
17 OUT Y71
18 OUT T1 K100
22 SET W1
23 OUT Y60
24 LD T1
25 OUT C1 K6
29 RST T1
33 LD X4
34 OUT Y72
35 OUT T2 K1200
39 SET W2
```

3. Enter an instruction to be inserted or added or device (LD M10), then the list input dialog box is displayed with the entered data being displayed in the device instruction text box. Press Enter key to make input in the edit window.
7.2.4 Deleting the existing program list

1. Move the cursor to a program to be deleted.

2. Press \texttt{Delete} key or \texttt{Shift} + \texttt{Delete} key to delete the program.

```
0 LD X2
1 OUT Y70
2 OUT T0 K600
6 SET H0
7 LD T0
8 OUT Q0 K3
12 RST T0
16 LD X3
17 OUT Y71
18 OUT T1 K100
22 SET N1
23 OUT Y40
24 LD T1
26 OUT C1 K6
29 RST T1
33 LD X4
34 OUT Y72
35 OUT T2 K1200
39 SET N2
```
7.2.5 Inserting NOPs

- Inserting NOPs in units of lines
  Move the cursor to a location for inserting a NOP, then press \[\text{Shift} + \text{Insert}\] key (The NOP is inserted in the line above the cursor.)

- Insert NOPs at a time
  Move the cursor to a location for inserting NOPs, then select [Edit] \rightarrow [insert NOP batch]. The following dialog box is displayed for confirmation.

  ![NOP Batch Insert Dialog]

  Input the number of NOPs to be inserted in insert no. of NOP text box, then click the [OK] button.

  A ladder may not be displayed if NOPs are inserted at any points in a ladder block and the number of ladder block steps exceeds about 4k steps.

  NOP insertion can take place even when the cursor has been positioned after the END line.

7.2.6 Deleting NOPs

- Deleting NOPs in units of lines
  Move the cursor to a location for deleting a NOP, then press [Delete] key or [Shift] + [Delete] key to delete it. (The NOP in the line above the cursor is deleted.)

- Deleting NOPs
  Press [Enter] key, and the program will be displayed in the list input dialog box.
  Select [Edit] \rightarrow [Delete NOP batch], and the following dialog box will be displayed.

  ![Delete NOP Batch Dialog]

  Click the [Yes] button, and NOPs will be deleted at a time.
  When there are NOPs after the END instruction, they are also deleted.
7.3 Find and Replace

7.3.1 Finding a device

See Section 6.4.1 for details.

7.3.2 Finding an instruction

See Section 6.4.2 for details.

7.3.3 Finding a step No.

See Section 6.4.3 for details.

7.3.4 Finding a character string

Searching for a statement or note takes place. See Section 6.4.4 for details.

7.3.5 Finding a contact/coil

See Section 6.4.5 for details.

7.3.6 Replacing a device

See Section 6.4.7 for details.

7.3.7 Replacing an instruction

See Section 6.4.8 for details.
7.3.8 Changing an A or B contact

See Section 6.4.9 for details.

7.3.9 Replacing a character string

See Section 6.4.10 for details.

7.3.10 Change module start address

See Section 6.4.11 for details.

7.3.11 Changing the statement or note type

See Section 6.4.12 for details.

7.3.12 Searching for a contact coil

See Section 6.4.14 for details.

7.3.13 Searching for an instruction using a device

See Section 6.4.15 for details.
7.4 Display

7.4.1 Displaying a Alias

[Purpose]
Displays the created Alias on the circuit edit window.

[Operating procedure]
1. Select [View] → [Alias] (Alt + Ctrl + F6).

2. The Alias is displayed in the window instead of the device.
7.5 Switching Read and Write Modes

7.5.1 Switching to read mode

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

See Chapter 6 for details.

7.5.2 Switching to write mode

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

See Chapter 6 for details.

7.5.3 Switching to circuit mode

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

See Chapter 6 for details.

7.6 Changing T/C Setting Values

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

See Section 6.3 for details.
8. CONVERSION

There are three kinds of menu provided for conversion, [Convert], [Convert (All programs being edited)], and [Convert (Online change)]. This chapter describes normal conversion and batch program conversion. For conversion from the [Convert (Online change)] menu, see Section 16.9.

8.1 Converting an Edit Program

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

[Purpose]
Converts the program currently being edited (in the active window).

[Operating Procedure]
Select [Convert] → [Convert].

8.2 Converting Multiple Edit Programs

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>×</td>
</tr>
</tbody>
</table>

[Purpose]
Converts multiple edit programs at a time.

[Operating Procedure]
Select [Convert] → [Convert (All programs being edited)].

[Description]
Edit programs are converted in the order that the sequence programs have been opened.

POINTS
- For the conversion operation for SFC diagram editing, refer to the following manual.
  GX Developer Version6 Operating Manual(SFC)
9. SETTING DEVICE COMMENTS

This chapter describes the points to be noted on comment creation with GX Developer. In addition, it describes how to input the device comments created with GX Developer to ACPU, QnACPU or FXCPU and how to input the data created with GPPA, GPPQ, FXGP(DOS) or FXGP(WIN) to GX Developer.

### 9.1 Points to be Noted before Comment Creation with GX Developer

This section describes the points to be noted and settings that vary depending on whether to handle comments only on peripheral devices or to input them to PLC.

1. **Comments on special resistors and special relays**
   - Since the comments on special resistors and special relays are created in the installed directory (MELSEC\GX Developer\Sample Comment), it is useful to copy them to projects for which sequence programs will be created.

   **Sample-1** ACPU COMMENT SP.M SP.D
   **Sample-2** A1FX COMMENT SP.M SP.D
   **Sample-3** QnA COMMENT SM, SD, J1/SB, J1/SW
   **Sample-4** FX CPU COMMENT SP.M SP.D
   **Sample-5** Q COMMENT SM, SD, J1/SB, J1/SW
   **Sample-6** Q (A Mode) (SP.M, SP.D)
     - For multi-CPU-compatible SMs, comments are stored in SM240 to 247 and SM390.
     - For multi-CPU-compatible SDs, comments are stored in SD4 to SD15 and SD395.

2. **Extended comments**
   - When AnNCP is selected, the extended comments can be created with GX Developer, but cannot be written to the PLC CPU.

   - The extended comments 2 to 4 cannot be written to the ACPU/GPPA file.

   The extended comments read from the ACPU/GPPA file to the GX Developer are stored in the common comment.
(3) Device comments when GX Developer and GPPA are used

Precautions:
*1: Only AnA and AnUCPU can be written to the PLC CPU.
*2: The extended comments 2 to 4 cannot be written to the PLC CPU.
*3: The comments created in X, Y, special resisters, special relays, SUB2, and SUB3 among those created by program cannot be written to the ACPU/GPPA file.
*4: Those devices other than the X, Y, special resisters, and special relays created in COMMENT (common comment) can be written to the ACPU/GPPA file by setting them in the extended comment (Refer to Section 9.7).
When a comment on the same device (X, Y, etc.) is created for a common device and an extended comment, the device comment set in the extended comment is read (Refer to Section 9.1.3 for details).
(4) About the device comment creation ranges for multi-CPU configuration

Device comments can be created in the following ranges for the buffer memory (3E00 to 3E3F) of the PLC CPU in a multi-CPU configuration.

<table>
<thead>
<tr>
<th>System Configuration</th>
<th>Creation Enabled Range</th>
<th>Creation Disabled Range</th>
</tr>
</thead>
<tbody>
<tr>
<td>No multi-CPU configuration</td>
<td>U0(¥G0) to U1FF(¥G65535)</td>
<td></td>
</tr>
<tr>
<td>Multi-CPU configuration</td>
<td></td>
<td>U200(¥G0) to U3DF(¥G65535)</td>
</tr>
<tr>
<td></td>
<td>U3E0(¥G0) to U3FF(¥G65535)</td>
<td></td>
</tr>
</tbody>
</table>

The created device comments are enabled for PLC read/write/verify and file read/write/verify.
9.1.1 Editing comments only on Personal computers

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>○</td>
<td>○</td>
<td>○</td>
</tr>
</tbody>
</table>

(1) In A series, Q/QnA/A/FX series, the created comments can be saved. Neither parameter settings nor comment range settings are required.

(2) Both common comments and comments by program can be created. Common comments can be created independent of comments for the main program and subprograms. (see Section 9.3 for details.)

(3) The common comment data name is fixed to "COMMENT."

(4) There are two methods for creating comments by program. The first method sets a comment data name according to the data name of a sequence program. The second method sets a data name different from the sequence program name. (see Sections 5.8 and 9.3 for details.)

(5) The devices subject to comment creation are all displayed (for monitoring) or printed out.

(6) When creating a Alias in A series, note that it cannot be input to ACPU or GPPA files.
POINT

- When a common comment and a comment by program have been set for the same device, click <<Each program>> tab on the dialog box displayed by selecting [Tools] → [Option] to set a comment to be displayed in units of devices (see Section 15.11 for details).

<table>
<thead>
<tr>
<th>Common comments</th>
<th>Comments by program</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device</td>
<td>Comment</td>
</tr>
<tr>
<td>X1</td>
<td>START</td>
</tr>
</tbody>
</table>

<<Each program>> sheet

- When either a common comment or a comment by program has been set for a device, the set comment is displayed automatically.

- The number of letters used in editing comment devices or used for display in the circuit mode can be changed from 16 to 32 and from 32 to 16. Click <<Whole data>> tab on the dialog box displayed by selecting [Tool] → [Option] (See Section 15.10).
9.1.2 Writing to ACPU/GPPA file

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>O</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>

(1) Writing to ACPU takes place according to the memory size setting (comment, extended comment) and write comment range setting (see Section 9.7) in the PLC parameter. Only comment1/2 and extended comment 1 can be input to the PLC. (Extended comments 2 to 4 cannot be input.)

(2) Comment1 (4032 comments x 15 character) can be input to ACPU while Comment2 (4032 comments x 16 character) can be input to ACPU.

(3) Devices other than X, Y, SP.M (special relay), and SP.D (special register) must be saved in the extended comment 1 area. (See Sections 9.3 and 9.7 for details.)

(4) When a comment has been created in more than 17 characters with GX Developer, the comment part in the 18th character and after is not input to the PLC.

(5) When X and Y areas are overlapping in a common comment, Y comment is not input because X takes precedence over Y.
### 9.1.3 Reading from ACPU/GPPA file

(1) When the comments X and Y created by the PLC or GPPA are read into GX Developer, they are pasted onto the edit windows X and Y respectively.

(2) When comment1/2 and extended comments have been set for the existing data, both comments are read into GX Developer common comments. In addition, when comment1/2 and extended comments are overlapping, the latter extended comments are read with precedence.

The comments for the main program and subprograms include the device comments, M, L, S, B, F, T, C, D, W, R, P, and I.
[Notes on reading and writing common comments]
When the common devices X0 to XF and extended comments Y0 to YF are overlapping (in files created on the preceding page), if they are read into GX Developer, then input to ACPU, care should be taken because the comments Y0 to YF read from the extended comments are input to the common devices and the original common device comments are overwritten.
9.1.4 Writing to QCPU(Qmode) QnACPU/GPPQ file

(1) Common comments or comments by program can be input to the PLC or GPPQ files according to the steps of editing.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>×</td>
<td>O</td>
<td>×</td>
</tr>
</tbody>
</table>

GX Developer

- Common comment (COMMENT)
- Comments by program
- Comments by program

PLC

- Comments by program
- Comments by program
- Comments by program

9.1.5 Reading from QCPU(Qmode) QnACPU

1. The comments created by GPPQ are read as they are. The GX Developer common comments are not read.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>×</td>
<td>O</td>
<td>×</td>
</tr>
</tbody>
</table>

QCPU(Qmode), QnACPU

- Common comment (COMMENT)
- Comments by program
- Comments by program

GX Developer

- Comments by program
- Comments by program
- Comments by program

When the file "COMMENT" has been created as a QnACPU or GPPQ file, it is read into GX Developer as a common comment.
9.1.6 Writing to FXCPU/FXGP(DOS), FXGP(WIN) file

1. Writing to FXCPU can take place according to the memory size setting (comment size) and write comment range setting (see Section 9.7.) in the PLC parameter.

2. Only common comments can be input to FXCPU as device comments. Comments by program cannot be input to the PLC (see Section 9.3.)

3. The number of comment1 characters that can be input to FXCPU from GX Developer is 16 characters. Though GX Developer allows comments of up to 32 characters, only 16 characters are input to the PLC. In addition, FXGP(DOS) allows only characters to be used for Comment1 and the maximum number of characters is 15. To display all comments normally by FXGP(DOS), device comments must be created in up to 15 characters.

4. The number of comment1 that can be input to FXCPU varies depending on the memory size setting in the PLC parameter.

5. All details of the common comment are written. For the Alias, however, only the alphanumeric characters and symbols (+, - / = . ? # $ % & ; _ ) of half size are made valid (See Section 9.4.1). Those Alias containing full size characters or unspecified characters will be deleted at the time of writing.
9.1.7 Reading from FXCPU/FXGP(DOS), FXGP(WIN) file

1. Comments in FXCPU are read as common comments as they are.

(1) Reading an FXGP(DOS) file
   All comments are read.

(2) Reading an FXGP(WIN) file
   Though FXGP(WIN) allows up to 50 characters to be input, only the first 32 characters are read for GX Developer input.
   The number of comments is not limited and all comments are read.
### 9.2 List of Device Comments

The types of devices and the possibility of comment setting are listed below.

<table>
<thead>
<tr>
<th>Device name</th>
<th>Symbol</th>
<th>Bit device</th>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bit device</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Input/Output</td>
<td>X/Y</td>
<td>√</td>
<td>√</td>
<td>√</td>
<td>√</td>
</tr>
<tr>
<td>Input/Output</td>
<td>DX/DY</td>
<td>–</td>
<td>√</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>Internal relay</td>
<td>M</td>
<td>√</td>
<td>√</td>
<td>√</td>
<td>√</td>
</tr>
<tr>
<td>Step relay</td>
<td>S</td>
<td>√</td>
<td>√</td>
<td>√</td>
<td>–</td>
</tr>
<tr>
<td>Latch relay</td>
<td>L</td>
<td>√</td>
<td>√</td>
<td>√</td>
<td>–</td>
</tr>
<tr>
<td>Annunciator</td>
<td>F</td>
<td>√</td>
<td>√</td>
<td>√</td>
<td>–</td>
</tr>
<tr>
<td>Special relay</td>
<td>SM</td>
<td>–</td>
<td>√</td>
<td>√</td>
<td>–</td>
</tr>
<tr>
<td></td>
<td>M</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>√</td>
</tr>
<tr>
<td>FB Input/FB Output</td>
<td>FX</td>
<td>–</td>
<td>×</td>
<td>×</td>
<td>–</td>
</tr>
<tr>
<td>Edge relay</td>
<td>V</td>
<td>–</td>
<td>√</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>Link relay</td>
<td>B</td>
<td>√</td>
<td>√</td>
<td>√</td>
<td>–</td>
</tr>
<tr>
<td>Link special relay</td>
<td>SB</td>
<td>–</td>
<td>√</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>State</td>
<td>S</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>√</td>
</tr>
<tr>
<td>Timer/Counter</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Timer</td>
<td>T</td>
<td>√</td>
<td>√</td>
<td>√</td>
<td>√</td>
</tr>
<tr>
<td>Counter</td>
<td>C</td>
<td>√</td>
<td>√</td>
<td>√</td>
<td>√</td>
</tr>
<tr>
<td>Count timer</td>
<td>ST</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>Word device</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Data register</td>
<td>D</td>
<td>√</td>
<td>√</td>
<td>√</td>
<td>√</td>
</tr>
<tr>
<td>Special register</td>
<td>SP.D</td>
<td>√</td>
<td>–</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td></td>
<td>SD</td>
<td>–</td>
<td>√</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td></td>
<td>D</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>√</td>
</tr>
<tr>
<td>Link register</td>
<td>W</td>
<td>√</td>
<td>√</td>
<td>√</td>
<td>–</td>
</tr>
<tr>
<td>File register</td>
<td>R</td>
<td>√</td>
<td>√</td>
<td>√</td>
<td>–</td>
</tr>
<tr>
<td>(RAM) File register</td>
<td>D</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>√</td>
</tr>
<tr>
<td>Sequence file R</td>
<td>ZR</td>
<td>–</td>
<td>√</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>Link special register</td>
<td>SW</td>
<td>–</td>
<td>√</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>FB data</td>
<td>FD</td>
<td>–</td>
<td>×</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>Others</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pointer</td>
<td>P</td>
<td>√</td>
<td>√</td>
<td>√</td>
<td>√</td>
</tr>
<tr>
<td>Accumulator</td>
<td>A</td>
<td>√</td>
<td>–</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>Interrupt pointer</td>
<td>I</td>
<td>√</td>
<td>√</td>
<td>√</td>
<td>√</td>
</tr>
<tr>
<td>Nesting</td>
<td>N</td>
<td>×</td>
<td>×</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>Extended specification</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Index</td>
<td>Z</td>
<td>×</td>
<td>×</td>
<td>×</td>
<td>√</td>
</tr>
<tr>
<td>I/O No.</td>
<td>U</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>Buffer register</td>
<td>G</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>SFC block device</td>
<td>BL</td>
<td>–</td>
<td>√</td>
<td>√</td>
<td>–</td>
</tr>
<tr>
<td>Step relay</td>
<td>BL\S</td>
<td>–</td>
<td>√</td>
<td>–</td>
<td>–</td>
</tr>
</tbody>
</table>

*: When the A1FXCPU is selected, S comment or extended comment cannot be created.
9.3 Common Comments and Comments by Program

[Device comment system]
Device comments include common comments and comments by program.

[Common comment]
A series
Settings are required when a common comment is assigned for all sequence programs in CPU types with subprograms.

Q/QnA series
Settings are required when single comment data is used in common for creation of multiple programs.
These settings can also be made even when multiple programs are not present.

FX series
Settings are required when a comment is assigned for the main program (MAIN).
In FX series connection, these settings are not related to subprograms (SUB) because only one program file is created.

The common comment name is fixed to COMMENT.
The common comment can be changed to comments by program later.

[Comments by program]
A series
Settings are required when a comment is assigned for each program during main sequence program creation or sub-sequence program creation.

Q/QnA series
Settings are required when a comment is assigned for each program.

FX series
Settings are required when comments other than common comments are assigned for the main program (MAIN).
In FX series, only common comments are automatically created in new project creation.
When comments by program are required, they must be added newly. (see Section 4.9 for details.)
Comments by program cannot be input to FXCPU and FXGP(DOS) or FXGP(WIN) files. When input to FXCPU or FXGP(DOS) or FXGP(WIN) files is required, comments must be created as common comments or the comments by program must be changed to common comments for operation. (see Section 9.6 for details.)
[Setting of comment data by program]
See Section 4.9 for details on operation methods.

Once the comments by program are set, they are displayed as shown in the figure to the left.

[Creation of only common comments]

Schematic diagram

A series (A4UCPU selection):

Sequence program (MAIN)  
Sequence program (SUB1)  
Sequence program (SUB2)  
Sequence program (SUB3)  

COMMENT common comment

Q/QnA series:

Sequence program A  
Sequence program B  
Sequence program C  

COMMENT common comment

FX series:

Sequence program (MAIN)  

COMMENT common comment
[Creation of only comments by program]

A series (A4UCPU selection):

- Main sequence program
- SUB1 Sequence program
- SUB2 Sequence program
- SUB3 Sequence program

Comments by Program
- MAIN
- SUB1
- SUB2
- SUB3

Q/QnA series:

- Sequence program A
- Sequence program B
- Sequence program C

Comments by Program
- Comment A
- Comment B
- Comment C

FX series:

- Main sequence program

Comments by Program
- MAIN
9.4 Creating Device Comments

9.4.1 Creating device comments on the device comment edit window

[Purpose]
Assigns the meaning for a device for easy-to-view programs. This function is helpful in creating the devices.

[Operating Procedure]
• For creation of common comments
  Device comment in the project data list → COMMENTO
• For creation of comments by program
  Set the data type (comments by program), name of new data to be added, and title in the dialog box displayed by selecting [Project] → [Edit data] → [New].

[Dialog Box]

1) Device
Designates a device for comment creation. After device designation, click the Display button. Once the device name is set, it is registered. When creating SFC comments, specify the device names as follows.
Block title : BLm
Step comment : BLm\Sn
Transition comment : BLm\TRn
(m: block number, n: step, transition number)
2) Comment
Sets a comment for each device.
- Comment1........... To be created in 15 characters.
  (see APP.11.2 for comment setting in the FX PLC.)
- Comment2........... To be created in 16 characters.

3) Alias
To be used when a device is set as an actual switch name.
A device name must be set in up to 8 characters.

<Example> Difference in displaying the Alias and device comment

<table>
<thead>
<tr>
<th>Alias</th>
<th>Device comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>SWITCH</td>
<td>Start</td>
</tr>
</tbody>
</table>

Device names created in A Series format will not be written when [Write to GPPA file] or [Write to PLC] is executed. Caution is necessary.

**POINTS**

- When either common comments or comments by program have already been created, the created device comments are displayed unconditionally.

- When a Alias is input to an FXGP(WIN) file, it must be set only in alphanumeric characters and symbols (· + · * / = . ? # $ % & ; _). Device names including the characters not permitted are deleted in writing them.

- The number of comment characters can be changed to 32 characters in the <<Data>> sheet on the dialog box displayed by selecting [Tools] → [Options]. However, the number of comment characters is restricted as follows for input to ACPU or FXCPU (Comment1 only).
  - Comment1 ........... Up to 15 characters (For FX series, see Section Appendix 11.2)
  - Comment2 ........... Up to 16 characters
9.4.2 Creating device comments for the created circuit

[Purpose]
Assigns the meaning for a device for easy-to-view programs. This function is helpful in modifying or adding device comments.

[Operating Procedure]
1. Move the cursor to a device comment creation location.

2. Press Enter key.

3. Make settings as follows for the circuit input dialog box. (Input two semicolons.)

4. Comment display takes place as follows.
9.4.3 Creating device comments after creating a circuit

[Purpose]
Assigns the meaning for a device for easy-to-view programs.
This function is helpful to create device comments and the circuit at the same time.

[Operating Procedure]
1. Check the Device comment check box on the dialog box displayed by selecting [Tools] → [Options].
2. Move the cursor to a device comment creation location.
3. Enter a contact and/or a device and click the OK button.
4. Enter a device comment and click the OK button.
5. Comment display takes place as follows.
9.4.4 Editing comments on the ladder editing screen

[Purpose]
Comments the devices for ease of program viewing. This function is useful for device comment corrections/additions.

[Setting Procedure]
1. [Edit] → [Documentation] → [Comment] ( )
2. Move the cursor to the position where a device comment will be created.
3. Pressing Enter shows the following dialog box.

```
 Enter device comment [ X1 ] COM... X
```

4. Enter a device comment and click the OK button.

```
 Enter device comment [ X1 ] COM... X
```

5. Providing a comment display shows the following ladder.

![Diagram of ladder logic]

**POINTS**
- To cancel the comment edit mode, choose this menu again and uncheck the checked menu item.
- Note that comments of M, L and S can be created on the A series.
- For the FROM/TO and other instructions which can handle multiple devices, the number of devices used can be commented.
9.5 Deleting Device Comments

9.5.1 Deleting all device comments and Alias

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>○</td>
<td>○</td>
<td>○</td>
</tr>
</tbody>
</table>

[Purpose]
Deletes all device comments and Alias set so far.

[Operating Procedure]
Display the device comment edit window, then select [Edit] → [Clear all (all devices)].

9.5.2 Deleting display device comments and Alias

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>○</td>
<td>○</td>
<td>○</td>
</tr>
</tbody>
</table>

[Purpose]
Deletes the device comments and Alias being displayed.

[Operating Procedure]
Display the device comment edit window, then select [Edit] → [Clear all (displayed devices)].
9.6 Setting Comment Types

[Purpose]
Switches the comment type from common comments to comments by program and vice versa.

<Example>
Settings are required when common comments are changed to SUB1 (comments by program) or comments by program are changed to common comments (COMMENT).

Before change After change
COMMENT (common comment) → SUB1 (comments by program)
MAIN (comments by program) → MAIN (comments by program)

[Operating Procedure]
Display the device comment edit window, then select [Edit] → [Setup comment].

[Dialog Box]

[Description]
1) Comment type
   Indicates the type of the data selected for Data name.

2) Data name
   Designates a data name for comment type change.

3) Change comment type to
   Classifies data set in the data name field into two categories: common comments and comments by program.

4) Change Data name to
   Changes the existing data name.
   This data name must be designated in up to 8 characters.

5) [OK] button
   Click this button after making necessary settings.
POINTS

- Common comments and comments by program can be classified from the device comment icons in the project data list.

- This icon is displayed for comments corresponding to the sequence programs.
- This icon is displayed for comments not corresponding to the sequence programs.

- One common comment is allowed within one program. In addition, the common comment data name is fixed to "COMMENT."
- Up to 124 comments by program can be set.
9.7 Setting Comment Ranges

[Purpose]
Sets a data range when data created with GX Developer is written to a PLC or when a GPPA, GPPQ, FXGP(DOS) or FXGP(WIN) file is written to the FD or HD.

[Operating Procedure]
Display the device comment edit window, then select [Edit] → [Setup comment range].

• When A series is started

[Dialog Box]
<<Common programs>> sheet

1) Comment type specification
   • Comment1
     To be selected when a device comment has been created as a Comment1.
   • Comment2
     To be set when a device comment has been created as a Comment2.
2) Range specification

- Indicates the name of data to be written as a GPPA file.
- Selects a destination to which a range-specified device is written.
- Designates the devices to be stored in the extended comments 1 to 4.

If the starting and end positions of a range are designated in GX Developer files, they are reflected in the PLC/GPPA table.

[Dialog Box]
<<Each program>> sheet (for main program and subprograms)

[Description]
1) PLC/GPPA Format
   Indicates the name of data to be written as a GPPA file.

2) GX Developer Format
   Designates MAIN or SUB1.
   Even if SUB2, SUB3 or SUB4 is created with GX Developer, it cannot be designated in this setting item.
3) Device range setting
   Designates a range of devices to be written to a PLC or a Personal computer.

4) Comment1/2 memory capacity
   Indicates the size of a device to be saved in the comment or extended comment.

[Operating Procedure]
- When QnA series is started

[Dialog Box]
<<Program common>> sheet

[Description]
1) Range setting
   - Designates the name of data to be written as a GPPQ file.
   - Designates the devices to be written to a PLC or FD/HD.

   If the starting and end positions of a range are designated in GX Developer files, they are reflected in the PLC/GPPA table.

2) PLC comment write format (PLC Format)
   Designates how many characters are to be written to a PLC.
### Description

1) **PLC /GPPQ Format**  
   Designates the name of data to be written as a GPPQ file.

2) **GX Developer Format**  
   Indicates a data name for comment range setting.

3) **Device range setting**  
   Designates the devices to be written to a PLC or Personal computer.

### POINT

- To make input to ACPU, the comment1/2 memory size must be designated in the memory size parameter. (The memory size displayed here is not reflected to the parameter memory size.)  
  If no size is designated, an error occurs.  
  No settings are required when the other files are used for input.
[Operating Procedure]
- When FX series is started

[Dialog Box]
<<Program common>> sheet

1) Range setting
- Designates the devices to be written to a PLC or Set
- Set the comment range created by the GX Developer.

2) PLC write comment form (PLC form).
- Setting is not possible for the FX series.

[Description]

[POINT]
- Comments by program cannot be written to PLC and FD/HD (see Section 9.3).
10. SETTING THE STATEMENTS AND NOTES

Sequence programs are annotated with comments for ease of understanding. Note that the A/FX series does not have the integrated statement/integrated note function.

10.1 About the Statements/Notes

This section describes the statements created on the Q/QnA/A/FX series. On the FXGP(DOS) and FXGP(WIN), statements are called "ladder comments".

Peripheral Statement
n line* × 64

Integrated Statement
n line* × 64

P statement
t line × 64
I statement
t line × 64

*:About the number of lines on which a peripheral statement/integrated statement can be created
A single line accepts 64 characters. No sentence can be written over two or more lines.
For the Q/QnA series
Number of statements that may be created in a single ladder block = 15 × number of lines in a single ladder block
The following ladder block can be annotated with statements on up to 30 lines.

X1
(Y1 )
(Y2)

2 lines × 15 → statement can be created in 30 lines.

What are statements?
Statements include line, P and I statements.
Statements can annotate each ladder block with comments to ensure ease of understanding a sequence of the whole program.
The A/FX series has statements, and the Q/QnA series has integrated and peripheral statements.
What are notes?
Notes include integrated and peripheral notes.
Notes can be created for coils and application instructions.
The A/FX series has peripheral notes and the Q/QnA series has integrated and peripheral notes.
However, when notes are written to the Personal computer in an ACPU or GPPA format file, only the first notes of single ladder blocks are written.
On the FXGP(WIN), notes are called "coil comments".

About the integrated statements/notes
Since integrated statements/notes can be displayed or edited on GX Developer or statements be handled as part of a program, they can be written/read to/from the PLC CPU.
When performing maintenance in a factory or the like, for example, statements/notes are useful because they can be read from the PLC CPU.
However, writing integrated statements/notes to the PLC CPU requires much program memory. So, if the PLC CPU has a small free memory area, write peripheral statements instead of integrated statements.

\[
\text{Number of steps exhausted} = 2 + \frac{\text{Number of characters}}{2} \text{ steps (Round off decimals.)}
\]

A space entered in a character string is also handled as one character.

About the peripheral statements/notes
They may be displayed or edited only on GX Developer.
Peripheral statements/notes are preceded by "".
Since they are not written to the PLC CPU, the program memory area of the PLC CPU can be reduced.
However, if program correction or similar operation is performed in the field or the like, the program on GX Developer will be different from the one in the PLC CPU. Therefore, if read from PLC is performed without merging ∗, the statements on GX Developer will be discarded. (Refer to Section 10.2.)
∗: Merging indicates that a program in the PLC CPU and statements on GX Developer are combined.

[A/FX series]
The statement steps are not exhausted.
Note that statements are not written to the PLC CPU.
The P, I statements of the FX series are not written in the FXGP(DOS) or FXGP(WIN) format.

[Q/QnA series]
The number of steps exhausted is 1 independently of the number of characters.
Note that statements are not written to the PLC CPU.
[Caution when reading statements from the PLC]
When overwriting a program without statements read from the PLC to the hard disk, the program stored in the hard disk will be overwritten by the program without statements. Before reading such a program, store the program (originally retained in the hard disk) in a floppy disk.
If any program is edited on a Personal computer and written during running, program mismatching may occur.

(1) When programs are not merged
For the Q/QnA series
Peripheral statements on GX Developer are deleted.

For the A/FX series
Statements existing in the beginning of ladder blocks are merged.
If the program read to GX Developer is different from the program in the PLC CPU, statements are not added to the correct positions, resulting in a ladder creation fault. Therefore, the statements are deleted.

(2) When programs are merged
For the Q/QnA series
1) If the program on GX Developer and the program in the PLC CPU differ in step No., they are merged from the beginning.
However, if the program on GX Developer has become larger due to editing, e.g. addition/correction to the program on GX Developer or deletion to the program in the PLC CPU, the peripheral statements in the area greater than the program in the PLC CPU are deleted.

2) If integrated statements/notes exist in the program on GX Developer, they are deleted from the program on GX Developer after merging.

3) If integrated statements/notes exist in the program within the PLC CPU, they are read unchanged onto GX Developer.
For the A/FX series

1) Programs are merged independently of the positions of the statements which are added to the programs on GX Developer and in the PLC CPU. (Merging may insert statements between ladders. As it will result in an unauthorized ladder on the ladder display screen, a warning message appears. In that case, make correction in the statement block edit or list mode.)

2) If the step where a statement exists in the program on GX Developer is not found in the data within the PLC CPU, that statement is discarded.

3) When choosing [Import from GPPA format file] to merge programs, statements in the data saved in the GPPA format file are the target of merging, independently of the statements added to the program opened on GX Developer.
[Caution when reading notes from the PLC]
When overwriting a program without notes read from the PLC to the hard disk, the program stored in the hard disk will be overwritten by the program without notes. Before reading such a program, store the program, (originally retained on the hard disk) in a floppy disk.
If any program is edited on a Personal computer and written during running, program mismatching may occur.

(1) When programs are not merged
For the Q/QnA series
Peripheral notes on GX Developer are deleted.
For the A/FX series
Only the coil instructions whose step numbers of the program on GX Developer and those of the program in the PLC CPU are identical are merged.

When a program with notes exists in the peripheral device, it will be displayed with the notes added to the program stored in the PLC. The programs will not be displayed correctly if they mismatch between the peripheral device and the PLC.

(2) When programs are merged
For the Q/QnA series
Refer to the caution given for reading statements from the PLC.
For the A/FX series
Programs are merged independently of the positions where the notes on GX Developer and the notes in the PLC CPU exist.
If the program on GX Developer has become larger due to editing, e.g. addition/correction to the program on GX Developer or deletion to the program in the PLC CPU, the peripheral statements in the area greater than the program in the PLC CPU are deleted.
### 10.2 About Merging Operation Procedure

The following operation procedure is used to merge the program on GX Developer and the program in the PLC CPU. Refer to Section 15.2 when merging a file saved on an FD or the like and a program on GX Developer.

**[Operating Procedure]**

1) **Read onto GX Developer the program which is equivalent to the program written to the PLC CPU.**
   (For the Q/QnA series, merging cannot be done if the programs on the PLC and GX Developer sides have the same data name.)

2) **Read setting**
   (1) **For read from PLC**
       Choose [Online] → [Read from PLC] → "Peripheral statement/merging note". (Refer to Section 16.3.3)
   (2) **For IC memory card**
       Choose [Tools] → [IC memory card] → [Read IC memory card] → "Peripheral statement/merging note". (Refer to Section 15.5.1)
   (3) **For reading other format files**
       Choose [Project] → [Import file] → [Import from GPPA format file] → "Peripheral statement/merging note". (Refer to Section 5.14)
       After setting, click the **Execute** button.

3) **Statement/note block edit**
   After completion of reading, perform the following operation.
   Choose [Edit] → [Documentation] → [Statement/Note block edit].
   Opening the statement/note block edit screen and clicking the **OK** button moves all statements/notes to the ladder.

4) **Check whether the statements/notes of the program read to GX Developer are in the correct positions.**

5) If they are not, reselect statement/note block edit and move them to the correct position. (Refer to Section 10.5)

6) **Choose [Project] → [Name project and save] to save the program.**

### POINT

**Merging instructions**

1. Programs are merged only when the statements added to the programs on GX Developer and in the PLC CPU are both peripheral statements.
2. Programs cannot be merged if their types are different. (Ladder and SFC programs cannot be merged.)
3. Programs cannot be merged if the program on GX Developer and the program written to the PLC CPU do not match in PLC type.
4. SFC programs cannot be merged.
10.3 Creating and Deleting Statements

10.3.1 When editing the circuit window

10.3.1(1) Creating statements in the circuit edit window

[Operating Procedure]

1. Enter the Insert key to set the insert mode.

2. Move the cursor to the position shown in the following figure.

3. By entering a semicolon ";" the circuit input dialog box is displayed to enable the user to enter a statement.

4. After entering the statement, press the Enter key or click the OK button.

POINTS

- For switching integrated statements/peripheral statements on the Q/QnA series, see Section 6.4.12.
- For displaying statements created, see Section 3.9.
10.3.1(2) Deleting statements in the circuit edit window

[Operating procedure]
1. Move the cursor to the statement to be deleted, and press *Delete* key.

2. After the statement has been deleted, convert the program.

---

[Diagram of ladder logic]

*Green lamp light on*
10.3.2 When editing the list window

10.3.2(1) Editing statements on the list edit window

1. Move the cursor to the head of the position to which a statement will be added. (Move the cursor to the head of the circuit block of a circuit.)

2. By entering a semicolon ";", the list input dialog box is displayed.

    Enter list

    PI: P, I statement → ENTER key or OK key

    Enter a desired statement.

3. Create a statement within up to 64 characters. Up to 255 characters can be entered in the text box.

POINTS

- Statements will be displayed in the list mode at all times (it is impossible to not display statements).
- For integrated statements and peripheral statements, see Section 10.1.
10.3.2(2) Deleting statements on the list edit window

1. Move the cursor to the statement to be deleted.

<table>
<thead>
<tr>
<th>1</th>
<th>MOV X0 X1</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>MOV X0 X7 X10</td>
</tr>
<tr>
<td>13</td>
<td>OUT C1</td>
</tr>
<tr>
<td>14</td>
<td>LD X0</td>
</tr>
<tr>
<td>15</td>
<td>END X4</td>
</tr>
<tr>
<td>16</td>
<td>AND X0</td>
</tr>
<tr>
<td>17</td>
<td>OR X0</td>
</tr>
<tr>
<td>18</td>
<td>ANX X0</td>
</tr>
<tr>
<td>21</td>
<td>OR X0 Y0</td>
</tr>
<tr>
<td>24</td>
<td>AND X0</td>
</tr>
<tr>
<td>25</td>
<td>OUT X0</td>
</tr>
<tr>
<td>26</td>
<td>AND X0</td>
</tr>
<tr>
<td>27</td>
<td>OR X0 Y0</td>
</tr>
<tr>
<td>28</td>
<td>SET X0</td>
</tr>
<tr>
<td>29</td>
<td>AND X0</td>
</tr>
<tr>
<td>30</td>
<td>OR X0 Y0</td>
</tr>
<tr>
<td>31</td>
<td>AND X0</td>
</tr>
<tr>
<td>32</td>
<td>OR X0 Y0</td>
</tr>
<tr>
<td>33</td>
<td>END</td>
</tr>
</tbody>
</table>

2. Press [Delete] key or [Shift] + [Delete] key.
10.3.3 Creating statements in the statement edit mode

[Purpose]
Statements can be created easily

[Operating Procedure]
1. [Edit] → [Documentation] → [Statement] (AQ 3 68 )
2. Move the cursor to the ladder block where you want to attach a statement.
3. Pressing [Enter] shows the following dialog box.

   ![Enter line statements dialog box]

4. Enter a statement and click the [OK] button.

   ![Enter line statements dialog box]

5. Providing a statement display shows the following ladder.

   ![Ladder diagram]

[POINT]
To cancel the statement edit mode, choose this menu again and uncheck the checked menu item.
10.4 Creating and Deleting Notes

10.4.1 Creating notes on the circuit edit window

10.4.1 (1) Creating notes on the circuit edit window

[Operating procedure]

1. Press [Insert] key to set the overwrite mode.
   Note that a circuit will be added by creating a note in the insert mode.

2. Move the cursor to the position shown in the following figure.

3. By pressing [Enter] key, the following dialog box is displayed.

4. Add a semicolon ";" after Y1, and enter a note.

5. After the note has been entered, press [Enter] key or click the [OK] button.

 POINTS

• For switching integrated notes and peripheral notes on the Q/QnA series, see Section 6.4.12.
• For displaying notes created, see Section 3.10.
10 SETTING THE STATEMENTS AND NOTES

10.4.1 (2) Deleting notes in the circuit edit window

[Operating procedure]

1. Press [Insert] key to set the overwrite mode.

2. Move the cursor to the note to be deleted, and press [Enter] key or double-click the [mouse] button.

3. Delete the statement Green lamp lights when operation preparations are completed. after the semicolon ;.

4. After the statement has been deleted, press the [Enter] key or click the [OK] button.
10.4.2 (1) Creating notes in the list edit window

[Operating procedure]
1. Move the cursor to the head of the position to which a note will be added. (Move the cursor to the head of the circuit block of a circuit.)

2. By entering a semicolon ";", the list input dialog box appears.

3. Create a note within up to 64 characters. Up to 255 characters can be entered in the text box.

POINTS
- Notes will be displayed in the list mode at all times (it is impossible to not display statements).
- For integrated notes and peripheral notes, see Section 10.1.
10.4.2 (2) Deleting notes in the list edit window

[Operating Procedure]

1. Move the cursor to the note to be deleted.

2. Press Delete key or Shift + Delete key.
10.4.3 Creating notes in the note edit mode

[Purpose]
Notes can be created easily

[Operating procedure]
1. [Edit] → [Documentation] → [Note] (AQ/QmA)
2. Move the cursor to the coil/application instruction where you want to attach a note.
3. Pressing [Enter] shows the following dialog box.

![Enter Note dialog box]

4. Enter a note and click the [OK] button.

![Enter Note dialog box with note entered]

5. Providing a note display shows the following ladder.

![Ladder diagram with note]

**POINT**
To cancel the note edit mode, choose this menu again and uncheck the checked menu item.
10.5 Batch-Editing the Statements/Notes

[Purpose]
You can batch-create multiple statements/notes. The position of statement/note can be changed easily.

[Operating Procedure]
Select [Edit] → [Documentation] → [Statement/Note block edit].

[Dialog Box]

[Description]
1) Type
   * : No  Integrated statement/note
   * : Yes Peripheral statement/note
   When changing the type, move the cursor to the line where you want to make a change, choose the Type (integrated/peripheral), and click the [Change type] button.

2) Step
   Shows the steps or device numbers where the corresponding statements/notes exist.
   Statement  : The number of first steps in all ladder blocks in the program are displayed.
   Note  : The number of steps equivalent to all coils in the program are displayed.
   P statement  : The pointer number existing in the program is displayed.
   I statement  : The pointer number existing in the program is displayed.
3) Insert line  
Inserts one line or selected lines of blank statements above the line at the cursor.

```
  1  2  3  4  5
  |  |  |  |  |
   O  | STATEMENT |
   1  |          |
   1  |          |
   1  |
```

   Insert line

```
  1  2  3  4  5
  |  |  |  |  |
   O  | STATEMENT |
   1  |          |
   1  |          |
   1  |
```

4) Add line  
Inserts one line or selected lines of blank statements under the line at the cursor.  
The inserted statement or statements are added to the ladder block at the cursor.

```
  1  2  3  4  5
  |  |  |  |  |
   O  | STATEMENT |
   1  |          |
   1  |          |
   1  |
```

   Add line

```
  1  2  3  4  5
  |  |  |  |  |
   O  | STATEMENT |
   1  |          |
   1  |          |
   1  |
```

5) Delete line  
Deletes the line of statement at the cursor or the selected lines of statements.

```
  1  2  3  4  5
  |  |  |  |  |
   O  | STATEMENT |
   1  |          |
   1  |          |
   1  |
```

   Delete line

```
  1  2  3  4  5
  |  |  |  |  |
   O  | STATEMENT |
   1  |          |
   1  |          |
   1  |
```
6) Move

If the statements/notes are not added to the correct positions after merge processing, they are moved to the positions which meet the purpose of the sequence program.

(1) Moving in line unit
   For the [Top] button
   Moves the statements/notes between the cursor line and bottom line up one line.
   For the [Bottom] button
   Moves the statements/notes between the cursor line and top line down one line.

   In the following example, the statements are moved up.

   ![Diagram showing statements moved up]

(2) Moving in ladder unit
   For the [Top] button
   Moves the statements/notes between the ladder block at the cursor and the bottom line up one ladder block.
   For the [Bottom] button
   Moves the statements/notes between the ladder block at the cursor and top line down one ladder block.

   In the following example, the statements are moved down.

   ![Diagram showing statements moved down]
7) Search  
   Makes a search up or down line by line relative to the cursor.

8) Jump  
   Searches for the ladder having the statement specified by the cursor.

<table>
<thead>
<tr>
<th>POINTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>• If a statement is created in other than the beginning of a ladder block, its step number is changed for the first step number of the ladder block and displayed when the dialog box is opened. Clicking the [OK] button moves the statement to the beginning of the ladder block.</td>
</tr>
<tr>
<td>• You cannot create a statement/note in the ladder block which does not exist in the program.</td>
</tr>
<tr>
<td>• An SFC allows only notes to be created.</td>
</tr>
<tr>
<td>• Do not edit the statements which are added for macro diversion.</td>
</tr>
</tbody>
</table>
11. SETTING DEVICE MEMORY (DWR SETTING)

11.1 Device Memory

Using device memory, data (for example, data registers, link registers, and file registers) can be set online or read from the PLC and edited.

Although setting data using device memory makes it unnecessary to create a program for initial setting using the sequence program, the original data will be overwritten with the operating values which will be written when the PLC is running. It is necessary to re-write data when the PLC mode is switched from reset to run.

- When data is not set using device memory

```
MOV1234 D0
MOV 5678 D1
MOV1 D10
MOV0 D11
MOV4 D12
```

The above program is required.

- When device memory is set

```
{MOV1234 D0}
{MOV5678 D1}
{MOV1 D10}
{MOV0 D11}
{MOV4 D12}
```

The above program is not required.

**POINT**

- On the Q/QnA series, initial device values can be set using device memory. Refer to the following manuals for the device init.
  QnA series: QnA Programming Manual (Fundamentals)
  Q series: QCPU User’s Manual
  (Function Explanations, Program Fundamentals)
11.2 Device Value Input

[Purpose]
Changes word device data in batch.

[Operating Procedure]
Select [Project] → [Edit data] → [New], and set the data type (device memory), the name of the data to be added, and the comment.

[Dialog Box]

[Description]
1) Device name
The types of devices that can be edited are listed below:

<table>
<thead>
<tr>
<th>A series</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timer (Current value)</td>
<td>T</td>
</tr>
<tr>
<td>Counter (Current value)</td>
<td>C</td>
</tr>
<tr>
<td>Retentive timer</td>
<td>ST</td>
</tr>
<tr>
<td>Data register</td>
<td>D</td>
</tr>
<tr>
<td>Special register</td>
<td>SD</td>
</tr>
<tr>
<td>Link register</td>
<td>W</td>
</tr>
<tr>
<td>File register</td>
<td>R</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Q/QnA series</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timer (Current value)</td>
<td>T</td>
</tr>
<tr>
<td>Counter (Current value)</td>
<td>C</td>
</tr>
<tr>
<td>Retentive timer</td>
<td>ST</td>
</tr>
<tr>
<td>Data register</td>
<td>D</td>
</tr>
<tr>
<td>Special register</td>
<td>SD</td>
</tr>
<tr>
<td>Link register</td>
<td>W</td>
</tr>
<tr>
<td>Link special register</td>
<td>SW</td>
</tr>
<tr>
<td>File register</td>
<td>R</td>
</tr>
<tr>
<td>Through file register</td>
<td>ZR</td>
</tr>
<tr>
<td>I/O No. setting</td>
<td>U***/G***</td>
</tr>
<tr>
<td>Link No. setting</td>
<td>J***/W****</td>
</tr>
</tbody>
</table>
FX series

<table>
<thead>
<tr>
<th>Device Name</th>
<th>Symbol</th>
<th>FX0</th>
<th>FX1</th>
<th>FX1S</th>
<th>FX1N</th>
<th>FX2N</th>
<th>FX2NC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data register</td>
<td>D</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>Special data register</td>
<td>D</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>File register</td>
<td>D</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>RAM file register</td>
<td>D</td>
<td>O</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
</tbody>
</table>

- Can be edited - : No corresponding device.

2) Display button
Click this button after a device has been set.

3) Display switching
You can change the screen values to the 16-bit integer, 32 bit integer, fixed decimal point or floating decimal point.

4) Display switching
Switches the display form on the edit screen between decimal and hexadecimal.

5) Device Value Input
The device value input ranges are as follows.

<table>
<thead>
<tr>
<th>Display Format Changing</th>
<th>Numeric Input Range</th>
</tr>
</thead>
<tbody>
<tr>
<td>16-bit integer</td>
<td>Decimal: -32768 to 32767</td>
</tr>
<tr>
<td></td>
<td>Hexadecimal: 0000 to FFFF</td>
</tr>
<tr>
<td>32-bit integer</td>
<td>Decimal: -2147483648 to 2147483647</td>
</tr>
<tr>
<td></td>
<td>Hexadecimal: 00000000 to FFFFFFFF</td>
</tr>
</tbody>
</table>
| Fixed decimal point     | According to the number of integer part digits
<Example>
If the number of integer part digits is 9
0, 0.01 to 999999999
-999999999 to -0.01

Floating decimal point

-3.402823e+38 to 3.402823e+38

To enter a character string (ASCII) in the device value input field, move the cursor to the desired device number and set the data. The number of characters accepted is 64.

POINTS

- When setting device memory in a Personal computer
  Data can be edited or stored, irrespective of the parameter setting range.
- When writing data to the PLC
  Data will be written within the parameter setting range.
6) Character string input field
Move the cursor to the position where you want to set data, and enter the characters or press the space key. The following dialog box then appears.

![Character string input dialog box](image)

The maximum number of characters that may be entered is 64.

If there is the existing data, the 16 characters of the character string in the selected position appear as a default.

Enter the character string (ASCII) data as follows.
Example: To set "Device memory input"
Entering "Device memory input" in the D0 to D7 position of the character string input column sets the data, starting from D0.

The first setting position of data is always the device number of a multiple of 8, e.g. D0, D8, D16 ...

![Data which cannot be converted to string character](image)

When copying/pasting the character string field that has no data, the following dialog box appears.

Note that clicking the **OK** button will set "." (2E2EH) as data.

7) Device number change (ZR only)
When setting ZR, click the ▼ or ▲ button to change the device number in steps of 32K points.

### POINTS
- When setting the device memory on a Personal computer
  You can edit or save without following the parameter setting range.
- When performing PC write
  Write the range set in the parameter.
- Refer to Section 6.4 for retrieval and substitution of device memory.
- A2N(S1), A2A(S1), A2U(S1), and A2US(S1) are set so that the default value of the device memory is 1024 points at the read/write to them. Change the range setting to within 512 points when data is read or written to A2N, A2A, A2U, or A2US.
11.3 All Clear

11.3.1 Clearing all devices

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

[Purpose]
Clears all device values for which device memory is set.

[Operating Procedure]
Display the device memory edit window, and select [Edit] → [Clear all (all clear)].

11.3.2 Clearing all display devices

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

[Purpose]
Clears device values displayed in the window, for which device memory is set.

[Operating Procedure]
Display the device memory edit window, and select [Edit] → [Clear all (displayed devices)].
11.4 Making Fill Settings

[Purpose]
Writes the same data to consecutive devices in batch.

[Operating Procedure]
Display the device memory edit window, and select [Edit] → [FILL] or press \( \text{FILL} \).

[Dialog Box]

[Description]
1) **FILL Range**
   Designates the devices to which the same data will be batch-written.
   <Example of device designation>
   D10-D20, T0-T30

2) **FILL data**
   Designates the data to be batch-written.
   Designate the data in the numeric form on the device memory edit window.

3) **[OK]** button
   Click this button after the setting has been completed.
12. SETTING DEVICE INITIALIZATION VALUES

[Purpose]
Utilizes the device values set in the device memory edit dialog box as device initialization values.

[Operating Procedure]
Set the type and name of the data to be added in the dialog box displayed by selecting [Project] → [Edit data] → [New].

[Dialog Box]

[Description]
1) Range to be set
Up to 8,000 points (8K words) can be set within a range. Each comment can be set within 32 characters.

The devices, which can be treated as initial values, are listed below:

<table>
<thead>
<tr>
<th>Device Name</th>
<th>Device</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timer</td>
<td>The present value of T.</td>
</tr>
<tr>
<td>Retentive Timer</td>
<td>The present value of ST.</td>
</tr>
<tr>
<td>Counter</td>
<td>The present value of C.</td>
</tr>
<tr>
<td>Data register</td>
<td>D</td>
</tr>
<tr>
<td>Special register</td>
<td>SD</td>
</tr>
<tr>
<td>Link register</td>
<td>W</td>
</tr>
<tr>
<td>Link special register</td>
<td>SW</td>
</tr>
<tr>
<td>File register</td>
<td>R, ZR</td>
</tr>
<tr>
<td>Special direct device</td>
<td>U*/G*</td>
</tr>
<tr>
<td>Link direct device</td>
<td>J*/W*, J*/SW*</td>
</tr>
</tbody>
</table>
2) Setting method
   Set the range of the devices to be set for device initial values by specifying
   [Start/End] or [No. of point/start] Device

3) Device memory registration diversion
   - All devices
     All devices set in the device initial value range setting dialog box are entered
     as device initial values.
   - Range to be set
     Choose the necessary device range out of the devices set in the device initial
     value range setting dialog box, and enter it as device initial values.
     Since the devices set in the device initial value range setting dialog box can
     be candidates, the devices not entered cannot be set.
     <Example>
     D0-D10, W0-W30

   - Register to device memory button
     The data set to the device initial values are reflected on the device memory.
     The data not set to the device initial values are not reflected.

4) OK button
   Click this button after the setting has been completed.

[Operating procedure] (Device data diversion)
1. Create new device memory.
2. Create device initial values in the device memory edit dialog box.
3. Create new device initial values.
4. Set the device initial values in the device initial value range setting dialog box.
5. Click the Device memory diversion button.
6. Choose All devices or Range to be set and click the Execute button.
7. Click the OK button in the device initial value range setting dialog box.
   If you click Cancel, the data are not reflected.

POINT

- To treat each device value, to which the range is set, as an initial value when
  starting the PLC, use the PLC file setting function for PLC parameters.
13. SETTING THE PARAMETERS

This manual explains only operations for the parameters. For any information or particular explanation required for parameter setting, refer to the corresponding CPU user's manual and programming manual to pre-design them. The setting items are assigned to the tab screen purpose-by-purpose.

**Remarks**

The following comparison table indicates the parameter item setting locations of GPPA and GX Developer because of the differences between them.

<table>
<thead>
<tr>
<th>GPPA</th>
<th>FXGP (DOS)</th>
<th>FXGP (WIN)</th>
<th>GX Developer</th>
</tr>
</thead>
<tbody>
<tr>
<td>LATCH RANGE</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Supplementary settings</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>STEP RELAY, TIMER, COUNTER</td>
<td>Device</td>
<td>Device</td>
<td>PLC system</td>
</tr>
<tr>
<td>RUN-PAUSE contacts, Output mode at STOP to RUN, Interrupt counter</td>
<td>PLC RAS</td>
<td>PLC name setting</td>
<td></td>
</tr>
<tr>
<td>WDT setup, Operating mode when there is an error, Annunciator display mode</td>
<td>PLC RAS</td>
<td>PLC system setting (1)</td>
<td></td>
</tr>
<tr>
<td>Data communications request batch processing</td>
<td>PLC system</td>
<td>PLC system setting (2)</td>
<td></td>
</tr>
<tr>
<td>MINI automatic refresh setting</td>
<td>Network parameter</td>
<td>Network parameter</td>
<td></td>
</tr>
</tbody>
</table>

The following comparison table indicates the parameter item setting locations of FXGP(DOS), FXGP(WIN) and GX Developer because of the differences between them.

<table>
<thead>
<tr>
<th>FXGP (DOS)</th>
<th>FXGP (WIN)</th>
<th>GX Developer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Latch range</td>
<td>Latch range</td>
<td>Device setting</td>
</tr>
<tr>
<td>Program title setting</td>
<td>Print title setting</td>
<td>PLC mode setting</td>
</tr>
<tr>
<td>PLC mode setting</td>
<td>PLC mode setting</td>
<td>PLC system setting (1)</td>
</tr>
<tr>
<td>Serial communication setting</td>
<td>Serial communication setting</td>
<td>PLC system setting (2)</td>
</tr>
<tr>
<td>—</td>
<td>—</td>
<td>Device assignment</td>
</tr>
<tr>
<td>—</td>
<td>—</td>
<td>I/O assignment setting</td>
</tr>
</tbody>
</table>
<Network parameter screen examples>

[MELSECNET/Ethernet setting screen] (for Q series)

- [MELSECNET/Ethernet setting screen] (for Q series)

[MELSECNET/MINI setting screen] (for QnA series)

- [MELSECNET/MINI setting screen] (for QnA series)

[CC-Link setting screen] (for Q series)

- [CC-Link setting screen] (for Q series)
13.1 Setting the PLC Parameters

The following table lists the PLC parameter setting items on a series basis. Set the parameters as required.

<table>
<thead>
<tr>
<th>PLC name</th>
<th>A</th>
<th>QnA</th>
<th>QCPU</th>
<th>Remote I/O</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>PLC system</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PLC file</td>
<td>x</td>
<td>o</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PLC RAS</td>
<td>o</td>
<td>o</td>
<td>o</td>
<td>o</td>
<td>x</td>
</tr>
<tr>
<td>Device</td>
<td>o</td>
<td>o</td>
<td>o</td>
<td>x</td>
<td>o</td>
</tr>
<tr>
<td>Program</td>
<td>x</td>
<td>o</td>
<td>o</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Boot file</td>
<td>x</td>
<td>o</td>
<td>o</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>SFC</td>
<td>x</td>
<td>o</td>
<td>x</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>I/O assignment</td>
<td>o</td>
<td>o</td>
<td>o</td>
<td>o</td>
<td></td>
</tr>
<tr>
<td>Memory capacity</td>
<td>o</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Operational settings</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>o</td>
<td>x</td>
</tr>
</tbody>
</table>
13.1.1 Common Notes on Parameters

[Parameter display]
This part describes the setting item tabs and network parameter setting items.

<Example>

The meanings of the symbols are the same also when displayed with network parameters.

Red : The PLC does not operate until data is set. (Data is not set.)
Blue : Data is set.
Magenta : The PLC operates without setting data or with the default. (Data is set.)
Dark blue : Data is set. (Data is set.)

[Common notes on parameters]
This part describes the settings common to PLC and network parameters.

**Default** button
Returns all of the set items or values to the previous settings.
This button is available only for the currently open tab.

**Check** button
Used to check the set items or values to see if they are correct.
This button is available only for the currently open tab.

**End setup**
Defines the set items or values and terminates the setting.

**Cancel** button
 Cancels the set items and terminates editing.
### Acknowledge X/Y Assignment button

This button is available for the models A2ACPU(S1), A3ACPU, A2AS(S1), A2AS-S30, A2AS-S60, A2UCPU(S1), A2USCPU(S1), A2USHCPU(S1), A3UCPU, A4UCPU, and QnACPU, QCPU(Q mode).

It is used to confirm the X/Y assignment numbers of the data set in the I/O assignment setting.

### Display by type

<table>
<thead>
<tr>
<th>Display</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>I/O assignment</td>
<td>Displays I/O assignment information.</td>
</tr>
<tr>
<td>MINI</td>
<td>Displays I/O assignment information and MINI automatic refresh setting information.</td>
</tr>
<tr>
<td>CC-Link</td>
<td>Displays I/O assignment information and CC-Link automatic refresh setting information.</td>
</tr>
<tr>
<td>NET (II)</td>
<td>Master station: Displays I/O assignment information and refresh parameter information.</td>
</tr>
<tr>
<td>Local station</td>
<td>Displays I/O assignment information and refresh parameter information.</td>
</tr>
<tr>
<td>NET/10</td>
<td>PLC-to-PLC network, remote I/O network: Displays network parameter information.</td>
</tr>
</tbody>
</table>

The priority of display is shown below:
1. I/O assignment (AnACPU, AnUCPU, Q/QnA series)
2. Fourth MELSECNET network refresh parameter (AnUCPU, Q/QnA series)
3. Third MELSECNET network refresh parameter (AnUCPU, Q/QnA series)
4. Second MELSECNET network refresh parameter (AnUCPU, Q/QnA series)
5. First MELSECNET network refresh parameter (AnUCPU, Q/QnA series)
6. MELSECNET/MINI refresh (AnACPU, AnUCPU, QCPU (A mode)/QnA series)
7. CC-Link remote I/O (Q/QnA series)

The Duplicate Error area displays the first duplicate item detected in checking the items according to the priority.

<table>
<thead>
<tr>
<th>Duplicate Error</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>First NET</td>
<td>First MELSECNET network parameter</td>
</tr>
<tr>
<td>Second NET</td>
<td>Second MELSECNET network parameter</td>
</tr>
<tr>
<td>Third NET</td>
<td>Third MELSECNET network parameter</td>
</tr>
<tr>
<td>Fourth NET</td>
<td>Fourth MELSECNET network parameter</td>
</tr>
<tr>
<td>MINI</td>
<td>MELSECNET/MINI refresh</td>
</tr>
<tr>
<td>CC-Link</td>
<td>CC-Link remote I/O</td>
</tr>
</tbody>
</table>
**Multiple PLC setting** button  
Setting cannot be made for remote I/O projects.

### Multiple PLC setting

- **No.of PLC**  
  Set one to four modules.

- **Out group input settings**  
  Set whether the input of the module outside the group is permitted or not.

- **Operating mode**  
  Set the operation (stop) at a PLC stop error.

- **Refresh settings**  
  Set the CPU shared memory G between multiple CPUs.  
  Usable devices...B, M, Y, D, W, R, ZR

[Description]

No. of PLC  
Clicking the [Default] button in I/O assignment keeps the multiple PLC setting unchanged.  
When the set number of PLCs is one, a multiple CPU system configuration is not set.

Out group input settings  
When the modules are not grouped, they are all put under the control PLC of the PLC No. 1.  
OPERATION ERROR appears if access is made to any module outside the groups.

Refresh settings  
The maximum input range of each module is 0 to 2048 points.  
Set the total number of all modules to within 4096 points.

[Diversion of multiple PLC parameter] button  
Specify the project to be diverted from the project opening screen. Setting the source project shows the multiple PLC parameter setting dialog box.
13.1.2 PLC Parameter Item Lists

The PLC parameter items of each series are listed below.

(1) PLC parameter item list of the Q series

### PLC system

- **Device Label**
  - Set the CPU label.

- **Comment**
  - Set the CPU comment.

- **Timer limit setup**
  - Set the time limits of the low-/high-speed timers.

- **RUN-PAUSE contacts**
  - Make setting to control RUN/PAUSE of the CPU.

- **Remote reset**
  - Set enable/disable of remote reset operation.

- **Output mode at STOP to RUN**
  - Set the output mode at STOP to RUN.

- **Floating point arithmetic processing**
  - Make setting to perform floating point arithmetic operation at high speed.

- **Intelligent functional module setting**
  - Set the assignment of the interrupt pointers (I50 to I255) and the first I/O No. and first SI No. of the intelligent function unit.

- **Common pointer**
  - Set the first No. of the common pointers.

- **Number of empty slots**
  - Set the number of empty slots.

- **System interrupt settings**
  - Set the first No. of the interrupt counters and the fixed scan intervals of the interrupt pointers.

- **Interrupt program/Fixed scan program setting**
  - Set whether the interrupt/fixed scan program is run at high speed or not.

- **Unit synchronization**
  - Set whether the start of the QCPU is synchronized with that of the intelligent function unit.

- **Compatibility with A-PLC**
  - Set whether the special relays/special registers for MELSEC-A series (SM1000/SD1000 and later) are used or not.

### PLC file

- **File register**
  - Set the file register file to be used.

- **Comment file used in a command**
  - Set the comment file to be used in a command.

- **Device initial value**
  - Set the device initial value file to be used.

- **File for local device**
  - Set the local device file to be used.

### Device

- **Dev. point**
  - Set the number of device points to be used.

- **Latch [1] start**
  - Set the latch range valid for latch clear key operation.

- **Latch [2] start**
  - Set the latch range invalid for latch clear key operation.

- **Local dev. start**
  - Set the range of the device used as a local device.
PLC RAS

- WDT [Watchdog timer] setup
  - WDT setting
  - Initial execution
- Low speed execution
  Make WDT settings of the CPU.
- Error check
  Set whether the specified error is to be detected or not.
- Operating mode when there is an error
  Set the display mode of the CPU on detection of an error.
- Constant scanning
  Set the constant scan time.
- Low speed program execution time
  Set the time for execution of a low-speed program.
- Breakdown history
  Set the storage target of the CPU's breakdown history.

Program

- Program
  Set the execution type for use of multiple programs.

Boot file

- Boot file setup
  Set the boot-run file, etc.

SFC

- SFC
  Make various settings needed for an SFC program.

I/O assignment

- I/O assignment
  - Set each unit loading status of the system.
  - Make switch settings of the intelligent function module.
  - Reserve the multiple CPUs.
  (Refer to the items common to the PLC parameters for the multiple PLC setting.)

Standard setting

- Standard setting
  Set the base model, power supply module model, etc.
(2) PLC parameter item list for Q series remote I/O station

**PLC system settings**
- Number of vacant slot points
  - Set the number of vacant slot points.
- Module synchronization setting
  - Set whether a QCPU startup is synchronized with an intelligent function module startup or not.

**PLC RAS settings**
- Error check
  - Set whether the specified error will be detected or not.
- Operating mode when there is an error
  - Set whether operation will be stopped or not at occurrence of a fuse blown or I/O module comparison error.

**Operation settings**
- Remote I/O station switch settings
  - Set cyclic communication error-time output hold and output hold designation enable.
- Inter-device transfer parameters
  - Set the link device range, etc. for communication with the I/O and special function modules of each remote I/O station.

**I/O assignment settings**
- I/O assignment settings
  - Set the module loading states of the system.
  - Make the switch settings of the intelligent function module.
- Basic settings
  - Set the base type, power supply module type, etc.
### (3) PLC parameter item list of the QnA series

<table>
<thead>
<tr>
<th>PLC name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device label</td>
<td>Set the CPU label.</td>
</tr>
<tr>
<td>Comment</td>
<td>Set the CPU comment.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>PLC system</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timer limit setup</td>
<td>Set the time limits of the low-/high-speed timers.</td>
</tr>
<tr>
<td>RUN-PAUSE contacts</td>
<td>Make setting to control RUN/PAUSE of the CPU.</td>
</tr>
<tr>
<td>Remote reset</td>
<td>Set enable/disable of remote reset operation.</td>
</tr>
<tr>
<td>Output mode at STOP to RUN</td>
<td>Set the output mode at STOP to RUN.</td>
</tr>
<tr>
<td>General data processing</td>
<td>Set the number of units to be handled by single general data processing.</td>
</tr>
<tr>
<td>Common pointer</td>
<td>Set the first No. of the common pointers.</td>
</tr>
<tr>
<td>Number of empty slots</td>
<td>Set the number of empty slots.</td>
</tr>
<tr>
<td>System interrupt settings</td>
<td>Set the first No. of the interrupt counters and the fixed scan intervals of the interrupt pointers.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>PLC file</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File register</td>
<td>Set the file register file to be used.</td>
</tr>
<tr>
<td>Comment file used in a command</td>
<td>Set the comment file to be used in a command.</td>
</tr>
<tr>
<td>Device initial value</td>
<td>Set the device initial value file to be used.</td>
</tr>
<tr>
<td>File for local device</td>
<td>Set the local device file to be used.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Device</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dev. point</td>
<td>Set the number of device points to be used.</td>
</tr>
<tr>
<td>Latch [1] start</td>
<td>Set the latch range valid for latch clear key operation.</td>
</tr>
<tr>
<td>Latch [2] start</td>
<td>Set the latch range invalid for latch clear key operation.</td>
</tr>
<tr>
<td>Local dev. start</td>
<td>Set the range of the device used as a local device.</td>
</tr>
</tbody>
</table>
SETTING THE PARAMETERS

- **PLC RAS**
  - WDT [Watchdog timer] setup
    - WDT setting
    - Initial execution
  - Low speed execution
    - Set the WDT timers of the CPU.
  - Error check
    - Set whether the specified error is to be detected or not.
  - Operating mode when there is an error
    - Set the display mode of the CPU on detection of an error.
  - Constant scanning
    - Set the constant scan time.
  - Low speed program execution time
    - Set the time for execution of a low-speed program.
  - Annunciator display mode
    - Display F No.
    - Display comment
    - Display occurrence time
    - Set the display mode established when the annunciator has turned on.
  - Breakdown history
    - Set the storage target of the CPU's breakdown history.

- **Program**
  - Set the execution type for use of multiple programs.

- **Boot file**
  - Boot file setup
    - Set the boot-run file, etc.

- **SFC**
  - Make various settings needed for an SFC program.

- **I/O assignment**
  - I/O assignment
    - Set each unit loading status of the system.
  - Standard setting
    - Set the base model, power supply unit model, etc.
(4) PLC parameter item list of the A series

**Memory capacity**
- Program capacity
  - Set the main, sub, microcomputer and other capacities.
- Comment
  - Set the comment capacity.
- Expanded comment
  - Set the extended comment capacity.
- File register
  - Set the file register capacity.
- Capacity for debugging
  - Set the sampling trace and status latch capacities.
- Memory capacity information
  - Display the total of memory to be used.

**PLC system**
- RUN-PAUSE contacts
  - Set the contacts which control RUN/PAUSE of the CPU.
- System interrupt setup
  - Set the range of the counter used in an interrupt program.
- Output mode at STOP to RUN
  - Set the output status at STOP to RUN.
- Data communications request batch processing
  - Set whether the transient communications request is processed or not in the END processing of its scan.
- Remote I/O setting for A2C PLC
  - Set the occupied slot count and remote I/O assignment of each station when the A2C/A2CJCPU is selected.

**PLC RAS**
- WDT setup
  - Set the WDT.
- Operating mode when there is an error
  - Set whether operation will be stopped or continued at occurrence of a fuse blow, operation error, I/O unit verify error or special unit access error.
- Annunciator display mode
  - Set whether annunciator display is provided or not.

**I/O assignment**
- I/O assignment
  - Set the type (empty, input, output, special), model and points.

**Device**
- Device setup
  - Set the points and latch range of each device used in a sequence program.
(5) PLC parameter item list of the FX series

**Memory capacity**
- Memory capacity
  - Set the memory capacity that the PLC has.
- Comment capacity
  - Set the comment capacity.
- File register capacity
  - Set the file register capacity.
- Program capacity
  - Set the sequence program capacity.

**Device**
- Device setup
  - Set the latch range.

**PLC name**
- PLC name
  - Comment the PLC program.

**I/O assignment**
- I/O assignment
  - Set the first/last values of the I/O relays.

**PLC system (1)**
- Battery less mode
  - Make this setting when performing operation without the memory backup battery of the FX2N or FX2NC PLC.
- MODEM initialized
  - Set the modem initialization command when making remote access to the FX2N or FX2NC PLC.
- RUN terminal input
  - When using the input (X) of the FX2N or FX2NC PLC as the external RUN/STOP terminal, set its input number.

**PLC system (2)**
- Protocol
  - Set the communication protocol.
- Data length
  - Set the data length.
- Parity
  - Set the parity.
- Stop bit
  - Set the stop bit.
- Baud rate
  - Set the baud rate.
- Header
  - Set the header.
- Terminator
  - Set when making the terminator valid.
- Control line
  - Set when making the control line valid.
- H/W type
  - Normally choose RS-232C or RS-485.
- Control mode
  - Display the control mode data.
- Sum check
  - Set when adding sum check.
- Transmission control procedure
  - Choose format 1/format 4.
- Station number setting
  - Make station number setting.
- Time out judge time
  - Set the time-out period.
13.1.3 Explanations for PLC Parameter Setting Screen

The following items are related to network parameter setting.

1. **Read PLC data** button
   
   **Location of Read PLC data button**
   
   [PLC parameter] → (I/O assignment) tab

   **For Q series**
   
   The implementation status is read if the parameter file exists in the PLC.
   
   If the unit model, first X/Y, base model, power supply unit model, extension cable model and slot count have been set on the Personal computer, the data will be deleted.
   
   If the parameters have been set on GX Developer, the following dialog box appears to ask you if the parameter data may be overwritten.

   ![GX Developer dialog box](image)

   **For QnA series**
   
   When the parameter file exists in the PLC
   
   - The parameter file is read.

   When the parameter file does not exist in the PLC (implementation read)
   
   - After deleting the parameter file in the PLC, set the PLC from RESET to RUN and read the PLC data.
   
   If the unit model, first X/Y, base, power supply unit and extension cable have been set on the Personal computer, the data will be deleted.
13.2 Setting the Network Parameters

The following table lists the network parameter setting items on a series basis. Set the parameters as required.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>O</td>
<td>O</td>
<td>×</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Protocol</th>
<th>AnNCPU</th>
<th>AnACPU</th>
<th>AnUCPU</th>
<th>QnA</th>
<th>CPU</th>
<th>Remote I/O</th>
</tr>
</thead>
<tbody>
<tr>
<td>MELSECNET</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>MELSECNET II</td>
<td>×</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>MELSECNET/10H</td>
<td>×</td>
<td>×</td>
<td>O</td>
<td>O</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>MELSECNET/MINI</td>
<td>×</td>
<td>×</td>
<td>×</td>
<td>×</td>
<td>O</td>
<td>×</td>
</tr>
<tr>
<td>CC-Link</td>
<td>×</td>
<td>×</td>
<td>×</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>Ethernet</td>
<td>×</td>
<td>×</td>
<td>×</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
</tbody>
</table>
13.2.1 About Items Common to the Network Parameters

[Purpose]
This section describes operations common to the setting of data link system and network system parameters. The setting examples use MELSECNET II comp (Master station) and MELSECNET/10 network range assignment parameters. The following operations cannot be performed as those common to the parameters.
- Cut, copy, paste
- Home and End keys are invalid.

[Dialog Box]
<Example> MELSECNET II combined (master station) network range assignment parameter setting window

[Description]
Specify local / Specify remote / Specify MNET II local button
Move the cursor to the L/R station No. to be specified, and click the corresponding button.

Assign the same point to each station button
Used to assign the same point to each local station.

Clear button
Used to default the preset parameters.

Check button
Used to check the preset parameter data.

End setup button
Clicking this button at the end of data setting returns to the network setting screen.
13 SETTING THE PARAMETERS

[Dialog Box]

<Example> MELSECNET/10 network range assignment

[Description]

**I/O Master station specification** button

Using Switch screens to choose LX/LY settings enables the I/O master station to be specified. To set the I/O master station, specify the station number with the cursor and click the **I/O Master station specification** button.

**Reserved station specification** button

Specify the reserved station No. and click this button.

**Equal assignment** button

Used to assign the link device points of all stations equally. The first and last stations can be set within the number of stations between the first and last equally assigned station numbers (total number of link stations - (first station number - 1)).

**Identical point assignment** button

Used to make simple assignment with the same points according to the preset total number of stations.

**Supplementary settings** button

Used to set the constant scan, max. number of reconnected stations during 1 scan, multiple transmission, communications error setting and transient setting.

**Station inherent parameters** button

Used to change the network unit storage locations of the link devices assigned to each station in the common parameters.

**Clear** button

Used to default the parameter settings.

**Check** button

Used to check the preset parameter data.

**End setup** button

Clicking this button at the end of data setting returns to the network setting screen.
### 13.2.2 Network Parameter Item Lists

The network parameter items of each series are listed below.

1. **Network parameter items of the Q series**
   - For the remote I/O project, only Ethernet or CC-Link may be set.

#### MELSECNET/10

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network type</td>
<td>Specify the MELSECNET/H·MELSECNET/10 mode, MELSECNET/10 or Ethernet.</td>
</tr>
<tr>
<td>Starting I/O No.</td>
<td>Set the starting I/O No.</td>
</tr>
<tr>
<td>Network No.</td>
<td>Set the network No.</td>
</tr>
<tr>
<td>Total stations</td>
<td>Set the total number of (slave) stations.</td>
</tr>
<tr>
<td>Group No.</td>
<td>Set the group No.</td>
</tr>
<tr>
<td>Mode</td>
<td>Set the mode.</td>
</tr>
<tr>
<td>Refresh parameters</td>
<td>Set the refresh parameters.</td>
</tr>
<tr>
<td>Interrupt settings</td>
<td>Set the interrupt parameters.</td>
</tr>
<tr>
<td>Station inherent parameters</td>
<td>Set the station inherent parameters.</td>
</tr>
</tbody>
</table>

#### MELSECNET/H

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network type</td>
<td>Specify the MELSECNET/H (remote master).</td>
</tr>
<tr>
<td>Starting I/O No.</td>
<td>Set the starting I/O No.</td>
</tr>
<tr>
<td>Network No.</td>
<td>Set the network No.</td>
</tr>
<tr>
<td>Total stations</td>
<td>Set the total number of (slave) stations.</td>
</tr>
<tr>
<td>Mode</td>
<td>Set the mode.</td>
</tr>
<tr>
<td>Reserved station specification</td>
<td>Specify the reserved station.</td>
</tr>
<tr>
<td>Equal assignment</td>
<td>Set when assigning the link device points of the specified stations equally.</td>
</tr>
<tr>
<td>Identical point assignment</td>
<td>Set the same points according to the preset total number of stations.</td>
</tr>
<tr>
<td>Supplementary settings</td>
<td>Make the transient, low-speed cyclic and other settings.</td>
</tr>
<tr>
<td>Refresh parameters</td>
<td>Set the refresh parameters.</td>
</tr>
<tr>
<td>Interrupt settings</td>
<td>Set the device code, detection method, interrupt condition, interrupt (SI) No., etc.</td>
</tr>
</tbody>
</table>
CC-Link

- **Unit count**
  Set the number of units. (1 to 4 units)

- **Operational settings**
  Set the parameter name and data link abnormal station.

- **Type**
  Set the master/local/standby master station, etc.

- **Master station data link type**
  Fixed to "PLC parameter auto start".

- **Mode**
  Set the mode.

- **All connect count**
  Set the number of slave stations connected. (1 to 64 stations)

- **Remote input [RX]**
  Set the bit devices to be batch-refreshed.

- **Remote output [RY]**
  Set the bit devices to be batch-refreshed.

- **Remote register [RWr]**
  Set the word devices to be batch-refreshed.

- **Remote register [RWw]**
  Set the word devices to be batch-refreshed.

- **Special relay [SB]**
  Set the bit devices to be batch-refreshed.

- **Special register [SW]**
  Set the bit devices to be batch-refreshed.

- **Retry count**
  Set the number of transmission retries.

- **Automatic reconnection station count**
  Set the number of stations automatically reconnected during 1 scan.

- **Wait master station No.**
  Set the station number of the standby master station.

- **PLC down select**
  Set whether data link is continued or stopped at a stop of the CPU.

- **Scan mode setting**
  Set whether sequence scans are synchronized or not.

- **Delay information settings**
  Set the link scan interval delay time.

- **Station information settings**
  Set the station type, number of occupied stations, etc.

- **Remote device station initial**
  Set the corresponding station number and procedure registration(operation, execution and other conditions).

- **Interrupt settings**
  Set the device code, detection method, interrupt condition, etc.

Ethernet

- **Network type**
  Specify the MELSECNET/10H mode or Ethernet.

- **Starting I/O No.**
  Set the starting I/O No.

- **Network No.**
  Set the network No.

- **Group No.**
  Set the group No.

- **Station No.**
  Set the station number.

- **Mode**
  Set the mode.

- **Operational settings**
  Make the communications data code setting, initial timing setting and IP address setting.

- **Initial settings**
  Make the timer setting and DNS setting.

- **Open settings**
  Make the open settings.

- **Routing information**
  Set the router relay function, sub-net mask pattern, default router IP address, etc.

- **MNET/10 routing information**
  Set the MNET/10 routing system, net mask pattern, etc.

- **FTP Parameters**
  Set the login name, password, command input watchdog timer, CPU watchdog timer, etc.

- **E-mail settings**
  - **General setting**
    Set the password, mail address, etc.
  - **Mail server name**
    Set the SMTP server name and IP address.
  - **Mail receive setting**
    Set the POP server name and IP address.
  - **Send mail address setting**
    Set the mail address.
  - **News setting**
    Set the condition device, monitor condition, etc.
  - **Interrupt settings**
    Set the detection method, interrupt condition, interrupt (SI) No., etc.
(2) Network parameter items of the QnA series

**MELSECNET/10**

- Network type
  Specify the MELSECNET (II, /10).
- Starting I/O No.
  Set the first I/O No.
- Network No.
  Set the network No.
- Total stations
  Set the total number of (slave) stations.
- Network range type (Common parameters)
  - I/O Master station specification
    Set the I/O master station on the LX/LY setting screen.
  - Reserved station specification
    Specify the reserved station.
  - Equal assignment
    Set when assigning the link device points of the specified stations equally.
  - Identical point assignment
    Set the same points according to the preset total number of stations.
  - Supplementary settings
    Make the transient, low-speed cyclic and other settings.
  - Station inherent parameters
    Set the station inherent parameters.
- Refresh parameters
  Set the refresh parameters.

**Ethernet**

- Network type
  Specify Ethernet.
- Starting I/O No.
  Set the first I/O No.
- Network No.
  Set the network No.
- Group No.
  Set the group No.
- Station No.
  Set the station number.
- IP Address Settings
  Set the IP address of the Ethernet unit.
- MNET/10 routing information
  Set the MNET/10 routing system, net mask pattern, etc.
- FTP Parameters
  Set the login name, password, command input watchdog timer, CPU watchdog timer, etc.
- Routing information
  Set the router relay function, sub-net mask pattern, default router IP address, etc.
### MELSECCNET/Mini
- **Unit count**
  - Set the number of units. (1 to 8 units)
- **Model name**
  - Set the model name of the MELSECCNET/Mini(S3) loaded.
- **Station count**
  - Set the total number of remote I/O stations.
- **Batch refresh receive data**
  - Set the receive data for batch refresh.
- **Batch refresh send data**
  - Set the send data for batch refresh.
- **Retry**
  - Set the number of retries made to the remote I/O station where a communications fault occurred.
- **Response**
  - Set whether access to the master unit buffer memory is assigned to "link" priority or "CPU" priority.
- **Error data clear**
  - Set whether the data of the station in communications error is cleared or held.
- **Abnormal station detection bit data**
  - Set the device where the abnormal station detection data will be stored.
- **Abnormal communication remote**
  - Set the device where the error code at error occurrence will be stored.
- **Circuit error check**
  - Set the transmission status at occurrence of a circuit error.
- **STOP time operation**
  - Set whether link is stopped or continued at STOP of the CPU.

### CC-Link
- **Unit count**
  - Set the number of units. (1 to 4 units)
- **Operational settings**
  - Set the parameter name and data link abnormal station.
- **Type**
  - Set the master/local/standby master station, etc.
- **Master station data link type**
  - Fixed to "PLC parameter auto start".
- **Mode**
  - Set the mode.
- **All connect count**
  - Set the number of slave stations connected. (1 to 64 stations)
- **Remote input [RX]**
  - Set the bit devices to be batch-refreshed.
- **Remote output [RY]**
  - Set the bit devices to be batch-refreshed.
- **Remote register [RW]r**
  - Set the word devices to be batch-refreshed.
- **Remote register [RW]w**
  - Set the word devices to be batch-refreshed.
- **Special relay [SB]**
  - Set the bit devices to be batch-refreshed.
- **Special register [SW]**
  - Set the bit devices to be batch-refreshed.
- **Retry count**
  - Set the number of transmission retries.
- **Automatic reconnection station count**
  - Set the number of stations automatically reconnected during 1 scan.
- **Wait master station No.**
  - Set the station number of the standby master station.
- **PLC down select**
  - Set whether the data of the station in communications error is cleared or held.
- **Circuit error check**
  - Set the transmission status at occurrence of a circuit error.
- **Delay information settings**
  - Set the station type, number of occupied stations, etc.

### POINT
- CC-Link parameters cannot be set to the Q4ARCPU.
(3) Network parameter items of the A series

**MELSECNET (II, /10)**
- **Network type**
  Specify the MELSECNET (II, /10).
- **Starting I/O No.**
  Set the first I/O No.
- **Network No.**
  Set the network No.
- **Total stations**
  Set the total number of (slave) stations.
- **Network range type (Common parameters)**
  - **I/O Master station specification**
    Set the I/O master station on the LX/LY setting screen.
  - **Reserved station specification**
    Specify the reserved station.
  - **Equal assignment**
    Set when assigning the link device points of the specified stations equally.
  - **Identical point assignment**
    Set the same points according to the preset total number of stations.
  - **Supplementary settings**
    Make the transient, link start indication and other settings.
  - **Station inherent parameters**
    Set the station inherent parameters.
- **Refresh parameters**
  Set the refresh parameters.

**MELSECNET/mini**
- **Unit count**
  Set the number of units. (1 to 8 units)
- **Model name**
  Set the model name of the MELSECNET/mini(S3) loaded.
- **Station count**
  Set the total number of remote I/O stations.
- **Batch refresh receive data**
  Set the receive data for batch refresh.
- **Batch refresh send data**
  Set the send data for batch refresh.
- **Retry**
  Set the number of retries made to the remote I/O station where a communications fault occurred.
- **Response**
  Set whether access to the master unit buffer memory is assigned to "link" priority or "CPU" priority.
- **Error data clear**
  Set whether the data of the station in communications error is cleared or held.
- **Abnormal station detection bit data**
  Set the device where the abnormal station detection data will be stored.
- **Abnormal communication remote**
  Set the device where the error code at error occurrence will be stored.
- **Circuit error check**
  Set the transmission status at occurrence of a circuit error.
- **STOP time operation**
  Cannot be set for the A series.
13.2.3 Explanations for Network Parameter Setting Screen

The following items are related to network parameter setting.

1. Unit valid for other station access
   This setting is made valid when there are multiple units which are used without specifying the network No. or when the network No. has not been set for access to the other station.

2. Read PLC data button
   Reads the implementation status.
   For QnA series
   Always delete the parameter file of the PLC before reading the implementation status.
   The parameter file is read if the parameter file exists in the PLC.

3. Remote I/O project
   You can set up to four Ethernet modules and CC-Link modules, respectively.

4. "MELSOFT connection" in Ethernet connection (Q Series only)
   This setting is used when connecting multiple MELSOFT products such as GX Developer (a maximum of 17 units) using the TCP/IP communication system.
   Setting procedure
   Ethernet → Open settings → Protocol (TCP) → Open system (MELSOFT connection)
   The screen below gives a setting example when user connections 14 to 16 are used to connect MELSOFT products, while connections 1 to 5 are used to communicate with non-MELSOFT products via a MC protocol communication, fixed-buffer communication, etc.

   ![Network parameter Ethernet open setting Module No.1]

   Used for various communications.
   Used to connect MELSOFT products.

REMARKS

For the Q series, Read PLC data is not available for the network parameters.
13.3 Setting the Remote Password

[Purpose]
Set the password to prevent access by other than the intended user since remote access can be made via the Q-compatible E71 and serial communication module (Q series). Refer to Appendix 7 to confirm the version of the PLC CPU with which this function is compatible.

[Operating Procedure]
Select Project list - [Parameter] - [Remote Pass].
Select Toolbar project change - [Parameter] - [Remote Pass].

Remote Password

Password
Set in four characters.
Usable characters: A to Z, a to z, numerals, @, !, #, $, %, &, /, (, ), *, +, ,, -, ., ;, :, <, =, >, ?, {, }, ~, [,

Password enabled module setting
Model name
Choose the QJ71E71 or QJ C24
Starting I/O No.
Set in increments of 16 points.
Detail Setting (Make this setting when you selected the Q-compatible E71.)
User's Connectiom
You can set connection No.1 to No.16.
System's Connectiom
Set the automatic connection UDP port.
Set the FTP update port (TCP/IP).
Set the GX Developer update port (TCP/IP).
Set the GX Developer update port (UDP/IP).

POINT
- Refer to Section 16.3 for the operating procedure used to access the PLC CPU where the remote password has been registered.
- The remote password is made invalid under any of the following conditions.
  (1) The project ends.
  (2) The connection setup is changed.
  (3) The PLC type is changed (only when the PLC series changes).
This chapter describes how to print data, including sequence programs created by a GX Developer, device comments, and set parameters, on a printer from a personal computer.

[Outline of operations to printing]
Shown below is the basic flow of steps to printing.
14.1 Setting Up a Printer

[Purpose]
Selects a printer for printing and sets the paper size, the printing orientation, and other printing format-related items.

[Operating procedure]
Select [Project] → [Printer setup] or click $\text{Ctrl} + P$ and the Printer setup button.

[Dialog box]

1) Printer
Selects a printer for printing.

2) Paper
Sets the size of the paper for printing and the paper feed method of the printer. The setting range depends on the printer.

3) Orientation
- Portrait
  Characters will be printed along the paper feed direction.
- Landscape
  Characters will be printed across the paper feed direction.

4) Properties button
Clicking this button displays the properties dialog box. The printer property option is used to make the basic settings of the printer.

5) OK button
Click this button after the printer setting is completed.
### POINTS

- A printer model operable, whose performance was verified by Mitsubishi, is available.
  - HP Laser Jet 4000N
- Consult the operation manual for the selected printer for the printer properties that depend on the printer manufacturer and the printer model.
- To print large quantities of data, open the printer property window from the control panel of Windows® 95, and select "Print directly to the printer" for the spool setting.
14.2 Setting a Page Layout

[Purpose]
Makes settings related paper, page number, header, and so on.

[Operating procedure]
Select [Project] → [Printing] and click the Page setup button, or click (Ctrl + P) then the Page setup button.

[Dialog box]

[Description]
1) Paper
   Sets paper size and paper feed method.

2) Print orientation
   Sets the orientation of printing on paper.

3) Page No. setting
   Page no. form................. When page numbers are not required, set "None"
   The symbol "-**-" indicates that page numbers starting from the initial value will be printed by item.
   However, serial number will be printed when the data to be printed is more than one page long.
   The symbol "***-***" indicates that page numbers starting from the initial number will be printed
   according to the printing order set in the Multi-Printing dialog box.
   No. position................. Sets the position of page numbers.
   Initial value................ Sets the page number to be printed on the first page.
4) Margins
Sets the margins of the page.

5) Common header setting
By checking off the check box, a header will be printed on each page.
Click the [Edit header] button, and the Header Edit dialog box as shown below
will be displayed.

Alternatively, clicking the [Edit footer] button displays the Footer Edit dialog box
like the Header Edit dialog box.
The header (or footer) can be edited within the range of 64 characters x seven
lines.
Lines and images cannot be edited, and characters cannot be decorated.

6) [Printer setup] button
By clicking this button, the printer dialog box will be displayed (see Section
14.1.).

7) [OK] button
Click this button after the page setting is completed.

POINT

- If the print characters are small, reduce the value of margin setting.
- When the mouse button is clicked while the shape of the mouse pointer is ,
  the window zooms in.
  When the mouse button is clicked while the shape of the mouse pointer is ,
  the data is displayed in the standard scale.
• The printing date will be printed automatically in the header (footer) by setting "#YY-MM-DD#" in the Header (Footer) Edit dialog box. The PC type will also be printed automatically in the header (footer) by setting "#CPU#."  

<Example> <Printing example>  

98-03-01  
A3U  

• Entered character patterns and printed characters

<table>
<thead>
<tr>
<th>Character Pattern</th>
<th>Function</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>#YY-MM-DD#</td>
<td>Date (year-month-day)</td>
<td></td>
</tr>
<tr>
<td>#YYYY-MM-DD#</td>
<td>Date (year-month-day)</td>
<td></td>
</tr>
<tr>
<td>#YY/MM/DD#</td>
<td>Date (year/month/day)</td>
<td></td>
</tr>
<tr>
<td>#YYYY/MM/DD#</td>
<td>Date (year/month/day)</td>
<td></td>
</tr>
<tr>
<td>#YY#</td>
<td>Year (last two digits)</td>
<td></td>
</tr>
<tr>
<td>#YYYY#</td>
<td>Year (four digits)</td>
<td></td>
</tr>
<tr>
<td>#MM#</td>
<td>Month</td>
<td></td>
</tr>
<tr>
<td>#DD#</td>
<td>Day</td>
<td></td>
</tr>
<tr>
<td>#CPU#</td>
<td>CPU model</td>
<td>When setting characters after the CPU model, the total length of characters including the CPU model must not exceed 64 characters. Otherwise the CPU model may not be printed.</td>
</tr>
<tr>
<td>#PROJECT#</td>
<td>Project name</td>
<td></td>
</tr>
<tr>
<td>#PROJ_COMMENT#</td>
<td>Quick reference title of project</td>
<td></td>
</tr>
<tr>
<td>#DATA#</td>
<td>Data name (MAIN, SUB1, etc.)</td>
<td></td>
</tr>
<tr>
<td>#DATACOMMENT#</td>
<td>Quick reference title of data name</td>
<td></td>
</tr>
</tbody>
</table>

To add a fixed character after the character pattern, insert a space after #CPU#.  

<Example> Printed characters when A2USHCPU-S1 is selected

When no space is inserted after CPU

#CPU# ABCD ➔ Print ➔ A2USH-S1ABCD

Insert a space.
14.3 Previewing a Print Image

[Purpose]
The image of the entire page when it is printed will be displayed.

[Operating procedure]
Select [Project] → [Print] and click the [Print preview] button, or click (Ctrl + P), then the [Print preview] button.

[Preview Window]
[Description]
1) [Print] button
   The data displayed on the print preview window will be printed.

2) [Zoom In] button
   The displayed image will be enlarged by clicking this button.
   Data will be displayed in three different scales.

3) [Zoom Out] button
   The displayed image will be reduced by clicking this button.

POINT

- The print preview may be displayed only on page 1.
  (It cannot be displayed on page 2 or later.)
  However, only the parameters can be previewed on all pages. (Except X/Y assignment confirmation)

- When the mouse button is clicked while the shape of the mouse pointer is 🔍, the window zooms in.
  When the mouse button is clicked while the shape of the mouse pointer is 🔍, the data is displayed in the standard scale.
14.4 Printing

[Purpose]
Prints data, such as sequence programs and device comments. Data can be printed in two ways: each volume of data will be printed or two or more volumes of data will be printed at a time.

[Operating procedure]
Select [Project] → [Print], or click \( Ctrl + P \), then the [Print preview] button.

[Dialog box]

1) Data print tabs
Clicking the required tab switches to the detail setting screen.

2) Sheet
Each sheet provides the items to be set to designate items and range of the data to be printed and other details. Select each item by checking the check box to the left. For details on each sheet, see Subsections 14.5.1 to 14.5.13.

3) [Print] button
Click this button after details have been set on each sheet. The data of the displayed sheet will be printed.
4) **Related function**
By clicking on each button, the corresponding dialog box related to printing will be displayed. (See Sections 14.1, 14.2, and 14.3.)

5) **Multiple printing** button
By clicking this button, the Multiple Data Printing dialog box shown below will be displayed.
Two or more volumes of data will be printed at a time.

6) **Print items**
Select the data items to batch-print by checking the check box.

7) **Print order**
Sets the order in which each data will be printed.
Set the order number of each item using \[ \text{order number} \]
The order number of any data, which is not set to be printed, will be ignored.

8) **Print** button
By clicking this button, the data items with a checkmark \( \sqrt{ } \) will be batch-printed.
Select data items to batch-print by checking their check boxes.

9) **End setup** button
The data items to print will be set, and the initial setting dialog box will be displayed.
[Setting procedure]
1. After the printer setting is completed, display the print dialog box.

2. Open the page setting dialog box, and set the page format.

3. Open each sheet, and set details.

4. To confirm the image of the data when it is printed, click [Print preview].

5. Click the [Print] button 3) when printing data one by one.
   The data displayed on the current sheet will be printed.
   To batch-print two or more volumes of data, click the [Multiple printing] button 5).
   The multiple data printing dialog box will be displayed.

6. Set the items to print 6) and the printing orders 7).

7. By clicking the [Print] button 8), the selected volumes of data will be batch-printed.

POINTS
- In data-by-data printing, a ladder will be printed by clicking the [Print] button when the <<Ladder>> sheet is displayed, or a device comment will be printed by clicking on the [Print] button when the <<Device comment>> is displayed.

- When the page number form "-.*-*" is set in page setting for multiple data printing, the data will be printed in the set printing order, and serial page numbers will be printed.

- Depending on the printer type, printer driver type/version, or set data, a part of the data may not be printed. If this problem occurs, change the setting of the printer driver.
14.5 Setting the Details for Printing

Set details for printing, such as the range and contents of each data. For a printing example of each data, see Section 14.6.

14.5.1 Creating a title

[Purpose]
Creates a title for the project to be printed.

[Operating procedure]
Select [Project] → [Print] and click the <<Title>> tab, or click \(\text{Ctrl} + \text{P}\), then the <<Title>> tab.

[Dialog box]

1) [Description of item]
   1) Title setting
   Edit the title within 64 characters x nine lines.
   Lines and images cannot be edited, and characters cannot be decorated.
   By checking the check box, the title edited will be framed.
   The date will be printed automatically when a character pattern, such as "#YY-MM-DD#" is set.
   On this dialog box, the date (#YY-MM-DD#) and the CPU model (#CPU#) can be set.
   For input characters patterns, see Section 14.2.
14.5.2 Setting a ladder print range

[Purpose]
Sets details about ladder printing, such as the ladder print range and additional information.

[Operating procedure]
Select [Project] → [Print] and click the <<Ladder>> tab, or click \(\text{Ctrl} + \text{P}\), then the <<Ladder>> tab.

[Dialog box]

1) Ladder print item (Label programming only)
   - Print Ladder........................ Printed as label name.
   - Print Ladder (Device) ............ Printed as actual device.

2) Additional information
   Any item with a checkmark \(\checkmark\) will be added to the ladder to be printed.
   By clicking the [Setup range] button for contact using data or for coil using data, the following Device Range Setting dialog box appears.
   Set the head and final devices or the number of points and the head device of each range to be specified.
Destinations where contacts and coils are used

Indicate the number of steps at destination where coils are used.

• Destination where contacts are used
  - Source
  - Contact
  - Number of steps when T10 is used at source.
  - Destination
  - Contact
  - Number of steps when T10 is used at destination.

2) Program selection
   If the program to be printed is not yet set, the data name of the program which is active in the ladder mode is automatically selected.
   If the program to be printed is already set, the set program name appears.
   Using the mouse, select on the list a program to print, and click the [Select] button to set the selection.
   Also, you can select and batch-print multiple sequence programs.

3) Print conditions
   Sets the condition for printing the ladder.
   - Print NOPLF (Except the FX series)
     NOPLF will be printed by checking the check box.
   - Renews page at each ladder block unit
     Pages will be renewed by ladder block by checking the check box.
     When the check box is not checked, pages will be renewed by ladder line.
   - Prints the blank lines with no device comments
     Any line without a device comment will also be printed by checking the check box.
   - Printing in the macro instruction format (Except the FX series)
     Prints the macro-input instructions in the macro format.

4) Print range
   Sets the print range of the ladder.
   ◎ All
     The entire range from step 0 to the END instruction of the program will be printed.
   ◎ Specified
     The range between the specified steps will be printed.
• Precautions

Printing condition

Pages will be fed at the position following an NOPLF instruction even if the
NOPLF check box is not checked. (Except the FX series)

If the program is read from the GPPA by selecting [Project] → [Import file],
the number of contacts to be displayed on a line is different between the GX
Developer and the GPPA and the number of lines printed by the GPPA may
therefore vary.

When feeding pages

If there are two or more lines of contact using data under the above
settings, pages will be fed in the middle of the lines. Pages will not be fed
in the middle of the ladder and the coil using data.
14.5.3 Setting a Instruction list print range

[Purpose]
Sets details about Instruction list printing, such as the list print range and additional information.

[Operating procedure]
Select [Project] → [Print] and click the <<Instruction list>> tab, or click (Ctrl + P), then the <<Instruction list>> tab.

[Dialog box]

1) Additional information
A device name will be added to the Instruction list. Select this item by checking the check box.

2) Program selection
If the program to be printed is not yet set, the data name of the program which is active in the ladder mode is automatically selected. If the program to be printed is already set, the set program name appears. Using the mouse, select on the list a program to print, and click the [Select] button to set the selection. Press the [Clear selection] button to clear the program selected.

3) Print conditions
Prints NOP
NOP will be printed by checking the check box.
Print NOPLF (Except the FX series)
NOPLF will be printed by checking the check box.
Printing in the macro instruction format (Except the FX series)
Prints the macro-input instructions in the macro format.
4) Print range
Set the print range of the list.

- All
  The entire range from step 0 to the END instruction of the program will be printed.
- Specified
  The range between the specified steps will be printed.

5) Print list
Print Instruction list (Device) prints the actual program in label programming. Choose [Edit] → [Documentation] → [Statement/Note block edit] to print the created statements/notes.

POINT

- Precautions
  Printing condition
  Pages will be fed at the position following an NOPLF instruction even if the Printing NOPLF check box is not checked. (Except the FX series)

  Print range
  In setting the print range, enter both the start step and the end step, and the former must be larger than the latter.
  When two or more steps are specified as the start or end step for an instruction, or when the instruction includes the steps specified, the instruction will also be printed.

  When printing data on A4 portrait paper
  If the number of device characters of an instruction exceeds 80 on A4 portrait paper or 130 on A4 landscape paper, the excessive characters may not be printed. Any entire instruction or device within eight characters will be printed. If a device is more than eight characters long, the third device will not be printed completely. (All device characters will be printed on A3 landscape paper even if the number of characters is maximum.)

  <Example> Printing on A4 portrait paper

<table>
<thead>
<tr>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
<th>7</th>
<th>8</th>
</tr>
</thead>
<tbody>
<tr>
<td>1234567890</td>
<td>1234567890</td>
<td>1234567890</td>
<td>1234567890</td>
<td>1234567890</td>
<td>1234567890</td>
<td>1234567890</td>
<td>1234567890</td>
</tr>
<tr>
<td>123</td>
<td>EFCALL</td>
<td>&quot;File001&quot;</td>
<td>P0</td>
<td>ZR1000Z0</td>
<td>ZR1100Z0</td>
<td>ZR1200Z0</td>
<td>ZR1300Z0</td>
</tr>
<tr>
<td>123</td>
<td>EFCALL</td>
<td>&quot;File001&quot;</td>
<td>P0</td>
<td>J123/W100Z12</td>
<td>J123/W100Z12</td>
<td>J123/W100Z12</td>
<td>J123/W100Z12</td>
</tr>
</tbody>
</table>

80 characters
Will not be printed.
14.5.4 Setting a TC setting value print range

[Purpose]
Sets details about timer or counter settings, such as the items to be printed and additional information.

[Operating procedure]
Select [Project] → [Print] and click the <<TC setting>> tab, or click (Ctrl + P), then the <<TC setting>> tab.

[Dialog box]

[Description]
1) Print items
The item with a checkmark ✓ will be printed.

2) Program selection
If the program to be printed is not yet set, the data name of the program which is active in the ladder mode is automatically selected.
If the program to be printed is already set, the set program name appears.
Select on the list a program for which timer or counter settings will be made, and click the [Select] button to set the selection.

3) Additional information
The item with a checkmark ✓ will be added.

4) Print conditions
Only the timer or counter used in the program will be printed by checking this check box.
14.5.5 Setting a device comment print range

[Purpose]
Sets the print range of device comments and so on.

[Operating procedure]
Select [Project] → [Print] and click the <<Device comment>> tab, or click (Ctrl + P), then the <<Device comment>> tab.

[Dialog box]

[Description]
1) Additional information
   Device comments will be printed with additional information. Check the desired check box.

2) Program selection
   Select on the list a program as the coil using data specified for Additional information, and click the [Select] button to set the selection.

3) Comment/Device Label selection
   Select on the list the device comment data to be printed, and click the [Select] button to set the selection.

4) Print conditions
   Only devices with a comment will be printed. Select this item by checking the check box.
5) Print range
   Set the range of the device comments to be printed.
   ○ All
     All device comments of the data selected will be printed.
   ○ Specified
     The device comments within the specified range will be printed.
     By clicking the [setup range] button, the Device Range Setting dialog box
     shown below will be displayed.
     Set the head and final devices or the number of points and the head device of
     the range to be designated.

<table>
<thead>
<tr>
<th>Part</th>
<th>Start</th>
<th>End</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

POINT

- Whenever device comments are read from the GPPA, GPPQ, FXGP(DOS)
  or FXGP(WIN) from the [Import file] menu, confirm before printing whether
  the data is read properly.
  If the data is not read properly, check whether the comment range is set
  according to Chapter 9 "Setting Device Comments."
14.5.6 Setting a device use list print range

[Purpose]
Sets the print range of device using data and so on.

[Operating procedure]
Select [Project] → [Print] and click the <<List of used device>> tab, or click (Ctrl + P), then the <<List of used device>> tab.

[Dialog box]

[Description]
1) Additional information
A device use list will be printed with additional information.
Check the desired check box.

2) Program selection
If the program to be printed is not yet set, the data name of the program which is active in the ladder mode is automatically selected.
If the program to be printed is already set, the set program name appears.
Select on the list a program as the device using data specified for Additional information, and click the [Select] button to set the selection.

3) Print conditions
Prints only devices being used during the program.
Select this item by checking the check box.
4) Print range
   Sets the range of the device use list to be printed.
   ☑ All
      All device use lists of the data selected will be printed.
   ☑ Specified
      The device use lists within the specified range will be printed.
      At the Device Range Setting dialog box displayed by clicking the [setup range] button, set the head and final devices or the number of points and the head device of the range to be designated.

5) Block print range (only for SFC selection)
   Set when block printing SFC programs.
14.5.7 Setting a device memory print range

[Purpose]
Sets the print range of the device memory using data and so on.

[Operating procedure]
Select [Project] → [Print] and click the <<Device memory>> tab, or click (Ctrl + P), then the <<Device memory>> tab.

[Dialog box]

[Description]
1) Print conditions
Any device whose value is "0" will also be printed.
Select this item by checking the check box.

2) Print range
Sets the print range of the device memory.

   ⊗ All
   The entire device memory will be printed.

   ⊗ Specified
   The specified range of the device memory will be printed.
   By clicking the [Specified range] button, the Device Range Setting dialog box will be displayed. Set the head and final devices or the number of points and the head device of the range to be designated.
3) Print type
   Set device memory values in 16-bit integers, 32-bit integers or real numbers.

4) Printing format
   Sets device memory values in binary, decimal or hexadecimal.

5) Device memory selection
   Allows multiple device memories to be selected.

14.5.8 Setting a device initial value print range

[Purpose]
Sets the print range of the QnA series device initial values and so on.

[Operating procedure]
Select [Project] → [Print] and click the <<Device init>> tab, or click (Ctrl + P), then the <<Device init>> tab.

[Dialog box]

[Description]
1) Print item
   The items selected will be printed.
   Select the desired item by checking the check box.

2) Print condition
   Any device whose value is "0" will also be printed.
   Select this item by checking the check box.
3) Print range
   Sets the print range of the device initial values.
   ☐ All
       All device initial values will be printed.
   ☐ Specified
       The device initial values within the specified range will be printed.
       By clicking the [Setup range] button, the Device Range Setting dialog box will
       be displayed. Set the head and final devices or the number of points and the
       head device of the range to be designated.

4) Print type
   Sets device initial values in 16-bit integers, 32-bit integers or real numbers.

5) Print format
   Sets device initial values in binary, decimal or hexadecimal.
14.5.9 Setting a PLC parameter print item

[Purpose]
Sets the PLC parameter items to be printed.

[Operating procedure]
Select [Project] → [Print] and click the <<PLC parameters>> tab, or click (Ctrl + P), then the <<PLC parameters>> tab.

[Dialog box]

[Description]
1) Print items
The items selected will be printed.
Select each desired item by checking the check box.
PLC name setting, PLC file setting, Program setting/Boot file setting, and SFC setting are not required and cannot therefore be selected for the A series.
Memory capacity setting is not required and cannot therefore be selected for the Q/QnA series.
PLC file setting, PLC RAS setting, Program setting, Boot file setting, and SFC setting are not required and cannot therefore be selected for the FX series.
X/Y assignment check can be selected only for the AnA, AnU, Q, and QnA series.
14.5.10 Setting a network parameter print item

[Purpose]
Sets the network parameter items to be printed.

[Operating procedure]
Select [Project] → [Print] and click the <<Network parameters>> tab, or click (`Ctrl` + `P`), then the <<Network parameters>> tab.

[Dialog box]

[Description]
1) Print items
The items selected will be printed.
Select each desired item by checking the check box.
CC-link setting is not available and cannot therefore be selected for the A series.
14.5.11 Setting a list of contact coil used

**[Purpose]**
Sets the print range of the devices used for contacts or coils and so on.

**[Operating procedure]**
Select [Project] → [Print] and click the <<List of contact coil used>> tab, or click (Ctrl + P), then the <<List of contact coil used>> tab.

**[Dialog box]**

**[Description]**
1) Print item
   A list will be printed with the selected items added. Check the desired check box.

2) Program selection
   If the program to be printed is not yet set, the data name of the program which is active in the ladder mode is automatically selected. If the program to be printed is already set, the set program name appears. Select on the list a program as the contact or coil using data, and click the Select button to set the selection.

3) Additional information
   The list will be printed with additional information. Select this item by checking the check box.

4) Print condition
   Only devices used in the program selected will be printed.
5) Print range
   Set the range of the contact/coil use list to be printed.
   ○ All
      The entire range from step 0 to the END instruction of the program will be
      printed.
   ○ Specified
      The range specified by the step numbers will be printed.
      To specify the range, set the head and final devices or the number of points and
      the head device in the Device Range Setting dialog box.

6) Block print range (only for SFC selection)
   Set when block printing SFC programs.

14.5.12 Displaying a project contents list

[Purpose]
Displays a list of project data.

[Operating procedure]
Select [Project] → [Print] and click the "<Project contents list>" tab, or click
("Ctrl" + P), then the "<Project contents list>" tab.

[Dialog box]

1) Print contents
   The items to be printed on a list of project data are displayed.
14.5.13 Setting the TEL data print area

[Purpose]
Prints the data set on the TEL data creation screen.

[Operating Procedure]
[Project] → [Print] → <TEL> tab or Ctrl + P) → <TEL> tab

[Dialog Box]

[Description]
1) TEL setting
   Prints the data set on the TEL data creation screen.

2) Phone book
   Prints the data registered on the phone number book setting screen.
14.5.14 Product information list

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>×</td>
<td>☑*</td>
<td>×</td>
</tr>
</tbody>
</table>

*: Compatible with only the QCPU (Q mode)

**Purpose**
Prints the production information list of System monitor.

**Operating Procedure**
Select [Project] → [Print] → <<Product information list>> tab or (Ctrl + P) → <<Product information list>> tab

**Dialog Box**

**Description**
1) File name
Set the product information list file (CSV format).
Make setting from only the [Browse] button.

**POINT**
- Before starting printing, always save the file when you have selected [Diagnostics] → [System monitor] → <<Product information list>> tab. (Refer to Section 21.4)
- An error will occur if you set the file other than the product information list file.
14.5.15 Printing labels

[Purpose]
Prints global and local variable data created by label programming.

[Operating Procedure]
Choose [Project] → [Print] → <<Label>> tab or (Ctrl + P) → <<Label>> tab.

[Dialog Box]

[Description]
1) Program selection
When the program to be printed is not yet specified, the data name of the active program is automatically selected.
When the program to be printed is already set, the preset program name appears.
When changing or adding the label program to be printed, specify the data name from program selection and click the Select button to make setting.
14.6 Print Examples

Print examples are shown below.

<<Title>>
M Corporation      N Factory
Line 1
Ladder
Parameter
Device

<<Ladder>>

<<TC setting>>

<table>
<thead>
<tr>
<th>Device</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>T0</td>
<td>K1000</td>
</tr>
<tr>
<td>T1</td>
<td>K120</td>
</tr>
<tr>
<td>T2</td>
<td>K6000</td>
</tr>
<tr>
<td>T3</td>
<td>K50</td>
</tr>
<tr>
<td>T4</td>
<td>K850</td>
</tr>
</tbody>
</table>
### <<Device comment>>

<table>
<thead>
<tr>
<th>Device</th>
<th>Device comment</th>
<th>Dev Lbl</th>
</tr>
</thead>
<tbody>
<tr>
<td>M10</td>
<td>Operation ready</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>X0</th>
<th>Safety equipment</th>
<th>SAFETY</th>
</tr>
</thead>
<tbody>
<tr>
<td>X1</td>
<td>Safety cover</td>
<td>COVER</td>
</tr>
<tr>
<td>X2</td>
<td>Operation ready</td>
<td>READY</td>
</tr>
<tr>
<td>X3</td>
<td>Oil pressure</td>
<td>OIL-M</td>
</tr>
</tbody>
</table>

### <<List of used device>>

<table>
<thead>
<tr>
<th>Device</th>
<th>Use/Not use</th>
<th>No.</th>
<th>Error</th>
<th>Device comment</th>
<th>Dev Lbl</th>
</tr>
</thead>
<tbody>
<tr>
<td>X0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>Safety equipment</td>
<td>SAFETY</td>
</tr>
<tr>
<td>X2</td>
<td>0</td>
<td>0</td>
<td></td>
<td>Cycle stop</td>
<td>READY</td>
</tr>
<tr>
<td>X3</td>
<td>0</td>
<td>0</td>
<td></td>
<td>Sensor1</td>
<td>OIL-M</td>
</tr>
<tr>
<td>X7</td>
<td>0</td>
<td></td>
<td></td>
<td>Safety cover</td>
<td></td>
</tr>
<tr>
<td>Y70</td>
<td>1</td>
<td></td>
<td>ERROR</td>
<td></td>
<td></td>
</tr>
<tr>
<td>M10</td>
<td>1</td>
<td></td>
<td></td>
<td>Operation ready</td>
<td></td>
</tr>
</tbody>
</table>

### <<Device memory>>

<table>
<thead>
<tr>
<th>Device</th>
<th>16 bits</th>
<th>Type</th>
<th>decimal</th>
</tr>
</thead>
<tbody>
<tr>
<td>D0</td>
<td>7086</td>
<td>37</td>
<td>3796</td>
</tr>
<tr>
<td>D1</td>
<td>9678</td>
<td>8660</td>
<td>7697</td>
</tr>
<tr>
<td>D16</td>
<td>67</td>
<td>3</td>
<td>7376</td>
</tr>
<tr>
<td>D24</td>
<td>100</td>
<td>738</td>
<td>737</td>
</tr>
<tr>
<td>D32</td>
<td>1156</td>
<td>678</td>
<td>763</td>
</tr>
<tr>
<td>D40</td>
<td>343</td>
<td>7895</td>
<td>64</td>
</tr>
<tr>
<td>D48</td>
<td>8381</td>
<td>137</td>
<td>434</td>
</tr>
<tr>
<td>D56</td>
<td>100</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>
<<Device init >>
Q/QnA series only

Dev init set range

<table>
<thead>
<tr>
<th>No.</th>
<th>Items</th>
<th>Start device</th>
<th>End device</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>50</td>
<td>D0</td>
<td>D49</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>100</td>
<td>D100</td>
<td>D199</td>
<td></td>
</tr>
</tbody>
</table>

Device memory list

<table>
<thead>
<tr>
<th>16 bit</th>
<th>Type</th>
<th>Character string</th>
</tr>
</thead>
<tbody>
<tr>
<td>+0</td>
<td>+1</td>
<td>+2</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Device</th>
<th>+0</th>
<th>+1</th>
<th>+2</th>
<th>+3</th>
<th>+4</th>
<th>+5</th>
<th>+6</th>
<th>+7</th>
<th>Character string</th>
</tr>
</thead>
<tbody>
<tr>
<td>D0</td>
<td>374</td>
<td>4687</td>
<td>6</td>
<td>746</td>
<td>76</td>
<td>37</td>
<td>3</td>
<td>387</td>
<td></td>
</tr>
<tr>
<td>D6</td>
<td>354</td>
<td>37</td>
<td>3</td>
<td>76</td>
<td>64</td>
<td>35</td>
<td>76</td>
<td>37</td>
<td></td>
</tr>
<tr>
<td>D16</td>
<td>697</td>
<td>879</td>
<td>6</td>
<td>78</td>
<td>3</td>
<td>3799</td>
<td>379</td>
<td>3794</td>
<td></td>
</tr>
<tr>
<td>D24</td>
<td>3998</td>
<td>3687</td>
<td>489</td>
<td>1579</td>
<td>3794</td>
<td>874</td>
<td>679</td>
<td>7897</td>
<td></td>
</tr>
<tr>
<td>D32</td>
<td>57</td>
<td>4</td>
<td>486</td>
<td>7</td>
<td>867</td>
<td>687</td>
<td>68</td>
<td>76</td>
<td></td>
</tr>
<tr>
<td>D40</td>
<td>87</td>
<td>8676</td>
<td>87</td>
<td>7767</td>
<td>6</td>
<td>76</td>
<td>7</td>
<td>687</td>
<td></td>
</tr>
<tr>
<td>D48</td>
<td>687</td>
<td>78</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<<PC parameters>>

Mem capcty set

1 Sequence program capacity

<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Sub</td>
<td>[0] K step</td>
</tr>
</tbody>
</table>

2 Microcomputer program capacity

<table>
<thead>
<tr>
<th>Main</th>
<th>[0] K step</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sub</td>
<td>[ ] K step</td>
</tr>
</tbody>
</table>

3 Comment capacity

<table>
<thead>
<tr>
<th>Comment</th>
<th>[0] K bytes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extension comment</td>
<td>[0] K bytes</td>
</tr>
</tbody>
</table>

4 File register capacity

| File register capacity | [0] K bytes |

5 Capacity for debug

| Sampling trace | [0] K bytes |
| Stat latch (data mem) | [ ] K bytes |

6 Total capacity

| Total capacity | [16] K bytes |
<<Network parameters>>
Except the FX series

Set unit count

<table>
<thead>
<tr>
<th>MELSECNET (II/10) No. of units</th>
<th>[2] Unit(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unit 1 &lt; MELSECNET/10 (Ctrl sta) &gt;</td>
<td></td>
</tr>
<tr>
<td>Unit 2 &lt; MELSECNET/10 (Ctrl sta) &gt;</td>
<td></td>
</tr>
<tr>
<td>Unit 3 &lt;</td>
<td>[ ]</td>
</tr>
<tr>
<td>Unit 4 &lt;</td>
<td>[ ]</td>
</tr>
</tbody>
</table>

Valid unit accessing other st  (Older of unit)

Network setting

<table>
<thead>
<tr>
<th>Start I/O No.</th>
<th>Unit 1 NET/10 Ctrl Sta</th>
<th>Unit 2 NET/10 Ctrl Sta</th>
<th>Unit 3</th>
<th>Unit 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>[ 0]</td>
<td>[ 30]</td>
<td>[ ]</td>
<td>[ ]</td>
<td>[ ]</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Network No.</th>
<th>Unit 1 NET/10 Ctrl Sta</th>
<th>Unit 2 NET/10 Ctrl Sta</th>
<th>Unit 3</th>
<th>Unit 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>[ 1]</td>
<td>[ 2]</td>
<td>[ ]</td>
<td>[ ]</td>
<td>[ ]</td>
</tr>
</tbody>
</table>

<<List contact coil used>>

List of Contact-Coil

<table>
<thead>
<tr>
<th>Device</th>
<th>Step</th>
<th>Ld sym</th>
<th>Ins</th>
<th>Pos</th>
</tr>
</thead>
<tbody>
<tr>
<td>X0</td>
<td>0</td>
<td>⊙ ⊙</td>
<td>LD</td>
<td>*</td>
</tr>
<tr>
<td>X2</td>
<td>4</td>
<td>⊙ ⊙</td>
<td>LDI</td>
<td>*</td>
</tr>
<tr>
<td>X3</td>
<td>5</td>
<td>⊙ ⊙</td>
<td>OR</td>
<td>*</td>
</tr>
<tr>
<td>X7</td>
<td>2</td>
<td>⊙ ⊙</td>
<td>ANI</td>
<td>*</td>
</tr>
<tr>
<td>Y70</td>
<td>7</td>
<td>⊙ ⊙</td>
<td>OUT</td>
<td>*</td>
</tr>
<tr>
<td>M10</td>
<td>1</td>
<td>⊙ ⊙</td>
<td>OR</td>
<td>*</td>
</tr>
<tr>
<td>M10</td>
<td>3</td>
<td>⊙ ⊙</td>
<td>OUT</td>
<td>*</td>
</tr>
<tr>
<td>M10</td>
<td>6</td>
<td>⊙ ⊙</td>
<td>AND</td>
<td>*</td>
</tr>
</tbody>
</table>

<<Project contents list>>

Drive/Path | A: |
Project name | TESTA |
Title

<table>
<thead>
<tr>
<th>Data name</th>
<th>Size</th>
<th>Creation data</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Program</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MAIN</td>
<td>13KB</td>
<td>1998/9/19 16:22:50</td>
<td></td>
</tr>
<tr>
<td>Device comment</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>COMMENT</td>
<td></td>
<td>1KB 1998/9/19 16:22:54</td>
<td></td>
</tr>
<tr>
<td>MAIN</td>
<td></td>
<td>1KB 1998/9/19 16:40:56</td>
<td></td>
</tr>
<tr>
<td>Device memory</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MAIN</td>
<td></td>
<td>1KB 1998/9/19 16:45:00</td>
<td></td>
</tr>
<tr>
<td>Parameter</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PC parameter</td>
<td>1998/9/19 16:44:56</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Network parameter</td>
<td>1998/9/19 16:44:56</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### <<A6TEL/Q6TEL data list>>

#### A6TEL data list

| Title | Mode
|-------|-----|
| AT command | ATQOEIV1KISO-1
| Line type | Tone
| Main/Sub switching time | 1 min

#### Register item and condition

<table>
<thead>
<tr>
<th>Title</th>
<th>TEST DATA</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reporting</td>
<td>Report 1 time.</td>
</tr>
<tr>
<td>Report information</td>
<td>Ma Call number 0123456789 An outside line number</td>
</tr>
<tr>
<td></td>
<td>Setting Select time Time 30 sec</td>
</tr>
<tr>
<td></td>
<td>Su Call number -- An outside line number --</td>
</tr>
<tr>
<td></td>
<td>Setting -- Time --</td>
</tr>
<tr>
<td>Trigger condition</td>
<td>Device Word device CO</td>
</tr>
<tr>
<td></td>
<td>Condition # Value Dec. 10</td>
</tr>
<tr>
<td>Paper message</td>
<td>History D100</td>
</tr>
</tbody>
</table>

### <<Product information list>>

<table>
<thead>
<tr>
<th>Slot</th>
<th>Type</th>
<th>Series</th>
<th>Type name</th>
<th>Items</th>
<th>Start/Out</th>
<th>Control/PLC</th>
<th>Serial No.</th>
<th>Ver</th>
</tr>
</thead>
<tbody>
<tr>
<td>PLC</td>
<td>PLC</td>
<td>Q</td>
<td>Q05HPV0</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>ST0010000000000 B</td>
<td></td>
</tr>
<tr>
<td>0-0</td>
<td>Input</td>
<td>Q</td>
<td>Q041</td>
<td>3pt</td>
<td>0000</td>
<td>-</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>0-1</td>
<td>Output</td>
<td>Q</td>
<td>Q41P</td>
<td>3pt</td>
<td>0020</td>
<td>-</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>0-2</td>
<td>Intell.</td>
<td>Q</td>
<td>Q71C24-82</td>
<td>3pt</td>
<td>0040</td>
<td>-</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>0-3</td>
<td>Intell.</td>
<td>Q</td>
<td>Q71LP01</td>
<td>3pt</td>
<td>0060</td>
<td>-</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>0-4</td>
<td>-</td>
<td>None</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>0-5</td>
<td>-</td>
<td>None</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>0-6</td>
<td>-</td>
<td>None</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>0-7</td>
<td>-</td>
<td>None</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>0-8</td>
<td>-</td>
<td>None</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>0-9</td>
<td>-</td>
<td>None</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>0-10</td>
<td>-</td>
<td>None</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>0-11</td>
<td>-</td>
<td>None</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td></td>
</tr>
</tbody>
</table>

### <<Label>>

#### Label

Local variables Program name : MAIN

<table>
<thead>
<tr>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set_value</td>
</tr>
<tr>
<td>Storage_register</td>
</tr>
<tr>
<td>Analog_value</td>
</tr>
<tr>
<td>PBI</td>
</tr>
<tr>
<td>PM2</td>
</tr>
<tr>
<td>Output_inelbara</td>
</tr>
<tr>
<td>DA_convert READY</td>
</tr>
<tr>
<td>Head_No</td>
</tr>
</tbody>
</table>
15. OTHER FUNCTIONS

15.1 Checking Programs

[Purpose]
Checks for logical errors and input errors in programs.

[Operating Procedure]
Select [Tools] → [Check program], or click .

[Dialog Box]

1) Check contents
Selects the item to be checked. The range for the check is from step 0 to the END instruction (or the end of the program if there is no END instruction).
- Instruction check
  Check the checkbox to check if instructions can be used, depending on the PC type.
- Ladder check
  Check the checkbox to check whether the program is a valid ladder.
- Consistency (pair) check
  Check the checkbox to check for consistency in the program, for example whether there are pointers at jump destinations and if there are RET instructions for subroutines.
- Double coil check
  Check the checkbox to check for duplicate coils.
• Device check
  Check the checkbox to check if device numbers are within the parameter range.
  For the A series, an error will not occur if the T/C outside the parameter range setting is used besides contacts and coils.

2) [Execute] button
   Click this button after making the necessary settings.

3) [Jump] button
   If there is a step with an error, designating the error in the check result and clicking this button moves the cursor to the relevant step of the ladder.

4) Check target
   ⊗ Target the whole program
     Checks all programs in the project.
   ⊗ Target the current program
     Checks only the currently open program.

5) Check result
   Displays the result of the project check.
15.2 Merging Programs

[Purpose]
Merges multiple programs/comment data. Merges label programs/local variables for label programming.

[Operating Procedure]
[Tools] → [Merge data]

[Dialog Box]

[Description]
1) Merged data type setting
Specify the data (programs/comments) to be merged.

2) Merge source drive/path, project name
Set the drive/path and project name of the data to be merged.
You can also set the drive/path and project name from the [Browse] button.

3) Merge source program list
Lists the programs of the merge source project.
Lists only label programs for label programming.

4) Merged program selection buttons
Press the [Select] button to choose the data specified in the merge source data list.
Press the [Select all] button to choose all data in the merge source data list.
Press the [Cancel the selection] button to clear the selected data.
Press the [Cancel all selections] button to clear all selected data.

5) Merged data setting
Shows up to 128 pieces of data to be merged.
Data are merged in displayed order.
When concatenating the data you are currently editing, first save the data and then add the name of the edited data to the selection.
6) **Merge range** button (Program only)
   Specifies the step numbers of the program specified as a merge source.
   The default is All range.
   For label programming, the program names and local variables specified as the merge range are merged unconditionally.

   ![Merge range setting](image)

7) Merge destination drive/path, project list
   Specifies the currently open project name and drive/path.

8) Merge destination data name
   Set the data name used after merging.
   If you specified the existing data name, the data overwrite confirmation dialog box appears.

9) **Merge option** button (Comment only)
   Data are merged in the order of selected data names.
   (Equipment names are not the object of an overlap check.)
   For label programming (programs only)

   ![Merge option](image)

If the data to be merged include the data which exceeds the device range of the merge destination CPU, the comment data in the excess area is deleted.

For A series
   The capacity set in the parameter/comment capacity setting of the merge destination is not checked. Data are merged after they are checked within the device range of the CPU.

For Q/QnA series
   The device range of the merge destination is the maximum points of the CPU type of the merge destination project, and the range check by the device setting of the parameter is not performed.
   Also, the number of ZR devices merged is up to 32k points.
For label programming

- If label names overlap at the time of local variable merging, they are merged according to the merge option setting.
- If the number of labels exceeds 5120 at the time of local variable merging, the 5121th and latter labels are not merged.

If the program/local variable capacity for label programming is exceeded by merging, the area in excess of the capacity is not merged.

10) [Execute] button
Click this button when the setting is finished.
When data are merged, the END instruction at any point in the program is deleted automatically and an END instruction is inserted at the end of the program.

[Setting Procedure] (When programs are merged in the entire range)
1. Choose the data type to be merged.
2. Set the drive/path and project name of the merge source data from the Browse button.
3. Choose the data to be merged at 5) from the data displayed at 3).
4. Repeat steps 1 and 2. When the data to be merged are all selected, set 8).
5. When the setting is over, click 10).

POINTS
- Any programs not saved in the peripheral device cannot be merged.
- After programs are merged, make a program check.
- Programs cannot be merged between different PLC series, e.g. A series and QnA series. However, they can be merged between ACPU and QCPU(Amode).
- When merging programs of the A or FX series, the program capacity is as set in the parameter of the merge destination project.
- When merging the programs of the Q/QnA series, the maximum number of steps corresponds to the PLC type of the merge destination project.

<table>
<thead>
<tr>
<th>PLC Type</th>
<th>Max. Number of Steps</th>
<th>PLC Type</th>
<th>Max. Number of Steps</th>
</tr>
</thead>
<tbody>
<tr>
<td>Q2A, Q2AS(H)</td>
<td>28K</td>
<td>Q02(H)</td>
<td>28K</td>
</tr>
<tr>
<td>Q2AS1, Q2AS(H)S1</td>
<td>60K</td>
<td>Q06H</td>
<td>60K</td>
</tr>
<tr>
<td>Q3A</td>
<td>92K</td>
<td>Q12H</td>
<td>124K</td>
</tr>
<tr>
<td>Q4A, 4AR</td>
<td>124K</td>
<td>Q25H</td>
<td>252K</td>
</tr>
</tbody>
</table>

- If the capacity is exceeded after merging, data are merged on a program basis up to the capacity. (Data that may only be merged to a midway point are not merged.)
- SFC programs cannot be merged.
15.3 Checking Parameters

[Purpose]
Checks for errors in the parameter settings.

[Operating Procedure]
Select [Tools] → [Check parameter], or click 📦.

[Dialog Box]

1) Check object
Select the items you want to check by clicking the unchecked checkboxes of the items.
Operational setting can be selected for a remote I/O project.
### 15.4 All-clearing the Parameters

<table>
<thead>
<tr>
<th>A</th>
<th>Q/QnA</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>☐</td>
<td>☐*</td>
<td>☐</td>
</tr>
</tbody>
</table>

*: This function is compatible with the Q series remote I/O.

**[Purpose]**
Clears all parameter settings and sets their default values.

**[Operating Procedure]**
Select [Tools] → [Clear all Parameters].

**[Dialog Box]**

![Dialog Box Image]

**[Description]**
1) **Clear target**
Select the items you want to clear by clicking the unchecked checkboxes of the items.
15.5 IC Memory Card (GX Developer ↔ IC Memory Card)

Read/write the data of the IC memory card. (Q series only)

(1) IC memory card overview
   (a) About driver

<table>
<thead>
<tr>
<th>PLC</th>
<th>IC Memory Card</th>
<th>Function</th>
<th>Driver</th>
<th>Driver</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Read</td>
<td>Write</td>
<td>Windows® 95/98</td>
</tr>
<tr>
<td>Q series</td>
<td>SRAM</td>
<td>O*1</td>
<td>O*1</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>ATA</td>
<td>O*2</td>
<td>O*2</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>Linear flash</td>
<td>×</td>
<td>×</td>
<td>—</td>
</tr>
</tbody>
</table>

*1: Depending on your personal computer or OS, the operations may not be performed.
*2: If it takes a long time to read/write the ATA data from GX Developer when Windows® 95 is used, change the driver from Hardware Controller ([Start] → [Control Panel] → [Hardware]) to "SunDisk (SunDisk ATA FlashDisk)".
*3: When using SRAM, set the driver to CONFIG.SYS.
   (For details, refer to Windows help.)
   When ATA is used, Windows recognizes it automatically.
   If it is not recognized, set it after choosing [Control Panel] → [System].
   Remove the driver for SRAM if it has been set to CONFIG.SYS.

(b) About loading of IC memory card into PLC card slot
   An adaptor is required to load the IC memory card into the PLC card slot.

<table>
<thead>
<tr>
<th>PLC card adaptor</th>
<th>Mitsubishi Electric Make (Model)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Q2MEM-ADP</td>
<td></td>
</tr>
</tbody>
</table>

(c) About formatting of IC memory card
   To format the IC memory card, choose [Online] → [Format PLC memory]
   on GX Developer. (For more information, refer to Section 20.2.)

<table>
<thead>
<tr>
<th>IC Memory Card</th>
<th>Memory Card Name on Setting Screen</th>
</tr>
</thead>
<tbody>
<tr>
<td>SRAM</td>
<td>Memory card (RAM)</td>
</tr>
<tr>
<td>ATA</td>
<td>Memory card (ROM)</td>
</tr>
</tbody>
</table>
(2) About PLC user data
    For read/write of PC user data from/to the IC memory card, GX Developer
    cannot directly access the IC memory card.
    Use Explorer of Windows or the like.
    Refer to Section 17.10 for the operation to read/write PLC user data when the
    IC memory card is loaded in the PLC.
15.5.1 Reading the data of the IC memory card

This section explains the operation to read the data of the IC memory card with the personal computer which has a PLC card slot. (Q series only)
Refer to Section 16.3 for reading data when the IC memory card is loaded in the PLC.

[Purpose]
Reads the data of the IC memory card.

[Operating Procedure]
Select [Tools] → [IC memory card] → [Read IC memory card].

[Dialog Box]

1) Read data list
Choose the data to be read.

2) <<Common>> tab, <<Local>> tab
Choose either tab when setting a range to comments to read.
For details, refer to Section 9.7.

3) Merge peripheral Statement/Note
Refer to Section 10.2.

POINT
- When there is a password already set, the confirmation dialog box appears at the time of read execution.
For details of the passwords, refer to Section 19.2.
15.5.2 Writing data to the IC memory card

This section explains the operation to write data to the IC memory card with the personal computer which has a PLC card slot. (Q series only) Refer to Section 16.3 for writing data when the IC memory card is loaded in the PLC.

[Purpose]
Writes data to the IC memory card.

[Operating Procedure]
Select [Tools] → [IC memory card] → [Write IC memory card].

[Dialog Box]

[Description]
1) Written data list
Choose the data to be written.

2) <<Common>> tab, <<Local>> tab
Choose either tab when setting a range to comments to read.
For details, refer to Section 9.7.

3) Password button
Sets the password from the password setting dialog box.
For details, refer to Section 19.2.

4) Reservation steps for Write during RUN
Reserves the area for the steps increased by Write during RUN.
For Write during RUN, refer to Section 16.9.

[CAUTION]
If the same file name already exists, the overwrite confirmation dialog box appears. Click the Yes button to abandon and overwrite the existing data.
15.6 Intelligent Function Utility

The corresponding intelligent function utilities must be installed.

(1) Utility list (Q series only)
Show the utility list by selecting [Tools] → [Intelligent function utility] → [Utility list].
This displays the list of the intelligent function utilities required to edit the intelligent function utility parameters in the currently edited project.

(2) Starting the intelligent function utilities (Q series only)
Start the intelligent function utilities by selecting [Tools] → [Intelligent function utility] → [Start].

(3) Intelligent function utility parameters on GX Developer (Q series only)
The intelligent function utility parameters are not displayed in the project list. However, they are displayed in the Read from/Write to/Delete PLC, Copy project and Read/Write IC memory card dialog boxes.
In this case, if the [Param+Prog] button in the corresponding dialog box is used to make selection, the intelligent function utility parameters are also selected. (Except for copying the project)
(4) Intelligent function utility parameters for operations (Q series only)

When the following operations are performed, the intelligent function utility parameters will be as described below.

If the intelligent function utilities have already used the intelligent function utility parameters, any of the following operations and others cannot be performed. Start any operation after closing the intelligent function utilities.

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read from PLC/Read IC memory card</td>
<td>The intelligent function utility parameters in the PLC/IC memory card are read to the GX Developer project. If the project name has not yet been set, the intelligent function utility parameters cannot be read.</td>
</tr>
<tr>
<td>Write to PLC/Write IC memory card</td>
<td>The intelligent function utility parameters in the GX Developer project are written to the PLC/IC memory card. If the project name has not yet been set, the intelligent function utility parameters cannot be written.</td>
</tr>
<tr>
<td>Newly read from PLC</td>
<td>Operation cannot be performed.</td>
</tr>
<tr>
<td>Password</td>
<td>Setting cannot be made.</td>
</tr>
<tr>
<td>Delete PLC data</td>
<td>The intelligent function utility parameters are deleted.</td>
</tr>
<tr>
<td>Verify PLC</td>
<td>Operation cannot be performed.</td>
</tr>
<tr>
<td>Save project</td>
<td>The intelligent function utility parameters are not changed.</td>
</tr>
<tr>
<td>Save as</td>
<td>The intelligent function utility parameters are added to the project to be saved.</td>
</tr>
<tr>
<td>Verify project</td>
<td>Operation cannot be performed.</td>
</tr>
<tr>
<td>Copy project</td>
<td>Copy cannot be performed if the copy source/destination is used in the intelligent function utilities.</td>
</tr>
<tr>
<td>Change PLC type</td>
<td>The intelligent function utility parameters are retained intact.</td>
</tr>
<tr>
<td>Q series → Q series</td>
<td>The intelligent function utility parameters are deleted.</td>
</tr>
<tr>
<td>Q series → other than Q series</td>
<td></td>
</tr>
<tr>
<td>Delete intelligent function utility parameters saved in GX Developer project</td>
<td>The intelligent function utility parameters cannot be deleted using GX Developer. Use the intelligent function utilities to delete.</td>
</tr>
</tbody>
</table>

**POINTS**

- Data in the PLC/IC memory card cannot be read/written directly from/to the intelligent function utilities. Use the corresponding read/write function of GX Developer to read/write them to the intelligent function utilities.

- For more information on the intelligent function utility parameters, refer to the corresponding module user’s manual.
15.7 Transferring ROM Data

Reads, writes, and verifies data from the GX Developer, either with respect to the EP-ROM or E²P-ROM installed in an A series memory cassette, or an FX series memory cassette.

(1) System configuration for ROM writer transfer
The system configuration for reading/writing/verification with a ROM writer is indicated below.

![System configuration diagram]

*1: See Appendix 6 for an example of connecting cable wiring.

The correctness of the operation was confirmed for the ROM writers shown below.
- PECKER-10(PKW-1000)
- PECKER-11(PKW-1100)
- PECKER-30(PKW-3100)

(2) Making settings at the ROM writer
Before reading/writing/verification with the ROM writer, make the following settings at it.

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data format</td>
<td></td>
</tr>
<tr>
<td>Data length</td>
<td>8-bit</td>
</tr>
<tr>
<td>Stop bit</td>
<td>1 bit</td>
</tr>
<tr>
<td>Parity</td>
<td>Odd</td>
</tr>
<tr>
<td>Baud rate</td>
<td>9600 bps</td>
</tr>
<tr>
<td>X ON/OFF</td>
<td>Provided</td>
</tr>
</tbody>
</table>
"A" series program memory configuration

(1) Memory capacity setting
The data written to the ROM is classified into two types: main program and main + subprogram.
A memory capacity setting must be made for each data type.

(a) Setting main program capacity
When a main program is set, the main program capacity set in the PLC parameters and automatically added parameters (fixed at 4K bytes) are written to the ROM.
Set the main program capacity in the PLC parameters so as to satisfy the following condition:

\[ \text{Main program capacity} \leq \text{Total memory capacity of ROM} - \text{parameters (4K bytes)} \]

In the case of an AnUCPU, QCPU(Amode) for which network parameters are set, up to 16K bytes (a maximum of 4K bytes for each network unit) is added.
Check the memory capacity in the network parameters on the PLC parameter memory capacity setting dialog box, then set the main program capacity.

\[ \text{Main program capacity} \leq \text{Total memory capacity of ROM} - \text{parameters (4K bytes)} - \text{network parameters} \]

If the writing capacity exceeds the capacity of the ROM, either make the setting for the main program memory capacity in the PLC parameters smaller, or replace the existing ROM with one with a larger capacity.

<Example> : Memory capacity setting for AnUCPU, QCPU(Amode) with network parameters set)

For A2U(S1)CPU

<table>
<thead>
<tr>
<th>Parameters</th>
<th>4K bytes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Main program (sequence + microcomputer) Max. 14K steps (28K bytes)</td>
<td></td>
</tr>
<tr>
<td>Network parameters Max. 16K bytes</td>
<td></td>
</tr>
</tbody>
</table>

1K step (1024 steps) = 2K bytes

For A3U, A4UCPU, QCPU-A

<table>
<thead>
<tr>
<th>Parameters 4K bytes (fixed)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Main program (sequence + microcomputer) Max. 30K steps (60K bytes)</td>
</tr>
<tr>
<td>Total not to exceed 60K bytes</td>
</tr>
<tr>
<td>Max. total 64K bytes</td>
</tr>
<tr>
<td>Network parameters Max. 16K bytes</td>
</tr>
</tbody>
</table>

Max. total 48K bytes
(b) Setting main program + subprogram capacity

Write A3U/A4UCPU, QCPU(Amode) subprograms together with the main program. It is not possible to write a subprogram by itself. When writing a main program + subprogram, the main program capacity set in the PLC parameters, the automatically added parameters (fixed at 4K bytes), and the subprogram capacity, are written to the ROM. The subprogram capacity is automatically set at 64K bytes per subprogram.

Example: Memory capacity setting for A3U/A4UCPU, QCPU(Amode)

### For A3UCPU

- Parameters 4K bytes (fixed)
- Main program Max. 30K steps (60K bytes)
- Network parameters Max. 16K bytes
- Subprogram T/C set values 1K byte
- Subprograms 30K steps (60K bytes)
- Free 3K bytes

### For A4UCPU, QCPU(Amode)

- Parameters 4K bytes (fixed)
- Main program 30K steps (60K bytes)
- Network parameters Max. 16K bytes
- Subprogram 1 T/C set values 1K byte
- Subprogram 1 30K steps (60K bytes)
- Free 3K bytes
- Subprogram 2 T/C set values 1K byte
- Subprogram 2 30K steps (60K bytes)
- Free 3K bytes
- Subprogram 3 T/C set values 1K byte
- Subprogram 3 30K steps (60K bytes)
- Free 3K bytes

### POINT

- The ROMs to which A3U/A4UCPU, QCPU(Amode) subprograms can be written are the 32KROM and the 64KROM. The 32KROM and 64KROM are capable of ROM operation with a subprogram written to them. The 32KROM and 64KROM can only be used with the A4UMCA-128 memory cassette.
The total memory capacity, including main program and subprograms, for each ROM, is indicated below.

| Model Name | ROM Type | A0J2H, A2C, A2CJ | A2A(S1), A2U(S1), A1N *1 | A2N(S1), A2A(S1), A2U(S1) | A3A, A3N *1 | A3U, A4U *1 QCPU(Amode) | A1S, A1SJ, A1SH, A1SJS | A2S(S1), A2USH-S1, A2AS(S1), A2AS-S30, A2AS-S60 |
|------------|----------|----------------|--------------------------|--------------------------|----------|----------------|----------------|----------------|----------------|
| 4KROM      |          | 2K steps (0 to 2046) | 6K steps (0 to 6142) | 6K steps (0 to 6142) | 6K steps (0 to 6142) | 6K steps (0 to 6142) | - | - |
| 4KROM      | X2864A   | -               | 6K steps (0 to 6142) | - | - | - | - | - |
| 8KROM      | 27128    | 6K steps (0 to 6142) | - | 14K steps (0 to 14334) | 14K steps (0 to 14334) | 14K steps (0 to 14334) | - | - |
| 16KROM     | 27256    | 14K steps (0 to 14334) | - | 14K steps (0 to 14334) | 30K steps (0 to 30178) | 30K steps (0 to 30718) | - | - |
| 32KROM *2  | 27512    | -               | - | - | 30K steps (0 to 30718) + 30K bytes | - | - |
| 64KROM *3  | 27010    | -               | - | - | 30K steps (0 to 30718) 30K + bytes x 3 | - | - |
| A1SNMCA-8KP *4 | - | - | - | - | 8K steps (0 to 8190) | - |
| A2SMCA-14KP *5 | - | - | - | - | - | 14K steps (0 to 14334) |

*1: Two ROMs of the same model are used (for odd addresses and even addresses).
*2: Only the A4UMCA-128 memory cassette can be installed.
  A main program and subprogram 1 can be written, and ROM operation with a subprogram is possible.
*3: Only the A4UMCA-128 memory cassette can be installed.
  With A4UCPU, QCPU(Amode), a main program and subprograms 1, 2, 3 can be written, and ROM operation with a subprogram is possible.
With A3UCPU, a main program and subprogram 1 can be written, and ROM operation with a subprogram is possible.
*4: An A6WA-28P memory rewrite adapter is required.
  Only mods PECKER-11 and 30 can perform write function.
  Other ROM writers (including PECKER-10) cannot perform write function.
  For occasions such as reading and writing, set the ROM type as "27256."
*5: An A2SWA-28P memory rewrite adapter is required.
  Only mods PECKER-11 and 30 can perform write function.
  Other ROM writers (including PECKER-10) cannot perform write function.
  For occasions such as reading and writing, set the ROM type as "27256."
  Switch between odd and even addresses with the ODD/EVEN setting pins of the A2SWA-28P rewrite adapter.

POINTS

- The A1SMCA-8KP conventional mode EP-ROM is not compatible with A1SHCPU.
  Note also that there is no EP-ROM cassette compatible with A2SHCPU.
- Since data writing with a ROM writer is not possible when using A1SNMCA-2KE/8KE or A2SNMCA-30KE EP-ROM cassettes, write data using the PLC write function.
(4) Address type
Depending on the CPU type, the ROM may have either of two address types (writing methods). The correspondence between CPU types and address types is indicated below.

<table>
<thead>
<tr>
<th>Address Type</th>
<th>Writing Method</th>
<th>CPU Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Odd *1</td>
<td>Addresses are divided into odd and even, and the data written to two ROM’s. *2</td>
<td>A1N, A2N(S1), A3N, A2A(S1), A3A, A2U(S1), A3U, A4U, A2S(S1), A2AS(S1), A2AS-S30, A2AS-S60, A2SH, A2US-S1, A2USH-S1</td>
</tr>
<tr>
<td>Contiguous</td>
<td>Data is written to one ROM without division into odd and even addresses.</td>
<td></td>
</tr>
</tbody>
</table>

*1: Two EP-ROMs of the same model are used (one for odd, one for even)
However, note that the EP-ROM cassettes that can be used with A2S, A2SH, A2US(S1), and A2USH-S1 have two ROMs built in.

*2: When there is one ROM writer socket, divide the data into odd and even addresses before writing to the ROM.
Note also that because the memory write adapter has to be switched over with A2S, A2SH, A2US(S1), and A2USH-S1, odd and even address data cannot be written at the same time.

**Example 1**: Writing the main program of an A1NCPU (4K steps) to a 4KROM

**Example 2**: Writing the main program of an A1SCPU to an A1SMCA-8KP
Program memory configuration of the FX series

(1) Memory capacity setting
The program memory of the PLC allows writing of sequence program (including parameters), file registers, and device comments.
The capacity setting ranges for each type of data are indicated below.

<table>
<thead>
<tr>
<th>Type</th>
<th>Setting Details</th>
<th>Capacity Setting Range</th>
</tr>
</thead>
<tbody>
<tr>
<td>FX0</td>
<td>Sequence programs</td>
<td>800</td>
</tr>
<tr>
<td></td>
<td>File registers</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>Comments</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>Total</td>
<td>800</td>
</tr>
<tr>
<td>FX0S</td>
<td>Sequence programs</td>
<td>500 to 2000</td>
</tr>
<tr>
<td></td>
<td>File registers</td>
<td>0 to 1500</td>
</tr>
<tr>
<td></td>
<td>Comments</td>
<td>0 to 1500</td>
</tr>
<tr>
<td></td>
<td>Total</td>
<td>2000</td>
</tr>
<tr>
<td>FX0N</td>
<td>Sequence programs</td>
<td>500 to 2000</td>
</tr>
<tr>
<td></td>
<td>File registers</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>Comments</td>
<td>0 to 4000 *1</td>
</tr>
<tr>
<td></td>
<td>Total</td>
<td>2000</td>
</tr>
<tr>
<td>FX1</td>
<td>Sequence programs</td>
<td>500 to 8000</td>
</tr>
<tr>
<td></td>
<td>File registers</td>
<td>0 to 2000</td>
</tr>
<tr>
<td></td>
<td>Comments</td>
<td>0 to 4000</td>
</tr>
<tr>
<td></td>
<td>Total</td>
<td>Max. 8000, 200/4000 modes also possible</td>
</tr>
<tr>
<td>FX</td>
<td>Sequence programs</td>
<td>500 to 2000</td>
</tr>
<tr>
<td>FX2</td>
<td>File registers</td>
<td>0 to 7000</td>
</tr>
<tr>
<td>FX2C</td>
<td>Comments</td>
<td>0 to 7500</td>
</tr>
<tr>
<td></td>
<td>Total</td>
<td>Max. 8000, 200/4000 modes also possible</td>
</tr>
<tr>
<td>FX1S</td>
<td>Sequence programs</td>
<td>500 to 2000</td>
</tr>
<tr>
<td></td>
<td>File registers</td>
<td>0 to 1500</td>
</tr>
<tr>
<td></td>
<td>Comments</td>
<td>0 to 1500</td>
</tr>
<tr>
<td></td>
<td>Total</td>
<td>2000</td>
</tr>
<tr>
<td>FX1N</td>
<td>Sequence programs</td>
<td>500 to 8000</td>
</tr>
<tr>
<td></td>
<td>File registers</td>
<td>0 to 7000</td>
</tr>
<tr>
<td></td>
<td>Comments</td>
<td>0 to 7500</td>
</tr>
<tr>
<td></td>
<td>Total</td>
<td>Max. 8000, 200/4000 modes also possible</td>
</tr>
<tr>
<td>FX2N</td>
<td>Sequence programs</td>
<td>500 to 16000</td>
</tr>
<tr>
<td></td>
<td>File registers</td>
<td>0 to 7000</td>
</tr>
<tr>
<td></td>
<td>Comments</td>
<td>0 to 15500</td>
</tr>
<tr>
<td></td>
<td>Total</td>
<td>Max. 16000, 2000, 4000, 8000 modes also possible</td>
</tr>
</tbody>
</table>

*1: The maximum program capacity is 2000 steps. However, when using a memory cassette it is possible to write comments up to 2000 steps outside the program area too.
15.7.1 ROM reading, writing, and verification

[Purpose]
Using a ROM writer connected to the personal computer, reads from the ROM, writes to the ROM, or verifies the data in the personal computer against the data in the ROM.

[Operating Procedure]
Select [Tools] → [Transfer ROM] → [Read] ([Write] / [Compare].)

[Dialog Box]
The dialog box for ROM reading is shown here; similar dialog boxes are displayed for writing and verification.

[Description]
1) Connection
Selects the interface at the personal computer connected to the ROM writer.

2) ROM (A series only)
Selects the type of ROM used.
"Automatic" cannot be selected for writing.

3) Target program (A series only)
Selects the type of data to be read, written, or verified.

4) Address type (A series only)
Sets the address type of the ROM.
The address type is sequential for the following CPU types: A0J2H, A1S, A1S(S1) A1SJ, A1SH, A2C, A2CJ, and either odd or even for other CPU types.
Note that when there are two ROM writer sockets it is possible to write simultaneously to odd and even addresses.
However, when writing to an A2SMCA-14KP, ODD and EVEN settings are made at the memory write adapter, making simultaneous writing impossible.
5) **Execute** button
   Click this button after setting the necessary settings.

[Operating Procedure]
- For ROM reading/verification
  1. Install the ROM at the ROM writer, connect to the personal computer and make the necessary settings.
  2. Set the memory capacity in the PLC parameters at the reading (verification) destination.
  3. Operate the ROM writer to read the ROM data into the buffer memory. *1
  4. Set (1) through (4) in the ROM reading (verification) dialog box.
  5. Click (5) after setting the necessary settings.

- For ROM writing
  1. Install the ROM at the ROM writer, connect to the personal computer and make the necessary settings.
  2. Set the memory capacity in the PLC parameters.
  3. Set (1) through (4) in the ROM writing dialog box.
  4. Click (5) after setting the necessary settings.
  5. Operate the ROM writer to write the buffer memory data to the ROM. *1

   *1: For details on how to operate the ROM writer, refer to the instruction manual for the model used.

**POINTS**
- When data is written to the ROM, the ROM writer checks in advance whether the data in the ROM has been deleted.
- If the address type setting is incorrect, reading, writing and verification with the ROM writer will not be possible.
  Affix labels to ROMs or use some other method to distinguish among them.
- When the ROM type is set to automatic for reading or verification, an error will occur if there is a discrepancy between the memory capacity settings at the ROM side and personal computer side.
  Alter the setting at the personal computer side.
15.7.2 Writing to files in ROM format

[Purpose]
Writes data to the HD, FD, etc., of a personal computer in a file format like the address type for writing to a ROM.

[Operating Procedure]
Select [Tools] → [Transfer ROM] → [Write to file].

[Dialog Box]

[Description]
1) ROM type (A series only)
   Set the same type as the ROM used.

2) Target program (A series only)
   Selects the type of data for file writing.

3) Address type (A series only)
   Set the same address type as the ROM used
   If the CPU type is A0J2H, A1S, A1S(S1), A1SJ, A1SH, A2C, or A2CJ, the address type is "sequential."
   In other cases it is odd, even, or odd/even.

4) Write destination directory
   Sets the folder of file writing destinations.

5) [Execute] button
   Click this button after setting the necessary settings.
### POINT

- Some examples of how files are saved, and the address type-dependent extensions used, when file writing operations are executed are given below.

**Saving example**

```
W[6512] hex
```

- **Identifier (common)**
- **File name (depends on ROM type, applicable program)**
- **Extension (depends on address type)**

**Extension**

- **W**........ Odd/even addresses
- **O**........ Odd addresses
- **E**........ Even addresses
- **S**........ Sequential addresses
15.8 Batch-Deleting the Unused Device Comments

[Purpose]
Batch-deletes comments not used in the program.

[Operating Procedure]
[Tools] → [Delete unused comments]

[Description]
Comments to be deleted should satisfy the following conditions.

1. Comments attached to the devices not used in the program are batch-deleted.
   Device comments not searched for in the device use list, if any, by a device search are deleted.

2. Common comments of the devices not used in all programs are deleted.

3. Comments by program which are not used in the corresponding program are deleted.

4. Comments by program whose program does not exist are deleted together with data.

5. Common comments and comments by program which are set to the same device used are not deleted.

6. Click the Yes button to perform batch delete.

POINTS
Device comments are batch-deleted under the following conditions.

• Any device using index qualification is handled as not being qualified.

<Example>

(1) MOV D0 D100Z0
    D0 and D100 will be the target of deletion and the device specified indirectly by Z0 will not be the target of deletion.

(2) Two words of any indirectly specified device will be the target of deletion.
    MOV D0 @D10
    D0, D10 and D11 will be the target of deletion, and the device number stored in D10 will not be the target of deletion.

• Comments not deleted are indicated below.
  SP.M (A series), SP.D (A series), SM (QnA series), SD (QnA series), Jn\SB, Jn\SW
15.9 Customizing Keys

[Purpose]
Sets the key allocations for ladder creation as GPPA format, GPPQ format, or MEDOC format.

[Operating Procedure]
Select [Tools] → [Customize keys].

[Dialog Box]

[Description]
1) GPPA format
   Sets the key allocations corresponding to GPPA.

2) GPPQ format
   Sets the key allocations corresponding to GPPQ.

3) MEDOC format
   Sets the key allocations corresponding to MELSEC MEDOC. *1

4) OK button
   Click this button after setting the necessary settings.

*1: "MELSEC MEDOC" is a programming and document creation system retailed by Mitsubishi Electric Europe GMBH.
15.10 Changing the Display Color

[Purpose]
Changes the GX Developer screen to any color.

[Operating Procedure]
Select [Tool] → [Change display color].

[Dialog Box]

[Description]
Ladder, list, SFC and MELSAP-L screens can be changed in color. Parameter, device memory, device comment edit and similar screens are not compatible with this function.

Clicking the [Default setting] button returns to the initial status.

POINT
Unless the personal computer of 256 or more colors is used, the screen may not be displayed properly.
### 15.11 Setting Options

<table>
<thead>
<tr>
<th>Purpose</th>
<th>Sets the options for data creation.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Operating Procedure</td>
<td>Select [Tools] → [Options].</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Dialog Box</td>
<td>&lt;&lt;Program common&gt;&gt; sheet</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td><img src="image.png" alt="Diagram" /></td>
<td></td>
</tr>
</tbody>
</table>

#### Description

1) Edit object (shift forward setting)
   - Continuous ladder block (Shift the program forward)
     If the edited ladder is shorter than it was before conversion, it is shifted forward on conversion.
   - 1 ladder block (Don’t shift the program forward)
     If the edited ladder is shorter than it was before conversion, NOP instructions are written at the missing steps on conversion.

2) Device comment input
   Check the checkbox to select.
   After ladder input the comment input window opens, allowing device comments to be set.
3) Double coil check setup
Sets whether a duplicate coil check is to be performed at program creation.
The devices and instructions to which the duplicate coil check applies are indicated below.

<table>
<thead>
<tr>
<th>A series</th>
<th>OUT</th>
<th>SET</th>
<th>SFT</th>
<th>PLS</th>
<th>PLF</th>
<th>MC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Y, M, L, B, F</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>T, C</td>
<td>O</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Q/QnA series</td>
<td>OUT</td>
<td>SET</td>
<td>SFT</td>
<td>PLS</td>
<td>PLF</td>
<td>EGP, EGF</td>
</tr>
<tr>
<td>Y, M, L, B, F, SM, DY, SB</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>—</td>
</tr>
<tr>
<td>D, SD, W, SW, R, ZR</td>
<td>O</td>
<td>—</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>—</td>
</tr>
<tr>
<td>T, C</td>
<td>O</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Z</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>O</td>
</tr>
</tbody>
</table>

☐: Applicable  —: Not applicable

FX series

<table>
<thead>
<tr>
<th>FX series</th>
<th>OUT</th>
<th>SET</th>
<th>PLS</th>
<th>PLF</th>
<th>MC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Y, M</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>—</td>
<td>O</td>
</tr>
<tr>
<td>S</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>T, C</td>
<td>O</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
</tbody>
</table>

☐: Applicable  —: Not applicable

It is possible to use the same coil, but attention must be paid to program operation.
In program editing by copying and pasting, no duplicate coil check is performed; for this reason you should perform a program check after editing.
See Section 15.1 for details of program checks.

4) Statement insertion method (Q/QnA series only)
At macro registration, regardless of the option, the statements registered together with ladder are expanded. If no statements have been registered, before expanding the macro select “CPU statement”, “GPP statement”, or “None”.

☐ CPU statement
When writing to the PLC, the statements are written as part of the program. However, the number of steps taken up increases.

☐ GPP statement
The statements of the macro are displayed only at the personal computer. The number of steps taken up does not increase, but the statements cannot be written to the PLC.

☐ None
Statements of the macro are not displayed.
5) After conversion writing behavior
Sets writing of the program to the PLC after conversion.

⊙ Write during RUN (while PLC is running)
The program is unconditionally written to the PLC during the RUN status.
LD[R Edit mode]* is displayed to the Title bar.

⊙ Write if PLC is STOP
The program is written to the PLC if its status is STOP (PAUSE).
"LD[R Edit mode]" is displayed to the Title bar.

⊙ Don't write to PLC
The program is not written to the PLC.
6) Step No. specification used in writing (Q/QnA series only)
Sets the method for online program change (write during RUN).

- **Absolute step No. (default)**
  Online program change (write during RUN) is executed based on absolute step numbers.

- **Relative step No. by pointer**
  Online program change (write during RUN) is executed based on relative step numbers, using pointers.

Only the pointer identified areas of a program created by several operators on a pointer-by-pointer basis can be written during RUN.
This method is useful when a program is to be debugged by several people.

Example:
Online program change (write during RUN) of the program at the personal computer and the program in the PLC in different states, for example when a single program is being written and debugged by several people.

<table>
<thead>
<tr>
<th>Write During Normal RUN</th>
<th>Relative Write by Pointer During RUN</th>
</tr>
</thead>
<tbody>
<tr>
<td>When another programmer has made an addition to the program in the PLC, normal write during RUN overwrites the steps before the addition, and the program discrepancy makes the writing impossible.</td>
<td>Even in a case where another programmer has made an addition to the program in the PLC from P1, since the writing is to relative steps, with respect to P2, no program discrepancy occurs.</td>
</tr>
</tbody>
</table>

![Diagram](Image)
7) Buffer, Link memory monitor (Except FX series)
   Checking the checkbox causes monitoring of the buffer memory and link
   memory during ladder monitoring.
   When the buffer memory and link memory are monitored, the scan time of the
   PLC is further increased.
   See 17.5 for monitor operation.

8) Show/don't show character string (Except FX series)
   Checking the checkbox causes display of comments/statements/notes/device
   names for all programs.

9) Ladder monitor of PLS/PLF instruction (FX series only)
   Checking the checkbox causes the monitor display of PLS/PLF instructions to
   be actuated in FXGP(DOS) and FXGP(WIN) formats. When the checkbox is
   cleared, monitor display is actuated in the GX Developer format. The default is
   the GX Developer format.
   (See Appendix 11.)

10) [OK] button
    Click this button after setting all the necessary settings in each dialog box.
[Dialog Box]

<<Each program>> sheet

[Description]

1) Copy source/display source of reference during comment edit
   When both a comment common to all programs and a comment specific to the individual program have been assigned to the same device, specifies which of these is to be displayed in the ladder window.
   However, where only a comment common to all programs or only a program-specific comment is set for a device, the set comment is automatically displayed and therefore this setting is invalidated.

2) Local dev./File reg. monitor (QnA series only)
   Monitors the local devices of the selected program.
   For the QnA series, the PLC of function version B or later must be used to perform local device monitor.
   Refer to Appendix 7 for the way to identify the module version.
**[Dialog Box]**

<<Whole data>> sheet

1) **Common device comment**
   Sets the largest number of characters that can be set for a device comment as 16 characters or 32 characters.

2) **All common data**
   Checking this checkbox causes the data to be saved automatically when the window is closed. The data is also automatically saved when ladder changes are made. However, if no project name has been set when creating a new project this setting is not possible because there is no saving destination.

3) **Extended setting**
   Do not make this setting.
When the GX Developer is connected via modem, set each item in correspondence with the error condition.

<<TEL function>> tab screen

<table>
<thead>
<tr>
<th>Setting Items</th>
<th>Contents/measures</th>
</tr>
</thead>
<tbody>
<tr>
<td>Waiting time for the line connection CD signal</td>
<td>Depending on the region (e.g., overseas) where line connection is made, extend the set time if the CD signal does not turn ON within the time.</td>
</tr>
<tr>
<td>Waiting time for the line connection report from modem</td>
<td>Extend the set time when the model response speed is slow.</td>
</tr>
<tr>
<td>Waiting time for the line disconnection CD signal</td>
<td>Depending on the region (e.g., overseas) where line is being disconnected, extend the set time if the CD signal does not turn OFF within the time.</td>
</tr>
<tr>
<td>Delay time for the line disconnection</td>
<td>Extend the set time when the model response speed is slow.</td>
</tr>
<tr>
<td>Delay time for the AT command data transmission</td>
<td>Extend the set time when the model response speed is slow.</td>
</tr>
<tr>
<td>Waiting time for the response of AT command</td>
<td>Extend the set time when the model response speed is slow.</td>
</tr>
<tr>
<td>Waiting time for the response of password cancellation</td>
<td>Extend the set time when the quality of line connection with the opposite party is poor.</td>
</tr>
<tr>
<td>Transmission retry times for AT command/password cancellation</td>
<td>Increase the set number of retries.</td>
</tr>
</tbody>
</table>
15.12 Displaying Multiple Windows

[Purpose]
Adjusts the size and position of windows when multiple windows are opened. However, when four or more windows are arranged horizontally or vertically, the number of lines and columns changes.

[Operating Procedure]
Select [Window] → [Cascade] ([Tile vertically], [Tile horizontally], [Arrange icons])

[Dialog Box]
This is an example where windows are displayed cascaded.

[Description]
1) Active window
If [Cascade] is selected, the sheet currently being edited is brought to the top. When [Arrange horizontally] or [Arrange vertically] is selected, the window being edited is brought to the top left of the screen.

2) Non-active window
When [Cascade] is selected, windows that are not being edited are moved to the back.

3) Icon
When [Arrange icons] is executed, icons (minimized windows) are arranged on the bottom line of the screen.

POINT
To close multiple windows at once, select [Window] → [Close all windows].
15.13 Opening a Specific Project Using a Shortcut

[Purpose]
Creates the start setting file that is to act as the shortcut to a particular project. Just by opening the start setting file, or double-clicking an icon, GX Developer can be started up and a project opened.

[Operating Procedure]
Select [Tools] → [Create Start-up setting file].

[Dialog Box]

[Description]
1) Project drive, Drive/path
   Sets where the start setting file is saved.

2) File name
   Sets the start setting file name.

3) [Save] button
   Click this button after setting all the necessary settings.

POINTS
- It is convenient to set the start setting files of frequently opened projects in the desktop.
- Initialization files have the extension "~.GPS."
  The icon at initial setting is as follows.

![Test gps icon]
15.14 Starting the Ladder Logic Test Tool

[Purpose]
Starts the GX Simulator from GX Developer and carries out debugging offline.

[Operating Procedure]
Select [Tools] → [Start ladder logic test], or click .

[Description]
Starting GX Simulator causes the ladder displayed on GX Developer to be automatically put in the monitor mode.

For label programming
For label programs, only actual programs compiled may be executed.
For programs not yet compiled, perform [Convert] → [Compile].
For details of various functions of GX Simulator, refer to the SW5D5C-LLT Operating Manual.

POINT
• The GX Simulator is available as an option.
  It must be purchased separately to debug programs offline.

15.15 Outline of Help Function

The help function reproduces some of the information in this manual and the PLC manual.
Information can be checked on the screen of the personal computer during GX Developer operations.
The help menu is explained below.

<table>
<thead>
<tr>
<th>Help menu</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU error</td>
<td>Displays details of the error codes listed in the User's Manuals for each CPU and elsewhere. Error codes read during PLC diagnosis can be checked at the personal computer.</td>
</tr>
<tr>
<td>Special relays/registers</td>
<td>Displays explanations of special relays and special registers, classified by function and device number. Allows you to check special relays and special registers during program creation and monitoring.</td>
</tr>
<tr>
<td>Shortcut key list</td>
<td>Displays shortcut keys for shortcuts to the menu in GX Developer, and lists the key allocations for key customization for ladder creation.</td>
</tr>
<tr>
<td>Product information</td>
<td>Displays information about the product, such as the GX Developer version.</td>
</tr>
<tr>
<td>Connect to MELFANSweb</td>
<td>Connect to MELFANSweb.</td>
</tr>
</tbody>
</table>