INVERTER A800 PLC Function Quick Start Guide
FR Configurator2 Compatible
READ BEFORE USING

Before using this product, read this Quick Start Guide and the related manuals referenced in this guide. Take all safety precautions and use the product correctly.

[Safety precautions for using the inverter]

⚠️ WARNING
- Do not touch the terminals while power is ON. Otherwise you may get an electric shock.
- Before opening the front cover, turn OFF the power or ensure safety.

⚠️ CAUTION
- If a fault occurs, immediately stop using the product.

[Detailed information]

This guide describes the basic procedures for using the PLC function. For further details, refer to the related manuals.

The related manuals are included in the CD-ROM packed with the product.

The manuals are also available for download at MITSUBISHI ELECTRIC FA Global Website (http://www.Mitsubishi Electric.co.jp/fa), the Mitsubishi Electric FA network service on the world wide web.

The manuals related to this guide are shown below.

<table>
<thead>
<tr>
<th>Manual name</th>
<th>Manual number</th>
</tr>
</thead>
<tbody>
<tr>
<td>FR-A800 Instruction Manual (Startup)</td>
<td>IB-0600493</td>
</tr>
<tr>
<td>FR-A800 Instruction Manual (Detailed)</td>
<td>IB-0600503ENG</td>
</tr>
<tr>
<td>FR-A800 PLC Function Programming Manual</td>
<td>IB-0600492ENG</td>
</tr>
<tr>
<td>FR Configurator2 Instruction Manual</td>
<td>IB-0600516ENG</td>
</tr>
<tr>
<td>GX Works2 Version 1 Operating Manual (Common)</td>
<td>SH-080779ENG</td>
</tr>
</tbody>
</table>

[Supplementary information]

- In this guide, operations are described using FR Configurator2 (Developer) Version 1.01. Depending on the software version used, different menus or screens may appear.
- For consultation and inquiries concerning the PLC function, please contact your sales representative.

Microsoft, Windows, Windows NT, and Windows Vista are registered trademarks of Microsoft Corporation in the United States and/or other countries. Other company and product names herein are the trademarks and registered trademarks of their respective owners.
# Introduction

## CONTENTS

- How to read this guide ........................................................................................................... 2
- Benefits of using the Mitsubishi A800 PLC function .......................................................... 3
- Before using the PLC function ............................................................................................. 4
- Wiring of the inverter ............................................................................................................. 6
- Checking power-ON ............................................................................................................... 8
- Programming .......................................................................................................................... 9
- Writing a program to the inverter ....................................................................................... 17
- Checking the operation ......................................................................................................... 20
- Making a program easy to understand <Comment> ......................................................... 22
- Monitoring the device value/status <Device monitor> .................................................... 28
- Changing the device value <Device test> ......................................................................... 32
- Checking errors <Error jump> .............................................................................................. 33

## 1. How to read this guide

The following table shows the symbols used in this guide and their descriptions.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="point.png" alt="Point" /></td>
<td>This symbol indicates the necessary information.</td>
</tr>
<tr>
<td><img src="reference.png" alt="Reference" /></td>
<td>This symbol indicates the reference manual or the page where details can be found.</td>
</tr>
<tr>
<td><img src="terminology.png" alt="Terminology" /></td>
<td>This symbol indicates that a technical term is explained.</td>
</tr>
<tr>
<td><img src="caution.png" alt="Caution" /></td>
<td>This symbol indicates precautions mandatory for the operation.</td>
</tr>
</tbody>
</table>
2. Benefits of using the Mitsubishi A800 PLC function

- Inverter operation sequence customized for the machine
  - Inverter control such as inverter operations triggered by input signals, signal output according to the inverter operating status, and monitor output can be freely customized according to the machine specifications, which enhances the possibilities of the inverter. For example, for opening/closing of a shutter, a signal from a sensor is used to check the number of opening and closing times. By controlling the opening/closing speed, various shutter operations can be achieved. Control programs can be created in sequence ladders using FR Configurator2 (Developer).

- Optimum for the decentralized control
  - The control of the whole system is decentralized to inverters, and each inverter can manage their subordinating devices.
  - A group of dedicated sequence programs is created and saved in each inverter. Therefore, the master controller does not process all the sequence programs, and the decentralized system accepts program changes more flexibly.

- Automatic operation in accordance with the time
  - With the real-time clock function, automatic operation can be performed at certain times (when the optional FR-LU08 is used).

- User-configurable parameter, protective function, and monitor settings
  - User parameter
    Up to 50 user parameters can be saved. The user parameters are linked with the data registers for the PLC function. Therefore, changing a user parameter also changes the linked data register.
  - User initiated fault
    Up to five specific fault-initiating conditions can be set to activate a protective function and shut off the inverter output.
  - User monitor setting
    User-defined data can be displayed on the operation panel.

- Useful functions
  - Inverter parameter read/write
    Parameter settings can be changed using sequence programs. The acceleration/deceleration time and patterns can also be changed according to the operating status. RAM or EEPROM can be selected to save the parameter settings. When the settings are changed frequently, select RAM.
  - PID function
    Two different loops of PID inverter operations can be preset and controlled using sequence programs.
  - Inverter operation lock
    The inverter operation can be locked against command sources other than the sequence programs.
  - Outline of the PLC function

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>I/O</td>
<td></td>
</tr>
<tr>
<td>General-purpose I/O</td>
<td>Sequence programs enable I/O signal transmission to/from the inverter and its plug-in options.</td>
</tr>
<tr>
<td>Analog I/O</td>
<td>Sequence programs enable analog I/O transmission to/from the inverter and its plug-in options.</td>
</tr>
<tr>
<td>Pulse train I/O</td>
<td>Sequence programs enable pulse train inputs (to terminal JOG) and pulse train outputs (from terminal F/C (FM)).</td>
</tr>
<tr>
<td>Inverter parameter read/write</td>
<td>Sequence programs enable inverter parameter read/write.</td>
</tr>
<tr>
<td>User parameter</td>
<td>Fifty user parameters (Pr.1150 to Pr.1199) are available and are linked with data registers D206 to D255, which accept direct access by sequence programs.</td>
</tr>
<tr>
<td>CC-Link</td>
<td>Installing a plug-in option (FR-A8NC) enables data communication between sequence programs and master modules.</td>
</tr>
<tr>
<td>Special function</td>
<td></td>
</tr>
<tr>
<td>PID operation</td>
<td>Inverter PID operations can be controlled (up to two loops) using sequence programs.</td>
</tr>
<tr>
<td>User initiated fault</td>
<td>Up to five fault-initiating conditions can be set to activate a protective function.</td>
</tr>
<tr>
<td>Fault clear</td>
<td>The protective function occurring in the inverter can be reset.</td>
</tr>
<tr>
<td>Inverter operation lock</td>
<td>Inverters can start up while the PLC function is running.</td>
</tr>
<tr>
<td>User monitor setting</td>
<td>User-defined data can be displayed on the operation panel.</td>
</tr>
</tbody>
</table>
### 3. Before using the PLC function

- **Procedure before using the PLC function**

<table>
<thead>
<tr>
<th>Description</th>
<th>Refer to page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using FR Configurator2 (Developer), create a PLC function project data model (program).</td>
<td>page 9</td>
</tr>
<tr>
<td>Write the created project data model (program) via a USB cable to the inverter.</td>
<td>page 17</td>
</tr>
<tr>
<td>Check the operation.</td>
<td>page 20</td>
</tr>
</tbody>
</table>

#### Diagram:
- **Personal computer + FR Configurator2 (Developer)**
  - Install
  - USB cable
  - A connector
  - **Project data**
  - **A800**
  - **FR-DU08**
  - **PLC function indicator**

---

**Preparation**

---
Example system configuration

In this guide, the system configuration below is used as an example. This system configuration is just an example and various other configurations are available. Inputs and outputs are configured as switches and lamps respectively.

![System Configuration Diagram]

* The inverter and I/O power supply cables are not shown.

Required system components

The following table shows the minimum system requirements for this guide.

<table>
<thead>
<tr>
<th>Equipment</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Personal computer</td>
<td>Creates sequence programs and writes them to the inverter.</td>
</tr>
<tr>
<td></td>
<td>FR Configurator2 (Developer) (SW1DND-FRC2-E)</td>
</tr>
<tr>
<td>USB cable</td>
<td>Connects the personal computer and the inverter.</td>
</tr>
<tr>
<td></td>
<td>Recommended USB cable: MR-J3USBCBL3M (cable length 3 m)</td>
</tr>
<tr>
<td></td>
<td>A connector</td>
</tr>
<tr>
<td>Sequence start switch</td>
<td>Sequence program execution key.</td>
</tr>
<tr>
<td></td>
<td>Switches between RUN and STOP.</td>
</tr>
<tr>
<td>Switch (input): 3</td>
<td>Connected to the external input terminal of the inverter.</td>
</tr>
<tr>
<td>Lamp (output): 3</td>
<td>Connected to the external output terminal of the inverter.</td>
</tr>
<tr>
<td>24 VDC power supply</td>
<td>Power supply for the indicator lamps</td>
</tr>
</tbody>
</table>

Input resistance 4.7 kΩ
Voltage when contacts are open: 21 to 27 VDC
When contacts are short-circuited: 4 to 6 mA DC
Permissible load 24 VDC (maximum 27 VDC) 0.1 A
(The voltage drop is 2.8 V at maximum while the signal is ON.)
4. Wiring of the inverter

Perform wiring of the inverter.

⚠️ Caution

Always switch the inverter power OFF before performing inverter wiring work.

Reference

For the details of wiring, refer to the FR-A800 Instruction Manual (Detailed) (IB-0600503ENG).

- Wiring of the power supply

The following shows an example of wiring of the power supply cables and the earthing (grounding) cable. Earthing (grounding) is performed to prevent electric shocks and malfunctions. The terminal layout depends on the inverter capacity.

Example of 0.4K
Preparation

- Wiring of the I/O signals

The following shows an example of wiring of the I/O signal cables.
5. Checking power-ON

After the wiring is completed, check that the power is properly supplied to the inverter.

### Operating procedure

1. **Checking before power-ON**
   - Wiring of the power supply
   - Power supply voltage
   - Check that the connected switches (page 7) are OFF.

2. **Turning the power ON**
   
   Check that the LED indicator on the operation panel (FR-DU08) is ON.

3. **Changing the inverter parameter settings**
   
   Perform parameter settings to use the PLC function.
   
   ① Enable the PLC function.
   
   Set "2" in **Pr.414 PLC function operation selection**.
   
   ② Sequence start (SQ) signal input terminal setting (sequence program execution key (STOP/RUN) setting)
   
   Set "50" in **Pr.189**.
   
   ③ I/O terminal assignment change
   
   Set "9999" in **Pr.178**, **Pr.179**, and **Pr.182**, and **Pr.190**, **Pr.191**, and **Pr.192**.
   
   Setting "9999" for the I/O terminals enable the use of the terminals as general-purpose I/O terminals. Consequently, the I/O terminals will be changed as follows.

<table>
<thead>
<tr>
<th>Pr.</th>
<th>Input terminal name</th>
<th>Device number</th>
</tr>
</thead>
<tbody>
<tr>
<td>178</td>
<td>STF</td>
<td>X0</td>
</tr>
<tr>
<td>179</td>
<td>STR</td>
<td>X1</td>
</tr>
<tr>
<td>182</td>
<td>RH</td>
<td>X2</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Pr.</th>
<th>Output terminal name</th>
<th>Device number</th>
</tr>
</thead>
<tbody>
<tr>
<td>190</td>
<td>RUN</td>
<td>Y0</td>
</tr>
<tr>
<td>191</td>
<td>SU</td>
<td>Y1</td>
</tr>
<tr>
<td>192</td>
<td>IPF</td>
<td>Y2</td>
</tr>
</tbody>
</table>

   **Point**
   
   The SQ signal can be assigned to the terminals other than the terminal RES. For the SQ signal, set "50" to any of **Pr.178 to Pr.189 (input terminal function selection)** to assign the function to the inverter input terminal. (Refer to the Instruction Manual (Detailed) of the inverter for the details.)

   **Terminology**
   
   Parameter: Setup information necessary to operate the inverter. By setting parameters, the PLC function is enabled, or the complicated motor control can be achieved.
Creating a sequence program

6. Programming

Create a program (sequence program) for sequence control.
For details, refer to the GX Works2 Version 1 Operating Manual (Common) (SH-080779ENG).

"Devices" and "Instruction symbols" for programming

Combine "Devices" and "Instruction symbols" to create a sequence program.

1. Devices

Devices include two types: bit devices and word devices.
A bit device handles one-bit information such as the ON/OFF of a switch or a lamp.

• ON/OFF of a switch • ON/OFF of a lamp

Examples of bit devices

<table>
<thead>
<tr>
<th>Device name</th>
<th>Device symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input</td>
<td>X</td>
<td>Receives a signal from an external device such as a switch.</td>
</tr>
<tr>
<td>Output</td>
<td>Y</td>
<td>Outputs a signal to an external device such as a lamp.</td>
</tr>
<tr>
<td>Internal relay</td>
<td>M</td>
<td>Temporarily stores status data in programs.</td>
</tr>
<tr>
<td>Timer (contact)</td>
<td>T</td>
<td>Used to measure time. (When the set time comes, the contact turns ON.)</td>
</tr>
<tr>
<td>Counter (contact)</td>
<td>C</td>
<td>Used to count the number of times the input condition turns from OFF to ON. (When the number of retries reaches the set number, the contact turns ON.)</td>
</tr>
</tbody>
</table>

A word device handles 16-bit information such as numeric values and character strings.

• Numeric value • Character string

123456789     abcdefg

Examples of word devices

<table>
<thead>
<tr>
<th>Device name</th>
<th>Device symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data register</td>
<td>D</td>
<td>Stores numeric values and character strings.</td>
</tr>
<tr>
<td>Timer (present value)</td>
<td>T</td>
<td>Used to measure time. (Stores the present time value being measured.)</td>
</tr>
<tr>
<td>Counter (present value)</td>
<td>C</td>
<td>Used to count the number of times the input condition turns from OFF to ON. (Stores the present count value being measured.)</td>
</tr>
</tbody>
</table>

Terminology

Device: An area to store data such as ON/OFF status, numeric values, and character strings for the PLC function.
Internal relay: A device that shuts off/connects the sequence circuit by switching ON/OFF.
Contact: An input used for creating a sequence program.
Creating a sequence program

2. Instruction symbols

<table>
<thead>
<tr>
<th>Instruction symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NO contact: Conducting when the input signal is ON.</td>
<td></td>
</tr>
<tr>
<td>NC contact: Conducting when the input signal is OFF.</td>
<td></td>
</tr>
<tr>
<td>Coil output: Data output to a specified device.</td>
<td></td>
</tr>
</tbody>
</table>

Terminology

Coil: An output used for creating a sequence program.

Reference

For the details of devices and instructions available for performing sequence control, refer to the FR-A800 PLC Function Programming Manual (IB-0600492ENG).

Creating a program

Now, create a sequence program.

The following shows how to create a sequence program with basic devices and instruction symbols for sequence control.

The following devices and instruction symbols are used.

• Input: "X" device
• Output: "Y" device
• Instruction symbols: , ,

Create a program to perform the following controls.

• When both the X0 and X1 switches are turned ON, the Y0 output lamp turns ON.
• When the X2 switch is turned ON, both the Y1 and Y2 output lamps turn OFF.

The following explains the procedure to create this sequence program.
Creating a sequence program

- Starting FR Configurator2 (Developer)

**Operating procedure**

1. From the FR Configurator2 menu, select [Tool] → [Developer].

After startup, the main screen of FR Configurator2 (Developer) appears.

- Creating a new project

A project consists mainly of programs, device comments, and parameters.

**Operating procedure**

1. Select [Project] → [New].

1. Select "FR-A800".

2. Click the **OK** button.
Creating a sequence program

A project tree and a ladder screen appear.

Creating a sequence program

Operating procedure

1. Entering \( X_0 \)
   ① Click the area to enter.
   ② Click \( \square \).
   ③ Enter "X0" on the ladder input screen, and then click the \( \text{Ok} \) button.

2. Entering \( X_1 \)
   ① Click the area to enter.
   ② Click \( \square \).
   ③ Enter "X1" on the ladder input screen, and then click the \( \text{Ok} \) button.
3. **Entering Y0**

   ① Click the area to enter.
   ② Click .
   ③ Enter "Y0" on the ladder input screen, and then click the OK button.

   Coil Y0 appears.

4. **Entering X2**

   ① Click the area to enter.
   ② Click .
   ③ Enter "X2" on the ladder input screen, and then click the OK button.
5. **Entering (Y1)**

   ① Click the area to enter.
   
   ② Click .
   
   ③ Enter "Y1" on the ladder input screen, and then click the button.

Coil Y1 appears.

6. **Drawing a line**

   ① Click the area to enter, and press and then .
7. **Entering Y2**

1. Click the area to enter.
2. Click .
3. Enter "Y2" on the ladder input screen, and then click the button.

Coil Y2 appears.

**Converting a program**

Confirm the contents of the entered ladder block.

<table>
<thead>
<tr>
<th>Operating procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select [Compile] → [Build].</td>
</tr>
</tbody>
</table>

Perform the conversion to align entered ladders. When the conversion is completed, the gray display turns white.

[Before conversion]

[After conversion]

The ladder is left-aligned.

The programming is completed.
Creating a sequence program

### Saving a project

Save the created program in a project.

#### Operating procedure

1. Select [Project] → [Save As].

   ![Save As window](image)

   The "Save As" window appears.

2. Specify the save location.

3. Enter the file name and the title.

4. Click the **Save** button.

   ![Save button](image)

5. Click the **OK** button.

   ![OK button](image)

   The project is saved.

#### Buttons on the toolbar or short-cut keys on the keyboard can also be used for editing programs.

<table>
<thead>
<tr>
<th>Editing</th>
<th>Toolbar</th>
<th>Short-cut key</th>
</tr>
</thead>
<tbody>
<tr>
<td>NO contact</td>
<td>-</td>
<td>F5</td>
</tr>
<tr>
<td>NC contact</td>
<td>-</td>
<td>F6</td>
</tr>
<tr>
<td>Drawing lines</td>
<td>F10</td>
<td></td>
</tr>
<tr>
<td>Inputting vertical lines</td>
<td>Shift + F9</td>
<td></td>
</tr>
<tr>
<td>Inputting horizontal lines</td>
<td>Ctrl +</td>
<td></td>
</tr>
<tr>
<td>Inputting horizontal lines continually</td>
<td>Ctrl + Shift +</td>
<td></td>
</tr>
</tbody>
</table>
7. Writing a program to the inverter

Write the created program to the inverter.

Operating procedure

1. Connecting the inverter and the personal computer
   Connect the inverter and the USB port of the personal computer with a USB cable.
   Connect the USB cable to the USB device (mini B connector) on the inverter.

2. Turning ON the inverter
   Turn the power ON to energize the inverter.

3. Setting the connection between FR Configurator2 (Developer) and the inverter
   ① Click [Connection Destination].
   ② Double-click the data name to be transferred.

The "Transfer Setup" window appears.
Creating a sequence program

③ Double-click "Serial USB".

The “PC side I/F Serial Setting” window appears.

④ Select "USB".

⑤ Click the  button.

⑥ Click "Main Module".

⑦ Click "No Specification".

⑧ Click the  button.

When the connection is properly established, the connection completion message appears.

⑨ Click the  button.

⑩ Click the  button.

The connection setting is completed.

(Point)

If the window shown below appears after Step ③, check that the USB driver has been installed correctly and that an appropriate connection cable (USB cable) is used.
### 4. Writing a program to the inverter

1. Select [Online] → [Write to PLC].

   ![Select Online Data Operation](image1)

   The "Online Data Operation" window appears.

2. Click "Parameter + Program". "Program" and "Parameter" are marked.

   ![Select Parameter + Program](image2)

3. Click **Execute**.

   ![Execute Program](image3)

When the "Write to PLC" function is completed successfully, the following message appears.

4. Click **Close**.

   ![Close Window](image4)

The program writing is completed.

Click the **Close** button to close the "Online Data Operation" window.
8. Checking the operation

Execute the program written to the inverter to check the operation.
Check the program operation with the switches and lamps or the monitor function of FR Configurator2 (Developer).

- Executing the program written to the inverter

  Use the switch between terminals RES (SQ) and SD of the inverter.
  [How the STOP/RUN switch is used]
  • Switch ON: RUN (SQ signal ON) .................... Executes the sequence program operation.
  • Switch OFF: STOP (SQ signal OFF) .................. Stops the sequence program operation.

Operating procedure

1. Executing the program

   Turn ON the STOP/RUN switch (SQ signal).

2. Using the operation panel to check the operation

   The sequence program operating (RUN) status can be checked with the operation panel (FR-DU08).

FR-DU08

<table>
<thead>
<tr>
<th>P.RUN state</th>
<th>PLC function operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>OFF (normal indication)</td>
<td>Sequence program stopped</td>
</tr>
<tr>
<td>ON (inverted indication)</td>
<td>Sequence program running</td>
</tr>
<tr>
<td>Flickering</td>
<td>Sequence error occurring</td>
</tr>
</tbody>
</table>
Creating a sequence program

- Using switches and FR Configurator2 (Developer) to check the operation

Check the program operation using the monitor mode of FR Configurator2 (Developer) by operating the switches ON/OFF.

Operating procedure

1. Using the monitor mode screen of the operating program

Select [Online] → [Monitor] → [Start Monitoring].

When monitoring is performed, the "Monitor Status" screen appears.

You can see the ON/OFF state of the bit devices on the ladder screen.
An ON-state contact or output is shown in blue.
Right after the execution of the program, bit devices X2, Y1, and Y2 are ON and shown in blue.

2. Operation check 1

① Turn ON the switch (X0) between terminals STF and SD of the inverter. → X0 turns ON.

3. Operation check 2

② Turn ON the switch (X1) between terminals STR and SD of the inverter. → X1 turns ON and Y0 turns ON.

4. Operation check 3

③ Turn ON the switch (X2) between terminals RH and SD of the inverter. → X2 turns OFF and Y1 and Y2 turn OFF.
Useful functions

This section describes functions frequently used in FR Configurator2 (Developer).

9. Making a program easy to understand <Comment>

Use comments to make the program easy to understand.

The following are the three types of comment.

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
<th>Number of characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device comment</td>
<td>Describes roles and applications of each device.</td>
<td>32</td>
</tr>
<tr>
<td>Statement</td>
<td>Describes roles and applications of ladder blocks.</td>
<td>64</td>
</tr>
<tr>
<td>Note</td>
<td>Describes roles and applications of output instructions.</td>
<td>32</td>
</tr>
</tbody>
</table>

Select [View] → [Comment] (CTRL key + F5 key) to switch between displaying/hiding of comments.
Useful functions

Creating device comments

Device comments can be entered from the list or on the ladder diagram.

Operating procedure

1. Double-click [Global Device Comment] in the project list.

2. Enter the start device number in the "Device Name" field and press the Enter key.

3. Enter a comment in the "Comment" field.

   * When entering comments for other devices, repeat Steps 2 and 3.
Operating procedure

① Select [Edit] → [Documentation] → [Device Comment].

② Double-click the ladder symbol to enter a comment.

③ Enter a comment on the "Input Device Comment" window.

④ Click the  button.

⑤ To finish the operation, select the [Device Comment] menu in Step ① again.
Useful functions

<Entering comments when creating ladders>

Operating procedure

1. Select [Tool] → [Options].

2. Select "Program Editor" → "Ladder1" → "Enter ladder".

3. Select "Enter label comment and device comment".

4. Click the OK button.

After the ladder entry operation, the "Input Device Comment" window appears and a comment can be entered.

Input Device Comment

Device Label  Device Label Comment

Switch  OK  Cancel

[Diagram of Input Device Comment window]
Useful functions

Creating statements

Operating procedure

1. Select [Edit] → [Documentation] → [Statement].

2. Double-click a ladder symbol to enter a statement.
3. Select "In PLC".

4. Enter a statement.
5. Click the OK button.

6. The statement appears on the ladder diagram.

7. To finish the operation, select the [Statement] menu in Step 1 again.
   If a statement is entered, the program needs to be "converted" to reflect the input. For details on the conversion, refer to page 15.

Point

The following are the two types of statement.

- "In PLC"
  Integrated statements can be written to/read from the inverter.
- "In Peripheral"
  The program memory capacity can be saved since peripheral statements are not written to the inverter. "*" is prefixed to the peripheral statement in the program.
Useful functions

Creating notes

Operating procedure

1. Select [Edit] → [Documentation] → [Note].

2. Double-click an output instruction to enter a note.
3. Select “In PLC”.

4. Enter a note.
5. Click the OK button.

6. The note appears on the ladder diagram.

7. To finish the operation, select the [Note] menu in Step 1 again. If a note is entered, the program needs to be "converted" to reflect the input. For details on the conversion, refer to page 15.

Point

The following are the two types of note.

- "In PLC"
  Integrated notes can be written to/read from the inverter.
- "In Peripheral"
  The program memory capacity can be saved since peripheral notes are not written to the inverter. **”** is prefixed to the peripheral note in the program.
10. Monitoring the device value/status <Device monitor>

The following are the two types of device monitor.

<table>
<thead>
<tr>
<th>Type</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device batch monitor</td>
<td>Used to monitor consecutive devices of one type.</td>
</tr>
<tr>
<td>Watch</td>
<td>Used to monitor devices away from one another on the ladder or devices of different types in one window at the same time.</td>
</tr>
</tbody>
</table>

### Device batch monitor

Consecutive devices are monitored by specifying the start device number.

#### Operating procedure

1. Select [Online] → [Monitor] → [Device Batch Monitor].

2. Enter the start device number to be monitored and press the [Enter] key.

The values of devices and the ON/OFF status of contacts/coils are displayed.

---

**Point**

The device batch monitor function can be used to change the present value or the display format.
Useful functions

**Watch**

To perform the Watch, specify target devices or the range of the ladder diagram for device registration. The status of devices can be displayed in watch windows 1 to 4.

<table>
<thead>
<tr>
<th>&lt;Specified device registration&gt;</th>
</tr>
</thead>
</table>

Register specified devices in Watch 1.

1. Select [Online] → [Monitor] → [Start Monitoring].

2. Select [View] → [Docking Window] → [Watch1].

* Watch 1 window appears on the bottom right on the screen.

3. Double-click a “Device/Label” field.

4. Enter the device/label to be registered and press the Enter key.

5. Select [Online] → [Watch] → [Start Watching].

The values of devices and the ON/OFF status of contacts/coils are displayed.
Useful functions

Specify the range of the ladder diagram on the ladder monitor screen and batch register the devices in the range.

1. Select [Online] → [Monitor] → [Start Monitoring].

2. Select [View] → [Docking Window] → [Watch1].

3. Click the start point of the ladder.

4. While pressing the Shift key, click the end point of the ladder. → The range is specified.
Useful functions

Register devices to the Watch.  
⑤ Drag and drop the selected range to watch 1 window.  
Position the mouse pointer to the outside frame of the selected range. When  appears, start dragging.

The values of the selected devices are monitored.  
⑥ Select [Online] → [Watch] → [Start Watching].
11. Changing the device value <Device test>

This function is used to change the present values of word devices (such as T, C, or D) or bit devices (X or Y).

Word device present value change

Change the present value of the word device (such as T, C, or D) in the inverter to the specified value.

Operating procedure

1. Select [Online] → [Monitor] → [Start Monitoring].

2. Select [Debug] → [Modify Value].

3. Enter the device number to be changed.
4. Select "Word[Signed]".
5. Enter the value to be changed.
6. Click the Set button.
12. Checking errors <Error jump>

If an error occurs, you can check the error with PLC diagnostics. By using the error jump, the cursor jumps to the step number of the sequence program corresponding to the error.

- PLC diagnostics

  The details of an error can be checked in the PLC diagnostics.

**Operating procedure**

1. Select [Diagnostics] → [PLC Diagnostics].

   [Image: PLC diagnostics screen (example)]

   PLC diagnostics screen (example)

2. Click the [Error Help] button of the current error or the error history.

   [Image: Help screen (example)]

   Help screen (example)

The details of the error and remedies appear.
Useful functions

- **Error jump**

  Errors can be checked easily with the error jump function of PLC diagnostics.

**Operating procedure**

1. Select [Diagnostics] → [PLC Diagnostics].

2. Click the [Error Jump] button of the current error or the error history.

The cursor jumps to the step number of the sequence program corresponding to the selected error.
Safety Warning

To ensure proper use of the products listed in this catalog, please be sure to read the instruction manual prior to use.

MITSUBISHI ELECTRIC CORPORATION
HEAD OFFICE: TOKYO BLDG., 2-7-3, MARUNOUCHI, CHIYODA-KU, TOKYO 100-8310, JAPAN